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IMPORTANT SAFETY INSTRUCTIONS

WARNING: TO REDUCE THE RISK OF FIRE OR ELECTRIC SHOCK, DO NOT EXPOSE
THE APPARATUS TO RAIN OR MOISTURE AND OBJECT FILLED WITH LIQUIDS,
SUCH AS VASES, SHOULD NOT BE PLACED ON THIS APPARATUS.

Read these instructions.

Keep these instructions.

Heed all warnings.

Follow all instructions.

Do not use this apparatus near water.

Clean only with a dry cloth.

Do not block any of the ventilation openings.
Install in accordance with the manufacturers
instructions.

Ensure that the power cord plug is readily
accessible so that it can be quickly and easily
unplugged from the outlet.

Unplug this apparatus during lightning storms
or when unused for long periods of time.

Only use attachments/accessories specified
by the manufacturer.

Use only with the cart, stand, tripod, bracket,
or table specified by the manufacturer, or sold
with the apparatus. When a cart is used, use
caution when moving the cart/apparatus
combination to avoid injury from tip-over.

Do not install near any heat sources such as
radiators, heat registers, stoves, or other
apparatus (including amplifiers) that produce
heat.

Do not defeat the safety purpose of the
polarized or grounding-type plug. A polarized
plug has two blades with one wider than the
other. A grounding type plug has two blades
and a third grounding prong. The wide blade
or the third prong are provided for your safety.
When the provided plug does not fit into your
outlet, consult an electrician for replacement of
the obsolete outlet.

Protect the power cord from being walked on
or pinched particularly at plugs, convenience
receptacles, and the point where they exit from
the apparatus.

Refer all servicing to qualified service
personnel. Servicing is required when the
apparatus has been damaged in any way,
such as power-supply cord or plug is
damaged, liquid has been spilled or objects
have fallen into the apparatus, the apparatus
has been exposed to rain or moisture, does
not operate normally, or has been dropped.

Explanation of safety related markings and symbols which appear on the outside of the apparatus.

é Lightning Bolt: Hazardous Live voltages present when this unit is in operation. Do not
touch terminals marked with this symbol while the unit is connected to live power.

Exclamation Point: Replace components (i.e. fuses) only with the values specified by the
/ i \ manufacturer. Failure to do so will compromise safe operation of this unit.




For more complete instructions, see the software Help file, or the printable Help documument (on CD).

Nexia Quick Start

Connecting to stand alone Nexia device

Each Nexia unit comes loaded with a default system configuration. Follow steps 1-7 for
connecting to a Nexia default configuration.

To create and load your own custom configuration, follow steps 1-5 and then go to step 10.

Install Nexia software on a Windows XP or 2000 PC
PC must have a 10/100baseT NIC.

Assign IP address to PC

Each Nexia device ships from the factory with a default IP address of 192.168.1.101.
PC must have a unique IP address before it can communicate with a Nexia device.
Right Click My Network>Properties>Local Area Connection>Right Click
Properties>TCP/IP>Properties

IP address should be 192.168.1.x (x=1-254 except 101 because that is what Nexia has.)
Subnet mask should be 255.255.255.0

Local Area Connection Properties 2x| Internet Protocol (TCP/IP) Properties P 21X
General | General |
Connact using You can get P setings assigned autormatically fyour network supparts this
capability. Otherwiss, you need to ask your network administrator forthe
| 3Com 3C420 Integrated Fast Ethernet Controller (3C805C-TX C appropriate [P sefiings.
£ Obtsin an IP address autoratically
Components checked are used by this connection — Use thefallowing IP address
Client for Microsoft Netwarks IP address: 152 . 168 1 200
& and Printer Sharing for Microsoft Networks SifEmEes 265 . 255 . 255 0
met Protocal (TCPAP)
Default gateway-
(ol
me— e Properies Obtain DS eerver address autarmaticaly
& Use thefallowing DNS server addresses
Desciiption

Transmission Control Protocol/ntemet Protocal. The defaultwids Il ] BN e

sreanetwork protocol that prevides communication across Aermate DNS sewer r.

diverse intercannected netiorks.
I~ Showican in taskbar when connected Actvanced.

oK Cancel Cancsl

Power up Nexia devices

Connect supplied power cord to a grounded AC mains voltage of 100-240VAC @50/60Hz.
Connect other end of power cord to power entrance located on the rear of Nexia unit. Note status of
front panel LED’s. Under normal conditions, all LED’s will remain green once power-up

sequence has completed.



4. Connect PC to Nexia unit
Connect “cross-over” Ethernet cable (supplied with unit) from PC 10/100baseT
Ethernet jack to Ethernet jack located on rear panel of Nexia unit. “Cross-over” Ethernet
cables have their pins swapped (pin 1 to pin 3, pin 2 to pin 6, pin3 to pinl) and can
easily be identified by looking at the conductors on the RJ-45 connectors. If the wiring is
different at each end, it is a “cross-over” cable.
5. Connect to network with Nexia software
Open Nexia software then connect to network.
File>Network>Connect to network
x|
Sy L Connect To System
Device Count
Send Systermn Config
Device Maintenance,
Close
Device List
Serial # IP Address Device ID Device Des. =
_ INO004642 SP Default
6. Connect to Nexia system
Choose default system configuration and hit Connect to System
x|
System List
: | System Description | Device Count Audio wl
All Devices 1 INJA Send System Canfig
SP Default Configuration
Device Maintenance
Close
Device List
7.  Adjust component parameters as needed
Optional:
8. Disconnect PC from Nexia system
File>Network>Disconnect from Nexia system
9. Disconnect PC from Network

File>Network>Disconnect from network



If you do not want to use the default Nexia configuration and wish to load your own custom
configuration, follow steps 1-7 above and then follow below.

10.  Reset/Initialize Nexia unit
Because each Nexia unit ships from the factory with a default system configuration, you must
first reset/initialize that unit before loading our own configuration.
File>Network>Perform Nexia Device Maintenance> Reset/Initialize Nexia unit

Device Maintenance il

System List
- - Dewvice Information...
System ID | System Description Device Count | Audio |
0 All Devices 1 M/A Set Date/Time..
o AR 5P Default Configuration 1 OFF
Set 1P Address
Set Device Description
Device List Serial Port Setting
i Device D | Device Descrip... | System ID | System Descrip... | Audio | RCB Feset/Initialize
SP 1642 SP Default Conf.. [ OFF [ No ]
Update Firmware..

RCB Devices

Disconnect Fram Metwark
Close

11. Design and Layout system
Layout signal flow and DSP as desired. Save layout file (.nex).

savess x|
Savein [ DataFlles x| 4+~ @k B
L

File nime Czod] =l Sare |
Savestpe |Lapout Files [ nes] =] Cancel

12. Compile Layout
Compilation results will display number and type of Nexia devices required as well as DSP power
used.
dit Wiew Proc
EE
® P[Compie]



13. Enter appropriate Nexia unit serial number to equipment table
Tools>Equipment table>Select serial number
Select OK when complete

1I
UrnitlD| Model Serial # Device Description Lakel 1[4 I

1

Phd

MO004631 | Eugene's P

Cancel |

14. Send Configuration
File>Network>Send System Configuration

Sends layout configuration to selected Nexia unit.

Enter System Configuration Description

The configuration information will now be uploaded to the Mexia
devices identified in the Equipment T able for the active document:

"Mutes_DLAB3T".

Supstem configuration 1D: 4631

Spstem configuration description label:

x|

[

oK I Cancel

15. Start Audio
Upon loading configuration, select the option to start audio

x

& Do you want to start audio?

‘feg

Mo |

16. Adjust component parameters as needed

Optional:

17. Disconnect PC from Nexia system
File>Network>Disconnect from Nexia system

18. Disconnect PC from Network

File>Network>Disconnect from network




1.

2.

Connecting to a networked system using two or more Nexia devices

Install Nexia software on a Windows XP or 2000 PC
PC must have a 10/100baseT NIC.

Design and Layout system
Launch Nexia software. Layout signal flow and DSP as desired. Save layout file (.nex).

avens 2l
Savein: [ DataFiles = « eF EE-

Save o lype: Loyout Files [ nex]

Compile Layout

Compilation results will display number and type of Nexia devices required as well as DSP
power used and NexLink connections between units.

dit Wiew Proc
EE
® 52|compik]

Power up Nexia devices
Connect supplied power cord to a grounded AC mains voltage of 100-240VAC @50/60Hz.
Connect other end of power cord to power entrance located on the rear of Nexia unit. Note status

of front panel LED’s. Under normal conditions, all LED’s will remain green once power-up
sequence has completed.



6.

Assign IP address to PC

Each Nexia device ships from the factory with a default IP address of 192.168.1.101.
PC must have a unique IP address before it can communicate with a Nexia device.
Right Click My Network>Properties>Local Area Connection>Right Click

Properties>TCP/IP>Properties

IP address should be 192.168.1.x (x=1-254 except 101 because that is what Nexia has.)

Subnet mask should be 255.255.255.0
Click Ok when complete
Close My Network

2%]

Local Area Connection Properties

Generel | General |

Connectusing

| 3Com 3C920 Integrated Fast Ethemnet Controller (3C305C-TX C

Companents checked are used by this connection:

1=, Client for Microsoft Networks P address

Subnet mask:

Default gateway:

Internet Protocol (TGP/IP) Properties

You can getIP settings assigned automatically ifyour netwark supports this
capability. Othervise. you heed o ask your netwark administrator for the
appropricte [P setings

" Obtain an IP address automatically

— Use the fallowing IP address:

2lx|

168 . 1 200

255 255 255 O

Uninstall

Install,

Froperties

area netwark protocal thet provides communication across
diverse inferconnected networks

Descriptio
( Transmission Coniral Pratacolinternst Pratocol. The defaultwide

£ Obtain DKS server address autamafically:
& Use the following DNS server addresses:

Preferred DNS server

Alternate DNS server.

,:
—

I Show icon in taskbar when connected

Advanced

OK. Cancel

Connect PC to network

Attach a “straight-through” Ethernet cable from PC 10/100baseT network card to a 10/100baseT

Ethernet switch. “Straight-through” Ethernet cables connect transmit pins directly to receive pins
(pin 1 to pin 1, pin 2 to pin2, pin 3 to pin3, etc.). You can easily determine if an Ethernet cable is

“straight-through” by looking at the conductors on the RJ-45 connectors. If the wiring is identical
on both ends, it is a “straight through™ Ethernet cable.

Connect Nexia device to network

Connect one Nexia device to network using “straight through” Ethernet cable attached from the rear
panel Ethernet jack to the 10/100baseT Ethernet switch.

Connect to network with Nexia software

Open Nexia software then connect to network.

File>Network>Connect to network
Close when complete

System Connect

System List

System D Spstern Description Device Caunt Audio
= 463 Mutes 1 i}
Device List

Serial # IP Address Device D | Device D. Spster |D | Spstem D... | Audio | RCB

6 __“_I!ﬂ
1 [Eugens. [ 4631 Hute

x

Cannect Tio System,
Send System Config
Device Maintenance.
Discornect From Network,
Close




10.

11.

Assign IP address to Nexia device

All Nexia units ship from the factory with an assigned IP address of 192.168.1.101. When using
more than one device in a system, each device must have a unique IP address. Nexia device IP
addresses must be different from any PC IP address that will be used in this system.
File>Network>Perform Nexia Device Maintenance>Select desired Audia device>Set IP address

IP address should be 192.168.1.x (x=1-254)
Subnet mask should be 255.255.255.0
Default gateway should be 0.0.0.0

Click Ok when complete

Close Device Maintenance when complete

Change IP Address il

Current IP address: New IF address

192.168.1.240

Current subnet mask:

MNew subnet mask:
[255.255.265.0 I

Current default gateway: MNew default gatewsy:
[pono [ o 0 i 0

Device description

|KH Machine

Serial number:

PDMDDW
0K |

Cancel |

Note: To avoid conflict issues that occur when connecting multiple Nexia devices with the same IP
number, be sure to only connect one Nexia device at a time to the Ethernet switch when assigning

IP addresses.

Repeat steps 6-8 until all Nexia devices in system have been connected to network
and assigned a unique IP address.

Reset/Initialize each Nexia unit

Because each Nexia unit ships from the factory with a default system configuration, you must
first reset/initialize that unit before loading our own configuration.

File>Network>Perform Nexia Device Maintenance> Reset/Initialize each connected Nexia unit

Device Maintenance il

System List

System ID

| Systemn Description

Device Information

| Device Count I Audio |

=8 4608
5 4547

Device List

i] All Devices
C5 Default Configuration 1 QFF
SP Default Configuration 1 QFF

& (N

SetDate/Time.
SetlP Address
Set Device Description.
Serial Port Setting

Device D | Device Descrip...

Systermn D | System Descrip... | Audio | RCB

4608 | CS Dafeult Conf..

4642 5P Detault Canf. OFF Mo

Reset/Initialize
Update Firmware

RCE Devices...

Disconnect From Network
Close




12. Connect NexLink

For multi-unit systems, “straight-through” Cat-5 cables must be connected from the
appropriate rear panel NexLink TX jack(s) to the appropriate NexLink RX jack(s) according
to the layout of your design. Check the compile results to verify correct NexLink connections.

13.  Open layout (.nex) file
File>Open>Select file

O 2l
Look i [ =4 DataFiles x| =Bk E-

File name [system 1

Open I
Cancel

KANEY

Files of type [Lapout Fies [ nex)

14.  Enter appropriate Nexia unit serial numbers to equipment table
Tools>Equipment table>Select appropriate serial numbers
Select OK when complete

x
UnitID| hodel Serial # Device Description Lahel 0K I
1| Pk | NO0D4631 | = Eugene's P
2| CS Cancel |

15.  Send Configuration
File>Network>Send System Configuration
Sends layout configuration to selected Nexia unit.

Enter System Configuration Description ﬂ

The configuration infarmation will now be uploaded to the Mexia
devices identified in the Equipment T able far the active document:
"Mutes_DL4B3T".

Syztem configuration 10 431

System configuration description label:

Ok I Cancel




16. Start Audio
Upon loading configuration, select the option to start audio

x

& Do you want to start audio?

‘feg Mo |

17.  Adjust component parameters as needed

Optional:

18.  Disconnect PC from Nexia system
File>Network>Disconnect from Nexia system

19. Disconnect PC from Network
File>Network>Disconnect from network



SAFETY INFORMATION

The words WARNING and CAUTION throughout the manual, and on the device, call attention to
important safety information. These words have the following meanings.

WARNING:  The related information alerts you to conditions that could result in serious
injury or damage to property if the instructions are not followed properly.

CAUTION:  The related information instructs you on how to prevent damage to the
equipment or how to avoid conditions that could result in minor injury if proper
steps are not followed.

“INFORMACION DE SEGURIDAD”

Product labelling and the operation manual may use the internationally
recognized symbols defined below to note safety messages.

The lightning flash with arrowhead symbol, endosed within a triangle, is
intended to alert the user to the of ge
voltage® within the s orat i i that

& may be of i i to i arisk of ical shock.

The exclamation poln\ enclosed wnthm a tnangle is intended to aten the
user ln and ( g)
in the i i

the

9

Las palabras PELIGRO (WARNING) y PRECAUCION (CAUTION) alo Iavgo del manual yenel
llaman la il acerca de una
Estas tienen los si i

PELIGRO :laii ion relata las
(WARNING) propiedad si no se siguen

en que podria ser dafiada seriamente la
las i 8

PRECAUCION : la informacién que se relata te instruye en cémo prevenir dafos al equipo o
(CAUTION) como evitar condiciones que podrian resultar en perjuicio menor si los pasos
d no son i

WARNING:  TO REDUCE THE RISK OF FIRE OR ELECTRICAL SHOCK,
DO NOT EXPOSE THIS APPARATUS TO RAIN OR MOISTURE.

CAUTION: Installation of this apparatus should be made by a qualified installation
person and should conform to all applicable local codes.

El enquemado del pxoducto y el manual de operacién pueden hacer uso de los simbolos

y cuyos jes estan idos a ion para modificar
mensajes de seguridad:
El simbolo del rayo en un tri alertar al usuario de la
presencia de un peligroso voltaje no aislado demro de la ca;a del aparato 0 a un
terminal de conexién y que podria ser de como para i

un grave riesgo de descarga eléctrica.

de las de i iony (servicio)

f El punto de ion dentro de un tri alertar al usuario de la
que acompaian al aparato.

Modification and optional i i { in this manual is for use
by qualified i and service only.
CAUTION

A e A
DO NOT OPEN.

CAUTION: TO REDUCE THE RISK OF ELECTRICAL SHOCK,
DO NOT REMOVE COVER.

NO USER-SERVICEABLE PARTS INSIDE.

REFER TO QUALH

PELIGRO : para reducir el riesgo de fuego o una descarga electrica, no exponer este
(WARNING) aparato a la lluvia o la humedad.

PRECAUCION : la instalacién de este aparato deberia hacerse por una persona cualificada
(CAUTION) en la instalacion, y deberia conformar todos los cédigos locales aplicables.

para ser utilizada uni por p en y servicio.

/A A

NO EXISTEN COMPONENTES DE SERVICIO EN EL INTERIOR.

C: La modificacion y la il i pcional del equipo i en este manual es

PRECAUCION
RIESGO DE DESCARGA
ELECTRICA NO ABRIR.

PRECAUCION: para reducr el riesgo de
descarga eléctrica no levantar la tapa.

REFERIRSE UNICAMENTE A PERSONAL
CUALIFICADO PARA SERVICIO TECNICO.

INFORMATION CONCERNANT
VOTRE SECURITE

INFORMAZIONI PER LA SICUREZZA

Les mots WARNING et CAUTION dans le manuel d'utilisation et sur les appareils attirent votre
ion sur les plus i votre sécurité. Ces mots ont la
signification suivante:

WARNING: Ce mot vous indique Iss circonstances dans lesquelles vous pourriez étre blessé ou
votre siles lions ne sont pas suivies correctement.

CAUTION: Ce mot vous indique comment éviter d’'endommager votre matériel et comment éviter
de vous blesser si vous ne suivez pas les instructions.

Le parole AWERTENZA (WARNING) e PRUDENZA (CAUTION) pos\e sul manuale d' uso e sul
la vostra i u delle i i per la vostra
Queste parole hanno il seguente slgmﬁcalo

AVVERTENZA: La suddetta indicazione vi avvisa sul rischio di incorrere in danni a cose o a
(WARNING) persone ,se le procedure d'uso e installazione non saranno seguite propriamente.

PRUDENZA: La suddetta indicazi vii su come p ire e ridurre al minimo, il rischio
(CAUTION)  di danni agli apparati e alle persone se le instruzioni saranno seguite propriamente.

Vous trouverez peut-étre les symboles suivants sur votre appareil ou dans le manuel d'utilisation.

voltage dangereux non isolé dans I'appareil ou d'une connexion d’'une amplitude

L'éclair se terminant en fléche dans un triangle permet de prévenir I'utilisateur d'un
L j Y suffisante pour constituer un risque de choc électrique.

Ls point d'exclamation dans un tnangle perme\ de prévenir l'utilisateur des points
& et ien de I'appareil

ﬁgurant dans le manuel d‘utuhsanon

Le i e i manuali di la gl
qui sotto dalle relative informazioni per la sicurezza.

La simbologia con il fulmine all'interno di un xﬁangoh, intende avvisare I'utente della

presenza di alto volaggio allinterno del ap, io in i e che il sudd
io si alimenta una i di rete ad alto ggio e che
dunque si potrebbe incorrere sul rischio di una possibile scossa elettrica.

La sil gia con il punto ivo allinterno di un triangolo, intende avvisare
l'utente di una serte dii ioni nel d'uso i i :
operato, © assi ] sara a corredo
dell'apparecchio.

WARNING: POUR REDUIRE LES RISQUES DE FEU OU DE CHOC ELECTRIQUE, NE PAS
METTRE L'APPAREIL SOUS LA PLUIE OU DANS L'HUMIDITE.

CAUTION:L'installation de cet appareil doit étre faite par un installateur qualifié et doit étre en
conformité avec toutes les lois locales en application.

AVVERTENZA: PER RIDURRE IL RISCHIO DI POSSIBILI INCENDI O SCOSSE
(WARNING) ELECTTRICHE ,SCONSIGLIAMO DI ESPORRE L’APPARECCHIO
ALLA PIOGGIA O ALL'UMIDITA'.

PRUDENZA: ['Installazione di questo apparato dovra essere effettuata solo da personale
(CAUTION) qualificato e il tipo di installazione dovra essere in regola con le norme vigenti locali..

Les informations concernant une modification ou un équipement en option dans le
manuel doivent étre effectué par du personnel qualifié.

ATTENTION:
Risque de choc
ne pas enlever le couver

ATTENTION: L'entretien des pidces intérieures ne peut pas
dtre talt par des personnes non qualifiées.

Faire faire V'entretien uniquement par du personnel qualifié.

Modifiche e ulteriori i i in questo sono
riservate al personale qualificato all'installazione.

Attenzione

Pericolo di scosse elettriche.
Non aprire I'apparecchio.




Sicherheitshinweise

Die Bergriffe WARNUNG (engl. WARNING) und ACHTUNG (engl. CAUTION) in der
Bedienungsanieitung und auf den Geraten machen auf wichtige Sicherheitsinformationen
aufmerksam. Diese Begriffe haben die folgende Bedeutung:

WARNUNG: Der folgende Text warnt Sle vor gen oder
(WARNING) die aus einer bzw. + des Gerates
kénnen.
ACHTUNG: Der folgs Text i iert Sie Uber i linweise zum Schutz Ihres
(CAUTION) Gerates oder weist auf i hin, wenn die Bedit g
nicht beachtet werden.

Sikkerhedsinformation

Ordene ADVARSEL (WARNING) og FOﬂSlGTIG (CAUTION), brugt i henholdsvis

bruger ing og pa selve at vigtig i ion omkring si feiger.
Ordene betyder falgende:

ADVARSEL: Den eﬁerlalgende information advarer Dem om forhold, der kan fore til alvorlige
(WARNING) ulykker og ejer hvis ikke vej foiges.

g

FORSIGTIG: Den efterfalgende information vejleder Dem i, hvordan De undgar skade pa
(CAUTION)  produktet, samt undgér forhold der kan fare til mindre ulykker og ejendomsskader,
hvis ikke vejledningen falges.

Die Beschriftung der Gerate und die Bedlenungsanlenungen weisen unter Umstéanden international
auf, die die

Das Blitzsymbol im Dreieck warnt vor anliegender, nicht isolierter ,geféhrlicher
Spannung” im Inneren oder an den Anschliissen des Gerates. Die Beriihrung der
unter Spannung stehenden Teile kann zu einem elektrischen Schock fishren.

Ser ise in der

é Das Rulzelchen im Dreieck macht auf wichtige Installations-, Bedienungs- und

og brugervejledning kan i dei
symboler der er vist nedenfor:

at &bne produktet.

Trekanten med udrabstegn har til hensigt at advare brugeren om, at vigtig
m(ormauon oomkring installation, brug, serwee og vediigeholdelse af produktet er

Trekanten med et lyn i midten har til hensigt at advare brugeren om, at produktet
indeholder “farlig speending”, og at det derfor er forbundet med fare for elektrisk sted
A iden bruger

WARNUNG: Zur Minderung des Risikos von Feuer und elektrischem Schock schiitzen Sie das
(WARNING) Geréat vor Regen und Feuchtigkeit.

ACHTUNG: Die Installation des Gerélas solite nur durch qualifiziertes Personal durchgetihrt
(CAUTION) werden und muB den j

ADVARSEL: Med henblik pa at reducere risikoen for brand eller elektrisk sted, ma produktet ikke
(WARNING) udseettes for regn eller fugt.

Die Modifikationen und die i zu den opti gen in der
Bedienungsanleitung sind nur fir qualifiziertes Personal bestimmt.

ACHTUNG

Risiko von elektrischem Schock
Gerét nicht dffnen

Achtung: Zur Minderung des Risikos von elekirischem
Sc

hock das Geriit nicht 3ffnen

Keine im Inneren

Service nur durch qualifiziertes Personai durchfihren lassen

FORSIGTIG: Installation af dette produkt skal ges af en i i og skal veere i
(CAUTION) med alle ige lokale
ivt udstyr i denne brugervejledning er kun
henvendt til kvahﬁcerede installatarer og servicepersonale.

FORSIGTIG
Fare for elektrisk sted
- mé ikke &bnes.
: Med henbiik ph st for elektrisk sted,
mA svabet iike flernes.
Indehoider ingen komponenter relevante for brugeren.

Anvend ved alte

VEILIGHEIDSINFORMATIE

De woorden WMRSOHUWING (WARNING) en VOORZICHTIG (CAUTION) we|ke in de
n op het U voor
Zij hebben de volgende betekenis:

WAARSCI De i U voor i die kunnen

(WARNING) leiden tot def of igi aan als dei niet
volledig worden opgevolgd.

VOORZICHTIG: De i ie i Uhoe U aan kunt

(CAUTION) of hoe U i kunt ijden die kunnen in

schade als de juiste stappen niet worden opgevolgd.

TURVALLISUUSTIEDOTE

Sa.nat VAROITUS (WAF\NlNG) ja HUOMIO (CAUTION) jotka esiintyvat manuaalissa ja itse
tur Nailla sanoilla on seuraava merkitys:

VAROITUS: Yhtey oleva i g i jotka johtaa vakaviin
(WARNING) in tai laitteen mikali ohjeita ei taysin noudateta.

HUOMIO: Yhteydessa oleva informaatio neuvoo, miten laitteen vaurioituminen voidaan
(CAUTION) ehkaista tai miten voidaan valttaa olosuhteet, jotka voivat johtaa lieviin vammoihin,
mikali ohjeita ei noudateta.

Produkt i ie en idi i d erkende om
veiligheidsinstructies aan te geven.

“gevaarlijke sp in het of bij de

/: De bhksemschucht in een driehoek wordt gebruikt om de gebruiker te anenderen
dle het risico van een electrische schok kunnen geven.

Het ullroepleken in een dnehoek wordt gebrulkt om de gebrmker te anenderen op
en in de die bij

het apparaat hoort.

WAARSCHUWING: OM HET RISICO VAN BRAND OF EEN ELECTRISCHE SCHOK TE

Tuotteessa tai kayttdohjeessa voidaan kayttaa seuraavia alla maariteltyja
invalisia ia, jotia vi — 8

Kolmlon sisélla olevan nuolipainen salama vammaa kamm laitteen sisalla tai
issé olevasta eri i &, joka saattaa olla

& i suuri ail o vaaran.

Kolmion sisélla oleva huutomerkin tarkoituksena on ilmoittaa kéyttajalle tarkeista
asennusta, kayttoa tai huoltoa koskevista ohjeista laitteen mukana seuraavassa
kirjallisuudessa.

(WARNING) VERMIJDEN DIENT U HET APPARAAT NIET AAN VOCHT BLOOT
TE STELLEN.
VOORZICHTIG: ie van dit dient te g i door ifi en
(CAUTION) dient te i conform de i i
Modificaties en i ie waar in de iding naar wordt N
dient alleen voor gebruik door gekwalificeerd personeel.

Waarschuwing: Om het risico van een electrische schok
1o verminderen het apparaat niet openen.

Er zijn geen, door gebrulker, vervangbare onderdelen in dit apparast.
Service overlaten san gekwalificeerd service personeel.

VAROITUS: ALA ALTISTA LAITETTA SATEELLE TAI KOSTEUDELLE TULIPALON JA
(WARNING) SAHKOISKUN VAARAN VUOKSI.

HUOMIO: Laitteen asentaminen tulisi jattaa itaitoisen henkilon i i ja
(CAUTION) tulee kaikkia isi ia

Tassa oleva i io, joka koskee Gitd ja lisalaittei
on itettu vain itaitois ja iIdiden kayttd
HUOMIO

HUOMIO: ALA AVAA KANTTA SAHKOISKUN VAARAN VUOKS!I

EI SISALLA KAYTTAJAN HUOLLETTAVIA OSIA-

JATA HUOLTO AMMATTITAITOISELLE HENKILOKUNNALLE




SIKKERHETS INFORMASJON

SAKERHETS INFORMATION

Nar ordene ADVARSEL (WARNING) og VIKTIG (CAUTION) blir brukt i manualen og pa produktet,
gjelder det i jon som har med & gjere. Ordene har felgende mening:

ADVARSEL: Tilhgrende informasjon viser til forhold som kan resultere i alvorlige skader eller
(WARNING) adeleggelser hvis anvisningene ikke folges naye.

VIKTIG: Tilherende informasijon forteller deg hvordan du skal unnga feil pa utstyret, eller
(CAUTION)  unnga situasjoner som kan resultere i mindre skader.

Orden VARNING (WARNING) och OBSERVERA (CAUTION) vilka anvénds i denna manual och

pé apparaten, &r menade att upp viktig sé ion. Dessa ord har foljande
betydelse.

H ion som pa som kan I i allvarlig
(WARNING) eller skada pa omil d ej foljs.

OBSERVERA: i a pai i om hur skada pé utrustning
(CAUTION) eller hur snuallonsr daér lattare personskador kan uppsté undvikes.

Produkt i ogb i bruker i j for & merke punkter som
er viktige for brukerens sikkerhet.

Lynet i en triangel advarer brukeren om uisolert “farlig spenning” inne i apparatet,
eller tilkoblings terminaler som kan gi stet.

Etter ulropstegnet ien lnangel lalger mformaslon som er viktig nar det gjelder
jon, bruk og (s ) av

Foljande il i & ord och anvands i och pa
pé produkten for att pa viktiga i

En blixt med pnl |nneslulen ien tnangel menad att uppmérksamma anvandare pa
eller pa

rliga i
& kontakter vnlka har tillrécklig styrka for att medfora risk for elektrisk sot.

Ett ulmpslscken inneslutet i en triangel, menad ah uppmérksamma anvéndare pa
viktiga it eller i i medfdljande
dokumentation.

ADVARSEL: FOR A REDUSERE FAREN FOR BRANN ELLER STOT MA APPARATET IKKE
(WARNING) UTSETTES FOR VANN ELLER FUKTIGHET.

VIKTIG: Installasjon av apparatet skal foretas av autorisert installater etter gjeldende
(CAUTION)  forskrifter.

VARNING:  FOR ATT MINSKA RISKEN FOR BRAND ELLER ELEKTRISK STOT,
(WARNING)  UTSATT EJ APPARATEN FOR FUKT ELLER VATSKA.

OBSERVERA: Installation av denna apparat skall utféras av kvalificerad installator samt enligt

iji Modifikasjoner og tilleggs informasjon som felger er kun for kvalifiserte installatgrer

eller service personell.
VIKTIG
FARE FOR STQT,
MA IKKE DEMONTERES.

VIKTIG: For & unngh faren for stet, mé ingen deksier flemes

Ingen interne deler skai justeres eller repareres av bruker.

Overiat service til sutorisert personell.

(CAUTION) alla géllande lokala bestammelser.
Eventuella modifierings i och annan i ion av teknisk art i denna
manual &r endast avsedd att anvéndas av kvalificierad installations och service
personal.

OBSERVERA
RISK FOR ELEKTRISK STOT
FAR EJ OPPNAS

OBSERVERA: FOR ATT MINSKA RISKEN FOR ELEKTRISK
STOT, AVLAGSNA EJ LOCKET.

INGA AV ANVANDARE UTBYTBARA ELLER REPARERBARA
KOMPONENTER INUTI DENNA APPARAT,

ALL SERVICE PA DENNA APPARAT SKALL UTFORAS AV
KVALIFICIERAD PERSONAL

IHHAHPO®OPIEX AXDPAAEIAX

O A KINAYNOE (WARNING) kat IPOZOXH (CAUTION) mov avagépoviat péoa o1o eyxewpisto
KQt GTT) GUOKELT}, ERIKEVIPOVOLY TV TIPOGOYT| OE CTIHAVTIKEG TANPOPOPIES acpalciag.
O Aé&eig avtég £YOVV TV RAPAKETEO onpacia.

KINAYNOZ: H uvaypnq»épsvn TANPOPOpia ETMGTE TNV TPOCOYT) GAG GE KATACTACEL; TOV
(WARNING) 6a va €xovv cav € coPapd L] pogi Mg
né\omcr(ug av ot 0dnyisg Sev axorovBnBodv katdAAnia.

INFORMAGAO SOBRE SEGURANCA

As palavras ADVERTENCIA (WARNING) e PHECAUCAO (CAUTION) neste manual, e no
dispositivo, alertam para imp Estas palavras significam o
seguinte:

ADVERTENCIA : Informagéo relacionada que alerta sobre condigdes que poderéo resultar em

(WARNING) lesdes sérias ou prejuizo, se as i ¢oes nao forem

PRECAUGAO : Informagéo relacionada que instrui como prevenir danos no equipamento ou
(CAUTION) como evitar condigdes que poderao resultar em lesdes leves, se 0s passos nao
forem seguidos adequadamente.

TPOLOXH: H PaAPOREVN oag 7@S va TPorap: pogi
(CAUTION)  tov eZom) b 1| médg va o mov Ba propod va £xouv @
A 0g av Sev axol bv Ta cwotd PApata.
Ing TV TP Kat 610 V Ta
owbvix uvuyv(npmouévﬂ uupBoM v (mo\mv o op\opég Siveran xapﬂm‘nm £to1 ot
papps QL pMVOH

7pocox Tou xpioT), TV YRAPEN M- HoVGREVIG « G 1oxbog » ot0
E£00TEPIKG TG CVOKEVT|G 1) OTIG GKpeg COVBEDTIC O1 OMOIEG UIOPEL Va EYOUV aPKETO péyEBog

H patevi avalapm pe copBolro 1o BErog, utoa ot0 rpwuvvo Exer m(oné va EmMOTHOEL THY
BoTe va TEPIEYOLV Kivduvo nhektporingiag.

xpfiom oTig onp odnyie ey pY1ag Kot cuvTiiprong (service) mov

To ene&nymuanikd onpeio, uéoa oto tpiywvo, qen oKon va emomosl ™V RPOCOYY) TOV
L i \ TEepEYovTaL oTa PUALGSIA IOV mrvo&coouv mv GVOKEVH.

KINAYNOZX : T va anogiyete tov kivduvo gonidg 1) nAextporinéiag, pnv exdétete avti tm
(WARNING) avoxevi} o€ Bpoy 1 o€ vypaoia.

MPOZOXH : H eykardortacn avtig TG vokevig B pénet va yiver and e£E8IKEVIEVO GTOHO Kat
(CAUTION)  6a mpénet va £TaL 6E GAOVG TOVG TOMIKOVG KDSIKES.

As etiquetas do produto e do manual de operagdes podem usar os simbolos
i abaixo para advertir mensagens de seguranga.

simbolo do relampago com uma seta, dentro de um tridngulo, tem o fim de

alenar 0 usudrio a presenga de “voltagem perigosa” sem isolagéo dentro da
caixa i do ou nos inais de ligagdo que podem ter a

magnitude suficiente que constitui um risco de choque eléctrico.

ponto de &0, dentro de um triangulo, tem o flm de alertar o usudrio
sobre instrugdes importantes de i a
na li que 0 ap

¢ Géo (servigos)

Ot | Kat ot & pieg Y1 Tov eE0MMONS, OV avaPEPOVTaL OE
avté To eyxewpidio, tpoopilovrar yia xprion pévo and eEerdikevpéva oIV EYKATACTOON KAt

010 service, Gropa.

j HPOLONH j

KINAYNOZ HAEKTPOITA

| MHN ANOITETE. I

TIPOZOXH : F1A NA MEIQEETE TON KINAYNO HAEKTPOTIAHZIAE,
MIN METAKINHEETE TO KAAYMMA.

AEN TAPEXONTAI ANTAAAAKTIKA SERVICE ETON XPHETH

T1A SERVICE ANAOFPOEITE £TO EEOYZIOAOTHMENO
MPOZQMIKO SERVICE

ADVERTENCIA : PARA REDUZIR O RISCO DE INCENDIO OU CHOQUE ELECTRICO,
(WARNING) NAO EXPONHA ESTE APARELHO A CHUVA OU HUMIDADE.

PRECAUGAO: A instalagao deste aparelho deve ser feita por um profissional qualificado
(CAUTION) e deve obedecer a todos os c6digos locais aplicaveis.

s8o para o uso exclusivo do pessoal qualificado de instalagéio e manuteng&o.

PRECAUGAO
A\ TR AN
NAO ABRA.

PRECAUCAO: PARA REDUZIR O RISCO DE CHOQUE
ELECTRICO, NAO REMOVA A TAMPA.

ij: Modificagdo e informagéao sobre equipamento adicional citados neste manual

PARTES INTERNAS NAO MANTIDAS PELO USUARIO.

ENCAMINHE A MANUTENGAO PARA PESSOAL
DE SERVICOS QUALIFICADO.




