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Software License Agreement
This Software License Agreement (“License Agreement”) is a legal agreement between you (either an
individual or a single entity) and Serif (Europe) Ltd. (“Serif”) for the accompanying software product,
which includes computer software and may include associated media, printed materials, and “online”
or electronic documentation (the “Software Product”). By installing, copying, or otherwise using the
Software Product, you agree to be bound by the terms of this License Agreement. If you do not agree
to the terms and conditions of this License Agreement, do not install or use the Software Product; you
may, however, return it to your place of purchase for a full refund.

THANK YOU FOR LICENSING THE USE OF THE SOFTWARE PRODUCT. IT IS IMPORTANT THAT YOU (THE “LICENSEE”)
READ THIS NOTICE CAREFULLY. THESE ARE THE ONLY TERMS AND CONDITIONS APPLICABLE TO YOUR RIGHTS
WITH RESPECT TO THE SOFTWARE PRODUCT. THE SOFTWARE PRODUCT IS PROTECTED BY COPYRIGHT LAWS AND
INTERNATIONAL COPYRIGHT TREATIES, AS WELL AS OTHER INTELLECTUAL PROPERTY LAWS AND TREATIES. THE
SOFTWARE PRODUCT IS LICENSED, NOT SOLD.

1. GRANT OF LICENSE

Serif hereby grants to Licensee a personal, non-exclusive, non-
transferable license (a “License”) to use one (1) copy of the
Software Product, including any updates thereto, and
accompanying documentation, if any, provided by Serif, according
to the terms set forth below. If the Software Product is being
provided to Licensee as an update or upgrade to software which
Licensee has previously licensed (such software referred to as the
“Prior Software”), then Licensee agrees to destroy all copies of the
Prior Software within thirty (30) days after opening this package
except for one backup copy of the Prior Software.

2. SCOPE OF USE

You may install and use one copy of the Software Product, on a
single computer. The primary user of the computer on which the
Software Product is installed may make a second copy for his or
her exclusive use on a portable computer. Licensee may also store
or install a copy of the Software Product on a storage device, such
as a network server, used only to install or run the Software
Product on other computers over an internal network; however,
you must acquire and dedicate a license for each separate computer
on which the Software Product is installed or run from the storage
device. A license for the Software Product may not be shared or
used concurrently on different computers.

3. LICENSE PAK

If you have acquired this LICENSE AGREEMENT in a Serif
License Pak, you may make the number of additional copies of the
computer software portion of the Software Product as authorized
in the Serif License Pak, and you may use each copy in the manner
specified above. You are also entitled to make a corresponding
number of secondary copies for portable computer use as specified
above.

4. PROHIBITIONS

You may not: modify, prepare derivative works from, translate,
reverse engineer, decompile, disassemble or otherwise derive
source code from the Software Product (except to the extent that
such acts are expressly permitted by applicable law
notwithstanding this limitation); copy the Software Product
(except as provided above) or the accompanying documentation;
rent, transfer, disclose, make available or grant any rights in the
Software Product (including any accompanying documentation) in
any form to any person without the prior written consent of Serif;
remove any proprietary notices, labels, or marks on the Software
Product (including any accompanying documentation); use the
Software Product in any manner that infringes the intellectual

property or other rights of another party; or use the Software
Product to provide on-line or other database services to any other
person.

5. RETENTION OF RIGHTS; TERMINATION

This License Agreement does not constitute a sale. All title, trade
secrets, copyrights, patents and other intellectual rights to the
Software Product, its accompanying documentation and any copy
made by Licensee remain with Serif, and Licensee hereby agrees
to preserve and acknowledges the foregoing. Licensee further
agrees and acknowledges that the Software Product and all copies
thereof are Serif’s exclusive property and constitute a valuable
trade secret of Serif. Licensee further agrees and acknowledges
that unauthorized copying of the Software Product or the
accompanying documentation, or failure to comply with any of the
provisions hereof (each, a “Terminable Event”), will result in
automatic termination of this License. In the event of a violation of
this License by Licensee, Serif reserves and shall have available all
legal remedies.

6. TERM OF LICENSE FOR TRIAL VERSION SOFTWARE

The License pertaining to a trial version of the Software Product (a
“Trial Version”) shall expire in accordance with the terms as set
forth in the installation process for the Trial Version along with the
designated trial period as set forth in the trial program.

7. LIMITED WARRANTY AND DISCLAIMER

Serif warrants that, for a period of ninety (90) days after delivery,
the diskettes or CD-ROMs on which the software included in the
Software Product is furnished will, under normal use, be free from
defects that prevent Licensee from loading the Software Product
on a computer. Serif’s entire liability and Licensee’s exclusive
remedy under this warranty will be, at Serif’s option, to (a) use
reasonable commercial efforts to attempt to correct or work around
errors, or (b) to replace the Software Product with functionally
equivalent Software Product, on diskettes or CD-ROM, as
applicable or (c) return the price paid for the Software Product, in
each case upon return of the Software Product to Serif together
with a copy of your receipt for the purchase thereof. This Limited
Warranty is void if failure of the Software Product or hardware has
resulted from accident, abuse, or misapplication. Any replacement
Software Product will be warranted for the remainder of the
original warranty period or thirty (30) days, whichever is longer.
Outside the United States, neither these remedies nor any product
support services offered by Serif are available without proof of
purchase from an authorized non-U.S. source. The Software
Product is licensed to you on an “as is” basis without any warranty
of any nature.



8. NO OTHER WARRANTIES

Except for the above express limited warranties, Serif and its
suppliers make and licensee receives no warranties or conditions,
or terms, express, implied, statutory, or in any communication with
licensee. To the maximum extent permitted by applicable law,
Serif and its suppliers disclaim all other warranties and conditions,
either express or implied, including, but not limited to, implied
warranties of merchantability, fitness for a particular purpose, title
and non-infringement, with regard to the software product and the
provision of or failure to provide support services. Licensee shall
be solely responsible for the selection, use, efficiency and
suitability of the software product and serif shall have no liability
therefor. Serif shall have no liability for, nor obligation to
indemnify licensee regarding actions alleging the infringement of
proprietary rights by the software product. Serif does not warrant
that the operation of the software product will be uninterrupted or
error free or that the software product will meet licensee’s specific
requirements. The Limited Warranty gives you specific legal
rights. You may have others, which vary from state/jurisdiction to
state/jurisdiction.

9. LIMITATION OF LIABILITY

In no event will Serif or its suppliers be liable for loss of data,
corruption, lost profits, cost of cover, or other special, incidental,
punitive, consequential, or indirect damages arising from the use
of the software product (including any accompanying
documentation), however caused and on any theory of liability.
This limitation will apply even if Serif or an authorized distributor
has been advised of the possibility of such damage. In no event
will Serif’s liability exceed the amount paid for the software
product. Licensee acknowledges that the amounts paid by licensee
for the software product reflect this allocation of risk. Some states
or other jurisdictions do not allow the exclusion or limitation of
liability for incidental or consequential damages, so the above
limitations and exclusions may not be applicable in certain
instances. None of the above affects the statutory rights of
licensees residing in the United Kingdom.

10. NOT FOR RESALE SOFTWARE

If the Software Product is labeled “Not for Resale” or “NFR,”
then, notwithstanding section 1 of this License, your use of the
Software Product is limited to use for demonstration, test, or
evaluation purposes.

11. NO RENTAL; OTHER TRANSFERS

You may transfer this License to another computer or workstation
only on a permanent basis (that is, with no intent to transfer again)
provided the computer, workstation, or other
digital electronic device from which you have transferred this
License no longer accesses or otherwise utilizes the Software
Product, and the Software Product is used in accordance with the
terms of this License Agreement.

12. TERMINATION

You may terminate this License Agreement at any time. Serif may
terminate this License Agreement if you fail to comply with the
terms and conditions of this License Agreement. In either event,
you must destroy all copies of the Software Product.

13. UPGRADE

If this License is an “Upgrade,” you must have a valid license for
the Prior Software for this License Agreement to be valid, and this
License Agreement must be used to replace such license for the
Prior Software. The total number of license “Upgrades” you may
acquire may not exceed the total number of computers,
workstations, or other digital electronic devices that were licensed

to access or otherwise utilize the Software Product at the time you
upgraded the Software Product.

14. GUIDELINES FOR THE USE OF DIGITAL CONTENT
IMAGES

This product contain numerous clipart and photo images
(collectively referred to as the “Images”) which are either owned
by SERIF or licensed from a third-party. As a user of this product
you are free to use, modify and publish the Images as you wish
subject to the restrictions set out below. If you are uncertain in as
to whether your intended use is in compliance with the Guidelines
set out below, we recommend that you seek the advice of your
own attorney or legal counsel.

A. YOU MAY, subject to any restrictions set out below:

1. incorporate any Image(s) into your own original work and
publish, display and distribute your work in any media. You may
not, however, resell, sublicense or otherwise make available the
Image(s) for use or distribution separately or detached from a
product or web page. For example, the Image(s) may be used as
part of a web page design, but may not be made available for
downloading separately or in a format designed or intended for
permanent storage or re-use by others. Similarly, clients may be
provided with copies of the Image(s) (including digital files) as an
integral part of a work product, but may not be provided with the
Image(s) or permitted to use the Image(s) separately or as part of
any other product;

2. make one (1) copy of the Image(s) for backup or archival
purposes.

B. YOU MAY NOT

1. create scandalous, obscene, defamatory or immoral works using
the Image(s) nor use the Image(s) for any other purpose which is
prohibited by law;

2. use or permit the use of the Image(s) or any part thereof as a
trademark or service mark, or claim any proprietary rights of any
sort in the Image(s) or any part thereof;

3. use the Image(s) in electronic format, on-line or in multimedia
applications unless the following is met:

(a) The Image(s) are incorporated for viewing purposes only and
no permission is given to download and/or save the Image(s) for
any reason.

4. rent, lease, sublicense or lend the Image(s), or a copy thereof, to
another person or legal entity. You may, however, transfer all your
license to use the Image(s) to another person or legal entity,
provided that (i) you transfer the Image(s) and this License,
including all copies (except copies incorporated into your work
product as permitted under this License), to such person or entity,
(ii) that you retain no copies, including copies stored on a
computer or other storage device, and (iii) the receiving party
agrees to be bound by the terms and

conditions of this License;

5. use any Image(s) except as expressly permitted by this License.

15. MISCELLANEOUS

This Agreement shall not be governed by the 1980 U. N.
Convention on Contracts for the International Sale of Goods;
rather, this Agreement shall be governed by English law. This
Agreement constitutes the entire agreement between Serif and
Licensee and supersedes all prior agreements, understandings,
communications, advertising, proposals or representations, oral or
written, by either party. If any provision of this Agreement is held
invalid or unenforceable, such provision shall be revised to the
extent necessary to cure the invalidity or non-enforceability, and
the remainder of this Agreement shall continue in full force and
effect. This Agreement shall be amended only by an executed
writing by authorized representatives of both parties.



How to contact us 

Our main office (UK, Europe): 

The Software Centre 

PO Box 2000, Nottingham, NG11 7GW, UK 

Main    (0115) 914 2000 

Registration (UK only)  (0800) 376 1989 

Sales (UK only)   (0800) 376 7070 

Technical Support (UK only) (0845) 345 6770  

Customer Service (UK only) (0845) 345 6770 

Customer Service/ 

Technical Support (International) +44 115 914 9090 

General Fax   (0115) 914 2020  

Technical Support E-mail  support@serif.co.uk 

American office (USA, Canada): 

The Software Center 

13 Columbia Drive, Suite 5, Amherst, NH 03031 

Main    (603) 889-8650 

Registration   (800) 794-6876 

Sales    (800) 55-SERIF or 557-3743 

Technical Support  (603) 886-6642 

Customer Service   (800) 489-6720 

General Fax   (603) 889-1127  

Technical Support E-mail  support@serif.com 

Online 

Visit us on the Web at  http://www.serif.com 

Serif newsgroups   news://news.serif.com 

International 

Please contact your local distributor/dealer. For further details please contact 

us at one of our phone numbers above.  

Comments or other feedback 

We want to hear from you! E-mail feedback@serif.com with your ideas and 

comments! 
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Introduction
Welcome to Serif PhotoPlus 8.0—absolutely the best value in image creation
and editing software for any home, school, organization, or growing
business. PhotoPlus is your number one choice for working with photographs
and paint-type images, whether for the Web, multimedia, or the printed page.

PhotoPlus has the features you’ll need... from importing or creating
pictures and animations, through manipulating colors and effects all the
way to final export. Built-in support for TWAIN scanners and cameras
makes it easy to bring in your own photos, while comprehensive import
filters let you open just about any standard bitmap image.

Once you’ve got your image into PhotoPlus, you can enhance and alter its
on-screen appearance with a diverse toolkit of functions and effects. A full
range of export options (with special attention to Web graphics), plus
powerful optimization capabilities, round out this high-performing package.

About the Companion
This Companion is your guide to getting started and getting results with
PhotoPlus—from the basics to advanced techniques. The chapter
sequence begins with basic concepts and proceeds gradually through
various tools and features. Hands-on Projects are integrated each step of
the way. We hope you’ll take your time and enjoy the learning process.
Here’s a quick summary of chapter contents:

1 Welcome. There, we’ve said it again!

2 Getting Started. Will have you up and running in no time with
an overview of key concepts and the PhotoPlus interface.

3 Manipulating Images. A rundown of basic techniques for
selecting and operating on all or just part of an image.

4 Working with Paint, Shapes, and Text. How to proceed from
the proverbial blank slate, using the PhotoPlus creation tools.

5 Using Layers and Masks. Understanding and mastering the
creative possibilities of these more advanced features.

6 Preparing Web Graphics. A review of Web image formats and
step-by-step guidance on animation and image preparation.

7 Color and Output Options. Combines essential background
material and terminology with helpful tips to improve your
images.
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What’s New in PhotoPlus 8.0
Whether you’re a new or returning PhotoPlus user, you’re sure to
appreciate all the advances that keep it right on the cutting edge of value
and performance:

♦ Astounding 3D Lighting and Surface Effects
Advanced algorithms bring flat shapes to life! Vary surface and
source light properties. Start with a pattern or a function, adjust
parameters for incredible surface contours, textures, fills.
Optimized for Intel® Pentium® 4 processors.

♦ 3D Painting using Depth Maps
Add instant dimensionality to your artwork. Painting or erasing on
a layer’s depth map appears as raised or lowered strokes on the
image! Use with 3D layer effects to achieve “carved” side-view
textures.

♦ Instant Effects Gallery
Puts our 3D technology and layer effects at your disposal, with no
learning curve—simply choose a surface texture, pattern, glow, or
bevel—then customize as you wish. Add your own categories and
effects!

♦ Instant Artist Painting Effects
Customizable, automatic effects that turn your photos into works of
art. Choose any style (Expressionist, Impressionist, Pointillist) or
medium (Oil, Pencil, Paint and Ink, Watercolor), then dial up the
effect you want!

♦ Universal Gradient Fill Editing
One master dialog allows editing of five fill types, now combining
both color and transparency. Choose from a built-in gallery of
presets, add your own categories and fills. Works with all PhotoPlus
tools and effects that employ gradient fills!

♦ Freehand and Bézier Curve and Shape Drawing
Powerful vector-drawing tools let you produce any shape under the
sun with controllable, connectable, editable line segments.

♦ Combinatorial Shapes
Now create multiple shapes on a single layer! For each additional
shape, you can add, subtract, intersect, or exclude with previous
shapes for frames, cutouts and custom contours.
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♦ Enhanced Selection Modes
Lots of news here! Paint to Select mode lets you literally “brush on”
selectedness. Border, Threshold, and Smooth commands for more
versatility. Store and load selections between any open file. Use
combination buttons (as for shapes) to define cutout selection
regions. Convert selections into paths or layers.

♦ Paths
Use the full range of line- and shape-drawing tools to create editable
outlines via the new Paths tab. Convert paths to or from selections
on any layer. “Stroke” paths using any brush to create bordered
shapes!

♦ More Powerful Masking
Masks now work on shape and text layers, too! Plus they now move
independently of their layers and store their own colors. Extra
convenience with mask preview thumbnails and key-assisted mode-
switching, and much more.

♦ UI Improvements
New Layers tab buttons for most-used operations, plus preview
thumbnails for masks and depth maps. Zoom to a region. View a
shaded exclusion zone when cropping. A redesigned Export
Optimizer. New Layout Guides, plus optional Snapping to grid or
guides for finer control when painting or erasing.

♦ Extended Import Capabilities
Support for Paint Shop Pro® 7 (.PSP) files including layer
information! And import Paint Shop Pro (.TUB) picture tubes to use
as PhotoPlus Picture Brushes!

♦ ...And More!
Quickly align shapes or text between multiple linked layers. Smart
Resize means more efficiency, less loss. The Deform Mesh tool for
reshaping any freeform region. New filters like Intelligent Blur,
Maximum, and Minimum... All filters rewritten for improvements
across the board!

Special Note: If you’ve upgraded to PhotoPlus 8.0 and want a quick-start
preview of what’s new and different, check out the “New Features”
tutorial on the PhotoPlus 8.0 Resource CD-ROM!
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Plus These Established Features...
PhotoPlus brought professional image editing to everyone—with features
like these:

♦ Editable QuickShapes
Easy to create, easy to change! Simply drag sliders to morph
chevrons, hearts, badges, teardrops, moons, zigzags, and many
more... apply layer effects and gradient fills... and edit any shape at
any time.

♦ Browse Image Files and Folders
The built-in Image Browser rapidly displays image thumbnails—
a folder at a time—so you can preview clip art or saved work and
inspect file details in a convenient, Explorer-style interface.

♦ Unique Selection Options
PhotoPlus goes well beyond the basic rectangle and lasso tools,
adding more than a dozen completely customizable selection shapes
like polygons, spirals, and stars. Use Magnetic Selection to find
edges as you trace them. Or define a selection shaped like text—
using any font and style! Advanced options let you fine-tune the
selection and its properties for smoother blends and precise effects.

♦ Stamp and Spray
Use Picture Brushes to lay down colorful arrays of single or multiple
mini-images: realistic machine cogs, colorful tubes, falling leaves,
flowers, jelly beans, jewels, raindrops, marbles, planets, and more...

♦ Powerful Image Export Optimizer
The Export Optimizer lets you see how your image will look (and
how much space it will take up) before you save it! Its multi-window
display provides side-by-side WYSIWYG previews of image quality
at various output settings, so you can make the best choice every
time.

♦ Web Animation Tools
Iit’s easy and fun to create or edit animations for the Web. You can
import and export animated GIFs, apply special effects, even let
PhotoPlus create entire animations for you automatically. Or export
to the .AVI format for movies and multimedia!

♦ Editable Text
Add formatted color text to an image, reposition and scale it,
integrate it with your design. Text layers keep the contents separate
so you can go back and alter the words or formatting at any time!
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♦ Special Erase Options
Need to remove that blue sky and leave the clouds? Use the Flood
Eraser to fill the blue regions with transparency. Want to isolate a
shape from a flat color background? The Background Eraser samples
pixels under the brush, so only unwanted colors drop out.

♦ Image Enhancement
Apply professional, darkroom-style color and histogram adjustments
to your images. Employ the Blur and Sharpen tools to enhance or
reduce local detail... blend multiple layers more cleanly. There’s
even a dedicated tool for removing “red eye” from flash photos.

♦ Special Effects, Image Correction Filters
A wild and whimsical assortment for instant creativity! Powerful
image correction functions for fingertip control over tones and
colors. Add Shadow, Bevel, Emboss layer effects for a sophisticated
3D look on text or other image elements. PhotoPlus supports third-
party Photoshop® plug-ins, and even lets you design your own
custom filters.

♦ Editable Adjustment Layers
Not only apply color corrections and special effects, but store each
change on a separate layer. To fine-tune any adjustment later, just
click its layer and change the settings!

♦ Versatile Deform and Warp Tools
“Swiss Army Knife” of image tools, Deform lets you rotate, resize,
skew, reshape, or add perspective to any selection or layer. Warp
tools pull, stretch, and distort image details, or shrink and enlarge.
Pixels turn to putty with the Mesh Warp tool! Use a customizable
grid of points and lines to bend images with precision.

♦ Gradient Fills
Take your pick of radial, linear, conical, or square fills—perfect for
masking, to hide or reveal parts of your photo using smooth
graduated blends to transparency. (Of course, there’s standard flood
fill as well.)

♦ Image Slicing and Image Maps
Now it’s not just the pros who can use these techniques to add links
to Web graphics! Simply click to divide images into segments—each
with its own hyperlink and popup text—or add hotspots to specific
regions. PhotoPlus outputs the HTML code and lets you preview the
results directly in your Web browser.
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♦ Advanced Tools and Features
Built-in support for most pressure-sensitive graphics tablets. RGB,
CMYK, HSV, and Grayscale color modes. Robust and convenient
layer management with pop-up preview and masking support.
Extract command to isolate a face, feature, or object.

♦ Professional Output Options
Output using CMYK separations or print directly to your desktop
printer with powerful controls. Include registration marks, crop
marks, file information, grayscale and color bars, and tile or scale
your output if required.

♦ Productive MDI Interface
Open and view multiple images and edit them simultaneously.
Dockable, floating tab windows work in conjunction with convenient
toolbars. The Navigator and Layers tab provide full control over all
regions and planes. Each document stores a massive Undo range
with dynamic memory and disk management, compressing
information for optimized performance. Built-in Autoselect for rapid
navigation in multi-layered images... handy Measure tool for
checking pixel dimensions... the Undo History tab so you never lose
track of where you’ve been. And PhotoPlus remembers your
preferred export settings, so your creative flow is undisturbed.

And that’s only part of the story! The PhotoPlus feature set includes all
the standard capabilities you’d expect in a photo editor. Tools like
Paintbrush, Airbrush, Clone, Smudge, and Erase. Customizable brush
tips, opacity, and blend mode settings. Flip, rotate, and crop. Anti-
aliasing. TWAIN support for scanner and digital camera input. A full
range of supported file formats for both import and export. Bonus
TrueType fonts. In short, more features for the price than allowed by law
in some jurisdictions (but don’t tell anyone)...
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Registration, Upgrades, and Support
If you see the Registration Wizard when you launch PhotoPlus, please
take a moment to complete the registration process. Just call Serif toll-
free and provide the installation number and code shown. We’ll give you
a personalized registration number in return. Remember, if you need
technical support please contact us. We aim to provide fast, friendly
service and knowledgeable help.

Installation

PhotoPlus system requirements
PhotoPlus runs with Windows 95 or later, so you’ll need a PC setup
which runs Windows adequately. If you need help installing Windows, or
setting up your printer, see Windows documentation and help.

Minimum:
♦ IBM compatible Pentium PC with CD-ROM drive and mouse (or

other Microsoft compatible pointing device)

♦ Microsoft Windows® 95, 98, 98 SE, Me, 2000, XP, or Windows
NT® 4.0 or later operating system

♦ 70MB (Windows 95/98), see manufacturer’s requirements for other
operating systems

♦ 40MB (recommended install) free hard disk space

♦ SVGA display (800x600 resolution, 16-bit color or higher)

Additional disk resources and memory are required when editing large
and/or complex images.

Optional:
♦ Windows-compatible printer

♦ TWAIN-compatible scanner and/or digital camera

♦ Stylus or other input device, including pressure sensitive pen

♦ Internet account and connection required for accessing online
resources.
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What you need to know
PhotoPlus is very easy to use, and you don’t need to have any prior
design experience. However, if you’re new to Windows computing, you
will find it much easier if, before installing and using PhotoPlus, you
spend a little time becoming familiar with the Windows operating
environment.

� From the Windows desktop, click the Start button at the lower left
and choose Help.

First-time install
To install PhotoPlus, simply insert the Program CD-ROM into your CD-
ROM drive. The AutoRun feature automatically starts the Setup process
and all you need to do is select the PhotoPlus Install option and answer
the on-screen questions. If the AutoRun does not start the install, use the
manual install instructions below.

Manual install/re-install
To re-install the software or to change any part of the installation at a
later date, select Settings/Control Panel from the Windows Start menu
and then click on the Add/Remove Programs icon. Make sure the
correct CD-ROM is inserted into your CD-ROM drive, click the Install…
button, and then simply follow the on-screen instructions. To install just
one particular component to your hard drive, choose the Custom option
and check only that component.
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Seven Key Concepts
If you’re new to photo editing programs, or perhaps have only worked
with a basic painting program like Microsoft Paint, a number of the
concepts in PhotoPlus may be new to you. Don’t be daunted! Many
thousands of artists have made the leap—the rewards are well worth it!

This section collects in one place some background material that should
serve as a concise introduction and save you some “head-scratching” later
on. We recommend you read through it before racing ahead to the rest of
the chapter. And check out the “Key Concepts” tutorial on the PhotoPlus
8.0 Resource CD-ROM for a hands-on walkthrough!

1 Image size and canvas size
Sometimes a tricky distinction if you haven’t encountered it before, this
is an important one when working with digital pictures. You probably
know that image dimensions are given in pixels (think of pixels as as the
“dots of paint” that comprise a screen image)—say, 640 wide by 480
high. If you want to change these dimensions, there are two ways to go
about it, and that’s where image and canvas come into
play. Changing the image size (I) means scaling the
whole image or just a selected region up or down.
Changing the canvas size (C) means adding or taking
away pixels at the edges of the image—rather like
adding a border around a mounted photo, or taking a
pair of scissors and cropping the photo to a smaller size. Either way, after
resizing, the image and canvas dimensions are once again identical.

2 Interacting tools and tabs
The Tools toolbar (see the PhotoPlus Toolbars and Tabs diagram later in
this chapter) is at the heart of PhotoPlus. Among its many offerings
you’ll find several basic painting/drawing tools,
plus tools for erasing, filling a region, and cloning a
region (all covered in detail in Chapter 4). As you try
each of these tools, keep in mind that the Tool
Properties tab and Brush Tip tab extend each tool’s
functionality by letting you customize its settings. Only with the aid of
the tabs can you choose a wide brush as opposed to a pencil point, or
experiment with the full range of effects each tool can command.
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3 Making a selection
In any photo editing program, the selection
tools (see Chapter 3) are as significant as any
of the basic brush tools or commands. The
basic principle is simple: quite often you’ll
want to perform an operation on just a portion
of the image. The wide range of selection options in PhotoPlus lets you:

♦ Define just about any selection shape

♦ Modify the extent or properties of the selection

♦ Carry out various manipulations on the selected pixels, including cut,
copy, paste, rotate, adjust colors, apply special effects, etc.

Although the techniques for using each selection tool vary a bit, the end
result of making a selection is always the same: a portion of the image
has been roped off from the rest of the image. The boundary is visible as
a broken line or marquee around the selected region.

4 Foreground and background colors
At any given time, PhotoPlus allows you to work
with just two colors—a foreground color and a
background color. These are always visible as
two swatches on the Color tab. Electronic artists
expend much of their creative energy deciding which of the millions of
available colors should fill those two slots. The actual steps involved,
however, can be quite simple (see Chapter 4).

5 Layers
If you’re accustomed to thinking of
pictures as flat illustrations in books,
or photgraphic prints, the concept of
image layers may take some getting
used to. In a typical PhotoPlus image—for example, a photograph you’ve
scanned in, a new picture file you’ve just created, or a bitmap file you’ve
opened—there is one layer that behaves like a conventional “flat” image.
This is called the Background layer, and you can think of it as having
paint overlaid on an opaque, solid color surface. (Don’t confuse the
“background color” with the “Background layer”—there’s absolutely no
connection!)
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On top of the Background layer, you can create any number of new layers
in your image. Each new one appears on top of another, comprising a
stack of layers that you can view and manipulate with the Layers tab. We
call these additional layers standard layers to differentiate them from the
Background layer. Standard layers behave like transparent sheets through
which the underlying layers are visible.

With few exceptions, you will work on just one layer at any given time,
clicking in the Layers tab to select the current or active layer. Selections
(see above) and layers are related concepts. Whenever there’s a selection,
certain tools and commands operate only on the pixels inside the
selection—as opposed to a condition where nothing is selected, in which
case those functions generally affect the entire active layer.

If your image has multiple layers, and you switch to another layer, the
selection doesn’t stay on the previous layer—it follows you to the new
active layer. This makes sense when you realize that the selection doesn’t
actually include image content—it just describes a region with
boundaries. And following the old advice “Don’t confuse the map with
the territory,” you can think of the selection as a kind of outline map, and
the active layer as the territory.

There are a few other special-purpose layers. For example, you can add
adjustment layers (see Chapter 3) that let you try out effects on lower
layers without actually applying them until you’re ready to do so.
PhotoPlus stores the text you create on text layers, while shapes go on
shape layers. Both text and shape layers (see Chapter 4) work pretty
much like standard transparent layers, and keep their respective elements
editable so you can go back and make changes later.

We’ll delve further into layers later in this chapter. Chapter 5 provides in-
depth coverage.

6 Opacity and transparency
Opacity and transparency are complementary—
like “half full” and “half empty.” They both refer
to the degree to which a particular pixel’s color
contributes to the overall color at that point in the
image. (Pixels again are the “screen dots” that comprise a bitmap image
in PhotoPlus.) Varying opacity is rather like lighting a gauze backdrop
(scrim) in a theater: depending on how light falls on it, it can be rendered
either visible or invisible, or in between. Fully opaque pixels contribute
their full color value to the image. Fully transparent pixels are invisible:
they contribute nothing to the image.
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In-between pixels are called semi-transparent. You’ll primarily encounter
these terms in two contexts. First, as a property of the pixels laid down by
individual paint tools, which can be more or less opaque, depending on
the tool’s opacity setting. Second, as a property of individual layers,
where opacity works like a “master setting” that you can vary after paint
has been laid down.

7 Saving and exporting
Saving a file in PhotoPlus means storing the
image in the native PhotoPlus file format,
using the .SPP extension. This format
preserves image information, such as multiple
layers, masks, or image map data, that would
be lost in conversion to another graphic
format. On the other hand, suppose you’ve opened a .BMP or .JPG file
and want to save it back to its original format. In this case, use the Save
Original command.

In yet another instance, you may be ready to save an .SPP file (or convert
some other image type) to one of the standard graphics formats. In
PhotoPlus, this is known as exporting. PhotoPlus includes a powerful
Export Optimizer that serves as your “command center” for exporting
images to various formats. It not only provides a variety of options for
each supported format, but lets you compare image quality using
different settings and even retains your preferred settings for each format!

There’s more on saving and exporting later in this chapter, and Chapter 7
includes details on file formats and optimizing images.

Starting PhotoPlus
Enough tedious lecture—on to the demonstrations! (We’ll skip the quiz.)
It’s time to begin exploring PhotoPlus.

� NOTE: Throughout the Companion, you’ll see � checkbox
bullets that mark the ongoing tutorial thread—steps we’d like you
to complete as you follow along with the text. You’ll come across
many other descriptions and examples of commands, tools, and
procedures (and of course you’re encouraged to experiment). But
remember—unless a step has a checkbox, it’s entirely optional!

The Setup routine adds a Serif PhotoPlus item to the Programs submenu
of the Windows Start menu.
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� Use the Windows Start button to pop up the Start Menu and click on
the PhotoPlus item.

PhotoPlus launches and displays the Startup Wizard, with a variety of
choices:

♦ Open Saved Work displays a browser that lets you preview and
open saved image files—pictures in any supported format as well as
animated GIFs (see Chapter 3).

♦ Create New Picture opens a new image window using a size and
background color you specify (see Chapter 4).

♦ Create New Animation opens a new image window and displays
the Animation tab, with controls for creating animation frames (see
Chapter 6).

♦ Import from TWAIN lets you bring in pictures from devices like
scanners and digital cameras (see Chapters 3 and 7).

♦ View Samples opens the gallery of PhotoPlus images.

If you don’t care to see the Startup Wizard again, uncheck the “Use the
Startup Wizard next time” box. However, we suggest you leave it
checked until you’re familiar with the equivalent PhotoPlus commands.

� Click Open Saved Work and then click the Browse button in the
dialog.
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� PhotoPlus is set to initially display the contents of the PhotoPlus
PROJECTS folder, located on your hard disk. If the Open dialog
displays a different folder, browse to PROGRAM

FILES\SERIF\PHOTOP80\PROJECTS.

� NOTE: Whether or not you use the Projects folder to store your
own work, remember its location so you’ll know where to find
Companion source files when they’re needed later on.

� Select the file CAT.JPG in the Projects folder and click Open.

The cat photograph opens in a new image window (your precise screen
layout may vary somewhat from the illustration).
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Getting Your Bearings
Now that you’ve got an image open, and the PhotoPlus menus and tools
are available, let’s take a quick look around the PhotoPlus environment.
Even if you’re in a rush to start working, don’t skip the rest of the
chapter! At the very least, take note of what’s here so you’ll know where
to find the information when you need it later.

Introducing the interface
PhotoPlus is an MDI application. MDI stands for Multiple Document
Interface and it means that you can have multiple documents—images, in
PhotoPlus terms—open at the same time. Each image window contains
one image, with the image’s name shown in the window’s titlebar. At any
given time, one image window will be active in front of any others, with
its name shown in the main PhotoPlus titlebar.

You can use commands from theWindow menu to arrange the image
windows. If you have more than one image open, then you can switch to
another window using the Window menu or the keyboard shortcut
Ctrl+Tab. Double-click on an image window’s titlebar to maximize it.

The PhotoPlus toolbars and tab windows (tabs for short) are are
essential features of the PhotoPlus environment. The PhotoPlus Toolbars
and Tabs diagram on the next page identifies the principal tabs and
provides an overview of what they do.

To display the related online help topic for any tab, first click the
Help button on the top toolbar, then click the tab.

When you first launch PhotoPlus, it opens with the PhotoPlus toolbars
and tabs all visible in default positions, with certain tabs “docked” or
joined together. You can hide, show,
or move them individually as needed,
and dock or undock the tabs. Chances
are you’ll want to keep the Tools
toolbar visible, but if your display
area is large enough you might
consider moving it to a horizontal
position alongside the top (Standard)
toolbar—or “floating” it as a separate
palette. Remember, there’s nothing fixed about the PhotoPlus interface,
so feel free to try different arrangements until you’re satisfied.
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Principal PhotoPlus Toolbars and Tabs

Standard toolbar
Provides standard file and Clipboard commands, plus
Zoom, Pan, Measure, and Web graphics tools.
Click the [?], then any tab, for context-sensitive help!

Tools toolbar
Features tools for selecting regions of the screen,
painting and erasing, cropping and deforming selections,
adding shapes and text, retouching... and more

Tool Properties tab
Lets you customize the
settings for many of the tools
on the Tools toolbar

Brush Tip tab
Lets you choose and customize

brush tips for the painting tools,
define custom brushes

Paths tab
Stores independent outlines
you can convert to (or from)
selections, apply to any layer
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Layers tab
Has controls for creating, deleting,

arranging, merging, and setting
properties of layers in the image

Color tab
Lets you select foreground and
background colors and change
the color mode

Navigator tab
Lets you quickly see different parts of
the image and change the zoom view

Animation tab
Provides controls for editing animation
files (only appears in Animation mode)

Instant Effects tab
Provides multiple categories of
preset effects for spectacular
textures and dimensionality
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To turn off a tab, click the Close button in its titlebar. To turn a tab or
toolbar off or on, uncheck or check its name on the View menu. If you
need more room on-screen for a particular operation, press the Tab key to
turn all the visible tabs off, and again to turn them back on.

To dock or undock a tab, click on its label and drag to the new position,
either floating independently or docked in a window next to another tab.

It’s easy to get online help in PhotoPlus. For a summary, see the “Getting
Help” section at the end of this chapter.

Setting preferences
To specify the ruler units, grid interval, and other preferences, choose
Preferences… from the File menu to open the Preferences dialog. Select
the appropriate options on the Undo, Plugins, Layout, Startup, and/or
Browser tab of the dialog. Note that less compression in Undo will
provide faster performance.

Changes to the Plugins folder will not take effect until PhotoPlus is
closed and restarted.

When you have made your choices, click theOK button to save your
changes or click Cancel to abandon them.

Setting the view
Zooming (changing the relative size of the image in relation to its
window) and panning (moving the image in relation to its window) are
essential when you’re operating at different levels of detail, or on
different portions or an image. PhotoPlus provides standard Zoom and
Pan tools, plus the Navigator tab which combines the best of both—it
lets you quickly see different parts of the image and change the zoom
view.

To change the image scale, choose the Zoom tool from the
Standard toolbar. To zoom in, left-click on the image. To zoom in on a
particular region, drag with the tool to outline the region. To zoom out,
right-click on the image. The current zoom percentage appears in the
titlebar of the image window, next to the file name. By the way, if you
have a wheel mouse, you can simply spin the wheel to change the zoom
view!
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You can also set a specific zoom ratio by choosing Zoom In or Zoom Out 
from the View menu, then selecting a ratio from the submenu. To restore a
1:1 viewing ratio, choose Normal Viewing from the View menu.

To pan, Choose the Pan tool from the Standard toolbar and drag the
image to move it in relation to its window.

The Navigator tab lets you quickly see different parts of the image and
change the zoom view.

The red view box rectangle on the
preview window marks the area of the
image currently visible in the image
window. You can drag it around or click
the preview to change how the image is
framed in its window.

Click the “-” button to zoom out, “+” to zoom in, or drag the slider to
change the zoom view. The current view ratio appears at the right.

How to Get an Image into PhotoPlus
Before you can manipulate an image, you’ll need something to work
with! PhotoPlus can open images saved in a wide variety of industry-
standard file formats, and acquire images from your TWAIN-compliant
digital camera or scanner.

To get a saved image into PhotoPlus, you select Open Saved Work
from the Startup Wizard. The dialog displays image files you’ve recently
worked on; select a file or click the Browse button to locate other saved
files. As an alternative to using the Startup Wizard, you can select the
name of a recently opened file from the File menu or choose
File/Open… to display the Open dialog.

The Open dialog shows dimensions and bit depth (see Chapter 7)
information for each selected image. To display a thumbnail of the image,
check Show preview.

Another option is to use the PhotoPlus Image Browser, which
automatically creates thumbnails for images in the folders you open. To
launch the Image Browser, choose Image Browser... from the File menu
(or Browse Resource CD-ROM... to view content on the PhotoPlus
Resource CD). Select source folders and preview thumbnails until you
find the image you need. Right-click a thumbnail for information about
the source image.



24 Getting Started

As a shortcut from either Windows Explorer or the Image Browser, you
can simply drag and drop a file icon or preview thumbnail into
PhotoPlus. If you drop onto an open PhotoPlus image window, the
picture appears as a new layer. To open a new image window, drop onto
a blank region within the main window.

If your scanner or digital camera supports the industry-wide TWAIN
standard, you can bring pictures from these devices directly into
PhotoPlus. (To set up your TWAIN device for importing, see the
documentation supplied with the device for operating instructions.)

To begin scanning a picture into PhotoPlus, either select the Import 
From TWAIN option in the Startup Wizard, or, if the program is already
running, choose Import from the File menu and then select Acquire. (If
PhotoPlus is running but there’s no image window open, choose New
from the File menu to display the Startup Wizard.) If you have more than
one TWAIN-compatible device installed, you may be prompted to select
one as the source—or you can specify a different source by choosing
Import/Select Source from the File menu.

The acquisition software for the selected device will start up and display
its window, and you can then carry out the scan, possibly having made a
few basic adjustments. Note that the features available in image
acquisition software vary widely and are not under the control of
PhotoPlus. Usually, you will at least be able to adjust settings for the
image source (such as a color photograph, black and white photograph, or
color halftone) and the resolution at which the image is to be scanned.
For color theory and tips on scanning, see Chapter 7.

Whether you import the image via the Open dialog or the TWAIN
interface, it will appear in a new image window in PhotoPlus. Assuming
the image is not in the native PhotoPlus (.SPP) format, it will always have
just a single layer, called the Background layer (see “Seven Key
Concepts” earlier in the chapter). Chapter 5 will explore layers in
considerable detail; until then we’ll be focusing on techniques that work
perfectly well on one—or at most two—layers.
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Saving and Exporting Files
PhotoPlus can save images in its own .SPP format, or export them to any
standard format (again, see “Seven Key Concepts”).

 Use File/Save (or click the
Save button) to save images in
PhotoPlus’s own .SPP format.
Only .SPP images preserve
information such as multiple
layers, masks, or image map data
that would be lost in conversion
to another graphic format.

Use File/Save As… to save the image as an .SPP file under a different
path or name. You can store files anywhere on your system. It’s a good
idea to group your images, for example into project-oriented or thematic
folders.

Suppose you’ve opened a .BMP or .JPG file, done some editing (without
adding layers), and now wish to save it back to its original format. In this
case, you can use the File/Save Original or File/Save Original As... 
commands. Using the former will overwrite the original file—so be sure
that’s what you want to do.

In many situations, you’ll want to save a file to one of the standard
graphics formats. In PhotoPlus, this is known as exporting. You can use
the Export Optimizer to preview image quality before at various settings
before going ahead with the export.

The File menu offers two ways of
accessing the Optimizer. Either choose
File/Export Optimizer... to display it
directly, or choose File/Export... and
then click the Optimize button in the
dialog. The Export dialog itself is a
standard file dialog where you can
specify the path, name, and format for
the image file.

The Export Optimizer consists of a left-hand preview display and a right-
hand settings region, with additional buttons along the left of the dialog.
In animation mode, there’s an extra tab for changing output settings.
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To display a different portion of the image, drag the image in the preview
pane. To change the display scale, click the Zoom In or Zoom Out
buttons at the lower left.

To adjust the preview display, click one of the View buttons at the lower
left to select Single, Double, or Quad display. The illustration above
shows Double view. The multi-pane (Double and Quad) settings let you
compare different export settings for one or more file formats. Just click
one of the display panes to select it as the active pane, then use the
Options panel at the right to choose an export format and specific
settings. Each time you make a new choice, the active pane updates to
show the effect of filtering using the new settings, as well as the
estimated file size!

When you’ve picked the optimum export settings, click the dialog’s
Export or OK button to proceed to the Export dialog.

For details on image file formats and optimization, see Chapter 7.
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Printing
Printing is controlled from the Print dialog, which you can access by
choosing Print… from the File menu, clicking the Print button on the
Standard toolbar, or pressing Ctrl+P.

Choose the printer to use from the drop-down list. If necessary, click the
Properties... button to set up the printer for the correct page size, etc. It’s
very important to set up your printer correctly to get the best results.
Click the Options... button if you need to set special print options such as
scaling, tiling, or CMYK color separations. (The various print options are
detailed in Chapter 7.)

After setting the printer properties and the print options, click on OK in
the main print dialog to send the image to the printer. Depending on the
size and complexity of the image, and the printer you’re using, it may
take several minutes before the printed page emerges.

Getting Help
The PhotoPlus online help system is designed to work for you. Whatever
your background, you’ll find it easy to navigate.

♦ To begin learning about PhotoPlus tools and menus, just move the
mouse pointer around the screen. Watch the HintLine at the lower
right for capsule descriptions of each feature. Event Tips pop up as
you try new tools and actions.

♦ For help on interface elements like toolbars and tab windows, click
the Help button on the top toolbar, then click on an element.

♦ For help on dialog boxes, click their internal Help button.

Several Help menu choices take you to key features of online help:
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♦ Choose PhotoPlus Help to display the main help menu screen,
displaying the table of contents and Visual Reference. Click the
Index button to view an alphabetical list of terms and topics.

♦ Choose Effects Gallery to display a visual sampler of color
adjustments, special effects, and blend modes—cross-referenced to
help topics (see Chapter 3 for more).

Once inside online help, use the Visual Reference to explore elements of
the interface, or choose How To topics from the table of contents for a
step-by-step approach—whichever you prefer. The Previous and Next 
buttons let you browse adjacent topics, while the topic list keeps your
place for you. Extensive cross-references make sure all the information is
interlinked.

If you’ve purchased the PhotoPlus 8.0 Resource CD-ROM, you can
choose View PhotoPlus Tutorials to access a set of illustrated, step-by-
step mini-lessons. Stored in HTML format, the tutorials supplement the
Companion’s hands-on exercises to let you explore features in more
depth. Check at the end of each Companion chapter for a handy summary
of relevant tutorials. And be sure to visit the Serif Web site regularly to
view the latest tips and tutorials!
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This chapter will focus on ways of manipulating existing pictures,
especially photos. We’ll begin with a Hands-on Project using the “cat”
image you briefly opened in the previous chapter. Note that all of the
techniques described here can also be applied to images created from
scratch, and to animations.

There are many reasons why you might want to manipulate a photo,
including:

♦ Cleaning up an old, damaged photo

♦ Removing an unwanted item or slogan from the background

♦ Preparing an image for printing, use on the World Wide Web, or in
another package

If you agree that it’s time to do something about that smug-looking cat
from Chapter 2, here’s a Hands-on Project that provides an introduction
to manipulating images. Remember, the bullet checkboxes denote the
actual steps you should complete; anything else is optional.

HANDS ON: Captioning a Cat
� Open CAT.JPG in the PhotoPlus PROJECTS folder, if it’s not already

open. (See the section “Starting PhotoPlus” in Chapter 2.)

Cropping the image
Cropping is one of the easiest ways to improve the appearance of a
photograph—by creating a more pleasing composition of its main
elements. In this particular photo, there’s just one main element, and it
fills the whole image! However, there are a couple of problems with
leaving the image uncropped. One is the rather boring curtain in the
background; the other is the large blurry tail in front. So let’s crop away
everything except the cat’s face.

PhotoPlus offers two basic ways of cropping an image. You can either
select a region of pixels, using any of the various selection tools, and then
use the Image/Crop to Selection command. We’ll cover this method
later in the chapter. If you’re cropping to a rectangular shape its generally
easier to use the Crop tool.
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� Choose the Crop tool from the Tools
toolbar and drag out a crop selection
around the cat’s head, as in the illustration.
Start at one corner and drag to the other.
Once you release the mouse button, you
can adjust the selection rectangle by
dragging its edges or corners, or from the
center to move it.

� Once you’ve selected the correct area,
double-click within the selection rectangle
to complete the cropping.

By the way, if you make a mistake, don’t worry. Most actions in
PhotoPlus can be undone using Undo from the Edit menu, the Undo
button on the Standard toolbar, or the keyboard shortcut Ctrl+Z. You can
even undo an “undo”—use Redo on the Edit menu, the Standard toolbar,
or with Ctrl+Y. (The File/Preferences... dialog lets you set options for
the Undo function.) Or you can use the Undo History tab to review
recent actions and jump back more than one step at a time.

Adjusting brightness and contrast
You may have noticed that this image is a little dark. No problem. We’ll
use one of the PhotoPlus image adjustment filters to improve it.

� Choose Adjust>Brightness/Contrast… from the Image menu to
open the Brightness and Contrast Filter dialog.

� Experiment with the Brightness and Contrast sliders. Each time you
change a slider setting, the image updates. Alternatively, you can
type values directly into the fields at the right.

Although you may not achieve perfection with just the
Brightness/Contrast adjustment, try to obtain solid “bottom” and “top”
(shadow and highlight) regions without obscuring details or washing out
the image. The Brightness slider tends to move all the tones in the image
one way or the other; Contrast compresses or expands the spread between
bottom and top. Try the values shown—but remember that monitor
settings and room lighting can make a difference.
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� When the picture looks good, click OK. (If you click Cancel, the
photo returns to its previous state.)

� At this point, you may wish to save the picture as a PhotoPlus (.SPP)
file using File/Save….

Adding a caption
Finally, we’ll venture into uncharted territory. Adding a caption to the
photo is easy, but it will introduce several new operations: choosing a
color, using the Text tool, and working with more than one layer. Don’t
worry—it will be a very mild introduction!

� Locate the Color tab, which is probably
still open at the right side of the screen—
but if it’s hidden, check its item on the
View menu to display it. Click the tab so it
comes to the front and you can see all of it.

The Color tab includes (among other things) two
color swatches that show the current foreground
and background color (another of those “Key Concepts”), and a spectrum
box that lets you change them.

� Move the “dropper” cursor over the spectrum box and a preview
swatch (as shown in the illustration) will appear, showing the exact
color under the cursor. Find a very light color that you like, and left-
click. You’ll see the foreground swatch update. If you want to
choose a different color, move the cursor and click again.
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� Now choose the Text tool from the Tools toolbar. Notice there
are two text tools on the flyout. Pick the first one, which is for solid
text (the other is for creating selections in the shape of text).

� Once your cursor has changed to an “A,” click it on the picture in the
approximate position where you want the text to be. This opens the
Add Text window.

� Type the caption text (on two lines, if you’re using our example) and
choose a font, pointsize, and style (we used Arial 14pt Bold).

Note that the formatting is applied to all the text in the window (no need
to select it first), and that the text is black (for visibility) rather than the
foreground color at this point. The dialog also has an Adjust Color
button—but let’s leave that for later.

� Click OK to insert the caption.

The text appears (in the foreground color) on a new text layer above the
Background layer that has the photo. The text layer is now the active
layer. Because it’s on a separate layer, the text is editable and can be
repositioned independently of any other image layers. (Chapter 4 will
have more on working with text.)
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� Choose the Move tool from
the Tools toolbar and drag the text
around until it is in the right
position on the image.

Finally, save the modified image again
and/or export it to another format,
such as .BMP or .JPG. Since exporting
“flattens” the image into a single
layer, you’ll probably want to retain
an .SPP image with the layers intact,
in case you decide to do some more
editing later.

Making Selections
Before you can apply effects or filters, or copy parts of a picture to the
Clipboard, you must define an active selection area.

Selection options
In the example just completed, you adjusted brightness and contrast in the
image as a whole, and dragged an entire text layer around. Many times,
however, you’ll want to select just a subset of the image (or layer) to
work on. Selecting, you may recall, was one of the “Key Concepts”
presented in Chapter 2. Understanding what you can do with selections
opens up exciting creative possibilities.

Whenever there’s a selection, certain tools and commands operate only
on the pixels inside the selection—as opposed to a condition where
nothing is selected, in which case those functions generally affect the
entire active layer. For example, when there’s a selection, the brush tools
only work inside the selection; the color simply doesn’t affect outside
pixels. If you apply an adjustment or special effect from the Image or
Effects menus, it only affects the selected region.

Clicking a layer’s name on the Layers tab makes it the active layer. To
select the whole active layer, choose Select All from the Select menu or
press Ctrl+A. To select just opaque pixels, Ctrl-click the layer thumbnail.

PhotoPlus offers a very wide range of selection methods, and a variety of
commands for modifying the extent or properties of the selected pixels.
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The standard selection tools are located on the Standard 
Selection Tools flyout on the Tools toolbar. There you can choose from
the Rectangle, Ellipse, Freehand, Polygon, or Magnetic selection tools.

To select a rectangular or elliptical area, select the Rectangle or
Ellipse tool from the flyout and drag to define a region on the image.

Rectangle / Square Ellipse / Circle

The selected region is bounded by a broken line or marquee, and the
cursor over the selection changes to the Move Marquee cursor, which lets
you reposition just the marquee as needed without affecting the
underlying pixels.

Holding down the Ctrl key during dragging constrains the selection shape
to either a square or a circle.

To select a freehand (irregular) area, select the Freehand selection
tool and just drag to draw around the area to be selected, making a closed
area.

Or use the Polygon selection tool to draw a series of line segments
(double-click to close the polygon).

Freehand Polygon

The Adjustable Selection Tools flyout, a unique
PhotoPlus feature, offers 24 different variable
selection shapes, including pie, star, arrow, heart,
spiral, wave, and so on.

Here’s how the adjustable selection tools work.
We’ll use the regular polygon selection shape as

an example. Choose a tool from the flyout and drag out a shape on the
image. You can hold down the Shift key to constrain the selection’s
aspect ratio.
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The regular polygon appears as a blue outline with
two slider tracks bounding it. Each of the slider
tracks has a square handle, and when you move
the cursor on to the handle it will change to a
small + sign. As you drag the sliders, the shape’s
properties change. In the case of the polygon, one
slider varies the number of sides, while the other rotates the shape. As
with standard selections, you can move the whole selection around by
dragging from its center.

Once you’re satisfied with the selection, double-click in the center (just
as with the Crop tool or Magnetic selection tool) to complete the
marquee.

TheMagnetic Selection tool makes it
easy to isolate part of an image where there’s
already a bit of an edge showing. You simply
trace around the edge, and PhotoPlus snaps
the selection marquee to the nearest dramatic
color change. Click once on the image to
place a starting node along an edge. With the
mouse button up, trace along the edge; the
marquee line follows the nearest edge. At regular distances, nodes
automatically appear along the line. Only the portion of the line beyond
the last node remains adjustable.

You can add a node manually (for example, at a corner), by clicking
once, or “back up” by pressing Delete to undo recent nodes one at a time.
To close the selection region, double-click or click again on the starting
node. On the Tool Properties tab, you can adjust the tool’s Frequency
(distance between automatic nodes) and Contrast (edge sensitivity) for
best results. As a shortcut, press the up and down arrow keys (or use your
mouse’s spinwheel) to adjust the contrast setting on the fly.

If you’re trying to lift a region away from its background and find the
Magnetic selection tool still too laborious, try the Edit menu’s Extract...
command. This lets you mark the edge contour rapidly using a broad
brush, and then applies edge-detection within the swath you’ve marked.
Note that Extract directly affects the layer or selection—pixels outside
the detected edge vanish to transparency, while interior pixels are
preserved. (See online help for details.)
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Using the Color Selection tool, you can select a region based on the
color similarity of adjacent pixels.

To make a selection in this way, choose the tool from the Tools toolbar
and then click on a starting pixel. This selects the pixel you clicked, and
any adjacent pixels that are similar in color, as measured by the tolerance
value shown on the Tool Properties tab. You can raise or lower the
tolerance setting to include more or fewer pixels.

PhotoPlus also offers a Text Selection tool that lets you create a text-
shaped selection region and vary its size or font (see the next chapter).

Modifying the selection
Once you’ve used a selection tool to select a region, you can carry out a
number of additional steps to fine-tune the selection before you actually
apply an effect or manipulation to the selected pixels.

Any time you’re using one of the selection tools, the cursor over a
selected region changes to the Move Marquee cursor, which lets you drag
the marquee outline to reposition it. In this case you’re only moving the
selection outline—not the image content inside it. You’d use the Move
tool (see below) to drag the selection plus its image content.

If the selection you’ve made isn’t quite the right shape, or doesn’t quite
include all the necessary pixels (or perhaps includes a few too many), you
can continue to use the selection tools to add to, or subtract from, the
selected region. To add to the existing selection, drag with the selection
tool while holding down the Shift key. To subtract, drag while holding
down the Alt key. Pressing the Ctrl key changes the tool temporarily to
the Move tool (see below), so you can move the selection’s content.

The Tool Properties tab includes four combination buttons (
Standard, Add, Subtract, and Intersect) that determine the
effect of each new operation with a selection tool. You may find this
easier than using the keyboard shortcuts, and the Intersect option is
unique. Starting with a standard square selection, here’s what a second
selection operation might produce with the other combination settings:

Standard Add Subtract Intersect
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TheModify item on the Select menu provides a submenu with several
functions that can save you the trouble of hand-drawing to change the
selection boundaries. Choose Contract... to shrink the borders of the
selection, or Expand... to extend its borders. Border... creates a new
selection as a “frame” of a specified pixel width around the current
selection. If the selected area has ragged edges or discontinuous regions
(for example, if you’ve just used the Color Selection tool), you can use
the Smooth... command to even them out.

Grow and Similar both expand the selection by seeking out pixels close
(in color terms) to those in the current selection. Grow only adds pixels
adjacent to the current selection, while Similar extends the selection to
any similar pixels in the active layer. Both of these use the current
tolerance value entered for the Color Selection tool (see above).

To remove the current selection, choose Deselect from the Select menu,
or use the keyboard shortcut Ctrl+D.

The Invert command on the Select menu (shortcut Ctrl+Shift+I) selects
the portion of the active layer outside the current selection. Unselected
pixels become selected, and vice versa.

Variable selections
Just as grayscale is more than black-and-white, a selection can be more
complex than an all-or-nothing proposition. Within the
selected/marqueed region, individual pixels can have varying degrees of
“selectedness.”

Anti-aliasing and feathering are properties of the various selection tools
that can help you achieve softer edges and smoother blending of elements
that are being combined in the image. You can turn either option on or off
for the Standard and Adjustable Selection tools, using the check boxes on
the Tools Properties tab. Anti-aliasing makes the selection’s edge pixels
semi-transparent, while feathering reduces the sharpness of a selection’s
edges not by varying transparency, but by partially selecting edge pixels.
If you lay down paint on a feathered selection, the paint will actually be
less intense around the edges.

You can apply feathering “after the fact” to an existing selection (but
before applying any editing changes) using the Select menu’s
Modify>Feather... command.Modify>Threshold converts a feathered,
soft-edged selection into a hard-edged selection. As with feathering, you
won’t see an immediate effect on the image, but painting and other
editing operations will work differently inside the selection.
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Paint to Select mode is a convenient way to achieve varying degrees of
selectedness on a layer. Using the standard painting and editing tools in
this mode, you can create a selection from scratch or modify an existing
selection. Check Paint to Select on the Select menu and the image view
switches to show fully selected regions masked in red and semi-selected
regions in pink (deselected regions are unmasked). This view shows
“selectedness” much more clearly than the standard marquee mode, so
it’s also a good way to preview or check a complex selection. Now you
can paint or use other manipulations on the temporary mask to directly
modify the selection according to the lightness of the colors you apply.
Painting in white adds to the selection; black subtracts from it; gray
creates partial selection.

In the illustration below, (A) depicts the incomplete result of using the
Magnetic Selection tool on a white flower. In Paint to Select mode (B)
the selected regions appear as red (gray here) and we are busy filling in
the selected regions with a white brush. (C) shows the completely filled-
in flower and (D) the fully selected result.

A B C D

Once you have selected precisely the pixels you want to work on (as
covered so far in this chapter), the question arises: what can you do with
the selection—or technically speaking, with the pixels you’ve outlined?
The rest of the chapter will survey the many possible manipulations you
can perform.

Using the Move Tool

TheMove tool (unlike the Move Marquee cursor associated with
the selection tools) is for pushing actual pixels around. With it, you can
drag the content of a selection from one place to another, rather than just
moving the selection outline. To use it, simply click on the selection and
drag to the new location. The selected part of the image moves also.
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If nothing is selected, dragging with the Move tool moves the entire
active layer. (Or, if the Move tool’s Automatically Select Layer
property is selected, the tool intelligently moves to the first visible layer.)
Moving image content on the Background layer exposes a “hole” that
appears in the current background color; on standard layers, the exposed
region is transparent.

To duplicate the contents of the selection on the active layer, press the Alt
key and click, then drag with the Move tool.

As a shortcut if you’re working with any one of the selection tools, you
can press the Ctrl key to switch temporarily to the Move tool. Press
Ctrl+Alt to duplicate. Release the key(s) to revert to the selection tool.

Cut, Copy, Paste, Delete
These operations work pretty much as you’d expect. You can use the
buttons on the Standard toolbar, choose commands from the Edit menu,
or use conventional keyboard shortcuts.

As with the Move tool, “holes” appear as either the current background
color or transparent, depending which layer you’re working on. Also
keep in mind the handy Alt+Move tool operation (above) for quickly
duplicating selected pixels.

When pasting from the Clipboard, PhotoPlus offers several options. The
standard paste (Ctrl+V) operation creates a new, untitled image window.
You can use other Edit menu choices to paste the Clipboard contents as a
new layer (Ctrl+L), or centered into the current selection (Shift+Ctrl+L). The
Into Selection option is useful if you’re pasting from one layer to another.
Because the selection marquee “follows” you to the new layer, you can use
it to keep the pasted contents in registration with the previous layer.

Cropping
Cropping is the electronic equivalent of taking a pair of scissors to a
photograph, except of course with a pair of scissors there is no second
chance! Cropping deletes all of the pixels outside the crop selection area,
and then resizes the image canvas so that only the area inside the crop
selection remains.

If you tried the captioning project earlier in the chapter, you’ve
already used the Crop tool to reduce an image to a regular, rectangular
area. Just select the Crop tool from the Tools toolbar and drag out a
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rectangular crop selection area on the image. (Hold down the Ctrl key
while dragging to constrain the selection to a square.) Adjust the selection
rectangle as needed, then double-click to complete cropping.

You can also crop an image to any selection region, no matter what
shape, as defined with one of the selection tools (see above).

Make a selection using one of the selection tools and then choose Crop 
to Selection from the Image menu. For example, here’s cropping applied
to a marquee drawn with the Freehand Selection tool:

PhotoPlus always crops to a rectangular image. If the selection region is
non-rectangular, the left-over surrounding region will be either
transparent (on a standard layer) or the background color (on the
Background layer).

Tip: To convert the Background layer to a standard layer, right-click
Background on the Layers tab and choose Promote to Layer. Now
operations on the layer’s content (such as moving, cutting, or irregular
cropping) will leave transparent “holes.”

Flipping, Rotating, and Deforming
Flipping and rotating are standard manipulations that you can carry out
on the whole image, the active layer, or just on a selection.

To flip, choose either Flip Horizontally or Flip Vertically from the
Image menu, then select Image, Layer, or Selection from the submenu.
If you flip an image horizontally, be careful not to accidentally reverse
things like text, numbers, and so on.
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To rotate, choose Rotate… from the Image menu to open the Rotate
dialog. Set the rotation angle (90, 180, or 270 degrees, or enter a custom
angle) and the direction (clockwise or counter-clockwise). Select Image,
Layer, or Selection and click OK.

The image will rotate about the center point.

Original image 15° counter-clockwise 10° clockwise

The Deform tool is a “Jack of all trades” that lets you move, scale,
rotate, or skew a selection or layer. Try it on a text
layer for unique results! Start by making a selection if
desired, then choose the tool. A rectangle appears with
handles at its corners and edges, and a fixed point
(initially in the center of the region). If there’s no
selection, the rectangle includes the whole active
layer.

The tool’s action depends on the exact position of the mouse pointer. As
you move the pointer around the enclosed region, the cursor changes as
shown below to indicate which action is possible.

To move the region without any deformation, drag from its
neutral midsection. This action works just like the Move tool.

To reshape the region, drag from an edge or corner handle. A
variety of options are available when you drag from a corner

(watch the HintLine for tips). You can resize in two dimensions or
relative to the fixed point, either with or without a constant aspect ratio.
In addition, you can get skew or perspective effects that move either one
corner by itself, or two adjacent corners!

To rotate the region about the fixed point, drag from just
outside a corner. To constrain rotation in 15-degree steps, press
the Shift key after you’ve begun rotation, and hold it down until

after you release the mouse button.
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To reposition the fixed point, move the cursor to the exact
center until a small target appears, then drag. The fixed point can

be moved anywhere—even outside the deformation region.

HANDS ON: Deforming text
To get a feel for the versatility of the Deform tool, let’s try a short
project.

� To begin, choose New from the File menu and (on the Startup
Wizard) click Create New Picture.

� In the New Image dialog, set the image dimensions to 500x500 or so.
The background type should be set to White.

� Click OK, and the new image window opens. The image initially has
a single Background layer.

� Now choose the Text tool and click in the image to open the Add
Text window. Type some text, set it large (around 24pt), and click
OK. (You’ve done this before in the captioning project.) The new
text appears on a separate text layer.

� Choose the Deform tool, which automatically grabs the text on the
layer.

� Move the cursor near a corner handle until you it changes to a
double-headed arrow. Then drag to resize the letters either vertically
or horizontally.

� Hold down the Shift key and drag from a corner to resize in both
dimensions at the same time.
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� Hold down the Ctrl key over a corner handle. Continue to hold down
the Ctrl key while dragging to skew the object.

� Move the cursor outside one corner of the text and it will change to a
curved arrow. Try dragging to rotate the text, and holding down the
Shift key for constrained rotation.

� Press Shift+Ctrl+Alt while dragging from a corner for a perspective
effect. Note that you can still apply layer effects, fills, and other
manipulations to deformed image content. And once you have
rotated or deformed text, you can still edit it as long as it’s on a text
layer!

Using Mesh Warp

TheMesh Warp tool works like the Deform tool (see above)
outfitted with complex curves. It lets you define a flexible grid of points
and lines that you can drag to distort an image, or part of an image (or
layer). You can edit the mesh to vary its curvature, and even custom-
design a mesh to match a particular image’s geometry, for more precise
control of the warp effect.

When you first select the tool, a simple rectangular mesh appears over the
image, with 9 nodes: one at each corner, one at the center, and one at the
midpoint of each edge. Straight lines connect adjacent nodes. The Mesh
toolbar also appears.
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These “straight” line segments are actually bendable curves. When you
alter the contours of the mesh and distort the initial rectangular grid, the
underlying image deforms accordingly. To change the mesh, you simply
move nodes, handles, or connecting lines; add or subtract nodes as
needed; and/or edit nodes to change the curvature of adjoining lines.

To select a mesh node, click it. (Shift-click or drag a marquee to select
multiple nodes.) One or more attractor handles appear on the selected
node(s) and on any adjacent nodes.

To warp the mesh, drag any mesh node or line segment, or drag a node’s
attractor handles. The image responds immediately as the mesh is
warped.

To add a new node, double-click on a line segment or click the
Add Node button on the Mesh toolbar.

To delete nodes, select them and press Delete, or click the Delete 
Node button.

The special Deform Mesh tool makes it easy to move, scale, skew,
or rotate a portion of the mesh about a fixed point. It works just like the
standard Deform tool (described above) on multiple nodes.

The bendability of line segments depends on the type of nodes at either
end. You can change a node from one type to another simply by selecting
it and using the Mesh toolbar buttons:
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Sharp means that the curves on either side of the node are
completely independent, so the contours can be adjusted separately.

Smooth means that the slope of the curve is the same on both sides
of the node, but the depth of the contours on either side can differ.

Symmetric nodes join curves with the same slope and depth on both
sides of the node.

See PhotoPlus online help for further details on Mesh Warp, including
Setup mode, which lets you create an initial custom mesh that conforms
to the underlying image, for more precise shaping of image contours.

Adjusting Image Values
PhotoPlus provides a number of different adjustment filters that you can
apply to a selection or to a standard layer. Typically, these adjustments
are used to correct deficiencies in the original image.You can apply them
either directly, via the Image/Adjust menu, or (in most cases) by using
an adjustment layer.

Each of the adjustment options works in a similar way. Alter the values
by dragging on a slider, moving it to the left to decrease the value, or the
right to increase the value, or enter a value in the field at the right of the
slider.

Tip: Instead of dragging the slider with the mouse, you can click on it
and then jog it with the left or right cursor arrow keys.

Here’s a quick summary of the PhotoPlus image adjustments.

♦ Levels presents a histogram plot of lightness (luminance) values in
the image, and you can adjust the tonal range by shifting dark, light,
and gamma values.

♦ Curves displays lightness (luminance) values in the image using a
line graph, and lets you adjust points along the curve to fine-tune the
tonal range.

♦ Color Balance lets you adjust color and tonal balance for general
color correction in the image.

♦ Brightness/Contrast: Brightness refers to overall lightness or
darkness, while contrast describes the tonal range, or spread
between lightest and darkest values.
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♦ Hue/Saturation/Lightness: Hue refers to the color’s tint—what
most of us think of as rainbow or spectrum colors with name
associations, like “blue” or “magenta.” Saturation describes the
color’s purity—a totally unsaturated image has only grays.
Lightness is what we intuitively understand as relative darkness or
lightness—ranging from full black at one end to full white at the
other.

♦ Replace Color lets you “tag” one or more ranges of the full color
spectrum that requre adjustment in the image, then apply variations
in hue, saturation, and/or brightness to just those color regions.

♦ Selective Color is a CMYK printing adjustment that lets you you
add or subtract a certain percentage of cyan, magenta, yellow, and/or
black ink.

♦ Channel Mixer lets you modify a color channel using a mix of the
current color channels.

♦ Gradient Map lets you remap grayscale (lightness) information in
the image to a selected gradient. The function replaces pixels of a
given lightness in the original image with the corresponding color
value from the gradient spectrum.

♦ Threshold creates a monochromatic (black and white) rendering.
You can set the threshold, that is the lightness or gray value above
which colors are inverted.

♦ Equalization evenly distributes the lightness levels between existing
bottom (darkest) and top (lightest) values.

♦ Stretch establishes new bottom and top values and spreads out the
existing lightness levels between them.

♦ Negative Image inverts the colors, giving the effect of a
photographic negative.

♦ Grayscale reduces a color picture to 256 shades of gray.

♦ Posterize produces a special effect by reducing the image to a
limited number of colors.

For an overview of image adjustments, take a look at the Effects Gallery,
a component of PhotoPlus online help. It’s a great way to get an overview
of what Adjustments and Effects do. Choose Effects Gallery... from the
Help menu, or click Effects Gallery on the main help Contents menu.
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The Effects Gallery provides
illustrations of all the Image and
Effects menu adjustments and effects,
plus the various Blend Modes (used for
paint tools and layers, and discussed
later in the Companion). For each
category, there’s a list of names.
Clicking on the name shown in red text
displays an example, and then clicking
the name again (now in green text)
displays the corresponding help topic
in an adjacent window. This way you
can browse the illustrations and read about them at the same time.

Click on the View Original button above each illustration to view the
image as it appeared before the filter was applied. Click on the Apply 
Effect button to see the after state.

Adjustment layers
Adjustment layers let you introduce any number of effects
experimentally. Instead of altering the image or layer directly, you allow
yourself the option of revisiting the settings for a given adjustment as
often as needed, while continuing to edit the image in other ways. If you
later decide you don’t even need an effect, you can simply remove it!

To create an adjustment layer, click the New Adjustment Layer
button on the Layers tab (or choose the item from the Layers menu) and
select the name of the adjustment to be applied; most of those listed
above are available. Then, just as if you’d selected the same effect from
the Image menu, you use a dialog to pick the settings to be applied. The
image responds as if you’d used the Image menu—but if you look over
on the Layers tab, you’ll see a new adjustment layer has been inserted
above the active layer.

Unlike the other layer types (as described in Chapter 5), adjustment
layers don’t store content in the form of bitmap images, text, or shapes.
Rather, each adjustment layer applies one effect to content on the layers
below it. You can even combine multiple effects by stacking several
adjustment layers.
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To change the specific settings for an effect, simply double-click the
adjustment layer’s name in the list and then use the dialog again. Right-
click to access conventional layer Properties such as name and blend
mode. You can drag an adjustment layer up or down within the list to
determine exactly which other layers are below and therefore affected by
it. To see how the image looks without the effect, click the Hide Layer
button next to the adjustment layer’s name. If you decide to permanently
remove the effect, you can delete the layer.

Applying Effect Filters
The PhotoPlus Effects menu includes a number of commands that apply
special effects to the active layer or selection. As with the image
adjustment filters you can use these effects to improve the image—for
example Unsharp Mask for crisper detail,Median to remove digital
camera artifacts, or Fix Red Eye to make baby look human—but more
often the emphasis here is on the wild and wacky (or perhaps we should
say “creative”) possibilities. If you’re creating animations, you can turn
most of these effects into animated transitions (see Chapter 6).

PhotoPlus lets you place industry-
standard Photoshop plug-in filters in a
Plugins folder and access them from
the Effects menu. You can even
define your own custom filters (see
online help for details).

The Effects Gallery, as mentioned
earlier, includes examples of all the
special effects, cross-referenced to
explanatory text for each effect.

To access a group of effects, choose
Effects and select one of the

commands.

At the top of most of the dialogs there is a preview window that updates
as you adjust the sliders or enter new values. To see a different part of the
image, drag it with the hand cursor. Click the Zoom buttons to zoom in or
out.

Effects menu filters are not the only way to apply special effects. Several
PhotoPlus tools let you use brushes to warp, smudge, blur, or sharpen the
image locally. For details, see Chapter 4’s discussion of the Warp and
Retouch flyouts.
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Finally, we should mention the wide range of PhotoPlus 2D and 3D layer
effects, available on the Layers menu and as presets on the Instant Effects
tab. Unlike image adjustments and Effects menu manipulations, layer
effects don’t directly change image pixels—they work like mathematical
“lenses” that transform how a layer’s bitmap appears. Since the settings
are independent, you can adjust them ad infinitum until you get the result
you want! You’ll find detailed coverage of layer effects in Chapter 5.

Multiple effects
It’s quite possible to apply several effects to the same image, and,
depending on the order in which they are applied, to end up with a
different final result.

The original image Blurred by 20 Embossed by 70

Original Embossed by 70 Blurred by 20

HANDS ON: Photo-painting I
This fun project will apply a series of experimental manipulations that
make a photograph of a Paris street scene look more like an abstract
painting. In the following project you can give the Instant Artist effects a
try.

� Open the file FRANCE.JPG in the PhotoPlus PROJECTS folder.

� To reduce clutter, use the Crop tool to create a new composition as
shown in the illustration. This will let you see the results of each
filter more clearly.
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� Choose Adjust>Brightness and Contrast from the Image menu and,
in the dialog, increase the brightness by 17.

� Choose Blur>Gaussian Blur from the Effects menu and apply a
Gaussian Blur with a Radius of 5.

� Choose Adjust>Posterize… from the Image menu and apply a
posterize value of 13.

� Choose Adjust>Hue, Saturation, Lightness from the Image menu
and boost the saturation to 75.

� Choose Edge>Enhance from the Effects menu, then Blur>Blur 
More from the Effects menu. Et voilà!

If you try repeating this sequence using adjustment layers for the
brightness, posterize, and saturation steps, you’ll see that the edge
enhancement step, which produced such dramatic results before, is now
barely noticeable. That’s because it’s applied directly to the Background
layer, and so changes the actual pixels there before the adjustment layer
effects are figured in. It doesn’t matter that you inserted the adjustment
layers earlier: they are still just commands to post-process pixels they
find on the layers below. That’s a useful concept to keep in mind when
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you work with adjustment layers.

HANDS ON: Photo-painting II
Here we’ll start with the same source image and see what kind of results
we can achieve with the Instant Artist effects.

� Open FRANCE.JPG and again crop the image as shown below. This
time, use Image/Adjust>Brightness and Contrast and boost the
Brightness by 10 to improve the tonal range.

It’s generally a good idea to optimize the image and clean up any
scratches or noise before applying an Instant Artist effect.

� Choose Instant Artist from the Effects menu and select Paint and 
Ink in the list. You’ll see most of the image in the preview window.
To see a different part of the image, drag with the hand cursor. Click
the Zoom buttons to zoom in or out. This filter really does yield a
nice result instantly, without any additional tweaking! Click OK to
see the effect applied to the entire image. (Shown here: Level 5,
Paint Detail 69.)

Now let’s get a sense of how much variety is possible within a single
effect.

� Use Undo to remove the previously applied effect, and choose
Instant Artist again. This time select Pointillist and click the
Advanced button to reveal the full range of settings. Online
help includes detailed coverage of all the parameters, but here’s a
quick synopsis. Dot Size, amazingly enough, determines the size of
the dots. A lower Color Jitter setting yields a closer match between
the brush color and the original image. Weight and Length both
affect the brush strokes you see, while Curve determines how
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closely original edges in the picture are followed. Edge Blur reduces
image detail, while the Enhance setting restores detail by enhancing
edges. Depending on the settings, you can achieve snappier results,
for example, or more/less of a brushed effect. (Here we’ve used Dot
Size 3, Color Jitter 80, Weight 70, Blur 8.)

� Keep on experimenting with other Instant Artist effects! Some will
work better than others on this particular photo, so you might want to
try a different starting image, perhaps one of your own
photographs—for example, a portrait, still life, or landscape.

Instant Artist/Oil effect (Brush 6, Accuracy 75)



Manipulating Images 55

HANDS ON: Removing Red Eye
Fixing “red eye” in flash photos—the annoying effect which makes
people’s eyes glow like a zombie—is normally tedious and time-
consuming, but PhotoPlus makes it easy with a built-in filter.

We’ve included a sample file that’s ideal for demonstrating the red eye
fix.

� Open REDEYE.JPG in the
PhotoPlus PROJECTS folder.

� Choose Other/Fix Red Eye…
from the Effects menu to open the
dialog.

You work on one eye region at a time.

� Click the Select Area
button and then click on the pupil
of the left eye.

Immediately, a selection mask (circle)
appears around the designated region
and the current correction settings are
applied there.

The default settings are probably good, but if fine-tuning is needed,
adjust the sliders (or enter specific values) as the preview window
updates. Redness Tolerance (from Loose to Strict) controls how much
red is removed. Blur Amount (from Hard to Soft) expands the black area
to form a bigger pupil.

� When the left eye is fixed, repeat the procedure for the right eye, and
when you’re done, click OK. That’s all there is to it!
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HANDS ON: Antiquing a Photo
This sequence will show you how to make a new color photo look like an
old sepia-toned image. The approach here is a bit labor-intensive, but it
serves to introduce some new layer techniques—a preview of Chapter 5’s
in-depth coverage. (For colorizing images quickly, you might also try the
Hue/Saturation/Lightness or Channel Mixer adjustments.)

� Open the file HOUSE.JPG in the PhotoPlus PROJECTS folder.

� Choose Adjust>Brightness & Contrast… from the Image menu and
increase both the brightness and contrast by 10 to make the picture
look a bit faded.

� Next, add some grain to the
image by choosing
Noise/Add… from the Effects
menu. Increase the value to
about 15.

� Choose Adjust>Grayscale
from the Image menu to make
the photograph black and
white.

To create the sepia look, we will be adding a semi-transparent color layer
above the photo.

� Choose New Layer from the Layers menu. In the dialog, call the
new layer “Sepia” and set its Opacity to 40. Leave the Blend Mode at
Normal for the time being. Click OK and you’ll see the new layer’s
name appear on the Layers tab (although the image won’t look any
different).

� Using the Color tab, set the foreground color to be an orange hue
(suggested values: R=255, G=166, B=0).
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� Select the Flood Fill tool and click on the image to fill the
active layer (“Sepia”) with the foreground color. (The next chapter
will look at fills in more detail.)

Even though the Sepia layer is semi-transparent, its lightness tends to
wash out the darker details in the photograph. Here’s how changing the
layer’s blend mode can correct that condition.

� On the Layers tab, click the drop-down list (now set to “Normal”)
and choose “Multiply.” The result is a new way of combining the
Sepia layer’s pixels with those below. Multiply always produces a
darker value, so the bottom tones in the original picture are
preserved.

The last step is to add a simple frame.

� On the Color tab, define black as the background color, either by
right-clicking in the spectrum or clicking the background swatch and
setting its RGB value to “0,0,0.”

� Choose Canvas Size... from the Image
menu. Add 40 to each value shown in the
Width and Height boxes. Click the center
Anchor point so that the existing image will
be centered with respect to the edge pixels
being added. Click OK.

The result? A black border around the sepia-toned photo. If the results
don’t look quite right to you, feel free to retrace your steps using Undo,
and try new toning values, transparency, or canvas adjustments.
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Tutorial Resources
For more experience with the tools and techniques covered in this
chapter, we recommend these HTML-based tutorials on the PhotoPlus 8.0
Resource CD-ROM:

Try this tutorial... For practice with these tools and techniques...

Respray Replace Color filter, Blend Modes

Splash Adding color to a grayscale image

Canvas Median Cut, Edge Enhance image filters; Export
Optimizer

Meshing Around Mesh Warp tool

Friendly Nature Mesh Warp tool’s Deform Mesh function, Crop tool

Graduate Scheme Linear fill editing and applying a Gradient Map

Salvage Image filters including Blur, Twirl, Edge Enhance,
Mosaic, Negative Image



Working with Paint,
Shapes, and Text
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The previous chapter described a variety of ways of working with
existing images—especially photographs, and usually on a single layer.
Now it’s time to look at creating elements from scratch, using the range
of PhotoPlus paint and text tools. Perhaps you need to add text to a photo,
along the lines of Chapter 2’s “cat” Hands-on Project. Or perhaps you’re
starting out with a blank canvas and want to try some interesting graphic
shapes and color combinations for a logo or custom Web button.

Whatever your creative goals, all of the functions described in this
chapter can be applied to photographic images or images opened from
file as well as to new work!

Choosing Colors
At any given time, PhotoPlus allows you to work with any two colors—
called the foreground color and the background color. These are always
visible as two swatches on the Color tab. In this example, the foreground
color is set to black and the background color to white. (Don’t confuse
the “background color” with the “Background layer”—there’s absolutely
no connection!)

Here are some things to remember about how these colors are used:

♦ Cutting, deleting, or erasing an area on the Background layer exposes
the background color. On other layers, removing an
area exposes transparency.

♦ To swap foreground and background colors, click the
double arrow next to the Color tab swatches.



62 Working with Paint, Shapes, and Text

There are a several simple ways to set the foreground or background
color.

One is to use the Color Pickup tool on the Tools toolbar. Left-click
with the tool anywhere on an image to “pick up” the color at that point as
the new foreground color, and right-click to define a new background
color. As a shortcut if you’re working with one of the drawing tools
(paintbrush, line, etc.), you can press the Alt key to switch temporarily to
the Color Pickup tool. Release the key to switch back once you’ve left- or
right-clicked to make a color selection.

Another way is to use the Color tab. To quickly
select foreground or background color, move the
mouse pointer (dropper cursor) around the tab’s

Color Spectrum. As you do so, a preview swatch pops up showing the
color at the cursor position. Left-click in the spectrum to set a new
foreground color, and right-click to set a new background color. As a
shortcut for white, drag up and off the top of the spectrum; for black, drag
down and off.

Yet another method is to click either the foreground or the background
swatch (a white border around either box tells you it’s selected), then use
the sliders or enter numeric values in the boxes to define a specific color.
The selected swatch updates instantly.

Double-clicking either a foreground or background color swatch on the
Color tab brings up the more complex Adjust Color dialog, which lets
you define and store a set of custom colors interactively, using a color
wheel. See the “Choosing colors” topic in online help for details.

The Color tab also makes it possible to set the working color mode to
any one of the following: RGB (Red, Green, Blue); HSL (Hue,
Saturation, Lightness); CMYK (Cyan, Magenta, Yellow, Black); or
Grayscale. (For lots of useful terms and theory relating to color
definition and color modes, see Chapter 7.)

HANDS ON: Step into the Sandbox
Our approach in exploring the various painting and drawing tools is
going to be decidedly freeform! Rather than prescribe step-by-step
sequences, we’ll let you follow your own muse as you experiment with
each tool. As you read through the descriptions, watch for the checkbox
bullets that will offer suggestions. No one is expecting a masterpiece—
perhaps just some inspired doodling!
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� To begin the session, choose New from the File menu and (on the
Startup Wizard) click Create New Picture.

� In the New Image dialog, set the image dimensions large enough to
give yourself plenty of white space. 500x500 should be about right.
Leave the resolution at 96 pixels per inch (that’s standard screen
resolution). The background type should be set to White.

� Click OK, and the new image window opens. The image initially has
a single Background layer.

� Choose New... from the Layers menu, then click OK in the dialog.

You’ve just created a new standard (transparent) layer named Layer 1.
You’ll see its name on the Layers tab, above the Background layer. As
we move through the tools, you should try them out on both the
Background layer or the standard layer, to see the difference.

� To begin with, click “Background” on the Layers tab, so it becomes
the active layer for painting on.

Painting and Drawing
PhotoPlus’s basic tools for painting and drawing are located, like the
selection tools, on the Tools toolbar (initially at the left of the main
window).

If you wish to display the related online help topic, choose the
Context Help button and then click the Tools toolbar. (The same goes
for any tab or toolbar.)

Note that if there is currently a selection, the brush tool will only work
inside the selected region. If you try to paint over the edge of a selection,
the cursor will continue moving but the line will come to an abrupt halt at
the edge of the selection. Or if you’ve forgotten that there’s a selection
(perhaps you hid the marquee) and the brush doesn’t seem to work—
you’re probably just painting outside a selected region.
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Using the basic Paintbrush tool

The Paintbrush tool is used for freehand drawing. Successful
freehand drawing requires practice and a steady hand! You might find it
easier if you use a graphics tablet, rather than a mouse.

To paint a line using the Paintbrush tool, select it from the Tools toolbar.
When you move the Paintbrush tool over the image the cursor will
change into a paintbrush.

� Select the Paintbrush tool. Left-click and drag to draw a freehand
line. Release the mouse button, then repeat to draw more lines.

� If you don’t like what you drew, press Ctrl+Z to undo (but
remember, this is all experimental—the more paint you get on the
screen, the better!).

� Your lines appear in the currently selected foreground color. To paint
with the background color, click the arrow on the Color tab to switch
the two colors. Now might be a good time to try various techniques
for selecting different foreground and background colors, as
described earlier in the chapter.

Choosing and customizing brush tips
All of the paint tools work in conjunction with the Brush Tip and/or Tool
Properties tabs, so let’s see how they work with the basic Paintbrush tool.

Brush Tips determine the basic size and shape of the mark the brush tools
make on-screen. The lines you’ve drawn so far with the Paintbrush tool
may be thick or thin, depending which brush is currently selected.

� Display the Brush tip tab and note which tip is selected. Click a
different one. To draw a “pencil” line, choose a single-pixel brush.
(For straight lines, use a guide or the the Straight Outine tool, as
described below.)
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You’ll notice that some brushes have hard edges, while others appear
fuzzy, with soft edges. The hardness of a brush is expressed as a
percentage of its full diameter. If less than 100%, the brush has a soft
edge region within which the opacity of applied color falls off gradually.

� To see what this means, try using a medium-sized hard-edge brush,
and then switch to a soft-edge brush. You’ll note the difference
immediately.

To customize a brush tip’s properties, double-click it on the Brush Tip
tab (or right-click it and use the popup menu) to open the Brush Options
dialog. As you vary the controls, you can see the effect of each change in
the preview window. Note there are five brush properties in all. (See the
tab’s Visual Reference entry in online help for details.)

Right-clicking a brush tip’s square on the Brush Tip tab provides several
other choices, including deleting a brush tip, creating a new one, or
importing a Paint Shop Pro picture tube. To define a custom brush
shape—for example a textured brush or special shape—first select part of
the image to be used as a custom brush (for best results, use a solid white
background), then right-click on the tab choose Define.

Setting tool properties
The Tool Properties tab is really an
extension of each tool’s functionality. Use
it to customize the way each tool affects
pixels on the screen, and (if you’re using a
pressure-sensitive drawing tablet) how the
tool responds to pressure variations you
apply with the pen.

For the basic Paintbrush tool and most other creation tools, you can alter
the Blend Mode, Opacity, and number of Fade steps.
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♦ Opacity is basically the same concept as “transparency”—they’re
just different ends of the same scale (0% opaque is 100%
transparent). Thus a lower opacity value produces paint that’s more
transparent, with less effect on existing pixels on the layer—more of
the underlying paint “shows through.” A fully opaque stroke
completely replaces all pixels in its path.

♦ Fade simulates a realistic brush stroke, with less paint applied over a
longer stroke. The more steps, the longer the stroke takes to fade out.
For a continuous flow, with no fade-out, use a setting of 0.

♦ Blend Mode determines how the pixels the tool lays down interact
with pixels already on the layer. It can be a bit complicated, with
each mode comparing “old” and “new” pixels in terms of values like
hue, lightness, and so on—but see online help’s Effects Gallery for
illustrations, and Chapter 7 for color theory.

� Take a few moments to experiment with varying the opacity and fade
settings. With opacity, note how different settings affect the way the
foreground color gets painted over existing color.

� Click “Layer 1” in the Layers tab and try painting on the upper,
transparent layer. Using semi-transparent brush strokes, you’ll begin
to see how you can combine and overlap colors on different layers.

� If you’re feeling adventurous, try out some different blend modes—
but those are probably best left for more advanced explorations!

If you have a pressure-sensitive stylus, checking the Size box causes the
brush size to vary according to pressure. A light application of the pen
makes for a very thin brush stroke, and full pressure allows the brush size
to expand up to the defined size. (If your brush tip is defined as 35 pixels
wide, that’s how wide it would be at full pressure.) You can also turn on
the Opacity option so that faint pressure then correlates to a fainter brush
stroke.
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Using the Airbrush tool

Like the Paintbrush tool, the Airbrush tool is used for freehand
drawing in the foreground color, but it behaves like a spray-can. Holding
the tool over one spot with the left mouse button held down “sprays”
more paint.

The choices for Brush Tip and Tool Properties tab settings for the
Airbrush are the same as for the Paintbrush. Note that PhotoPlus
“remembers” your custom settings for each individual tool.

To paint a line using the Airbrush tool, select it from the Tools toolbar
and drag over the image area.

� Choose the Airbrush tool and experiment with it, noting how it
differs from the Paintbrush.

� Try airbrushing on both the Background and the standard
(transparent) layer while varying properties, particularly opacity.

Using the Picture Brush tool

The Picture Brush tool works like a custom
brush that sprays a series of predefined images at
regular intervals as you drag. The Brush Tip tab
lets you select from a variety of picture brushes in
different categories.

� Choose the Picture Brush tool and (on the
Brush Tip tab) pick a brush tip to try out.

� Click in various places on your canvas. Then
try dragging in a continuous line.

Note that the tool can be used either to “stamp” single images at specific
points—by clicking and releasing the mouse button each time, as in the letter
“S” at right—or to lay out a continuous stream of pictures as you drag along
a path. Either way, you can scale the size of the elements each brush
produces, and control their spacing and sequencing. To do so, select and then
right-click a brush name on the Brush Tip tab, and choose Brush Options.

The Spacing setting determines how closely the elements are packed
together when you draw continuously. At the minimum setting of 1%, the
brushed line resembles a tube of toothpaste! Higher settings increase the
separation between each element.
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The Order setting controls how the mini-images are laid down. Select
Sequentially to apply the original element sequence repetitively along
the line; Randomly to mix up the order of elements; or By Direction to
place elements according to the line’s local slope (in other words, the
direction of your stroke determines which sequence appears).

How does the Picture Brush work? Each Picture Brush tip has its own
stored master image where mini-images have been arranged in rows and
columns. The Rows and Columns settings tell the tool how to partition
each tip’s master image—so you should leave these values intact. With a
bit of forethought, it’s not difficult to lay out your own master images and
from them create custom Picture Brush tips. (For details, see online help.)

Using the Eraser tools
Sometimes the rubber end of the pencil can be just as important to an
artist as the pointed one. The three Eraser tools can replace an existing
color either with another color or with degrees of transparency. This
review of basic PhotoPlus painting and drawing techniques wouldn’t be
complete without considering how you can use these three tools—located
on the Eraser Tools flyout—to enhance an image.

The standard Eraser tool works very much like the Paintbrush, with
the same range of Brush Tip and Tool Properties tab options. But instead,
on the Background layer, erased pixels are replaced by (or mixed with)
the current background color. On other layers, they are “watered down”
by adding transparency.

� To erase, select the tool from the flyout and drag over the image
area. Try erasing and experiment with varying the Opacity setting on
the Tool Properties tab. You’ll see that erasing is by no means an all-
or-nothing proposition. Some wonderfully creative effects are
possible using a semi-transparent eraser to reduce the contribution of
existing pixels to the overall image.

� Again, switch between the Background and standard layers to
compare the results.
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The Background Eraser tool erases pixels that are similar to a
sampled reference color underlying the cursor cross-hair. Hence it’s
perfect for painting out unwanted background colors. For example, you
can use it to isolate objects or people photographed against a studio
backdrop. You can select either “Continual” sampling, which updates the
reference color as you drag, or “Once,” which retains the color sampled
at the first click point. The “Edge Detected” setting helps to prevent
erasure of similar pixels on the other side of the edge you’re tracing.
“Background Swatch” detects and erases the current background color.

The Flood Eraser tool fills a region with transparency, erasing
pixels similar to the color under the cursor when you first click. With
both the Flood and Eraser tools, you can select a “Contiguous” effect to
erase only pixels in the region around the initial sample point, or switch
to a discontigous effect to erase similar pixels anywhere in the image.

� Try both tools using different settings. Also, experiment with the
Background Eraser’s “Edge Detect” setting, which improves erasure
on one side of a contrasting edge or line.

� By now, you may be getting inspired to create something
“interesting” instead of just scribbling. Perhaps it’s time to get a
beverage, make a few phone calls, and while you’re at it (if you
haven’t already) save this masterpiece-in-progress. We’d suggest
SANDBOX.SPP.

Warping, Retouching, and Cloning
In this section we’ll look briefly at the three Warp tools (Elastic,
Thick/Thin, and Unwarp), the three Retouch tools (Smudge, Blur, and
Sharpen), and the Clone tool. These will be useful once you’ve
established the basic elements of an image—perhaps using multiple
layers—and are ready to begin removing defects, altering details, and
improving the overall image either creatively or technically.

Using the Warp tools
The three entries on the Warp Tools flyout work as a group. Two of the
tools shift pixels pixels that the brush passes over, while the third undoes
the effects of the other two. The actual amount of pixel displacement
depends on the direction of brush movement, the brush tip, and the Tool
Properties settings.
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The Elastic Warp tool shifts pixels in the direction of brush
motion, hence the appearance of pulling or elasticity.

The Thick/Thin Warp tool shifts pixels 90º to the right of the brush
direction, which has the effect of spreading or compressing edges along
the stroke.

Unlike the Retouch tools, the Warp tools result in little blending or
blurring. In fact, their effect is not easy to describe. The images below are
magnified views of the two tools in action. Using a hard brush with a
diameter of 19 pixels, we dragged straight across a grid of black, single-
pixel dots—in one case left to right, in another right to left.

Elastic

L to R

R to L

Thick/Thin

L to R

R to L

Notice the distinct trails left by the Elastic Warp brush; also note that
pixels below the end point of its brush stroke are unaffected. The
Thick/Thin Warp effect follows a “right hand rule”—displacing pixels to
the right of the drag trajectory. Creatively speaking, if you drag the
Thick/Thin tool clockwise, you’ll get a concave “pinch” effect, while
counter-clockwise motion results in a convex “punch” effect.

You should check out the Image Gallery’s before/after examples of these
effects—but even better, try them for yourself, using the image we’ve
recommended, or any picture with good detail and contrast.

� Open a suitable test image, such as SCORE.JPG in the Projects
folder, and experiment with the Warp tools.

The Unwarp tool quite simply lives up to its name. Drag the
Unwarp brush across a warped region to restore its unwarped state.
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Note that Unwarp only works as long as you’re still using the Warp tools.
Once you select some other tool that’s not on the Warp Tools flyout, in
effect your “warping session” is over. If you return to the flyout later, it’s
a new session: Unwarp will reset itself and forget any previous warping.
Similarly, PhotoPlus treats all your operations during one warping
session as a single, cumulative event; using the Undo command clears the
whole session. As a safety measure, you might occasionally switch to a
non-Warp tool in the midst of warping, just to record your work up to that
point as a separate event.

On the Tool Properties tab, the Opacity setting determines the degree of
warping or unwarping that takes place. The Density setting relates to how
carefully each tool calculates new pixel values while you’re moving the
brush, as opposed to using interpolation to speed things up. A higher
Density setting will produce better results on most systems, but try a
lower setting if brush movement appears jerky. However powerful your
system, it’s a good idea to click the Refine button when you’re done, to
update the image using fully recalculated pixel values.

Using the Retouch tools
The Retouch Tools flyout includes three comparatively simple brush
tools that are sure to come in handy at various stages of photo editing.
Again, you’ll find before/after illustrations in the Effects Gallery.

Smudging may sound silly, but the Smudge tool can be quite
useful for blending pixels the way an artist might hand-blend pastels.
Along with the Clone tool (see below), it’s useful for blending together
separate images in collage work, where seamless stitching is essential.

To use the tool, select it from the Tools toolbar and drag to pick up color
from the initial click point and “push” it in the direction of the brush
stroke. Short back-and-forth strokes work well to blend edges.

Smudge tool properties are the same as for the Paintbrush and Airbrush,
except that there’s no Fade setting.

� Using an image with multiple lines or sharp edges, try using the tool
to smear a line or edge outward, or create a mix of two colors (using
a semi-transparent setting). Experiment with the effects of both a
hard-edge and a soft-edge brush tip.
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� For best results when using extended strokes, set the brush tip’s
Spacing property to 1.

The Blur tool reduces contrast under the brush, softening edges
without smearing colors the way the Smudge tool would. To apply the
same effect to a selected region or the active layer, use the
Image/Blur>Blur... command.

The Sharpen tool has the opposite effect, increasing contrast under
the brush to accentuate the appearance of sharpness. Use the
Image/Other>Sharpen... command to sharpen an entire selection or
layer.

Using the Clone tool

The Clone tool is one of the most powerful weapons in the
electronic artist’s arsenal. Like the preceding
tools, it uses a brush, but it’s really like two
magic brushes locked together. While you trace or
“pick up” an original drawing with one brush, the
other draws (“puts down”) an exact duplicate
somewhere else. When retouching, for example, you can use the Clone
tool to brush away skin blemishes by cloning some “good skin” over
them, or remove an unwanted object from an image by extending some
foliage to cover it. Or you can easily clone a sheep...

To clone a region, select the tool from the Tools toolbar and set its
properties. Then Shift-click where you want to begin copying; we’ll call
this the “pickup point.” Click and begin dragging somewhere else—even
in another image window—where you want to begin placing the copied
pixels; let’s term this the “putdown point.” You’ll see a crosshair cursor
appear back at the pickup point. As you drag, pixels from the pickup
region are cloned in the putdown region by the tool’s brush tip. The
crosshair and brush tip cursors move in sync. The result? A perfect copy.
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� You really should try this firsthand. Choose the Clone tool and
(working on either layer), follow the procedures just described.
You’ll see the best results if you clone a region that’s well painted
over, rather than just a thin line. Remember: Shift-click to pick up,
click and drag to put down. Watch the cursors and what’s happening
will be evident.

In addition to the usual settings, the Clone tool has an Aligned option on
the Tool Properties tab. This affects what happens if you use more than
one brush stroke. There are two possibilities when you click to begin
another stroke, as seen in this example.

Aligned: The pickup point changes, staying
a fixed distance from the brush tip

on each subsequent stroke.

Non-aligned: The pickup point stays in the
same place on each subsequent stroke.

In the first case (called “aligned” because the two cursors remain in
alignment), subsequent brush strokes extend the cloned region rather than
producing multiple copies. In the second you begin cloning the same
pixels all over again from the original pickup point.

� Again, experience is the best teacher. Repeat the cloning procedures
you tried a moment ago—but this time reverse the Aligned setting.
You’ll see the difference.

Creating and Editing Lines and Shapes
The tools we’ve described so far in this chapter have been for “pixel
pushing”—manipulating the color and/or transparency of the image
content on the Background and standard layers. You may recall (from
Chapter 2’s Key Concepts) that PhotoPlus stores shapes separately, on
special layers. It’s a key distinction: lines and shapes in PhotoPlus are
vector objects, as opposed to the raster or bitmap content that’s stored
on the regular pixel-based layers. So now we’ll switch from covering the
various painting tools to a different set of tools, used for drawing
shapes.
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The QuickShape Tools flyout features an assortment of tools for
creating rectangles, ellipses, polygons, and other shapes.

The tools on the Outline Tools flyout let you draw outline
shapes: skinny ones that serve as straight lines, plus freehand and curved
outlines for variety.

Each of the drawing tools has its own creation and editing rules. Before
we get to the differences, let’s cover some things that all shape objects
have in common. First of all, both QuickShapes and outline shapes
occupy special shape layers, marked with an symbol on the Layers
tab. Each shape layer includes a path thumbnail representing the
shape(s) on that layer. (We’ll cover paths in more detail later; every shape
has one.)

Path thumbnail selected Path thumbnail deselected

Assuming you’re working on a non-shape layer when you create a shape,
the new shape appears on a new shape layer. But what about the next
shape you create? Shape layers can store more than one shape, and it’s up
to you where the next one will go. The path thumbnail works like a
button that lets you select a shape layer for drawing. If you want to draw
the next shape on the same layer, leave the same path thumbnail selected
(as at left above). For a shape on a brand new layer, first deselect the
active layer’s path thumbnail (as at right). Or, to create a shape on a
shape layer that already exists, simply activate that layer first.

The four combination buttons ( Add, Subtract, Intersect, and
Exclude) on the Tool Properties tab determine the effect of each new

shape-creation operation. For example, starting with an initial square
shape, here’s what drawing a second such QuickShape might produce
with each setting:

Add Subtract Intersect Exclude
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You can alter a shape layer’s transparency using the Layers tab, or apply
effects like bevel or drop shadow by choosing Effects… from the Layers
menu. Painting tools and adjustment filters don’t work on shape layers;
you’ll first need to convert the layer to a bitmap layer first (right-click the
layer name and choose Render).

To align shapes on different layers with each other, first link the layers by
clicking their Link Layer buttons. Then choose Align Linked from
the Layers menu. You can choose to align tops, bottoms, edges,

and so on.

QuickShapes
QuickShapes in PhotoPlus are pre-designed, filled contours that work
just like the Adjustable Selection tools—you can instantly add rectangles,
ellipses, polygons, and other shapes to your page, then adjust and vary
them using control handles—for innumerable possibilities!

The QuickShape Tools flyout contains a wide
variety of commonly used shapes, including
boxes, ovals, arrows, polygons, and stars. Each
shape has its own built-in “intelligent” properties,
which you can use to customize the basic shape.

As you draw a QuickShape, it displays as an
outline; hold down the Ctrl key while drawing to constrain the aspect
ratio. Once drawn, the shape takes a Solid fill using the foreground color
(see the next section). The active tool switches to the Node Edit tool, and
now you can adjust the shape. The number of handles varies according to
the shape; for example, the rectangle has just one control, the polygon has
two, and the star has four. To adjust a QuickShape, simply drag one of its
handles (the tool changes to a “+” when it is above a handle).

� You’ll have fun with these! Try building up a pile of shapes, each
using a different color with partial transparency so you can see
through to the shapes below. Or just play around with QuickShape
handles to create zany designs or meaningful symbols. Often, forms
like these can communicate quite a lot in a small space—think about
the possibilities for Web buttons or icons.
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Outline shapes
Earlier we noted that shape layers include a path thumbnail. The “path” is
the outline around a shape, and although technically, QuickShapes have
paths, too—the three Outline tools are genuine DIY (draw-it-yourself)
path-drawing tools.

As we mentioned earlier, a straight line in PhotoPlus is just a very
thin shape. To draw one, select the Straight Outline tool from the
Outline Tools flyout and drag the tool on the image.

Hold down the Shift key while dragging to constrain the line to 15º
angles.

The Tool Properties tab provides the
familiar Blend Mode and Opacity settings
for the Line tool. You can also set the
Weight (thickness) of the drawn line, and
turn Anti-aliasing on or off. Anti-aliasing
produces smooth edges by making the
selection’s edge pixels semi-transparent.
It’s great for avoiding “jaggies” on diagonal lines.

� Go ahead and experiment a bit with the Line
tool—trying various weights and turning anti-
aliasing on and off.

The Freehand Outline tool, as its name implies, lets you draw a
squiggly line (or a connected series, starting each segment from another’s
end point), then attach it back to itself to create a closed shape. Simply
click and drag! The Smoothness setting on Tool Properties evens out
ragged contours automatically—useful if your hand shakes.
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The Curved Outline tool can produce complex combination curves
and shapes in a highly controlled way. After choosing the tool, click and
hold down the mouse button. An additional pair of handles appear,
defining a pair of red attractor nodes that orbit the original click point as
you continue to drag the mouse. What these nodes do is define the
curvature of the line segment you’re about to draw. The distance between
attractors determines the depth of the resulting curved line.

Release the mouse button, then click again where you want the first
curved segment to end. To extend an existing path, repeat the process for
each new end point. As with the Freehand Outline tool, you can connect
the curved outline back to its starting point. And you can switch between
the two tools to construct a complex outline in a series of segments.

On a shape layer, PhotoPlus needs to treat each path as a closed shape, so
if it will automatically add a straight “closing segment” (as in the middle
illustration above) even if you haven’t joined the two end points. You can
either leave the shape that way, or continue to draw segments until you
yourself have officially closed it.

Editing shapes

The Edit Tools flyout includes two tools custom-made for editing
QuickShapes and outline shapes. To edit either kind, first activate its
layer and make sure the layer’s path thumbnail is selected.

You can use the Move tool to reposition the shapes on a layer as a
group, but the Shape Edit tool does much more. In fact, it applies the
move, resize, scale, skew, and rotation functions of the Deform tool to
individual shapes on a shape layer. While the Shape Edit tool is active,
you can also use the combination buttons on the Tool Properties tab (see
above) to reset how a selected shape (other than the first one you created
on the layer) interacts with other shapes.
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A B C

The illustration above shows a cool feature of QuickShapes: you can
deform one with the Shape Edit tool (in B, changing A’s wave
into a “road”) and it will still remain adjustable with the Node 

Edit tool! If you look closely at C, you’ll note we’ve added an extra bend
to the “road” after the deformation!

Besides being useful with QuickShapes, the Node Edit tool really comes
into its own with outline shapes. What is an outline, anyway? It’s a
collection of line segments and nodes (points where the line segments
meet). There are three different node types (see Chapter 4’s discussion of
comparable Mesh Warping), and the node type determines the slope and
curvature of adjoining segments.

With the Node Edit tool, you can click and drag directly on a line
segment, drag one or more individual nodes, or alter the node handles to
reshape the outline. To add a new node, double-click on a line segment.
To straighten a line, delete a node or change it from one type to another,
use the set of buttons on the Tool Properties tab.

� Try reshaping, distorting, and rotating all kinds of shapes using the
Edit tools. Lots of possibilities arise using shapes with the two fill
tools as described next. Hint: Because it’s easy to create multiple
shapes with subtly different proportions, QuickShapes lend
themselves to animation, too. (Chapter 6 has a Hands-on example.)
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Filling Regions
The Fill Tools flyout on the Tools toolbar includes two tools: Flood Fill 
and Gradient Fill. As with the paint tools, if there is a selection, the Fill
tools only affect pixels within the selected region. If you’re operating on
a shape or text layer (see the previous and next sections), a single fill
affects the interior of the object(s) on the layer.

The Flood Fill tool replaces an existing color region with the
foreground color. It works only on standard layers, not with shape or text
layers. How large a region is “flooded” with the fill color depends on the
difference between the color of the pixel you initially click and the color of
surrounding pixels.

You can use the Tool Properties tab to set a tolerance value—how much
of a color difference the tool looks for. With a low tolerance setting, the
tool gives up easily and only fills pixels very close in color to the one you
click (a setting of 0 would fill only pixels of the same color; 255 would
fill all pixels). As the tolerance increases, so does the tool’s effect on
pixels further in color from the original pixel, so a larger region is
flooded.

Check Contiguous to affect only pixels connected to the clicked pixel;
uncheck to affect in-range pixels throughout the region. Check Include 
Diagonals for more thorough flooding (more of each pixel’s neighbors
are taken into account).

To apply a flood fill using the foreground color, select the tool from the
flyout, and set tolerance and layer fill options. Then just click with the
tool where you want to start the flood!

� Try flood-filling some existing color regions in your image.

Whereas solid fills use a single color, all gradient fills in PhotoPlus
utilize at least two “key” colors, with a spread of hues in between each
key color, creating a “spectrum” effect. You can fine-tune the actual
spread of color between pairs of key colors. Likewise, a gradient fill in
PhotoPlus can have either solid transparency—one level of opacity, like
50% or 100%, across its entire range—or variable transparency, with at
least two “key” opacity levels and a spread of values in between.
(Remember that opacity is simply an inverse way of expressing
transparency.)
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The Gradient Fill tool lets you apply both color and/or
transparency fills directly to a layer. Five types of fill (Solid, Linear,
Radial, Conical, and Square) are available. Technically, a Solid fill is
different (it uses just one color)—but in practice you can also achieve a
unicolor effect using a gradient fill.

Solid Linear Radial Conical Square

Applying a gradient fill on any kind of layer entails selecting one of the
fill types, editing the fill colors and/or transparency, then applying the
fill. However, gradient fills behave differently depending on the kind of
layer you’re working on.

On standard and Background layers, the tool creates a “spectrum” effect,
filling the active layer or selection with colors spreading between the
current foreground and background colors. The fill is applied rather like a
coat of spray paint over existing pixels on the layer; color values in the
fill gradient interact with the existing pixels to produce new values. In
other words, once you’ve applied the fill, you can’t go back and edit it
(except by undoing it and trying again). Transparency works in a
comparable way, affecting how much the paint you apply is “thinned.” At
full opacity, the fill completely obscures pixels underneath.

Because text and shapes are vector objects in PhotoPlus, the Gradient Fill
tool is even more powerful on these layers—the fill’s color and
transparency properties remain editable. Note that the Gradient Fill tool
doubles on these layers as a solid fill tool; the Flood Fill tool doesn’t
work with text or shapes.

When first drawn, a shape takes a Solid fill using the foreground color.
To edit the color or switch to a different fill type, either double-click the
layer name or choose the Gradient Fill tool and use the Tool Properties
tab. Either option lets you choose a fill type, and/or click the color (or
gradient) sample to edit the fill. Gradient fills incorporate both color and
transparency, and a single fill applies to all the shapes on a particular
layer. So if you want to draw a red box and a yellow box, for example,
you’ll need two shape layers.
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Once you’ve defined the fill, click with the tool where you want to start
the fill and drag to the point where you want it to end. On shape and text
layers, the fill path (the line in the illustration above) remains visible
even after you’ve applied the fill, and you can adjust the fill’s placement
after the fact by dragging the fill path’s end nodes with the Gradient Fill
tool.

Editing a gradient fill
As mentioned above, to define a fill before you apply it, or to change it
after the fact on a shape or text layer, you simply click the gradient
sample. The PhotoPlus Gradient dialog appears whenever you’re editing
a gradient fill, and lets you adjust the fill’s color and/or transparency
spreads. Its central feature is a sample window with a spectrum showing
both color and transparency. Let’s use the gradient shown here as an
example:
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The little house-shaped pointers above and below the spectrum are the
key to making changes in the dialog. Each pointer marks a stop where a
spread of either opacity or color begins and ends. To vary the color
gradient, you’ll use the lower pointers, which show key colors. To vary
the transparency gradient, you’ll work with the upper set of pointers,
which use grayscale values to represent key opacity levels (white =
100% opaque). In the example shown, the gradient has three color
spreads (from blue to yellow, then to blue, then back to yellow), and one
opacity spread (actually uniform opacity, with 80% at each end). As you
can see, the position of the pointers corresponds to transition points in
each gradient.

Whether you’re adjusting the fill’s color or its
opacity properties, the same basic steps are
involved. To make life very simple, you can
begin by selecting a preset fill from the gallery.
Right-click the gallery to select a different
category, or add/delete your own fills or
categories.

For more complex banding in a gradient, add one or more stops to define
new key values and spreads. Click at the position where you want to
place the new stop—either just above the spectrum to add a transparency
stop or just below it for to add a color stop. A new pointer appears, using
an intermediate value. (The tip of a selected pointer is black; unselected
pointers have gray tips.)

To change a key color, select its stop and click the Color box (or just
double-click the pointer) to display the Adjust Color dialog, then select
the new color. To change a key opacity value, select the stop and type a
percentage into the Opacity box. To adjust the length of a spread, move
an intermediate stop by dragging its pointer to a new position along the
spectrum. You can also select the pointer, then type a number into the
Location box. To delete a stop you’ve added, click to select its pointer
and click the appropriate Delete button (or press the Delete key).

The diamond-shaped markers that appear between stops let you adjust the
spread of values between the two stops. Initially, values are graduated
evenly from one stop to the next. To change the value distribution
between adjacent stops, simply drag the intermediate marker. Adjust the
Smoothness slider for more even transitions between bands in a
multicolor fill. Finally, click OK to accept changes.
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Let’s try a mini-project simulating a sphere, using a radial fill inside a
circle. First make sure you have some white space (about a square inch
should do it) available on the Background layer. Perhaps its time to erase
a section, or enlarge the canvas area.

� Choose the Ellipse selection tool and Ctrl-drag over the white region
to create a circular selection about an inch in diameter.

� Choose the Gradient Fill tool from the flyout, then select Radial as
the Fill Type on the Tool Properties tab.

� Click inside the selection, near but not at the top left edge, drag
diagonally down and to the right across the opposite edge. When you
release the mouse button, the selected region takes the fill.

Our “sphere” may not have quite the convincing depth of a 3D model—
but it shows how gradient fills can interact with special selection shapes
to create unusual effects. Choose the gradient paths carefully so that high
and low values fall at specific points inside the selection.

Working with Paths
Paths are basically outlines. As such, every filled shape you draw (see
the preceding sections) has a path—namely the outline that defines it. We
noted that each shape layer has its own path thumbnail next to the layer
name, representing the shape(s) that reside on that layer. But PhotoPlus
also lets you work with independent paths: outlines that don’t reside on
any particular layer, but which are created separately and can be applied
in various ways to any layer. That’s what we’ll introduce in this section.

What are paths good for? Consider the precision and editability of vector-
based drawing and apply it to the concept of a selection. Now think of all
the ways that selections can be used (and reused). In PhotoPlus,
selections and paths are interchangeable. And there’s more... as you’ll
see.
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The Paths tab provides a special window for working with independent
paths.

Each path consists of a path channel, depicted with its own name, and a
path outline on that channel. First you create the channel, then you
create the outline—either by drawing it from scratch or basing it on the
current selection. In the illustration, you can see two path channels and
one path outline (shown in Path 2’s thumbnail). Once you’ve got a path
outline, you can reshape it with the same Edit tools you’d use for shapes,
and convert it to a selection. You can even stroke a path—that is, trace it
onto a bitmap layer using the current brush. Paths are saved along with
the image whenever you use the .SPP format.

To create an empty path channel, display the Paths tab and click the
New Path button. In the dialog, provide a name for the path, then click
OK.

To create a path outline, create an empty path channel or select an
existing path channel on the Paths tab, then draw a path outline using the
QuickShape and/or Outline tools. (See “Creating and editing shapes.”)

Alternatively, you can create a path from the current selection
simply by clicking the Selection to Path button on the Paths tab.

This method creates a new path channel automatically and lets you
choose a Smoothness setting to even out jagged selections, if you wish.
Either way, you’ll end up with an unfilled shape on the path channel. To
duplicate, delete, or rename a path channel, right-click it and choose from
the menu. (You can also double-click a path channel to rename it.)
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To edit a path outline, you use the same Node Edit and Shape Edit tools
described earlier for shape-editing. With them you can move, resize,
reshape, rotate, and skew the path. Since the same tools are used for both
independent paths and outline shapes, you’ll need to tell PhotoPlus when
to switch out of path-editing mode. To exit path-editing mode, deselect
the current path on the Paths tab by clicking in the blank space below the
path names.

When deselected, the current path’s thumbnail loses its border, and you’ll
no longer see the path outlines onscreen. Now you can use the editing
tools on a shape layer. To re-enter path-editing mode, click a path’s
thumbnail again.

To create a selection from a path, use the Layers tab to select the
target Background or standard layer, and on the Paths tab select the path
channel you want to use. Click the Selection to Path button. A dialog
appears with various options for the new selection: feathering, anti-
aliasing, and combination. (Refer to Chapter 3’s section on “Making
Selections” for details.) Click OK and the selection marquee appears on
the target layer.

Stroking a path is a convenient way of creating painted lines or unfilled
shapes without having to draw them directly. First select the target layer
and source path. Choose a brush tool (such as the Paintbrush or Picture
Brush) and set Color, Brush Tip, and Tool Properties options. Make sure

the path is positioned where you want it, then click the Stroke 
Path button on the Layers tab. That’s it!

Before (path) After (bitmap)

Click here
to deselect
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Working with Text
Use the Text Tools flyout on the Tools toolbar to select from two text
tools—one for entering solid, colorful text on a new layer, and the other
for creating a selection in the shape of text with which to manipulate
content on an existing layer.

To create new solid text, choose the standard Text tool from the
flyout. Click with the tool where you want to insert text (it can be moved
later). The Add Text window opens.

Type your text and use the formatting options at the top of the dialog.
Formatting is applied to all the text in the window, so you don’t need to
select the text first. To apply semi-transparent edges to the characters,
check the Anti-Alias box. (Anti-aliasing is generally recommended with
text sizes 14pt or larger.)

To set text color, click the Adjust Color button and use the dialog. You
won’t see the effect of the new color until you close the Add Text
window. (For details on using the Adjust Color dialog, see the “Choosing
colors” topic in online help.)

When you’re done, click OK. The text appears on a new transparent layer
in the image. You can now use the Move tool or other tools and
commands to manipulate it, just like the contents of any layer.

The Layers tab designates text layers with a symbol. Like shapes (as
discussed earlier), solid text in PhotoPlus is editable: as long as it remains
on a separate text layer, you can retype it or change its properties at any
time. To edit existing text, either double-click the text layer’s name on
the Layers tab, or select the layer and—using the standard Text tool—
move the cursor over the text until it changes to an I-beam, then click on
the text. The Add Text window appears, with the text ready for editing.

In order to keep text editable, only one block of text can occupy a text
layer, so various functions—such as paint tools, adjustment filters, or the
Paste Into Layer command—are disabled on text layers. To convert any
text layer to a standard layer, right-click on the layer name and choose
Render from the menu.
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Bonus fonts: PhotoPlus includes a special collection of TrueType fonts!
You’ll find them on your PhotoPlus CD in the SERIF\FONTS directory.

Text selections work like standard or adjustable selections, except that
(you guessed it) they’re shaped like text! This opens up a number of
creative possibilities, such as using the text selections to “pick up”
patterns or filling the region with unusual fills.

To create a text selection, choose the Text Selection tool from the
Text Tools flyout and click in the image to display the Add Text window.
Type your text and apply formatting just as when creating solid text.
Click OK when you’re done. Instead of solid text on a separate layer,
you’ll see a selection region on the active layer. Now you can cut, copy,
move, modify, and apply various effects to it, just as with the other types
of selection. (Note that text selections, unlike solid text, cannot be edited
with the Add Text window.)

HANDS ON: Creating Filled Text
This sequence shows you how to create some text and fill it with a
pattern. One image will serve as a fill for the text created in another.

� Open WATER.JPG (our fill image) in the PhotoPlus PROJECTS

folder.

Next, create a new empty image to use for the text.

� Choose New from the File menu to open the New Picture dialog.
Make the size 500×100, with a transparent background.

� Now choose the Text Selection tool and click it in the new image
window to open the Add Text window. Select Cairo SF and 72
points from the formatting options.

� Type the word “water” in the box and click OK to drop the text on
the blank image. Use the Move tool to reposition the selection if
necessary.

� Now, use Ctrl+Tab to go back to WATER.JPG. Select an area from
that image and copy the selection to the Clipboard.
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� Toggle back to the new image and paste the Clipboard contents into
the selection by choosing Paste>Paste into Selection from the Edit
menu.

The final stage is to give the word a drop
shadow so that it stands out from the
background.

� Choose Effects... from the Layers menu
and check Drop Shadow.

� Use the controls to adjust the drop
shadow’s properties, and click OK when
you’re ready to apply the effect.

HANDS ON: Raised Filled Text Effect
This sequence will show you how to create a text effect which looks as if
it has been carved in a block of wood.

� Open the file WOOD.JPG in the
PhotoPlus PROJECTS folder.

� Copy the image to the Clipboard so
that it will be available to paste in a
moment.

� Adjust the brightness of the image by
choosing Adjust>Brightness/ 
Contrast from the Image menu.
Increase the Brightness by 10 but
leave the contrast alone.

� Next, blur the image by choosing
Blur>Average Blur… from the
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Effects menu and blurring by a value of 4 or so.

These steps will have created a background for the effect. Don’t forget to
save your work as you go along! The next step is to add some text, which
is done on a new layer.

� Add the new layer, then choose the Text Selection tool and click on
the image to open the Add Text box. Choose Basic Sans Heavy SF
and set the size to 72.

� Type the text “PhotoPlus” in the box (at least, that’s what we typed!)
and click OK to place the text-shaped selecton on the new layer. Use
the Move tool to drag the layer until the selection marquee is
positioned centrally.

� Choose Paste>Into Selection from the Edit menu.

At this point the coloration of the letters closely matches that of the
background.

� Change the text layer’s Blend Mode from Normal toMultiply using
the Layers tab, and the letters will be darker and more visible.

� Next, give the text a raised look by choosing Effects...from the
Layers menu. Check Bevel and Emboss and use the dialog to add
an Inner or Outer Bevel effect. Adjust the settings to your liking.

You can fill lettering with any bitmap from the Clipboard, and obviously
the best way to find out how different fills and effects work is to
experiment!
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Tutorial Resources
For more experience with the tools and techniques covered in this
chapter, we recommend these HTML-based tutorials on the PhotoPlus 8.0
Resource CD-ROM:

Try this tutorial... For practice with these tools and techniques...

Selection Tools Basic selection concepts

Exploring Color Spaces Color Modes: RGB and HSL

PolyDolly Clone tool basics

Retouching I Clone tool for stitching images back together

Textraordinaire Text creation plus Gradient Fill, Paintbrush, Smudge,
Blur, Deform tools and various effects

Framed! QuickShape and Outline Shape tools plus a 3D Effect

Neon Gel Layer effects and the Curves adjustment on text

Close Encounters of the 
Curved Kind

Changing tonal qualities with Color Selection Tool,
Curves adjustment, adding Lens Flare
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Layers
If you’re accustomed to thinking of pictures as flat illustrations in books,
or photographic prints, the concept of image layers may take some
getting used to. In fact, layers are hardly unique to electronic images. The
emulsion of photographic film has separate layers, each sensitive to a
different color—and we’ve all noticed multiple-image depth effects like
shop window reflections or mirrored interiors. There is still something
magical about being able to build up an image in a series of planes, like
sheets of electronic glass, each of which can vary in transparency and
interact with the layers below to produce exciting new images and colors.

Kinds of layers
In a typical PhotoPlus image—for example, a photograph you’ve scanned
in, a new picture file you’ve just created, or a standard bitmap file you’ve
opened—there is one layer that behaves like a conventional “flat” image.
This is called the Background layer, and
you can think of it as having paint overlaid
on an opaque, solid color surface.

You can create any number of new layers
in your image. Each new one appears on
top of the rest, comprising a stack of layers
that you can view and manipulate with the
Layers tab. We call these additional
layers standard layers to differentiate
them from the Background layer. Standard layers behave like transparent
sheets through which the underlying layers are visible.
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In the previous chapter, we covered shape layers and text layers, which
are specifically designed to keep objects (either shapes or text) separate
from the other layers so that they remain editable. Chapter 3 described
adjustment layers, which apply filter effects to lower layers. Refer back
to the earlier sections for coverage of these special-purpose layers—here
we are concerned mainly with the Background and standard layers.

A key thing to keep in mind is that pixels on the Background layer, once
laid down, are fully opaque, while those on standard layers can vary in
opacity (or transparency, which is really the same thing). That’s because
standard layers have a “master” Opacity setting that you can change at
any time, while the Background layer does not. A couple of examples
will show how this rule is applied in PhotoPlus:

Suppose you are creating a new picture image. The New Image dialog
provides three choices for Background:White, Background Color, and
Transparent. If you pick White or Background Color, the Layers tab
shows a single layer named “Background.” If you pick Transparent,
however, the single layer is named “Layer 1”—in this case, the image
(typically an animation file) has no Background layer.

If you cut, delete, or move a selection on the
Background layer, the “hole” that’s left is
filled with the current background color (as
shown on the Color tab). The same operations
on a standard layer leave a transparent hole.

Many standard operations, such as painting, selecting and moving,
Clipboard actions, adjusting colors, applying effects, and so on, are
possible on both the Background layer and standard layers.

Others, such as rearranging the order of layers in the stack, setting up
different color interactions (blend modes) between layers, varying layer
opacity (transparency), masking, or creating animation frames, only work
with standard layers.

Once an image has more than just a background layer, the layer
information can only be preserved by saving the image in the native
PhotoPlus (.SPP) format. Multiple layers are merged when you export an
image to a standard “flat” bitmap format like .JPG or .BMP. In general,
we recommend that you save your work-in-progress as .SPP files, and
only export to a different file format as the final step.
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Basic layer operations
To select a layer, left- or right-click on its name in the Layers tab. The
selected layer is now termed the active layer. (Note that “selecting” a
layer doesn’t imply selecting a region of pixels—that’s a separate step,
using tools described in Chapter 3.)

To create a new standard layer above the active layer, click the New 
Layer button on the Layers tab. To clone the active layer and its contents
as a new standard layer, choose Duplicate... from the Layers menu. As a
shortcut to either command, you can simply right-click a layer name.

To convert the Background layer to a standard (transparent) layer, right-
click “Background” on the Layers tab and choose Promote to Layer.
The layer’s name changes from “Background” to “Layer <number>.”

To remove the active layer, click the Delete button on the Layers
tab. (You can delete the Background layer, as long as it’s not the last
layer.)

To make a layer’s contents visible or invisible, click the Hide/Show 
Layer button next to its name on the Layers tab. The icon switches
between an open and closed eye. Shortcut: Left- or right-click a hidden
layer’s name to make the layer visible again.

To prevent further editing of transparent regions on a standard layer,
click the Protect Transparency button next to its name on the Layers
tab.

Note that each layer’s entry includes a preview thumbnail, which is
visible at all times—especially useful if you’re working with many
similar layers, image fragments, and/or hidden layers.

Manipulating layers
Control over layers means control over a great variety of creative
possibilities. This section will review some of the manipulations you
should know about.

Note that commands on the Image and Effects menus, such as color
adjustments and special effects, typically are applied to the current
selection (if one exists). Otherwise they affect the active layer (the one
currently selected in the Layers tab).



96 Using Layers and Masks

Moving the contents of one or more layers

To move the contents of the entire active layer, make sure nothing is
selected, then drag with the Move tool. Note that layer content moved in
this way outside the image window (canvas area) survives—you can drag
it back inside the window later if desired.

You can link one or more layers to the active layer so that when you
drag with the Move tool, the contents of all linked layers move together.
Click the Link Layer button next to the layer’s name on the Layers tab.
The link button is always “down” (as shown) for the active layer. You
can see which others are linked to it by checking to see which other link
buttons are also down. Once layers are linked, they remain so regardless
of which layer in a linked group is active.

To align linked layers with each other, choose Align Linked from the
Layers menu, then select Top, Vertical Center, Bottom, Left, Horizontal 
Center, or Right from the submenu.

To unlink a layer from the active layer, click its link button again (so it’s
now “up,” with an open-link icon).

Clipboard operations involving layers
To copy (or cut) the contents of the entire active layer to the Clipboard,
select nothing and use the standard Ctrl+C or Ctrl+X commands. Cut or
deleted pixels are replaced (on the Background layer) with the current
background color, or (on standard layers) with transparency.

You can paste the copied or cut layer into another PhotoPlus image
window, using the Paste>As New Layer command on the Edit menu.
Note that text layers become standard layers when pasted.

Rearranging standard layers in the stack
To move a standard layer up or down in the layer stack, click on the layer
name in the Layers tab and drag up or down. A black line “drop target”
appears between layers as you drag. Drop the layer on a target to relocate
it in the stack.

Another method is to select the layer and choose
Arrange from the Layers menu, then choose one of
the following:

• Bring to Top places the layer on the top of the stack.
• Move Up moves the layer up one in the stack.
• Move Down moves the layer down one in the stack.
• Send to Bottom places the layer just above the Background layer (if
present) in the stack
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Merging layers
Merging layers combines multiple layers into one, decreasing the memory
required to store the image. Once layers have been merged, they become a
single layer and their previous contents are no longer separately editable.

To merge the active layer with the layer below it, chooseMerge Down
from the Layers menu. To merge just the currently visible layers into a
single layer, chooseMerge Visible from the Layers menu.

To merge all image layers into a single layer, chooseMerge All from the
Layers menu. This is called flattening the image because the result is a
“flat” file with just a Background layer.

To copy the selection (or image, if there’s no selection) to the Clipboard
in flattened form without physically merging its layers, choose Copy 
Merged from the Edit menu.

Blend Modes
You can think of blend modes as different ways of putting pixels
together to create a resulting color. In PhotoPlus, we’ve already
encountered blend modes as a property of individual tools (Paintbrush,
Clone, Eraser, Airbrush, Fill, Smudge, Shape, and Line), where the tool’s
blend mode determines how new color pixels look
when painting on top of existing pixels.

As a property of individual layers, a layer’s blend
mode determines the result of combining each pixel
on that layer with those on layers below. (Because
there are no layers below the Background layer, it
can’t have a blend mode.) Note that unlike working
with paint tools, changing a layer’s blend mode
property doesn’t actually alter the pixels on the layer.
This means you can create different blend mode
effects after creating the image content, then merge
layers (see the previous section) when you’ve
achieved the result you want.

To set a layer’s blend mode, select it on the Layers tab
and choose from the drop-down list as shown at right.

To learn more about the individual blend modes, choose Effects Gallery
from the Help menu, then select from the Gallery menu. Each mode is
illustrated for quick comparisons, and the listing of modes is cross-
referenced to explanatory help topics (just click the green links).
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HANDS ON: Making a Montage
Now we’ll put several layers from several files together to create one
image (in this case an ad for a music event) using a base image, text, and
backgrounds. We’re going to use an image of a musical score as the main
background for our composite.

� Open the file SCORE.JPG in the PhotoPlus PROJECTS folder.

� Save the image under the name MONTAGE.SPP. This will become
the primary working window (we’ll refer to it as the “Montage
window”).

� Now open the file PIANO.JPG in the Sample folder. Copy the image
to the Clipboard and then close the image window without saving.

� In the Montage window, choose Paste>As New Layer from the Edit
menu to paste the piano image as a new layer (Layer 1).

� Choose Adjust>Hue/Saturation/Lightness… from the Image menu
and boost the layer’s Lightness by 25.

� Open the file STATUE.JPG in the PROJECTS folder. Carefully select
around the statue, using the “Ellipse” Adjustable Selection tool to
make a circular selection including just the statue’s head.
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� Copy the selected area to the Clipboard and close the image window.
Then in the Montage window, choose Paste>As New Layer from
the Edit menu to paste another new layer (Layer 2).

� Select the Deform tool and drag to enlarge the head slightly, keeping
the Shift key down to maintain the aspect ratio.

� Save the work-in-progress at this point (and every so often for the
rest of the project).

Now, we’ll add some text.

� Make the foreground color red on the Color tab, and then select the
Text tool. Click the Text tool on the image, and in the Add Text
window type the words “Liberty Concert.” Use Basic Sans Heavy
SF, 72 points, with centered alignment and a line break after
“Liberty.” Click OK to place the text as a new text layer.

� Use the Deform tool to position, resize, and rotate the text on its
layer so it is parallel to the piano keys, then choose Effects… from
the Layers menu and check Drop Shadow to add a shadow behind
the text.

� Select the piano layer (Layer 1) on the Layers tab. Adjust the
Opacity for that layer to 75% and set its Blend Mode to Multiply.
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� On the Color tab, set the foreground color to black and the
background color to white. Then choose the Gradient Fill tool and
(on the Tool Properties tab) select a Linear fill with both starting and
ending Opacity values of 50%. Apply the fill to the piano layer by
drawing a path from the top left to the bottom right of the image.

� Open MOON.JPG in the PROJECTS folder and use the “Crescent”
Adjustable Selection tool to select a portion of the moon.

� Copy the selected region to the Clipboard, then close the image
window. In the Montage window, choose Paste>As New Layer
from the Edit menu.

� Use the Deform tool to resize and reposition the selection as shown.

� Make the foreground color in the Color tab white, and select the Text
tool. Add the text “Music By Moonlight” in Basic Sans, bold, size 14
points, on three lines, and drag it next to the crescent moon using the
Move tool.

� Select the Text tool again, and add the text “Independence Day” in
Handscript SF, 24 points. Drag the text to the top of the image using
the Move tool.
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� Add a slight bevel effect to the new layer by choosing Effects… from
the Layers menu, checking Bevel and Emboss, and setting an Outer
Bevel... and you’re done!

� You can save the image as an .SPP if you want to preserve the layers,
or chooseMerge All from the Layers menu to flatten the file and
conserve some disk space.

Extracting part of a layer
The Edit/Extract... command can speed the task of isolating one portion
of a layer. Using the special dialog, you simply brush an outline around
the edges of the region you want to extract, then mark a “foreground”
area to be retained—usually inside the outline. PhotoPlus applies
sophisticated edge detection within the marked edge band, decides which
pixels to keep, and turns the rest of the layer transparent, with variable
blending along the edge. In preview mode, you can fine-tune and reapply
the extraction settings, and manually touch up the image until the result is
just right.

Instead of marking a foreground region, you can designate a specific
“key” color to which edge pixels can be compared. Similar pixels will be
kept, and dissimilar pixels discarded. (See online help for details.)
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Layer Effects
Layer effects are creative effects that you can
apply to the contents of standard (transparent)
layers, text layers, or shape layers. Standard or
2D layer effects like shadow, glow, bevel, and
emboss are particularly well adapted to text,
while 3D layer effects create the impression of a
textured surface. Because the Background layer
doesn’t support transparency, the effects are not
available there. Another thing to keep in mind is
that none of the layer effects will “do” anything
to an empty layer—you’ll need to have some
color there to see the difference they make!

For an overview of all the available layer effects,
take a look at the Effects Gallery in online help.
Choose Effects Gallery... from the Help menu, or click Effects Gallery
on the main help Contents menu. You can browse the effects and link
directly to details on their respective settings.

To apply an effect to the active layer, click the Layer Effects button
on the Layers tab (or choose Effects... from the Layers menu). The Layer
Effects dialog appears, with a branching checklist of available effects. As
the checkbox format suggests, you can apply one or more effects to the
same layer simply by checking boxes to switch them on individually.
Suppose we preview the settings for one of the basic 2D effects, Drop 
Shadow.

As with all the layer effects, you can check the Automatic box to preview
the effect continually applied to the image as you make adjustments, or
uncheck it and click theManual button only when you want to update
the preview. You can also choose a Blend Mode to determine how the
effect’s colors interact with image colors, and adjust the various sliders
(or enter specific values) to change the total effect. In this particular
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dialog, there’s also an Angle dial that lets you control the direction of the
cast shadow, and a Color swatch to change the base shadow color. Don’t
worry—online help includes details on every single layer effect setting!

3D layer effects are just as easy to
apply, but they’re a bit more complex
than their 2D cousins. Actually,
there’s an easy way to get with them:
simply display the Instant Effects tab
and preview its gallery thumbnails.
There you’ll see a variety of
remarkable 3D surface and texture
presets (wood, metal, skin, etc.), all
generated with the PhotoPlus engine.
Click any thumbnail to apply it to the
active layer. Assuming the layer has
some color on it to start with, you’ll see an instant result!

Depending on the size of your original image and what’s depicted in it,
you may want to vary the Scale slider to reproportion the effect (for
example, to achieve a more realistic orange-peel texture). Having applied
a preset effect, you can now bring up the Layer Effects dialog and inspect
the settings used in the preset. The first thing you’ll notice is that the 3D 
Effects and 3D Lighting boxes will always be checked. The master
settings of Blur and Depth make a great difference; you can click the “+”
button to unlink them for independent adjustment. As for 3D Lighting,
without a “light source” switched on, the depth information in the effect
wouldn’t be visible.

Another thing you’ll probably wonder about is that all the 3D effects seem
to have “map” in their name. So what is a map, anyway? Actually, it’s the
key to understanding how these effects work. Let’s call it a channel of
information overlaid on the image, storing values for each underlying image
pixel. You can think of the layer as a picture printed on a flexible sheet,
which is flat to start with. Each 3D effect employs a map that interacts with
the underlying layer’s image to create the impression of a textured surface.

Bump Maps superimpose depth information for a bumpy, peak-and-
valley effect. Using the flexible sheet metaphor, the bump map adds up-
and-down contours and the image “flexes” along with these bumps, like
shrink-wrap, while a light from off to one side accentuates the contours.
Pattern Maps contribute color variations using a choice of blend modes
and opacity, for realistic (or otherworldly!) depictions of wood grain,
marbling, and blotches or striations of all kinds.
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You’ll notice that Bump Maps and Pattern Maps come in two varieties:
“2D” and “3D.” Don’t be misled! These are all three-dimensional effects;
the distinction has to do with how each one achieves its result. With the
“3D” Bump Maps and Pattern Maps, you first pick a mathematical
function. With the “2D” variants, you begin by selecting a bitmap from a
gallery. The function-based maps include data about the interior of the
“space,” while the bitmap-based maps describe only surface
characteristics. You’ll see the distinction more clearly if you experiment
with depth maps, as covered in the next section.

See online help for extended technical coverage of the 3D layer effects.
For now, just spend some time playing with them! For an exercise
combining layer effects with depth maps, see the “Letters in the Sand”
Hands-on Project a few pages on.

Depth Maps
Depth maps let you add remarkable 3D realism to ordinary images, with
or without the use of 3D layer effects (as described above). A standard
“flat” image, of course, has only two dimensions: X and Y, or width and
height. Adding a depth map to a layer gives you an extra channel that
stores information for a third (Z-axis or depth) dimension, in effect
adding “volume” to the image. It’s as if the original image acquires a
surface with peaks and valleys—and you can play with the elevation of
the landscape to achieve different visual results.

The depth map itself is a grayscale representation that uses lightness
values to encode the Z-axis or “elevation” data, with 256 possible levels
for each underlying image pixel. Lighter areas represent peaks and darker
areas represent valleys. Here’s a schematic view of how an imaginary 3D
volume (the stack on the left) might be encoded as a depth map:

The several levels of elevation on the stack translate or “map” directly to
lightness values in the grayscale depth map on the right. What PhotoPlus
can do is take the depth map and translate it back into light-and-shadow
information that appears (to us) as depth in an image... hence the illusion
of three-dimensionality.
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Typically, you’ll begin by creating a new blank depth map on a layer,
then modify it by painting or erasing directly on the map. Changes on the
grayscale map layer produce the effect of highs and lows in the “surface.”
This kind of grayscale painting is not unlike
using Paint to Select mode (see Chapter 3) or
working on a mask... only in this case, it’s
like using a 3D brush! At right, a typical first
effort: showing how a solid color layer
appears after scrawling in white with a fuzzy
brush on the depth map...

So how can you go about creating a depth map? Just activate the
layer in the Layers tab and click the Add Layer Depth Map button.
You’ll see a thumbnail of the depth map appear next to the layer name.
Initially, the depth map appears solid black, i.e. with zero depth. When
you create a depth map, the 3D Effects and 3D Lighting layer effects are
switched on by default (so that depth will be visible); the 3D Lighting
contributes a bevel effect around the edge, providing initial edge relief.
The Colors tab switches to Grayscale mode with White initially the
foreground color and Black the background color—and you’re ready to
go!

The basic way to produce an effect is to paint or erase on the depth map.
Painting in a lighter shade adds “highs,” while painting in a darker shade
adds “lows.” The fill and selection tools, work, too! For example, instead
of starting with an all-black depth map, you can fill all or part of the
depth map with gray to start with, and then use painting or eraser tools.

� Try following the steps above and experiment with your own
“handwriting” in 3D.

� Try using the Text tool to create a selection in the shape of text, then
paint inside it.

While working on the layer, you can switch back and forth between the
image level, depth map, and (optional) mask by clicking the appropriate
thumbnail. You can also switch the depth map off and on to assess its
contribution to the image, or subtract it for creative reasons: Shift-click its
preview thumbnail, next to the layer name.

Bitmap selected Depth map selected
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Once you’ve gotten the basic idea of 3D-by-painting, you might want to
try another way of incorporating depth information: create a suitable
bitmap image separately (or borrow one from somewhere else) and then
paste it via the Clipboard to an existing PhotoPlus depth map. See online
help for the details. And needless to say, you can combine depth maps
with 3D layer effects or Instant Effects tab presets to create even more
fascinating surfaces and textures.

No question about it: these tools will add a whole new dimension to your
artwork!

HANDS ON: Letters in the Sand
In this sequence, we’ll create a depth map with the aid of the Inner
Shadow layer effect, and then put it to creative use.

� Open DESERT.JPG in the PhotoPlus PROJECTS folder.

� Select a middle gray (128, 128, 128) as your foreground color.
Choose the Text tool and click to display the Add Text dialog.

� Using Basic Sans Heavy, type the word “thirst” and set it to 72pt,
then click OK.

� Choose the Deform tool and drag to roughly center the text in the
image. Drag from the lower corner nodes to enlarge the text block so
it’s nearly as wide as the image, and drag from the interior to
position the word near the foreground. Ctrl-drag from each upper
corner node, this time inward so as to add a perspective deformation.
Don’t worry if a couple of letters get out of position; you’ll fix them
later.
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� Choose Effects... from the Layers menu and check Inner Shadow.
Select settings as follows: White as the color, Normal Blend Mode,
Opacity 100, Blur 15, Distance 4, Intensity 6. Leave the Angle at 45.

Now for a series of operations to turn the text into a depth map where the
darker interior of the letters will subtract depth, while the white edges
will serve as the “high ground.”

� Right-click the text layer and choose Render to convert it into a
transparent standard layer. If a couple of letters are mis-aligned,
now’s the time to use the Freehand Selection tool and drag them
(kicking and screaming) into position. We couldn’t have done this, of
course, as long as the letters were still on a text layer. Your layer
structure should now look like this:

� To create a depth map, we need an image layer that supports
transparency, so right-click the Background layer and choose
Promote to Layer.

� Click the New Layer button to create a new layer between the
two existing ones. Select White as the foreground color and use the
Flood Fill tool to fill this new layer.
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� Activate the “thirst” layer and chooseMerge Down from the Layers
menu. Now the layer structure should appear as below, and we’re
ready to create the depth map.

� On Layer 2, press Ctrl-A to Select All, and then click the layer’s
Hide/Show Layer button so all you see is Layer 1.

� With Layer 1 activated, click the Add Layer Depth Map
button. We’re still in Select All mode with the new map now
selected, so choose Paste>Into Selection from the Edit menu. You’ll
see an instant transformation! What started as a text layer has been
converted to grayscale variations on the depth map.

� Initially the effect will appear extremely blurry, but a few
adjustments will fix that. Click the layer’s Layer Effects button and
adjust the linked Blur and Depth settings for 3D Effects to 10. For
3D Lighting, drag the Specular slider to 0 to remove the highlight
reflections—out of place on sandy terrain. You might also adjust the
Elevation value to 50.

� For a clearer visual statement, we moved the sandy region up to
cover the mountains and create a higher horizon line:
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Masks
Masking in a program like PhotoPlus is a wee bit more complicated than
applying masking tape to the screen! But fundamentally the concept is
the same: you can hide certain parts of an image—in this case by
rendering them transparent, hence invisible. To do that, you create a
mask on a non-Background layer. You can also use a mask with an
adjustment layer, too—to restrict the effect to certain regions.

By changing the grayscale values
on the mask (using the paint tools
and other devices), you can effect
corresponding changes in the
opacity of the underlying layer’s
pixels. For example, by “blacking out” on the mask, you render the
layer’s underlying pixels transparent, and they disappear from the image.
On an adjustment layer, blacking out hides the adjustment’s effect. And
because you’re working with 256 levels of gray (i.e. opacity), tremendous
variations are achievable.

Besides the creative possibilities, ranging from vignetting to multi-layer
montage to gradient masking and beyond, a great feature of working on a
mask is that it is “temporary”—if you don’t like the way things are going,
you can abandon your changes and start over without ever having
affected the actual pixels on the layer!

Each non-Background layer can have one mask at any given time. (The
Background layer can’t have one because it doesn’t support
transparency.) Mask information, like layer information, can only be
preserved by saving the image in the native PhotoPlus (.SPP) format.

Mask-making
Here are the three basic steps in using a mask:

1 Create the mask on a layer.

2 Edit the mask itself to “preview” changes to the layer.

3 Merge the mask with the layer to make the changes permanent, or
delete the mask without applying changes.

Let’s take these in turn. (The description assumes you’re working with a
standard layer, but the procedures are similar for adjustment layers.)
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1 Creating the Mask
Before you can use a mask, you have to create it on a particular layer.
The mask can start out as all transparent (revealing the whole layer) or all
opaque (hiding the whole layer)—or you can create a mask from a
selection, in which case part of the mask will be transparent and the rest
opaque. The choice depends on how you want to work with the layer’s
contents. By darkening portions of a clear mask, you can selectively fade
underlying layer pixels. By lightening an opaque mask, you selectively
reveal layer pixels.

To create a mask, first select the layer where you want to create the mask,
and select specific region(s) if desired. Choose Add Mask from the
Layers menu and then one of the following from the submenu:

• Reveal All for a transparent mask over the whole layer
• Hide All for an opaque mask over the whole layer
• Reveal Selection for an opaque mask with transparent “holes” over the
selected region(s)
• Hide Selection for a transparent mask with opaque “blocks” over the
selected region(s)

You can also click the layer’s Add Layer Mask button to create a
Reveal All mask (or Reveal Selection if there is one).

On the Layers tab, a mask preview thumbnail appears, confirming that a
mask exists.

2 Editing on the Mask
In Edit Mask mode, you can use the full range of painting tools, selection
options, and effects to alter the mask’s grayscale values. These
manipulations cause corresponding changes in opacity, which in turn
changes the appearance of the pixels on the layer itself.

Remember, as long as you are editing the mask, you’re only seeing a
preview of changes on the layer. No permanent changes will be applied
until you actually merge the mask with the layer.
You can switch out of Edit Mask mode at any
time to work directly on the layer (or any other
part of the image), then switch back to resume
work on the mask.

To edit the active layer’s mask, click the mask
preview thumbnail, or check Edit Mask on the
Layers menu. (Click the layer’s bitmap
thumbnail or uncheck the menu item to switch out of Edit Mask mode.)
The Color tab switches to Grayscale mode when you’re editing a mask,
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and reverts to the previous setting when you exit Edit Mask mode. This
means anything you paste from the Clipboard onto the mask will
automatically be converted to grayscale. The image window’s titlebar
shows “[MASK],” indicating that a mask is currently being edited.

In Edit Mask mode, you’re normally viewing not the mask, but rather the
effects of changes “as if” you were making them on the layer below.
Adding a Reveal All mask can be a bit confusing, because there’s initially
no evidence the mask is there at all (i.e. the layer appears exactly the
same as it did before you added the mask)! It’s sometimes helpful to
switch on the View Mask setting (Alt-click the mask preview thumbnail,
or use the Layers menu), which hides the
layer and lets you see only the mask, in all
its black, white, or grayscale glory. For
example, a Reveal All mask appears pure
white in View Mask mode (as at right).
This represents a clear mask with no effect
on the underlying pixels’ opacity.

View Mask can also be useful in the latter stages of working on a mask,
to locate any small regions that may have escaped your attention.

You can disable the mask (Shift-click the mask preview thumbnail or
check Disable Mask on the Layers menu) to see how the layer looks
without the mask’s effects. Note that disabling the mask is not the same
as cancelling Edit Mask mode—it only affects your view of the layer, not
which plane (i.e. mask or layer) you’re working on. When the mask is
disabled, a red “X” appears across its thumbnail.

You can also create a selection directly from the mask by selecting its
preview thumbnail and choosing Create from Mask from the Select
menu. Within the resulting selection, pixels that are lighter on the mask
(conferring more opacity) become relatively more selected. This
correlates with Paint to Select mode (see Chapter 3), where painting in
lighter tones also confers “selectedness.”

3 Applying changes to the layer
Once you’re satisfied with the appearance of the layer as seen with the
mask enabled, you can chooseMerge Mask from the Layers menu to
make the changes permanent.

Of course, you may choose to delete the mask (choose Delete Mask
from the Layers menu) without applying changes... perhaps to try again.
In either case, whether merged or deleted, the old mask is no longer
present and the layer is ready to accept a new mask.
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Merging masks reduces clutter and file size, but note that the effects of
masking appear in exported images whether or not you’ve merged masks.

HANDS ON: Vignetting
� Open BRIDGE.JPG in the PhotoPlus PROJECTS folder.

� Right-click the Background layer and choose Promote to Layer.
Now that the layer (renamed “Layer 1”) is transparent, we can make
a mask on it.

� Select the “Ellipse” Adjustable Selection tool and drag out an
elliptical selection on the image. Move the selection marquee if
necessary so that the bridge is exactly centered within it, and double-
click to confirm your selection.

The region within the oval selection is
our area of interest. To create a vignette
effect—a gradual fade-in from the
edges—we’ll want to make the pixels
at the edge transparent, grading in to
opaque pixels in the part of the picture
we want to keep. Feathering the
selection will produce this effect.

Feathering proceeds outwards from the
edges of a selection, so to feather
within the region we’ve defined, we’ll
first contract the selection and then
feather out from there.

� ChooseModify>Contract... from the Select menu, and type in 20 as
the number of pixels. Click OK.
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� Now chooseModify>Feather... from the Select menu, and again
enter 20.

There’s no immediately visible effect on the image, but we have altered
the selection, as you’ll see...

� Choose Add Mask>Reveal Selection from
the Layers menu.

Right away the effect of the mask created from
the selection becomes clear—literally! The gray-
and-white checkerboard pattern shows the
transparent regions of this single-layer image.
Feathering has produced a gradation of opacity.

� Merge the mask with the underlying layer by choosingMerge Mask 
from the Layers menu.

Now let’s put a mat around the image.

� Choose New... from the Layers menu and click OK to create a new
layer.

� On the Layers tab, drag the new layer down below the first one so
that it’s on the bottom. (You still won’t see any change in the image.)
Make the new bottom layer the active layer, and press Ctrl+D to
remove the selection (if there still is one).

� Pick a neutral beige or pastel foreground color, and click with the
Flood Fill tool on the active bottom layer.

� As a finishing touch, you can
drag the “bridge” layer slightly
with the Move tool to center it
with respect to the mat.

� You can now save the image as
an .SPP, export it to another
format, print it, or perform more
manipulations.
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Tutorial Resources
For more experience with the tools and techniques covered in this
chapter, we recommend these HTML-based tutorials on the PhotoPlus 8.0
Resource CD-ROM. All involve working with multiple layers:

Try this tutorial... For practice with these tools and techniques...

Giraffic Park Extract command, working between two images

Giraffic Park 2 Adding shadows, reflection, and more with the Deform
tool, Crop tool, layer duplication and flipping, custom
selections with feathering and layer opacity

Tantastic Retouching and a photo frame, using Clone tool,
Replace Color filter, layers

Holidays Extract command to transform a group picture into an
array of “fakes”

Rollin'! Combining images using Clone tool, Deform tool,
optional masking, layer transparency, Blur tool

Shut It Down! A custom Windows shutdown screen using Deform tool,
Flood Fill tool, Text, Layer Effects, Resize filter and
Export Optimizer.

Vectoriffic Adding dimensionality with QuickShapes, gradient fills,
transparency

Criminal Intent Depth map fingerprint on a square of “chocolate”

Instant Artistry Oil effect applied to a photo
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One of the main uses for PhotoPlus is to produce graphics for use on the
World Wide Web. This chapter looks at the prevalent Web graphics file
formats, techniques for creating and editing animations, and two
specialized techniques (image slicing and image maps) used to extend the
performance of Web images.

“Performance” may seem like an odd aspect of graphic design, but it’s
actually one of the key factors in designing for the Web. Among other
things, it means load time: how long it takes for your whole page,
including text and graphics, to display completely in a Web browser. In
practice, it’s hard to measure. Things like connection bandwidth, server
speed, and modem rating all play a part.

Load time is a function of the total size of all the page objects that need to
load; and graphics usually take up the lion’s share. Is there anything you
can do to reduce the total size of your graphics, aside from using fewer
graphics? An obvious suggestion is not to make them any larger than they
need to be to get your point across. Since file size increases as the square
of each dimension, shrinking both height and width by half reduces the
file size by 75%.

The PhotoPlus Export Optimizer will greatly help you in reducing file
sizes as far as possible while maintaining image quality. For related
background material, be sure to consult the “Color concepts” and
“Optimizing images” sections of Chapter 7.

Formats for the Web
Here are some general notes on the principal file formats used for Web
pictures and animation—.GIF, .JPG, and .PNG—and details on the
options you’ll encounter in the PhotoPlus Export Optimizer.

� The details will make a lot more sense if you have the Export
Optimizer open. Try using Double or Quad view (see Chapter 3) for
side-by-side quality comparisons at different settings.

.GIF format
The .GIF (Graphics Interchange Format) file format is universally
supported in Web browsers for both static and animated Web graphics.
It’s a lossless format (there’s no image degradation) with excellent
compression but a limitation of 256 colors. Use it for non-photographic
images with sharp edges and geometrics—for example buttons, bursts,
decorative elements, and text graphics. It’s suitable for grayscale photos
as well.
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The .GIF format supports binary transparency. That is, any portion of the
image may be either fully opaque or fully transparent. Typically, this is
used to eliminate the box-shaped frame around the graphic that would
otherwise be present. Elements with rounded edges, such as characters or
shapes, preserve their contours over any background color or pattern.

If you’re producing transparent GIFs, try to avoid anti-aliasing and
feathering (i.e. turn them off in the Tool Properties tab). The semi-
transparency these functions impart may look fine in PhotoPlus, but
remember that .GIF wants “all or nothing.” Pixels that aren’t 100%
transparent will end up opaque, and the exported graphic will display
sharp or even ragged edges when viewed over a Web page background.

GIF is also a multi-part format, which means one file can store multiple
images. As such, it’s the preferred format for Web animations.

Recommended .GIF export settings
Format (Bits per pixel, Number of colors): 8-bit (256 colors) is the
only available setting for animations, and the maximum supported by the
format. For pictures, 4-bit (16-color) and 1-bit (2-color) exports are also
possible.

Dithering (None, Ordered, Error diffusion): Dithering schemes
substitute pixel patterns for original colors to preserve apparent
coloration when the actual number of colors in the image is being
reduced. Choose Ordered (not available for animations) for a more
regular dot pattern, and Error diffusion for a more adaptive dot pattern.

Palette (Web-safe, Optimized): Choose Optimized to let the PhotoPlus
export filter determine the best colors to apply, but without regard for
standard colors. ChooseWeb-safe to reduce the colors to only those
found in the 216-color palette used by Web browsers. This will ensure
that an image you place on a Web page won’t change its appearance
when viewed by users of most other systems or browsers.

GIF Options (Transparent, Interlaced): .GIF files support
transparency—one reason they’re commonly used over backgrounds on
Web pages. PhotoPlus gives you the option of exporting GIFs with or
without a transparent background. Check Transparent to turn clear
“checkerboard” regions of your graphic (those with no pixels or 0%
opacity) into transparent regions in the GIF. All other regions will
become opaque. If unchecked, transparent regions will become white.
Check Interlaced to use an image format that will display
“progressively” in a browser: first a low-quality image will display,
followed by an improved image as the complete GIF is loaded.
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.JPG format
The .JPG or JPEG (Joint Photographic Experts Group) file format, like
.GIF, is universally supported in Web browsers. Unlike .GIF, it encodes
24-bit images and is a lossy format (i.e. it discards some image
information) with variable compression settings. JPG is clearly the format
of choice for full-color photographic images. For “black and white” (256-
level, 8-bit grayscale) photos, it has no particular advantages over .GIF.

The unique aspect of exporting as a JPG is in fact the slider control you
use to choose one setting from 10 possible levels. At one end of the scale,
the export applies maximum compression and produces an extremely
small (but quite ugly) image. At the other end, there is effectively no loss
of quality, but file sizes are relatively much larger, although still compact
compared to BMPs, for example.

When choosing a quality setting for .JPG export, keep in mind the
number of times you expect to be re-exporting a particular image. A
photograph may look fine in the Export Optimizer the first time you
export it at .JPG level 6, but after several such saves, you’ll really see a
cumulative quality loss .

.PNG format
For Web graphics, the newer .PNG (Portable Network Graphics,
pronounced “ping”) format has a number of advantages over .GIF—the
main ones, from an artist’s perspective, being “lossless” 24-bit images
and support for variable transparency. Whereas .GIF supports simple
binary (“on-off”) transparency, .PNG allows up to 254 levels of partial
transparency for normal images. The image file includes an “alpha
channel” that directs pixels in the foreground image to merge with those
in a background image. Most commonly used with 24-bit images, anti-
aliasing creates the illusion of smooth curves by varying pixel colors-—
for rounded images that look good against any background, not just
against a white background. It’s especially useful for the small graphics
commonly used on Web pages, such as bullets and fancy text.

Photo images included on the PhotoPlus Resource CD-ROM) are stored
in .PNG format.
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HANDS ON: Making A Web Button
Making labeled buttons is a typical use for text in PhotoPlus. Here, we’re
going to make a simple “Stop sign” button.

The first step is to create a basic Background layer for the button.

� Choose New… from the File menu, or click the New button on the
Standard toolbar. (Then if the Startup Wizard is enabled, click on
Create New Picture.)

� In the New Image dialog, set the size to 600×600 pixels and specify a
white background.

This is much larger than the finished button will be, when saved as a .GIF
file, but it is much easier to work on a larger image. We’ll resize it just
before exporting as a .GIF.

� Click OK to create an empty image with a layer called
“Background.”

� Before going any further, choose Save As… from the File menu and
save the image as BUTTON.SPP.

The next step is to fill the background
with a plain color.

� Select a light blue foreground color
from the Colors tab (we suggest
R=168, G=245, B=255).

� Select the Flood Fill tool from the Tools toolbar and click on the
image to fill with the foreground color.

Now we’ll add a bevel effect to make the image look like a button. You
can’t apply Layer effects to the Background layer, so right-click on
“Background” on the Layers tab and choose Promote to Layer.
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� Choose Effects… from the Layers menu and
check Bevel and Emboss, then set an outer
bevel. Bearing in mind that the image will
eventually be reduced in size considerably,
increase the Opacity to 90 and the Blur to 20.

Next, we’ll add a graphical element. We’ll put this on its own layer, so
we need to add a new layer.

� On the Layers tab, right-click on “Layer 1” and
choose New…. In the dialog, name the layer
“Shape.”

� Change the foreground color to deep red, then
select the Polygon tool from the QuickShape Tools flyout.

� Draw a polygon shape. Adjust the left handle so the shape is
octagonal, with eight sides, and drag the top handle to rotate the
figure into a “stop sign” orientation. Then double-click inside the
figure to complete drawing the shape.

� Choose Effects… from the Layers menu and
check Bevel and Emboss, and this time set an
outer bevel with Opacity 75 and Blur 5.

Next, select White as the foreground color.

� Select the Text tool and click it on the image. In the Add Text
window, type the word “STOP” and format it as Arial, Bold, 72
points.

� Use the Deform tool to shrink or expand the word so it fills the
center of the octagon. (Or you can click the text with the Text tool
and use the Add Text box to adjust the pointsize.)

Finally, we’ll resize the image to a more suitable size for a Web button.

� To preserve the proportions of the bevel effect, chooseMerge All
from the Layers menu before resizing.

� Choose Image Size… from the Image menu and
resize the image to 50×50 pixels.

� Finally, choose Export Optimizer… from the
File menu and export the image as a .GIF after
checking the options.
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Producing Web Animations
Animation creates an illusion of motion or change by displaying a series
of still pictures, rapidly enough to fool the eye—or more accurately, the
brain. With PhotoPlus, it’s easy to create and edit images with multiple
frames, then export them as animated GIFs that a Web browser can play
back. You use exactly the same tools and interface as for creating
standard, multi-layer PhotoPlus images, with an extra tab window that
includes all the additional controls you need to set up frames, add special
effects, and preview the animation. Once you’re satisfied, use the Export
Optimizer to output to the .GIF file format.

The .GIF format is what makes Web animation possible, for a couple of
reasons. First, it’s universally supported by Web browsers. Second, it’s a
multi-part format, capable of encoding not just one image but multiple
images in the same file. A GIF animation player or Web browser can
display these images in sequence, in accordance with certain settings
(looping, frame delay, etc.) included in the file. The result—it moves!

PhotoPlus gives you the choice of either creating your animations from
scratch, then exporting to .GIF, or starting out by importing a .GIF
animation and then editing it. Either way, once PhotoPlus detects an
animation file, it switches on the Animation tab. If the image file is new,
you’ll see a single, blank frame, labeled “Frame 1.” If you’ve imported an
animation, the tab displays each frame separately. Animation files can
have one layer, or many (see below), but all their layers are standard
(transparent) layers; there’s no Background layer. (If you need to brush
up on the concept of layers, see Chapter 5.)

Layers and frames
Animations are defined by the Animation tab working together with the
Layers tab. Let’s look at a little animated GIF of a rotating spiral.

� Open the file SWIRL1.GIF in the PhotoPlus PROJECTS folder. When
the image opens, the Animation tab appears.

Notice the playback control buttons on the right, below the frames.
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� Click the Play button to preview the animation, and click

Stop to freeze it. Try the other playback buttons, while you’re at
it!

To display the Visual Reference topic describing the various features of the
Animation tab, click the button and then click anywhere on the tab.

Let’s examine the Swirl animation more closely. In this file (as in any
imported GIF animation) the individual frames each have been assigned
one layer in the PhotoPlus image.

On the Layers tab, the layer stack for this
animation corresponds nicely with the frame
sequence, with default names—in this case,
“Frame 1 of 6” through “Frame 6 of 6.”

� Select Frame 1 on the Animation tab.

Notice that on the Layers tab only the “Frame
1” layer is marked as shown, with an open-eye
button; the other layers are all hidden, with
closed-eye buttons.

� Now select Frame 2 on the Animation tab.

This time, only the “Frame 2” layer will be shown, and the rest will be
hidden. And so on with the other frames.

The above example, with its one-to-one correspondence between frames
and layers, is easy to grasp but deceptively simple. Don’t make the
mistake of thinking that a “frame” is just another name for a “layer.”
Frames in PhotoPlus are actually much more versatile!

Key point: A so-called “frame” is really just a particular state or
snapshot of the various layers in the image, in terms of three layer
properties:

1 Shown/Hidden: Which layers are shown and which are hidden

2 Position: The position of the contents of each “shown” layer

3 Opacity: The opacity setting of each “shown” layer

As you switch between frames, you are switching between states of the
image. In the simple example above, the six frames define six states in
terms of Property 1—each of the six frames defines a different layer as
“shown.” We could rearrange the stacking order of the layers, or rename
them—and the animation itself wouldn’t change.
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Thus, when you create a new frame on the Animation tab, you’re not
adding a new layer. The new frame merely enables you to define a new
state of the layers that already exist. Of course, you could go on and
create an additional layer, but then all your frames would need to take
that layer into account—in other words, hide it when it wasn’t needed.

HANDS ON: Follow the Bouncing Ball
To demonstrate single-layer animation, let’s create an example with a
bouncing ball—created with four frames but on just one layer. In this
animation, the four frames will define four states in terms of Property 2—
the position of the layer contents.

� Close the Swirl animation window (we’re done with it). To begin
creating a new animation, choose New… from the File menu. If the
Startup Wizard is enabled, click on Create New Animation to open
the New Image dialog. You’ll notice that the Animation option box
is checked.

� Specify dimensions (100x100 is fine), set the Background to
“Transparent,” and click OK.

A new, untitled image window will open, and the Animation tab will now
something look like this:

� For this project, make sure the Endless Loop button is down.

The Show/Hide Captions button should be up (captions
hidden) so that each frame’s image content is easier to see.
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� Working in the image window, choose the
“Ellipse” Shape tool and Ctrl-drag to draw a small,
dark circle at the left side of the square canvas.
(The color doesn’t matter, as long as it shows up.)
The new shape appears on its own layer. 

� Now click the New Frame button on the
Animation tab three times to add three clones of Frame 1.

� On the Animation tab, click on the second dot (Frame 2) to select it.
In the image window, choose the Move tool and (with nothing
selected) drag the whole layer so the ball is now at the top of the
canvas. When you release the mouse, you’ll see Frame 2 on the
Animation tab update to show the new “state” of the image.

� Click Frame 3 and drag the layer so the ball is at the right of the
window, and finally in Frame 4 put the ball at the bottom of the
window. The Animation tab will show the four frames like this:

� Click the Play button. Not bad for a few minutes’ work!

� If the animation runs too fast, you can increase the frame delay. Each
frame has its own delay factor, but here’s how to set one factor for
all frames. Just click all four frames while holding down the Shift
key (that selects them all), then enter the new number in the Frame
Delay box. Try playing the animation again.

� Click the Fixed Loop button and try entering a specific number of
repeats in the box. (The most common setting here would be “1,” for
example with a longer sequence that only needed to play once.)
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� We suggest that besides saving your creation as an .SPP file, you
also export it as a .GIF. You’ll notice that the Export Optimizer has a
special tab for previewing and setting final animation options before
exporting to the .GIF format. On the Optimizer’s main Options tab,
you can check or uncheck the Transparent box. Since this little
example has only an opaque dot on a clear background, it should
export well as a transparent animation.

� You can also choose Preview in Browser from the File menu to
preview your animation in your Web browser.

We’ll leave it to you to create another example, varying only opacity on a
single layer, perhaps some text (like “CLICK HERE”) blinking on and
off. Two frames could accomplish that—in one, the layer set to 0%
opacity, and in the other, to 100%.

Notes on animation

♦ In practice, you can use one, two, or even all three of the layer
properties when creating a given piece of animation. Just remember
that a separate layer is only required for each element that moves
independently, or each differently-drawn state of a given element.
An element that doesn’t change its shape or color, but merely moves
about or changes opacity (appears or disappears), can be animated on
a single layer.

♦ With a little forethought and sketching, you can figure out in advance
how many layers you’ll need. Then you can set up the image with the
right number of layers to begin with.

♦ To preserve layer properties, be sure to save the image in the native
PhotoPlus (.SPP) format. You can reopen an image you’ve exported
as a GIF, but it will have lost PhotoPlus layer properties like opacity
and position.

♦ Although .SPP animations and .SPP pictures share the same file
extension, there’s no direct conversion option—a file either has
animation properties, or it doesn’t. To convert an .SPP picture file to
an animation, or extract a single frame from an animation to a
picture, first create a new image window and then use conventional
copy/paste commands to copy elements and/or layers from one file to
the other.

♦ Use animations sparingly on Web pages. Like all attention grabbers,
they can lose their impact if overused. Also, animated .GIFs (because
of the additional image information) are substantially larger than a
static graphics, a consideration if you expect people to view your
pages over a slow Internet connection.
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♦ PhotoPlus also lets you export animations to the .AVI movie format
(for details, search “AVI” in the online help Index). AVIs are
suitable for specialized multimedia work, but are neither compact nor
universal enough for general use on Web pages.

Animation effects
You can turn a variety of PhotoPlus effects (as illustrated in the Effects
Gallery, plus Fade and Move) into animated transition sequences. The
process “in-betweens” or “morphs” a layer from a designated starting
frame to some end-state over a specified number of frames, creating one
new layer per frame. If you like, you can select a “Ping Pong” option that
includes a reverse transition so the final frame looks just like the first one.

The Fade effect steps the opacity of each frame in the sequence up or
down between the Start and End values, for a fade-in or fade-out. The
Move effect displaces the contents of the frame in a straight line between
designated Start and End positions. Note that objects on text or shape
layers can only use the Fade and Move effects. To use text or shapes with
one of the other animation effects, first merge the layer into a standard
layer, or convert it to a standard layer by right-clicking on the layer name
and choosing Render from the menu.

You can either have PhotoPlus create a sequence of new frames for the
effect (check Create as new frames) or you can create some empty
frames yourself and then generate the effect with the Create as new 
frames option unchecked. This will integrate the new layers into the
existing blank frames, beginning with the designated Start frame.

As a simple example, we’ll create a line that wriggles.

HANDS ON: Making Waves
� Create a new, transparent animation about 600×75 pixels.

� In the first frame, use the Line tool to draw a long, thick line the
whole width of the image.

� Click Effects… on the Animation tab.

� ChooseWave Filter from the Effects list to open the Wave Filter
controls.
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The dialog has two preview windows, the left-hand one for the Start and
the other for the End state of the transition. You can apply effect settings
to either or both states. We’re going to leave the straight line to start with,
define a wavy line as the end state, and have the animation cycle back to
the starting line.

� Click the right-hand (End Preview) window.

� Set the Intensity slider to 20, andWaves to 10. As starting values,
use “10” for the number of frames and also for the frame delay.
Check both the Create as new frames and Ping Pong boxes. The
dialog has its own Play and Stop buttons so you can preview the
effect in the End window.

� Click OK to create the effect. PhotoPlus adds one new layer to the
image for each new frame. Click the Play button and you’ll see the
animation unwind in the image window.

� Now you can save, export, and/or preview the sequence in a browser.

Image Slicing
Image slicing and image maps are two convenient ways to create
navigation bars and clickable graphics for Web pages. With image
slicing, a graphic is carved up into smaller graphics—each of which can
have its own link, like any Web graphic—and PhotoPlus saves the
sections as separate files when you export the image. The process also
exports HTML tags describing a table containing the separate graphics,
allowing a Web browser to reassemble them seamlessly. The result
appears as a single larger graphic, but with different regions linked to
different targets.

For example, this menubar graphic...
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...can be sliced into four separate graphics, each linked to a different Web
page.

The Image Slice tool lets you divide the image into sections, which can
be exported using the .GIF or .JPG format. You can specify alternate text
and URL links for each of the image sections individually.

Slicing an image

The Image Slice tool looks like a small, black-handled knife. When
it is selected, the cursor also changes to a small knife.

To slice an image horizontally (left to right) select the image slice tool
and left-click on the image. Shift-click to slice an image vertically (top to
bottom). Repeat as many times as necessary. Each click inserts a red slice
guide. You can move a guide up or down by dragging it, or delete a guide
by dragging it out of the image window.

To specify the alternate text and/or URL link for an image slice, right-
click it and enter the information into the dialog, then click OK.

When exporting a sliced image, check the Create Image Slices box on
the Export dialog. Specify a name and folder for the files as usual, and
choose either .GIF or .JPG as the export file type. We recommend using
.GIF for non-photographic images and .JPG for photo-quality images.

This will create multiple files in the specified folder, depending on how
many slices you have defined. There will be a series of image files (for
example, MYFILEH0V0.GIF, MYFILEH0V1.GIF, etc.) and a single
HTML file (for example, MYFILE.HTM). The HTML file contains the
tags for the set of image slices, ready to be pasted into the source code for
the Web page.
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Image Maps
Whereas image slicing subdivides an entire graphic into smaller graphics
and exports them separately, image maps consist of hotspots that you
draw with special tools over selected parts of an image. When a visitor
passes their mouse cursor over the hotspot, a small caption is displayed
and the pointer will change to a pointing hand. Clicking the mouse while
the cursor is over the hotspot will invoke a hyperlink to a specified URL.

You assign each hotspot its own target—for example, the URL of a Web
page. Hotspots aren’t attached to a particular image, but become part of a
larger “map” that gets exported along with an image and turns into
HTML code. It’s then up to you or your Web developer to embed the
image map code properly into the Web page.

Creating image maps by hand can be difficult and time-consuming, but
PhotoPlus makes it easy. The Image Map Tools flyout on the Standard
toolbar displays a flyout menu of tools for creating and editing image
maps.

There are four image map tools:

♦ The Selection tool, used to modify the area drawn with one of the
other tools and to actually set the image map properties;

♦ The Rectangle tool, used to draw a rectangular hotspot;

♦ The Circle tool, used to draw a circular hotspot;

♦ The Polygon tool, used to draw a polygonal hotspot.

Creating hotspots
To begin, click the Image Map Tools flyout and choose the Rectangle,
Ellipse, or Polygon tool. Use the tool to draw a hotspot on the active
layer. To draw a polygon, drag and release the mouse button to define
each line segment; double-click to close the polygon. Hotspot outlines
appear in red.

To edit a hotspot, click the Image Map Tools flyout and choose the
Selection tool. To resize the hotspot, drag from an edge. To move the
hotspot, drag from the center. Right-click the hotspot with the Selection
tool to delete it, set layer options, or access hotspot properties.
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In the Image Map dialog, enter the text which will pop up when the
cursor moves over the hotspot, and
the full URL for the hotspot to link
to. Previously-used URLs are saved
and can be selected from the drop-
down list by clicking on the arrow at
the end of the box.

Normally you will export the image for which you have created the
image map as a .GIF (for non-photographic images) or a .JPG (for
photographic images). We recommend that you use the Export Optimizer
(choose Export Optimizer… from the File menu) to compare the quality
and file size which results from various settings.

Make sure that the Create HTML for Image Maps box is checked in the
Export dialog, then click Save. This will create identically named .HTM
and image files. The HTML file contains the tags for the image map,
ready to be pasted into the source code for the Web page.

If you’re looking for a powerful yet easy-to-use tool for Web page
design, look no further than Serif PagePlus, which lets you create your
own Web site from scratch or with Web Page Wizards (using its Design
CD-ROM). PagePlus enables effortless, WYSIWYG Web page design—
and you can incorporate the animations, sliced images, and image maps
you’ve created with PhotoPlus.

Tutorial Resources
For more experience with the tools and techniques covered in this
chapter, we recommend these HTML-based tutorials on the PhotoPlus 8.0
Resource CD-ROM:

Try this tutorial... For practice with these tools and techniques...

Statuesque Instant Effects, Mesh Warp tool to create an animation

Buttonflies Multi-layer graphical buttons using QuickShapes, Image
Browser, Image Slice, Image Map tools
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This chapter ties together a variety of loose ends... mindful of the fact that
every PhotoPlus user will arrive with different needs and prior
experience. The other Companion chapters focus on step-by-step
procedures to build familiarity with tools and functions. Much of the
important theory that underlies the program’s workings has had to take a
back seat.

As you read through the topics here—all dealing in one way or another
with different ways of representing pictures as on-screen bits and bytes—
you’ll realize how indispensable these underlying concepts are. Although
this is the final chapter, it can make a good starting point, too.

Color Concepts
It’s always difficult to draw a line between concepts you should
understand before you get started, and those that can wait until you
absolutely need them. Here we’ve collected a few key terms and concepts
relating to color, and presented them roughly in order of priority, trying
to keep it simple without oversimplifying. So we suggest you just begin
at the beginning, and treat this as a reference section you can revisit at
any time.

Bitmaps
First of all, PhotoPlus is all of the following things and more: a “photo
editor,” a “paint program,” a “bitmap editor.” It lets you create
manipulate images called “bitmaps,” “paint-type” images,” or “raster
graphics.” Don’t be overwhelmed by the jargon—all these terms
communicate a single concept! Bitmaps (let’s settle on that term) are
digital pictures (which may or may not be photographs) represented by
lots of colored dots (“pixels”) on a computer screen (“raster”). You create
these images by “painting” or filling in regions on the screen, regions that
can be as small as a single pixel or as large as the whole screen (or
larger).
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Bit depth
A bitmap is basically a bunch (literally a “map”) of numbers that tell each
dot (pixel) on a computer monitor what color it should be. And since
computer numbers consist of binary digits (1’s and 0’s, or “bits”), each
pixel in effect has one or more bits backing it up, telling it what to do.
From this fact arises the concept of bit depth (also known as “pixel
depth”), one of the essential attributes of any bitmapped image. Bitmaps
not only have height and width, they have depth. The more bits assigned
to each pixel, the more possible color states the pixel can be told to
take—the greater its “color depth.”

For example: If you’re only using 1 bit per pixel, the pixel can only be
ON or OFF, in other words “1” or “0,” the two states of the bit—hence
white or black (monochrome). By comparison, a bit depth of 4 bits per
pixel can store 16 values; 8 bits per pixel, 256, and so on. 16-bit images
have roughly “thousands” of values to describe each pixel’s color, and
24-bit images have “millions.” Not
surprisingly, the file size of an image is
basically the product of its linear
dimensions (number of pixels) times its bit
depth, so a picture saved as a 24-bit image
would take up three times as much disk
space as an 8-bit version.

Of course, the appearance of a bitmap on a screen depends not only on
the bit depth of the picture but on that of the computer screen displaying
it. Just a few years ago (in the “old days”), many monitors were limited to
16 colors, and 256 was a big deal. There were “VGA” and “SVGA,” and
today the choices include “High Color” (16 bit) and “True Color.”

Just because you may have a higher-end system, don’t forget that many
others do not. A 24-bit image with millions of colors may look abysmal
on a 256-color monitor—a key consideration when it comes to creating
graphics for the Web, as opposed to CMYK separations for a print
publication. In print publishing, designers must worry about whether the
colors specified in their electronic images will produce “true” output
when reproduced in ink, under standard lighting conditions. In Web or
CD-ROM publishing, the main worry is how to optimize or reduce the
file size as far as possible, while maintaining some semblance of quality
in the image (more about optimizing below). Fortunately, PhotoPlus
includes tools to support all these needs.
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Bit depth in PhotoPlus
One of the main differences between PhotoPlus and most other paint
programs is that we’ve put aside the restrictive notion of working with a
limited number of colors. You can work on any image in 24-bit mode,
accessing the full color spectrum via the Color tab. Native format (.SPP)
images are stored in this mode. When and if the time comes to save in a
different format, and reduce colors, PhotoPlus provides the Export
Optimizer for maximum quality control.

While novices will appreciate the ease of use this approach brings, more
experienced users may at first need to adjust to the absence of color
swatches and the constraints of working in 256-color mode. Still, we’re
confident that the benefits of concentrating on image production first, and
color reduction last, will soon become apparent!

Tip: You can use the Open dialog to peruse images on your system one
at a time, or the Image Browser to display a folder-full of thumbnails at a
time. The Open dialog gives the bit depth and dimensions of each image,
while the browser shows dimensions (plus additional file data if you
right-click a thumbnail and choose Information...).

Resolution
Bitmaps are created at a fixed resolution, measured in dpi (dots per inch)
and hence lose quality if resized upwards. Resizing downwards is a
different matter, which is why it’s always a good idea to scan pictures at
higher dpi settings and scale down later (see the “Scanning Tips” section
later in this chapter). The reproduction quality of bitmaps can vary
dramatically, and depends on factors such as the dpi stored in the original
file, the dpi used for reproduction (printing), the bit depth, and the scaling
factor used in reproduction.

High resolution bitmaps compensate for quality problems, but tend to be
very large files.

Color modes
The PhotoPlus Color tab includes a control that lets you select one of four
color modes: RGB, CMYK, HSL, or Grayscale. You
should know something about these modes, even if you
only have occasion to work in one or two of them. Much
of the terminology overlaps. Let’s consider these, starting
with the simplest.
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A grayscale image looks like what we would call a “black and white”
photograph, which properly speaking has many levels of black and white
(not just two, as in a monochrome line drawing). On computers,
Grayscale mode stores 256 shades of gray or levels of lightness. A value
of 0 represents pure black, a value of 255 pure white. Sometimes we
speak of the “tones” in a grayscale image—it’s just another word for the
different “values” or “lightness levels.”

To understand HSL, imagine the difference between watching a TV
program on a black and white set as opposed to a color set. It’s the same
color signal, right? But the black and white set doesn’t reproduce the
color. What it does pick up is the grayscale or lightness channel of the
signal. In the same way, any color image in PhotoPlus has a channel that
stores lightness information. The “L” in HSL stands for Lightness. To
repeat—and this is important when it comes to understanding topics like
masking and blend modes—lightness and grayscale values (and for that
matter tones, luminance, and brightness) all refer to the same thing.

The additional Hue and Saturation channels in HSL mode together store
the color information that’s missing from a simple grayscale image. Like
Lightness/Grayscale values, Hue and Saturation channel values are
expressed in numbers, ranging from 0 to 255. (If you’re alert, you’ll note
that 256 is equivalent to 8 bits of information, so H+S+L has three 8-bit
channels totalling 24 bits—which is where the “24” in “24-bit” comes
from.

Hue refers to the color’s tint—what most of us think of as rainbow or
spectrum colors with name associations, like
“blue” or “magenta.” A color wheel (like the one
in the PhotoPlus Adjust Color dialog) is useful for
representing the spectrum of hues as a continuous
cycle, like a clock. The hue “red” is arbitrarily
assigned the value 0 at a certain position, and the
values run around the circle. Saturation describes
the color’s purity—a totally unsaturated image has only grays.
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RGB mode is much less intuitive than HSL as a method of mixing colors,
but it’s the standard way of describing colors the way they’re displayed
on computer monitors—as mixtures of separate Red, Green, and Blue
components. Anyone who’s seen (in school, perhaps) a demonstration of
three projector beams in a dark room, one of each color, merging to
produce a pool of white light, has seen a primitive version of the RGB
system. Turn all the elements off and you get black. On computers, as
with the HSL system, 8 bits are used to encode each of the three
channels, for a total of 24 bits, and with 256 possible levels (0-255) for
each channel. An RGB value of “0,0,0” represents pure black, while a
value of “255,255,255” represents pure white.

To quickly get a feel for the HSL and RGB color mode variables, double-
click either the foreground or background color swatch on the Color tab
and try mixing your own colors using the Adjust Color dialog. (See
online help for details.)

Finally, CMYK is a color model used for preparing printed work, where
ink on paper is the medium that determines color reproduction. It’s based
on the “subtractive” principle by which our perception of a pigment’s
color depends on the light wavelengths it absorbs and reflects. Traditional
process color printing creates colors by mixing inks and absorbing light,
so that your eyes can mix the reflected light.

The four process inks are Cyan, Magenta, Yellow, and Black (Black is
referred to as Key). Mix the four process inks, and you get black. No ink
gives you white (or the color of the paper). In PhotoPlus, the C, M, Y,
and K channel values are given as percentages, from 0 to 100%.
PhotoPlus supports CMYK output of process color separations (see the
section later in this chapter).

Color mode tips

♦ The color mode setting (on the Color tab) determines how image
data gets pasted from the Windows Clipboard—in other words, as
grayscale values in Grayscale mode, or as full 24-bit color in any of
the other modes.

♦ If you start editing a layer mask (which represents opacity values by
shades of gray), the Color tab switches temporarily to Grayscale
mode. Applying the Image/Adjust/Grayscale filter or equivalent
adjustment layer, however, doesn’t affect the color mode.
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♦ You can use the Color Pickup tool as a probe to read component
values in an image. Move the tool around the image and watch the
HintLine. Depending on the color mode, you’ll see a readout of
values (R, G, B, H, S, L, O, etc.) under the current cursor position.
By the way, the “O” represents Opacity.

Optimizing Images
In a perfect world, there would be just one digital picture format that
everybody used. Infinite storage capacity and bandwidth would allow
full-color images to be stored and transmitted instantly, uncompressed...
but let’s leave that for a sci-fi novel! The reality is that at least hundreds
of picture formats have been created, with more ever on the way. A dozen
or so are currently in widespread use among computer professionals. The
tradeoff between image quality and file size will remain a fact of life.
Hence the need to optimize images—that is, achieve the best quality in
the least file size, and within whatever other contstraints (such as number
of colors) the job may impose.

PhotoPlus features a powerful Export Optimizer (introduced in Chapter
2) that serves as your “command center” for exporting images to various
formats. It not only provides a variety of options for each supported
format, but lets you compare image quality using different settings and
even retains your preferred settings for each format. You can access the
Export Optimizer at any time—not just at export time—to take advantage
of its compararison capabilities. While the visual comparisons speak for
themselves, some of the available settings may need some explanation.

Palettes
The PhotoPlus Export Optimizer offers two standard Palette options
when you export using 8 bits or less. A color palette (no relation to a
“floating” palette) is a table of color values that gets stored with any
image having 256 colors or less. This could mean a .BMP, .GIF, .PCX, or
.WMF image—plus quite a few more. Computer users with high-color
monitors may not give it much thought, but in the realm of 256-color
displays, palettes can make a great deal of difference. Windows itself
reserves “slots” for its own “system” colors, and each application must
“declare” a palette while the graphics system tries to ensure peaceful
coexistence. When several colorful applications are in use, and you
switch from one you another, you sometimes see the ghastly result of
palettes clashing as neither application wants to relinquish its hold on a
scarce system resource.
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To avoid that kind of calamity when displaying Web pages, both
Netscape and Microsoft browsers use the same Web-safe palette of 216
colors to display images. Since you’ve gotten this far, you may be
interested to know that the Web-safe palette is based on RGB values that
are either 0, or divisible by 51. Permissible values are in the series 0, 51,
102, 153, 204, 255. So, for example, the RGB definition “0,102,51”
would be a safe Web color, while “0,102,52” would not.

If you’re exporting at 256 colors or less, and Web display is not an issue,
there’s no question you should choose the Optimized setting—as a quick
side-by-side comparison in the preview window will always confirm. The
program will always do a better job when it’s allowed to select a range of
color values that best match those in the 24-bit version, rather than
having to apply the same 216 colors every time.

Note: When you open an image that already has an associated palette,
PhotoPlus doesn’t attempt to hold on to the palette—it always re-optimizes,
even if you use the Save Original command. Usually this yields the best
possible results; but if keeping exactly the same image palette is essential to
your particular application, our advice would be to export from PhotoPlus in
24-bit mode and use a third-party program to apply the palette.

Dithering
Dithering (not to be confused with “showing flustered excitement or
fear”) comes into play with images being reduced to 256 colors or less.
It’s a method of approximating colors outside the actual image palette—
for example, by alternating pixels of red and blue from within the palette
to produce the visual impression of a purple color that’s not in the palette.
Applications (including Web browsers) use dithering in 256-color mode
if the images being displayed include colors outside the application
palette. This can degrade solid-color areas and is one of the main reasons
to export Web-bound images using the Web-safe palette.

When you’re exporting to 256 colors or less, PhotoPlus lets you choose
whether or not to use dithering. If you have an image with few colors,
and preserving areas of solid color is essential, you should opt for no
dithering—and the export filter will pick “nearest-match” color values
from the palette being applied. You may see some color shifting, but the
solid color areas will be preserved. For photographic images, on the other
hand, dithering is clearly the best choice. With the “optimized palette”
option, you can choose either ordered or error diffusion dithering. The
former produces a discernably patterned effect, while the latter tends to
average away the patterns for a more natural result.
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Compression
Compression schemes, which apply different algorithms to encode the
image information with fewer total bits and bytes, are used in many
formats. With some, like .BMP and .TIF, the Export Optimizer gives you
a choice of compression scheme. In general, use the default setting unless
you know for a fact that some other scheme is called for.

The .JPG format, widely used for photographs (and detailed in Chapter
6), is unusual in that you can set the level of quality desired using a
slider. As you might expect, the highest-quality setting uses least
compression, with no loss of image quality but the largest file size. The
lowest-quality setting applies maximum compression for smallest size,
but yields rather poor quality. With the aid of the Export Optimizer, you
can judge for yourself—but another factor to keep in mind is the number
of times you expect to be re-exporting a particular image. A photograph
may look fine the first time you export it at JPG level 6, but after several
such saves, you’ll really see the quality loss. As a rule, keep images in the
native .SPP format, or export them using only lossless compression
schemes, until it’s time for the final export.

File Formats
PhotoPlus can import and export most types of graphics file which you’re
likely to encounter. In order to use PhotoPlus images in other programs,
you will have to export them into one of the widely used formats.

For pictures and animations intended for use on the World Wide Web, the
two prevalent formats are .GIF (for both) and .JPG (just for photos). A
newer format, .PNG, affords excellent compression and variable
transparency but older browsers may not support it. See Chapter 6 for
details on Web format features and options. (PhotoPlus also lets you
export animations to the .AVI movie format.)

For print use, we recommend that you use .TIF or .BMP as most other
programs allow you to import files in that format.
If you’re exporting an image so that it can be used in four-color process
printing, be sure to enable the CMYK option in the Export Optimizer.
The other export formats use the RGB color model (see the section on
“Color modes” earlier in this chapter), which is not suitable for use in
process printing.
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The .WMF metafile format used by Windows can include bitmap data,
vector data, or both (in vector images the picture is stored compactly as a
set of lines). To generate vector information for scalable images you can
work with in a draw program, choose the Autotraced Metafile export
option (available only as an add-on with the PhotoPlus Resource CD-
ROM). PhotoPlus processes the image and includes traced vector data in
the output file.

Tips for Scanning
Scanning hardware and software varies considerably. One myth is that
the higher the resolution of your scanner, the better results you’ll achieve.
While that’s true in theory, the real limit to quality is how the image will
ultimately be reproduced. Will it end up on the printed page or on-screen?
Either way, the real issue is how many “extra pixels” you’ll need in the
original scan.

If the image will be professionally printed, will that be onto a sheet of
newsprint or a glossy coated stock? Paper itself puts a ceiling on
reproduction quality. Lower-grade paper tends to spread ink around more
easily, so the dots of ink used to print a picture need to be larger. This
means a wider halftone screen with fewer lines per inch (lpi).

If you’ll generate your output on a desktop printer, the device will be
putting bits of toner or droplets of ink on the paper. On a laser printer,
shades of gray result from variations in toner coverage. Desktop color
printers create color by laying down dots of cyan, magenta, yellow, and
black ink. Again, printer resolution and paper type are quite variable. Dpi
(dots per inch) is the most common measure of print quality. But the
lines per inch, based on halftone reproduction, is equally useful. A print
resolution of 600 dpi corresponds to about 100 lpi.

♦ As a general rule, the optimal scanning resolution for print work (in
dpi) is about one-third the dpi setting (i.e. twice the resultant lpi) on
the printer or other device that will be used. 200 dpi scanning is fine
for most printed output

Or will your image end up on-screen instead of in print? If so, it will no
doubt be viewed at standard screen resolution of 96 dpi. (That’s why this
is the default resolution in PhotoPlus.) If you’re producing Web images,
it makes more sense to regard resolution as a fixed factor, and think in
terms of image dimensions instead.
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This means that, for an image that will end up on a Web page, it’s just
possible you can get great results scanning at 100dpi, at exactly the
screen dimensions you need. But that’s cutting it close, especially if
you’ll be editing the image at all.

For either print or screen images, you must always take into account what
kinds of manipulations you plan to carry out on the image in your photo
editor, i.e. PhotoPlus. Color adjustments, resizing (with resampling),
blurring, and other effects tend to disturb the arrangement of pixels in the
original scanned image. So let’s add another guideline:

♦ If preserving detail is a consideration—as it almost always is—and
you plan to manipulate the image, then give yourself enough pixels
to work with! Scan at a higher resolution (or higher size) and scale
the image down later.

Of course, file size and the capacity of your system are also factors in
choosing scanner settings. It makes little sense to work slowly on a
20MB file, if you’d get the same final quality working quickly with a
5MB file.

Depending on your scanner software, your may be able to perform initial
adjustments right at the source. For example, you can use the controls to
get a true black on one end and true white on the other. Often you can de-
screen images to eliminate possible moiré patterns (interference
between the regular dot patterns in printed images and the scanner’s
path).

♦ If your scanner software doesn’t provide de-screening, try using the
PhotoPlus Gaussian Blur filter to remove moiré. Make sure you’ve
scanned at higher resolution (or size) so that you can then scale down
the image to regain detail.

Some other tips:

♦ If you’re scanning a number of pictures, you may find it’s faster to
save scanned images to disk rather than bringing them directly into
PhotoPlus.

♦ In PhotoPlus, you can rotate an image if necessary to correct for any
mis-alignment in the scan, then crop to remove any unwanted border
pixels. Use the Brightness/Contrast, Hue/Saturation/Lightness,
Gamma, Equalization, and/or Stretch adjustments to improve
image quality.
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Advanced Printing
Click the Options… button from the Print dialog to access additional
printer settings.

Scaling and tiling
The Layout tab is where you can specify Scaling and Tiling options.

Scaling is usually set to 100%, but you might reduce it to proof a large
image on one page or increase it to blow up a small image to fit a whole
page. Choose the Reduce to fit option to make sure that your image will
fit on the page.

Tiling allows you to print a large image on several sheets to be stuck
together later.

The Preview area shows where on the page the image will be printed. It
changes according to whether the printer driver is set to portrait (wide) or
landscape (tall) orientation.

After specifying options, click one of the other tabs to set more options,
or click OK to return to the main Print dialog and save any changes.
Click Cancel to abandon changes.

Including printer marks
On the Output tab, you can specify whether the program is to print
various marks as well as the image.
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Marks and file information can only be printed if the physical paper size
is one inch or more larger all round than the image.

After specifying options, click one of the other tabs to set more options,
or click OK to return to the main Print dialog and save any changes.
Click Cancel to abandon changes.

CMYK color separations
An offset press needs one independent plate for each color that will print
on the job. PhotoPlus will let you choose to print either a composite copy
or color separations which are used when printing the job to an
imagesetter.

If the job is created properly, you then get, for each page, one complete
negative for each color. If you were working on a flyer, you could print
out a composite copy on your laser or ink jet printer which would give
you one piece of paper with the whole flyer, or seps, which would give
you four sheets of paper.

The Separations tab controls the printing of color separations.
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If you are using a PostScript® output device, checking the Print 
Separations box on the Separations tab allows you to choose whether to
print separations for process printing and if selected, which separations to
print. This box will be grayed out if you are not using a PostScript®
printer driver.

Normally, separations are not enabled. On a color printer (e.g. an ink jet),
if separations are not enabled you will get a single composite color page
and on a mono printer (e.g. a laser printer) it will give a single grayscale
page.

After specifying options, click one of the other tabs to set more options,
or click OK to return to the main Print dialog and save any changes.
Click Cancel to abandon changes.

PhotoPlus as an OLE Server
Finally, PhotoPlus can act as an OLE server. This means that you can
embed PhotoPlus images as objects in other programs, such as Serif
PagePlus, then just double-click them for editing using the PhotoPlus
tools.
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To embed a PhotoPlus object into a document in another program (in this
case PagePlus), copy the image to the Clipboard by choosing Copy 
Merged (or Copy, for single-
layer images) from the Edit
menu.

Switch to the other program
and choose Paste Special…
from its Edit menu. The
cursor will change to the
insert picture cursor. Click
once to insert the image.

Tutorial Resources
For more experience with the tools and techniques covered in this
chapter, we recommend these HTML-based tutorials on the PhotoPlus 8.0
Resource CD-ROM:

Try this tutorial... For practice with these tools and techniques...

Exploring Color 
Spaces 

Color modes: RGB and HSL

Image Formats Choices in the Image Optimizer



PhotoPlus Keyboard Shortcuts

Tool shortcuts
Press... With... To...

Shift  ------- ------- Selection tools Add to current selection

 Alt  ------- Selection tools Subtract from current selection

  Ctrl  Selection tools Move selection contents

 Alt  Ctrl  Selection tools Duplicate selection contents

 Alt  ------- Move tool Duplicate selection contents

  Ctrl  Adjustable
Selection tools, Crop

tool, QuickShape tools,
Image Map rectangle

Constrain aspect ratio when
dragging to define shape or
region

Shift    Straight Outline tool Constrain to 15° angle intervals

 Alt  ------- Text, Paintbrush,
Airbrush, Fill, Outline,

QuickShape tools

Left-click to pick up foreground
color; right-click to pick up
background color

Shift  ------- ------- Clone tool Define pickup origin point

Shift  ------- ------- Deform tool, Deform
Mesh tool, Shape Edit

tool

Drag center to constrain rotation
to 15° angle intervals

Shift  ------- ------- as above Drag corner handle to constrain
aspect ratio

 Alt  ------- as above Drag corner handle to resize
relative to fixed point

Shift  Alt  ------- as above Drag corner handle to resize
relative to fixed point while
constraining aspect ratio

  Ctrl  as above Drag corner handle to skew

Shift  Alt  Ctrl  as above Drag corner handle to change
perspective



Menu command shortcuts
Press... With... To...

  Ctrl  Z Undo last action

  Ctrl  Y Redo last undone action

  Ctrl  L  Paste from Clipboard as new layer

Shift  ------- Ctrl  L  Paste from Clipboard into selection

  Ctrl  C Copy selection or layer to Clipboard

Shift  ------- Ctrl  C Copy merged (all layers as one layer) to
Clipboard

  Ctrl  X Cut selection to Clipboard

  Ctrl  V Paste from Clipboard as new image

  Ctrl  D Deselect pixels

Shift  ------- Ctrl  I  Invert selection

  Ctrl  A Select all

  Ctrl  N New image

  Ctrl  O Open file

  Ctrl  P Print

  Ctrl  S Save

  Ctrl  Tab Switch between image windows

  Ctrl  F4 Close current image window

 Alt  ------- F4 Close PhotoPlus

 Alt  ------- ------- Activate menus

   Tab Hide/show active tab windows
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A
active layer, 63, 95
Add Mask command, 110
Add Text window, 34, 86, 99
Adjust Color dialog, 62, 86
Adjustable Selection tools, 36
adjustment filters. See filters
adjustment layers, 49, 109
Airbrush tool, 67
aligning layers and shapes, 75, 96
animation

.GIF format for Web, 118, 122
creating, 122
effects, 127

Animation tab, 21, 122
anti-aliasing, 76, 86, 118
arranging layers, 96
arrow

drawing, 75
selecting shape, 36

artistic effects, 53
aspect ratio, constraining, 36, 75
autotraced metafile, 143
AVI file format, 127

B
background color, 14, 33, 61, 68, 105
Background Eraser tool, 69
Background layer. See layers
Bevel (effect filter), 89, 121
bit depth, 118, 136
bitmap, 135
blend modes, 49, 57, 66, 89, 94, 97, 102,

103, 138
blur filters. See filters
Blur tool, 72
box, drawing, 75
Brightness/Contrast (adjustment filter),

32, 47
browser, previewing images in, 126
Brush Tip tab, 13, 20, 64
brush tips, creating custom, 65
Bump Map (layer effect), 103

C
canvas, resizing, 13, 41, 57, 121
captions, adding, 31, 33
Channel Mixer (adjustment filter), 48,

56
circle

drawing, 75
placing hotspot, 130
selecting shape, 36

Clipboard operations, 41, 96, 139
Clone tool, 72
CMYK

color separations, 146
mode, 62, 139
Selective Color filter, 48

Color Balance (adjustment filter), 47
Color Pickup tool, 62, 140
Color Selection tool, 38
Color tab, 14, 21, 33, 61
colors

adjusting, 47
choosing, 33, 62
colorizing images, 56
key colors in gradient, 82
modes, 62, 137
palettes, 140
replacing, 48
separations, 146
theory, 135
wheel, 138
Windows system, 140

combination options
for selection, 38
for shapes, 74

compression, 117, 119, 142
Conical (gradient fill type), 80
Context Help button, 27, 63
contrast, adjusting, 32, 47
Copy command, 41, 96, 148
Copy Merged command, 148
Create HTML for Image Maps setting,

131
Create Image Slices setting, 129
Crop to Selection command, 31, 42



Crop tool, 31, 41
Curved Outline tool, 77
Curves (adjustment filter), 47
custom filters, 50
Cut command, 41, 96

D
Deform tool, 43
Delete command, 41
Delete Mask command, 111
depth maps, 104
Deselect command, 39
diameter (of brush), 65
digital camera (TWAIN) input, 24
Disable Mask command, 111
distortion filters. See filters
dithering, 118, 141
dpi (dots per inch), 137, 143
drag and drop, 24
drawing. See also tools

hotspots (image maps), 130
lines, 64, 76
shapes, 75

drawing tablet, 65, 66
Drop Shadow effect, 102
Duplicate Layer command, 95
duplicating a selection, 41

E
edge filters. See filters
Edit Mask mode, 110
Edit tools, 77, 84
effect filters. See filters
Effects Gallery, 48, 50, 97, 102, 127
Elastic Warp tool, 70
ellipse

drawing, 75
selecting shape, 36

Emboss (effect filter), 51
Enhance Edges (effect filter), 52
Equalization (adjustment filter), 48
Eraser tools, 68
Export Optimizer, 16, 25, 126, 140
exporting files, 16, 25

animation, 126
image maps, 131
image slices, 129
optimization, 140

Extract command, 37, 101

F
Fade effect (animation), 127
Fade property, 66
feathering, 39, 112, 118
features, key, 6
file formats

.AVI, 127

.GIF, 117

.JPG, 119

.PNG, 119

.SPP, 16, 25, 94, 109, 126, 137

.WMF, 143
for Web graphics, 117

Fill tools
Flood, 79
Gradient, 79

filters
Bevel, 89, 121
blur, 51, 52
Brightness/Contrast, 32, 47
Channel Mixer, 48, 56
Color Balance, 47
Curves, 47
custom, 50
edge, 52
effects, 50
Emboss, 51
Equalization, 48
Gaussian Blur, 144
Gradient Map, 48
Grayscale, 48, 56
Hue/Saturation/Lightness, 48, 52, 56
Levels, 47
Median, 50
Negative Image, 48
plug-in, 22
Posterize, 52
Red Eye, 55
Replace Color, 48
Selective Color, 48
Stretch, 48
Threshold, 48
Unsharp Mask, 50
Wave, 127

flattening an image, 35, 97
Flip command, 42
Flood Eraser tool, 69



Flood Fill tool, 57, 79
fonts, bonus TrueType, 87
foreground color, 14, 33, 61, 64, 66, 67,

75, 79, 80, 105
formatting text, 86
frames (animation), 123
Freehand Outline tool, 76

G
Gaussian Blur (effect filter), 52, 144
GIF file format, 117
GIF options (when exporting), 118
Gradient Fill tool, 79
Gradient Map (adjustment filter), 48
Grayscale (adjustment filter), 48, 56
Grayscale mode, 62, 105, 110, 138, 139
Grow Selection command, 39
guides, 64

H
halftone screen, 143
hardness (of brush), 65
heart, selecting shape, 36
help, getting in PhotoPlus, 27
HintLine, 27, 43, 140
hotspots (for image maps), 130
HSL mode, 62, 138
HTML

for image maps, 131
for image slices, 129

hue, defined, 138
Hue/Saturation/Lightness (adjustment

filter), 48, 52, 56
hyperlinks

for image maps, 131
for image slices, 129

I
Image Browser, 23
image formats. See file formats
Image Map tools, 130
Image Slice tool, 129
importing from TWAIN source, 24
installation, 9
Instant Artist effects, 53

Instant Effects tab, 21, 51, 103
Invert Selection command, 39

J
JPEG (.JPG) file format, 119

K
key colors, 82

L
layers, 14, 93

active layer, 15, 63, 95
adjustment layers, 49, 109
aligning, 96
and animation frames, 123, 126
arranging, 96
Background layer, 14, 24, 41, 42, 52,

61, 63, 68, 80, 93, 94, 95, 96, 97,
102, 109

blend modes, 97
Clipboard operations, 96
creating, 56, 63, 95
deleting, 95
depth maps, 104
hiding and showing, 95
layer effects, 51, 102
linking and unlinking, 96
merging, 97
moving, 96
opacity, 42, 123
Promote to Layer, 42, 95, 120
protecting, 95
shape layers, 15, 74, 79, 127
standard layers, 15, 93
text layers, 15, 34, 79, 86, 127

Layers tab, 21, 93, 96, 122
Levels (adjustment filter), 47
lighting (render) filters. See filters
lightness

adjusting, 48
defined, 138

Linear (gradient fill type), 80
looping (animation), 124, 125
lpi (lines per inch), 143



M
manipulating photos, 31, 51, 53, 56
marquee, 14, 36, 37, 38, 39, 40, 41, 42,

63, 85
masking, 109
Median, 50
Merge command (layers), 97
Merge Mask command, 111
Mesh toolbar, 45
Mesh Warp tool, 45
metafiles, 143
moiré patterns, 144
monochrome, 136, 138
montage, creating, 98
Move effect (animation), 127
Move Marquee cursor, 38, 40
Move tool, 35, 40, 96

N
Navigator tab, 21, 23
Negative Image (adjustment filter), 48
New Frame button, 125
Node Edit tool, 78
noise filters. See filters

O
OLE, PhotoPlus as server, 147
opacity, 15, 42, 65, 66, 68, 82, 94, 111,

123
opening an existing file, 23
optimizing images, 140
Outline tools, 74, 84
oval, drawing, 75

P
Paint to Select mode, 40
Paintbrush tool, 64
painting. See tools
palette, Web-safe, 118, 141
palettes, color, 118, 140
Pan tool, 23
Paste command, 41, 86, 89, 96
paths, 83
Paths tab, 20, 84
Pattern Map (layer effect), 103
PhotoPlus

.SPP file format, 16, 25, 84, 94, 109,
126, 137

bonus TrueType fonts, 87
key concepts, 13
key features, 6
Resource CD-ROM, 23, 28, 119, 143
shortcuts, 149

Picture Brush tool, 67
picture tubes (Paint Shop Pro), 65
pie, selecting shape, 36
Ping Pong (animation), 127
pixels, 13, 38, 40, 71, 79, 94, 135
plug-in filters, 22
PNG file format, 119
polygon

drawing, 75
placing hotspot, 130

Posterize (effect filter), 52
preferences, setting, 22, 32
Preview in Browser command, 126
printer marks, including, 145
printing, 27, 145
Promote to Layer command, 42, 95, 120
properties, setting for tools, 65
Protect Transparency, 95

Q
quality

adjustments for, 144
in exported images, 119
in exported images, 117

QuickShape tools, 74, 75, 84, 121

R
Radial (gradient fill type), 80
raster, 73
rectangle

drawing, 75
placing hotspot, 130
selecting shape, 36

Red eye, removing from photo, 55
Reduce to fit option, 145
registration, 9
Render command, 75, 86, 127
render filters. See filters
Replace Color (adjustment filter), 48
resizing, 13, 41, 57
resolution, 137, 143



Resource CD-ROM, 23, 28, 119, 143
retouching photos, 71
RGB mode, 62, 139
Rotate command, 42

S
saturation

adjusting, 48
defined, 138

saving files, 16, 25, 141
scaling, 145
scanning, 24, 143
Select Similar command, 39
selection, 14, 35

creating, 35
deselecting, 39
duplicating, 40
feathering, 112
from mask, 111
inverting, 39
modifying, 38
Paint to Select mode, 40
resizing, 43
rotating, 43
Text Selection tool, 87
to and from path, 84
variable, 39

Selective Color (adjustment filter), 48
separations, CMYK color, 146
sepia tone, adding to photo, 56
Shape Edit tool, 77
shape layers, 74, 79, 127
shapes

aligning, 75
Sharpen tool, 72
shortcuts, table of, 149
Smudge tool, 71
Soften filter, 52
Solid (fill type), 80
solid fill. See flood fill
special effects filters. See filters
spiral, selecting shape, 36
SPP file format, 16, 25, 84, 94, 109, 126,

137
square

drawing, 75
selecting shape, 36

Square (gradient fill type), 80
Standard Selection tools, 36, 42
Standard toolbar, 20
star

drawing, 75
selecting shape, 36

Starting PhotoPlus, 16
Startup Wizard, 17
Straight Outline tool, 76
Stretch (adjustment filter), 48
stroking a path, 84
support, technical, 9
system requirements, 9

T
tab windows, 13

Animation tab, 21, 122
Brush Tip tab, 13, 20, 64
Color tab, 14, 21, 33, 61
docking and undocking, 19
Instant Effects tab, 21, 103
Layers tab, 21, 93, 96, 122
Navigator tab, 21, 23
Paths tab, 20, 84
Tool Properties tab, 13, 20, 37, 38,

64, 65, 67, 68, 69, 71, 73, 74, 76,
78, 79, 80, 118

Undo History tab, 32
technical support, 9
text

adding, 34, 86
creating selection in shape of, 87
deforming, 44
editing, 86

text layers, 79, 86, 127
Text Selection tool, 87
Text tool, 34, 86
Thick/Thin Warp tool, 70
Threshold (adjustment filter), 48
Threshold command, 39
tiling, 145
tolerance setting, 38, 55, 79
Tool Properties tab, 13, 20, 37, 38, 64,

65, 67, 68, 69, 71, 73, 74, 76, 78, 79,
80, 118

toolbars
Mesh, 45



Standard, 20
Tools, 13, 20

tools, 13
Adjustable Selection tools, 36
Airbrush tool, 67
Blur tool, 72
Clone tool, 72
Color Pickup tool, 62, 140
Color Selection tool, 38
Crop tool, 31, 41
Curved Outline tool, 77
Deform tool, 43
Eraser tools, 68
Flood Fill tool, 57, 79
Freehand Outline tool, 76
Gradient Fill tool, 79
Image Map tools, 130
Image Slice tool, 129
Mesh Warp tool, 45
Move tool, 35, 40, 96
Node Edit tool, 78
Paintbrush tool, 64
Picture Brush tool, 67
QuickShape tools, 121
Shape Edit tool, 77
Sharpen tool, 72
Smudge tool, 71
Standard Selection tools, 36, 42
Straight Outline tool, 76
Text Selection tool, 87
Text tool, 86
Warp tools, 69

Tools toolbar, 13, 20
transparency. See also opacity

in exported images, 118, 119
tutorials, 28
TWAIN input, 24

U
Undo options, 32, 71
Unsharp Mask, 50
URLs

for image maps, 131
for image slices, 129

V
vector, 73
View Mask setting, 111
view, setting, 22
vignetting, 112

W
Warp tools, 69
Wave (effect filter), 127
wave, selecting shape, 36
Web images

animations, 122
file formats for, 117
performance issues, 117
previewing in browser, 126
Web-safe palette, 118, 141

weight (line thickness), 76
Windows system colors, 140
WMF file format, 143

Z
Zoom tool, 22
zoom view, setting, 22




