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About WinChart Command

The About WinChart command opens a dialog box with the program version number and copyright date, 
and contains icons that you click for information about other Micrografx products.



About WinChart Dialog Box

The About WinChart dialog box contains the program version number and copyright date, and contains 
icons that you click for information about other Micrografx products.



Learning Windows Basics

Click an entry to learn more about it.

Adding a Window
Choosing Menus and Commands
Choosing Options in a Dialog Box
Closing WinChart
Maximizing and Restoring a Window
Minimizing and Restoring a Window
Moving in a Dialog Box
Moving Windows and Icons
Resizing Windows
Switching Among Application Windows



Choosing Menus and Commands

Commands in WinChart are organized in menus on the menu bar.

An inactive command appears gray in the menu. You may have to select something in the window before 
the command is active. For example, you have to select data in the Worksheet before you can create a 
chart.

To open a menu with the mouse:

· Move the pointer to the menu title and click Button 1. The menu remains open until you choose a 
command or click Button 1.

To choose a command with the mouse:

1. Open the menu.
2. Point to a command and click Button 1.

To open a menu with the keyboard:

1. Press and hold Alt.
2. Press the Spacebar. The Control menu opens.
3. Release Alt. The menu remains on the screen.
4. Press Right Arrow. The File menu on the menu bar opens.
5. Press Right Arrow again. The Edit menu opens. (The Left Arrow key displays menus to the left.)
6. Press Esc to close the menu without choosing a command.

Shortcut: Press Alt and the underlined letter of the menu title to open a menu. For example, Alt+F opens 
the File menu.

To choose a command with the keyboard:

1. Open the menu.
2. Press the Down Arrow to highlight the command you want.
3. Press Enter.

Shortcut: Press Alt and the underlined letter of the menu, followed by the underlined letter of the 
command, to execute the command. For example, press Alt+F and then N to execute the New command 
in the File menu.



Choosing Options in a Dialog Box

Options in a dialog box have square check boxes or round option buttons. In a group of options with 
square check boxes, you can select several options at the same time. In a group of options with round 
option buttons, you can select only one option at a time.

To choose an option with the mouse:

· Point to the option you want and click Button 1. Click again to deselect the option.

To choose an option with the keyboard:

1. Press Tab to move to the option area you want. Press Shift+Tab to move in the reverse direction 
in the dialog box.

2. Press the Arrow keys to move among options within the area.
3. Press the Spacebar to select an option.



Maximizing a Window

You can enlarge a window to cover the entire screen.

To maximize a window with the mouse:

· Click the Maximize box (containing the up arrow) in the upper right corner of the window. The 
window fills the entire screen.

To maximize a window with the keyboard:

1. Press Alt+Spacebar to open the Control menu.
2. Press X for the Maximize command. The window fills the entire screen.



Minimizing a Window

When you minimize a window, it becomes an icon. The icon then appears at the bottom of the screen. 
You can remove WinChart from the screen, but keep it in memory, by minimizing its window. Then, when 
you want to work in WinChart again, bring it back on screen by restoring the window.

When you minimize a window, another window becomes active.

To minimize a window with the mouse:

· Click the Minimize box (containing the down arrow) in the upper right corner of the window.

To minimize a window with the keyboard:

· Press Alt+Spacebar and then N to choose the Minimize command.

To restore a window with the keyboard:

1. Press and hold Alt.
2. Press Tab repeatedly until the icon of the program you want to restore is chosen.
3. Release Alt. The icon expands into a window.



Restoring a Window

To restore a window to its previous size with the mouse:

· Click the Maximize box (containing both up and down arrows).

To restore a window to its previous size with the keyboard:

· Press Alt+Spacebar and then R to choose the Restore command. The window returns to its 
previous size.

To restore a window (from an icon) with the mouse:

· Double click the icon. The icon expands into a window.

To restore a window (from an icon) with the keyboard:

1. Press and hold Alt.
2. Press Tab repeatedly until the icon of the program you want to restore is chosen.
3. Release Alt. The icon expands into a window.



Moving in a Dialog Box

To move to an area in a dialog box with the mouse, you simply point and click.

To move to an area in a dialog box with the keyboard, press Tab to move the cursor through the options 
and Shift+Tab to move in the reverse direction.

Some areas have descriptive names with an underlined letter (mnemonic). You can press Alt then the 
underlined letter to move to that area.



Moving Windows and Icons

Several windows can be displayed at the same time; for example, WinChart, PhotoMagic, Windows 
OrgChart, and Windows Draw can all be displayed at once. You can rearrange them by moving one 
window at a time anywhere on the screen.

The window with the highlighted title bar is the active window. To make another window the active window 
with the mouse, click anywhere in that window. With the keyboard, press Alt+Tab to toggle among the 
windows and icons. An icon's title bar (below the icon) is highlighted when the icon is active.

To move a window with the mouse:

1. Point to the title bar and press and hold Button 1. The window's border changes color.
2. Drag the outline of the window to another location.
3. Release Button 1.

To move a window with the keyboard:

1. Press Alt+Spacebar and then M to choose the Move command in the Control menu. A four-
headed arrow appears on the title bar.

2. Press the Arrow keys to move an outline of the window to a new location.
3. Press Enter.

To move an icon with the mouse:

1. Point to the icon and press and hold Button 1.
2. Drag the icon to another location.
3. Release Button 1.

To move an icon with the keyboard:

1. Press Alt+Esc to highlight the icon.
2. Press Alt+Spacebar to open the Control menu.
3. Press M to choose the Move command. A four-headed arrow appears on the icon.
4. Press the Arrow keys to move the icon.
5. Press Enter.



Resizing Windows

You can make the WinChart window larger or smaller, resizing it in any direction. With the mouse, you 
can resize horizontally and vertically at the same time from a window's corner.

To resize the window with the mouse:

1. Point to a border or corner and press and hold Button 1. The pointer changes to a double-headed 
arrow.

2. Drag the border or corner until the new border indicates the desired size.
3. Release Button 1.

To resize the window with the keyboard:

1. Press Alt+Spacebar and then S to choose the Size command. A four-headed arrow appears in 
the center of the window.

2. Press an Arrow key to move the four-pointed arrow to the border you want to move. To move to a 
corner, press the two Arrow keys that point to that corner.

3. Press the Arrow keys repeatedly to change the window to the desired size.
4. Press Enter. The active window changes to the new size.



Switch To Command

The Switch To command in the Control menu starts the Task List, which lets you switch among running 
applications and rearrange their windows and icons on your desktop.

Related Topics
Dialog Box information
Procedure information



Switch To Dialog Box

The Switch To dialog box appears when you choose the Switch To command in the Control menu.

Task List list box
The Task List list box displays the active (running) applications. Double click an application name to 
switch to it.

Switch To button
Click the Switch To button to switch to the highlighted application.

End Task button
Click the End Task button to close the highlighted application.

Cascade button
Click the Cascade button to cascade the applications in the Task List. The windows overlap so that each 
title bar is visible.

Tile button
Click the Tile button to tile the applications in the Task List. The open windows are arranged in smaller 
sizes to fit on the desktop.

Related Topics
Command information
Procedure information



Switching Among Application Windows

Choose the Switch To command in the Control menu to switch among active applications.

To switch among application windows:

1. Click the Control menu box and choose Switch To. The Task List opens.
2. Double click the application name you want from the list box, or select the name of the application 

you want and choose Switch To.

Related Topics
Command information
Dialog Box information



Adding a Window

The Add Window command loads another WinChart window on top of the current window. You can 
transfer symbols between the two windows using commands in the Edit menu.



WinChart Commands

File Menu The commands in the File menu let you clear the presentation area, and open, 
recall, save, import, export, and print files. Additional commands let you change 
the setup of your printer, add ClipArt to your drawing, and close WinChart.

Edit Menu The commands in the Edit menu undo operations and transfer symbols to and 
from the Clipboard. This menu also provides commands for selecting symbols, 
and deleting selected symbols from the presentation area.

Change Menu The commands in the Change menu let you align, arrange, flip, name, change 
the order of symbols, rotate symbols, and smooth and unsmooth symbols.

Preferences Menu The Preferences menu lets you change the crosshairs, default page size, 
borders, orientation, and screen color.



Creating Data Charts

With WinChart, you can create data charts quickly and easily. Just enter data into the Worksheet, 
highlight the data you want to chart, then choose the type of chart you want. Afterwards, you can add a 
title or other enhancements and print a copy of the chart.

While you're learning how to create data charts, you will see underlined words or phrases, such as open a 
data file. The underline indicates that more information is available. To read the information, point to the 
underlined word or phrase and click Button 1.

To enter data into the Worksheet:

1. Open the Worksheet (choose the Worksheet tool or click Button 2).
2. Enter data into the Worksheet or open an existing data file.
3. Highlight the data you want to chart. Point to the first data cell, press and hold Button 1, then drag 

the pointer to highlight the rest of the data.
4. Close the Worksheet (press Ctrl+W or click Button 2).

When creating a chart, WinChart uses the first column of highlighted data in the Worksheet for category 
labels in the chart. (Category labels appear along the horizontal or x-axis in most data charts.) WinChart 
uses the first row of highlighted data for series labels, which appear in the chart's legend.

To create a chart:

1. Click a chart tool. The Chart dialog box opens, displaying several chart formats.
2. Choose the chart format you want. Make certain that Auto Paste is selected.
3. Click New. The chart appears in the middle of the presentation area.

You can then add a title to your chart and print it. Before adding a title, you may wish to select a text font 
and font size that helps enhance the appearance of your chart.

To select a font:

1. Click the Text tool and choose the Font Style button.
2. Choose the font type and size you want.
3. Click Ok.

To add a title:

1. Click the Text tool, and choose the Text Cursor button.
2. Click Button 1 where you want to start the text.
3. Type the title.
4. Press Esc, double click Button 1, or choose the Pointer tool in the toolbox to leave text mode.

To print a chart:

1. Be sure that the correct printer driver is installed.
2. Be sure the printer page orientation (portrait or landscape) matches the page orientation specified 

with the Pages command in the Preferences menu.
3. Open the File menu and choose Print. The Print submenu opens.
4. Choose one of the Print commands.

To customize a chart:

Whenever you wish, you can customize your chart using the commands in the various menus. Here are 
some of the ways you can customize your chart:



· add a legend
· add projection (3D)
· change colors
· add ClipArt
· and much more!



File Menu

The commands in the File menu let you clear the presentation area, and open, recall, save, import, 
export, and print files. Additional commands let you change the setup of your printer, add ClipArt to your 
drawing, and close WinChart.

New Clears the presentation area.
Open Lets you open (or load) a file into the presentation area.
ClipArt Lets you select and preview ClipArt.
Save Saves the file on which you are working, using the current filename.
Save As Assigns a name to a file or makes a copy of the file under a new name.
Print Prints your file to the current printer.
Printer Setup Selects a printer and changes the output options.
Run Lets you choose other Graphics Works applications to run (launch).
Exit Closes WinChart.



New Command

When you want to clear the presentation area in WinChart, use the New command. This command clears 
everything from the window and resets the program defaults.

To clear the window:

· Open the File menu and choose New. WinChart clears the window.

If the file you are working with has changed, and you did not save it before choosing the New command, 
the Save Changes dialog box opens and requests that you select one of three choices: Yes, No, or 
Cancel.

· Yes saves the current changes before clearing the window.

· No clears the window without saving any changes.

· Cancel cancels the New command and returns you to the current drawing.

Related Topics
Procedure information



Creating a New Presentation

Choose the New command to open a new window and create a new presentation.

To create a new presentation:

· Open the File menu and choose New. The window clears.

Related Topics
Command information



Open Command

The Open command lets you open (or load) a file into the presentation area.

Related Topics
Dialog Box information
Procedure information



Open File Dialog Box

When you choose the Open command, the Open File dialog box opens.

Open File text box
Type the name of the file you want to open in the Open File text box.

Directories list box
The Directories list box displays directories and disk drives in brackets. If you choose [-a-], the directories 
and filenames on the diskette in drive A appear in the list box. To see the filenames in another directory, 
choose the directory name or type the directory name separated with backslashes. For example, type c:
\winchart\tutorial and press Enter. The filenames associated with the specified drive and directory 
appear in the list box.

To change directories, point to the directory containing the files you want to open and double click Button 
1. The list box changes to the directory you selected.

The current path is displayed below the Directories list box. To quickly back up one or more directories, 
double click the directory you want.

Save option
The Save option saves the current directory as the new default directory. This directory then displays 
each time you choose the Open command. The Save option also sets the default directory for the Save 
and Save As commands.

File Type options
GRF WinChart chart file
DAT WinChart data file
DIF Data-interchange format
DRW Micrografx Draw file format
SPC Space-delimited ASCII file
SLK Microsoft symbolic link format
WK1 Lotus file
WKS Lotus file
XLS Excel file

Related Topics
Command information
Procedure information



Opening a File

To open a file:

1. Open the File menu and choose Open. The Open File dialog box opens.

If the file you are working with has changed, and you did not save it before choosing the Open command, 
the Save Changes dialog box opens and requests that you select one of three choices: Yes, No, or 
Cancel.

· Yes saves changes to your drawing before opening the Open File dialog box.

· No does not save changes to the current file and opens the Open File dialog box.

· Cancel cancels the Open command and returns you to the current drawing.

2. Point to the drive and directory containing the file that you want to open.
3. Double click the file. The drawing appears in the presentation area.

Related Topics
Command information
Dialog Box information



ClipArt Command

The ClipArt command lets you add Micrografx ClipArt to your charts. You can preview a selected symbol 
before adding it to a chart.

Related Topics
Dialog Box information
Procedure information



Find ClipArt Dialog Box

Auto Paste

When the Auto paste button is selected, then the ClipArt symbol is pasted to your presentation area 
without using the Windows clipboard. This means that the contents of the clipboard are not disturbed.

Related Topics
Command information
Procedure information



Using ClipArt

The following description is one way to use the ClipArt command.

To add a ClipArt symbol to a drawing:

1. Open the File menu and choose ClipArt . The Find ClipArt dialog box opens.
2. Locate the GRF or DRW file containing the Clipart you want and click Open to open the file. The 

ClipArt dialog box opens and thumbnail sketches and names of the available ClipArt symbols 
appear.

3. Select one or more of the available symbols by clicking on either the name or the thumbnail.
4. Click Ok. The symbol is pasted into your presentation area.

Related Topics
Command information
Dialog Box information



Save Command

The Save command saves the current chart or drawing.



Save As Command

The Save As command lets you assign a name to a file or make a copy of an existing file by giving it a 
new name. When you choose this command, the Save As dialog box opens.

Related Topics
Dialog Box information
Procedure information



Save File As Dialog Box

The Save File As dialog box opens when you choose the Save As command in the File menu.

Save File As text box
Type a filename in the Save File As text box, then click Ok.

Related Topics
Command information
Procedure information



Saving a File

To save a new or existing file:

1. Open the File menu and choose Save As. The Save File As dialog box opens.
2. Type a name for file in the text box or accept the name in the text box.
3. Click Ok.

Related Topics
Command information
Dialog Box information



Print Command

The Print command opens the Print submenu. You can choose the Page, View, or All pages command, 
depending on your printing preference.

Command Action

Page Prints the page. After you select this option, the page spools and prints.

View Prints the portion of the drawing area that you select by dragging a bounding box 
around it. The portion that you choose is resized to fit the printer page.

All pages Prints all the pages in the file.

Related Topics
Procedure information



Printing a Drawing or View

To print a drawing or view:

1. Open the File menu and choose Print. The Print submenu opens.
2. Choose one of the Print commands in the Print submenu.

Related Topics
Command information



Printer Setup Command

The Printer Setup command lets you select a printer and change its output options.

Related Topics
Dialog Box information
Procedure information



Select Printer Dialog Box

The Select Printer dialog box opens when you choose the Printer Setup command, and lets you choose 
printers.

Related Topics
Command information
Procedure information



Selecting a Printer

To select a printer:

1. Open the File menu and choose Printer Setup. The Select Printer dialog box opens.

Note: WinChart defaults to the printing device selected in the Windows Control Panel.

2. Point to the printer you want and click Button 1 to select it.
3. Click Ok to save your choice and close the Select Printer dialog box.

Note: Make sure that the printer's page orientation matches the page orientation you set with the Pages 
command in the Preferences menu. For example, if you set the page to landscape in the Pages dialog 
box, you must set the printer's page orientation to landscape for the page to be printed in landscape 
format.

Related Topics
Command information
Dialog Box information



Run Command

The Run command lets you quickly start a Graphics Works program from another Graphics Works 
program. When you choose the Run command, a submenu opens, displaying the applications you can 
open.

Command Opens

PhotoMagic PhotoMagic, the fun way to retouch photo images.
WinChart WinChart, the powerful and easy-to-use charting package.
Windows Draw Windows Draw, the best selling Windows drawing program.
Windows OrgChart Windows OrgChart, the quick and easy way to create and edit professional 

organization charts and tree diagrams.
SlideShow SlideShow, the perfect way to show your presentation.

To open one of the applications:

1. Open the File menu and choose Run. The Run submenu opens.
2. Choose the application that you want to open.



Exit Command

The Exit command closes WinChart.

Related Topics
Procedure information



Closing WinChart

To close WinChart:

· Open the File menu and choose Exit.

If the file you are working with has changed, and you did not save it before choosing the Exit command, 
the Save Changes dialog box opens and requests that you select one of three choices: Yes, No, or 
Cancel.

· Yes opens the Save File dialog box, which lets you save changes to the drawing.

· No does not save changes to your drawing and closes WinChart.

· Cancel cancels the Exit command and returns you to the current drawing.

Related Topics
Command information



Edit Menu

The commands in the Edit menu undo operations and transfer symbols to and from the Clipboard. This 
menu also provides commands for selecting symbols, and deleting selected symbols from the 
presentation area.

Undo Reverses the last edit or change to a symbol.
Cut Cuts the selected symbol(s) to the Clipboard.
Copy Copies the selected symbol(s) to the Clipboard.
Paste Pastes the selected symbol(s) from the Clipboard.
Delete Deletes the selected symbol(s) from the presentation.
Remove Deletes the currently selected chart items, and also deletes chosen chart items 

from two or more overlaid charts.
Block Select Selects all symbols in a particular area of the window.
Select All Selects all symbols in the window.



Undo Command

The Undo command reverses the last change you made to a symbol. It must be chosen immediately after 
an action is executed, and before any other change is made. To reinstate the change (undo the undo), 
choose Undo again.

Related Topics
Procedure information



Reversing Changes to a Symbol

To undo changes to a symbol:

· Open the Edit menu and choose Undo. The symbol appears as it did before your last edit.

Note: The Undo command does not reverse changes made with commands in the File menu. The Undo 
command is disabled (grayed out) if WinChart cannot reverse the most recent action.

Related Topics
Command information



Cut Command

The Cut command removes selected symbols from the presentation area and moves them to the 
Clipboard. These symbols can be pasted back into the same WinChart window, a different WinChart 
window, or another Windows application, such as Windows Draw.

Related Topics
Procedure information



Cutting Symbols

Choose the Cut command in the Edit menu to move selected symbols from the presentation area to the 
Clipboard.

To cut a symbol to the Clipboard:

1. Select the symbol you want to cut from the window.
2. Open the Edit menu and choose Cut. The selected symbol is cut to the Clipboard.

Related Topics
Command information



Copy Command

The Copy command copies selected symbols from the presentation area to the Clipboard. Symbols 
copied to the Clipboard can be pasted back into the same WinChart window, another WinChart window, 
or another Windows application, such as Windows Draw.

Related Topics
Procedure information



Copying Symbols

Choose the Copy command in the Edit menu to copy selected symbols from the presentation area to the 
Clipboard.

To copy a symbol to the Clipboard:

1. Select the symbol in the window that you want to copy.
2. Open the Edit menu and choose Copy. The selected symbol is copied to the Clipboard.

Related Topics
Command information



Paste Command

The Paste command retrieves a symbol from the Clipboard, previously cut or copied from WinChart or 
another Windows application. You may repeatedly paste the same symbol from the Clipboard until you 
cut or copy a new symbol to the Clipboard.

Related Topics
Procedure information



Pasting Symbols

The Paste command (Shift+Ins) in the Edit menu retrieves data from the Clipboard that was cut or copied 
from WinChart or another Windows application.

To paste a symbol from the Clipboard:

· Open the Edit menu and choose Paste. The symbol appears in the presentation area.

Related Topics
Command information



Delete Command

The Delete command removes selected symbols from the presentation area.

Related Topics
Procedure information



Deleting Symbols

Choose the Delete command in the Edit menu to delete selected symbols from the drawing.

To delete a symbol:

1. Select the symbol you want to delete.
2. Open the Edit menu and choose Delete. The symbol is removed from the window.

Note: You can restore a symbol that was deleted with the Delete command by choosing the Undo 
command in the Edit menu immediately after deleting the symbol.

Related Topics
Command information



Remove Command

The Remove command deletes the currently selected chart items. It also removes the chosen chart items 
from two or more overlaid charts.

Related Topics
Procedure information



Removing a Chart Item

Choose the Remove command in the Edit menu to delete currently selected chart items.

To remove a chart item:

1. Select the chart item you want to Remove.
2. Open the Edit menu and choose Remove. The chart item is removed from the window.

Note: You can restore a symbol that was removed with the Remove command by choosing the Undo 
command in the Edit menu immediately after deleting the symbol.

Related Topics
Command information



Block Select Command

The Block Select command enables you to select all the symbols in a particular area on the page.

Related Topics
Procedure information



Block Select Symbols

Choose the Block Select command in the Edit menu to block select symbols.

To block select symbols:

1. Open the Edit menu and choose Block Select.
2. Point above and to the left of the desired symbols, press and hold Button 1, and drag a dotted 

rectangle around the symbols. Handles appear around the symbols to indicate that they are 
selected.

Related Topics
Command information



Select All Command

The Select All command selects all text and symbols in the window. You can use this command to select 
all text and symbols, then press and hold shift while you select individual symbols to remove them from 
the selected group.

Related Topics
Procedure information



Selecting All Symbols

Choose the Select All command in the Edit menu when you want to have all text and symbols selected.

To select all text and symbols in the window:

· Open the Edit menu and choose Select All. All text and symbols in the window are selected.

Note: Pressing Shift+F2 selects all symbols that were not selected and deselects those that were 
selected.

Related Topics
Command information



Glossary

Active window
Back up (verb)
Backup (noun)
Baseline
Bitmap pattern
Bounding box
Cancel
Category labels
Chart element
Chart grid
Check box
Click
ClipArt
Clipboard
Color palette
Command
Control menu box
Control menu
Correlation
Cursor
Default settings
Dependent variable
Deselect
Device fonts
Dialog box
Direction keys
Direction line
Double click
Drag
Driver
Drop shadow
Edit
End style
Extension
Font
Frame depth
Gradient
Grid
Handles
Hatch pattern
Highlight
Hint line
Hourglass cursor
Icon
Independent variable
Legend
Line style
List box
Menu bar
Menu
Minimize and maximize boxes
Mouse
Non-proportional resize
Page orientation



Page size
Palette (color)
Palette set
Paper size
Pica
Pixel
Point (noun)
Point (verb)
Point size
Pointer
Press
Print Spooler
Proportional resize
Resize
Rulers
Scroll bars and scroll arrows
Scroll keys
Scroll
Select
Series labels
Shadow chart
Shared axis
Shortcut key
Snap to rulers
Spooling
Status bar
Submenus
Symbol name
Symbol
Text cursor
Text style
Title bar
Toggle
Toolbox
Trend
Type style
Typeface
Value labels
Window
WYSIWYG



Active window 

The window in which you are working is the active window. The active window receives the next action.



Backup (noun)

Any file with a BAK extension. Backup files created by WinChart can be opened if the extension is 
changed to DRW.



Back up (verb)

To make a duplicate of a file before saving, assuring that the previous version of the file is not overwritten 
by the newer version.



Bitmap pattern

An intricate fill pattern composed of dots. See also Hatch pattern.



Bounding box

The invisible rectangle that encloses an entire symbol. When you move, resize, or duplicate a symbol, a 
dotted rectangle representing the bounding box appears instead of the actual symbol.



Cancel

A command button used to close a dialog box without making changes to the drawing. The Esc key also 
chooses Cancel.



Check box

A square box in a dialog box that can be toggled on or off. Check boxes are usually for multiple options 
you can set.



Click

To press and release Button 1 quickly. When you click the mouse button, you should hear and feel a faint 
click.



Clipboard

A data exchange storage area for symbols that are cut or copied from WinChart or another program.



ClipArt

A collection of symbols drawn by Micrografx artists. These symbols are available using the ClipArt 
command in WinChart. You can also create symbols and add them to the ClipArt Catalog



Color palette

The palette located in the Color/Style dialog box that contains the default palette that ships with WinChart. 
You can click to choose a color in the palette. 



Command

A word or phrase, usually found in a menu, that opens a dialog box, enters a mode, or carries out an 
action.



Control menu

A menu common to all windows. You use the Control menu to resize, move, minimize, maximize, or close 
the WinChart window. 



Control menu box

The small box, on the left of the windows title bar, that contains the Control menu.



Cursor

The entry point for entering or placing information. The cursor changes according to the command or 
button chosen.



Default settings

The preset options built into a program. You can change certain options using the Preferences menu.



Deselect

To move the pointer away from all selected symbols and click Button 1 to deselect them. Commands and 
tools no longer affect the symbols.



Device fonts

Fonts supported directly by a printer or display device.



Dialog box

A window that appears when the program needs information from you before it can carry out an action.



Direction keys

The Arrow keys (Up, Down, Right, and Left), and the Home, End, Pgup, and Pgdn keys. When used 
alone, the Arrow keys move the pointer in the direction indicated. The Home and End keys move the 
pointer to the upper left of the screen and to the lower right of the screen. The Pgup and Pgdn keys 
move one screen up and one screen down (in zoom mode only).



Direction line

On a Bézier symbol, a dotted line that indicates which anchor points and control points are associated.



Double click

To press and release Button 1 twice rapidly without moving the mouse.



DPI

The number of dots (pixels) per inch on the display or hard copy. Most laser printers print at 300 dpi. 
High-resolution phototypesetters provide 1270 and 2540 dpi.



Drag

To point to a symbol with the mouse, press and hold Button 1, and move the mouse so that the symbol 
moves across the screen.



Drawing area

The portion of the WinChart window where you create and view the drawings and documents you want to 
print.



Driver

A program that translates data from software for use with a specific hardware device.



Edit

To change or alter symbols using the commands in the Edit, Change, and Colors menus or the buttons 
associated with tools in the toolbox.



End style

Markers at the ends of lines and open symbols. End styles include arrowheads, lines, squares, circles, 
and triangles.



Extension

The period and one to three characters at the end of a filename that identify the kind of information in the 
file. For example, .DRW is the extension for WinChart files.



Font

A specific set of characters in a specific typeface design.



Gradient

A gradual fade in color intensity or a gradual fade from one color to another.



Grid

A matrix of dots in the drawing area used to help you align symbols along the x- and y-axes of the 
WinChart window.



Handles

Rectangular boxes that appear on the corners and sides of the bounding box of a symbol when the 
symbol is selected. You use handles to resize a symbol proportionally or non-proportionally.



Hatch pattern

A fill pattern composed of lines occurring at regular intervals. Hatch patterns can be output to a plotter. 
See also Bitmap pattern.



Highlight

To use the pointer to indicate a selection, such as changing a block of text to the same point size. The 
selection appears in reverse video, light on a dark background, or dark on a light background.



Hint line

A one-line message at the bottom of the main WinChart window that provides information about a feature 
you have selected.



Hourglass cursor

The pointer changes to an hourglass symbol to indicate that the program is performing an operation, such 
as saving a file with WinChart. When the cursor returns to a pointer, you can continue working.



Icon

A small graphic symbol that represents a software program. You can open the program by double clicking 
the icon.



Line style

Solid, dashed, dotted, or dashed and dotted line types.



List box

A dialog box containing a list of names.



Menu

A list of commands organized under a menu title in the menu bar and within some buttons.



Menu bar

The bar, under the title bar of a window, that contains the titles of menus in the application. The menus 
contain a variety of commands for performing tasks in WinChart.



Minimize and maximize boxes

The boxes located in the upper right corner of the screen used to reduce or enlarge the window. The 
frame around the window also is used to resize the window.



Mouse

A pointing device that you move across a flat surface to move the pointer on your screen. A mouse can 
have one or more buttons, which you press to carry out various actions.



Non-proportional resize

To resize a symbol, using the side handles (or corner handles while pressing Shift), such that the ratio of 
the symbol's width and height changes.



Outline fonts

Fonts that produce text on the screen as it appears when printed (WYSIWYG, or what-you-see-is-what-
you-get). See also Vector fonts.



Page orientation

The position of a drawing on paper. Portrait (vertical) orientation displays a page taller than it is wide. 
Landscape (horizontal) orientation displays a page wider than it is tall.



Page size

The dimensions of a page on the screen.



Palette (color)

A collection of colors available in WinChart.



Palette set

A collection of palettes saved as a PAL file.



Paper size

The physical size of the paper in a printing device.



Pica

A type measure equal to 1/6" or .423 cm.



Pixel

An individual dot on the screen or printed page. 



Point (noun)

A type measure equal to 1/72" or .035 cm. There are 12 points in a pica.



Point (verb)

To move the pointer on the screen until it rests on the symbol you want.



Point size

A measurement of the height of characters in a font. There are approximately 72 points in an inch.



Pointer

A graphic symbol used to show the current screen location. You move the pointer by moving the mouse or 
by pressing the Direction keys. The pointer is usually an arrow, but changes shape depending on the 
commands or buttons you choose.



Press

To press and hold down the mouse button momentarily.



Print spooler

An accessory that creates a print file before printing begins.



Proportional resize

To resize a symbol, using the corner handles, such that the ratio of the symbols width and height remains 
the same.



Proportional typeface

A typeface in which the widths vary from character to character: a w or an m is wider than a t or an i. 
Bitstream Dutch and Swiss are examples of proportional typefaces.



Resize

To change the size of a symbol. Dragging a corner handle changes the size proportionally, while dragging 
a side handle changes the size non-proportionally. Dragging a handle into the symbol reduces the size of 
a symbol; dragging a handle away from a symbol makes it larger.



Rulers

Horizontal and vertical rulers that allow precise placement of symbols. The horizontal ruler borders the top 
of the WinChart window, and the vertical ruler borders the left side of the window.



Scroll

To change the visible portion of a drawing window without changing the size in which the symbols are 
displayed.



Scroll bars and scroll arrows

The bars and arrows at the right side or bottom of the WinChart window that allow you to travel vertically 
and horizontally across the window (in zoom mode only).



Scroll keys

Pressing Pgup or Pgdn scrolls one screen up or one screen down, respectively (in zoom mode only). 
Pressing an Arrow key until the pointer goes beyond the edge of the drawing area scrolls the window in 
the direction of the Arrow key.



Select

To choose a symbol or part of a symbol, indicating that commands and buttons are to affect that symbol 
or part of a symbol. In WinChart, a selected symbol displays handles.



Shortcut key

A function key or a mnemonic key, used with the Alt, Ctrl, or Shift key, that executes a command quickly. 
Shortcut keys appear with their corresponding commands in the hint line at the bottom of the WinChart 
window.



Snap to rulers

A default option that causes the increments of the ruler to exert a pull on the pointer or on a symbol that 
comes close to the increment.



Spooling

To send a page to a file before printing. When spooling is complete, the page begins to print and you may 
work in the window again or select another print operation.



Status bar

The bar located at the top right of the ribbon area that keeps you informed about the pointer location; and 
the location, rotation, slant, and resize dimensions of the currently selected symbol.



Submenus

A submenu opens when you choose a command with an arrow opposite it. Submenus provide additional 
commands related to the desired task you want to accomplish.



Symbol

A graphic object created with WinChart or provided in Micrografx ClipArt.



Symbol name

A name or number up to 80 characters in length for identifying a symbol. You use a symbol name to load 
a symbol into a drawing.



Text cursor

A blinking vertical bar that indicates where to begin entering or editing text.



Text style

The features applied to a font. Text styles include bold, italic, and underline.



Title bar

The bar across the top of the main window that contains the name WinChart. The title bar also contains 
the windows Control menu box and minimize and maximize boxes.



Toggle

To alternately turn a function on and off.



Toolbox

The area of the WinChart window located to the left of the vertical ruler that contains five tools: Edit, 
Draw, Text, View, and Color. Select a tool to display a row of buttons in the ribbon area corresponding to 
the tool you selected (except for the View and Color tools, which open a horizontal row of buttons).



Type style

A standard variation within a typeface family. Common styles include roman (upright, plain, or regular), 
italic, bold, and bold italic. Each style within a typeface family is a unique typeface design of its own. For 
example, the design of Bitstream Dutch Bold is distinct from Bitstream Dutch Roman.



Typeface

The design of a set of characters. Bitstream Charter Roman and Bitstream Charter Italic are examples of 
typefaces. They share a common typeface family: Bitstream Charter; and they each have a particular 
style: roman (also called plain, upright, normal, or regular) and italic.



Window

A rectangular area on the screen that displays the WinChart program. Every window has a title bar and a 
menu bar, and may also have one or two scroll bars.



Working area

The area outside the drawing area where you edit, resize, and store symbols.



WYSIWYG

What-you-see-is-what-you-get. An industry-wide term describing a close similarity between a screen 
image and the printed output of that image.



Baseline

The line that runs along the horizontal axis of a chart, usually indicating the zero point. On a Bar chart, the 
baseline runs along the vertical axis.



Category labels

Labels that appear on the independent axis of a chart (usually the x-axis; on a Bar chart, the y-axis).



Chart element

A component (such as a column, grid, or label) of a chart.



Chart grid

Horizontal and vertical lines that criss-cross a chart and divide the chart into easy-to-read segments. The 
eye follows a grid line to a value or a label on one of the axes.



Correlation

The relationship the independent (x-axis) variable has to the dependent (y-axis) variable. This value is 
called the correlation coefficient (referred to as r), and varies from -1 to +1. A value close to -1 or +1 
indicates a strong relationship; a value close to 0 suggests a random association.



Dependent variable

A quantity whose value is affected by the value of another variable. Normally plotted on the y-axis (except 
in a Bar chart, where it is plotted in the x-axis).



Drop shadow

A shaded repetition of a shape--for example, a rectangle--that is usually in black. When dropped slightly 
to the left or right and behind the original shape, the shape appears to be casting a shadow.



Frame depth of a chart

When a chart adds depth or projection, the frame depth of the chart is the projection of the x-axis and y-
axis.



Independent variable

A quantity whose value is determined by the user. Normally plotted on the x-axis (except in a Bar chart, 
where it is plotted on the y-axis).



Legend

An explanatory list of the series labels in the Worksheet. The legend maintains the colors, patterns, 
markers, and line styles from the plotted chart.



Series labels

Labels that appear in a legend of a chart, and on the z-axis of a ranked chart.



Shadow chart

A shaded repetition of a chart (usually in black) that is dropped slightly to the left or right and behind the 
original chart and that appears to be casting a shadow.



Shared axis

Two charts that are overlaid can share the same scale (or axis) or can each have a different axis. When 
sharing the same axis, overlaid charts share the same formats (such as axis orientation, labels, and scale 
increment).



Trend

The general movement or change of the dependent (y-axis) variable over time.



Value labels

Labels that appear on the dependent axis of a chart (usually the y-axis; on a Bar chart, the x-axis). Value 
labels are generated by Charisma and are not visible in the Worksheet.



Using On-line Help

On-line help messages provide detailed information about commands, dialog boxes, buttons, and tools; 
techniques for drawing and editing; and additional concepts specific to WinChart and the Windows 
environment. Using on-line help is more convenient than using a manual because getting information is 
as easy as pressing a button.

Accessing On-line Help

You can access help one of two ways. The first way involves pressing F1 to access context-sensitive 
help. When you press F1, you receive a help message specific to the command, dialog box, button, or 
tool you choose or open.

The second way involves using the Help menu. The Help menu lets you access information about 
WinChart commands, terms and phrases, error messages and solutions, and topics specific to WinChart 
and the Windows environment.

How Help Messages are Organized

Finding information in the WinChart help system is easy; it is much like using a roadmap. It provides 
landmarks (related topics) and pointers (jump terms) to easily get you where you want to go.

Help messages are organized hierarchically. Topics are "linked" to subtopics by jump terms. 

All WinChart commands contain a Related Topics section that points you to additional information related 
to the following: command information, dialog box information, and procedure information.

Command Messages
Command messages define and describe commands in WinChart. 

Dialog Box Messages
Dialog box messages list and explain the areas of a dialog box.

Procedure Messages
The procedure message contains step-by-step instructions for performing a particular task.

Jump Terms
Some help messages contain underlined words and phrases called "jump" terms. A jump term takes you 
to a related message for that term. Jump terms let you move throughout the help system without returning 
to the Help menu.

Glossary Terms
Words underlined with a dashed line have definitions attached to them. To view a definition for a word, 
point to the word and click Button 1. After reading the definition, click Button 1 to close the definition.

Printing Help
You can print a help message using the Print Topic command in the File menu of the Help window.

To print a help message:

· Click the Help File menu and choose Print Topic. 

Closing Help

You can close help and return to the image window in one of three ways.



· Double click the Control menu box in the Help window.
· Click the Help File menu and choose Exit.
· Click the Help Control menu and choose Close, or press Alt+F4.

About Help

Designed, written, and produced by Shannon L. Bridges.



Change Menu

The commands in the Change menu let you align, arrange, flip, name, change the order of symbols, 
rotate symbols, and smooth and unsmooth symbols.

Align Lets you align symbols, charts, and text.
Arrange Lets you connect a symbol closed, combine several symbols to form a single 

symbol, or break apart combined or connected symbols.
Duplicate Lets you create a duplicate copy of selected symbols.
Flip Lets you flip selected symbols.
Order Lets you move selected symbols to the front and back.
Rotate Lets you rotate selected symbols.
Smooth Smooths selected symbols.
Unsmooth Unsmooths selected symbols.
Name Assigns a name to a selected symbol.
Colors/Style Opens the Color/Style dialog box.



Align Command

The Align command lets you align symbols, charts, and text to each other and to the page.

Related Topics
Dialog Box information
Procedure information



Align Dialog Box

The Align command opens a dialog box containing the following options.

Option Action

Left Aligns selected symbols to the left side of the bounding box

Center Centers selected symbols between the right and left sides of the bounding box

Right Aligns selected symbols to the right side of the bounding box

Top Aligns selected symbols to the top of the bounding box

Middle Centers selected symbols midway between the top and bottom of the bounding 
box

Bottom Aligns selected symbols to the bottom of the bounding box

Page Center Aligns selected symbols to the center of the page

Page Middle Aligns selected symbols midway between the top and bottom margins of the 
page

Middle/Center Aligns selected symbols in the center of the page, midway between the top and 
bottom margins of the page

Ruler Aligns selected symbols to the current ruler divisions

Align to Chart Frame Aligns selected symbols to the frame of the chart.

Related Topics
Command information
Procedure information



Aligning Symbols

To align symbols:

1. Select the symbols you want to align.
2. Open the Change menu and choose Align. The Align submenu opens.
3. Choose the Align command you want to use.
4. Click Ok. The symbols redraw accordingly.

Related Topics
Command information
Dialog Box information



Arrange Command

The Arrange command opens a submenu that lets you connect a symbol closed, combine several 
symbols to form a single symbol, or break apart combined or connected symbols. Open symbols, such as 
polylines, curves, or arcs, connect from end point to closest end point, creating a single connected 
symbol. Closed symbols, such as rectangles, ellipses, or symbols already connected, can be combined 
together to form a single symbol.

The Arrange submenu lets you choose from the following commands.

Command Action

Group Combines selected individual symbols, including text, into a single symbol

Ungroup Breaks apart selected symbols combined with the Group command

Connect Connects a selected symbol or multiple symbols and fills them with the currently 
selected color, pattern, or gradient

Disconnect Disconnects selected connected symbols and removes any color, pattern, or 
gradient

Related Topics
Procedure information



Arranging Symbols

To group or connect symbols:

1. Select the symbols you want to group (combine) or connect.
2. Open the Change menu and choose Arrange. The Arrange submenu opens.
3. Choose Group or Connect. All of the selected symbols are grouped or connected.

To ungroup or disconnect symbols:

1. Select the symbols you want to ungroup (break apart) or disconnect.
2. Open the Change menu and choose Arrange. The Arrange submenu opens.
3. Choose Ungroup or Disconnect. All of the selected symbols are ungrouped or disconnected.

Related Topics
Command information



Duplicate Command

The Duplicate command lets you create a duplicate copy of a selected symbol.

Related Topics
Procedure information



Duplicating Symbols

To duplicate a symbol:

1. Select the symbol you want to duplicate.
2. Open the Edit menu and choose Duplicate. The pointer changes to indicate duplicate mode.
3. Point to the selected symbol, press and hold Button 1, and drag the new symbol to where you 

want it.

Note: Pressing Ctrl while dragging a symbol forces a horizontal or vertical move.

Related Topics
Command information



Flip Command

The Flip command opens a submenu containing the following commands.

Command Action

Horizontally Flips selected symbols horizontally, reversing them side to side

Vertically Flips selected symbols vertically, reversing them top to bottom

Related Topics
Procedure information



Flipping Symbols

To flip symbols horizontally or vertically:

1. Select the symbols you want to flip.
2. Open the Change menu and choose Flip. The Flip submenu opens.
3. Choose Horizontally or Vertically. The symbols change accordingly.

Related Topics
Command information



Order Command

The Order command opens a submenu containing the following commands.

Command Action

Move to Back Moves the currently selected symbols behind all other symbols

Move to Front Moves the currently selected symbols in front of all other symbols

Related Topics
Procedure information



Changing the Order of Symbols

To change the order of symbols:

1. Select the symbols you want to reorder.
2. Open the Change menu and choose Order. The Order submenu opens.
3. Choose Move to Back or Move to Front. The symbols change position relative to the other 

symbols.

Related Topics
Command information



Rotate Command

The Rotate command lets you rotate a selected symbol (or text) in fifteen-degree increments.

To rotate a symbol, move the pointer in a circular motion around the pivot point (a circle with intersecting 
lines) in the direction you want to rotate. The default pivot point is the center point of the symbol's 
bounding box.

If you select multiple symbols, the entire group of symbols rotates around the center point of the group's 
bounding box.

Related Topics
Procedure information



Rotating Symbols

To rotate a symbol:

1. Select the symbol you want to rotate.
2. Open the Change menu and choose Rotate. The pivot point appears in the center of the symbol, 

and the pointer changes to indicate rotate mode.
3. Point to the symbol, press and hold Button 1, and drag the pointer in a circular motion in the 

direction you want to rotate. The symbol rotates as you move the pointer. The left side of the 
status bar displays the degree of rotation.

4. Release Button 1.

Related Topics
Command information



Smooth Command

The Smooth command lets you smooth selected symbols.

Related Topics
Procedure information



Smoothing Symbols

To smooth a symbol:

1. Select the symbol you want to smooth.
2. Open the Change menu and choose Smooth.

Note: The Smooth and Unsmooth commands are not always opposites. If you choose Unsmooth after 
choosing Smooth, a symbol may not revert exactly to its previous shape.

Related Topics
Command information



Unsmooth Command

The Unsmooth command unsmooths selected symbols.

Related Topics
Procedure information



Unsmoothing Symbols

To unsmooth a symbol:

1. Select the symbol you want to unsmooth.
2. Open the Change menu and choose Unsmooth.

Note: The Smooth and Unsmooth commands are not always opposites. If you choose Unsmooth after 
choosing Smooth, a symbol may not revert exactly to its previous shape.

Related Topics
Command information



Name Command

The Name command lets you assign a name to a selected symbol. If the symbol already has a name, it 
appears in the text box of the Symbol Name dialog box. You can accept the name in the text box, or type 
a new name.

Related Topics
Dialog Box information
Procedure information



Symbol Name Dialog Box

The Symbol Name dialog box lets you assign a name to a selected symbol.

Symbol Name text box
Type a name (up to 80 characters) for the selected symbol in the Symbol Name text box, then click Ok.

Related Topics
Command information
Procedure information



Naming Symbols

To name a symbol:

1. Select the symbol that you want to assign a name.
2. Open the Change menu and choose Name. The Symbol Name dialog box opens.
3. Type the symbol name in the Symbol Name text box (80 characters maximum), or accept the 

name in the text box.
4. Press Enter.

Naming symbols enables you to build your own ClipArt libraries. When you save the file, the name will be 
saved also. When you use the ClipArt command in the file menu to open the file, the symbol appears with 
the name you associated with it.

Related Topics
Command information
Dialog Box information



Colors/Style Command

The Colors/Style command opens the Color/Style dialog box.



Chart Tool

WinChart lets you choose from six different data chart types--column, bar, area, line, pie, and table charts.

Click an icon below to read more information about the tool.

Click the Area Chart button to create a chart that shows broad trends among several items over a 
continuous period of time.

Click the Bar Chart button to create a chart that compares several items at a specific point in 
time.

Click the Column Chart button to create a chart that shows the value of several items both at 
specific points in time and over a period of time.

Click the Line Chart button to create a chart that shows the slope or direction for several sets of 
data over a period of time.

Click the Pie Chart button to create a chart that reveals the relative proportion that each data 
value contributes to the entire set of data values.

Click the Table Chart button to create a chart that uses a matrix of rows and columns to display 
precise data values.

Related Topics
Dialog Box information
Procedure information
Changing the color and style of chart items
Overlaying charts



Chart Dialog Box

All data chart types are created from highlighted data in the Worksheet and placed in the same way. 
When you click a Chart button in the toolbox, the Chart dialog box opens.

3D option
The 3D option adds depth perspective to your chart.

Legend option
The Legend option adds a legend to your chart. WinChart uses the first row of highlighted data in the 
Worksheet to create series labels for a chart.

Table option
The Table option adds a table of information to column, area, and line charts.

Auto Paste option
The Auto Paste option automatically places the chart in the presentation area, thus bypassing the 
Clipboard. WinChart places the image into the center of the displayed presentation area.

Save option
Click the Save option to save your choices as the default settings for that chart type.

New button
Click New to create the chart in the chosen format.

Overlay button
Click Overlay to create a combination chart with a selected chart. If no chart is selected, Overlay is not 
available.

Replace button
Click Replace to delete the selected chart and replace it with the new chart, which uses the same data 
and options chosen for the original chart. If no chart is selected, the Replace option is not available.

Cancel button
Click Cancel to close the Chart dialog box with no action taken, and return to the presentation area.

Related Topics
Procedure information
Changing the color and style of chart items



Creating a Chart

To create a chart:

1. Highlight the data you want to use for the chart using the Worksheet tool.
2. Click a Chart button.
3. Click the options you want.
4. Click New. The chart appears in the center of the presentation area.

Note: If the Auto Paste option is deselected, a paste cursor appears. Press Button 1 to apply the chart.

If you want to move the chart, point to it, press and hold Button 1, and drag the chart to a new location on 
the same page or on any page in the presentation area.

Related Topics
Dialog Box information
Changing the color and style of chart items
Overlaying charts



Changing the Colors and Style of Chart Items

You can change the colors and styles of individual items in charts.

To change the color or style of an item:

1. Click on a chart item to select it.
2. Click on the Color/Style button in the toolbox.
3. Use the buttons and palettes in the Color/Style dialog box to make your selection.
4. Click Ok in the Color/Style dialog box to make a change.
5. Click Close when you are finished making changes to the chart items. The Color/Style dialog box 

closes.



Column Chart button

The Column Chart button lets you create column charts, which show the value of several items both at 
specific points in time and to show changes in (or the distribution of) them over a period of time.

The horizontal axis (x-axis) of the column chart plots the values of the range (for example, the months of 
the year); the vertical axis (y-axis) displays the number of occurrences (or frequency) of each value.

The top of each column corresponds to a value on the vertical axis. The value can be expressed as a 
number, such as the total number of apples harvested last year in the United States; or as a percent, 
such as the percent of apples harvested in Washington state. The label (a year or month, for example) for 
each item in the range appears at the base of each column or column group.

A column chart looks like a bar chart rotated 90 degrees counterclockwise. However, a column chart 
better illustrates changes over time (time series).

Related Topics
Dialog Box information
Procedure information
Overlaying charts



Bar Chart Button

The Bar Chart button lets you create bar charts, which compare several items at a specific point in time. 
The baseline is along the vertical axis, and the bars extend to the right to show an amount or a percent. 
Bar charts are one of the simplest and most widely used charts.

A bar chart uses the horizontal axis (x-axis) as a value axis to display the number of occurrences (or 
frequency) of each value. The vertical axis (y-axis) is a category axis and plots the values of the range.

If you need to show values to the left of the baseline (below zero), enter negative values into the 
Worksheet. WinChart moves the baseline and plots negative values to the left of it, while positive values 
are plotted to the right of the baseline.

Related Topics
Dialog Box information
Procedure information
Overlaying charts



Area Chart Button

The Area Chart button lets you create area charts, which show broad trends between several items over 
a continuous period of time. Area charts are popular in newspapers and magazines because they are 
straightforward and easy to interpret.

A simple area chart shows one or two sets of data values, but several sets of data can be used in an area 
chart to show a cumulative trend. The top of each band represents the sum of that band and all the bands 
below it.

In stacked area charts, the appearance of the chart can change (sometimes dramatically) when the order 
of the bands (sets of data values) is changed. To aid viewers in interpreting an area chart, plot the most 
stable band of data (the data with the least variation) at the base of the chart. WinChart plots the first 
selected data series as the first band on the chart. If you want to change the order in which data values 
are plotted, select multiple ranges in the order you want them plotted.

Alternatively, if you want to focus attention on a particular band, highlight that set of data values in the 
Worksheet first so that it appears at the base of the chart. The bottom band is the easiest to interpret and 
usually the most conspicuous, especially if it uses a dark color.

Related Topics
Dialog Box information
Procedure information
Overlaying charts



Line Chart Button

The Line Chart button lets you create line charts, which show the slope or direction for several sets of 
data over a period of time. Line charts turn up frequently on the business pages of newspapers because 
they effectively chart large amounts of quantitative information.

You can use a line chart successfully to plot many data points that show a trend over a span of time. If 
you want to show the relative distribution of one variable (such as annual earnings) through another 
variable (such as women between the ages of 25 and 40), a line chart is a logical choice.

When comparing the trends of several items, use a multiple-line chart. But remember that five lines are 
usually the upper limit before confusion reigns.

Each line should be unique, either by thickness, style, color, or by the addition of a recurring marker that 
distinguishes it from the other lines and from the background of the chart.

Consider eliminating the grid in a line chart. The criss-crossing chart and grid lines tend to cause 
confusion. If you do use a grid, choose only a major horizontal or major vertical grid, and change the lines 
from solid to dashed. Major tick marks may be sufficient as visual cues for determining the value of each 
data point.

If you have many series to plot, consider creating several line charts and presenting them on the same 
page. To quickly and easily interpret the charts, make the scales of the charts (and the lines and markers 
that represent the same information) consistent throughout the charts.

Related Topics
Dialog Box information
Procedure information
Overlaying charts



Pie Chart Button

The Pie Chart button lets you create pie charts, which reveal the relative proportion that each part 
contributes to the whole. Pie charts are popular because they are easy to understand, and are attractive 
when enhanced with colors and patterns.

Pie charts show the relative proportions of the parts to the whole. A limitation of the pie chart is that it 
cannot compare multiple data series. A pie chart does show, however, the relationships of the segments 
to each other, as well as to the whole.

Five or six pie segments on a pie chart are ideal; 12 should be the upper limit. For superior readability, 
begin the largest segment at 12 oclock; the other segments progress clockwise from large to small. Place 
a segment representing "all other" or "miscellaneous" after the smallest segment.

Use the Sort command in the Worksheets Data menu to sort data in descending order. Then the pie 
segments plot from largest to smallest.

For additional information about each segment, display the value or percent (inside or outside) of the 
segments.

Related Topics
Dialog Box information
Procedure information
Exploding the pie



Exploding the Pie

You can also explode a segment after the chart is created by selecting a segment and dragging it away 
from the pie. You can even explode all segments by selecting a segment, pressing and holding Button 1 
and Shift, dragging the segment away, releasing Button 1, and releasing Shift.



Table Chart Button

The Table Chart button lets you create table charts, which use a matrix of rows and columns to display a 
set of precise data values. The primary purpose of a table chart is to show exact data values that the 
reader can quickly and easily locate.

Table charts can be used to present a small or a large number of data values. If you want to emphasize 
the data values for the rows, use vertical grid lines. Use horizontal grid lines when you want to guide the 
readers eyes along the data values for the columns. To further help the reader, use a sans-serif typeface 
(such as Helvetica) and a large point size in the table.

A table chart is often effective when combined with another chart, such as a column or line chart.

Related Topics
Dialog Box information
Procedure information



Overlaid Charts

Charts are often most effective when they are overlaid, especially when showing the relationship between 
two or more series of items (for example, a companys sales and its advertising costs).

Here are some guidelines for overlaying charts.

· Area, column, and line charts can be overlaid.
· Bar charts can overlay only bar charts.
· Pie and table charts cannot overlay any chart.

Overlaid charts can share the same axis, labels, and scale, or each chart can have its own.

The Chart dialog box contains the Overlay button, which lets you overlay two charts. When you click 
Overlay, the Overlay dialog box opens, containing the Scale 1 and Scale 2 options. Choose Scale 1 when 
you want both charts to share the same axis, labels, and scale. Choose Scale 2 when you want each 
chart to have its own axis, labels, and scale.

Note: When you choose Scale 2, the first charts axis, labels, and scale appear on the left axis; the 
second charts axis, labels, and scale appear on the right axis.

To overlay two charts:

1. Create the first chart.
2. Highlight the data for the second chart.
3. Select the first chart.
4. Click a Chart button in the toolbox.
5. Choose a chart format and then choose Overlay.
6. Choose Scale 1 or Scale 2, then click Ok. The second chart overlays the first.

To select one chart from two or more overlaid charts, point to an element of the chart you want to select 
and click Button 1. To delete an overlaid chart, select it (the status line displays which chart is selected), 
and press Ctrl+X to choose the Remove command in the Edit menu.



Color Tool

Click the Color tool to open the Color/Style dialog box.

Related Topics
Fill option
Line option
Text option
Bkg option



Color/Style Dialog Box

The Color/Style dialog box opens when you click the Color tool in the toolbox, and lets you set symbol 
colors, gradients, line styles, text colors, and other features.

The Color/Style dialog box has four major components.

Menus
The choices available for the Palette, Color, and Style menus change depending on which option you 
select.

Options
The second component is a set of four options. You can only choose one of these options at a time. 
These options are Fill, Line, Text, and Bkg. Selecting one of these options determines the type of 
attributes that will be applied to the selected object.

Color Palette
The third component is a color palette. This displays the available colors in the palette you have currently 
selected.

Set option
Click the Set option to keep the Color/Style dialog box open as you work. When you want to close the 
Color/Style dialog box, click Close or click Set again.

Related Topics
Fill option
Line option
Text option
Bkg option



Fill Option

If the Fill option is selected your choices in the dialog box are applied to the pattern fill of a selected 
symbol.

To change the pattern fill for a selected symbol:

1. Click the Color tool, or open the Change menu and choose Colors/Style.
2. Click the color you want in the palette colors. To change the available colors, you can choose a 

different palette using the Palette menu command.
3. If you want, click on a new style for the fill pattern. You can choose among several fill styles by 

changing the selection under the Style menu.
4. Click Ok. The selected symbol pattern fill changes accordingly.

In order for the symbol to change color, it must have a fill style other than Unfilled. If the symbol was 
Unfilled, its style is changed to Solid.

Related Topics
Palette menu
Color menu
Style menu



Palette Menu

Use the Palette menu to select one of the 9 groups of colors (palettes). Each choice in the default Palette 
menu displays several colors. 

To choose a new palette:

· Open the Palette menu and choose the name of the palette you want. The displayed palette of 
colors changes to display your choice.

If more colors are present in the palette than can be displayed immediately, a scroll bar appears below 
the color choices. You can use it to scroll to the other colors.



Style Menu (Fill Option)

The Style menu for the Fill option opens a menu containing commands that let you change the style for 
fills.

Unfilled Click the Unfilled command to remove a pattern and color from the selected 
symbol

Solid Click the Solid command to fill the selected symbol with the current fill color
Hatch Click the Hatch command to fill the selected symbol with a pattern composed of 

lines occurring at regular intervals
Bitmap Click the Bitmap command to fill the selected symbol with a pattern composed of 

various groupings of dots



Unfilled Command

The Unfilled command removes a fill pattern, color, or both from a selected symbol.

Related Topics
Procedure information



Unfilling a Symbol

To unfill a symbol:

1. Select the symbol.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Style menu and choose Unfilled. The symbol appears without a pattern or color.

Note: The Unfilled command does not affect lines or text.

Related Topics
Command information



Solid Command

The Solid command fills a selected symbol with the color selected in the color palette.

Related Topics
Procedure information



Filling a Symbol with Color

To fill a symbol with a color:

1. Select the symbol to which you want to add a color.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Style menu and choose Solid.

Note: The Solid command does not affect lines or text.

Related Topics
Command information



Hatch Command

The Hatch command fills the selected symbol with a pattern composed of lines occurring at regular 
intervals.

Related Topics
Dialog Box information
Procedure information



Hatch Dialog Box

When you choose the Hatch command, the Hatch dialog box opens. In the dialog box, you can view and 
choose any pattern fill. Dense patterns show less of the background color and sparse patterns show more 
background color. Experiment with the different patterns and colors to see the interesting effects you can 
produce.

The pattern in a selected chart element or symbol is enclosed in a rectangle in the Hatch dialog box. If 
nothing is selected or if more than one symbol is selected, the last pattern chosen is enclosed in a 
rectangle in the dialog box.

Note: The exact way a pattern appears on a screen or a printer depends on the device and the driver. 
Some bitmap patterns may appear solid when printed at a resolution higher than 72 dpi (dots per inch).

The choices in this menu enable you to select one of 6 hatch patterns. Select by moving the mouse 
pointer over the style you want and clicking button 1.

Avoid using patterns in bar and column charts. Striped patterns often create optical illusions, which can 
distort the information.

Related Topics
Command information
Procedure information



Choosing a Hatch Pattern

To change the pattern of a selected chart element or symbol:

1. Click the Color tool, or open the Change menu and choose Colors/Style.
2. Click the Fill option.
3. Open the Style menu and choose Hatch. The Hatch dialog box opens.
4. Point to a pattern and click Button 1.
5. Click Ok.



Bitmap Command

The Bitmap command fills the selected symbol with a pattern composed of various groupings of dots.

Related Topics
Dialog Box information
Procedure information



Bitmap Dialog Box

When you choose the Bitmap command, the Bitmap dialog box opens.

The choices in this menu enable you to select one of 32 bitmap patterns. Select by moving the mouse 
pointer over the style you want and clicking button 1.

Related Topics
Command information
Procedure information



Choosing a Bitmap

To change the pattern of a selected chart element or symbol:

1. Click the Color tool, or open the Change menu and choose Colors/Style.
2. Click the Fill option.
3. Open the Style menu and choose Bitmap. The Bitmap dialog box opens.
4. Point to a pattern and click Button 1.
5. Click Ok.

Related Topics
Command information
Dialog Box information



Line Option

The Line option lets you choose a color from the color palette for individual lines and the symbol outline. 
Select the Line option to change the color, width, line style, and end styles of lines.

To change the line color:

1. Select the line you want to color.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Click the color you want in the palette colors. To change the available colors, you can choose a 

different palette using the Palette menu.
4. Click Ok. The selected line color changes accordingly.

Related Topics
Palette menu
Color menu
Style menu



Style Menu (Line Option)

You can change the style, width, and ends of lines and all open symbols (arcs, curves, freehand symbols, 
and polylines) with the commands in the Style menu. You can also alter the styles and widths of lines for 
closed symbols (such as a rectangle or an ellipse).

The commands in the Style menu (for lines) are:

Invisible
Hairline
Width
None
Ends



Invisible Command

The Invisible command in the Style menu removes the line or border of a selected symbol. However, 
selecting solid or dashed later will cause the line to re-appear.

Related Topics
Procedure information



Making a Line Invisible

To make a line invisible:

1. Select the line you want to make invisible.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Click the Line option.
4. Open the Style menu and choose Invisible.

Related Topics
Command information



Hairline Command

The Hairline command sets the width of a line to the default line width.

Related Topics
Procedure information



Using the Hairline Command

To set the default line to a hairline:

1. Click the Color tool, or open the Change menu and choose Colors/Style.
2. Click the Line option.
3. Open the Style menu and choose Hairline. The default line width is now a hairline.

Related Topics
Command information



Width Command

The Width command in the Style menu lets you set the width of selected lines. You can also preset the 
line width so every line or symbol draws in the new width.

The default line width is a hairline, which is the narrowest line supported by the display screen and the 
printing device.

When you choose another line width with the Width command, the new width appears in the menu.

Related Topics
Dialog Box information
Procedure information



Width Dialog Box

The Width dialog box opens when you choose the Width command in the Style menu (for Lines), and lets 
you choose widths as decimals and fractions. 

Note: When you choose centimeters in the Rulers dialog box, the default width changes to .063 cm and 
the metric measurement appears in the Style menu.

The dialog box contains four width options: 10th, 16th, 64th, and 100th (of an inch or a centimeter). After 
selecting one of the options, use the scroll arrows to change the line width. The fraction and decimal 
equivalents change accordingly.

Related Topics
Command information
Procedure information



Changing the Width of Lines

To change the width of a selected line:

1. Click the Color tool, or open the Change menu and choose the Colors/Style command.
2. Click the Line option to select it.
3. Open the Style menu and choose Width. The Width submenu opens.
4. Choose one of the available line widths from the submenu. The selected line or open symbol 

changes to the new style. Subsequent lines and open symbols draw in the new style.

Related Topics
Command information
Dialog Box information



None Command

The None command lets you set the end styles of lines to no end styles.

Related Topics
Procedure information



Setting the End Styles to None

To set the end style to no end style:

1. Click the Color tool, or open the Change menu and choose the Colors/Style command.
2. Click the Line option to select it.
3. Open the Style menu and choose the Ends command.

Related Topics
Command information



Ends Command

The Ends command in the Style menu changes the end styles of a line or an open symbol. Subsequent 
lines and open symbols appear with the new style.

End styles include arrowheads, lines, squares, circles, and triangles.

Related Topics
Dialog Box information
Procedure information



Ends Dialog Box

The Ends dialog box lets you choose ends for selected lines and set default line end styles. You can set 
both ends of a line or an open symbol to the same end style or choose different styles for each end. You 
can also have an end style on only one end of an open symbol.

As you select end styles, the ones you choose are added to the Style menu and replace the default end 
styles in the Style menu. The menu shows the three most recently selected end styles and None for no 
end style.

Lines for closed symbols will not have an end style.

Related Topics
Command information
Procedure information



Changing End Styles

To set the end style of a selected line:

1. Click the Color tool, or open the Change menu and choose the Colors/Style command.
2. Click the Line option to select it.
3. Open the Style menu and choose Ends. The Ends submenu opens.
4. Click the desired end style. The selected line or open symbol changes to the new style. 

Subsequent lines and open symbols draw in the new style.

To change the end style of a selected line in a chart or symbol:

1. Click the Color tool, or open the Change menu and choose the Colors/Style command.
2. Click the Line option to select it.
3. Open the Style menu and choose the Ends command.
4. Select an end style option for each side of the line.

or
Click the end style between the option buttons to select the same end style for both sides.

5. Click Ok.

Related Topics
Command information
Dialog Box information



Text Option

The Text option allows you to change the color, style, and other features of text symbols in the 
presentation area.

To change the color for selected text:

1. Select the text you want to color.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Click the Text option.
4. Click the color you want in the palette colors. To change the available colors, you can choose a 

different palette using the Palette menu.
5. Click Ok. The selected text changes to the new color. Subsequent text entered will appear in the 

new color.

Related Topics
Palette menu
Color menu
Style menu



Style Menu (Text Option)

The Style menu for text lets you change certain qualities of the displayed text.

Command Action

Normal For normal font appearance
Bold For a bold font
Italic For an italic font
Strike out For a line drawn through each character
Underline For a line under the characters

To change the text syle of the selected text:

1. Select the text you want to change.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Style menu and choose the text style you want from the choices presented. The 

selected text changes to the new style. Subsequent text entered will appear in the new style.



Bkg Option

The Bkg option (background) lets you choose a color from the color palette for the background of a 
selected symbol, as well as the fade-from color of a gradient.

Choose the Bkg option to fill the background of the selected symbol with the selected color.

The background color can be changed independently of the foreground color. Imagine that each symbol, 
including lines and text, is created with a double layer. The bottom layer can be one color, while the top 
layer is another. When you add a pattern or a line style to the top layer, the bottom layer shows through. 
Lines show their background color only when they are in one of the dashed line styles.

To change the background color of a selected symbol:

1. Select a symbol.
2. Click the Bkg option in the Color/Style dialog box.
3. Select a color from the palette and click Button 1.
4. Click Ok. The background of the selected symbol changes to the new color.

To change the color of a symbol, that symbol must be selected. After selecting the symbol, select the 
desired color. To select a particular color, move the mouse pointer to the color and click Button 1. Now 
that both the symbol and desired color are selected, click the Ok dialog box button.

In order for the symbol to change color, it must have a fill style other than Unfilled.

Related Topics
Palette menu
Color menu
Style menu



Style Menu (Bkg Option)

The Style menu for the Bkg option contains the Opaque and Transparent commands. The default Opaque 
command lets a symbol's background color show. When you choose the Transparent command, the 
background color does not show. With Transparent selected, you can display a see-through pattern in a 
symbol. Then, the symbols below show through.

The background color can be changed independently of the foreground color. Imagine that each symbol, 
including lines and text, is created with a double layer. The bottom layer can be one color while the top 
layer is another. When you add a pattern or a line style to the top layer, the bottom layer shows through. 
Lines only show their background color when they are in one of the dotted or dashed line styles.

Note: If a symbol is filled with a solid (foreground) color, the background color does not show through. If 
the background color is the same as the foreground color, a fill pattern is not visible. To change the 
foreground color of a selected symbol, choose the Fill Color, Line Color, or Text    Option in the Color/Style 
dialog box, depending on the type of symbol.

The background of text symbols is transparent by default. Choose the Opaque command in the Style 
menu to let the background color show.

Related Topics
Procedure information



Changing the Background Color

To change the background color of a selected symbol:

1. Select a symbol.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Click the Bkg option in the Color/Style dialog box.
4. Point to a color in the palette and click Button 1.
5. Click Ok. The background of the selected symbol changes to the new color.

Double click a color to choose the color and Ok simultaneously.

Related Topics
Command information



Color Menu

The commands in this menu let you set the colors for particular items such as symbols, chart items, and 
the screen. You can also use the commands in this menu to create gradient fills. Gradient fills are areas 
of color which change smoothly from one to another.

Color/Style Click the Color/Style command to choose symbol FILL colors and styles.
Chart Colors Click the Chart Colors command to set the default chart colors.
Gradient Click the Gradient command to set gradient colors.
Screen Color Click the Screen Color command to set the screen color.
Current Color Click the Current Color command to see the color of the currently selected 

symbol.



Color/Style Command

The Colors/Style command displays the Color/Style dialog box with the Fill option selected.

Related Topics
Fill option



Chart Colors Command

Use the Chart Colors command to change the color of the data elements (such as bars or columns) in a 
chart. The default palette for this mode has colors specifically designed for data charts.

Notice that when you select a color in the Chart Colors mode, the data items displayed in the chart are 
painted with successive colors from the palette.

Related Topics
Procedure information



Changing the Colors of a Chart

To change the colors of a chart's data elements:

1. Select the chart, or select a specific data element.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Color menu and choose Chart Colors.
4. Choose a color in the color palette.
5. Click Ok. The first element changes to that color, the second element changes to the next color to 

the right, and so on.

Related Topics
Command information



Gradient Command

The Gradient command makes a gradual transition between two different colors.

Gradients provide useful visual effects to help you produce a more three-dimensional drawing. 

Related Topics
Procedure information



Adding Gradients

You can add a gradient to any closed symbol. A gradient fades from a selected background color to a 
selected fill color.

Linear gradients provide a gradual fade from one color to another in a specified direction within a symbol. 
Radial (circular) gradients fade from one color on the inner part of the fill to another color on the outer part 
of the fill. 

To add a gradient to a symbol:

1. Select the symbol to which you want to add a gradient.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Color menu and choose Gradient. The dialog box presents you with choices for 

gradient starting and ending colors.
4. Open the Style menu and choose the style you want. The symbol fills with the selected gradient.

To add color to a gradient:

1. Select the symbol containing a gradient that you want to add a color.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Color menu and choose Gradient. The dialog box presents you with choices for 

gradient starting and ending colors.
4. Click the Start button.
5. Click the color in the color palette you want as the gradient from color.
6. Click Ok.
7. Click the End button.
8. Click the color in the color palette you want for the gradient color with which to end.
9. Click Ok. The symbol redraws with the gradient and colors you selected.

Related Topics
Command information



Screen Color Command

Use the Screen Color command to color the presentation area.

Related Topics
Procedure information



Changing the Presentation Area Color

To change the presentation area color:

1. Click the Color tool, or open the Change menu and choose Colors/Style.
2. Open the Color menu and choose Screen Color.
3. Choose a color a new color. You may open another palette to choose a different color. From 

those presented.
4. Click Ok. The screen changes accordingly.

Related Topics
Command information



Current Color Command

The Current Color command lets you see the color in the currently selected symbol.

Related Topics
Procedure information



Using the Current Color Command

To view the current color:

1. Select the symbol containing the color you want to display.
2. Click the Color tool, or open the Change menu and choose Colors/Style.
3. Open the Color menu and choose Current Color.

Related Topics
Command information



Draw Tool

To draw a symbol, choose the drawing tool that best suits the shape you want to create.

Click the Rectangle button to draw rectangles and squares.

Click the Rounded Rectangle button to draw rectangles and squares with rounded corners.

Click the Ellipse button to draw ellipses and circles.

Click the Polyline button to draw polylines and polygons.

Click the Curve button to draw curves.

Click the Freehand button to draw freehand symbols.

Click the Arc button to draw arcs.



Default Settings

The default settings for lines, patterns, and text are shown below. 

Setting Default

Line color Black

Line width Hairline

Line style Solid

Line ends None

Fill color Black

Fill pattern Unfilled

Background color White

Background Transparent

Text color Black



Rectangle Button

The Rectangle button lets you draw rectangles and squares in any size.

Related Topics
Procedure information



Drawing a Rectangle

To draw a rectangle:

1. Click the Draw tool in the toolbox, then click the Rectangle button. The pointer changes to 
indicate draw mode.

2. Point to where you want to begin the rectangle.
3. Press and hold Tool 1, and drag the pointer to draw the rectangle. The rectangle appears on the 

screen and changes size and proportion as you move the pointer.
4. Release Tool 1 when the rectangle is the size you want.

Pressing Ctrl while drawing with the Rectangle button creates a square.

Related Topics
Button information



Rounded Rectangle Button

The Rounded Rectangle button lets you draw rectangles and squares with rounded corners.

Related Topics
Procedure information



Drawing a Rounded Rectangle

To draw a rounded rectangle:

1. Click the Draw tool in the toolbox, then click the Rounded Rectangle button. The pointer changes 
to indicate draw mode.

2. Point to where you want to begin the rounded rectangle.
3. Press and hold Button 1, and drag the pointer to draw the rounded rectangle. The rounded 

rectangle appears on the screen and changes size and proportion as you move the pointer.
4. Release Button 1 when the rounded rectangle is the size you want.

Pressing Ctrl while drawing a rounded rectangle creates a rounded square.

Related Topics
Button information



Ellipse Button

The Ellipse button lets you draw ellipses and circles in any size.

Related Topics
Procedure information



Drawing an Ellipse

To draw an ellipse:

1. Click the Draw tool in the toolbox, then click the Ellipse button. The pointer changes to indicate 
draw mode.

2. Press and hold Button 1, and drag the pointer to draw the ellipse. An ellipse appears on the 
screen and changes size and proportion as you move the pointer.

3. Release Button 1 when the ellipse is the size you want.

Pressing Ctrl while drawing an ellipse creates a circle.

Related Topics
Button information



Polyline Button

The Polyline button lets you draw symbols with irregularly shaped borders, such as a polygon, which is a 
closed polyline. On a polygon, the end point of the last side must be at the beginning point of the first 
side.

You can choose the Undo command in the Edit menu to delete each side of a polygonfrom the last 
created to the first created.

Another way to close an open polygon is to select the symbol, open the Change menu and choose the 
Arrange command, then choose the Connect command.

Related Topics
Procedure information



Drawing a Polyline

To draw a polyline:

1. Click the Draw tool in the toolbox, then click the Polyline button. The pointer changes to indicate 
draw mode.

2. Point to where you want to begin the polyline.
3. Press and hold Button 1, and drag the pointer to draw the first side. Release Button 1. Point to an 

end point for the second side, and press and hold Button 1. The second side draws from the end 
of the first side to the pointer.

4. Drag the pointer (while still holding Button 1) to reposition the line.
5. Release Button 1 when the line is where you want it.
6. Repeat steps 4 through 6 for each additional side. 
7. Click Button 1 to complete the symbol.

Press Shift to draw a freehand segment; press Ctrl to draw a horizontal, vertical, or diagonal line 
segment.

Related Topics
Buttoninformation



Curve Button

The Curve button lets you draw a curve by placing a point at the intersection of each curved line segment. 
Draw curved segments by pressing and holding Button 1 as you move the pointer.

You can choose the Undo command in the Edit menu to delete incorrect segments created when drawing 
curved line segments. The segments are deleted in the reverse order that they were created.

Related Topics
Procedure information



Drawing a Curve

To draw a curve:

1. Click the Draw tool in the toolbox, then click the Curve button. The pointer changes to indicate 
draw mode.

2. Point to where you want to begin the curve.
3. Press and hold Button 1, and drag the pointer to draw a line.
4. Release Button 1.
5. Press and hold Button 1, and drag the pointer. The line curves in the direction you move the 

pointer.
6. Release Button 1 when the curve is the shape and length you want.
7. Repeat steps 5 and 6 to add more curved line segments.

Press Shift to draw a line segment; press Ctrl to draw a horizontal, vertical, or diagonal line segment.

Related Topics
Button information



Freehand Button

The Freehand button lets you draw symbols as if you were using a pencil and paper.

If the beginning and ending points of the freehand symbol are the same, the symbol is closed. You can 
then fill it with a color, a pattern, or a gradient. When the freehand symbol is complete, WinChart 
automatically smooths the lines and converts them to curves.

Related Topics
Procedure information



Drawing a Freehand Symbol

To draw a freehand symbol:

1. Click the Draw tool in the toolbox, then click the Freehand button. The pointer changes to indicate 
draw mode.

2. Point to where you want to begin drawing the freehand symbol.
3. Press and hold Button 1, and drag the pointer to draw the symbol.
4. Release Button 1 when the symbol is what you want.
5. Click Button 1 to complete the symbol.

Pressing Shift when drawing a freehand symbol draws straight line segments. Pressing Ctrl when 
dragging the pointer forces a horizontal, vertical, or diagonal move.

Related Topics
Button information



Arc Button

The Arc button lets you draw one quarter of an ellipse.

Related Topics
Procedure information



Drawing an Arc

To draw an arc:

1. Click the Draw tool in the toolbox, then click the Arc button. The pointer changes to indicate draw 
mode.

2. Press and hold Button 1, and drag the pointer to draw the arc. The arc appears on the screen and 
changes size and proportion as you move the pointer.

3. Release Button 1 when the arc has the desired shape.

Pressing Ctrl as you create an arc forces square proportions, creating one quarter of a circle. Pressing 
Shift as you create an arc inverts the arc.

Related Topics
Button information



Messages and Solutions

An older Micrografx application is running. Close it and run WinChart again.
Are you sure you want to delete this file?
Delete is not available in multiple areas.
Error writing (filename)--file not saved.
(Filename) is not a valid filename.
(Filename) is not a valid WinChart file.
(Filename) is read-only.
(Filename) not found.
Insert is not available in multiple areas.
Invalid constant.
Invalid precision--must be in range 0 to 10.
Invalid precision--must be in range 1 to 6.
Invalid version--file may not be loaded correctly.
Leave data in clipboard?
No symbol identifiers found in (filename).
Not a valid page size.
Not a valid point size.
Not enough disk space to spool file.
Not enough disk space--unable to save.
Not enough memory (all messages).
Page is larger than printable area. Set page size to printable area?
Page margins fall outside printable area. Move page within printable area?
Replace existing (filename)?
Save changes to (filename)?
There are no items to be printed.
Unable to find (filename).
Unable to insert data into Worksheet.
Unable to load device driver (filename).
Unable to load (filename) completely.
Unable to open (filename).
Unable to paste data.
Unable to paste image.
Unable to print--please check printer.
Unable to print--please select printer.
Unable to render (filename) clipboard format.



An older Micrografx application is running. Close it and run WinChart again.

You are running another Micrografx application shipped with an older version of a required file.

Update the other Micrografx application, or close it and run WinChart again.



Are you sure you want to delete this file?

You are trying to delete a file.

Click Yes to delete the file or click No to return to WinChart.



Delete is not available in multiple areas.

More than one range is selected in the Worksheet.

Select only one range to delete.



Error writing (filename)--file not saved.

The file is not saved on the disk.

Type a new pathname to save the file on a different drive.



(Filename) is not a valid filename.

The filename contains more than eight characters, or contains characters that are not allowed.

Type a different filename.



(Filename) is not a valid WinChart file.

The file is not a WinChart file and cannot be opened.

Open a different file with a .GRF, .DRW, or .DAT extension.



(Filename) is read-only.

You are trying to save a file that is Read-Only. (You opened a file that is on a shared drive, and the file is 
in use by someone else.)

Type a different file name to save the file. The original file will not be erased.



(Filename) not found.

The file indicated is not in the current directory or on the diskette in the current disk drive, or the 
subdirectory does not exist.

Change directories to the directory containing the desired file, or reenter the complete pathname.



Insert is not available in multiple areas.

More than one range is selected in the Worksheet.

To insert a column or row, select only one range.



Invalid constant.

You typed a nonnumeric value into the Constant area of the Math dialog box.

Type a numeric value.



Invalid precision--must be in range 0 to 10.

You typed a nonnumeric value or a value that is not a valid number for the Function Precision area of the 
Regression dialog box.

Type a number from 0 to 10.



Invalid precision--must be in range 1 to 6.

You typed a nonnumeric value or a value that is not a valid number for the Function Precision area of the 
Regression dialog box.

Type a number from 1 to 6.



Invalid version--file may not be loaded correctly.

The file was saved in a previous version of the program.

Create a new file.



Leave data in Clipboard?

You are closing WinChart, and the Clipboard contains an object you cut or copied.

Click Yes to leave the data in the Clipboard to be available for other applications, or Click No to close 
WinChart and empty the Clipboard.



No symbol identifiers found in (filename).

You have chosen the ClipArt command and selected a drawing with no name assigned to any symbols.

Assign Symbol IDs to symbols in the chart, or open a chart that has symbols with Symbol IDs.



Not a valid page size.

You have typed a page size that cannot be set.

Type different page dimensions.



Not a valid point size.

You have typed a point size that cannot be set.

Type a number from 1 and 144.



Not enough disk space to spool file.

There is not enough room on the disk to print the chart.

Delete some files to make room, or insert another formatted disk and try again.



Not enough disk space--unable to save.

There is not enough room on the disk to save the chart.

Delete some files to make room, or insert another formatted disk and try again.



Not enough memory (all messages).

There is not enough system memory to run WinChart or to complete the current operation.

Remove memory-resident programs from memory. Either close other open applications or add additional 
memory to your computer. Emptying the contents of the Clipboard can also free memory.



Page is larger than printable area. Set page size to printable area?

You have chosen a page size or page orientation that is different from the printer page size or orientation.

Choose a different page size or page orientation.



Page margins fall outside printable area. Move page within printable area?

The drawing margins overlap the margins required by the printer.

Click Yes for WinChart to center the chart on the printer page. Click No to truncate the drawing and print 
what fits on the printer page. Click Cancel to return to the chart.



Replace existing (filename)?

A file already exists with the name you have typed.

Click Yes to replace the existing file. Click No to avoid replacing the existing file, and then choose the 
Save As command and type a different name.



Save changes to (filename)?

Changes have been made to the chart and have not been saved.

Click Yes to save the changes. Click No to waive saving the changes. Click Cancel to return to the chart 
without saving.



There are no items to be printed.

You have opened a new file and nothing has been created yet, or you have opened an existing file that is 
empty.

Create a chart or draw a symbol, or open an existing file that is not empty, and try again.



Unable to find (filename).

The file indicated is not in the current directory or on the diskette in the current disk drive, or the 
subdirectory does not exist.

Change directories to the directory containing the desired file, or reenter the complete pathname.



Unable to insert data into Worksheet.

The range of data values copied to the Clipboard exceeds the maximum number of rows or columns in 
the Worksheet, which is 16,384 rows and 256 columns.

Break the data into two or more data parts, insert each part, and save it as a separate DAT file.



Unable to load device driver (filename).

The driver is not on the path or is not installed.

Install the device with WinCharts installation program.



Unable to load (filename) completely.

The drawing you indicated does exist but cannot be completely loaded.

The diskette may be damaged, or there may be a damaged sector on the hard disk. Run the DOS 
CHKDSK command. Use a backup of the file you want to open.



Unable to open (filename).

When you save a file, or perform any similar operation, a temporary file is created. The program is looking 
for a directory called TEMP or TMP in which to store data temporarily, and none exists.

Add the following entries to AUTOEXEC.BAT file to provide for both TEMP and TMP directories.
For example,
Set TEMP=C:\TEMP
Set TEMP=C:\TMP

Then, be sure that you create these directories in the path you specified.



Unable to paste data.

There is not enough memory to complete the current operation.

Remove memory-resident programs from memory. Either close other open applications or add additional 
memory to your computer. Emptying the contents of the Clipboard can also free memory.



Unable to paste image.

There is not enough memory to complete the current operation.

Remove memory-resident programs from memory. Either close other open applications or add additional 
memory to your computer. Emptying the contents of the Clipboard can also free memory.



Unable to print--please check printer.

The printer is not available for printing.

Check the printer to ensure that it is online, has paper installed, and is properly set up for printing. Make 
sure that the printer driver is in the current directory or in a directory on the path.



Unable to print--please select printer.

You have not selected a printer.

Select a printer with the Printer Setup command in the File menu.



Unable to render clipboard format.

There has been an error transferring the object, or the driver is not working properly.

Contact Micrografx Technical Support at 214-234-2694.



Object Linking and Embedding (OLE)

WinChart includes object linking and embedding (OLE), a new feature that lets you edit an object in one 
application and automatically transfer the edited object to one or more applications.

Related Topics
OLE concepts
Clipboard operations and OLE
Object linking versus object embedding
Common problems
OLE terminology



OLE Concepts

OLE is a feature that lets you control information within a compound document. A compound document is 
a file containing one or more items created with different software applications. An item, hereafter referred 
to as an object, can consist of any chart you create in WinChart.

OLE operates on a server/client relationship. To help you remember this terminology, think of a waiter 
serving you dinner. You (the client) are represented by an open hand. The waiter (the server) is 
represented holding dinner (the object).

Note: Unlike some applications that can operate in either a server or a client mode, WinChart only 
operates as a server.



Clipboard Operations and OLE

To understand OLE, it helps to understand normal Clipboard operations. The Clipboard is the standard 
way you move data between applications. To transfer data using this method, you first open the 
application used to create the object. Next, you select and copy the object to the Clipboard. You then 
open the application into which you want to paste the object. To edit the object after it is pasted, you must 
return to the objects original file and repeat the complete procedure. (When you use OLE, you never 
repeat the copy and paste sequences.)

Though OLE operations appear similar to Clipboard operations, they are actually quite different. Clipboard 
operations require that the exchanged data be translated into a format that is understood by the client 
application. When data is translated, two things occur: the data is no longer editable by WinChart and the 
quality of the produced chart is often inferior. When OLE data is placed in the Clipboard by a server 
application, the data used by the server to edit, display, and print the object is also included. By saving the 
OLE data, the client application can restart the server application and allow the object to be edited. The 
client application also can use the OLE object and a rendering program (provided by the server 
application) to display and print the object.



Object Linking versus Object Embedding

A client application can save an OLE object using one of two methods: object linking or object 
embedding.

Object Linking

Use object linking when you want to insert a chart that will be updated later directly by WinChart or when 
the chart will be shared by several client applications.

A linked object contains a graphic representation of the object and information that identifies the original 
file and the server application. The actual object information resides in the original file.

Lets imagine you have a document created in Microsoft Write for Windows, an OLE-compatible word 
processing application. The document contains an object created in WinChart. If you edit the original 
WinChart file after linking it, then reopen the file, the changes made to the WinChart file automatically 
appear in the Write file.

Note: If the original file is moved to another directory, you must re-establish the link within the client 
application. If you do not re-establish the link, a non-OLE backup of the object appears.

Object Embedding

Use object embedding when the chart will be used in the client application only and to simplify file 
management.

An embedded object contains a graphic representation of the object and all the information needed to re-
create the original object.

The procedure for editing an embedded object is exactly the same as for a linked object. The difference 
between the two is that an embedded object resides inside the client application. An embedded object 
contains a server identifier and other server information that allows the client application to display and 
print the object in the server format.

OLE Exercise

This section provides an exercise to help you understand how compound documents are created 
between WinChart and Microsoft Write.

The exercises below show you how to create an object in WinChart, then link and embed the same object 
into a Microsoft Write file.

Note: If you have another client OLE application, such as Microsoft Word for Windows, you may 
substitute it for Microsoft Write in the following examples.

To link a WinChart object to a Write file:

1. Start WinChart by double clicking its program icon in the Program Manager.
2. Open an existing chart.
3. Select a chart you want to edit.
4. Open the Edit menu and choose Copy.

Note: You must use the Copy command to perform linking operations.

5. Minimize WinChart.
6. Start Write by double clicking its program icon in the Program Manager.



7. Type the sentence: This is a linked object. Press Enter twice.
8. Open the Edit menu and choose Paste Link. The object is linked from WinChart (the server) to 

Write (the client).

Note: The entire chart is linked when using object linking.

To edit the linked WinChart object in the Write file:

1. Double click the object in Write. WinChart opens and displays the object.
2. Make changes to the chart.
3. Open the File menu and choose Exit. A WinChart dialog box displays a message prompting you 

to save the current changes.
4. Click Yes. Write becomes active again, and the Write file reflects your changes.

To verify that the object is linked, open the Edit menu and choose the Links command. The Links dialog 
box opens and displays the chart filename. Click Ok to close the dialog box.

Now lets embed the same object into the same Write file.

To embed a WinChart object into a Write file:

1. Minimize Write, and start WinChart by double clicking its program icon in the Program Manager.
2. Open an existing chart.
3. Select a chart you want to edit.
4. Open the Edit menu and choose Copy.
5. Minimize WinChart, and open Write. Place the cursor in front of the end-of-file symbol and press 

Enter twice.
6. Type the sentence: This is an embedded object. Press Enter twice.
7. Open the Edit menu and choose Paste Special. The Paste Special dialog box opens.
8. Highlight the WinChart Object, and click Paste. The edited object is embedded into the Write file.

To edit the embedded WinChart object in the Write file:

1. Double click the embedded object in Write. WinChart opens and displays the object.
2. Make changes to the chart.
3. Open the File menu and choose Exit To Client. A WinChart dialog box displays a message 

prompting you to save the current changes.
4. Click Yes. Write displays the edited embedded object.
5. Open the Write File menu and choose Exit.
6. Click No when prompted to save current changes.



Common Problems

To prevent undesirable results, such as lost data or broken OLE links, read the following comments 
before using OLE.

Many applications prompt you to save data in the Clipboard when an application closes. If the data is to 
be linked or embedded, choose Yes. If you choose No, the information is lost and linking or embedding 
the object is no longer possible. This problem does not occur if the server application remains open while 
OLE transfers data.

Moving a linked file to another directory, or deleting a linked file, breaks the OLE link. You must re-
establish the link within the client application.



OLE Terminology

This section provides definitions for common terms associated with OLE.

Term: Definition:

Client application an application capable of accepting objects from OLE-compatible server 
applications

Clipboard a Windows feature allowing the transfer of information between Windows 
applications; Clipboard commands are Copy, Cut, Paste, Paste Link, and 
Paste Special

Compound document a document containing multiple objects created with different OLE-
compatible server applications

Embedded object an object containing a graphic representation of the object and all the 
information required by the server application to re-create the original 
object

Linked object an object containing a graphic representation of the object and 
information identifying the original server data file and application

Object a set of data such as a chart

Original file a file containing the source (original) object created with the server 
application; the original object can be linked to or embedded into a 
compound document

Paste Link a command used by the client application to link an object; the Paste 
Link command is similar to the Paste command

Paste Special a command used by the client application to embed an object

Server application an application capable of copying OLE-compatible objects to the 
Clipboard



Update Command

The Update command in the File menu lets you update (save) an embedded object in the client 
application and leave WinChart open.

Related Topics
Procedure information



Updating an Embedded Object

Choose the Update command in the File menu to update (save) the most recent changes to an 
embedded object.

To update an embedded object:

1. Select the embedded object within WinChart.
2. Click the File menu and choose Update. The current version of the object is updated in the client 

application.

Related Topics
Command information



Exit and Return To Command

The Exit and Return To command in the File menu lets you update (save) changes to an embedded 
object, exit the server application (WinChart), and return to the client application.

Related Topics
Dialog box information
Procedure information



Exit and Return To Dialog Box

Choosing the Exit and Return To command in the File menu opens the Exit and Return To dialog box.

The Exit and Return To dialog box informs you that the command you have chosen will close the 
connection between the open embedded object and the client application file. It then prompts you to 
select one of three choices: Yes, No, or Cancel.

· Yes updates (saves) changes made to the embedded object in the server application (WinChart), 
then restores the window of the client application.

· No does not update (save) changes to the embedded object and restores the window of the client 
application.

· Cancel cancels the Exit and Return To command and returns you to the current object in the 
server application (WinChart).

Related Topics
Command information
Procedure information



Exiting and Returning to the Client Application

Choose the Exit and Return To command in the File menu to update (save) an embedded object in the 
server application (WinChart), exit the application, and return to the client application.

To exit and return to the client application:

1. Double click the embedded object within the client application. WinChart opens and displays the 
object.

2. Select the object and make your changes.
3. Click the File menu and choose Exit and Return To. The Exit and Return To dialog box opens to 

inform you that this command will close the connection between the open embedded object and 
the client application. It prompts you to update the open embedded object before proceeding.

4. Click Yes. WinChart closes and the client application displays the edited embedded object.

Related Topics
Command information
Dialog box information



Save Copy As Command

The Save Copy As command lets you assign a name to an object file or make a copy of an existing object 
file by giving it a new name.

Related Topics
Dialog box information
Procedure information



Save Copy As Dialog Box

The Save Copy As dialog box opens when you choose the Save Copy As command in the File menu.

Save File As text box
Type a filename in the Save File As text box, then click Save.

Backup option
Use the Backup option to retain a copy of the previous version of the object file. WinChart appends the 
extension BAK to the filename. As long as the Backup option is checked, you have two copies of the 
saved drawing on disk: the current version and the previously saved version. The backup version is 
overwritten each time you save the drawing.

Related Topics
Command information
Procedure information



Saving an Object File

Choose the Save Copy As command in the File menu to assign a name to an object file.

To save an object file with a new filename:

1. Click the File menu and choose Save Copy As. The Save Copy As dialog box opens to let you 
type a new filename for the object file.

2. Type a filename for the drawing.
3. Click the Backup option, if you want.
4. Click Save.

Related Topics
Dialog box information
Command information



Preferences Menu

The Preferences menu lets you change the crosshairs, default page size, borders, orientation, and screen 
color.

Crosshairs Turns the crosshairs on and off.
Pages Lets you set up the page.
Rulers/Grid Lets you choose ruler and grid settings.
Screen Color Lets you choose the colors for your screen.



Crosshairs Command

In order to assist you in more precise positioning, you can turn on a set of crosshairs for your cursor.

Related Topics
Procedure information



Using the Crosshairs

To turn on the crosshairs

· Open the Preferences menu and choose Crosshairs.

To turn the crosshairs off, simply repeat the steps above.

Related Topics
Command information



Pages Command

Use the Pages command to choose the size of the page, the size of the page margins (borders), and the 
orientation of the page (portrait or landscape) within the presentation area. The default page size is 8 1/2" 
x 11" with a portrait orientation, and 0.75" margins on the left and right of the page and 0.50" margins on 
the top and bottom of the page.

Related Topics
Dialog box information
Procedure information



Pages Dialog Box

The Pages dialog box opens when you choose the Page command in the Preferences menu.

Show Pages option
The Show Pages option enables a grid that shows an outline of the pages in the presentation area.

Save option
The Save option causes WinChart to save the new page sizes as the default for future use.

Page Size area
The Page Size area lets you choose page size, width and height settings, and page orientation.

Six standard U.S. and international page sizes are available. In addition, you can choose a width and 
height setting in the Page Size area. 

Click the Print Area option in the Page Size area to get the largest drawing area for the selected printer.

Click the Portrait or Landscape option to choose the page orientation.

Margins area
The Margins area lets you choose the page margins (border widths) for left, right, top, and bottom 
margins. Type the margins you want in .01" increments, or use the scroll arrows to specify the values in 
.25" increments.

Save option
Click the Save option to save the settings as the new defaults.

Related Topics
Command information
Procedure information



Setting up the Page

Choose the Page command in the Preferences menu to set the page size, print area, page orientation, 
and margins.

To change the default page:

1. Open the Preferences menu and choose Page. The Page dialog box opens.
2. Choose the page size, margins, and page orientation.
3. Click Ok. The page changes accordingly.

Related Topics
Command information
Dialog box information



Rulers/Grid Command

The Rulers/Grid command opens a dialog box that lets you

· choose inches or centimeters for ruler units
· set the number of increments per ruler unit
· turn on or off Snap to Rulers and Show Grid
· save options in the dialog box as new defaults

Note: The Snap to Rulers option forces symbols to adhere to the ruler divisions.

Related Topics
Dialog box information
Procedure information



Rulers/Grid Dialog Box

Rulers area
Choose the Horizontal and Vertical settings for the Rulers.

Show Position option
Click Show Position to toggle the option on and off.

Show Rulers option
Click Show Rulers to toggle the option on and off.

Snap to Rulers option
Click Snap to Rulers to toggle the option on and off.

Save option
Click Save to save new defaults in the dialog box.

Related Topics
Command information
Procedure information



Changing the Rulers and Grid

To set the rulers and grid:

1. Open the Preferences menu and choose Rulers/Grid. The Rulers/Grid dialog box opens.
2. Choose the options that you want.
3. Click Ok. The rulers and grid change accordingly.

Related Topics
Command information
Dialog box information



Screen Color Command

The Screen Color command opens the Color/Style dialog box with the Screen Color command in the 
Color menu selected for you.

You can choose a color from the palette shown, or you may open another palette using the command 
under the Palette menu in the dialog box.

Related Topics
Procedure information



Setting the Screen Color

To set the screen color

1. Open the Preferences menu and choose Screen Color.
2. Select the color you want in the Color/Style dialog box.
3. Click Ok.

Related Topics
Command information



WinChart Read Me

Read this on-line "Read Me" file to learn about features not documented in the manual, corrections to the 
manual, and other information necessary for you to use WinChart. 

Click each topic below for more information.

Corrections to the Manual
Other Information



Corrections to the Manual

On page 3-20 of the WinChart section of the Graphics Works User's Guide, the second paragraph of the 
note incorrectly states "Click Button 1 to apply the chart." The sentence should read "Press Button 1 to 
apply the chart."



Other Information

Micrografx outline fonts are automatically installed with Windows Draw and WinChart. These fonts are not 
available for use with PhotoMagic or Windows OrgChart; however, TrueType fonts and ATM fonts can be 
used with all of the Graphics Works applications.

Windows Draw and WinChart do not provide a translation filter for Windows OrgChart (.WOC) files. Use 
the Windows Clipboard to transfer charts from Windows OrgChart to other applications.

ClipArt can be accessed directly from the compact disc, if you installed Graphics Works from the compact 
disc.

You cannot open Excel 4.x files in WinChart; however, you can save the file as an Excel 3.0 file in Excel, 
then open the file in WinChart.



Subject Index

Align
Arc button
Area Chart button
Arrange
Bar
Bitmap
Bkg option
Block Select
Chart Colors
Chart tool
Clear (Worksheet)
ClipArt
Color/Style
Color
Column
Connect
Copy
Copy (Worksheet)
Crosshairs
Current Color
Curve
Cut
Cut (Worksheet)
Delete
Delete (Worksheet)
Disconnect
Draw tool
Duplicate
Ellipse button
Ends
Exit
Fill option
Flip
Flip horizontally
Flip vertically
Font Style button
Freehand button
Gradient
Group
Hairline
Hatch
Insert (Worksheet)
Invisible
Line Chart button
Line option
Math
Name
New
New (Worksheet)
None
Object linking and embedding (OLE)
Open
Open Data (Worksheet)
Order



Pages
Paste
Paste (Worksheet)
Pie button
Pointer
Polyline button
Printer Setup
Print
Print all pages
Print Page
Print View
Rectangle button
Redraw
Remove
Rotate
Rounded Rectangle button
Rulers/Grid
Run
Save
Save As
Save Data (Worksheet)
Screen Color
Select All
Smooth
Solid
Sort
Table Chart button
Text Alignment button
Text Cursor button
Text option
Text tool
Undo
Undo (Worksheet)
Unfilled
Ungroup
Unsmooth
View Actual Size button
View All Pages button
View Page button
View Previous button
View tool
View Used Pages button
Width
Work
Zoom button



Text Tool

The Text tool lets you enter and edit text in your drawings, select typefaces and point sizes, and choose 
text attributes.

When the Text tool is selected, a set of tools specific to the Text tool appears.

Click an icon to learn more about it.

Click the Text Cursor button to enter and edit text in the presentation area.

Click the Font Style button to choose fonts, font sizes, and styles.

Click the Text Alignment button to set or change the alignment for selected text.



Text Cursor Button

The Text Cursor button lets you enter and edit text in the presentation area.

Press Shift+Enter to start a new text block.

Related Topics
Procedure information



Entering and Editing Text in the Window

To enter or edit text in the window:

1. Click the Text tool in the toolbox, then click the Text Cursor button. The pointer changes to 
indicate text mode.

2. Point to where you want to enter or edit text, and click Button 1. A blinking text cursor appears.
3. Type the new text or edit the existing text.
4. Press Esc to leave text mode. The text redraws.

Related Topics
Button information



Font Style Button

When you select the Font Style button in the toolbox, a dialog box listing fonts, font sizes and styles 
appears.

Related Topics
Dialog Box information
Procedure information



Fonts Dialog Box

The Fonts dialog box opens when you click the Font Style button in the toolbox.

Typeface list box
The Fonts dialog box lists the typefaces the specified printer supports (and any fonts already in the 
drawing). Winchart uses the closest screen font to match an outline or device font. The appearance of 
output, however, can vary. (The PostScript font Zapf Dingbats is an example of how different a font can 
look on the screen and when printed.)

Sample box
The Sample box displays the letter A in the currently selected typeface. When you highlight a typeface in 
the Fonts dialog box, the character in the box is redrawn using the highlighted typeface. You can type a 
different character in the box to have it display every time you open the Fonts dialog box.

Font Size list box
You choose the size of text in the Font Size list box. The font size you choose changes the size of 
selected text and sets the size for subsequent text. 

Font sizes are measured in points (the default) or in millimeters (mm).

Style area
The Style area lets you change the style of selected text. You can choose, Bold, Italic, Strike Out, or 
underline.

Set Chart Default option
Choose the Set Chart Default option to set the options you chose as the default options for text in charts.

All Text option
Choose the All Text option to set the options you chose as the default for all text.

Related Topics
Button information
Procedure information



Choosing Fonts, Font Sizes, and Styles

WinChart provides you with a choice of fonts (typefaces), font sizes, and styles. You can change fonts, 
sizes, and styles for selected text or specify them for text you enter at a later time.

To choose a font, font size, and style for selected text:

1. Click the Text tool in the toolbox.
2. Click the Font style button. The Fonts dialog box opens.
3. Scroll to the font you want to use and click Button 1 to select it.
4. Point to the number in the Font Size list box, and click Button 1 to highlight the point size.
5. Type a point size, then press Enter.
6. Click the Bold, Italic, or Underline Button. The text redraws on the screen with the new options 

you have selected.
7. Click Ok.

Related Topics
Button information
Dialog Box information



Text Alignment Button

The Text Alignment button lets you set or change the alignment for selected text. 

Related Topics
Dialog Box information
Procedure information



Align Text Dialog Box

The Align Text dialog box opens when you click the Text Alignment button.

Text Alignment options
Click one of the text alignment options to align text.

Option Result

Left Aligns text to the left margin, with a ragged right margin.

Center Centers text between the left and right margins.

Right Aligns text to the right margin, with a ragged left margin.

Top Aligns text to the top of its bounding box.

Middle Aligns text to the middle of its bounding box.

Bottom Aligns text to the bottom of its bounding box.

Related Topics
Button information
Procedure information



Aligning Text

Click the Text tool, then choose the Text Alignment Button to align text.

To align text:

1. Select the text you want to align.
2. Click the Text tool and choose the Text Alignment button. The Align Text dialog box opens.
3. Choose an alignment option. The text changes accordingly.

Related Topics
Button information
Dialog Box information



WinChart Toolbox

The WinChart toolbox gives you easy access to the tools you use most.

Click the Pointer tool to select, rotate, and reshape symbols.

Click the Worksheet tool to open the Worksheet.

Click the View tool to change the view of your presentation.

Click the Draw tool to choose a drawing tool.

Click the Chart tool to choose a charting tool.

Click the Text tool to enter and change text.

Click the Color tool to open the Color/Style dialog box.

Click the Snap tool to turn Snap on and off.

Click the Grid tool to toggle the grid on and off.



Pointer Tool

The Pointer tool lets you select, rotate, and reshape symbols.

Use the Pointer tool to select symbols, symbol handles, charts, and text.

Related Topics
Procedure information



Selecting Symbols, Handles, Charts, and Text

To select an item in the presentation area:

1. Click the Pointer tool in the toolbox.
2. Point to the symbol, text, or chart item and click Button 1 to select it.

Related Topics
Tool information



Snap Tool

The Snap tool forces symbols to adhere to the ruler divisions.

Unless you have specific reasons for turning it off, leave Snap on. Snap makes it easier to align text and 
symbols.

If you create a symbol when Snap to Rulers is turned off and then want to align the symbol to the current 
ruler divisions, select the symbol and turn Snap on. Then choose the Align command in the Change menu 
and choose the Ruler option.

Related Topics
Procedure information



Using the Snap Tool

To toggle Snap:

· Click the Snap tool.

Related Topics
Tool information



Grid Tool

The Grid tool toggles the display of the background grid on and off.

Related Topics
Procedure information



Using the Grid Tool

To toggle the grid on and off:

· Click the Grid tool.

Related Topics
Tool information



View Tool

The View tool provides six ways for you to view your work. You'll find view modes particularly useful when 
you want a full view of a drawing or when you want to perform detailed work on a symbol.

Click the Zoom button to zoom in on a symbol.

Click the View Page button to view the entire page.

Click the View All Pages button to see all of the pages.

Click the View Used button to see all of the pages that contain objects.

Click the View Actual Size button to view a drawing at actual size.

Click the View Previous button to return to the previous view.

Click the Redraw button to redraw the drawing.



Zoom Button

The Zoom button lets you see and edit symbols in finer detail. You define the zoom area by clicking and 
dragging bounding box surrounding the area or symbols you want to magnify.

Related Topics
Procedure information



View Page Button

The View Page button displays the entire page of the drawing, including the working area.

Related Topics
Procedure information



View All Pages Button

The View All Pages button displays all the pages available in the file

Related Topics
Procedure information



View Used Pages Button

The View Used Pages displays only those pages which are occupied by some part of the illustration or 
chart in this file.

Related Topics
Procedure information



View Actual Size Button

The View Actual Size button displays symbols in the same size they print. You can also select a symbol 
and click the View Actual Size button to center the selected symbol on the screen.

Related Topics
Procedure information



View Previous Button

The View Previous button displays (in reverse order) up to the last 16 views.

Related Topics
Procedure information



Redraw Button

The Redraw button clears the screen of unwanted "fragments" that occasionally result from manipulating 
symbols.

Related Topics
Procedure information



Using a View Button

To use a View button:

1. Click the View tool in the toolbox. A horizontal row of View buttons appears to the right of the tool.
2. Click the appropriate View button. The view changes accordingly.

Note: To use the Zoom button, point above and to the left of the area or symbol and drag a dotted 
rectangle around the view or symbol to enlarge the view.

Related Topics
Zoom button
View All Pages button
View Used button
View Page button
View Actual Size button
View Previous button
Redraw button



Worksheet Tool

The Worksheet tool in the toolbox opens the Worksheet. The Worksheet is a spreadsheet-like window 
which lets you open data files or enter data to be charted.

Before you create a data chart in WinChart, you must first open a data file or enter data in the Worksheet, 
and highlight the data that you want to chart.

Related Topics
Worksheet File menu commands
Worksheet Edit menu commands
Worksheet Data menu commands



Opening the Worksheet

To open the Worksheet:

· Click the Worksheet tool in the toolbox. The Worksheet opens.

Note: To open the Worksheet you may also Click Button 2, or press Ctrl+W.

The Worksheet window is a separate window from the WinChart window. Both windows do, however, 
share the same menu bar. When you open the Worksheet window, the menus for the Worksheet display 
in the menu bar; when you open the WinChart window, the menus change to reflect the available menus 
in the WinChart window.

Note: The Help menu on the right side of the menu bar displays in both the Worksheet window and the 
WinChart window.

The Worksheet consists of a matrix of data cells that are divided into a series of rows and columns. You 
use these cells to enter data values and labels for a chart. The current cell is the cell that is selected, and 
its contents display in the data editor. You can enter and edit data only in the current cell.



Worksheet File Menu Commands

New Click the New command to clear the Worksheet.
Open Data Click the Open Data command to open a data file.
Save Data Click the Save Data command to save the data in the Worksheet.



New Command (Worksheet File Menu)

The New command clears the Worksheet.

Related Topics
Procedure information



Clearing The Worksheet

The New command in the Worksheet File menu clears the Worksheet window. If the Worksheet you are 
working with has changed, and you did not save it before you chose the New command, a dialog box 
prompts you to save it before the window is cleared.

· Choose Yes to save the changes to the current file before opening another file.
· Click No to waive saving the changes. Any changes made to the data file are lost.
· Click Cancel to cancel the New command and return to the current data file.

Related Topics
Command information



Open Data Command (Worksheet File Menu)

The Open Data command opens a previously saved data file.

Choose the extension for the type of file you want to open. WinChart displays files with that extension in 
the current directory. You can change the directory if you wish. The Save option keeps the current 
directory as the default.

If you open a file, data from the file is placed into the Worksheet. If you open a GRF file, the chart is 
placed in the WinChart window and the corresponding data file is placed into the Worksheet.

Other data file types may be opened.

Related Topics
Dialog Box information
Procedure information



Open Data Dialog Box

WinChart can open files with the extension DAT, which is the WinChart file format. It may also open data 
files from other programs with compatible file formats.

The following file formats are compatible with WinChart:

File format Used by

DAT WinChart data file
DIF Data interchange format
DRW Micrografx Draw file format
SLK (SYLK) Excel and Multiplan
SPC ASCII files (space delimited)
WK1, WKS, Lotus 
XLS Excel (contains spreadsheet data)

Related Topics
Command information
Procedure information



Opening a Data File

To open a DAT file:

1. Open the Worksheet File menu and choose Open Data.
2. Locate and double click the filename.

To open a compatible data file:

1. Open the Worksheet File menu and choose Open Data.
2. Click the file format that you want.
3. Locate and double click the filename.

Note: Compatible spreadsheet files (such as XLS and SLK files) should contain only values and labels 
because formulas are not recognized by WinChart. If formulas are present, WinChart ignores them. If you 
use Lotus 1-2-3, Symphony, or Excel files, save the files as "values" rather than "formulas" so that 
WinChart can recognize and use their values.

Related Topics
Command information
Dialog Box information



Save Data Command (Worksheet File Menu)

The Save Data command saves the data from the Worksheet using the filename that you type in the 
dialog box. The extension is always DAT.

Related Topics
Dialog Box information
Procedure information



Save Data Dialog Box

The Save Data File dialog box opens when you choose the Save Data command in the Worksheet File 
menu.

Save File As text box
Type a filename in the Save File As text box, then click Ok.

Directories list box
The Directories list box displays directories and disk drives in brackets. If you choose [-a-], the directories 
and filenames on the diskette in drive A appear in the list box. To see the filenames in another directory, 
choose the directory name or type the directory name separated with backslashes. For example, type c:
\winchart\tutorial and press Enter. The filenames associated with the specified drive and directory 
appear in the list box.

To change directories, point to the directory containing the files you want to open and double click Button 
1. The list box changes to the directory you selected.

The current path is displayed below the Directories list box. To quickly back up one or more directories, 
double click the directory you want.

Related Topics
Command information
Procedure information



Saving Data

To save the Worksheet data:

1. Open the Worksheet File menu and choose Save Data.
2. Move to the drive and directory that you want to save the file.
3. Type a filename.
4. Click Ok.

Related Topics
Command information
Dialog Box information



Worksheet Edit Menu Commands

The commands in the Worksheet Edit menu undo operations and transfer data to and from the Clipboard. 
Other commands clear, delete, and insert rows or columns in the Worksheet.

Undo Reverses the last edit or change to a symbol.
Cut Cuts the selected data to the Clipboard.
Copy Copies the selected data to the Clipboard.
Paste Pastes the selected data from the Clipboard.
Clear Deletes the selected data from the Worksheet.
Delete Deletes the highlighted rows or columns from the Worksheet.
Insert Inserts rows or columns.



Undo Command (Worksheet Edit Menu)

The Undo command reverses the last change to a data element. The Undo command reverses 
commands in the Worksheet Edit and Data menus. The Undo command is disabled if it cannot reverse 
the most recent action.

Undo must be chosen immediately after an action, before any other changes are made.

The Undo command is a toggle. To reinstate the change (undo the undo), choose Undo again.

Related Topics
Procedure information



Reversing Changes in the Worksheet

To undo a change:

· Choose Undo in the Worksheet Edit menu, or press Alt+Backspace.

Related Topics
Command information



Cut Command (Worksheet Edit Menu)

The Cut command moves highlighted data from the Worksheet to the Clipboard. From the Clipboard, data 
can be pasted back into the Worksheet starting at another data cell.

Related Topics
Procedure information



Cutting Data to the Clipboard

To cut data to the Clipboard:

1. Highlight the range of cells you want to cut.
2. Open the Worksheet Edit menu and choose Cut, or press Shift+Del.

Related Topics
Command information



Copy Command (Worksheet Edit Menu)

The Copy command copies highlighted data from the Worksheet to the Clipboard. From the Clipboard, 
data can be pasted back into the Worksheet starting at another data cell.

Related Topics
Procedure information



Copying Data to the Clipboard

To copy data to the Clipboard:

1. Highlight the range of cells you want to copy.
2. Open the Worksheet Edit menu and choose Copy, or press Ctrl+Ins.

Related Topics
Command information



Paste Command (Worksheet Edit Menu)

The Paste command retrieves data from the Clipboard that was cut or copied from the Worksheet. The 
data values are inserted into the Worksheet starting at the first highlighted cell.

Related Topics
Procedure information



Pasting Data

Use the Paste command to insert copied or cut data into a cell or a range of cells, or to paste data copied 
from another application.

To paste data from the Clipboard:

1. Select the cell in the Worksheet.
2. Open the Worksheet Edit menu and choose Paste, or press Shift+Ins.

Related Topics
Command information



Clear Command (Worksheet Edit Menu)

The Clear command deletes data from a highlighted cell or range of cells. Data deleted with the Clear 
command cannot be retrieved except by immediately choosing the Undo command.

Related Topics
Procedure information



Clearing Data

To clear data from the Worksheet:

1. Highlight the range of cells you want to clear.
2. Open the Worksheet Edit menu and choose Clear.

Related Topics
Command information



Delete Command (Worksheet Edit Menu)

The Delete command deletes highlighted rows or columns of cells and moves adjoining rows up. 
Adjoining columns move to the left.

Related Topics
Procedure information



Deleting Rows or Columns

If you delete a row, the rows below move up to replace the deleted row. If you delete a column, the 
columns on the right side of the data move to the left to replace the deleted columns.

If you delete data by mistake, use the Undo command immediately to recover the data.

To delete rows or columns:

1. Highlight a range of rows, columns, or cells.
2. Open the Worksheet Edit menu and choose Delete.
3. If the dialog box opens, choose the Rows or Columns option.
4. Click Ok.

Related Topics
Command information



Insert Command (Worksheet Edit Menu)

The Insert command adds blank rows or columns of cells and moves highlighted rows down; highlighted 
columns move to the right.

Related Topics
Procedure information



Inserting Rows or Columns

If you insert a column, the columns move to the right to accommodate the inserted column. If you insert a 
row, the rows move down to accommodate the inserted row.

To insert rows or columns:

1. Highlight a range of rows, columns, or cells.
2. Open the Worksheet Edit menu and choose the Insert command.
3. If the dialog box opens, choose the Rows option or Columns option.
4. Choose Ok.

Related Topics
Command information



Data Menu Commands

Use the Data menu commands to sort and perform arithmetic operations on the selected data in the 
worksheet.

Sort Click the Sort command to arrange selected data.
Math Click the Math command to perform arithmetic functions on selected data.



Sort Command

Use Sort to select options to arrange data in the currently selected cell or block of cells.

Related Topics
Dialog Box information
Procedure information



Data Sort Dialog Box

Sort area
Select Horizontally to sort the data across the row; select Vertically to sort the data down the column.

Order area
Select Ascending to order the data from low number to high number. For example, 4 3 8 6 sorts to 3 4 6 
8. Select Descending to order the data from high number to low number. For example, 4 3 8 6 sorts to 8 6 
4 3.

Related Topics
Command information
Procedure information



Sorting Data

The Sort command sorts highlighted data in ascending or descending order, and horizontally or vertically. 
You can also use the Sort command to alphabetize category (x-axis) labels and value (y-axis) labels.

To sort data:

1. Highlight a range of cells.
2. Open the Data menu and choose Sort.
3. Choose the Horizontally or Vertically option.
4. Choose the Ascending or Descending option.
5. Click Ok.

Related Topics
Command information
Dialog Box information



Math Command

Use the Math command to select an arithmetic operation to perform on the currently selected cell or block 
of cells.

Related Topics
Dialog Box information
Procedure information



Data Math Dialog Box

Function area
The Function area lets you choose the arithmetic function you want to perform on the selected data.

Click To

Add Add the numbers in the cell or block of cells
Subtract Subtracts the numbers in the cell or block of cells
Multiply Multiplies the numbers in the cell or block of cells
Divide Divides the numbers in the cell or block of cells

Constant Area
Type the number in the Constant area that is to be used with the selected operation. For example, if you 
select Add and type 5, then 5 is added to the currently selected cell or block of cells.

Related Topics
Command information
Procedure information



Using the Math Command

The Math command performs one of four arithmetic functions on highlighted cells: addition, subtraction, 
multiplication, and division.

To use the Math command:

1. Highlight a range of cells.
2. Open the Data menu and choose Math.
3. Type a numeric constant.
4. Choose one of the four arithmetic functions.
5. Click Ok.

Related Topics
Command information
Dialog Box information



Chart Labels

Most data charts contain three types of chart labels:

· category labels
· value labels
· series labels

WinChart uses the first column of highlighted data in the Worksheet for category labels in a chart, while it 
uses the first row of highlighted data for series labels. Value labels are automatically generated by 
WinChart. The range of highlighted data values determines the range (or scale) of value labels in the 
chart.

Note: WinChart recognizes only non-numeric labels in the Worksheet.



Moving Around the Worksheet

You can use the mouse or the keyboard to move around the Worksheet. 

Youll find it most efficient to use the keyboard when moving to an adjacent cell, while its convenient to use 
the mouse when selecting a distant cell. 

To move with the mouse, simply point and click. To move using the keyboard, you use Tab, Shift+Tab, 
Up Arrow, and Down Arrow. 



Entering and Editing Data

The data editor under the Worksheet title bar displays the information in the current cell. (The cells 
identification appears to the left of the data editor.) If the cell is empty, the data editor is also empty. When 
you enter data into the current cell, the data value appears in the data editor and in the current cell.

You can enter up to 80 characters in each cell; however, the cell may not display all the characters. The 
data editor under the Worksheet title bar does display what is in the current cell. For numeric entries, 
WinChart plots a chart based on only the first 17 digits.

To enter data in the Worksheet:

1. Select the data cell.
2. Type the data for the cell.

To edit a data cell:

1. Select the data cell.
2. Move the pointer to the data editor. The pointer changes to a vertical, text cursor.
3. Move the cursor to the right of the numbers or letters that you want to edit.
4. Click Button 1 to insert the cursor.
5. Press Backspace to delete the number or letter, and type the new number or letter.

Note: You can edit data in only one cell at a time.



Highlighting Data

WinChart creates charts using selected (highlighted) data from the Worksheet. You can highlight all the 
data in the Worksheet, a range of data cells, or several ranges of cells.

To highlight all the cells in the Worksheet:

· Click the asterisk in the upper left corner of the cells.

To deselect highlighted cells, choose any cell and click Button 1 or press esc. (If in Edit mode, press Esc 
twice.)

To highlight a range of cells:

1. Point to the cell at the beginning or the end of the range of cells.
2. Press Button 1 and drag the pointer to the opposite end of the range of cells. If the pointer meets 

the edge of the Worksheet, the Worksheet scrolls to let you continue highlighting.

To highlight a large range of cells:

1. Point to the first cell in the range, and click Button 1 to choose it, but not highlight it.
2. Use the Worksheets scroll bars to display the end of the large data range.
3. Point to the last cell in the range.
4. Press Shift and click Button 1 to highlight the range.

Note: To highlight a range of columns (or rows), choose a letter at the top (or a number at the left) of the 
Worksheet. Then drag the pointer to highlight additional columns (or rows).

You can highlight multiple ranges of cells in the Worksheet (a maximum of 10 ranges) to be plotted in a 
chart. This is useful when importing data (for example, from Lotus 1-2-3) with embedded spaces and 
labels because you can then avoid selecting these cells. You can also move ranges in the Worksheet 
using the Cut, Copy, and Paste commands in the Worksheet Edit menu.

Note: The order in which multiple ranges are highlighted determines the order in which they are plotted, 
with the first range plotted first. 

To highlight multiple ranges of cells:

1. Highlight the first range of cells as previously described.
2. Point to the cell at the beginning or the end of another range of cells.
3. Press and hold Ctrl, then press and hold Button 1.
4. Drag the pointer to the opposite end of the second range of cells.
5. Release Ctrl and Button 1.
6. Repeat steps 2 through 5 to highlight additional ranges.



Using WinChart

Creating data charts
Drawing symbols
Opening charts
Printing presentations
Setting the Rulers
Setting up the Page
Viewing presentations




