
Contents
Navigation

Installation

Main Window

Menu Bar

Tool Bar

Status Bar

Using the Pointer

Accessing On-line Help

Exiting

Working with Images

Opening a File

Displaying Thumbnails

Area Manipulation

Color Adjusting

Orientation

Size & Color Level

Undo

Zooming

Displaying File Information

Printing

Saving an Image

Enhancements

Renaming Files

Deleting Files

File Encoding

Windows Administration

Files

Thumbnail Database

Preferences

Mosaic and Netscape

Supported File Formats

BMP



EPS/PS

GIF

JPEG/JPG/JFIF

PCX

PNG

RAS

TGA/TARGA

TIF/TIFF

XWD

Contact and Ordering

Profile

Copyright and License



Installation
To install for Windows:

1. From diskette, insert disk #1 into the proper floppy drive. From hard disk, verify the location of the 
GraphX Viewer installation files.

2. Choose Run from the Windows Program Manager File menu.

3. Type a:install (designate the appropriate drive or path location) and select OK.

4. Follow the directions on the screen to navigate the Install program.

GraphX Viewer requires a minimum configuration of a 386/486 PC compatible, Windows 3.1, 4MB RAM, 
3MB of hard disk space, and a Super VGA level (256 colors) display.



Main Window
GraphX Viewer loads images both in full-screen mode and in thumbnail mode. When loaded full-screen, 
images can be panned, zoomed, and edited in the main window. When in thumbnail mode, small 
thumbnail size images of graphics files are displayed in the main window. Thumbnails can be selected 
using the pointer. Double click on a thumbnail to launch it into full-screen viewing mode.



Menu Bar
The menu bar is the horizontal bar across the top of the GraphX Viewer window that lists the title of each 
pull down menu. Options include:

File - Includes Open and Save, Display Thumbnails, Encode and Decode, Rename and Delete, Print, and 
Exit.

Edit - Includes Undo, Cut, Copy, Paste, and Clear.

View - Includes Refresh, Zooming, and Information.

Image - Includes Color Adjust, Orientation, Size & Color, Invert, Swap Red & Blue, Emboss, Equalize, 
Remove Noise, and Sharpness.

Area - Includes Mirror X, Mirror Y, Rotate-90, Crop, and Duplicate.

Options - Includes Thumbnail Database, and Preferences.

Help - Includes Contents, Using Help, and About.



Tool Bar
The Tool Bar consists of a row of icons displayed directly below the Menu Bar.

The tools in the order of appearance are:

Open
Save
Display Thumbnails
Print
Undo
Zoom In
Zoom Out
Info
Color Adjust
Orientation
Size & Color
Help
Exit



Status Bar
A status bar appears at the bottom of the GraphX Viewer window.

The status bar displays a help prompt for each menu item or tool selected. In addition, the zoom level, 
X:Y cursor location, and stretch percentage are shown for the full-screen mode. A selected image's 
sequence number, file name, and format information is displayed when in thumbnail mode.



 Using the Pointer
The Pointer (cursor) is used to select menus, tools, and thumbnail images. The Pointer is also used to 
define areas for moving, sizing, cutting, copying, pasting, duplicating, mirroring, rotating, and bounded 
area manipulation.

To define an area, Select and Drag the Bounding Box until an area is enclosed, then Release. Cancel to 
unselect. Press <Shift> or use the middle mouse button to produce an exact square.



 Accessing On-line Help
Select Help from the menu bar or Select the Help Tool. The Help menu includes the following help 
capabilities:

1. Contents. A dialog box containing the help topics is displayed. Select a topic from the list and its 
appropriate help message displays.

2. Using Help. Help is provided on using the help system.

3. About. The version number and copyright information is displayed.



 Exiting
Select Exit from the File menu or Select the Exit tool to end a GraphX Viewer session. A dialog box asks 
whether to save the image or to exit without saving if the current file has not been saved since the last 
change. 



 Opening a File
Select Open from the File menu or Select the Open tool. The File Selection dialog box is displayed. Use 
the pop-up List Files menu to Select a filter extension. 

Use the Directories list box to select the path and the File Name list box to select the file name or 
manually type the name of the file in the input field. The specified file is loaded when the OK button is 
pressed.



 Displaying Thumbnails
Select Display Thumbnails from the File menu or Select the Display Thumbnails tool to display a list of the 
currently defined thumbnail catalogs. The Display Thumbnails dialog box is displayed. Use the Current 
Catalogs list box to select the desired thumbnail catalog.

To build a new catalog, Select the Build New Catalog button. Use the Directories list box to select the 
desired directory path. Use the Files list box to view the image file names located in the selected 
directory. Enter a name for the catalog in the Catalog Name input field and Select OK.

The Update Database? dialog will prompt you before adding images to the thumbnail database. Select 
Yes to add the images to the database, No to view the thumbnail images without adding them to the 
thumbnail database, or Cancel to discontinue the operation.

Once thumbnail images are loaded, double click on any thumbnail to launch the image into fullscreen 
editing mode.



 Area Manipulation
An area is defined by the Pointer. A rectangular area is bounded by a dotted line with a small black 
square at each vertex (Bounding Box). An area may be cut, copied, duplicated, moved, sized, rotated, 
and mirrored.

1. Clear, Copy, Crop, and Cut. Define an area and then apply the appropriate function.

2. Paste. Apply the appropriate function and then move and size the pasted area.

3. Move. The cursor changes to a four-sided arrow when placed within the Bounding Box. Select 
anywhere the four-sided arrow is present, then Drag the outline to the new location, and Release. 
The Status Bar indicates the change in position as the outline is moved. 

4. Size. The cursor changes to a side pull bar or a corner pull bar when placed at the edges or on 
the black squares in the corners of the Bounding Box. Select a pull bar and Drag the side or 
corner to the desired size. Press <Shift> to size proportionately. The Status Bar indicates the 
change in scale as the outline is moved.

5. Duplicate. Ensure that the Duplicate check on the Area menu is On. Select an area using the 
Pointer, then Select and Drag from inside the bounded area to move a duplicate image of that 
area anywhere on the Canvas.

6. Mirror. Select an area using the Pointer. Select Mirror X or Mirror Y from the Area menu. The 
bounded area is inverted along the appropriate axis.

7. Rotate-90. Select an area using the Pointer. Select Rotate 90 from the Area menu. The bounded 
area is rotated 90 degrees around its center.



 Color Adjusting
To modify the brightness, contrast, or gamma of an image, Select Color Adjust from the Image menu or 
Select the Color Adjust tool. Select and Drag the appropriate slider to the desired value. Select the 
Channel pop-up to define the color channel as Red, Green, Blue, or All. Press View to interactively adjust 
the image, OK to accept the changes, or Cancel to discard the changes.



 Orientation
An image may be rotated 90, 180, or 270 degrees. Select Orientation from the Image menu or Select the 
Orientation tool. Select the desired orientation. Press OK to change the image.



 Size & Color Level
Select Size & Color from the Image menu or Select the Size & Color tool. Enter the dimensions for Width 
and Height in pixels and Select the Maintain Aspect Ratio box if the proportional ratio between Height and 
Width is to be maintained. GraphX Viewer provides a high quality algorithm for stretching and reducing an 
image; however, size increases will eventually blur any image. Maintain the aspect ratio to produce the 
best results.

Select the desired color reduction option to reduce the number of colors in the image. Press View to 
interactively adjust the image, OK to accept the changes, or Cancel to discard the changes.

It is quite possible to define a combination of Width and Height which exceeds the memory capacity of the 
system. An error message indicates that the system is out of memory when such values are entered. 
Select a smaller size to reduce memory utilization.



 Undo
Select Undo from the Edit menu or Select the Undo tool to reverse the immediately previous action. 
GraphX Viewer provides one level of undo. An action consists of one iterative procedure and includes 
area manipulation, cut/paste, color/size change, orientation, filtering, or thumbnail display. It does not 
apply to the Delete, Rename, or Save functions.



 Zooming
Select a zoom level from the View menu or Select the desired Zoom tool. The Positive Zoom tool zooms 
in on the image, the Negative Zoom tool zooms out on the image. The View menu contains options for 
fitting the entire image in the window and for fitting the width of the image in the window.



 Displaying File Information
Select Information from the View menu or Select the Info tool to display a dialog of information about the 
currently loaded or selected thumbnail image.

Information is displayed for file name, file size, and modification date. In addition, the graphics format type 
is defined, compression method used, width and height dimensions in pixel units, aspect ratio 
(height/width), color type, and number of color shades.



 Printing
Select Print from the File menu or Select the Print tool. Select Setup to change the target Printer or printer 
definitions. GraphX Viewer allows printing of a single image, a selected thumbnail, a range of thumbnails, 
or an entire thumbnail catalog.

GraphX Viewer appropriately fits an image to the page when printing. Enter a Margin value in inches to 
define the amount of spacing between the image and the edge of the page. For thumbnail printing, define 
a Thumbnails Per Page value to define the thumbnail layout.



 Saving an Image
Select Save or Save As from the File menu or Select the Save tool. Save stores the image under its 
existing file name and native format. Save As allows a new file name to be entered or a new format or 
variation of the existing format to be defined.

The File Selection dialog box is displayed. Select a file format using the Files Type pop-up menu. Select 
the Options button to define color depth, compression, and options associated with the defined file type. 
Use the Directories list box to select the path and the File Name list box to select the file name or 
manually type the name of the file in the input field. The current image is saved under the specified file 
name when the OK button is pressed.

Related Topics:
Options



Options

Color Depth. Allows saving an image at any supported bit depth. When the defined bit depth contains 
fewer colors than that found in the current image, dithering will be used to reduce the number of colors.

Compression. Some file formats support different compression methods or no compression at all. 
Possible options include None, RLE, LZW, Packbits, Group 3, Group 4, CCITT, JPEG, and ZIP.

JPEG Quality. The export quality, Q Factor, of JPEG images can be defined from 25 to 100. The Q 
Factor determines the amount of lossiness for an image inversely related to the amount of compression 
for an image. For example, a Q Factor of 25 would produce maximum image loss but the most 
compression. A Q Factor of 100 would produce a near lossless image but with almost no compression.

Interlaced. Images that are interlaced provide a seemingly faster view time when displaying via an on-
line service. This is possible because it first displays a less detailed image followed by a display of the 
complete image.



Enhancements
A number of filtering methods can be applied to an image to change and enhance it. Following are 
descriptions for each method and the purpose for using it.

Related Topics:
Emboss

Equalize

Invert

Remove Noise

Sharpness

Swap Red & Blue



Emboss

To apply an embossed filtering effect to an image, Select Emboss from the Image menu. Select and Drag 
the Light Angle slider to the desired value. Press View to interactively adjust the image, OK to accept the 
changes, or Cancel to discard the changes.



Equalize

When an image is too dark or too light and cannot be adequately adjusted using the brightness control, it 
is recommended to use the Equalize filter. This filter analyzes the image's histogram of luminosity and 
adjusts the colors so that an equal amount of luminosity exists throughout the image. To equalize the 
image, Select Equalize from the Image menu.



Invert

When importing image files from a variety of sources it is possible to run across an image that has been 
inverted. This is often true of monochrome files. To invert the image, Select Invert from the Image menu.



Remove Noise

Often a file comes from a source which has introduced noise to the image. For example, a video grab 
may include small white pixels (snow) or a fax file might contain a number of small black pixels. The 
Remove Noise filter can help clean such images.

This filter evaluates every pixel in an image, samples the surrounding pixel values, determines a median 
color value, and compares the original pixel value to that median. If the difference is greater than the 
defined threshold value, the pixel is replaced by the median color value. Threshold values can be defined 
from 1 to 128. A higher defined value results in less pixel replacement. Conversely, a lower value results 
in more pixel replacement. A value between 32-64 is recommended for effective noise reduction.

To remove noise from an image, Select Remove Noise from the Image menu. Select and Drag the slider 
to the desired value. Press View to interactively adjust the image, OK to accept the changes, or Cancel to 
discard the changes.



Sharpness

To modify the sharpness of an image, Select Sharpness from the Image menu. Select and Drag the slider 
to the desired value. Press View to interactively adjust the image, OK to accept the changes, or Cancel to 
discard the changes.



Swap Red & Blue

When importing image files from a variety of sources it is possible to run across an image with the red 
and blue pixels swapped. This is often true of SunRaster files. To swap the red and blue pixels, Select 
Swap Red & Blue from the Image menu.



Renaming Files
While in thumbnail mode, Select the desired image or range of images to rename. Select Rename from 
the File menu. In the Rename dialog box, input the desired file name. Include both the suffix and prefix for 
the file name.



Deleting Files
While in thumbnail mode, Select the desired image or range of images to delete. Select Delete from the 
File menu. A warning dialog will prompt before deleting the file. Select OK to delete the file or Cancel to 
end the delete procedure.



File Encoding
File encoding is a method used to convert binary files into coded ASCII files. By doing this, it creates a file 
that is easier and more reliable to transfer via telecommunication lines. This method is most often used 
for mailing or posting binary files to the Internet. When transferring files between Unix and DOS systems, 
be sure the naming scheme of the original file and the encoded files are appropriate.

Related Topics:
Encoding

Decoding



Encoding

The encoder can encode any binary file including images and executable files. It provides options for the 
popular UUencoding technique or the XXencoding method. In addition, longer files can be separated into 
multiple parts using a variety of popular methods.

Select Encode from the File menu. A File Selection dialog box is displayed. Use the Directories list box to 
select the path and the File Name list box to select the file or manually type the name of the file in the 
input field. Select either the UU or XX encode method. Select the Multi-Part Format pop-up to define 
Single File or the desired multi-part method. If a multi-part format is selected, enter the maximum file size 
in bytes in the Max File Size input field. The default is 60,000.

The Encode File Name dialog is displayed when the OK button is pressed. By default, Single File format 
files are named with the original prefix and the appropriate UUE or XXE suffix. For example, image.gif 
would become image.uue. Multi-part format files have the prefix appended with the part number and are 
given the appropriate UUE or XXE suffix. For example, a 3-part image.gif file would become 
image01.uue, image02.uue, and image03.uue.



Decoding

The decoder can decode any UUencoded or XXencoded file. In addition, it can decode multi-part files 
without the user having to combine them into one file with a text editor.

Select Decode from the File menu. A File Selection dialog box is displayed. Specify a filter extension, then 
use the Directories list box to select the path and the File Name list box to select the file or manually type 
the name of the file in the input field. The specified file is decoded when the OK button is pressed.

The Save Decoded File dialog displays the decoded file name as defined the encoded file. Accept the file 
name or change appropriately.

For multi-part files, you will be prompted to define each part in sequence. The decoder will discard any 
message text or CUT remarks in the file and automatically construct the multiple parts into a single binary 
file. Be careful to define the files in order.



Files
GraphX Viewer requires the following files.

Delivered:

gviewer.exe¾binary executable

gviewer.hlp¾help file

gviewer.ini¾defaults located    in \windows

bc45rtl.dll¾control file

bids45.dll¾control file

bwcc.dll¾control file

ctl3dv2.dll¾control file

owl250.dll¾control file

readme.txt¾updated release information

Created by GraphX Viewer:

gviewer.dat¾thumbnail database file



Thumbnail Database
GraphX Viewer maintains a database file called gviewer.dat for all the defined image catalogs. This file, 
by default, is located in the GraphX Viewer directory. It can be located in a different directory as long as 
the path is modified for the DatPath definition located in the gviewer.ini file. For users accessing GraphX 
Viewer on a network server or on a Windows NT server, it is important to define the DatPath variable to 
the local client.

When a new image catalog is defined, thumbnails are built and added to the gviewer.dat file. Each 
thumbnail increases the size of the gviewer.dat file by 10 KB. This database file provides fast thumbnail 
display of an image catalog. Images that have been deleted, renamed, or added are appropriately 
updated during the next catalog display.

Select Thumbnail Database from the Options menu. The Thumbnail Database dialog allows image 
catalogs and their associated thumbnails to be removed. This should be done when a directory has been 
removed, a thumbnail catalog is no longer desired, or the user wants to decrease the physical size of the 
gviewer.dat file. Highlight the desired catalog and Select the Delete button to remove its entry.

Eventually the database will begin to develop "empty" slots after several catalog deletions. When the 
Percentage Used status drops below 90%, Compact Database will improve access time and reduce the 
gviewer.dat file size. A minimum swap space equal to that of the gviewer.dat file is required for a 
successful compression.



Preferences
Several options relating to the operation of the GraphX Viewer environment are included on the 
Preferences dialog box.

Select Preferences from the Options menu:

1. Image Display. On systems using less than a 24-bit display, GraphX Viewer can load images 
using a "best fit" to the currently defined system color map or can dither the image for the best 
possible display. Select Fast to have the images load, zoom, and scroll at optimum speed. Select 
Best to have images fully dithered when loading. Depending on the color content of an image, the 
difference between Fast and Best might not be detectable. However, the Fast option does 
improve speed considerably. All images retain their native color content regardless of the on-
screen display.

2. Thumbnail Display. The arrangement of thumbnails in the window may be defined by the user or 
set automatically by the system. Select Preferences from the Options menu, then Select Auto to 
allow the system to pick the best arrangement of thumbnail images. Select Custom and enter a 
numeric value in the input field to specify the number of thumbnails per row.

3. Save Settings. Select this button and the gviewer.ini file is automatically updated with the current 
settings.



Mosaic and Netscape
GraphX Viewer can be defined as an external viewer or "helper" application in most common Web 
browsers including Mosaic and Netscape. Doing this extends the capabilities of viewing, editing, and 
saving images from the Internet.

To define GraphX Viewer as the image viewer, edit the browser's configuration for viewing image files. 
Define the GraphX Viewer executable as the viewer for all the supported image formats.

Related Topics:
Enhanced Mosaic 2.x

Netscape Navigator



Enhanced Mosaic 2.x

To configure GraphX Viewer in Enhanced Mosaic 2.x from Spyglass, Select Helpers located in the Edit 
menu. Change the viewer option for the formats JPEG, GIF, and TIFF. Input the GraphX Viewer 
executable in the Helper Application field making sure not to append this entry with %s. Input GViewer in 
the Service Name field. GraphX Viewer utilizes the Spyglass SDI for optimal communication.



Netscape Navigator

To configure GraphX Viewer in the Netscape Navigator, Select Preferences located in the Options menu. 
Change the settings for Helper Applications. Define the GraphX Viewer executable for the supported 
image formats.



BMP
OS/2 Bitmap: Similar to Windows BMP, the standard image format for use with OS/2. GraphX Viewer 
supports BMP files with no compression.    Color depths may be 1, 4, 8, or 24-bit.

Windows Bitmap: The image format created by Microsoft for use with Windows. GraphX Viewer 
supports BMP files with no compression.    Color depths may be 1, 4, 8, or 24-bit.



EPS/PS
Encapsulated PostScript: A PostScript output program file. PS files are typically sent directly to 
PostScript printers, while EPS files are created for importing into other products. GraphX Viewer exports 
EPS and PS files to PostScript Level 1 (8-bit gray scale) or PostScript Level 2 (24-bit color).



GIF
Graphics Interchange Format: The format created by CompuServe for the efficient exchange of 
graphics over modem lines. This format is commonly found on many on-line services and throughout the 
Internet. GraphX Viewer supports type 87a, 89a, interlaced, and non-interlaced GIF files. Color depths 
may be 1, 4, or 8-bit.



JPEG/JPG/JFIF
Joint Photographic Expert Group: 24-bit support and excellent compression make this format a new 
standard for on-line services. GraphX Viewer supports JPEG code version 5. Color depths may be 8-bit 
gray scale or 24-bit color. Export quality, Q factor, can be defined from 25 to 100.



PCX
ZSoft's PC Paintbrush: GraphX Viewer supports the import of PCX versions 2, 3, 4, and 5 and exports 
PCX version 5. Images must use standard PCX RLE compression. Color depths may be 1, 4, 8, or 24-bit.



PNG
Portable Network Graphics: The format created in response to the GIF licensing debacle. Developed for 
optimized graphics use on the Internet and other on-line services. GraphX Viewer supports interlaced and 
non-interlaced PNG files. Color depths may be 1, 2, 4, 8, 16, 24, or 48-bit.



RAS
Sun Raster: The native bitmap file format for Sun workstations. GraphX Viewer supports Sun Raster files 
with color depths of 1, 8, or 24-bit and supports standard RLE compression.



TGA/TARGA
Truevision Advanced Raster Graphics Adapter: Introduced by AT&T to support their image capture 
boards and now supported by Truevision. GraphX Viewer supports TARGA Type 2 (no color map, 
uncompressed) and Type 10 (no color map, RLE compressed) files. Color depths may be 16, 24, or 32-
bit.



TIF/TIFF
Tagged Image File Format: The most widely used raster format, it is jointly developed and supported by 
Aldus and Microsoft. GraphX Viewer supports Type 1 (no compression), Type 5 (LZW compression), and 
Type 32773 (Packbits compression). Color depths may be 1, 4, 8, or 24-bit. GraphX Viewer also supports 
CCITT Group 3 and Group 4 fax formats. Multi-page TIFF files display only the first image and there is no 
support for tiled or JTIF images. Imported TIFF files may be in either Intel or Motorola byte order. 
Exported TIFF files comply with the TIFF 6.0 specification.



XWD
X Window Dump: A screen dump raster format created by M.I.T. for use with the X Window utilities xwd 
and xwud. This format is also supported by many X Window applications and is an excellent means for 
creating image files from the X Window System. GraphX Viewer supports uncompressed XWD files in 1, 
4, 8, or 24-bit color depths.



Contact and Ordering
To purchase a commercial version of GraphX Viewer or inquire about site licenses, OEM bundling, 
graphics libraries, or other Group 42 products, contact us at:

Orders: 800-520-0042
Telephone: (513) 831-3400
Internet: info@group42.com
Web: http://www.group42.com
CompuServe: 73441,305

GraphX Viewer is available for Windows, Windows NT, and a variety of Unix X/Motif platforms. GraphX 
Viewer for Windows is priced at $49.95, GraphX Viewer for Unix is priced at $99.95. Prices are subject to 
change. Payment is accepted via Mastercard, Visa, COD, and prepay check.

Technical support is provided for registered commercial users via Internet email, CompuServe, or snail 
mail.

Group 42, Inc.
228 Mill Street #102
Milford, OH 45150



Profile
Group 42 is a developer of graphics and imaging software with products for Unix, Windows, and Windows 
NT platforms. We specialize in developing functional, yet powerful multi-media utilities that are easy to 
use and easy to integrate.

Group 42 has available freeware and commercial versions of GraphX Viewer for Windows, Windows NT, 
and a variety of Unix X/Motif platforms. GraphX Viewer is available for end-user sales, OEM licensing, 
product bundling, and site licensing.

Group 42 also offers an extensive line of graphics libraries available for product integration. In addition, 
we have products for painting, drawing, and on-screen presentation.

Call or email for availability and pricing.



Copyright and License
GraphX Viewer is copyrighted Ó 1995 Group 42, Inc. Use, copy, and disclosure restricted by license 
agreement. JPEG format support is based in part on the work of the Independent JPEG Group. PNG 
format support is based in part on the work of the PNG Group.

GraphX Viewer is supplied "AS IS". Group 42, Inc. disclaims all warranties, expressed or implied, 
including, without limitation, the warranties of merchantability and of fitness for any purpose. Group 42, 
Inc. assumes no liability for damages, direct or consequential, which may result from the use of GraphX 
Viewer.

As with any software distributed on-line, please examine the downloaded software with a virus checking 
program to guarantee virus-free operation.

If you desire to distribute the GraphX Viewer Freeware version, alone, bundled, or as part of any 
publication, and receive any type of remuneration, you must first contact Group 42, Inc. for authorization 
and terms.

All packaging, manuals, and promotional materials are designed to minimize waste and encourage 
recycling. Please conserve, recycle, and purchase recycled products. Listen to the Lorax!




