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arising out of the use of or inability to use the software or documentation even if Luckman Interac
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If you acquired this product in the United States, this Agreement is governed by the laws of the S
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Welcome to the Internet
It’s the topic of the decade. The promise of the future. Not since
introduction of the personal computer itself has a single techno
ical event promised such profound possibilities. From Los Ange
to London, to Moscow, it has become a household word. You ca
pick up a newspaper or magazine without at least one in-depth
cle about how it has the potential to change the very fabric of s
ety. It’s a business tool, education resource, communication 
network, financial center, world-wide shopping mall, global mai
box, entertainment superstore. 

It’s the Internet. 

What began in 1969 as a simple, yet technologically advanced 
for government scientists to correspond and share research with
leagues has grown into the world’s largest computer network. O
any given day you will find 25 or so million ordinary (and some 
rather extraordinary) people taking part in this electronic revolut
called the Internet. 

Because of its size, its availability, and its ease of use, the Inte
is rapidly transforming and redefining modern communications,
search techniques, and sources of entertainment. It is also red
ing how people are using their personal computers. The Interne
and of itself, is cited by many new buyers of PCs as the very rea
they want one in their home. 

The Internet is a link — an interactive link — to the world. 

What exactly is the Internet?
At its most basic level, the Internet is a giant library that is open
hours a day, 7 days a week, 365 days a year. You use the Intern
find information. Once located, you can read it on-line, downloa
and save it to your computer’s hard disk, or discuss it with other
ternet users. This was the original and still principal benefit of t
Internet, to share ideas and knowledge with other people.
 Welcome to the Internet, 1-3
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In the last few years, however, the Internet has also become so
thing else: the world’s largest shopping mall. Once you have fin
ished your research at the library, you can then go shopping fo
anything you might want, from an on-line version of Moby Dick, to 
a review of the latest John Grisham novel, to a new winter coat
whatever it is you are after, you will surely find it on the Interne

A Brief History

Technically, the Internet is comprised of over 3 million individua
computers (called hosts) located around the world that are con
ed together through a series of networks. 

Each host stores information — text, graphics, pictures, sounds,
eos — on every imaginable subject. Hosts (also called servers 
sites) are usually maintained by a specific entity that controls the
formation available on that server. For example, NASA operate
host, so does Stanford University, the Library of Congress, the 
White House, IBM, ABC, the Department of Energy, Microsoft, 
and so on. This diversity is what makes the Internet so interest
No single person, organization or government controls it. The in
mation that is available runs the full gamut of human interests. A
everyone with a personal computer and a modem has access to it. It 
is the world’s single largest source of information. 

The Internet was developed in 1969 by the Department of Defen
Advanced Research and Projects Agency (ARPA). Initially, it w
designed as a cold war defensive strategy, thought to be less vu
able than the typical computer networks of the day for the meth
in which it transferred information. Rather than sending a file as
whole file, information was (and still is) transferred over the Inte
net in “packets,” small pieces of information. Once they reach th
destination, the packets are assembled back to their original fo
That way, if a network went down, there was less risk of losing 
the information. 

By the 1980’s the military, as often happens when civilians find o
what they are up to, went its own way and the Internet became
exclusive property of the Universities and other governmental ag
cies. NASA, the Department of Energy, and the National Institu
of Health soon added their own networks. 
1-4, Welcome to the Internet
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Then came the supercomputer centers, and the corporations. B
1990, the Internet had become the largest e-mail network in the
world. Its ability to transfer full documents, including graphics, 
sound and images, made it a very popular interface. 

Today, nine out of 10 sites added to the Internet are commercia
nature wanting to sell you everything from soap to tires, real es
to balloons. This explosive growth has made the Internet as dyn
ic and diverse as the population itself.

Networks — Lots of Them

Just like your own computer stores information on its hard disk, 
Internet might be thought of as a series of very big (to put it mild
hard disks. 

If you have two computers in your office or home and you conn
them together, you can access information from both the comp
er’s hard disks. This same concept is true with the Internet, altho
now you have 3 million plus computers connected by over 40,0
individual networks which are available for you to access. 

A network is the method by which all these computers share in
mation (how they are hooked or linked together). The Internet ta
the concept of networks to its logical conclusion — it doesn’t ju
link up computers, it links up the networks themselves. This me
that once you get access (using an Internet provider or ISP), you
access a computer in Ireland or Sweden or Peru as easily as yo
a site in your own hometown.

It cannot be said enough: the Internet offers unparalleled access to 
information!

What’s on the Internet?

In a word, everything!

• Like to read? You’ll find a warehouse of on-line publications 
from Time magazine, to Playboy, to the Wall Street Journal, 
Wired, to Better Homes and Gardens. Browse through the pe
odical catalogs of the Library of Congress, Harvard Universit
or the University of Iowa.
 Welcome to the Internet, 1-5
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• Want to see photographs? You’ll find the latest shots from th
Hubble telescope available on one of NASA’s computers. Or
tour an Ansel Adams display at the Metropolitan Museum of 
Art. Or send pictures of your own kids to family members livin
on the other coast.

• Want to travel? Take a tour of the White House, the Grand C
yon, or the Museum of Modern Art. How about Paris or the wi
country in Northern California? Book your flight, hotel, and 
rent-a-car. Order tickets to Broadway, the Mets or (coming so
Disneyland.

• Get involved! Leave a message for the President, your Cong
man, or your favorite television actor or actress. You’ll often 
find these otherwise inaccessible people actually on-line, tak
your questions and answering them as if they were in your liv
room talking with you personally.

• Want to chat? Join in a live conversation on any imaginable 
topic with people from around the world.

• Want to network? Talk with friends, family or business assoc
ates anywhere on the planet. Share ideas, documents or files
Send e-mail to other e-mail addresses on the Internet (or oth
on-line services such as America Online or CompuServe).

• Need research material? Download and save text files, photo
graphs, graphics, sound files, videos, even computer softwar

And one of the greatest benefits to the Internet is that usually, all
can be had for the price of a local telephone call (and your ISP
monthly charge, which also tends to be inexpensive).

Because the Internet is not “owned” by any single person, organ
tion or government, the diversity of what you will find available 
only limited by your imagination.

Additionally, the Internet is far from complete. It’s a work in 
progress. Everyday another computer joins the network and ano
thousand people log on. It’s estimated that the Internet is growin
the rate of approximately 10% a month!

What’s on the Internet? What isn’t?
1-6, Welcome to the Internet
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The World Wide Web
Recently, the Internet, like the rest of the computer world, has g
far beyond displaying information in a traditional text file format
With the advent of hypertext, a computer technology that allow
you to easily link documents and files, the Internet is now a mu
media center combining text, sound, graphics, even video.

The World Wide Web (WWW or Web) is the fastest growing se
ment of the Internet for its ability to display information in a mul
media format. If the Internet is growing at 10% a month, the Web
growing at 20%. 

Like the Internet itself, the Web was originally developed as a to
for researchers to more easily access information. That is still true 
today. However, the Web has developed into something much 
more. It has become a virtual on-line shopping mall and playhou
Everyone from General Motors and IBM, to Joe’s Shoe store is s
ing goods and services on their own Web home page. There ar
games, videos and music. You don’t need to go farther than you
to find the largest “shopping mall” in the world. And when it come
to entertainment, this interactive powerhouse is slowly overtaki
the television as the centerpoint of the family den.

However, like everything else on the Internet, the WWW is so lar
and complex, you will find just about anything you can think of 
somewhere on a Web site. 

For example, you’ll find:

Education  — The Web continues to be one of the world’s grea
scholarly lending libraries. Research centers from around the w
put their newsletters, papers, research programs, and conferen
sults on the Web. The ability to incorporate text with graphics a
photographs has made the Web a mecca for serious research.

Entertainment  — You’ll find Web sites for music, drama, televi
sion, the movies, whatever your interest. Listen to the latest sin
from a favorite recording artist or view a clip from this summer’
blockbuster movie. Play computer games, view paintings from 
some of the finest museums in the world, or check out the latest 
Trek offering.
 Welcome to the Internet, 1-7
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Commerce  —The Web is a shoppers paradise. Review a color 
alog and order on-line. Buy cars, computers, stocks, or real est
Find consultants, lawyers, doctors. You’ll even find the want ad
with employment opportunities in just about every city of the wor

Government  — Review the workings of Congress or your loca
city council. Every day another city, country, region, state and n
tional government organization opens a new Web site. This is e
tronic democracy in its infancy and now you can get involved.

How does the WWW Work?
The WWW uses a computer language called hypertext. This eas
use language allows documents to be linked to other documen
lowing for a nonlinear access to information. You get from one 
place to another by simply clicking your mouse on a word or graph
ic. Because you are not restricted from going from site A to B to
but can navigate in an almost circular fashion, most Web brows
(such as Enhanced Mosaic) allow to track your path and save fa
ite Web sites to a “hotlist,” which allows for direct return.

Web Terminology
Like any technology, the Web uses its own terms which you wi
find helpful to understand.

Home Page  — A home page is simply the starting point for a We
site. Usually the home page tells you where you are, provides a 
description of what can be found at the site, and provides the li
to access the site’s available information. Think of a home page
a table of contents.

URL — Uniform Resource Locator. This is the “address” of a si
or document on the computer system where it is stored. Just like
need to know the path for files in your own computer’s hard disk
order to access them, the same is true for the WWW. A URL 
uniquely identifies a file on the Internet and allows you to find it

For more detailed information on URLs, refer to Chapter 2, Using 
Enhanced Mosaic to Browse the Internet.
1-8, Welcome to the Internet
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Hypermedia  — Documents which contain a mixture of text, 
graphics, sound or video images are known as hypermedia doc
ments.

HTTP and HTML  — HTTP is a software specification that define
how hypermedia files get from the WWW servers to your comput
A computer that stores and transmits WWW hypermedia docu-
ments is running software called an HTTP server. HTML (Hype
Text Markup Language) is a standard set of codes that are inse
into a document displayed on the WWW. This determines how t
and other components of the document are displayed.

For more detailed information on the Internet and the World Wi
Web, see Chapter 4, Using Enhanced Mosaic to Browse the Inte
net.

Accessing the Internet
To access the Internet you need four basic things:

• A personal computer (486, 8 MB RAM or higher recommende

• A modem (9600 bps or higher recommended)

• An Internet provider (ISP)

• Internet browser software

Net Commander gives you all the software you need to access
work in the Internet. Additionally, it automatically registers you 
with an Internet provider.

If want to see what the Super Highway is all about, you’ve come
the right place.
 Welcome to the Internet, 1-9
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Overview
Luckman’s Net Commander—Your All-In-One Internet Package
is an advanced application suite containing all the tools you nee
access and work in the Internet. 

Included in this comprehensive collection of Internet application
are the following: 

Enhanced Mosaic 2.1(Windows 3.1) — Browsing the World 
Wide Web (WWW) has never been easier. Navigate through th
multitude of Web sites and take advantage of all the on-line 
services, information, education and entertainment resources t
the WWW has to offer. 

Microsoft ® Internet Explorer™ 2.0 (Windows 95)  — For 
Windows 95 users, Net Commander installs Microsoft’s fast an
easy-to-use Web browser as the primary browser.

Trumpet Winsock (Windows 3.1) — This stack and dialer pro-
gram makes the physical connection to the Internet and then w
“behind the scenes” keeping your connection open and recordi
key session information, such as the amount of time you have b
on-line.

Eudora® E-Mail — One of the most widely used e-mail applica
tions on the Internet, Eudora is easy to use and feature rich. 

NewsXpress  — A powerful newsreader allowing you to access
thousands of UseNet newsgroups. Join a favorite newsgroup to 
or post articles. You can even send an e-mail message to the a
of an article.

NetCall — If you have a sound card, microphone and speakers, 
is the ultimate Internet tool! Internet Voice allows you to telepho
and talk in real time — using your own voice — to anyone else
around the world who is logged on (and using NetCall) for the pr
of a local telephone call.

TrueSpeech® Player — Listen to recorded broadcasts and oth
audio files on the Internet. The TrueSpeech Player plays back so
files as they are downloaded; say goodbye to long waits for do
loading large audio files.
 Introduction, 2-3
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CU-SeeME™ — Have a videoconference over the Internet! Th
breakthrough software puts real-time, simultaneous audio and v
conferencing in the hands of anyone with a video camera and P
adapter. (New, inexpensive cameras plug into a parallel port an
you dispense with the video capture card.)

StreamWorks™  — Listen to Internet radio stations and TV, or
play back sound and video files real-time.

CheckFree® Wallet  — Make purchases on the Internet. Set up
virtual “wallets” for simple and secure shopping in the new glob
electronic mall — the Internet!

FTP — Transfer files (documents, photographs, even software
from an FTP server to your own local hard disk.

IRC — The Internet Relay Chat (IRC) application is your key to
communicating in an on-line chat group on any subject imagina
Discussions are frank, uncensored and in most cases, free-form

Telnet  — Connect to a Telnet server and access the services, 
mands and programs found on the hundreds of Telnet sites avai
over the Internet.

Archie  — One of the principal Internet search tools, Archie allow
you to locate and download public domain text files, graphic file
and sound files from 40 Archie sites around the world.

Gopher  — Another popular Internet search and retrieve applica
tion, Gopher lets you access over 1600 servers to find docume
and files in an easy to use interface. You’ll find being in “gophe
space” a great way to find information.

Ping  — Check any Internet connection with this easy to use util
program. With Ping, you can be sure your connection is good.

WhoIs  — Locate people, host servers, gateways or networks o
any Internet server.

Finger  — Locate and display information about other Internet u
ers.
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Helpers  — Net Commander includes the following Internet “hel
ers” or “Internet tools” to ensure you are able to take full advanta
of all the files and programs you will find on the Internet, regardle
of their format.

• Video for Windows  — View AVI video clips.

• QuickTime for Windows  — View Quicktime movies (MOV 
files).

• Panorama  — Display SGML documents.

• Adobe Acrobat™  — Display documents saved in Adobe PD
format, including the Net Commander on-line manual.

• VMPEG — With VMPEG installed, you can use the Windows
MediaPlayer to play MPEG-compressed video files.

• VR Scout™  — View VRML (Virtual Reality Modeling Lan-
guage) files. Virtual reality is now yours to explore. Walk — o
fly! — through three-dimensional worlds of the imagination.

With the suite of Net Commander tools, you have complete Inter
control, from checking out the latest WWW home page, to sear
ing the Library of Congress card catalog, to communicating wit
world leaders. 

The world is literally at your finger tips!

Net Commander Program Group
 Introduction, 2-5
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Working with Net Commander
After installing and registering Net Commander, you will have 3
days of free access to explore the Internet. Spend some time with 
this User’s Guide to get some ideas of how to make the most of th
free period, to become knowledgeable about what is available on
Internet and how you can make the best use of your time using
exciting tools contained in the Net Commander suite.

When working with Net Commander applications, keep in mind t
following points:

• Enhanced Mosaic 2.1 supports over 250 modems running at
9600 or higher baud rate. When connecting to the Internet, it w
automatically run your modem at its maximum speed that is s
ported by the Internet Service Provider, or “ISP”).

• You can run different Net Commander applications simulta-
neously (depending on available memory).

• Most of the Net Commander applications contain on-line help
which offers assistance in answering questions or solving pro
lems. Look for a Help menu on the menu bar and explore the
Help’s table of contents. Help files often contain shortcuts an
advanced features that can improve your productivity.

• You can execute commands in Net Commander using the mo
or (if working in Windows 3.1), an Alt-key combination. Menus
commands and button labels each contain a “hot key,” desig
nated by an underlined letter. This allows you to press and h
the ALT key, then press the corresponding hot key to execute
command. For example, suppose you want to select the Print 
command contained in the File menu. To do so, press and hold
the ALT key, press the F key to open the File menu, then pre
to execute the Print command. 
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What's New in Enhanced Mosaic 2.1
Enhanced Mosaic 2.1 is built on an open standards-based arch
ture. This makes it adaptable to the various requirements of netw
publishing and commerce. Key aspects of the new architecture
a brief description of new features are listed below. 

Unsurpassed Performance 
Advanced display technology lets you interact with documents 
multiple windows during downloads. Text is immediately dis-
played, allowing you to follow links before the downloads are co
plete. 

Built-in Audio  Players
Enhanced Mosaic includes built-in support for AIFF and AU aud
formats.

Inline JPEG Support  
In addition to GIF images, inline JPEG images are supported. 

Built-in GIF and JPEG Viewers  
Enhanced Mosaic's internal image viewer automatically display
stand-alone GIF and JPEG files. 

Configurable Helper Applications  
Configuring helper applications to support new file types is now
easier than ever using the Edit menu’s Helper dialog. 

Client-Side Image Maps  
Now you can create and use image maps locally without interac
with a server. 

Security Framework  
Enhanced Mosaic's open security framework allows for plug-in
curity modules. Basic Authentication, Digest Authentication, an
First Virtual modules come pre-installed. 

Software Development Interface (SDI) 
This two-way application programming interface allows other a
plications, such as Adobe Acrobat and Panorama, to seamless
teroperate with Enhanced Mosaic. 
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Toolbar  
A new toolbar provides quick access to frequently used menu c
mands. 

Where to Go Next
Now that you have had a taste of what lies ahead, proceed to Ch
3, Installation and Registration. The procedures in that chapter 
you step-by-step through the processes of installing Net Comm
er and registering an Internet account. You will also find instruc
tions for installing the Net Commander Helper applications.

Get ready for excitement, education, and entertainment—get re
for the Internet and the World Wide Web!

Technical Support
If you encounter a problem installing or using Net Commander, y
can contact Luckman Interactive Technical Support as follows:

• Voice: (213) 614-1758

• Fax: (213) 614-1929

• E-mail: support@luckman.com

Technical Support is available between 6:00 am and 5:00 pm Pa
Time.
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Overview
Installing Net Commander onto your computer’s hard disk is a 
straightforward and simple process. Net Commander’s advanc
setup program automates the time-consuming and often confu
requirements for connecting your computer to an Internet provid
By following the detailed step-by-step on-screen prompts, you w
be ready to explore the Internet in a very short time. This chapt
helps you install Net Commander’s suite of applications onto yo
computer and obtain your Internet account. It contains the follow
information and procedures:

• Hardware requirements

• Software requirements

• Installing Net Commander 

• Creating an Internet account

Because there are some differences between the Net Comman
installation procedures for Windows 3.1 and Windows 95, both p
cedures are included.

Once you complete the installation and registration process, yo
will be ready to use your e-mail account, join a news group, tal
“live” with other Internet users, and take full advantage of all the
ternet has to offer. 

Following the Internet account registration section you will find 
structions for installing additional “helper” or “tool” applications,
which enable you to use Net Commander to view or play many
ferent kinds of files found on the Internet, such as Adobe Acrob
files, live video and audio “streams,” movie files, virtual reality 
(VRML) files, and more.

Welcome to the Information Super Highway!

Hardware Requirements
The following hardware requirements represent the minimum con-
figuration that is supported by Net Commander:
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• 486 or later IBM PC or compatible computer

• 8 MB RAM

• Hard disk with at least 15 MB free space

• Double-speed CD-ROM (if installing from the CD-ROM ver-
sion)

• 1.44 Meg High Density 3.5” floppy drive disk (if installing from
the floppy disk version)

• 9600 baud rate or higher modem connected to a COM port

• Mouse

Software Requirements
The following software must be installed on your computer in ord
to run Net Commander:

• DOS 5.0 or later

• Windows 95, or Microsoft Windows 3.1 or later 

Installing Net Commander: Windows 3.1
You should not be running any other application when installing 
Net Commander suite of applications. Additionally, it is always 
good policy to backup your computer before installing any new
software package, including this one.

Running  32-Bit Applications
Net Commander is an advanced, state-of-the-art 32-bit applicat
This means it can do more things, faster, than older 16-bit applica-
tions. For Windows 95 users, the news is even better. Because it is 
a 32-bit application written specifically to run other 32-bit applic
tions, Net Commander will automatically perform at the maximu
power the moment you launch it. 

For Windows 3.1 users however, you need to add a special drive
order to run Net Commander. Windows can only run a 32-bit ap
cation if the appropriate WIN32s drivers are installed in your WI
DOWS\SYSTEM subdirectory. Therefore, before installing the N
3-4, Installation and Registration
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Commander applications, the Setup program automatically sca
your system to see if you are configured to run 32-bit applicatio
and displays a message allowing you to install the latest versio
the WIN32s drivers.

Even though Net Commander does this automatically, if your s
tem contains an older version of WIN32s, you may want to remo
it prior to running the Net Commander installation program to e
sure an absolutely clean installation.

To remove WIN32s from your Windows 3.1 system:

1 From Program Manager, double-click the File Manager icon in 
Main program group.

2 Click the Windows folder to display the contents of your Win-
dows directory.

3 Double-click on the SYSTEM.INI file.

4 In the [Enh 386] section, remove the following line:

device=<SYSTEM>win32s\w32s.386

where<SYSTEM> is your Windows\System directory

5 In the [BOOT] section, locate the following line:

drivers=mmsystem.dll winmm16.dll

6 Delete the WINMM16.DLL statement (leaving any other DLLs on
the line) to read as follows: 

drivers=mmsystem.dll

7 Save the SYSTEM.INI file.

8 In File Manager, delete the following files from your WIN-
DOWS\SYSTEM directory:

• WIN32S.INI

• W32SYS.DLL

• WIN32S16.DLL

• WINMM16.DLL

• Additionally, delete all the files in the WINDOWS\SYS-
TEM\WIN32S subdirectory.
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9 Restart Windows by choosing the Exit Windows command from
the File menu (Alt F, X) in Program Manager.

Installing Net Commander
To install Net Commander onto your computer’s hard disk, from
Program Manager or the Windows 95 desktop:

1 Insert the Net Commander CD into your computer’s CD drive, 
the disk labeled Disk 1 Setup.

2 Choose the Run command from the File menu (Alt F, R). 

The Run dialog displays. 

Run dialog

3 Type X:\DISK1\SETUP.EXE (X=your CD drive), or if using a 
floppy disk, A:\SETUP.EXE and click OK.

The Net Commander Setup dialog displays. Be sure you are not
ning any other Windows application during the installation proce
If you are, click Exit, close the running application(s) and begin
again, starting with Step 1.

Type 
X:\DISK1\SETUP.EXE
 and click OK (where X 
is your CD drive)...

...or type 
A:\SETUP.EXE and 
click OK (if using a 
floppy disk).
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Net Commander Setup dialog

4 Click Continue to continue the installation.

The WIN32s 
screens display 
only for Win-
dows 3.1 instal-
lations, and 
only if WIN32s 
files are not 
found.

Net Commander begins the installation process and displays th
WIN32s dialog prior to installing the WIN32s drivers.

WIN32s Message dialog

5 Click Continue. A confirmation message displays showing you
where Setup will install the WIN32s components.
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WIN32s Confirmation Message

6 Click Continue to install the WIN32s drivers onto your system.

A confirmation message displays informing you that WIN32s w
successfully installed (if your system already has the very lates
WIN32s drivers, you will not see this message. Instead, you will 
a message informing you that the WIN32s drivers are already i
stalled).

WIN32s Installation Confirmation message

7 Click Continue. 

The Verify Net Commander Path dialog displays showing you t
directory where the Net Commander applications will be install
on your computer’s hard disk. By default, the Setup program 
3-8, Installation and Registration
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selects your C: drive. If you wish to install the applications on 
another drive, you may change the drive designation.

8 To change the drive, use the Left Arrow Key to move the curso
the front of the drive designation (C:), press the Delete key and
type the desired drive letter.

Verify Net Commander Path dialog

9 Click Continue.

In a few moments, the Net Commander Setup dialog displays a
lowing you to select the Internet tools you want installed. By de
fault, all tools are selected.

Net Commander Setup dialog

You may choose to install the following tools:

If you do not want to 
install a tool, click the 
mouse on its check-
box (it becomes 
blank).
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In most cases, you will want to install all the tools. If, however, y
do not want to install a particular tool, click the mouse on the ch
box next to the item (it will become blank).

12 Click Continue. 

The remaining Net Commander files are copied to your hard di
and a message displayed that the installation was successful.

Internet Tool Description

Eudora E-Mail Allows you to send and receive electronic 
mail over the Internet.

Newsgroup 
Reader

Allows you to subscribe to newsgroups and
to read and post articles.

WhoIs Allows you to display information about oth-
er Internet users (such as their network nam
and E-Mail address).

Archie Search 
Tool

Allows you to view and retrieve public do-
main files from anonymous FTP hosts.

Finger Allows you to display information about us-
ers on a specific computer.

IRC Chat Tool Allows you to join and interact with a “live” 
chat group via the keyboard.

Gopher Allows you to browse public files on the Go
pher information server.

CU-SeeME Allows you to use a camera and microphon
to videoconference with other CU-SeeME 
users.

TrueSpeech Allows you to play sound files as they are 
downloaded.
3-10, Installation and Registration
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Installation Successful message

13 Click OK.

If the Setup program loaded WIN32s into your system, Window
will automatically be restarted in order to update your SYS-
TEM.INI file and load the drivers necessary to run Net Command

When setup is complete, the Net Commander program group a
the Net Commander Setup program group will be displayed in P
gram Manager. 

Net Commander Program Group
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The Net Commander group contains all of the applications that
ready to use. The Net Commander Setup group contains bundl
programs which have their own setup programs that need to be
to complete their installation. The procedures for installing thes
“helper applications,” or “tools,” are presented in this chapter fo
lowing the sections on Internet account registration.

You are now ready to register your Internet account. See “Regi
ing an Internet Account” (page 3-17).

Installing Net Commander: Windows 95
Before Net Commander for Windows 95 can be installed, both 
Windows 95 Dial-Up Scripting Tool and Microsoft Internet Explo
er 2.0 (“Internet Explorer”) must be installed first. If the Dial-Up
Scripting Tool was not installed with Windows 95, you will need 
install it (step-by-step instructions are included here). This take
only a few minutes; you will need to have your Windows 95 CD
ROM at hand. When done, you will resume the Net Commande
Setup procedure right where you left off.

If Internet Explorer has not been installed, the Net Commander
up program will automatically take you through the few simple 
steps to install it (it is included on the Net Commander CD-ROM

Use the following procedure to install Net Commander for Win-
dows 95 onto your computer’s hard disk.

Preliminary Steps

1 Start Windows 95.

Important!
If you are using a computer where you normally have to enter a
Windows logon and password when starting Windows 95 (for 
example on a multi-user workstation), be sure you enter your 
logon and password this time, before you install Net Command
This enables certain security features that will be needed later 
If you are using a computer where you do not have to enter a W
dows logon, you do not need to be concerned.

2 Insert the Net Commander CD in your computer’s CD-ROM 
drive.In a moment, the Net Commander logo window displays 
3-12, Installation and Registration
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automatically. (Note that the Add Tools and Register buttons a
not enabled at this point.)

Net Commander Setup window

3 Click Install.

If the Dial-Up Scripting Tool has already been installed, you 
should skip to “Net Commander Setup” (page 3-16).

Dial-Up Scripting Tool Setup

If the Dial-Up Scripting Tool is not installed, the following messag
displays.

Dial-Up Scripting Tool Not Installed Message

The next few steps are equivalent to the instructions in the RE-
ADME.TXT file, so it is not necessary to view the file, unless you 
would like to print it. Click OK to open the file, or click Cancel to
skip viewing it. In either case you are returned to the Windows 
desktop. 
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Follows these steps to install the Dial-Up Scripting Tool.

1 Remove the Net Commander CD from the CD-ROM drive and
replace it with your Windows 95 CD.

2 When the Windows 95 “splash screen” appears, click anywher
get to the desktop.

3 Choose Settings from the Start menu, then choose Control Pa

4 Click Add/Remove Programs.

5 Click the Windows Setup tab.

6 Click Have Disk; then click Browse.

7 Select your CD-ROM drive; then select the directory called 
dscript. You should see a file called RNAPLUS.INF in the file 
list box.

8 Click the RNAPLUS.INF file, then click OK in the Browse dialog
and then click OK in the next dialog.

9 Click the Dial-Up Scripting Tool check box, then click Install.

10 Click OK.

11 Close the Control Panel window.

12 In My Computer open the CD-ROM drive, to return to the Net 
Commander setup window.

13 Click Install to resume the Net Commander installation proces

If Internet Explorer has already been installed on your compute
skip to “Net Commander Setup” (page 3-16). Otherwise, the fo
lowing brief procedure is necessary.

Internet Explorer Setup

If Internet Explorer is not present on you system, the following 
message displays when you click Install in the main Net Com-
mander setup window.
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Internet Explorer Not Installed Message

1 Click OK. 

2 A confirmation message displays. Click Yes.

3 The Internet Explorer License Agreement dialog displays. Rea
the agreement. If you agree to the terms states, click I Agree.

4 The Browse for Folder dialog displays. Select the directory und
which you want to install the Internet Explorer directory. Click 
OK. The Copying Files dialog displays while Internet Explorer 
installed on your hard disk.

5  When the “installation complete” message displays, click OK.

The Initializing Setup message will appear, then you will see N
Commander Setup’s “Welcome” dialog.

Welcome dialog
 Installation and Registration, 3-15
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Net Commander Setup

1 Read the Welcome dialog text, then click Continue.

2 The Verify Net Commander Path dialog displays. The default 
directory for Net Commander is C:\NETCMDR. You may chang
the path to whatever you prefer. Click Continue when done.

3 The next dialog lists the Internet applications that you can insta
as part of Net Commander, in addition to the Enhanced Mosaic
Web browser. All are selected by default. Read the description
each application. If there are any applications that you do not want 
to install, click on the check boxes next to their names to unsel
them.

Click Continue when done.

4 The Net Commander files are installed onto your hard disk. Wh
the “installation successful” message displays, click OK.

Installation Successful Message

Note
The “installation successful” message dialog may be partially h
den by other windows. You may have to move one or more win
dows to see it.

The Net Commander program group displays on the desktop. A
on the desktop is the main Net Commander setup window, with
Install, Add Tools, Register, and Exit buttons. Note that the Ad
Tools and Register buttons are enabled.
3-16, Installation and Registration
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Net Commander Setup Menu

You may now proceed to “Registering an Internet Account,” belo
After you have set up an Internet account, you can return to the
Commander setup program and install the additional tools, or he
applications. Procedures for installing the tools follow the sectio
on registering an Internet account.

Registering an Internet Account
To register your Internet account, double-click the Account Reg
tration icon in the Net Commander program group. 

Windows 95 Note
If you are installing Net Commander for Windows 95, Click Reg
ter in the Net Commander logo window. (If this window is not op
but the Net Commander CD is in the CD-ROM drive, select the C
ROM drive from My Computer. Otherwise, put the Net Comman
er CD in the CD-ROM drive and wait a moment.)

The Internet Account Registration dialog displays.
 Installation and Registration, 3-17
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Internet Account Registration dialog

1 Enter the following information:

Field Description

Name Enter your full name (First name, Last name
as you wish it shown on your billing state-
ment.

Organization Enter any applicable organization or compa
ny name.

Address Enter your street address (e.g., 123 South 
Street).

Address 2 Use this optional field to enter an apartmen
number, suite number or Post Office box.

City Enter your city or select it from the drop-
down list.

State/Province Enter your state (or province).

Zip/Postal Code Enter your zip code (up to 5 characters).

Country Enter the country in which you live (e.g., 
USA) or select it from the drop-down list.
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Field Description

Credit Card 
Number

Enter a Visa or Master Card number includ
ing dashes to which you wish your account 
billed.

Visa/Master 
Card

Click the appropriate button for the credit 
card you are using to bill your account.

Expiration Enter your credit card expiration date in 
MMYY format (e.g., 1197).

Local Telephone 
Number 

Enter the telephone number for the line you 
will use to access the Internet. This may be 
your home or office number depending on 
where you are installing Net Commander. 
This field is used to determine your local 
POP (post office protocol) number which 
provides the means to store incoming mes
sages (such as e-mail) on the host until yo
log on when the messages are then down-
loaded to your computer, so make sure you
enter the correct (modem line) telephone 
number. Enter the entire telephone numbe
including area code (e.g., 512-555-1212).

Office Telephone 
Number

Enter your office (or secondary-non modem
telephone, including area code.

Fax Number Enter your fax telephone number, including
area code (e.g., 512-1212).

User Login Name: 
First Choice

Enter a name (user ID) using 3-6 character
that you would like to be known as when 
working on the Internet. Use lowercase let-
ters only. The user login name also acts as
your e-mail address name. User login name
must be unique or they will not be accepted

Use a name has that meaning to you. It is 
quite common to use your name, or a portio
of your name as your user login name. For
example, if your name is Tom Jefferson yo
might use TJEFF as your host name. 
 Installation and Registration, 3-19



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

k 

reg-

pro-

eds 

t be 
the 

 
l 
n 
2 After entering all the information on the registration dialog, clic
Register to create and register your new account.

The Portal User Agreement dialog displays. 

Portal User Agreement

3 Read this agreement completely and click I Agree to continue 
istering your account. If you click I Do Not Agree, you will not be 
able to access the Internet as no account will be created.

Net Commander automatically establishes a link to the Internet 
vider (the default ISP), establishes your Internet account, and cre-
ates your Host name and password. A message box displays 
showing you the steps Net Commander is executing as it proce
through this process.

Notes
If you receive a message that a connection to the provider canno
made, click OK to close the message and try again by clicking 

Field Description

User Login Name:
Second Choice

Enter a second host name choice using 3-6
characters (lowercase only). This name wil
be used if your first choice has already bee
assigned to another Internet user.
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Register button. This message simply means that the line to the
vider was busy or that an error occurred in making the link. In mo
cases, you will be successful in establishing a link on your first or
second attempt.

If you receive a message that Net Commander cannot connec
the provider because your modem COM port appears to be inc
rect, or if you continually receive a message that a connection c
not be made, you may need to change your modem settings. C
the message (click OK), and refer to “Changing Modem Setting
Windows 3.1” (page 3-24) or “Changing Modem Settings: Win-
dows 95” (page 3-25).

In a few moments, the Portal AAC: Please Confirm message d
plays informing you that your account has been successfully creat-
ed.

Portal AAC:Please Confirm message

6 Click OK to accept the offer and close the dialog. 

After a few moments, a confirmation Account dialog displays 
showing your account information including your account numb
with the ISP, your host name, and your password.

Click OK.
 Installation and Registration, 3-21
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Confirmation Account dialog

7 Write down your account number and your password and store
them in a safe location. This is the only time you will see both o
these items. If you ever need to contact the provider for custom
or technical service, they will ask you for your account number.

While your password is automatically inserted into the stack and
aler (and automatically transmitted to the Internet during logon)
is encrypted with asterisks (******). The only time you will see 
your Internet password is on the Confirmation Account dialog. 

RECORD YOUR PASSWORD AND ACCOUNT NUMBER 
BEFORE CLOSING THE DIALOG!

8 After recording your password and account number, click OK to 
close the dialog.

Notes
If Net Commander cannot find a local POP number, it displays 
pop-up list of local CompuServe telephone numbers. Select the
phone number you would like to use (select the most local num
and click OK.

If you cannot locate a local CompuServe telephone number on
pop-up list, call your telephone information service (for example
213-555-1212) to get the number and re-register the account.

A final Internet Account Registration dialog message displays.

Write down your pass-
word and account 
number and store them 
in a safe location. This 
is the only time you will 
be shown your pass-
word and account 
number. WRITE THEM 
DOWN NOW.
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Internet Account Registration dialog

9 Click OK to close the message.

The Registration dialog re-displays and then closes. 

The Net Commander program group (or folder group) displays.

Net Commander Program Group

For more information about technical support and your ISP acco
(including billing charges), double-click the Release Notes icon
display a Notepad (or WordPad) text file. 

When finished, choose the Exit command from the File menu t
close the dialog.

You are now ready to explore the Internet with 30 free days com-
plements of Net Commander. 

Enjoy!

To start the Web 
browser, double-
click the Enhanced 
Mosaic icon.
 Installation and Registration, 3-23
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Viewing Your Account Information
If you would like to review your account information, double-clic
the Account Registration icon in the Net Commander program 
group or folder to display the Internet Account Registration dial
(see page 3-18). The dialog displays the information as you enter
it with the exception of your credit card account number.

To close the dialog, click Cancel.

Changing Modem Settings: Windows 3.1
If you change the COM port to which your modem is attached, o
you install a new modem, you need to change the settings in the
count Registration - Advanced dialog in order for the stack and
aler to work properly. You may also need to change your mode
settings if you have trouble making a connection when register
an Internet account.

1 In the Internet Account Registration window, click Advanced.

Net Commander will scan your system and make its best gues
about how your COM ports are configured. It then displays the
Advanced Setup dialog, showing you the results of the search.

Advanced Setup dialog
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2 Enter or modify the following information, as needed:

3 Click OK. 

You can now re-run the registration program by clicking the Re
ister button in the Internet Account Registration window.

Changing Modem Settings: Windows 95
If you change the COM port to which your modem is attached, o
you install a new modem, you need to change the settings in the
count Registration - Advanced dialog in order for the stack and
aler to work properly. You may also need to change your mode
settings if you have trouble making a connection when register
an Internet account.

1 In the Internet Account Registration window, Click Advanced. 
The pre-set phone book entry for Portal account registration di
plays.

Field Description

COM Port Select the COM port to which your modem i
attached from the drop-down list.

Baud Rate Select your modem’s maximum baud rate 
from the drop-down list. (For 14400 mo-
dems, choose 19200; for 28800 modems, 
choose 38400.)

Modem Select your modem type from the drop-dow
list. If it is not contained in the list, or you are
not sure of its make, select the DEFAULT 
MODEM SETTINGS option.

Init String Displays the selected modem’s default ini-
tialization string.

Dialing Prefix If you need to use a prefix to dial an outsid
line (such as 9), enter it.
 Installation and Registration, 3-25
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

n-
ple 

m 
Portal Communications Phone Book Entry dialog

2 Select a different modem, if necessary.

3 Click Configure to view the current modem properties. The Ge
eral Properties dialog for the current modem displays (see sam
below).

Modem Properties dialog

4 Select a different COM port, or enter a different maximum mode
speed, if necessary.

Click Configure to change 
modem port or speed.

Select a different modem 
from this list, if applicable.
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5 Click OK in each dialog until you return to the Internet Account 
Registration window.

6 Click Register to continue the account registration process (se
“Registering an Internet Account,” page 3-17).

Installing the WWW Yellow Pages
The World Wide Web (WWW) Yellow Pages contains hundreds
popular WWW sites and documents in numerous topical areas.
Yellow Pages includes a full description of the Web site and a h
perlink to get there. This is a very informative and helpful tool fo
browsing the Web.

When installed, the WWW Yellow Pages can be accessed dire
from the Enhanced Mosaic home page.

To install the WWW Yellow Pages:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the WWW Yellow Pages Setup icon in the Net Co
mander Setup program group or folder. (In Windows 95, click 
Add Tools, pick WWW Yellow Pages, then click Install.)

The WWW Yellow Pages Setup dialog displays. 

Be sure you are not running any other Windows application dur
the installation process. If you are, click Exit, close the running 
plication(s) and begin again, starting with Step 1.

WWW Yellow Pages Setup dialog
 Installation and Registration, 3-27



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

. . . . . 

ion 

ced 
m-

ve 
is-
in-
es 
 

-

ing 
ap-
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

3 Click Continue to continue the installation.

After the files have been installed to your hard disk, an installat
successful dialog displays.

WWW Yellow Pages Setup Successful Message

The WWW Yellow Pages is now available for use on the Enhan
Mosaic home page and an icon has been placed in the Net Co
mander program group or folder.

Installing Video for Windows 
In order for you to view video clips on the Internet, you must ha
an application installed on your computer that can “read” and d
play them. The two most popular video viewers are Video for W
dows™ and QuickTime for Windows™. Net Commander provid
you with both. Video for Windows is used to play AVI files, while
QuickTime for Windows is used to play MOV files.

To install Video for Windows:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the Video for Windows Setup icon in the Net Com
mander Setup program group or folder.

The Video for Windows Welcome dialog displays. 

Be sure you are not running any other Windows application dur
the installation process. If you are, click Exit, close the running 
plication(s) and begin again, starting with Step 1.

If you are using 
Windows 95, 
Video for Windows 
is already installed.
3-28, Installation and Registration
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Video for Windows Welcome dialog

3 Click Continue to continue the installation.

After the files have been installed to your hard disk, an installat
successful dialog displays.

Video for Windows Installation Successful Message

4 Click Restart Now to restart Windows and complete the installa
tion process. Video for Windows is now installed and ready to u

For more information on using Video for Windows, refer to page3-
6 in Appendix A, Helper Applications.

.
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Installing QuickTime for Windows 
Apple Computer’s QuickTime for Windows™ is another popula
video viewer, designed to play back files in the MOV format.

To install QuickTime for Windows:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the QuickTime for Windows Setup icon in the Net
Commander Setup program group or folder. (In Windows 95, cl
Add Tools, pick QuickTime for Windows, then click Install.)

The QuickTime for Windows Installation dialog displays. 

Be sure you are not running any other Windows application dur
the installation process. If you are, click Exit, close the running 
plication(s) and begin again, starting with Step 1.

QuickTime for Windows Installation dialog

3 Be sure the Local option is selected, then click Continue to con
tinue the installation. The Setup program checks for older versi
of QuickTime for Windows. If it finds any files belonging to an 
older version, you will see a message asking if you want to rem
them. You should choose Remove.

After the files have been installed to your hard disk, an installat
successful dialog displays.
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QuickTime for Windows Installation Successful Message

4 Click OK.

A QuickTime for Windows program group or folder is created. T
learn more about QuickTime, double-click the Read Me icon. F
information about using QuickTime for Windows, refer to page 3-
9 in Appendix A, Helper Applications. 

Installing Adobe Acrobat Reader
Adobe’s Acrobat Reader™ allows you to open, view and print d
uments saved as PDF (Portable Document Format) files, includ
the Net Commander on-line manual.

To install Acrobat Reader:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the Acrobat Setup icon in the Net Commander Se
program group or folder. (In Windows 95, click Add Tools, pick
Acrobat Reader, then click Install.)

The Acrobat License Agreement dialog displays. 
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Acrobat License Agreement dialog

3 Read the license agreement completely and click Accept to co
tinue the installation.

The Target Directory dialog displays.

Target Directory dialog

4 Change the drive designation as desired and click Install. 

Change the drive designa-
tion as desired and click 
Install.
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In a moment, another Installer dialog displays. This dialog con
tains a message about registering Acrobat.

5 Click OK to continue. 

In another moment, a dialog displays prompting you to enter y
name and organization.

Name and Organization dialog

6 Enter your name and organization (as applicable).

7 Click OK.

The Acrobat files are installed to your hard disk. An “installation
complete” dialog displays.

Acrobat Installation Complete Message

8 Click OK. The Adobe Acrobat program group or folder displays
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Adobe Acrobat program group

Adobe Acrobat is now installed. For information on using Acrob
refer to page 3-25 in Appendix A, Helper Applications.

Installing Panorama
Panorama is a helper application that allows you to view SGML
documents. Before installing Panorama, Enhanced Mosaic mus
ready be installed.

After installing Panorama, refer to page 3-20 in Appendix A, Helper 
Applications, for information on using Panorama.

Note
Panorama cannot be used with Windows 95.

To install Panorama:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the Panorama Setup icon in the Net Commander 
Setup program group, or folder.

To learn more about 
Adobe Acrobat, double-
click the Readme icon.
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The Setup Welcome dialog displays.

Setup Welcome dialog

3 Click Continue.

4 For each browser that Panorama’s Setup program finds on your 
system, the following dialog displays:

Web Browser Configuration dialog

Click Yes to set up Panorama as the SGML reader for the brow
listed in the dialog.

5 In a moment, the Installation Location dialog displays.
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Installation Location dialog

Change the drive designation as desired and click OK.

The Panorama files are installed to your hard disk.

6 The Setup program prompts you to choose the Web browser s
ware which you want to be configured to use Panorama as a he
program.

Select Web Browser dialog

Click Spyglass, if you have installed Enhanced Mosaic.
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7 The Program Group dialog displays.

Create Program dialog

8 Click OK to accept the default program group settings. If the pro-
gram groups already exists, the Setup program displays a mes
informing you that some program items may be overwritten. If y
see this message, click OK.

The Installation Complete dialog displays.

Installation Complete dialog

9 Click Yes to exit Setup and see the Readme file, or No to exit 
Setup and display the Panorama program group or folder.

Panorama Program Group
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Installing StreamWorks™
StreamWorks is a program that plays “streams” of audio and vid
data on the Internet, including Internet “radio” and “TV” broadcas
and audio recordings. These files are played as they are downl
ed, in contrast to waiting for a huge file to be copied to your har
drive and then running a player application.

For information on configuring and using StreamWorks, refer to
page 3-35 in Appendix A, Helper Applications.

To install StreamWorks:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the StreamWorks Setup icon in the Net Command
Setup program group, or folder. (In Windows 95, click Add Too
pick StreamWorks, then click Install.) The Welcome dialog dis-
plays.

Setup Welcome dialog

3 Click Continue. The Get Destination Path for WNETVIEW dis-
plays. (WNETVIEW is the name of the StreamWorks software th
“reads” files sent from a StreamWorks server.)
3-38, Installation and Registration

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Installing StreamWorks™
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

he 
ired 

am 

ead 
di-
r 
-

Get Destination Path dialog

4 If you want to install StreamWorks to a different directory than t
default shown in the dialog, enter the complete path to the des
destination directory in the Path text box.

Click Continue. The Setup Compete dialog displays.

Setup Complete dialog

Click OK.

The Xing™ StreamWorks program group is added to the Progr
Manager window (or Explorer). 

Before using StreamWorks for the first time, take a moment to r
the short DCINOTE.TXT file that is located in the StreamWorks 
rectory. This text file contains information about the video drive
that the StreamWorks Setup program installed. To open DCINO
TE.TXT in a Notepad window, simply double-click on it in Win-
dows File Manager (or Explorer).
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Installing VR Scout
The worlds of virtual reality (VR) are yours to explore on the Int
net with VR Scout. VR files create the illusion of three-dimension
space, or “worlds,” in which you move by simply dragging your 
mouse on the screen or pressing keys on the keyboard. You can
choose to “walk” or “fly” inside the world created by VRML—vir
tual reality modeling language—files.

For information on configuring and using VR Scout, refer to pag
3-58 in Appendix A, Helper Applications.

To install VR Scout:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the VRML Player Setup icon in the Net Command
Setup program group, or folder. (In Windows 95, click Add Too
pick VRML Viewer, then click Install.)

The Welcome dialog displays.

3 Click Next. The VR Scout License Agreement displays.

4 Read the agreement, then click I Agree. The Choose Destinati
Location dialog displays. 

Choose Destination Location dialog

5 If you accept the default directory, click Next. You may enter a d
ferent directory, if you prefer (you may enter a directory that do
not exist; the Setup program will create it). Click Next when don
3-40, Installation and Registration
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The Select Program Folder dialog displays.

Select Program Folder dialog

6 Choose the program group where you want the VR Scout icon
appear. Click Next. The Start Copying Files dialog displays, wh
gives you a chance to confirm or change the destination direct
for the VR Scout files.

Start Copying Files Dialog

Click Back to change the destination. When the destination is 
rect, click Next.

The VR Scout files are now copied to you hard disk. If you hav
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never installed Microsoft Reality Lab (a set of files that speeds
the display of graphics), a message displays to inform you that
will be installed.

Reality Lab Installation Notice

Click OK. The Reality Lab Setup program runs, then the remai
ing VR Scout files are installed.

7 When all files have been installed, a message displays the info
tion that Reality Lab has been installed successfully. Click OK. 
The Setup Complete dialog displays.

Setup Complete dialog

8 This screen provides options for viewing the ReadMe file and f
starting VR Scout at the end of setup. Select the options you w
When done, click Finish.

The VR Scout icons are added to the program group you selec
in step 4. Depending on your choices in the Setup Complete d
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return to Windows Program Manager or the desktop.

Installing VMPEG
VMPEG is a player for MPEG-1 compressed motion video files.
stalling VMPEG configures the Windows Media Player to use 
VMPEG to run MPEG files that you download from the Internet

For information on configuring and using VMPEG, refer to page3-
68 in Appendix A, Helper Applications.

To install VMPEG:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the MPEG Player Setup icon in the Net Command
Setup program group, or folder. (In Windows 95, click Add Too
pick MPEG Player, then click Install.) The Welcome dialog dis-
plays.

Setup Welcome dialog

3 Click Continue. The Setup Options dialog displays.
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Setup Options dialog

The WinG Runtime Libraries are files that speed up the display
graphics. It is recommended that you install them.

4 Click Continue. The next Setup dialog shows the default instal
tion directory for the VMPEG files.

Setup Path dialog

Enter a different directory, if desired.

5 Click Continue. The VMPEG files are installed, and the Setup E
dialog displays with the message that setup is complete.

6 Click OK to finish the VMPEG setup procedure. The VMPEG 
program group is added to Windows.

Installing CheckFree® Wallet
CheckFree Wallet is your ticket to worry-free shopping on the In
net. The first time you use CheckFree Wallet, you are led throu
the process of creating one or more “wallets.” Each wallet conta
securely encrypted name, password, and credit card informatio
3-44, Installation and Registration

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Installing CheckFree® Wallet
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

t 

-

K. 
k 

ry.

ing 
tem 
h” 
When you find something you want to buy on the Web, you jus
“pull out your wallet.”

For instructions on using CheckFree Wallet, refer to page 3-43 in 
Appendix A, Helper Applications.

To install CheckFree Wallet:

1 Insert the Net Commander CD into your computer’s CD drive.

2 Double-click the CheckFree Wallet Setup icon in the Net Com-
mander Setup program group, or folder. (In Windows 95, click 
Add Tools, pick CheckFree Wallet, then click Install.) After the 
Setup program is initialized, the Installation Location dialog dis
plays.

CheckFree Wallet Installation Location dialog

3 To accept the default location for the CheckFree Wallet, click O
You may also change the destination directory if you wish; clic
OK when you have finished entering the new directory path.

The CheckFree Wallet files are installed in the specified directo

After installing the files, the Setup program displays a dialog ask
if you want to configure any Web browsers you have on your sys
to work with CheckFree Wallet. This involves adding a “cybercas
file-type description to the browsers’ initialization files.
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Setup Question dialog

4 Click Yes.

The Setup program searches for the INI files of any Web brows
on your system and displays a list of the INI file(s) it finds.

Select Web Browsers to Setup dialog

5 The name of each INI file indicates the browser it belongs to. F
example, “emosaic.ini” is the initialization file for Enhanced 
Mosaic. Click on each INI file that you want to update to recogn
the “cybercash” file type in shopping pages on the Web.

Tip: The Select All and Deselect All buttons provide a one-click
method for highlighting and unhighlighting all of the listed files a
once.

(If you decide you do not want to change any Web browser con
uration files, click Skip, and proceed to step 7.)

When you have made your selection, click Setup.
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6 Setup displays an Information dialog informing you which files 
changed, and how the saved backup copies were renamed.

Setup Information dialog

Click OK.

7 The final Setup dialog displays.

Setup Successful dialog

Click Yes to view the README file.

The README file can also be opened later from the CheckFre
program group, if you prefer. If you do view the README file, 
simply close the Notepad window when done. CheckFree Wall
setup is complete.
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Overview
Enhanced Mosaic 2.1 is an advanced Windows application de-
signed specifically to work with the Internet, in particular the Wor
Wide Web (WWW). The WWW has fast become the most popu
component of the Internet for its ease of use and its ability to in
grate text, sound, graphics, and video. Enhanced Mosaic 2.1 is
“browser” you use to navigate through the multitude of informati
sites and documents located on the WWW. After learning a few
sic procedures, you will quickly be ready to tap into all of the on
line services, information, education and entertainment resourc
the Internet and the WWW has to offer. From electronic shoppi
malls, to on-line art galleries, to magazines and newspapers, to
versity libraries and government departments, the world will liter
ly be at your fingertips. 

The World Wide Web 
Hyperlink text is 
identified on a 
document by 
colored, under-
lined text.

The World Wide Web (WWW) has greatly simplified accessing i
formation and services on the Internet by using a computer proto
known as HTTP (Hypertext Transport Protocol). “Hypertext”, as it 
is commonly called is based on a computer language known as
HTML (HyperText Markup Language) that lets you interactively
navigate to Web sites, files, documents and other areas by “jum
ing” to a desired item whenever the mouse is clicked once on a
pertext hot spot, called a hyperlink.

Hyperlink 
graphics are 
enclosed in a 
colored border.

When you click the mouse on a hyperlink, you go directly to tha
item (Web page, document, photograph, and so on). Hyperlinks 
may be text or graphics and are used not only to view a Web sit
“page” but also to access and display the documents, photographs, 
videos and other information contained on a particular Web pag
is a powerful technology that could not be easier to use.

Hypertext “hot spot” (hyperlink).

If you are using 
Windows 95, 
Microsoft Internet 
Explorer is 
installed as the 
default World Wide 
Web browser for 
Net Commander. 
Refer to Chapter 5 
for information 
about Internet 
Explorer.
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Uniform Resource Locators (URLs)

Technically, every site on the Internet has a unique address cal
Uniform Resource Locator (URL). Just like the postal service ne
to know your address before they can deliver your mail, Enhan
Mosaic needs to know a site’s ULR before it can find and displa
on your monitor. 

A URL is read as follows:

In the above example, the URL of the White House is http://
www.whitehouse.gov. In order for you to access and display this 
White House Web page, you have to tell Enhanced Mosaic it’s 
URL. 

This could be done by typing the URL directly into the Enhance
Mosaic dialog (as explain later in this chapter), or by clicking on
hyperlink to the White House. In that case, the URL is automatica
passed on to Enhanced Mosaic allowing it to find the White Hou
Web page on the Internet without you having to do anything bu
click the mouse. Hypertext and hyperlinks have made getting fr
site to site, and document to document, very easy.

Enhanced Mosaic supports all the leading protocols (which indic
the type of server (see the next section) on which a document 
sides). Specifically, Enhanced Mosaic supports:

http://  (HTTP server)

ftp://  (FTP server)

file://  (local HTML file)

telnet:// (Telnet server)

gopher:// (Gopher server)

http://www.whitehouse.gov/tours/oval_office.gif

Internet protocol 
used to transmit 

the file.

Location of the 
computer server.

Path name. File name and 
format.

This URL displays a photograph of the oval office (in a .GIF format). It is stored in 
a sub-directory called Tours on the Whitehouse.gov http server connected to the 
World Wide Web network. 
 Using Enhanced Mosaic
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Networks and Servers

The information available on the Internet is stored somewhere in
world on an individual computer server. This is simply a computer 
that is dedicated to storing information and responding to reque
to see the information from people authorized to access it. A net-
work  is a method for connecting these individual computers tog
er, allowing them to share information. 

In practical terms, this means that when working over a networ
you can access information not from just one server, but from a
the servers that are tied to the network. In the case of the Intern
this means literally thousands. 

The Internet takes the concept of information sharing one step 
ther by connecting not just individual servers, but the networks 
themselves. This is why the Internet hosts such a vast array of i
mation from around the world. It is a very complex system that 
lows you to share information with all the millions of people who
are connected. It should also be noted that the Internet is a wo
process; every day another Web page, another server, another
work is added.

What You’ll Find

The possibilities of what you can find on the WWW are almost lim-
itless. From downloading software for your computer, to seeing 
latest photographs taken from NASA’s Hubble Space Telescope
leaving a message for the President of the United States, the W
has it all. 

While Enhanced Mosaic offers some suggestions on sites you 
want to visit, the best way to see what the WWW has to offer is
simply explore what’s out there during your free 30 day period. 
hanced Mosaic provides you with the leading search tools for e
ploring the Internet, including Yahoo, the WWW Virtual Library,
the World Wide Web Worm and WebCrawler. You’ll find hyper-
links to these tools by choosing the History command from the N
igate menu and/or in the on-line help (see “Search the Internet”).
 Using Enhanced Mosaic, 4-7
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Using Enhanced Mosaic to Browse the 
Internet

When you first install Net Commander, the Enhanced Mosaic 2
home menu page is automatically displayed. To display the hom
menu page after installation, double-click the Enhanced Mosaic
icon located in the Net Commander program group, or folder.

Enhanced Mosaic Home Menu Page

The Enhanced Mosaic home menu page is your starting point f
navigating the Internet and the World Wide Web. It is similar to a
other Windows application containing a menu bar, tool bar, con
menu and status bar. You can move the window on your desktop
size it, minimize it or maximize it (see your Windows User Guide 
for more information on these procedures).

You can select menus and commands using the mouse or thei
propriate Alt-key combination (Windows 3.1 users only — pres

Minimize/Maximize 
buttons

Activity icon

URL entry box

Control menu

Menu bar

Tool bar

Page forward/
backward

Document 
display 
window

Scroll bar

Status bar
 Using Enhanced Mosaic
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and hold the Alt key, then press the underlined letter of the men
command. For example to open the File menu, hold down the Alt 
key and press F. To select the Print command from the File menu, 
press P).

While you can use a different home page other than the defaul
hanced Mosaic home page (see “Changing Preferences” on pa4-
29 for procedures), the interface — menu bar, commands, tool 
and so on — and the procedures as described in this chapter re
the same.

Window Components
Displayed icons 
are from 
Windows 3.1.

The Enhanced Mosaic main window contains the following com
nents:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
icon) in the upper left corner of the window. It contains the stand
Windows operations to Move, Size, Maximize, and Close the w
dow. For more information on these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains all the commands which may be executed while work
with the Enhanced Mosaic application (see page 4-11 for more in-
formation).

Tool bar
Allows you to quickly execute many of the commands contained
the Menus by simply clicking the mouse on the icon (see page 4-13 
for more information).
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Page Forward/Page Backward buttons
These buttons are available only when you have opened more 
one document. They allow you to quickly page back and forwa
through the current session of opened WWW sites, documents, pho-
tographs, or other items.

URL field
Displays the currently displayed URL. You may type another UR
into the entry box and press Enter to go to and display that item

Activity icon
The icon in the upper right corner of the Enhanced Mosaic wind
animates whenever Enhanced Mosaic is connecting to a URL, 
transferring information or waiting to receive information.

Document display window
This is the area where the information contained in a URL is di
played. You can open multiple document windows and interact w
each window independently (to read one document while down
loading information in the other, for example). When documents 
loaded into the window, text is displayed first, followed by graphi
and images. You do not have to wait for images to be loaded to m
another hyperlink or menu command selection.

To cycle between open windows, press and hold the Control ke
then press the Tab key.

Scroll bars
If the window contains more information than can be displayed
the viewable area, use the scroll bars on the right side and botto
the viewing area to see more information.

Status bar
Displays status messages and a file-transfer progress indicator
along the bottom of the window. The status message may show
the ULR of a hyperlink whenever the mouse is moved over a lin
the status of a file transfer, or the command description whene
the mouse is moved over a menu command or tool bar icon. Th
progress indicator shows the time remaining for a file to be load
, Using Enhanced Mosaic
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Enhanced Mosaic Menus

You may select the following commands from the Enhanced Mos
menu bar:

File menu
Open a new window; enter (and go to) a specific URL; open (an
display) a file saved to your hard disk or local network; close the
tive window (and exit Enhanced Mosaic if only one window is 
open); save the active file to your hard disk; print the active wind
contents; change the layout of printed pages; change printer opt
exit Enhanced Mosaic.

File menu

Edit menu
Copy selected text and images; select all text in the current doc
ment; search a document for a specified word or phrase; repea
previous search; view HTML text; view security protocols; chan
parameters (such as color) for hyperlinks, the default home pag
and servers; view and configure hypermedia helpers.

Open, close and print win-
dows and documents.
 Using Enhanced Mosaic, 4-11
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Edit menu

Navigate menu
Go back, forward or to the home page; display the navigational
tory for the past 60 days (and go to a file); display the hotlist; a
the current file to the hotlist; load and reload missing graphics.

Navigate menu

Tools menu
Display the WWW Yellow Pages.

Tools menu

Copy text; find text; view 
security protocols; setup 
Enhanced Mosaic prefer-
ences and helpers.

Display and navigate 
through documents.

Open the WWW yellow 
pages.
, Using Enhanced Mosaic
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of 
Window menu
Tile or cascade open windows; select an open window.

Window menu

Help menu
Display the on-line help; display information about this version 
Enhanced Mosaic.

Help menu

Tool Bar
The Enhanced Mosaic tool bar allows you to access the following 
commands by clicking the mouse on the applicable icon:

Organize windows.

Display on-line help and 
system support information.

Go to 
your 

Home 
Page.

Open and 
go to a 
URL.

Open a 
saved file.

Reload 
the current 
document.

Load 
unloaded 
images.

Repeat 
find.

Save the 
displayed 

file.

Add cur-
rent docu-

ment to 
hotlist.

Interrupt 
current 

operation.

Find a 
word or 
phrase.

Print 
current 
window.

Display 
hotlist 

window.

Display 
on-line 
help.

Display 
WWW 
Yellow 
Pages.
 Using Enhanced Mosaic, 4-13
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide

4-14

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

. . .

tool 

r 

om 

asy 

om-
n 

ou 

ds 

-
. 

t 
the 
s 
Keyboard Commands and Suggestions

When working on the WWW, keep the following keyboard and 
working options in mind:

• To stop a file transfer, press Esc or click the Stop icon on the 
bar.

• If you cannot retrieve a file or open a Web site, try again late
(the server may be overloaded).

• To return to your home page, choose the Home command fr
the Navigate file, or click the Home Page icon on the toolbar.

• Add interesting sites or documents to your hotlist to make it e
to find them later (see page 4-24 for more information).

• To load a missing graphic, select the Load Missing Images c
mand from the Navigate menu, or click the right mouse butto
on the missing (and empty) image box.

• Press the Tab key to select the URL entry box.

• Press the Shift key at the same time you click a hyperlink if y
would like to display the file in a new window.

• Press and hold the Ctrl key, then press the Tab key to cycle 
between open windows.

Working with Enhanced Mosaic

As you work with Enhanced Mosaic, use the following comman
to make your session more productive:

Printing a Document
To print the contents of the active window, choose the Print com
mand from the File menu, or click the Print icon on the tool bar
When the Print dialog displays, click OK. 

From this point on in the current session, the Print dialog will no
display when you select the Print command — the contents of 
active window will automatically print whenever the command i
selected.
, Using Enhanced Mosaic
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If you need to setup your printer, click the Setup button on the P
dialog. Refer to your Windows User Guide for information on set-
ting up a printer.

Copying Text
You may copy text from a WWW document to the Windows clip
board (and paste it into another application) by holding down th
left mouse key, dragging the mouse over the text you wish to co
then choosing the Copy command from the Edit menu, or by pr
ing the Ctrl+C keys.

To select all text in the active window, choose the Select All co
mand from the Edit menu, or press Ctrl+A.

Searching a Document
To search a document using a word or phrase, choose the Find
mand from the Edit menu, or click the Find icon on the tool bar. T
Find dialog displays.

Find dialog

1 Type the word or phrase you wish to locate in the active docum

2 To narrow the search, click the Match Case checkbox.

3 To start the search from the top of the document, click the Sta
From Top checkbox.

4 Click OK. Enhanced Mosaic will search the document and high
light the specified word or phrase.

5 To repeat the search, choose the Find Again command from th
Edit menu, or click the Find Again icon on the tool bar. 

To locate a word or 
phrase in a document, 
type the text and click 
OK.
 Using Enhanced Mosaic, 4-15
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Navigating Open Documents
To navigate among open documents, use the commands conta
in the Navigate menu (Back, Forward, Home) or click the page 
ward/backward keys.

Closing a Document
If you have multiple windows open and wish to close the active
window, choose the Close command from the File menu. If only o
window is open, this will close and exit the Enhanced Mosaic ap
cation. 

Exiting Enhanced Mosaic
To exit Enhanced Mosaic, and close all open windows and con
tions, choose the Exit command from the File menu.

Getting Started
If you are a new Internet user, use the following procedure to g
started exploring the WWW.

With the Enhanced Mosaic home page displayed:

1 Click the starting points hyperlink located in the Getting Started
section of the home page.

The Cyberspace Sampler page displays with a wide variety of 
gestions for exploration. While these represent only a tiny fract
of what is available of the WWW, they are popular sites and wi
get you accustomed to working on the Web.

2 Click the mouse once on one of the colored/underlined hyperlin
to open that document or Web site.

When documents are loaded into the document window, text is
loaded first, followed by graphics and images. You do not have
wait for images to load to make another hyperlink or menu com
mand selection.
, Using Enhanced Mosaic
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The WWW Yellow Pages
Both new and experienced Internet users will find the WWW Ye
low Pages extremely informative and helpful in locating interesti
Web sites. The WWW Yellow pages contains hundreds of popular 
sites and documents in numerous topical areas with a full desc
tion of what you’ll find at the site and a hyperlink to get there. A
ditionally, many items contain keywords which can be used to 
search for additional information using such Internet search tool
Archie or Gopher. Items are displayed in the WWW Yellow Pag
in alphabetical order.

If you have installed the WWW Yellow Pages (see page 4-27), y
may display the WWW Yellow pages from the Enhanced Mosa
home page as follows:

1 Choose the World Wide Web Yellow Pages command from the
Tools menu. The WWW Yellow Pages main window displays.

WWW Yellow Pages main window

2 Use the scroll bar to view all the available topics. 

3 To display the contents of a subject area, click on the subject’s
box.

The descriptions and hyperlinks to the sites and documents for
selected subject are displayed as shown below.

To select a 
topic, click on 
a subject box.
 Using Enhanced Mosaic, 4-17
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WWW Topic Descriptions 

4 Use the scroll bar to see additional site descriptions.

5 To change subject areas, click on a desired letter in the alphab
cal bar at the top of the screen below the subject area title.

6 To open a URL, click on the hyperlink contained in its descripti

Opening a URL
To visit a web site or view a document, you must tell Enhanced M
saic where you want to go and what you want to view by enteri
its URL. This may be done in any a number of ways, such as:

• Typing in the URL address directly.

• Selecting an item from your history list or hotlist.

• Opening a saved file.

• Clicking on a hyperlink to the document.

Without question, the easiest method to open a URL is to simp
click the mouse once on a hyperlink. The harder question is de
ing where you want to go.

As we have already reviewed, Enhanced Mosaic assists new u

Click a letter 
to jump to that 
section in the 
list.

Click the 
hyperlink to 
open the URL.
, Using Enhanced Mosaic
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in their exploration of the WWW with a number of suggestions f
getting started. Additionally, the WWW electronic Yellow Pages
can help all users locate exciting Web sites in a variety of topica
eas. Once you become an experienced user, you can save fav
sites to your hotlist making them quickly available at the click of t
mouse or you can enter a URL address directly into the URL bo

Entering URLs directly

You do not have to use a hyperlink in order to open a URL. If y
know the URL, you may enter it directly into the URL entry box 
the top of the Enhanced Mosaic window. 

To enter a URL directly:

1 Double-click on the current entry in the URL entry box.

2 Press the Delete key.

3 Type the URL you wish to open. URLs are case sensitive and m
not begin with a space.

4 Press the Enter key. 

If you have entered the URL correctly, Enhanced Mosaic will loc
and display it.

URL Entry Box

From the File Menu
You can also enter a URL directly by choosing the Open URL co
mand from the File menu, or clicking the Open URL icon on the
toolbar. The Open URL dialog displays (see page 4-20).

Type the URL and press Enter.
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Open URL dialog

1 Type the URL you wish to open (or paste it using the Ctrl+V ke
if you have copied a URL from your Hotlist). Remember, URLs
are case sensitive and must not begin with a space.

2 Click OK. 

If you have entered the URL correctly, Enhanced Mosaic will loca
and display it.

The History List
Enhanced Mosaic remembers every URL you open for 60 days
lists them in the order they were opened (most recent first) in a
tory list. You can re-open a URL contained in the history list at a
time by simply double-clicking it. 

To display your history list:

1 Choose the History command from the Navigate menu. The H
tory dialog displays (see page 4-21).
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History dialog

The History dialog lists your activity for the past 60 days beginni
with the most recently opened URL at the top of the list. The old
URLs are deleted from the history list after 60 days. From this d
log, you may:

• Go to (open) a URL.

• Delete an item from the list.

• Export and save the list.

To close the History list, click the Close button.

Opening a URL From the History List

To open a URL contained on the history list, highlight the item i
the list and click the Go To button, or double-click the item in th
list.

Deleting an Item 

To delete an item contained on the history list, highlight the item 
click the Delete button.

To open a URL, 
highlight it and click 
Go To, or simply 
double-click it.
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Saving the History List

To save a history list to your hard disk, click the Export button. T
Export History dialog displays.

Export History dialog

1 By default, files are saved to the C:\NETCMDR directory. You 
may change this directory as desired (refer to your Windows User 
Guide for procedures).

2 Type a file name using an .HTM extension in the File Name te
box.

3 Click OK.

Opening a Saved History List

You may open and display a saved history list in hyperlink form
(each entry in the list is displayed as a hyperlink) at any time.

To open a saved history list:

1 Choose the Open Local command from the File menu, or click 
Open File icon on the tool bar. The Open Local dialog displays
(see page 4-23).
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Open Local dialog

2 Open the directory where you have saved your history list files
the Directories box. The C:\NETCMDR directory is opened by 
default.

3 Highlight the file you wish to open in the File Name list box.

4 Click OK. 

The history list is opened and displayed with each entry now a
hyperlink to its URL. To open an item on the list, click the mous
once on its hyperlink.

Opened History List

To open an item in 
the saved history 
file, click the 
mouse once on its 
hyperlink.
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The Hotlist
The hotlist allows you to quickly save favorite files, sites or doc
ments to an easily accessible file. 

Adding a Document to the Hotlist
 With the document displayed in the active window, choose the

Add Current to Hotlist command from the Navigate menu, or cli
the Hotlist icon on the tool bar. The document is added to the h
list.

Displaying the Hotlist
By default, Enhanced Mosaic adds a few popular Web sites to y
hotlist. Additionally, it contains any other items you have added
it.

To open an item contained on your hotlist:

1 Choose the Hotlist command from the Navigate menu, or click 
Hotlist icon on the tool bar. The Hotlist displays.

Hotlist dialog

To open an 
item in the Hot-
list, highlight 
the item and 
click Go To.
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2 Highlight the file you wish to open and click Go To, or double-
click the file. 

The item’s URL is automatically passed to Enhanced Mosaic a
is displayed.

3 Click Close to close the Hotlist.

Deleting Hotlist Items
To delete an item contained in your hotlist, with the Hotlist dis-
played, highlight the item and click the Delete button. The item 
removed from the list.

Editing Hotlist Items
To change the title of a hotlist item, or to copy the URL, with the
Hotlist displayed:

1 Click the Edit button. The Edit Hotlist Entry dialog displays.

Edit Hotlist Entry dialog

2 Type a different title or URL as desired. To copy the URL, doub
click the URL box and press Crtl+C.

3 Click OK. The name is changed in your Hotlist.
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Saving the Hotlist

You may create and save as many hotlists as desired.

To save a hotlist:

1 With the Hotlist displayed, click the Export button. The Export 
Hotlist dialog displays (see page 4-22 for a representative sample
of the dialog. It is identical to the Export History dialog).

2 By default, files are saved to the C:\NETCMDR directory. You 
may change this directory as desired (see the Windows User Guide 
for procedures on navigating drives and directories).

3 Type a file name using an .HTM extension in the File Name te
box.

4 Click OK. The file is saved to the designated sub-directory on 
your hard disk.

Opening a Saved Hotlist 
To open a saved hotlist:

1 Choose the Open Local command from the File menu, or click 
Open File icon on the tool bar. The Open Local dialog displays
shown on page 4-23.

2 Open the directory where you have saved your hotlist files in th
Directories box. The C:\NETCMDR directory is opened by 
default.

3 Highlight the file you wish to open in the File Name list.

4 Click OK. 

The hotlist is opened and displayed with each entry now a hyp
link to its URL (see page 4-27). To open an item on the list, click 
the mouse once on the item’s hyperlink.
, Using Enhanced Mosaic
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Saved Hotlist

Saving a File
You can save any active document — text, image, sound file or 
eo file — to your hard disk.

To save a displayed document:

1 Choose the Save As command from the File menu, or click the
Save As icon on the tool bar. The Save As dialog displays (see
page 4-28).

Click a hyper-
link to open 
an item from 
the Hotlist.
 Using Enhanced Mosaic, 4-27
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide

4-28

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

. . .

 

the 
 

 in 
Save As dialog

2 By default, files are saved to the C:\NETCMDR directory. You 
may change this directory as desired (see your Windows User 
Guide for procedures on navigating drives and directories).

3 Type a file name with an .HTM extension in the File Name text
box.

4 Click OK. The file is saved to the designated sub-directory on 
your hard disk.

Opening a Saved File
To open a saved file:

1 Choose the Open Local command from the File menu, or click 
Open File icon on the tool bar. The Open Local dialog displays
(see page 4-23).

2 Open the directory where you have saved your history list files
the Directories box. The C:\NETCMDR directory is opened by 
default.

3 Highlight the file you wish to open in the File Name list.

4 Click OK. The document is opened and displayed.
, Using Enhanced Mosaic
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Changing Preferences
You can change a number of Enhanced Mosaic preferences in
ing:

• Page layout 

• Document format

• Hyperlink format

• Home pages

• Default Servers

Changing the Page Layout
You can change the margins, headers and footers that Enhance
saic uses for printed pages.

To change the page layout:

1 Choose the Page Setup from the File menu. The Page Setup d
displays.

Page Setup dialog

2 To change the page margins, type the desired measurements,
inches, in the Page Margins fields.

Change margins, 
headers and foot-
ers.
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3 Type the desired variable that you want to print on the page hea
and footer. You can print a left and right header and footer. Yo
can also combine variables with text (for example Page &p of 
&P). 

Select from the following variables:

&w  — window title

&U  — URL

&d  — date (Feb 24 1996)

&D  — date (24 Feb 1996)

&t  — time (05:30 PM)

&T  — time (17:30)

&p  — current page number

&P  — total number of pages

&&  — single ampersand (&)

4 Click OK to save and apply the page layout changes.

Changing Document Preferences
The Preferences command in the Edit menu enables you to ch
how Enhanced Mosaic displays and prints documents, includin
fonts and font sizes, and the format and colors used for hyperlin
You can also create a memory cache and set up a proxy server, in 
addition to other options.

Improving Performance
Documents load quicker without images. To improve performan
you can select to load only a documents text, and not any assoc
images. You can load all the images linked to a document later
choosing the Load Missing Images command from the Navigat
menu. You can load a single image in a document by clicking t
right mouse button on the image box.
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To keep images from loading with a document:

1 Choose the Preferences command from the Edit menu. The Pr
ences dialog displays.

2 Click the Load Images Automatically checkbox (it becomes 
blank)

3 Click OK to apply the change.

Preferences dialog

Changing Fonts
You can change your display and printer font and font size, spe
a header font, and specify a proportional font.

To change fonts and font sizes:

1 Choose the Preferences command from the Edit menu. The Pr
ences dialog displays.

2 Press the arrow at the bottom of the screen next to the Display
field.

3 Select the Fonts option from the drop-down list to display the fo
options (see page 4-32).

Click (uncheck) the 
Load Images Automat-
ically checkbox.
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Preferences dialog - Fonts options

4 Click the arrow next to the option for which you want to change
the font or font size.

5 Highlight the desired font or font size and release the mouse.

6 Click OK to apply the change.

Changing Colors
You may change the colors used to display text, links, visited lin
or the display background.

To change system colors:

1 Choose the Preferences command from the Edit menu. The Pr
ences dialog displays.

2 Select the Colors option from the drop-down list at the bottom 
the screen. The Colors options display.

Control fonts using the 
Fonts option from the 
drop-down list.
, Using Enhanced Mosaic
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Preferences dialog - Colors options

3 Click the appropriate set button to change the default color. Th
Color dialog displays.

Color dialog

4 Click on the desired color, then click OK.

Note
The visited link color automatically reverts to its default color aft
24 hours.

Setting a Memory Cache
You can improve system performance by setting a memory cac

To set a memory cache:

1 Choose the Preferences command from the Edit menu. The Pr
ences dialog displays.

Control system colors 
using the Colors 
option from the drop-
down list.
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2 Select the Cache option from the drop-down list at the bottom 
the page. The Cache Options dialog displays.

Preferences dialog - Cache options

3 Type the directory path you wish to use for the cache or select
directory from the Browse button.

4 Change the cache size (the default is 2048) as desired.

5 Select how often you wish the cache verified during a session 
(Never, Once or Always).

6 To flush the cache each time you exit Enhanced Mosaic, click 
Flush Cache on Exit checkbox.

7 Click OK to close the dialog and apply the options.

Setting up a Proxy Server
You can use a proxy server to access the Internet and bypass the de-
fault gateway. Because of the technical nature of this procedure,you 
should fully understand the use of proxy servers before you atte
it. For more information, refer to the Enhanced Mosaic on-line h
topic “Setting up a Proxy Server”.

To setup a proxy server:

1 Choose the Preferences command from the Edit menu. The Pr
ences dialog displays.

Setup a memory 
cache using the 
Cache option from the 
drop-down list.
, Using Enhanced Mosaic
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2 Select the Proxy option from the drop-down list at the bottom o
the page. The Proxy options display.

Preferences dialog - Proxy options

3 Enter the proxy information and click OK.

Changing Home Pages and Other Items
While Enhanced Mosaic comes with a default home page, you 
change it and use any URL document you wish. It is recommend
however, that you use a document that has been saved to your
disk to load it quickly. You can also control other display option
such as if you display the Enhanced Mosaic toolbar, or server m
sages.

To change display options:

1 Choose the Preferences command from the Edit menu. The Pr
ences dialog displays.

2 Select the Miscellaneous option from the drop-down list at the 
tom of the screen. 

Setup a proxy 
server using the 
Proxy option on the 
drop-down list.
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Preferences dialog - Miscellaneous options

3 Double click the entry in the Home Page text box and press th
Delete key.

4 Type, or paste, the URL of the document you want to use as y
home page.

5 Enter your e-mail address in order to send e-mail from the 
Enhanced Mosaic browser.

6 Enter your e-mail server address to send e-mail from the Enhan
Mosaic browser.

7 Enter your news service address to access the news groups from 
the Enhanced Mosaic browser.

8 Select a language from the drop-down list as desired (the defau
English).

9 Select to show or hide the following items (checked options wi
display):

• Toolbar

• Server Messages

• Underline Links

10 Click OK to apply the changes and close the dialog.

Change display 
options using the 
Miscellaneous option 
from the drop-down 
list.
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Configuring Helper Applications
Enhanced Mosaic Helpers define the types of files you can view 
work with as you explore the Internet. Enhanced Mosaic has bu
in support for the following file types:

• HTML documents

• Text documents

• JPEG and GIF images

• AU and AIFF sound files

You can configure support for other types of files (such as vide
files) by assigning a helper application. Any program that accep
command line instructions can be used as a helper application.

To configure a helper application:

1 Start Enhanced Mosaic by double-clicking its icon in the Net 
Commander program group or folder. The Enhanced Mosaic ho
page displays (see page 4-8).

2 Choose the Helpers command from the Edit menu. The Helpe
dialog displays.

Helpers dialog

To see which helper 
has been configured 
to read or play a par-
ticular file type, high-
light the file type and 
look at the status 
message. 
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3 Select the file type for which you want support and click the Ed
button. The Configure File Type dialog displays.

Configure File Type dialog

For most predefined file types, the Helper Application field is th
only field you need to complete. Default values are provided for 
other fields and are displayed when you select a file type. 

4 Click the Browse button. The Browse dialog displays.

Browse dialog

5 Select the appropriate application that can run or interpret the 
selected file type from your system. Usually, these are containe
your Windows directory. After highlighting the application, click
OK (or double-click the application in the File Name box).

Unless you 
are adding a 
new file type, 
the only field 
you need to 
complete is 
the Helper 
Application. 
, Using Enhanced Mosaic
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The Configure File Type dialog re-displays with the Helper App
cation field filled-in.

6 Click OK.

The Helpers dialog re-displays and the helper is configured for 
selected file type.

7 Click Close to close the Helpers dialog.

Adding a New File Type
If you want to create a file type which is not contained on the He
ers dialog, you may do so using the following procedure.

To create a new file type:

1 Choose the Helpers command from the Edit menu. The Helpe
dialog displays.

2 Click the Add button. A blank Configure File Type dialog display
(see page 4-38). 

3 Complete the following fields:

Field Description

Description Type a descriptive name for the file type. 

MIME Type Type the MIME type of the file type. MIME 
(Multipurpose Internet Mail Extensions) is a
standard for sending multimedia file types b
e-mail. File types are identified by the MIME
type, a value that specifies the type and su
type of the data (type/subtype). For example, 
the MIME type used to identify JPEG files is
image/jpeg. If a MIME type is not provided, 
Enhanced Mosaic uses the file extension to
determine the file type. 

Use one of the following types (for the type 
portion):

•text

•multipart
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4 Click OK.

The configured helper is added to the Helpers list.

5 Click the Close button to close the Helpers dialog.

Field Description

 •message

•application

•image

•audio

•video

If none of these types describes the file typ
use the application type.

Use your own description for the subtype. To 
distinguish your subtype form registered su
types, type “x-” before the subtype. For ex-
ample, application/x-acad.

For more information on MIME types, refer
to the Enhanced Mosaic on-line help.

Suffixes Type each filename extension associated 
with the file type. Separate each extension b
a space (for example, .JPG).

Encoding Select the Binary or Text option to indicate
how the file type is encoded. 

Helper 
Application

Type the full path and name of the helper a
plication, followed by “%s” where the name
of a downloaded file should be inserted, or
click the Browse button to select the helper
application (as explained above). 

Service Name If the helper application is compatible with 
the Mosaic Software Development Interface
enter the DDE service name of the applica
tion. If no service name is specified, the com
mand line in the Helper Application field will 
be used to launch the helper application.
, Using Enhanced Mosaic
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Deleting a Helper

You can delete any unused or incorrect helper listed in the Help
dialog.

To delete a helper:

1 Choose the Helpers command from the Edit menu. The Helpe
dialog displays.

2 Highlight the helper you wish to delete.

3 Click the Delete button.

The helper is removed from the Helpers list.

4 Click the Close button to close the Helpers dialog.

Security Protocols
Security modules are third-party programs that allow Enhanced
Mosaic to communicate with secure servers using various secu
protocols. Since different applications (banking, education, etc.,
quire different levels of security, multiple security modules may 
installed. Once a security module is installed, it is ready to use.

When Enhanced Mosaic accesses a secure server, it activates t
curity module required by that server. If the required module is 
installed on your system, you will need to obtain the correct mod
from that server. Security modules and instructions for installing
and configuring modules should be available from servers that 
quire them. 

The following modules are pre-installed with Enhanced Mosaic

• First Virtual — Supports an Internet payment system from Fir
Virtual Holdings Inc. Before you use First Virtual the first time
you will be prompted to create an account. This process is 
accessed from the Web page itself where the First Virtual link
located.

• Digest Authentication — Uses MD5-encrypted passwords for 
authorization to receive an HTTP reply. 

• Basic Authentication — A basic, non-secure protocol supporte
 Using Enhanced Mosaic, 4-41
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by nearly all WWW servers. A user name and password are s
to the server in UUENCODED form. This method can be use
to limit access to a server. 

In most cases, the pre-installed security modules allow you to a
cess most all information on the Internet.

If you would like to view the security modules installed on your s
tem, choose the Security command from the Edit menu. A casc
ing menu displays allowing you to select one of the installed 
modules.

For more information on security, refer to the Enhanced Mosaic
line help topic “Security Modules”.
, Using Enhanced Mosaic
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Overview
In addition to the Enhanced Mosaic World Wide Web browser, N
Commander includes the Microsoft® Internet Explorer™ Web 
browser. If you are using Windows 95, Internet Explorer is the d
fault Web browser that runs when you click “The Internet” icon o
the desktop. You may, of course, run Enhanced Mosaic instead
opening the Start menu, pointing to Programs, Net Commander,
clicking Enhanced Mosaic.

This chapter gets you up and running with Internet Explorer an
provides a guided tour of the most frequently used features. (At
time of this writing, version 2.0 was the latest version of Interne
Explorer; by the time you read this, there may be a newer versi
If so, the Internet Explorer Help file will fill you in on new feature
and how to use them.)

Starting Internet Explorer
When you run Internet Explorer, it is set up by default to autom
cally dial your ISP’s number. It also loads the Microsoft Networ
starting page (or “home page”), whether or not you subscribed to
Microsoft Network when you installed Windows 95. (Later in thi
chapter you will find out how to change the default starting pag

To launch Internet Explorer:

• Click “The Internet” icon on the desktop, or

• Open the Start menu, then point to Programs, Net Commander, 
Internet Explorer.

The following figure illustrates the Internet Explorer window as 
looks with a Web page displayed.

This chapter 
assumes that 
your Internet 
connection has 
been set up cor-
rectly during 
installation.
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Internet Explorer window

Window Components
Address bar
Displays the URL—Uniform Resource Locator, or Internet ad-
dress—of the currently displayed page. You may type a differen
URL into this entry box and press Enter to find and display that
item.

Activity icons
The “clouds” graphic animates whenever Internet Explorer is co
necting to a URL, transferring information or waiting to receive 
formation. The “Web document” icon at the right end of the stat
bar—a globe on a page—has three states:

• The icon looks like a globe when Internet Explorer is trying to
connect to the requested server.

• The globe-on-page icon is animated while the requested doc
ment is being loaded.

Tool bar

Address bar

Document 
viewing area

Status bar

Activity icons
5-4, Using Microsoft Internet Explorer
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• The globe-on-page icon is still when the transfer is done and
document is being displayed.

Document display area
This is the area where the information contained in a URL is d
played. You can open multiple document windows and interac
with each window independently (to read one document while 
downloading information in the other, for example). When doc
ments are loaded into the window, text is displayed first, follow
by graphics and images. You do not have to wait for images to
loaded to scroll through the window, or make another hyperlink
menu command selection.

To cycle between open windows, press and hold the Control k
then press the Tab key.

Status bar
The status message may show you the URL of a hyperlink wh
ever the mouse is moved over a link, the status of a file transfe
the command description whenever the mouse is moved over 
menu command or tool bar icon. The progress indicator at the r
side of the status bar fills as a file is received.

Internet Explorer Menus
Internet Explorer includes the following menus:

File menu
Use the File menu (see next page) to open a new window, ope
new page, save documents, set up print margins and headers,
documents, and exit Internet Explorer. The File menu also con
niently lists the last several pages that you visited, for easy red
play.
 Using Microsoft Internet Explorer, 5-5
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File menu

Edit menu
Use the Edit menu to cut, copy, and paste selected text and i
es, select all text in the current document, and search a docum
for a specified word or phrase.

Edit menu

View menu
Use the View menu (see next page) to turn on or off the tool b
address bar, or status bar; enlarge or reduce font size; stop th
transfer of a document; refresh the current page; view the do
ment’s HTML source file; and set up most of the Internet Explo
options (see the “Configuring Preferences” section later in thi
chapter.)
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View menu

Go menu
Use the Go menu to navigate backward and forward through th
pages that have been displayed during the current session, and
the default Start Page or Search Page.

Go menu

Favorites menu
Use the Favorites menu (see next page) to display and manage
favorite pages—the ones you plan to revisit pretty regularly. (Th
Favorites list is sometimes called the “hotlist” or “bookmarks.”) U
to 19 items from the Favorites list appear on this menu, for easy
cess. (See the section on “Using The Favorites List” later in this
chapter.)
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Favorites menu

Help menu
Use the Help menu to get information about Internet Explorer’s f
tures and how to use them.

Help menu

Tool Bar
The Internet Explorer tool bar allows you to access many com-
mands by clicking the mouse on the applicable icon.

Go to Start 
Page.

Open a 
saved 

file.

Print the 
current 
page.

Paste
 text.

Add page 
to Favorites

folder.

Go to 
Search 
Page.

Reduce 
font.

Paste 
short-
cut in
e-mail.

Go to 
previous 

page.

Stop the 
current 
activity.

Go to 
next 

page.

Refresh 
the current 

page.

Read 
News-
groups.

Open 
Favor-
ites 

Enlarge 
font.

Cut 
text.

Copy 
text.
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Keyboard Commands and Suggestions

When using the Web, keep the following keyboard and working 
tions in mind:

• To stop a file transfer, press Esc or click the Stop icon on the t
bar.

• If you cannot retrieve a file or open a Web site, try again later
(the server may be overloaded).

• To return to your search page, choose the Search Page comm
from the Go menu, or click the Search Page icon on the toolb

• Add interesting sites or documents to your Favorites folder to
make it easy to find them later.

• To load a missing graphic, right-click on the image’s icon and
choose the Show Picture command.

• Press the Shift key at the same time you click a hyperlink if y
would like to display the file in a new window.

• Press and hold the Ctrl key, then press the Tab key to cycle 
between open windows.

Getting Started

If you are a new Internet user, use the following procedure to be
exploring the Web, using the Luckman Interactive World Wide 
Web Yellow Pages starting page. (For instructions on installing 
WWW Yellow Pages, see page 5-27). New and experienced Inter-
net users both will find the WWW Yellow Pages extremely infor
mative and helpful in locating interesting Web sites. The WWW
Yellow pages contains hundreds of popular sites and documen
numerous topical areas with a full description of what you’ll find 
the site and a hyperlink to get there. Additionally, many items c
tain keywords which can be used to search for additional inform
tion using such Internet search tools as Archie or Gopher. Items
displayed in the WWW Yellow Pages in alphabetical order.

With the Internet Explorer home page displayed:

1 Choose the File Open command from the File menu, and browse 
for the path to the file named subjects.htm in the \YP directory 
(for example, c:\netcmdr\yp\subjects.htm). 
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

 . . . . 

of 

ys, 
ite 

 
 to 
-

s 

-
. 

rd 
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

2 Click OK until you return to Internet Explorer. The home page 
the WWW Yellow Pages displays.

WWW Yellow Pages main window

3 Scroll through the subject heading boxes (each box is a link) and 
click on any one that interests you. In the document that displa
there is an alphabetical index, followed by a list of URLs with s
descriptions. Click on any underlined link to load a document.

When documents are loaded into the document window, text is
loaded first, followed by graphics and images. You do not have
wait for images to load to make another hyperlink or menu com
mand selection.

Working with Internet Explorer
As you work with Internet Explorer, use the following command
to make your session more productive:

Printing a Web Document
To print the contents of the active window, choose the Print com
mand from the File menu, or click the Print icon on the tool bar
When the Print dialog displays, click OK. 

Copying Text
You may copy text from a Web document to the Windows clipboa
(and paste it into another application) by holding down the left 
5-10, Using Microsoft Internet Explorer



Working with Internet Explorer
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

hen 
 the 

m-

com-

ent.

t 

e 

ined 
ns.

ec-
mouse key, dragging the mouse over the text you wish to copy, t
choosing the Copy command from the Edit menu, or by pressing
Ctrl+C keys.

To select all text in the active window, choose the Select All co
mand from the Edit menu, or press Ctrl+A.

Searching a Document
To search a document using a word or phrase, choose the Find 
mand from the Edit menu. The Find dialog displays.

Find dialog

1 Type the word or phrase you wish to locate in the active docum

2 To narrow the search, click the Match Case checkbox.

3 To start the search from the top of the document, click the Star
From Top checkbox.

4 Click OK. Internet Explorer will search the document and high-
light the specified word or phrase.

5 To repeat the search, choose the Find Again command from th
Edit menu.

Navigating Open Documents
To navigate among open documents, use the commands conta
in the Go menu, or click the page forward/backward tool bar ico

Exiting Internet Explorer
To exit Internet Explorer, and close all open windows and conn
tions, choose the Exit command from the File menu.
 Using Microsoft Internet Explorer, 5-11
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

b 

pen 
x-
 

hap-

x-
ing 

ly 
cid-

b 
ced 
g 
y a 
-

 If 
try 
ow. 
Opening a URL
A URL is simply the address of a document on the Internet. We
documents are distinguished by their hypertext links, which are spe-
cially formatted URLs embedded in the document. These links o
the documents they refer to when you click on them. Internet E
plorer creates shortcuts for URLs when it stores them in the History
list and Favorites list (these two lists are discussed later in this c
ter).

To visit a web site or view a document, you must tell Internet E
plorer where you want to go and what you want to view by enter
its URL. This may be done in any a number of ways, such as:

• Typing the URL address directly in the Address field.

• Selecting an item from your History list or Favorites folder.

• Opening a saved file.

• Clicking on a hyperlink to the document.

Without question, the easiest method to open a URL is to simp
click the mouse once on a hyperlink. The harder question is de
ing where you want to go.

The WWW Yellow Pages can help all users locate exciting We
sites in a variety of topical areas. Once you become an experien
user, you can save favorite sites to your Favorites folder, makin
them quickly available at the click of the mouse, or you can cop
URL address from the WWW Yellow Pages directly into the Ad
dress field.

Using the Address Bar
You do not have to click on a hyperlink in order to open a URL.
you know the URL, you may enter it directly into the Address en
box in the Address bar near the top of the Internet Explorer wind

To enter a URL directly:

1 Double-click on the current entry in the Address entry box.

2 Press the Delete key.
5-12, Using Microsoft Internet Explorer
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3 Type the URL you wish to open. URLs are case sensitive and m
not begin with a space.

4 Press the Enter key. 

If you have entered the URL correctly, Internet Explorer will loca
and display it.

Address (URL) entry box

Using the File Open Dialog
You can also enter a URL directly by choosing the Open comma
from the File menu, or clicking the Open icon on the toolbar. Th
Open Internet Address dialog displays.

Open Internet Address dialog

1 Type the URL you wish to open (or paste it using the Ctrl+V ke
if you have copied a URL from a document). Remember, URLs
are case sensitive and must not begin with a space.

2 Click OK. 

If you have entered the URL correctly, Internet Explorer will loca
and display it.

Type the URL and press Enter.
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Using The History List
Internet Explorer maintains a list of every URL you open, up to
number that you specify (the default is 300, the maximum is 3,0
you will learn how to set this number shortly). When the limit is 
reached, the oldest URLs are dropped and the most recent one
added.

On the File menu, several of the most recent URLs that you ha
opened are always listed (and numbered). You can return to th
Web pages simply by clicking on them. The following procedur
explain how to access the complete History list.

To display the History list:

• Choose the More History command from the File menu. A W
dows Explorer window opens, showing the contents of your H
tory folder. 

To open a URL from the History list:

• Double-click the item in the History list.

To delete an item from the History list:

• Highlight the item and choose the Delete command from the
File menu, or right-click on the item and choose Delete.

Configuring the History List
You can specify the maximum number of URLs to store in the H
tory list, you can empty the list and start over, and you can ass
the History list to a different directory. These operations are pe
formed in the Options dialog, using the Advanced tab (selected
from the View menu).
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View Options, Advanced

To set the maximum size of the History folder:

Use the” Remember the last...places visited” spin control to incre
or decrease the number. Each entry is the History list is small—
entries takes about 20 kilobytes—so you do not need to worry ab
running short of disk space if you choose to store hundreds or t
sands of URLs in the History folder.

To empty the History folder:

• Click Empty.

To assign a different directory for the History folder:

• Click Change, and in the dialog that appears, enter the new p
to the history folder.
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You may want to archive your History folder from time to time. T
do so, simply copy the contents of the History folder to a differe
folder (and compress them, if you wish), then empty the History
folder to make room for more entries.

Using the Global History File

The URLs of all the Web pages you have visited are also store
a “global history” file. This is an HTML file, meaning that you ca
display it right in Internet Explorer, with each URL in the file ap
pearing as a link. 

(This file is not updated until you exit Internet Explorer, so the g
bal history file will not show a history of the URLs visited during
the current session. Use the More History command from the F
menu for that purpose.)

To open the global history file:

• Choose Open File command from the Open File sub-menu in
File menu, then browse fro globhist.htm. This file is usually 
located in the directory where Windows 95 is installed. Click 
OK, then click Open.

To make the global history file readily available at any time, add
to your Favorites folder (see the next section).

Using The Favorites List
The Favorites list allows you to quickly save favorite Web pages
an easily accessible list. In some circles the term “hotlist” is used
“Favorites folder.” The idea behind the Favorites list is that you w
want to revisit these pages frequently, so they should be the m
convenient to access.

You can add an item to your Favorites list while the item is dis-
played, or you can wait until later and copy the item from the H
tory list (see the previous section) to the Favorites list.

The Favorites menu has room for 19 items from your Favorites 
for extremely easy access. By creating folders and folders-with
folders of your favorite pages, you can actually list hundreds of
pages right on the Favorites menu, as will be explained shortly
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To add the current document to your Favorites list:

1 With the document displayed in the active Internet Explorer wi
dow, choose the Add Current to Favorites command from the 
Favorites menu, or click the Add to Favorites icon on the tool b
or right-click the item and choose Add to Favorites. The Add to
Favorites dialog opens, with the new item’s name displayed in 
Name field.

Add to Favorites dialog

2 Click OK to add the item to the Favorites list and close the dial

To open an item in the Favorites list:

1 If the item is listed on the Favorites menu or is in a folder on th
Favorites menu, select it from the menu. Otherwise, choose th
Open Favorites command from the Favorites menu, or click th
Open Favorites icon on the tool bar. The Favorites list displays
(see next page).
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Favorites list

2 Double-click the item you wish to open. The item’s URL is auto
matically passed to Internet Explorer and displayed.

3 Close the Favorites list.

To delete an item in the Favorites list:

• Highlight the item and click the Delete button, or right-click th
item and choose Delete. The item is removed from the list.

Sometimes you may want to find out the actual URL (or “target
URL”) that corresponds to an item in your Favorites list.

To see the URL of an item in the Favorites list:

• Right-click the item and choose Properties from the pop-up 
menu button. Click on the Internet Shortcut tab. The Target U
is show in the first field of the Properties dialog that opens (s
next page).
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Creating Favorites Folders

You may create and save as many folders in the Favorites list a
sired.

To create a Favorites folder:

1 Open the Favorites list. Choose the New, Folder command fro
the Files menu.

2 Enter the name of the folder. This should be the name of a cat
gory that you want to use to organize your favorite pages (for 
example, Zines, Java, Brain Research). Click OK.

3 Now move items in the Favorites list into the folders you create
for them.

4 Close the Favorites list window.

The first 19 folders and other items (alphabetically) will appear 
the Favorites menu. You can create new folders within the top-le
folders to subdivide your categories, and fit even more pages o
the Favorites menu. Nested folders in effect create “cascading 
menus” on the Favorites menu.
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Saving a File
You can save any active document — text, image, sound file or 
eo file — to your hard disk.

To save a displayed document:

1 Choose the Save As command from the File menu.

The Standard Windows 95 Save As dialog displays.

Save As dialog

2 Choose the folder where you want to file to be saved.

3 Type a file name with an HTM extension in the File Name text 
box.

4 Click OK. The file is saved to the designated folder.

Using Right-Click Pop-Up Menus
When you click the right mouse button in a Web page, different
menus pop up depending on the item you have clicked on, suc
text, background, picture, and so on.
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Right-Click Pop-Up Menus

• Right-clicking on the background of a Web page pops up a 
menu that allows you to save the background graphic in a file
use it as your desktop wallpaper, or copy the background 
graphic to the Clipboard.

• Right-clicking on a picture pops up a menu that allows you to
save the picture or use the picture as your desktop wallpape
the picture is also a link, the menu includes commands for ad
ing the picture’s URL to you Favorites list, opening the picture
linked document in a separate window, or copying the picture
URL to the Clipboard.

• Right-clicking on normal text (not a link) pops up a menu tha
allows you to view the HTML source document of the Web 
page. If the text is a link, the pop-up menu allows you to cop
the links URL to the Clipboard or add it to the Favorites list.

Right-click on background or text Right-click on text link

Right-click on image Right-click on image link
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• If the “Show pictures” option has been turned off (as is describ
in the “Configuring Preferences” section below), a placeholde
graphic appears on the screen where the picture would norm
appear. Right-clicking on the placeholder image pops up a m
that allows you to load the picture itself.

Configuring Preferences
You can change a number of Internet Explorer preferences inc
ing:

• Page layout 

• Document-loading speed

• Document appearance

• Default Start Page and Search Page

• Applications associated with file types

• Security

Changing Page Layout
You can change the margins, headers and footers that Internet
plorer uses for printed pages.

To change the page layout:

1 Choose the Page Setup command from the File menu. The Pa
Setup dialog displays (see next page).
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Page Setup dialog

2 To change the page margins, type the desired measurements,
inches, in the Page Margins fields.

3 Click Headers. The Headers and Footers section of the Page S
dialog appears.

Page Setup - Header and Footers

4 Type the desired variable that you want to print on the page hea
and footer (see the list below). You can print a different left-pag
and right-page header and footer. You can also combine varia
 Using Microsoft Internet Explorer, 5-23
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with text (for example Page &p of &P). 

Select from the following variables:

&w  — window title

&U  — URL

&d  — date (Feb 24 1996)

&D  — date (24 Feb 1996)

&t  — time (05:30 PM)

&T  — time (17:30)

&p  — current page number

&P  — total number of pages

&&  — single ampersand (&)

5 Click OK to save and apply the page layout changes.

Improving Document-Loading Speed
There are two ways to speed up document loading in Internet E
plorer:

• “Turn off” inline images, sound files, and animation files, so th
they are not automatically displayed or played when docume
containing them are loaded.

• Enlarge the cache (hard-disk space) where no-longer-display
pages are stored. Pages stored in the cache can be redispla
faster than pages that have to be reloaded from a remote We
server.

Each of these performance enhancement procedures is discuss
this section.

Turning Off Image, Sound, Animation Files
Documents load quicker when graphical images, sound files, a
animation files are not loaded or played when loading a docum
that contains such elements. To improve performance, you can
lect to load only a document’s text, and not any associated ima
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sound files, or animation files. You can load an image later by rig
clicking on its graphical placeholder and choosing Show Pictur

To keep from loading image, sound, or animation files:

1 Choose the Options command from the View menu. 

2 Select the Appearance tab.

3 In the Page section, clear the checkboxes that correspond to w
you want to turn off: Show pictures, Play sounds, or Show anim
tions.

4 Click Apply to apply the change(s).

Setting Cache Options
You can improve document-loading performance by adjusting t
size of the virtual memory (hard-disk) cache where pages are st
when they are no longer displayed in an Internet Explorer windo
Pages stored in the cache folder redisplay very quickly when y
open their URLs in the History list or Favorites list, compared to
loading the page from a remote site.

However, there are two caveats to keep in mind regarding the ca
folder. First, cached pages take up a lot of disk space. Internet
plorer lets you decide the maximum percent of hard disk drive sp
the cache can occupy. Second, a page loaded from the cache 
not be current; that is, the actual page on the Web site where y
found it may have changed since you last viewed it. Internet Exp
er lets you decide if you want to update the URLs in the cache o
per session, or never. You can also empty the cache folder or cr
a new cache folder.

To set the cache options:

1 Choose the Options command from the View menu. 

2 Select the Advanced tab.
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Cache Section of Advanced Option

3 In the Cache section, choose the Update pages option your pr
Once per session, or Never.

4 Slide the slider control left or right to adjust the maximum perce
of drive space you want to devote to the cache. Increasing the per-
cent means more pages can be saved in the cache.

5 If you want to empty the cache folder, click the Change button. 
This will release disk space for additional pages, but of course you
will lose the pages that are currently in the cache.

6 If you want to create a new (additional) cache folder, click the 
Change button and specify the new folder.

7 Click Apply to apply the change(s).

8 Close the Options dialog.

Changing Document Appearance
Internet Explorer’s View Options include an Appearance tab, w
which you can set many preferences regarding the appearance
various elements of Web pages.

Changing Fonts
You can change the font that is used for proportional and fixed-
width text in Web pages.

To change fonts:

1 Choose the Options command from the View menu. 

2 Select the Appearance tab.
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3 In the Page section, select the desired fonts from the Proportio
font and Fixed-width font drop-down lists.

4 Click Apply to apply the change(s).

Changing Text and Background Colors
You may change the colors used to display text, links, visited lin
or the display background.

To change text and background colors:

1 Choose the Options command from the View menu. 

2 Select the Appearance tab.

3 In the Shortcuts section, click in the Use Custom Color checkb
(if it is not already selected).

4 Click on the Text color button.

5 In the popup color palette, click on the color you want to use fo
plain text in Web documents. Click Apply to apply the change.

6 Click on the Background color button.

7 In the popup color palette, click on the color you want to use fo
Web document backgrounds. 

8 Click OK in the Options dialog.

To change the color of visited and not-visited links:

1 Choose the Options command from the View menu. 

2 Select the Appearance tab.
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3 In the Shortcuts section, click on the Already viewed color butto

4 In the popup color palette, select the color you want to use for 
links that you have not yet visited (clicked on). Click Apply to 
apply the change.

5 Back in the Options dialog, in Shortcuts section, click on the N
yet viewed color button. 

6 In the popup color palette, select the color you want to use for 
links that you have visited (clicked on). Click Apply to apply the
change.

7 Close the Options dialog.

Setting the Address Display Format
URLs in their full glory are admittedly cumbersome to type and
read. You can set up Internet Explorer to show you full http://–st
addresses, or simplified addresses that show you the name of 
page. For example, compare Caffeine and http://www.halluci-
net.net/caffeine/. The style you choose affects the display of URL
in the History and Favorites lists.

To select an address display style:

1 Choose the Options command from the View menu and click o
the Appearance tab.

2 In the Addresses section (at the bottom of the dialog), choose 
plified or Full addresses.

3 Click OK.
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Changing the Default Start and Search Pages

While Internet Explorer comes with a default home page, you c
change it and use any URL document you wish. It is recommend
however, that you use a document that has been saved to your
disk to load it quickly. You can also control other display option
such as if you display the Internet Explorer toolbar, or server m
sages.

To change the default Start Page:

1 Open the page that you want to be your Start Page in Internet 
Explorer.

2 Choose the Options command from the View menu.

3 Select the Start and Search Pages tab.

View Options - Start and Search Pages

The drop-down list should be showing Start Page. If it is not, 
choose Start Page from the list. The URL of your current Start 
Page is displayed.

4 To change the default to the page currently displayed in Intern
Explorer’s document viewing area, click Use Current.
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5 Close the Options dialog.

To change the default Search Page:

1 Open the page that you want to be your Search Page in Intern
Explorer.

2 Choose the Options command from the View menu. 

3 Select the Start and Search Pages tab (see the previous page

4 Choose Search Page from the drop-down list.

5 The URL of your current Search Page is displayed. To change
default to the page currently displayed in Internet Explorer’s do
ment viewing area, click Use Current.

6 Close the Options dialog.

Associating Applications with File Types
Web pages can include as links files of different types that requ
different software to “play” them. For example, To hear an RA fi
that has been included in a Web page requires that a “helper” a
cation capable of reading RA files (such as RealAudio) be insta
and associated with the RA file type.

Internet Explorer includes support for many different types of file
especially graphic files such as GIF and JPEG. But over time y
will almost certainly want to download and install new helper ap
cations. In Internet Explorer, you use the View, Options’ File Ty
tab to associate each file type (file “extension”) with the specific
program that will run when you select a link of that type. 

To change the helper application for an existing file type:

1 Choose the Options command from the View menu and select
File Types tab (see next page).
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View, Options - File Types

2 Select the file type for which you want support and click the Ed
button. The Edit File Type dialog displays.

Edit File Type dialog
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3 Click on one of the entries in the Action section of the dialog, th
click Edit. The Editing Action dialog displays.

Editing Action dialog

4 In the “Application used to perform action” box, delete the exis
ing entry and enter the complete path to the application that yo
want to perform the selected Action, or use the Browse dialog.

5 When done, click OK in the Editing Action dialog, then close th
Edit File Types dialog, and finally close the Options dialog.

Adding a New File Type
You can create a new file type and associate an application wit
using the following procedure.

To create a new file type:

1 Choose the Options command from the View menu and select
File Types tab.

2 Click New Type. The Add New File Type dialog displays. This 
looks just like the Edit File Type dialog that you see if you click
Edit in the File Types dialog, except that all of the fields are bla
and there is an additional field (Associated extension).

3 Enter Description of type - Type a descriptive name for the file 
type. 

4 Enter Associated extension - Enter the extension that belongs to
this file type.

5 Select Content Type (MIME)  - Select a type/subtype description
from the drop-down list. The default extension for the MIME typ
subtype displays in the Default Extension for Content Type fiel
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MIME (Multipurpose Internet Mail Extensions) is a standard for
sending multimedia file types by e-mail. File types are identified 
the MIME type, a value that specifies the type and subtype of t
data (type/subtype). For example, the MIME type used to identify
JPEG files is image/jpeg. If a MIME type is not provided, Internet
Explorer uses the file extension to determine the file type. If no
of these types describes the file type, use the application type.

6 Enter Action -Enter an action that the application performs on t
file type, such as Open or Run.

7 Click New. The New Action dialog displays.

New Action dialog

8 In the “Application used to perform action” box, enter the com-
plete path to the application that you want to perform the selec
Action, or use the Browse dialog.

9 If the application will use DDE, click in the Use DDE checkbox
and fill in the four new fields that appear below the checkbox.

10 When done, click OK in the New Action dialog, then click OK in
the Add New File Type dialog, and finally close the Options dia
log.
 Using Microsoft Internet Explorer, 5-33
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Security

Internet Explorer can check the security of any Internet site you
connecting with and warn you when the site is not secure. This
important when you want to send confidential information, such
a credit card number. You can select the level of warning you w
to receive when viewing or sending data to an Internet site.

To select security warning options:

1 Choose the Options command from the View menu and select
Security tab.

View Options - Security

2 Click on the “Tell me about Internet security” button, read the he
text, then close the help window.

3 Select the Security While Sending and Security While Viewing
options that you wish.

4 Close the Options dialog.
5-34, Using Microsoft Internet Explorer
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Introduction
Most of the Net Commander applications automatically start wh
is called the “stack and dialer” program (or dial-up networking p
gram) that is responsible for making the connection between yo
computer and the Internet (through your ISP’s network). Some
times, however, you may want to connect to the Internet “manu
ly,” so to speak, before you run a Net Commander application. T
is required before running some of the “helper” applications or 
“tools” that come with Net Commander (see Appendix A, Helpe
Applications, page 6-5). 

This chapter explains how to connect to the Internet by directly r
ning the program that makes the connection. Instructions are p
vided for Windows 3.1 and Windows 95.

Connecting to the Internet in Windows 3.1
The next several sections explain the program and procedures 
to connect to the Internet if you are using Windows 3.1

Trumpet Winsock
Trumpet Winsock is the Net Commander client application that
tablishes the physical modem connection to the Internet network
ing PPP (Point-to-Point Protocol) or SLIP (Serial Line Internet 
Protocol). Trumpet Winsock allows you to run all the Net Com-
mander applications.

During installation of Net Commander, key information about yo
modem and Internet account is automatically passed to Trump
Winsock making it unnecessary for you to manually configure t
application. Once you complete your Internet registration (see 
“Registering an Internet Account,” page 6-17), the application is 
ready to use. 

For the most part, Trumpet Winsock works “behind the scenes”
you work in Net Commander. When launched, Trumpet Winsoc
automatically opens your modem line, dials the ISP, connects 
to the ISP network and passes on your host ID and password. F
then on, it works in the background, keeping your connection op
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The following sections explain how to use the Trumpet Winsock
plication to:

• Connect to and disconnect from the Internet.

• Change modem settings.

• Change network configuration.

• Change dialer options.

PPP and SLIP

PPP (Point-to-Point Protocol) and SLIP (Serial Line Internet Proto-
col) are the software used by the dialer to tell your computer how
communicate with another computer. While PPP is a slower pr
col than SLIP, it generally offers more error protection to ensure
formation gets back and forth as intended. Which protocol is use
based on what your ISP is using. The Trumpet Winsock applica
contains both protocols.

Starting the Application

The Trumpet Winsock application is started in one of three way

• Click a WWW hyperlink in Enhanced Mosaic. The first time 
you click a hyperlink to a WWW URL, the stack and dialer, as it
is commonly known, automatically launches, makes the conn
tion and remains open in the background in an iconized state

To display the Trumpet Winsock main window (see page 6-6), 
double-click the minimized icon.

• Double-click a Net Commander application configured to 
make an Internet connection at launch. Many of the client 
applications automatically start Trumpet Winsock at the sam
time as they start.

• Double-click the Connect icon in the Net Commander pro-
gram group. The Trumpet Winsock main window displays an
the Login script is started automatically.
6-4, Connecting to the Internet
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The following sections explain the features of the Trumpet Winso
window and menus.

The Trumpet Winsock Window

The Trumpet Winsock window displays communication and co
nection information. It is similar to any other Windows applicatio
in that you can re-size it, move it on your desktop, minimize it o
maximize it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements (see pa
6-6).

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 

For more information on these commands, refer to your Windo
User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains all the commands which may be executed while work
with the Trumpet Winsock application.

Display area
Shows you key information for the current on-line session such
your connect status, baud rate, ISP, and error messages. You 
copy or clear screen information as desired.
Connecting to the Internet, 6-5
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Scroll bar
If the window contains more information than can be displayed
the viewable area, use the scroll bar to see more information.

Trumpet Winsock window

Menu Commands
While working with the Trumpet Winsock window, the following
commands from the menu bar may assist you in maximizing yo
productivity:

From the File menu:

Setup  — Change network configuration settings, including IP a
dresses, server names, and PPP/SLIP options. This command
quires some technical understanding of IP addressing and 
communication protocols.

Minimize/Maximize 
buttonsControl menu

Menu bar

Display 
Window

Scroll bar
6-6, Connecting to the Internet
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Register — Used to register the Trumpet Winsock application.
You do not need to register this application if you followed the 
original Net Commander installation and registration proce-
dures. 

Firewall Setup — Set up firewalls to prevent unauthorized acce
to a network. This is an advanced feature that requires technica
derstanding of the Internet, networks and addressing conventio
Under most circumstances, you will not need to execute this fea

PPP Options — Allows you to setup a password authentication
protocol (PAP) requiring you to verify a user name and passwo
each time you login to the Internet. To do so, click the Use Passw
Authentication Protocol checkbox, enter a user name and passw
then click OK. For most users, you will not need to execute this
command.

Exit — Closes the main window and disconnects you from the 
ternet (if you are on-line). 

From the Edit menu:

Copy — To copy text to the clipboard, hold down the left mous
button, drag the mouse over the text you wish to copy (it becom
highlighted), and choose the Copy command. Text may then b
pasted into another text processor (Notepad, Windows Write, M
crosoft Word, etc.).

Clear — To clear the display area of all displayed text, choose 
Clear command.

From the Special menu:

Info  — Select this command to display current session informat

Kill Socket — Displays a dialog allowing you to exclude a parti
ular socket (an IP address identifying a host) and a port addres
(identifying an application running on this host). After entering th
socket, press OK. This function requires some technical knowle
of addressing conventions and will, under most circumstances,
be used.
Connecting to the Internet, 6-7



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

ug-
not 
o by 

ript 

.

 it 
ical 
ces, 

s 
 by 

o-

nd 
From the Trace menu:

The commands contained in this menu are used to display deb
ging information should you experience a technical problem. Do 
enable any option in this menu unless you are instructed to do s
a technical support technician.

From the Dialer menu:

Login — Select this command to execute the login command sc
that connects you to the Internet.

Bye — Disconnects and closes your active Internet connection

Other — Allows you to run another command script by selecting
from the File Open dialog. This command requires some techn
understanding of command scripts, and under most circumstan
will not be used.

Manual Login — Allows you to manually login to the Internet.

Edit Scripts — Allows you to edit command scripts. This require
technical knowledge of programming scripts and will not be used
most users.

Options — Allows you to change dialer options such as an aut
matic login, redial settings and parity settings.

From the Help menu:

About  — Displays information about this version of the stack a
dialer.
6-8, Connecting to the Internet
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Connecting to the Internet
If you receive 
an error mes-
sage that the 
connection can 
not be made, try 
again in a few 
minutes.

Trumpet Winsock automatically connects you to the Internet wh
ever you initially click a hyperlink to a WWW URL in Enhanced
Mosaic (or if set by default, when you launch Enhanced Mosaic

After making a successful connection from Enhanced Mosaic, 
Trumpet Winsock automatically minimizes. 

To make a manual connection to the Internet:

• Double-click the Connect icon in the Net Commander progra
group. The Trumpet Winsock main window displays (as show
on page 6-6) and the Login script is automatically started.

If you stop the connection process and want to restart the Log
script, choose Login from the Dialer menu.

Stopping a Connection
• To stop a connection in progress, press the ESC key.

Disconnecting from the Internet

If you are working in Net Commander, you are usually disconne
ed automatically from the Internet whenever you exit the last pr
gram that uses an Internet connection. You can also disconnec
clicking on the Trumpet Winsock icon to display the Control me
then selecting the Close command.

If you are working in the Trumpet Winsock main window, choos
the Bye command from the Dialer menu.

Changing Network Configurations

You may change Trumpet Winsock network configurations by 
choosing the Setup command from the File menu. The Networ
Configuration dialog displays.
Connecting to the Internet, 6-9
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Network Configuration dialog

Changing default settings requires some technical understandin
IP addressing and communication protocols. Most users will no
find it necessary to change these settings.

Changing Modem Settings

The Trumpet Winsock application is automatically configured wi
your modem port configuration when you install Net Command
If you change your modem or modem port configuration, you m
change the settings using the Advanced button in the Registrat
dialog. Refer to “Changing Modem Settings,” page 6-24, for proce-
dures. If you are an advanced user who understands how to ed
command script, you can also change your modem port setting
editing the login script which may be selected using the Edit Scr
command in the Dialer menu.

Changing Dialer Options

Dialer options that can be changed include automatic login pro
dure, timeout redial options, and the settings for parity and wor
size.

To change dialer options:

1 Choose the Options command from the Dialer menu. The Dial
Options dialog displays.

Default settings are made 
when you install Net Com-
mander. 
6-10, Connecting to the Internet
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Dialer Options dialog

2 Click the options you wish to select and/or enter a SLIP inactiv
timeout period.

3 Click OK to close the dialog and save the changes.

Connecting to the Internet in Windows 95
In Windows 95, Dial-Up Networking is used to connect to the In
ternet. You set up a Dial-Up Networking program for your partic
lar ISP when you installed Net Commander (see “Registering a
Internet Account” page 6-17). The following sections explain how
to launch the connection program “manually” and how to discon
nect from the Internet when done.

To connect to the Internet:

1 From the Start menu choose Accessories, then choose Dial-Up 
Networking. The Dial-Up Networking window displays.
Connecting to the Internet, 6-11
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Dial-Up Networking window

2 If you set up an account with Portal when you installed Net Com
mander, open the Portal connection. If you chose a different IS
during Net Commander installation, choose that connection 
instead.

3 The Connect To dialog displays.

Connect To dialog

If you did not turn on the Save Password option, enter your pa
word and click Connect. If the password is already filled in (as 
asterisks), click Connect.

The dial-up networking program dials your ISP and notifies you
when it has made a connection.
6-12, Connecting to the Internet
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Connected To... dialog

To disconnect from the Internet:

1 Click on the connect task in the task bar (for example, “Portal”),
switch to the Connected To... dialog.

2 Click Disconnect in the Connected To... dialog.

Changing Modem Settings
The Connect program is automatically configured with your mod
port configuration when you install Net Commander. If you insta
a different modem or change your modem port configuration, y
must change the settings using the Advanced button in the Reg
tion dialog. Refer to “Changing Modem Settings,” page 6-25, for 
procedures.
Connecting to the Internet, 6-13
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Overview
Net Commander’s electronic mail application, Eudora, is fast be-
coming one of the most widely used e-mail applications on the 
ternet for its ease of use and its feature-rich interface. With Eud
you can effortlessly send and receive mail to/from anyone in the 
world. 

During installation of Net Commander, information about your I
ternet account is passed to the Eudora e-mail application allowin
to automatically configure itself to the proper account and e-ma
server. If you are using the default Net Commander Internet pro
er, Eudora is ready to use — you do not have to do anything to 
figure it!

This chapter shows you how to send and receive e-mail, includ
how to attach documents, use nicknames and create additional 
boxes. Additionally, it shows you how to customize application 
preferences and how to configure Eudora should you change In
net providers.

Starting the E-Mail Program
To start the Eudora e-mail program, double-click the Mail icon i
the Net Commander program group.

The Eudora main window displays (see page 7-7). This window is 
similar to any other Windows application in that you can re-size
move it on your desktop, minimize it or maximize it (refer to you
Windows User Guide for procedures).

The main window is comprised of the following elements (all 
screen and icon samples are from Windows 3.1):

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.
E-Mail, 7-5
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Starting the E-Mail Program
Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. For more information on using these comman
refer to your Windows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains all the commands which may be executed while work
with Eudora.

Tool bar
On many Eudora dialogs, a tool bar displays allowing you to se
key commands quickly.

Scroll Bar
Scroll bars may be displayed on the far right of the window sho
the viewable area not contain all the available information.

Display area
Displays other windows and dialogs which are used to configur
send and receive mail.
 E-Mail
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Eudora main menu

E-Mail Addresses
If you change 
your ISP, you 
will have to 
manually config-
ure Eudora with 
a new e-mail 
address. For 
procedures, 
refer to page 
7-33.

Your e-mail address is automatically created when you install Net 
Commander. Like your own home address, an electronic mail ad-
dress is used to identify who you are and where you are located on 
the Internet. When sending mail, you need to know the e-mail ad-
dress of the recipient in order for the mail to be delivered.

E-mail addresses are constructed as follows:

Minimize/Maximize 
buttonsControl menu

Display 
Window

Menu bar

hostIDname@mail.ip.portal.com

Your Host 
ID 

Separator ISP server name (where 
you have your account)
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Creating an Outgoing Message
An outgoing message is one that you send to another mailbox. 
can send a message to a single person or to multiple people. Yo
also attach (and send) documents (such as a word processing f
spreadsheet file) with your message.

A message is comprised of a header (who the message is to/fr
and its subject) and the message body (the actual message tex

To create an outgoing message:

1 Choose the New Message command from the Message menu
blank message window displays.

Message window

2 Enter the following header information:

Press the 
Tab key to 
move to each 
header line. Message Header

Message Body Text
 E-Mail
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Field Description

To: Type the complete e-mail address for the per-
son to whom you want to send the message. 
You can use a “nickname” in this field rather 
than the complete e-mail address, as appro-
priate (see page 7-26 for procedures on creat-
ing nicknames).

From: Your return e-mail address and your full 
name is automatically filled in.

Subject: Type a brief description of the subject of your 
message.

CC: To send a copy of the message to another per-
son, enter that person’s e-mail address. To 
send multiple copies, separate each e-mail 
addresses by a comma. E-mail addresses en-
tered in the CC: field display in the message 
header (and can be read by all recipients).

Bcc: To send a copy of the message to a “blind” 
recipient, enter the applicable e-mail address. 
Addresses listed here do not display in the 
message header (and are not seen by recipi-
ents). This may be useful when you wish to 
send a message to someone without other re-
cipients of the message knowing.

Attachments: If you want to attach a document to the mes-
sage, click the mouse next to the Attachment: 
field and choose the Attach Document com-
mand from the Message menu, then select 
the document you want to attach from the 
displayed dialog. 
E-Mail, 7-9
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3 Type the message. You can use the following commands from
Edit menu when creating a message.

• Cut text — highlight the text you want to cut by holding down
the left mouse key and dragging the mouse over the text, the
choose the Cut command. The cut text is placed in the clipbo

• Copy text — highlight the text you want to copy by holding 
down the left mouse key and dragging the mouse over the te
then choose the Copy command. The text is placed in the cli
board.

• Delete text — highlight the text you want to delete by holding
down the left mouse key and dragging the mouse over the te
then choose the Clear command. 

• Paste text — place the cursor where you want to paste cut or
copied text and choose the Paste command. 

• Paste as Quotation — to denote quoted text with a “>” charac
ter at the beginning of the text, choose the Paste as Quotatio
command. 

• Undo last command — to undo the last executed command, 
choose the Undo command. 

• Select all text — to select (and highlight) all text in the messag
area, choose the Select All command.

Field Description

Attachment
(continued)

If you have not enabled a default attachment 
type, select a format from the Attachment 
Type drop-down list on the tool bar. You 
may select MIME (Multipurpose Internet 
Mail Extensions) or Bin Hex. In most cases, 
MIME is the preferred selection. 

A default attachment format can be set in the 
Switches dialog (see page 7-38) selected 
from the Special menu.

For more information on attaching docu-
ments, refer to page 7-13.
, E-Mail
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4 Select a message priority from the Priority drop-down list butto
on the tool bar. In most cases, messages are assigned a Norm
ority. 

Message Priority drop-down list

5 As desired, you can attach your signature to the end of the mes
by selecting the Signature drop-down list on the tool bar (this m
also be set by default in the Switches dialog (see page 7-38) 
selected from the Special menu). Refer to page 7-14 for informa-
tion on creating a signature.

Signature Priority drop-down list

6 Click the Send button on the tool bar, or select the Send Imme
ately command from the Messages menu. 

The message is sent immediately. To send the message again
choose the Send Again command from the Message menu.

Click the mouse on the 
desired priority level.
E-Mail, 7-11
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Saving an Outgoing Message

If you want to save a copy of the outgoing message, choose the 
command from the File menu. A copy of the message is saved
your Out Mailbox (this may also be set by default in the Switche
dialog (see page 7-38) selected from the Special menu).

To close a displayed message, choose the Close command from
File menu.

Opening a Saved Outgoing Message

Messages saved to the Out Mailbox are identified by the recipie
e-mail address (the To: field) and the message subject (the Sub
field). Messages remain in the Out Mailbox until you delete them
move them to another folder.

To open a saved outgoing message:

1 Choose the Out command from the Mailbox menu. Your Out 
Mailbox displays.

Out Mailbox

2 To open a message, double-click the message, or press the E
key when the message is highlighted. The message is opened
the message window.

New mes-
sages are 
identified by 
a bullet.
, E-Mail
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Attaching Documents

Attachments are separate documents you can send with a mes
You can attach any document you like to a message displayed in
Message window.

To attach a document to an outgoing message:

1 With the cursor at the Attachments: field, choose the Attach Do
ment command from the Message menu. The Attach Documen
dialog displays. This dialog is identical to the standard Window
File Open dialog. 

2 Select the document you want to attach and click OK. For mor
information on navigating files and directories, refer to your Wi
dows User Guide.

The full path name of the attachment is displayed in the Attach
ments: field in the message header.

3 Repeat steps 1 and 2 for each document to be sent with the m
sage.

To remove an attached document from the message:

1 Click the document’s path name in the Attachments: field.

2 Press the Delete or Backspace key, or choose the Clear comm
from the Edit menu.

The document is removed from the message.

Setting a Default Attachment Type

Attachments must be converted to a special format in order to b
transmitted over the Internet. You may select either MIME (Mul
purpose Internet Mail Extensions) or Bin Hex. In most cases, MIM
is the preferred selection. While you can select an attachment t
for each attachment from the Attachment drop-down list on the
message window, you can also set a default type which will be u
for all attachments unless changed.
E-Mail, 7-13
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To set a default attachment type:

1 Choose the Switches command from the Special menu. The 
Switches dialog displays (see page 7-38).

2 Enable the Always as Attachment option by clicking its checkb
(it should be checked).

3 Select an attachment format: MIME or BinHex.

4 Click OK to save the option change and close the Switches dia

Default Attachments options

Creating a Signature
A signature is a brief message added to the end of your outgoi
message. 

You can include whatever you like in a signature (for example, 
telephone number), but at a minimum, it should consist of your f
name and your e-mail address. 

To create a signature:

1 Choose the Signature command from the Window menu. The 
nature window displays.

2 Type the signature text in the blank window. To begin a new lin
press the Enter key.

3 After completing the text, choose the Save command from the 
menu.

4 Choose the Close command from the File menu to close the S
ture window.

Setting a default attachment 
type encodes all attachments 
in the selected type.
, E-Mail
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The signature is created and is automatically added to an outg
message whenever you select it from the Signature drop-down
on the Message window menu bar or if you have enabled the U
Signature option in the Switches options dialog (see page 7-38). In 
this case, the signature is added to all outgoing messages by 
default.

Queuing Messages

If you do not want to send an outgoing message immediately, y
can queue it to send at a later time. 

To queue a message:

• With the message displayed, save it to your Out Mailbox by 
choosing the Save command from the File menu.

To send a queued message:

1 Choose the Switches command from the Special menu. The 
Switches dialog displays (see page 7-38).

2 Click the Immediate Send checkbox (it becomes blank) to ena
queue message sending.

3 Click OK to close the Switches dialog.

4 Choose the Queue for Delivery command from the Message me
Notice that the Send button now reads Queue.

5 Click the Queue button. The Out Mailbox displays (see page 
7-12). Queued messages are identified by a “Q” in the far left c
umn of the mailbox.

6 Choose the Send Queued Message command from the File m

The queued messages are sent.
E-Mail, 7-15
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Sending Timed Messages

You can also send messages at a specified future time.

To send a timed message:

1 With the message displayed, choose the Change Queueing co
mand from the Message menu. The Change Queueing dialog 
plays.

Change Queueing dialog

2 Select one of the following options by clicking the radio button 
next to the option:

Field Description

Right Now Send the message immediately when the O
button is clicked.

Next Time 
Queued 
Messages are 
Sent

Send the message the next time queued m
sage are sent.
, E-Mail
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3 Click OK to save the options.

Additional Tool Bar Options
The Message window tool bar contains five additional options 
which are enabled by default. To disable an option, click on the 
ton.

Quoted-Printable Encoding
Quotes print on a printed message (identified as a “>” characte

Word Wrap
Text is automatically wrapped to the next line after approximate
76 characters. 

Tabs in Body
Tabs are inserted into the message whenever the Tab key is pre

Keep Copy
A copy of each message sent is kept in your Out Mailbox (identif
by an “S” in the far left column). Messages are saved until dele
or transferred to a different folder.

Text as Document
Text files attached to messages are sent as separate documen
disabled, text files are incorporated into the message.

Field Description

On or After:
Time
Date

Send the message on the specified time or
date. Messages are held in the Out Mailbo
as Queued messages, but sent at the specif
time/date.

Don’t Send This option changes the message from a 
Queued message (Q) to a Saved message 
in which case, the message is saved in the
Out Mailbox until it is either deleted, re-
queued, or sent.
E-Mail, 7-17
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Checking For and Receiving Mail
There are two ways to see if you have new mail: 

• You can configure Eudora to automatically notify you whenev
new mail is received.

• You can manually check for it.

Passwords
By default, Eudora requests a password prior to your first mail 
check regardless of whether it is an automatic or manual check
the first request for mail, the Enter Password dialog displays. 

Enter Password dialog

• Type your account password (assigned by the ISP) and click 
OK. Remember that passwords are case sensitive; enter the
exactly as assigned.

To disable this function (and not be prompted to enter a passw
when checking mail), choose the Switches command from the S
cial menu, then select the Save Password option in the Checki
box (see page 7-38). Click OK to apply the change. Your passwor
is now passed to Eudora automatically (and you do not have to m
ually enter it when checking mail).

This is the password 
returned to you during 
your automatic regis-
tration of Net Com-
mander (see page 7-
22).
, E-Mail
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Changing Your Password
If you wish to change your password, choose the Change Passw
command from the Special menu. The Change Password dialog
plays.

You will be prompted to type your old password once, then a n
password twice. You may use up to 8 characters in a password

Manually Checking for Mail
To manually check for new mail:

1 Choose the Check Mail command from the File menu. 

Eudora opens your account on the Internet, displaying a progr
window as the connection and mail check are made. 

If new mail is located, the progress window remains at the top o
your screen, allowing you to monitor the transfer of messages fr
the server to your hard disk. 

Once your mail has been downloaded, a message displays thatYou 
have new mail”. 

2 Click OK to close the mail notification message. By default, ne
mail is saved to your In Mailbox.

To stop a mail check in progress, press the Esc key.

Checking Mail Automatically
To have Eudora automatically check for new mail at a specified
terval and then alert you when new mail is downloaded:

1 Choose the Configuration command from the Special menu. T
Configuration dialog displays (see page 7-34).

2 Type the interval, in minutes, that you want Eudora to check fo
new mail in the Check For Mail Every ? Minutes field. For exam
ple, if you type 15, Eudora will check every 15 minutes for new
mail.

To stop an automatic mail check in progress, press the Esc key
E-Mail, 7-19
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Notification Options
You have three different notification options which are specified 
the Switches dialog. 

To select a notification option:

1 Choose the Switches command from the Special menu. The 
Switches dialog displays (see page 7-38).

2 Select the options you wish to set in the New Mail Notification 
box. You may select to have Eudora:

• Display an alert message dialog.

• Sound an audio alert.

• Automatically open the In Mailbox.

• Execute any combination of the above.

To enable an option, click its corresponding checkbox (it should
checked).

3 Click OK to save the settings and close the Switches dialog.

New Mail Notification options

Reading Your Mail
By default, mail is downloaded to your In Mailbox and designat
as new, unread, mail (identified with a bullet). Incoming messag
are saved indefinitely in the In Mailbox until they are deleted or
transferred to another mailbox.

Select an option by clicking the 
checkbox.
, E-Mail
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To open your In Mailbox:

1 Choose the In command from the Mailbox menu. The In Mailb
displays.

In Mailbox

 The Mailbox Size Button displays three numbers showing you 
following information:

• Number of messages in the mailbox.

• Total amount of space required for the messages.

• Disk space wasted in the mailbox. 

To recover wasted space, choose the Compact Mailboxes comm
from the Special menu.

2 To open a message, double-click on it, or press the Enter key w
the message is highlighted.

3 To close the message, either double-click the close box in the 
upper left hand corner of the message window or select the Clo
command from the File menu. The In Mailbox can be closed in 
same manner.

Incoming Mail Options
By default, Eudora downloads new mail messages to your hard 
and deletes the messages from the server. However, you can ch
this behavior as may be desired.
E-Mail, 7-21
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Keep a Copy on the Server
If you would like to keep a copy of your messages on the serve

1 Choose the Switches command from the Special menu. The 
Switches dialog displays (see page 7-38).

2 Enable the Leave Mail on Server option in the Checking option
by clicking on its check box (a checkmark displays in the box).

3 Click OK to close the dialog and apply the change.

This option can result in a significant buildup of messages and 
should be used with caution. If saving messages on the server
view your messages often, deleting those you do not need to s

Skip Big Messages
You can configure Eudora to download only the first few lines o
messages 40k or larger. This may be desirable if you are work
from a slow connection. 

1 Choose the Switches command from the Special menu. The 
Switches dialog displays (see page 7-38).

2 Enable the Skip Big Messages option in the Checking options 
clicking on its check box (a checkmark displays in the box).

3 Click OK to close the dialog and apply the change.

Incoming Mail options

Receiving Attachments
The most convenient method for receiving attachments is to as
a default directory for saving them. Otherwise, each time you re
ceive a message with an attachment, you are manually prompt
with a dialog to select the directory in which to save the attachm

To enable an option, click on 
the checkbox with the mouse.
, E-Mail
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To assign a default attachment directory:

1 Choose the Configuration command from the Special menu. T
Configuration dialog displays (see page 7-34).

2 Click the large button next to the Auto Receive Attachment Dir
tory. A dialog displays allowing you to select the directory to 
which incoming attachments will be saved. For procedures on n
igating files and directories, refer to your Windows User Guide.

3 After closing the Select dialog, the directory path name display
the button.

4 Click the Auto Receive Attachment Directory checkbox.

5 Click OK to apply the change.

Replying to a Message
To reply to a message, with the original message displayed or h
lighted in a mailbox:

1 Choose the Reply command from the Message menu, or click 
Reply button on the mailbox tool bar. You can send the reply to
everyone who received the original message by holding down 
Shift key when choosing the Reply command, or by clicking the
Reply All button on the mailbox tool bar.

A new message window displays with the original sender’s 
address automatically inserted in the To: field.

2 Type the reply message.

3 Send the message. 

Enable the option to automatically save 
attachments to the specified directory.

To select a directory, click this button.
E-Mail, 7-23
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Forwarding a Message
To forward a message, with the message displayed or highlighte
a mailbox:

1 Choose the Forward command from the Message menu, or cli
the Forward button on the mailbox tool bar.

A new message window displays containing the header and bo
of the original message.

2 Enter the To: field (to whom you want to forward the message)

3 Send the message.

Redirecting a Message
To redirect a message elsewhere, with the message displayed
highlighted in a mailbox:

1 Choose the Redirect command from the Message menu, or cl
the Redirect button on the mailbox tool bar.

A new message window displays containing the header and bo
of the message.

2 Enter the To: field for where you wish the message to be deliv
ered.

3 Send the message.

Printing Messages
To print a message from the Message window or with a messa
highlighted in a mailbox:

1 Choose the Print command from the File menu, or click the Pr
icon on the mailbox tool bar. A standard Windows Print dialog 
displays.

2 Choose the print options and click OK.
, E-Mail
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Deleting Messages
You delete messages as follows:

From the Message Window
To delete a message displayed in the Message window, choos
Delete command from the Message menu. The message is tra
ferred to the Trash Mailbox.

From a Mailbox
To delete a message from a mailbox, highlight the message an
choose the Delete command from the Message menu, or click 
Trash icon on the tool bar. The message is transferred to the T
Mailbox.

From the Trash Mailbox
To empty (and delete) messages transferred to the Trash Mailb
choose the Empty Trash from the Special menu. You can also 
figure Eudora to automatically empty the Trash Mailbox each time 
you exit the application by enabling the Empty Trash on Quit opt
on the Switches dialog (see page 7-38).

To delete a specific message from the Trash Mailbox (rather tha
of them), highlight the message and choose the Delete comma
from the Message menu, or click the Trash button on the tool b

Transferring Messages 
Messages may be transferred between any two mailboxes. 

To transfer a message:

1 Display the mailbox containing the message you want to trans
(select it from the Mailboxes menu).

2 Highlight the message you want to transfer.

3 Select the mailbox to which you want to transfer the message f
the Transfer menu. 
E-Mail, 7-25
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Copying a Message

To copy a message to another folder, rather than transfer it, ho
down the Shift key when selecting the Transfer command.

Creating and Using Nicknames
When sending messages, a nickname (which associates an ac
name with an e-mail address) can be used in place of the user
e-mail address. You may find this more meaningful than the ful
user e-mail address. Nicknames may be used in the To:, Cc:, a
Bcc: header fields.

To create a nickname:

• Choose the Nicknames command from the Windows menu. T
Nicknames window displays.

Nickname window

Creating a New Nickname

To create a new nickname:

1 Click the New button. The New Nickname dialog displays. 

2 Type the nickname you wish to use. 
, E-Mail
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3 If you want the name to display in the Quick Recipient list locat
in the Message menu (to allow for quick selection from the me
bar), click the check box. 

4 Click OK. 

5 Type the complete e-mail address of the person represented b
nickname in the Address(es) field.

6 Enter any notes about the association (such as company name
or telephone number) in the Notes text entry box.

7 Choose the Save command from the File menu.

Renaming a Nickname
To rename a nickname, from the Nicknames dialog:

1 Highlight the name in the Nickname field.

2 Click the Rename button. The Rename Nickname dialog displa

3 Type the new nickname. 

4 If you want this name to display in the Quick Recipient list locat
in the Message menu, click the check box. 

5 Click OK. 

6 Change the complete e-mail address of the person represente
the new nickname, as necessary, in the Address(es) field.

7 Choose the Save command from the File menu.

Deleting a Nickname
To remove a nickname, from the Nicknames dialog:

1 Highlight the name in the Nickname field.

2 Click the Remove button. 
E-Mail, 7-27
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Using the Nickname
You can insert and use a nickname in one of two ways:

1 From the Nicknames window, click the To:, Cc:, or Bcc: buttons
to begin a new message with the nickname inserted into the 
selected field.

2 From the Message window, with the cursor in the desired field 
(To:, Cc:, or Bcc:), select the Insert Recipient command from th
Edit menu. Select the desired nickname from the displayed list

You can also select and use a nickname when creating a new 
sage, replaying to, forwarding or redirecting a message (see “Quick 
Recipient List” on page 4-31 for more information).

Creating a New Mailbox
By default, Eudora contains two mailboxes: In Mailbox and Out
Mailbox. You can, however, create as many additional mailboxe
you like to better organize your e-mail.

To create a new mailbox:

1 Choose the New command from the Mailbox menu. The New 
Mailbox dialog displays.

New Mailbox dialog

2 Type a name for the mailbox using up to 8 characters.
, E-Mail
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3 Click OK. The new mailbox is added to the Mailbox and Transf
menus on the menu bar.

Creating Mail Folders to Store Mailboxes
To further define your e-mail organization, you can also create m
folders in which to store your mailboxes.

To create a new mail folder.

1 Choose the New command from the Mailbox menu. The New 
Mailbox dialog displays.

2 Type a name for the folder using up to 8 characters.

3 Click the Make it a Folder checkbox.

4 Click OK. The new mail folder is added to the bottom of the Ma
box and Transfer menus on the menu bar. Folders are designa
by an arrow next to the name. Click on the folder to displ
and select any correspondence contained in a mailbox,

Creating a Mailbox within a Mail Folder
To create a mailbox within a mail folder:

1 Select the mail folder from the Mailbox menu and choose New
The New Mailbox dialog displays (see page 7-28).

2 Create the new mailbox as described above. It is saved in the 
ignated mail folder.

Mailboxes Window
You may create, rename, delete or move mailboxes and mail fol
by choosing the Mailboxes command from the Window menu. T
Mailboxes dialog displays (see page 7-30).

Hard disk

Mail Folder

Mailbox

E-Mail
E-Mail, 7-29
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Mailboxes dialog

The Mailboxes dialog allows you to perform the following func-
tions by highlighting a mailbox mail folder or message, and clicki
the corresponding button. To display messages in a folder, dou
click the folder.

Button Action

Move Moves the item from one mailbox to anothe

Rename Displays the Re-name dialog. Type a new 
name and click Rename.

Remove Displays a remove confirmation message. T
remove the item, click Remove It.

New Displays the New Mailbox dialog allowing 
you to create a new mailbox or mail folder.
, E-Mail
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Quick Recipient List
The Quick Recipient List allows you to add nicknames or full e-m
addresses to key commands on the Message menu. You can t
choose to send a new message, reply to, forward or redirect a 
sage to an individual simply by selecting them from the appropri
menu command. When selected, a Message window displays w
the header portion of the message automatically filled in.

Each time you create a nickname, you have the option to add i
the Quick Recipient List.

To add a full e-mail address to the Quick Recipient List, with a m
sage window containing the address displayed, highlight the e-m
address and choose the Add as Recipient command from the Sp
menu (Alt S, A).

Removing an Entry
To remove an entry from your Quick Recipient List, choose the 
move Recipient command from the Special menu. Highlight the
try you wish to remove. When you release the mouse, the entry
removed from the list.

Finding Text within Messages
Eudora allows you to search for specific text within a single me
sage, multiple messages, or even multiple mailboxes. 

To search messages:

1 Choose the Find command from the Edit Menu. A sub-menu d
plays.

2 Choose Find. The Find dialog displays.
E-Mail, 7-31
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Find dialog

3 Type the text by which you wish to search.

4 Click Find. Eudora searches the current message for the spec
text. If located, the text is highlighted.

• To continue searching, click the Find or Next buttons. The Ne
button will search the current document first, then the next m
sage in the current mailbox.

• To begin a search with the message following the current me
sage, click the Next Message button.

• To begin a search with the next mailbox following the curren
mailbox, click the Next Mailbox button.

• You can specify that a search look for an exact capitalization
match or that Eudora search only the Sender and Subject fie
for a match by clicking the appropriate checkbox in the Find 
dialog.

Sorting Messages within Mailboxes
You can sort messages in your mailboxes by any of the followi
sort types:

• Status

• Priority

• Sender

• Date

• Subject
, E-Mail
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To specify a sort type:

1 Choose the Sort command from the Edit menu. A sub-director
displays.

2 Select a sort option.

By default, Eudora sorts in ascending order, the smallest item f
To sort in descending order, hold down the Shift key when selec
a sort order.

Eudora Configurations
The Configuration dialog is used to configure Eudora with key 
ternet provider information, such as your account number, nam
server ID and Host ID. This dialog is also used to control how m
sages display on screen and how they are printed. 

If you are using the Net Commander default provider through t
electronic registration, you do not have to do anything to config
Eudora. However, if you change providers, you must change th
configuration in order for the application to work. 

Regardless of your ISP, you may also wish to access this dialo
order to change screen and print specifications.

To display the Configuration dialog:

1 Choose the Configuration command from the Special menu. T
Configuration dialog displays (see page 7-34).
E-Mail, 7-33
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Configuration menu

Network Configuration

Each of the fields in the Network Configuration segment of the
Configuration dialog is described below. The default settings a
listed in brackets after the name of each field. 

Field Description

POP Account: 
[none]

Automatically set at 
installation; you only 
need to change the field 
if you change ISPs.

Enter your Host ID for the account, followed
by an “@” sign and the (domain) name of th
computer.

For example, if the login name for your ac-
count is “carolyn,” and the name of the com
puter is “uxh.cso.uiuc.edu,” type 
carolyn@uxh.cso.uiuc.edu in this field.
, E-Mail
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Field Description

Real Name: 
[none]

Automatically set at 
installation; you only 
need to change the field 
if you change ISPs.

Type your actual name. It is placed in paren-
theses after your return address in your ou
going mail. It is also displayed in the Sende
column of incoming message summaries.

SMTP Server: 
[none]

In order to send mail, a computer with an 
SMTP (Simple Mail Transfer Protocol) serv
er program is necessary. You need not have
login on this computer, but you must have a
cess to it through your network. If the com-
puter on which you have your account is als
an SMTP server, leave this field blank. Oth
erwise, specify the name of the computer 
which you want to use as the SMTP server

Return Address: 
[none]

Automatically set at 
installation; you only 
need to change the field 
if you change ISPs.

Normally, Eudora uses your Account as the
return address. If you wish to use a return a
dress other than your account, enter it here

Important: If you type an address in this 
field, test the address (by sending a messa
to yourself) to be sure that mail sent to it is in
deed delivered to you. If you use an invalid
return address, no one can reply to your ma

Check For Mail 
Every ? Minute(s) 
[0]

Enables Eudora to automatically check the
server for new mail at a specified interval an
transfer it to your hard disk. The number yo
enter specifies the number of minutes be-
tween checks of the server. The minimum 
recommended interval is 15 minutes. Chec
ing mail more frequently puts an unnecessa
drain on the server. 

Ph Server: 
[none]

Leave blank.
E-Mail, 7-35
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Message Configuration

The Message Configuration section of the Configuration dialog
lows you to configure how messages display on your screen. D
fault settings are listed in brackets after the name of each field.

Field Description

Message Width: 
[80]

Specifies the message windows width (in 
characters). The default value is 80. This se
ting has no effect on what your mail looks 
like when it is sent. When mail is sent, Eudo
ra wraps at or before 76 columns.

If you use a proportional font, Eudora sets th
window width based on the average width o
the characters in the font.

Message Lines: 
[20]

Specifies the message windows height (in 
lines). The default value is 20.

If the Zoom Windows option in the Switches
dialog is turned on, received message win-
dow heights are automatically adjusted to th
length of the message text. 

Tab Stop: 
[8]

Specifies the number of spaces between ta
stops.

Screen Font, Size: 
[Courier New]

Allows you to select a screen font for dis-
playing text on screen. 

Type the desired size (in points) of the font i
the Size field.
, E-Mail
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Changing Preferences 
You may customize many of Eudora’s options and commands,
cluding:

• Sending mail options

• Checking mail options

• Attachment options

• Notification options

To change system options:

1 Choose the Switches command from the Special menu. The 
Switches dialog displays (see page 7-38).

Field Description

Printer Font, Size: 
[Courier New]

Allows you to select a font for printed mes-
sages. 

Type the desired size (in points) of the font i
the Size field.

Auto Receive 
Attachment 
Directory: 
[off, none]

If checked, Eudora automatically places file
attachments that come with messages into
the specified directory. To change the set-
ting, click on the application name button 
(the default is blank). A dialog displays al-
lowing you to select the directory. 
E-Mail, 7-37
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Switches dialog

The Switches dialog is divided into seven option sections. A ch
in the checkbox next to the option indicates that the option is e
abled. Blank checkboxes indicate the option is disabled. Each o
options is described below. Default settings are listed in bracke

Composition Options
Many of the Composition options can be turned on and off for in
vidual messages by selecting the appropriate icon on the tool b
the top of the Message window. However, you can also specify
fault settings on this dialog and avoid having to make a tool bar
lection for each message you create. 

Field Description

Use Signature 
[on]

Eudora automatically attaches your signatu
file (if you have created one) to the end of 
outgoing messages.
, E-Mail
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Field Description

May Use QP 
[on]

Eudora uses quoted-printable encoding whe
necessary for long lines of text or special 
characters. If this option is off, quoted-print
able encoding is not used.

Word Wrap 
[on]

A carriage return is not required at the end o
each line of type in an outgoing message. E
dora automatically wraps text to the next 
line, with line breaks at roughly 76 character
per line. It is strongly recommended that yo
turn this option on.

Tabs in Body 
[on]

Pressing the Tab key inserts a tab (the num
ber of spaces in a tab is set in the Configur
tion dialog). If this option is off, hitting the 
Tab key returns the cursor to the To: field o
the message header.

Keep Copies 
[off]  

A copy of each message (which is sent) is 
kept in the Out Mailbox (their summaries are
marked with an “S” in the Status/Priority col
umn). If this option is off, Eudora moves out
going messages to the Trash Mailbox after
they are sent.

Reply to All 
[off]

Selecting Reply from the Message menu cr
ates a message addressed not only to the 
sender of the original message, but also to a
of its recipients. If the option is off, Reply ad
dresses the new message only to the send

You can use the Shift key to reverse this se
ting for any given reply. 
E-Mail, 7-39
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Send Attachments Options
The options in this section define the way attachments are sen

Field Description

Include Self 
[off]

When you do a reply all (as described abov
your e-mail address is left in the address lis
of the new message and you receive a copy
your own reply. If this option is off, your e-
mail address is removed from the reply me
sage.

To determine who you are, Eudora uses th
contents of the Account and Return Addres
fields from the Configuration dialog. If you 
have additional addresses, you can create 
“me” nickname using the Nicknames win-
dow (see page 7-26). Be sure to list all of the 
addresses and aliases you wish to use for 
yourself in the Address(es) field for the “me”
nickname. This gives Eudora a more com-
plete listing of who you are. It also ensures
that when you reply to messages sent to yo
at an address other than what is listed in th
Configuration dialog, the Include Self option
works correctly.

Field Description

Always as 
Attachment 
[off]

Text files attached to messages are sent a
separate documents and encoded using th
selected Encode With format. If this option is
off, text files are incorporated into the mes-
sage as part of the message body, (in a pla
text format). If this option is off and the at-
tachment is not a text file, it is sent as a se
arate document and encoded using the 
selected format.
, E-Mail
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Checking Options
These options determine the way Eudora checks for and receiv
mail.

Field Description

Encode With: 
[Bin Hex]

Specifies the format attached documents a
encoded with: MIME or Bin Hex. MIME is 
best for recipients with MIME and Bin Hex 
is most compatible with old Macintosh mail
ers and previous versions of Eudora.

Field Description

Save Password 
[off]

If Save Password is on, you never have to e
ter your password to check your mail (even 
you quit Eudora and restart it) because your 
password is stored on your PC. Only use th
option if your PC is in a secure place.

Leave Mail On 
Server 
[off]

Eudora normally transfers your incoming 
messages from your account on the server
your PC, and deletes it from the server. If 
Leave Mail On Server is on, Eudora transfer
incoming messages to your PC and also 
keeps copies on the server.

Skip Big 
Messages 
[off]

If Skip Big Messages is on, Eudora does no
download the entire text of very large mes-
sages from the server, but only the first few
lines. This can be useful when using a slow
connection.
E-Mail, 7-41
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide

7-42

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

. . .

 
r 

e-

 

 

i-

 
 

es-

r-
 in 
Sending Options
These options determine the way Eudora sends mail.

New Mail Notification Options
These options determine how Eudora responds to new mail.

Field Description

Send On Check 
[on]

Eudora automatically sends any messages
that are queued in the Out Mailbox wheneve
it checks the server for new mail. 

Immediate Send 
[on]

If Immediate Send is on, clicking the Send 
button sends the message to the server imm
diately. If the option is off, the button is la-
beled Queue and clicking on it places the 
message in the Out Mailbox marked ready
for delivery (Q).

Field Description

Alert 
[on]

If Alert is on, Eudora displays a dialog box to
notify you when new mail arrives.

Sound 
[on]

If Sound is on, Eudora issues a sound notif
cation when new mail arrives.

Open ‘In’ 
Mailbox 
[on]

Eudora automatically opens the In Mailbox
when new mail arrives. It also scrolls to the
end of the mailbox and selects the first un-
read message of the last unread batch of m
sages. If this option is off, Eudora doesn’t 
open the In Mailbox when new messages a
rive. It does, however, place the messages
the mailbox in the same order.
, E-Mail
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Switch Messages With Options

These options allow you to use the arrow keys to toggle throug
messages.

Miscellaneous Options
These options control miscellaneous Eudora functions.

Field Description

Plain Arrows: 
[off]

If Plain Arrows is on and there is a messag
window open on the screen, the arrow keys
can be used to close the current message a
open the next or previous message in the 
mailbox. The up or left arrow key opens the
previous message; the down or right arrow
key opens the next message. If this option 
off, the arrow keys can be used to move th
insertion point in messages.

Ctrl-Arrows: 
[on]

If Ctrl-Arrows is on, message switching us-
ing the arrow keys (as described above) is e
abled only when the Ctrl key is used in 
combination with the arrow key.

Field Description

Show All 
Headers 
[off]

If Show All Headers is on, Eudora displays
the complete header with the message. If th
option is off, Eudora does not display the 
message routing (Cc:, Bb:).
E-Mail, 7-43
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Field Description

Zoom Windows 
[off]

If Zoom Windows is on, new message win-
dows automatically open to their “zoomed”
size. The zoomed size can be different for 
each window. The zoomed size length is 
based on the length of the message (but n
longer than the main window), and as wide a
the Message Window Width setting in the 
Configuration dialog. When creating a mes
sage, the Message window zoom is based 
the height specified by the Message Lines 
setting in the Configuration dialog.

Easy Delete 
[off]

If Easy Delete is on, Eudora does not alert 
you when deleting messages that have not
been read or when transferring queued me
sages out of the Out Mailbox.

Mailbox 
Superclose 
[off]

If Mailbox Superclose is on, closing a mail-
box window closes all open messages from
that mailbox.

Empty Trash On 
Quit 
[on]

If Empty Trash On Quit is on, Eudora auto-
matically empties the Trash mailbox when-
ever you quit the application. If this option is
off, Eudora empties the Trash only when yo
select the Empty Trash command from the
Special menu.

If you want to remove some messages from
the trash but don’t want to empty all of them
highlight the summaries you want to delete
then choose the Delete command from the
Message menu. The selected messages a
deleted.

Easy Open 
[on]

If Easy Open is on, after deleting or transfe
ring an open message, the next message i
the mailbox is automatically opened, but 
only if that next message is unread.
, E-Mail
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Exiting the Application
To exit and quit the application, choose the Exit command from 
File menu. 

If you have queued messages, or timed messages due to be se
the next 12 hours, you are given the option to send them before 
ting. If the Empty Trash on Quit option in the Switches dialog is
turned on, quitting Eudora also empties your Trash mailbox.

Field Description

Show Progress 
[on]

If Show Progress is on, Eudora displays a 
Progress window at the top of your screen-
showing the progress made when making a
network connection, transferring mail or oth
er time consuming operations.

Auto-Ok 
[on]

Many network problems are temporary. 
When a problem occurs while Eudora is 
transferring or checking your mail, you are 
notified in the same way you would be if you
were receiving new mail. If Auto-Ok is on, 
these notifications automatically go away a
ter a couple of minutes. This allows Eudora
time to try the communication again. This 
setting is most useful if you have a non-zer
value for the Check for mail every ? 
minute(s) setting in the Configuration dialog
E-Mail, 7-45
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Overview
Subscribing to newsgroups could not be easier then with Net Co
mander’s News Xpress. This powerful newsreader allows you t
scan the thousands of UseNet newsgroups available on the Intern
on just about any topic imaginable. Using News Xpress, you ca
then join your favorite newsgroup to read an article, post a reply
an article, send an e-mail message to the author, or write and p
your own original article. 

When you install Net Commander, key information about your 
ternet account is passed to News Xpress and it is automatically
figured for you. You do not have to do anything in order to begi
using News Xpress — it’s ready to go!

This chapter will show you how to use News Xpress to navigate
exciting and ever-changing world of newsgroups.

What are Newsgroups?
Newsgroups are world-wide open forums where people discuss
bate, educate and entertain each other on topics of mutual inte
As you might imagine, there are about as many newsgroups on
Internet as there are individual interests. They range from the v
broad and popular (such as the latest blockbuster movies and h
line news), to the most specialized (how about recipes for marm
lade), to the inane (would you believe an “I hate Barney” 
newsgroup). There are scientific newsgroups, educational new
groups, entertainment newsgroups, computer newsgroups, and
many, many more.

Newsgroups amuse, inform, educate and challenge, but most o
they provide a never-ending supply of information on just about a
topic. If you’re looking for information, regardless of the topic, 
you’ll find it here.

UseNet (short for Users Network) is the method by which news
groups are distributed over the Internet.
Subscribing to Newsgroups, 8-3
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Interacting with a Newsgroup

You participate in a newsgroup by first joining, then writing and
submitting “articles” on the newsgroup’s focused topic. Articles c
be as short as a sentence or as long as a novel. Articles can be a
to another article, a new original article or a follow-up to a previo
ly written article. Articles can be read by anyone who belongs to
newsgroup. 

• Joining a newsgroup is known as “subscribing.”

• Displaying an article on your screen is known as “reading an
article.”

• Submitting an article is known as “posting an article.” 

Often, articles build on each other, like a never ending story. O
writer may ask a question which is answered by the next writer w
in turn, asks additional questions and so on down the line. The
tom line on Newgroups is that they are interactive computing at
best. 

Newsgroup Categories 
News articles that are posted on the UseNet system are classif
into newsgroup categories based on their subject matter and id
fied by a newsgroup name (for example alt.news-media is the name 
for the news-media newsgroup which posts news articles in the
ternative (alt) newsgroup category). 

Because of the wide-variety of newsgroups and the massive am
of articles that exist, you will have to make some choices over t
information you would like to sample. 

To help simplify this search, newsgroups are arranged by categ
(identified by the first portion of the newsgroup name). Howeve
even the categories of newgroups are about as volatile as a ne
group itself. New categories are added every day. And they can
appear just as fast. There are national categories, local catego
corporate categories, education categories, and on and on. Wit
some exploration, you will quickly discover those categories tha
terest you.
8-4, Subscribing to Newsgroups
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The following categories represent the principal (and more stab
newsgroup categories:

Starting News Xpress
To start News Xpress, double-click the News Xpress icon in the 
Commander program group, or folder. The News Xpress main w
dow displays (see page 8-7). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements (icon a
window samples are from Windows 3.1):

Category Description

alt Alternative. This newsgroup category is a 
compilation of everything that does not fit 
into another category (including the miscel-
laneous category!). 

biz Business related topics.

comp Computer related topics.

k12 Education (K-12th grade) related topics.

misc Miscellaneous. Like the alt group, this cate-
gory contains newsgroups that do not fit in 
other categories.

news UseNet news and information.

rec Recreation and hobbies.

sci Science related topics.

soc Social issues and topics.

talk Controversial subjects (politics, sex, reli-
gion, etc.).
Subscribing to Newsgroups, 8-5
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Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar in
upper left corner of the window. It contains the standard Windo
operations to Restore, Move, Size, Minimize, Maximize, and Clo
the window. For more information on using these commands, re
to your Windows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains all the commands which may be executed while work
with News Xpress.

Tool bar
Allows you to select key commands quickly by clicking the icon

Scroll Bar
Scroll bars may be displayed on the far right of the window sho
the viewable area not contain all the available information.

Status Bar
The status bar at the bottom of the window displays key informat
when working with newsgroups. For example, it will show you th
progress while scanning newsgroups, the number of articles co
tained in the group and what each command in the menu bar and
tool bar is used for.

Display area
Displays other windows and dialogs which are used to subscrib
read, and post articles.
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News Xpress main menu

Subscribing to a Newsgroup
Subscribing to a newsgroup simply means you select the newsg
you wish to join in order to read or post articles.

To subscribe to a newsgroup:

1 Choose the Connect command from the File menu to connect 
the UseNet server and load the available newsgroups.

Since there are thousands of newsgroups distributed by UseNet
will take a few moments. 

When all newsgroups have been loaded, they are displayed in 
News Xpress window (see page 8-8).

Minimize/Maximize 
buttonsControl menu

Display 
Window

Menu bar

Tool bar

Status bar
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Loaded Newsgroups

The newsgroups list displays all the available newsgroups to wh
you can subscribe on the UseNet server. To the left of each ne
group is a number showing you the current number of articles c
tained in the newsgroup. Next to it is a checkbox used to subsc
(checked) or unsubscribe (blank) to a newsgroup.

2 Scroll the list of newsgroups using the scroll bar, Filter box or F
dialog.

Filtering the List
The Filter box is a quick way to navigate the newsgroup list. 

To use the Filter box:

1 Type the first few letters or name of the newsgroup or topic yo
wish to find and the list is filtered to only those newsgroups con
taining the typed letters. 

For example, typing C will cause the list to display only those ne
groups containing the letter C. Type CD-ROM and the list displa
only those newsgroups continuing CD-ROM in their name. 

Use the scroll 
bar or Filter 
box to view (or 
locate) addi-
tional news-
groups.
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2 To re-display the entire list, delete the Filter entry (by highlightin
the entry and pressing the Delete key).

Finding a Newsgroup
You can find a newsgroup or any other text using the Find dialo

To find a newsgroup:

1 Click the Find icon on the tool bar or choose the Find comman
from the Edit menu. The Find dialog displays.

Find dialog

2 Type the text by which you want to search the list. If you want 
make the search case sensitive, click the Case Sensitive check

You may also select the following options by clicking the applic
ble radio button:

• Pause  — highlight and pause at the first entry containing the
entered text.

• Tag — tag all occurrences of the entered text. Matches are h
lighted and numbered at the right hand side of the window.

• Scope  — choose to search the entire list (All), from the curre
location Up or from the current location Down.

3 Click Find.

If no match can be made, a message displays. Try the Find fu
tion again using different search text.

4 Click the Find button to continue searching the list. 
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Subscribing to Newsgroups

When you locate a newsgroup you want to subscribe to:

1 Click the checkbox next its name, or highlight the newsgroup a
click the Subscribe icon on the tool bar, or choose the Subscrib
command from the Group menu.

You may subscribe to as many newsgroups as you like.

To unsubscribe to a newsgroup, click the checkbox again (it be
comes blank), or click the Unsubscribe icon on the tool bar, or 
choose the Unsubscribe command from the Group menu.

2 Click the Show All Groups On/Off icon or choose the All Group
command in the View menu to close the full newsgroup list and
display only those newsgroups to which you have subscribed.

To re-display the full newsgroup list, click the Show All Groups O
Off icon again, or choose the All Groups command again. Thes
commands toggle between the full newsgroup list and your sub
scribed newsgroup list.

Saving Newsgroups
You may want to save favorite newsgroups to your Newsgroup
folder in order to quickly locate them later. Each newsgroup yo
subscribe to and then save is automatically added to the Newsg
folder.

• To save a subscribed newsgroup(s), click the Save icon on th
tool bar, or choose the Save command from the File menu. 
Newsgroups to which you subscribe remain in this folder unti
you unsubscribe to the group.

Opening Saved Newsgroups
The Newsgroup folder containing your saved newsgroups is au
matically displayed on all future launchings of News Xpress. Ad
tionally, should you close the Newsgroup folder, you can re-ope
by choosing the Newsgroup command from the Folder menu.
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Subsequent Connections to UseNet
The initial connection to UseNet downloads the entire newsgro
list to News Xpress. When you exit the application, this list is sav
By default, the next time you open News Xpress, the full newsgro
list is displayed (if you have subscribed to a newsgroup and sa
it to your Newsgroup folder, it is displayed instead of the full lis
To view the full list, click the Show All Groups On/Off icon on th
tool bar).

You can disable 
this feature (to 
speed-up con-
nection time) in 
the Preferences 
dialog. Refer to 
page 8-27.

Set by default, on subsequent connections to UseNet, News Xp
scans the full newgroup list on your hard disk and the UseNet s
er. It then displays a dialog listing only those newsgroups which
have been added or updated (with new articles) to the UseNet se
since your last connection.

Subsequent Newsgroups dialog

• You may subscribe to the newsgroups listed in this dialog by
highlighting them and clicking the Subscribe button, or by clic
ing the checkbox next to its name. 

• To close the dialog and add the groups to the full newsgroup 
click OK.
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Listing and Viewing Articles
The number of articles contained in a newsgroup is indicated by
number to its left in the newsgroup list.

To display an articles list:

1 Double-click on the newsgroup for which you wish to view an 
article list.

The list of articles contained in the newsgroup displays in a new
ticle window.

Article List window

The Article List contains all the articles available to read for the 
lected newsgroup. Multiple articles on a particular topic are sto
in folders. The window displays the article name, number of by
(or in the case of folders, the number of articles in the folder), th
date and time the article was posted, and the author. 

When working with the Article List, you have the following op-
tions:

• Scroll the list using the scroll bar or the Find dialog (see page
8-9 for procedures).
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• To display articles contained in folders, click on the folder, or
click the Expand All Threads On/Off icon on the tool bar, or 
choose the Expand All Threads command from the View me

• To visually display articles posted in response to an article (a
their sequence), select the Indent Threads command from th
View menu.

• To close an expanded article list, click the Show All Articles O
Off icon on the tool bar, or select the All Articles command fro
the View menu.

Sorting Articles

By default, newsgroups are sorted by Group Name and articles
the Article List by Subject. You can change the sort of your artic
list at any time by selecting the Sort command from the View me
A sub-menu with the following sort options displays: 

• By Group Name (Newsgroup list only)

• By Subject

• By Author

• By Lines

• By Date

To change the sort, click on an option.

Finding an Article on a Server

You can search for an article on a news server by subject, usin
“from” statement or by keyword.

To find an article:

1 When connected to a news server, click the Find Article icon o
the tool bar or choose the Find Article command from the Artic
menu. The Find Article dialog displays (see page 8-14).
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Find Article dialog

2 Select the type of search you wish to make from the Header dr
down list. You may search by subject, use a “from” search or 
search by keyword.

3 Type the text by which you want to search in the Pattern field. 
you want to make the search case sensitive, click the Match 
Exactly checkbox. 

4 Select a destination folder in which to save the article(s) from t
Destination drop-down list.

5 Click OK.

If no match can be made, a message displays. Try the search 
tion again using different search text.

Reading Articles
News Xpress provides multiple ways for you to display and scr
the articles contained in an Articles List. By default, each opened
ticle is displayed in its own window.

To read an article:

1 Double-click on an article title in the Article List or click the Nex
Article button on the tool bar to display the first article (see pag
8-15).
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Article sample

2 To read another article in the newsgroup, click the Next Article
Next Unread Article button on the tool bar, or choose the Next 
Next Unread commands from the View menu.

When reading articles, the following options are available to yo

• Go to previous article — Click the Previous Article button to 
return to the previous article, or choose the Previous comma
from the View menu.

• Close the article — To close an article, choose the Close com
mand from its Control menu, or double-click the Control men
bar.

• Change the word wrap — Click the Word Wrap icon on the 
tool bar, or choose the Word Wrap command from the View 
menu to turn on/off the default word wrap as set in the Prefe
ences dialog (see page 8-27).
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• Change font — Click the Switch Font icon on the tool bar or 
choose the Switch Font command from the View menu to swi
the display font from your default font to Courier (see page 8-39 
for more information on setting a default font).

• Turn off/on article header — Choose the Full Headers com-
mand from the View menu, or click the Full Headers icon on t
tool bar to toggle off/on the article header information.

• Encode an article — Choose the ROT 13 command from the 
View menu to encode (decode) an article. 

• Copy text — Hold the left mouse down, drag the mouse over t
text you wish to copy and choose the Copy command from th
Edit menu. To select all the article text, choose the Select All
command. Copied text is placed in the clipboard and can be 
pasted into another application.

• Print an article — To print an article, click the Print icon on the
tool bar, or choose the Print command from the File menu. T
Print dialog displays allowing you to select your printer. Click
OK to print the article.

• Mark all articles as read — After reading articles, you can 
mark the entire newsgroup as read. To do so, with the Sub-
scribed Newsgroups list as the active window, click the Catch
Up icon on the tool bar, or choose the Catch Up command fr
the Group menu. This marks the articles as read, and change
number of articles in the newsgroup list to 0. 

• Mark individual articles as read — To mark an individual arti-
cle as read, with the article displayed in the active window, o
selected in the Article List, choose the Mark Read command 
the Article menu.

• Unmark read articles — To unmark a read article, with the 
article displayed in the active window, or selected in the Artic
List, choose the Mark Unread command from the Article men

• Update articles — To update a newsgroup’s list of articles, 
highlight the newsgroup and choose the Update command fr
the Group menu. Articles posted to UseNet since you connec
are updated and displayed in your Article List.
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• Check for new articles — To check for new articles in a news
group, highlight the newsgroup and choose the Check New A
cles command from the Group menu. New articles since you
last connection are displayed in a new Article List.

• Reload old articles — To reload all the articles to a newsgroup
choose the Reload Old Articles command from the Group me
A new Articles List displays containing all the newsgroups ar
cles, including the ones you have marked as “Read”.

• Delete an article — To delete an article, with the article dis-
played in the active window, or selected in the Article List, 
choose the Delete command from the Article menu. A confirm
tion dialog displays. Click Yes to delete the article.

• Kill/AutoSelect patterns for a selected group — To set or edit 
kill/autoselect pattern information for a selected group, highlig
the group in the Article List and choose the Kill/Autoselect co
mand from the Group menu. The Kill/Autoselect dialog dis-
plays. Enter the appropriate information and click Close.

• Stopping an operation — To stop an operation in progress, 
click the Stop icon on the tool bar, or choose the Stop comm
from the File menu.

Saving an Article

You may save articles as a text (with a .TXT extension) file (whi
may then be opened and displayed in any application that supp
the .TXT format), or to folders in News Xpress.

To save an article as a .TXT file:

1 With the article in the active window, click the Save icon on the
tool bar, or choose the Save or Save As command from the Fil
menu. The Save Articles dialog displays. This dialog is identica
a standard Windows Save As dialog.

2 Enter a name for the article in the File Name text box. Be sure
use a .TXT extension with the article name. For more informati
on navigating files and directories, refer to your Windows User 
Guide.

3 Click OK to save the article.
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To save an article to a News Xpress folder:

1 With the article in the active window, choose the Transfer men
This menu displays any folders you have created and one titled
New.

2 To save an article to a previously created folder (see page 8-38 for 
more information on creating folders), click the folder name in t
Transfer menu.

The article closes from the screen and is transferred to the sele
folder.

3 To transfer the article to a new folder, choose the New comma
The Prompt dialog displays.

Prompt dialog

4 Type a name for the folder and click OK.

The article closes from the screen and is transferred into the ne
folder, which is now listed in the Transfer and Folder menus.

Opening an Article from a Folder
To open an article you have transferred to a folder:

1 Click the desired folder name in the Folder menu.

The Folder List displays (see page8-19).
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Folder List

2 To open an article contained in the folder, double-click on the a
cle, or click the Next Article button on the tool bar.

Sending a Reply
News Xpress allows you to send a reply to the author of a poste
ticle. To send a reply, the article must be displayed in the active w
dow or highlighted in the Article List.

To send a reply to an author:

1 Click the Reply icon on the tool bar, or choose the Reply com-
mand from the Article menu. The Reply window displays.

Reply window
Subscribing to Newsgroups, 8-19
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The Reply window automatically inserts the Subject and To fiel
The cursor is located in the CC field.

2 If you want to CC your reply, enter the complete e-mail addres
for the applicable person(s).

3 If you want to attach a document(s) to your reply, click the Atta
ments text box, or choose the Attach command from the File 
menu. The Attachments dialog displays.

Attachments dialog

• Type the complete path to the document you wish to attach in
Filename text box or click the button to the far right of the fiel
to display an Open dialog. This is a standard Windows Open 
log used to select a file. For information on navigating files an
directories, refer to your Windows User Guide.

• Select the document you wish to attach to the reply and click
OK. The full path statement is inserted into the Filename text
box.

• Select the options you wish to apply to the attachment by clic
ing the appropriate checkbox. You have the option of:

• Sending the attachment as a separate article.

• Cutting the article text off after a specified number of 
characters.

• Adding a boundary to the attachment.
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• If you wish to encode the attachment, select the encoding op
from the Encoding drop-down list.

• Click the Add button. The file is added to the Attachment list 
box. To remove an attachment, click the Delete button.

• Click OK. The file is added to the Attachment text box. 

• Repeat this procedure for each document you want to attach

For more information on attaching documents, refer to Chapter 4, 
E-Mail.

4 The original article is included in the reply text box. You can us
the Cut, Copy, Paste and Undo commands from the Edit menu
when working in the Reply window. To scroll to the end of the 
original article, use the Scroll bar or the Tab key.

5 Type your reply.

6 If you wish to include a .TXT file in the reply, place the cursor a
the position you want the file to begin and choose the Include 
command from the File menu. A standard Windows Open dialo
displays allowing you to select the .TXT file you want to include
For information on navigating files and directories, refer to you
Windows User Guide.

7 After selecting the .TXT file, click OK to close the Open dialog 
and paste the .TXT file into the reply document at the cursor lo
tion.

8 To send the reply, click the Send icon on the tool bar or choose
Send command from the File menu. A confirmation message d
plays. 

9 Click Yes to send the reply.

A copy of a posted reply is automatically saved to your Outbox
folder until moved to another folder or deleted.

Sending a Follow-up to an Article
A follow-up is an addition or response you write and post to an
ticle originally posted by yourself or another author. To create a 
low-up, the article must be displayed in the active window, or 
selected on the Article List.
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To create and send a follow-up:

1 Click the Follow-up button on the tool bar, or choose the Follow
up command from the Article menu.

The Follow-up window displays.

Follow-up window

The Follow-up window automatically inserts the Subject and To
fields. The cursor is located in the TO field.

2 If you wish to address the follow-up to a particular person, ente
the complete e-mail in the TO field.

3 If you want to attach a document(s) to your follow-up, click the
Attachments text box, or choose the Attach command from the
File menu. The Attachments dialog displays (see page 8-20 for 
procedures on attaching a document).

4 The original article is included in the follow-up text box. You ca
use the Cut, Copy, Paste and Undo commands from the Edit m
when working in the Follow-up window. To scroll to the end of th
original article, use the Scroll bar or the Tab key.

5 Type your follow-up text.
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6 If you wish to include a .TXT file in the follow-up, place the cur
sor at the position you want the file to begin and choose the 
Include command from the File menu. A standard Windows Op
dialog displays allowing you to select the .TXT file you want to
include. For information on navigating files and directories, refe
to your Windows User Guide.

7 After selecting the .TXT file, click OK to close the Open dialog 
and paste the .TXT file into the reply document at the cursor lo
tion.

8 To send the follow-up, click the Send icon on the tool bar or 
choose the Send command from the File menu. A confirmation
message displays. 

9 Click Yes to send the follow-up.

To cancel the posting of the follow-up, choose the Cancel Post c
mand from the Article menu.

A copy of a posted follow-up is automatically saved to your Outb
folder until moved to another folder or deleted.

Posting an Article
After subscribing to a newsgroup, you can post your own article
which can then be read by anyone who subscribes to the newsg

To post an article:

1 Highlight the newsgroup in your Subscribed Newsgroup List fo
which you wish to post an article.

2 Click the Post icon on the tool bar or choose the Post comman
from the Article menu. The Post window displays (see page 8-24).
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

e.

-
 

 

om-
s-
or 
n-

e 
ge 
Post window

3 Enter the Subject of your article.

4 Enter any Keywords by which readers can search for the articl

5 Type a brief Summary of the article.

6 If you want to attach a document to the article, click the Attach
ments text box to display the Attachment dialog. Refer to page8-
20 for procedures on attaching a document.

7 Type your article. You can use the Cut, Copy, Paste, and Undo
commands from the Edit menu when creating your article.

8 If you wish to include a .TXT file in the article, place the cursor at 
the position you want the file to begin and choose the Include c
mand from the File menu. A standard Windows Open dialog di
plays allowing you to select the .TXT file you want to include. F
information on navigating files and directories, refer to your Wi
dows User Guide.

9 After selecting the .TXT file, click OK to close the Open dialog 
and paste the .TXT file into the Article at the cursor location.

10 To post the article, click the Send icon on the tool bar or choos
the Send command from the File menu. A confirmation messa
displays. 

11 Click Yes to post the article.
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To cancel the posting, choose the Cancel Post command from 
Article menu.

12 To save your article to your Outbox folder (and display a blank
Post window), click the Save icon on the tool bar or choose the
Save or Save As command from the File menu. 

A copy of a posted article is automatically saved to your Outbo
folder until moved to another folder or deleted.

Send E-Mail
News Xpress includes a fully functional e-mail application whic
can be used when working in the newsreader.

To send an e-mail message:

1 Click the Mail icon on the tool bar, or choose the Mail/Forward
command from the Article menu. A Mail window displays.

Mail window

2 Type the Subject of the message.

3 Enter the full e-mail address for the person you are sending th
message.
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4 If you wish to send a copy of the message to other individuals,
enter their e-mail address in the CC field.

5 If you want to attach a document(s) to the message, click the 
Attachments text box, or choose the Attach command from the
File menu. The Attachments dialog displays (see page 8-20 for 
procedures on attaching a document).

6 Type the message text. You can use the Cut, Copy, Paste and
Undo commands from the Edit menu when working in the Mail
window. 

7 If you wish to include a .TXT file in the message, place the cur
at the position you want the file to begin and choose the Includ
command from the File menu. A standard Windows Open dialo
displays allowing you to select the .TXT file you want to include
For information on navigating files and directories, refer to you
Windows User Guide.

8 After selecting the .TXT file, click OK to close the Open dialog 
and paste the .TXT file into the message at the cursor location

9 To send the message, click the Send icon on the tool bar or ch
the Send command from the File menu. A confirmation messa
displays. 

10 Click Yes to send the message.

A copy of your outgoing e-mail is automatically saved to your O
box folder until moved to another folder or deleted.

For more information on using e-mail, refer to Chapter 4, E-Mail.

Decoded Files 
Binary files must be encoded into text files before they may be p
ed or sent via e-mail in News Xpress. Additionally, large article
over 64k must be broken into 64k sections in order to be transmi
over UseNet. News Xpress automatically does this for you, for b
posting or downloading files. With News Xpress, not only are fil
automatically converted to the applicable format, but they are e
coded and restored to their original format once the transfer is c
plete.
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You can open a decoded file by choosing the Decode comman
from the Article menu. A standard Windows Open dialog displa
Select the desired .UUE file and click OK.

Changing Preferences
News Xpress is preconfigured with the most common preferenc
settings. You can, however, change these preferences at any tim
better suit your own working style.

To view or change system settings:

1 Choose the Preferences command from the Config menu. The
Preferences dialog displays.

Preferences dialog

2 A series of tabs along the top of the dialog allow you to change
preferences for Groups, Articles, Compose, Headers and Misc
neous settings. To select an option category, click the mouse o
the desired tab.
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You may change the following fields:

Groups Tab

Field Description

On Connect Specifies whether News Xpress should re-
trieve all the active newsgroups, only new 
groups (since your last connection), or no 
groups from the news server each time a co
nection is established.

Connect at 
Startup

If enabled, News Xpress automatically con
nects to your news server when it is launche
from Program Manager (without using the 
Connect command).

Prompt for New 
Groups

If enabled, News Xpress prompts you and 
gives you the option to subscribe to new 
groups found after connecting to the news 
server.

Update 
Subscribed 
Groups Every nn 
Mins

If enabled, News Xpress retrieves subscribe
newgroups information after a connection i
established. You can also specify how ofte
News Xpress should update the subscribed
groups in a session. If a group is opened, a
new articles are downloaded. You can ente
0 to disable this feature.

Hide Groups 
without Articles

Check this option if you don't want groups 
with a 0 unread article count to be displaye
in the newsgroups window.

New Window for 
Each Group

If enabled, you can browse more than one 
group at the same time.
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Articles Options
To set options for article display, click the Articles tab at the top
the window.

Field Description

Articles Sorted 
by

This specifies the option for sorting articles
Select Subject, Author, Lines or Date from 
the drop-down list.

Threaded by News Xpress can thread articles by Subjec
and References. It will try to thread as muc
as possible if both options are checked.

Max Hdrs Per 
Read

This specifies the maximum range of heade
information per read. For examples, if you 
specify this number as 20, and there are 50
articles available, News Xpress breaks up th
request into 1-20, 21-40, and 41-50, allowin
you to stop the transfer in the middle of a
header transfer. If you specify this as 0 or 1
News Xpress sends the request 1-50 at on

You will notice a significant speed degrada
tion if you make this number too small. If you
don't bother to stop the headers transfer or
you have a higher network bandwidth, mak
ing this number 0 will give you better perfor
mance.

Date Time 
Format

This is the format specification for date and
time displayed in threads windows. The for
mat string consists of directives and ordinar
characters. 

A directive consists of the % character fol-
lowed by a character. Possible directives in
clude:

%a Abbreviation weekday name
%A Full weekday name
%b Abbreviation month name
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Field Description

Date Time 
Format
(continued)

%B Full month name
%c Date and time
%d 2 digits day of month (01-31)
%H 2 digits hour (00-23)
%I 2 digits hour (01-12)
%j 3 digits day of year (001-366)
%m 2 digits month (01-12)
%M 2 digits minute (00-59)
p AM or PM
%S 2 digits second (00-59)
%U 2 digits week number (00-52), Sun

day is first day of week
%w Weekday (0-6), Sunday is 0
%%W 2 digit week number (00-52), Mon-

day is first day of week
%x Date
%X Time
%y 2 digits year (00-99)
%Y Year with century

Skip Old Articles Specifies whether News Xpress should re-
trieve all or the minimum header information
from the news server. If enabled, News 
Xpress retrieves header information for un-
read articles only.

Suppress “Re:” If enabled, “Re:” prefix in any subject heade
is not displayed in threads windows.

New Window for 
Each Article

If enabled, News Xpress opens a new win-
dow for each article.

Show Grid Lines If enabled, grid lines display on the main 
window.

Display Hdrs Specifies which headers should or should n
be displayed. If Except is checked, headers
which are not in the list are displayed. The 
delimiter used to separate headers is a com
ma.
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Compose Options
To set reply, forward and composition options, click the Compo
tab at the top of the window. You have the following options:

Field Description

Max Include 
Lines

Specifies the maximum lines of an original 
article to be quoted in a follow-up or reply. 
Default is 50 lines.

Include Prefix This is a string used for quoting original arti
cles. The maximum length is 10, including 
the prefix.

Include Headers
of Original

Specifies whether or not to quote the heade
of an original article in a follow-up or reply.

Prompt for 
Including 
Original 

If enabled, News Xpress prompts you to 
quote an original article or not.

Word Wrap, Max 
Chars per Line

If enabled, word wrap is applied by default.
The message editor wraps lines based on t
window size. If the width of the window is 
larger than the specified value in the Max 
Chars per Line, News Xpress wraps lines a
this specific position.

Generate 
Message ID

If enabled, News Xpress generates and in-
serts a Message-ID header into your poste
articles. Leaving this option disabled is 
recommended, unless your news server re
quires one.

CC by Mail If enabled, copies are automatically send to
CC: entries.

Copy Self If enabled, you automatically are copied on
all outgoing correspondence. Copies are 
stored in your Copy Self folder, selected 
from the Folder menu.

Confirm on Post 
and Send Mail

If enabled, News Xpress prompts you for a
confirmation before posting or sending mai
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Header Options
To set header options, click the Headers tab at the top of the w
dow. You have the following options:

Field Description

Post Headers 
Template

News Xpress allows you to define your own
headers for composing articles by editing th
headers template. You can also enter a de
fault contents in the template. For example

Newsgroups:
Followup-To: poster
Subject:
Distribution: world

Multiple line headers are not supported. Fo
example:

Summary: Summary line 1
Summary line 2
   ...

You MUST complete the Newsgroups and 
Subject fields in the post headers template
and the To and Subject fields in the mail 
headers template. News Xpress does not a
tomatically add any missing field. 

To enter a new item, click the mouse at the
end of the list and type the desired entry. T
delete an item, highlight the item (or double
click on it) and press the Delete key. To rese
the group to its default settings, click the Re
set button.

Mail Headers
Template

Defines mail header categories. Use the sam
procedures as described above.
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Miscellaneous Options
To set miscellaneous options, click the Miscellaneous tab at th
top of the window. You have the following options:

3 After setting options, click OK to save and apply the changes.

News Xpress  Setup
News Xpress is automatically configured for you when you inst
Net Commander. If, however, you should change Internet prov
ers, you will need to change the setup configuration in order to 
News Xpress. 

Field Description

Subject 
Template

Specifies the default subject template for a
tachments. The template consists of direc-
tives and ordinary characters. A directive 
consists of the % character followed by a 
character. Possible directives include:

%s Original subject
%f Filename
%p Current part
%t Total parts

Cut Size Specifies the default multiparts split size.

Directory Default directory for decoded files.

Prompt for 
Directory

If enabled, News Xpress prompts you befor
decoding selected articles.

Execute after 
Decoded

If enabled, News Xpress attempts to execu
the decoded files immediately after selectio

Applications To change the location of your FTP, WWW 
(Enhanced Mosaic) and Gopher application
(automatically entered during installation), 
click the button next to the field to display a
standard Windows Open dialog. Locate the
application and click OK to insert its path 
name into the applications field.
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Additionally, the Setup dialog allows you to attach a signature t
your e-mail or setup a username and password to prevent unau
rized use of News Xpress.

To display the Setup dialog:

1 Choose the Setup command from the Config menu. The Setup
log displays.

Setup dialog

2 The following fields are contained on the Setup dialog:

Field Description

NNTP Server A fully qualified Internet hostname or an IP
address of a NNTP news server. You must
have access to a news server in order to ru
News Xpress. This field is automatically con-
figured for you if you are using the default 
ISP.
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Field Description

NNTP Port 
Number

Specifies the protocol port number which 
News Xpress uses to contact the news serv
News Xpress will use the default port num-
ber if you enter 0. The most common port r
served for NNTP is 119. 

This field is automatically configured for you
if you are using the default ISP.

SMTP Server A fully qualified Internet hostname or an IP
address of a SMTP mail relay. You can leav
this blank if you are going to use another ma
client (such as Eudora). 

This field is automatically configured for you
if you are using the default ISP.

SMTP Port 
Number

Specifies the protocol port number which 
News Xpress can use to contact your mail 
server. News Xpress will use the default po
number if you enter 0. The most common 
port reserved for SMTP is 25. 

This field is automatically configured for you
if you are using the default ISP.

Fullname Your name is used to construct headers on 
ticles and e-mail. 

This field is automatically configured for you
if you are using the default ISP.

E-Mail This information is used to construct heade
on articles and e-mail. 

This field is automatically configured for you
if you are using the default ISP.

Organization Used to construct headers on articles and e
mails. 
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Field Description

Signature File If you wish to use a default signature on you
outgoing e-mail, click the button next to this
filed and select the .TXT file containing your
signature. You create the signature in any a
plication that can be saved in the .TXT for-
mat. You can use a maximum of 20 lines in 
signature. For more information on creating 
signature, see page 8-14.

Username and 
Password 

Some news servers restrict access to part 
all of their services to an authenticated use
only, (e.g. protected groups access and post-
ing articles). If you are an authorized user, 
you can enter the assigned username and 
password in these fields to gain access to 
these services. Otherwise, you should leav
these fields empty. News Xpress encrypts 
your password and saves it in the profile.

Home Directory Specifies the home directory for News 
Xpress to keep NEWSRC, a log file, and va
ious temporary files. 

This field is automatically configured for you
if you are using the default ISP.

News RC File Specifies the name of your newsrc file. If you
don't specify the pathname, News Xpress 
will create it in the home directory. 

This field is automatically configured for you
if you are using the default ISP.
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3 After making changes on the Setup dialog, click OK.

Field Description

Time Zone Specifies the time zone information for New
Xpress to generate GMT date and time 
stamps for outgoing messages. The format 
the time zone string is shown as follows.

zzz[+/-]d[d][lll]

zzz Three-character string repre-
senting the name of the curren
time zone. All three characters
are required.

[+/-]d[d ] Required field containing an 
optionally signed number with 
1 or more digits. This number is
the local time zone's difference
from GMT in hours.

- Positive number adjust west-
ward from GMT.

- Negative number adjust east-
ward from GMT.

This number is used in the cal-
culation of timezones.

lll Optional three-character field 
that represents the local time 
zone's daylight saving time.

- If this field is present, daylight is 
set to non-zero.

- If this field is absent, daylight is 
set to 0.

If the time zone string isn't in the specified 
form, News Xpress presumes the default 
EST5EDT.
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Managing Folders
While you can create folders as you need them from the Trans
menu (see page 8-18), you can also create them, delete them and
name them by choosing the Folders command from the Config
menu.

You can create as many newsgroup folders as desired.

To manage your newsgroup folders:

1 Choose the Folders command from the Config menu. The Fold
dialog displays.

Folders dialog

2 To create a new folder, click Add. The Prompt dialog displays.

Prompt dialog

3  Type the folder name and click OK. 

The folder is created and listed in the Folder dialog. 
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When you exit this dialog, the new folder displays in the Transf
and Folders menu.

Deleting a Folder

To delete a folder, highlight the folder you want to delete and cl
Delete. The folder (and any articles contained in the folder) is de
ed.

Renaming a Folder

To rename a folder, highlight the folder and click Rename. The
Prompt dialog displays with the name of the folder highlighted. 
Press the Delete key, type a new name for the folder and click 

The folder is renamed.

Changing the Default Font
You can specify the font you want to use in each type of window
described below:

To change a font:

1 Choose the Fonts command from the Config menu. A sub-men
displays allowing you to select the font you wish to change.

2 Select the font you want to change. A Font dialog displays (se
page 8-40).

Lists Font Newsgroups and threads font.

Article Font Article font.

Edit Font Message editor font.

Status Bar Font Font used to display status information in th
status bar.

Printer Font Font used when printing articles.
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3 Select the desired font, font style and size.

4 Click OK. The selected font attributes are applied immediately

Disconnecting from UseNet
To disconnect from UseNet, choose the Disconnect command f
the File menu.

Exiting News Xpress
To exit and close News Xpress, choose the Exit command from
File menu.

Select a font, 
style and size.
8-40, Subscribing to Newsgroups

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Chapter 9
Joining a Chat Group



Chapter Contents
Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-3

Starting IRC. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-3

Tool Bar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-6

Changing Your Nickname. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-8

Changing IRC Servers. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-9

Basic IRC Procedures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-10

Connecting to an IRC Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-10
Listing Available Chat Groups. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-10
Joining a Chat Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-10
Entering the Conversation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-11
Starting a Private Chat Group. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-11

Disconnecting from the IRC Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-12
9-2, Joining a Chat Group
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Overview
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

. 
s 
e 

orld 
any 
o the 
rank 
a 

al-
do 
the 

ro-
cts 
tion 

 
ize 

 

Overview
Net Commander’s IRC (Internet Relay Chat) application allows 
you to communicate with other Internet users around the world
With IRC, you can join up to 5 concurrent electronic chat group
(called channels) or set up your own private chat group for thos
times when you want to control who has access to the session.

What makes IRC popular among users is that it is accessible w
wide from any site that is connected to the Internet. This allows 
computer user, regardless of the ISP they are using, to connect t
IRC server and be able to communicate. The discussions are f
and uncensored. In most instances, they are free-form without 
central group monitor.

Like other Net Commander client applications, IRC is automatic
ly configured when you install Net Commander. All you have to 
is start the application, change your nickname, and connect to 
IRC server and you’re ready to go “on-line”.

Starting IRC
To start IRC, double-click the IRC icon in the Net Commander p
gram group, or folder. The stack and dialog automatically conne
you to the Internet and to the default IRC server. Once a connec
is made, the IRC main window displays (see page 9-5). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements (icons
and screen samples are from Windows 3.1):
Joining a Chat Group, 9-3
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Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar in
upper left corner of the window. It contains the standard Windo
operations to Restore, Move, Size, Minimize, Maximize, and Clo
the window. For more information on using these commands, re
to your Windows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains connection, server and client commands.

Tool bar
Manage your on-line sessions by clicking appropriate icons on 
tool bar.

Scroll Bar
Scroll bars may be displayed on the far right of the window sho
the viewable area not contain all the available information.

Status Bar
The status bar at the bottom of the window displays key informat
about menu bar commands, tool bar commands, connections s
and so on.

Display area
Displays other windows and dialogs which are used when joinin
chat group.
9-4, Joining a Chat Group
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A new Message 
window is 
opened for each 
chat group you 
join.

Message window
This area displays connection information, command informatio
and once in a chat group, the dialog from the group. Pay close a
tion to the messages sent to you by the Server. In many cases, 
messages can help you in executing commands and troublesho
problems. 

The identity of who is communicating is shown to the left of the
text. For example <SERVER> indicates a message from the ser
When you send text, your nickname will display to the left of yo
text <YOUR NICKNAME>. 

You can maximize the message window by clicking its Maximiz
button. 

Text Entry box
Enter you conversation text in the text entry box.

IRC main menu

Minimize/Maximize 
buttons

Control menu

Display 
Window

Menu bar

Tool bar

Status bar

Message 
Window

Text Entry box
Joining a Chat Group, 9-5
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Tool Bar
You manage your on-line conversations using the icons located
the tool bar. These icons allow you to perform the following fun
tions:

Connect to Server  — Connects you to the IRC server specifie
in the Server Setup dialog. 

While you are automatically connected to the IRC server when y
initially launch the program, should you disconnect during a ses
sion, this icon can be used to re-connect. You can also select t
Connect command from the File menu.

Disconnect from Server  — Disconnects you from the IRC serv
er. You can also select the Disconnect command from the File 
menu.

Server Options Setup  — Displays the Setup Options dialog al
lowing you to change your IRC server or nickname. Additionally
should you change your ISP, you must change your user name
mail address and PC name address in this dialog. For more info
tion refer to “Changing Your Nickname” on page 9-8 and “Chang-
ing IRC Servers” on page 9-9. This dialog can also be displayed b
selecting the Server command from the Options menu.

Help  — Displays the available on-line help. You can also displa
the on-line help by choosing the Contents command from the H
menu.

Reset/Cascade/Tile Windows  — These icons allow you to 
manage your window display area. If you open more than one c
group, you can arrange your windows to cascade, tile or reset t
to their original position. These commands may also be selecte
from the Window menu.

Set/Reset Away Message — Displays a dialog allowing you to
type a message and change your on-line status to “AWAY”. Thi
often used when you remain connected to a session, but are no
rently participating. After entering the message, click OK. It is im
mediately transmitted and displayed in the message area.
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Join a Channel  — Displays a dialog allowing you to join a chan
nel (chat group) by entering its name and clicking OK. If you ha
the available channels listed in the message area, you can join
by double-clicking on the desired channel. For more informatio
see “Joining a Chat Group” on page 9-10.

List Channels  — Displays all the available channels (chat 
groups) for this IRC server on the right side of the message are
You can also type “LIST” in the text box to display the list.

Get WHOIS Information for a Nickname  — Displays a dialog 
allowing you to locate a person on an IRC server. Enter the nic
name of the person you are looking for and click OK. If IRC locat
the nickname, it displays the person’s E-mail address and the c
rent server they are logged into.

Send Private Message to Nickname  — If you want to send a 
private message that can be read only by the specified individu
click this icon. A dialog displays allowing you to type the person
nickname. Click OK, type the message in the text message area
press Enter.

Describe to Nickname  — Allows you to send your E-mail ad-
dress to another person. Type your nickname in the displayed di
and click OK. 

Ignore Nickname  — Allows you to ignore (and not display text
from) a nickname in the chat group. Enter the nickname you wi
to ignore in the displayed dialog and click OK.

Send CTCP Query to Nickname  — Displays a dialog allowing 
you to send a CTCP query to another person. Type the nicknam
the person, the CTCP query and click OK.

Start a DCC Chat with a Nickname  — Displays a dialog allow-
ing you to specify a nickname with whom you want to start a priv
chat session. Type the nickname and click OK. A new window d
plays in which the private chat will take place. For more informa
tion, refer to “Starting a Private Chat Group” on page 9-11.
Joining a Chat Group, 9-7
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

-
ame 

 

-

OK.

me 

he 

he 

hat 

et 
 ap-
-
ss 
-

 the 
ons 
Start a DCC Send with a Nickname  — Displays a dialog al-
lowing you to send a file to another IRC member. Type the nick
name of the person you want to send the file, then the full path n
of where the file is located (for example, C:\TCPPRO\IRC\RE-
ADME.TXT) and click OK. The file is displayed in a new window
on the receiver’s screen.

Action in Channel  — Displays a dialog allowing you to enter ac
tion text. After entering the text, click OK.

Set Mode for Channel/Nickname  — Displays a dialog allow-
ing you to change your current mode. Enter the mode and click 

Invite Nickname to Channel  — Displays a dialog allowing you 
to invite a person to join a private chat session. Type the nickna
of the person you want to invite to the session and click OK.

Kick Nickname from Channel  — Displays a dialog allowing 
you to remove a person from your private chat session. Enter t
nickname of the person you want to remove and click OK.

Ban Nickname from Channel  — Displays a dialog allowing 
you to ban a person from joining a private chat session. Enter t
nickname and click OK.

Unban Nickname from Channel  — Displays a dialog allowing 
you to unban a nickname you previously banned from a private c
session. Enter the nickname and click OK.

Changing Your Nickname
When you install Net Commander, information about your Intern
account is automatically passed to IRC in order to configure the
plication for use. The default setting Net Commander applies in
cludes an IRC Server and a Nickname. When you initially acce
IRC, you should check the Setup Options and change your nick
name as may be desired.

To change your nickname:

1 Choose the Server commands from the Options menu, or click
Server Setup Options icon on the tool bar. The IRC Setup Opti
dialog displays (see page 9-9).
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IRC Setup Options dialog

2 Type a new nickname using up to 9 characters and click OK. T
new nickname is effective on your next connection.

You can also change your nickname from the text entry box at 
time by typing /NICK newname where newname is the new nick-
name you wish to use. After typing the new nickname, press En

Changing IRC Servers
You can add up to 18 IRC servers to the IRC Server list in the I
Setup Options screen. For suggestions on IRC server sites, ref
the IRC Server topic in the on-line help.

To add and select a new IRC server:

1 Choose the Server commands from the Options menu, or click
Server Setup Options icon on the tool bar. The IRC Setup Opti
dialog displays.

2 Type the server name in the IRC Server field. It is automaticall
added to the Server drop-down list.

Change IRC Servers or 
change your NickName.
Joining a Chat Group, 9-9
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3 To select a server, click the arrow next to the IRC Server field 
display the drop-down list of available servers.

4 Highlight the server you wish to access and release the mouse

5 Click OK. The change becomes effective on your next connect

Basic IRC Procedures
The following represent the primary procedures you need to kn
in order to navigate within an IRC chat group. Be sure to pay at
tion to the messages that display in the message area. They ca
of great assistance in troubleshooting problems, changing mod
and other key system diagnostics.

Connecting to an IRC Server
Each time you start IRC, you are automatically connected to the
fault IRC server (if you change servers, it becomes the default)
Should you disconnect from a session and wish to re-join, choo
the Connect command from the File menu, or click the Connec
Server icon on the tool bar.

Listing Available Chat Groups
To list the available chat groups on the server, type LIST in the t
entry box and press Enter, or click the List Available Channels ic
on the tool bar. Available groups are listed to the right of the m
sage area.

Joining a Chat Group
You can join a chat group using any of the following methods:

• Type JOIN #chat, where chat is the name of the group (for 
example JOIN #AFRICA) in the text entry box and press Ente

• Double-click the mouse on the group.

• Click the Join a Channel icon on the toolbar, type the group 
name (#AFRICA) and click OK. 
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After joining a group, a Channel dialog displays.

Channel dialog

Entering the Conversation

To join the conversation, simply type a line of text in the text en
box and press Enter. When first joining a group, it is common co
tesy to introduce yourself and say “Hello”. 

From this point on, feel free to join the conversion and use any
the icons on the tool bar to manage your chat session.

Starting a Private Chat Group

You can create a private chat session allowing only invited gue
to join in the group.

To start a private chat group:

1 Click the Start a Chat Session icon on the toolbar. A DCC Cha
dialog displays (see page 9-12).

Messages and 
conversation 
text.

People currently 
in the group.

Text Entry box.
Joining a Chat Group, 9-11
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DCC Chat dialog

2 Type your nickname and click OK. A DCC Channel dialog dis-
plays (which is identical to any other Channel dialog).

3 Click the Invite Nickname to Channel icon on the tool bar. Type 
the nickname of the person you want to invite to the session an
click OK.

4 Repeat step 3 for each person you want to join the private group.

Disconnecting from the IRC Server
To disconnect from the server, choose the Disconnect comman
from the File menu, or click the Disconnect icon on the tool bar

Disconnecting from the IRC Server does not disconnect you fro
the Internet. If you want to quit this Internet session, be sure to
choose the Bye command from the Dialer menu in the Trumpe
Winsock window, or choose Close from the Control menu (Win
dows 3.1). In Windows 95, click Disconnect in the Connected to
dialog.
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Overview
The FTP (File Transfer Protocol) application lets you transfer fil
— documents, photographs, even software — from an Internet
computer to your hard disk, or if you have the proper access rig
from your hard disk to a host computer.

Using FTP
To start FTP, double-click the FTP icon in the Net Commander p
gram group, or folder. The FTP main window and FTP Site Man
er dialog displays. You manage your FTP sites on the Site Mana
dialog, including making an initial site selection (see page 10-5).

The FTP main window is similar to any other Windows applicatio
in that you can re-size it, move it on your desktop, minimize it o
maximize it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements (icon a
screen samples are from Windows 3.1):

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. For more information on using these comman
refer to your Windows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains the FTP commands which may be selected and appli
Working with FTP Files, 10-3
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Tool bar
Allows you to quickly select key commands by clicking the app
cable icon. To see what each icon will do when selected, move
mouse slowly over the icon.

Status bar
Displays system and operation information such as the number
files and bytes being copied and the number of seconds it take
copy a file. It also displays the current connection status and th
connected Host address.

FTP main menu

FTP Site Manager
When first launched, the FTP Site Manager is displayed over th
main menu. This dialog is used to manage your sites, including

• Add, delete or rename folders

• Import FTP sites

• Add, delete and edit site information

• Connect to an FTP site

Minimize/Maximize 
buttons

Menu bar

Control menu

Tool bar

Status bar

View, copy, 
rename, and delete 
files in the System 
boxes.

Displays the directories and 
files on the remote (Host)
system.

Displays your local system 
(hard disk) directories and 
files.
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FTP Site Manager

The FTP Site Manager contains a number of default FTP sites. 
can use the Site Manager to add others as you work with FTP.

• Click on an FTP site folder on the left hand side of the screen
display the sites contained in the folder on the right hand side
the screen.

• Highlight a site to review a brief description of it at the right bo
tom of the screen.

Managing Site Folders

You can manage site folders as follows:

Add a folder  — Click the Add folder button. Type the new folde
name in the displayed dialog and click OK. The folder is added
the FTP Sites directory.

Delete a folder  — To delete a folder, highlight the folder and 
click the Delete folder button. Click Yes on the displayed confirm
tion message. 
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Rename a folder  — To rename a folder, highlight the folder an
click the Rename folder button. Type the new name in the displa
dialog and click OK.

Importing Saved FTP Sites
If you have saved FTP sites (on your hard disk or floppy), you m
import them into the Site Manager dialog as follows:

1 Click the Import button. A standard Windows File Open dialog 
displays.

2 Locate and highlight the FTP file (saved FTP site files use a .D
extension). For information on navigating files and directories, 
refer to your Windows User’s Guide.

3 Click OK. The sites are added to the Site Manager.

Managing FTP Sites
The FTP Site Manager allows you to easily manage FTP sites. 
can add sites, delete sites or edit site information.

Adding a Site
Before you can connect to an FTP site, you need to define the 
so the FTP application knows where to go when the site is sele

To define an FTP site:

1 Click the Add site button. The FTP Site Edit dialog displays (se
page 10-7).
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FTP Site Edit dialog

2 Enter the following information for the FTP site.

Field Description

Site Label Enter a name for the site as you wish it to di
play on the Site Manager list.

Host Address Enter the full IP address of the FTP site.

User ID If you have an account ID with the host, enter
it; otherwise, enter ANONYMOUS.

Password If you have a password with the FTP host, e
ter it; otherwise enter your e-mail address.

Login type In most all cases, you will want to use the d
fault login type ANONYMOUS. For infor-
mation on other options, refer to the on-line
help topic for the Site Edit dialog.

Transfer type In most cases, you will want to use the de-
fault Auto-Detect which allows FTP to trans
fer files with .TXT extensions as ASCII files.
For all other files, Image mode is used.
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Field Description

Initial Remote 
Directory

If you want to go immediately to a specific 
directory when you connect to this FTP site
enter the directory’s full path name. Other-
wise, leave this field blank and it will auto-
matically be completed with the host’s 
default directory after you login.

Initial Local 
Directory

Enter the full path name for the directory 
where you wish downloaded files to be 
stored. If you leave this field blank, the de-
fault download directory from the Options 
dialog is used.

Port Leave the entered 21.

Delay If you want to specify a delay before FTP re
tries to make a connection should the site b
busy, enter the number of seconds.

Retry Enter the number of connect retries you wan
FTP to attempt.

Max Safe Index
Size

Enter the size (in kilobytes) for the largest 
file to load without first displaying a prompt.
The default is 10kb.

Logical Parent 
Dirs

Default is YES. Specifies whether or not you
want FTP to regard the parent directory to th
previously visited directory instead of a 
physical parent when changing to a linked d
rectory.

Auto-Load Index
Files

Default is YES. Specifies if index files 
should be automatically loaded along with 
directory listings when you change to a new
directory.

Use firewall Default is YES. Allows you to specify the 
use of security firewalls.

Resolve Links Default is YES. Allows FTP to automatically
resolve links between sites.
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3 Click OK to save the site information and display it in the Site 
Manager window.

Delete a Site
To delete a site, highlight the site and click the Delete site butto
Click Yes on the displayed confirmation message.

Edit a Site
To edit a sites information, click the Edit site button. The FTP S
Edit dialog displays with the sites current information. Edit the i
formation as desired and click OK to save the information.

Connecting to an FTP Site
You can connect to an FTP site from the Site Manager or from 
FTP main window. Connecting from the Site Manager is the quic
est method for connecting to an FTP site.

To connect to an FTP site from the Site Manager:

1 Highlight the site to which you want to connect.

2 Click the Connect button. 

The Site Manager dialog closes, the FTP main window display
and the connection is made to the selected FTP site.

To connect to an FTP site from the FTP main window:

1 Choose the Quick Connect command from the FTP menu, or c
the Quick Connect icon on the toolbar. A blank FTP Site Edit d
log displays. 

2 Enter the Host Address, Login Type, Transfer Type and any ot
desired field.

3 Click OK. 

Information is not saved when connecting to an FTP site using 
method. If you wish to save FTP site information (to access it ag

Field Description

Comments Enter a description of the FTP site to displa
on the Site Manager description window.
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Manager.

To display the Site Manager dialog from the main window, choo
the Site Manager command from the FTP menu or click the Sit
Manager icon on the toolbar.

Directory Icons 

The directory icons in both the Local System and Remote Syst
are used to display key information about the files:

• Double-click a directory icon to obtain the contents of the dire
tory from the remote host.

• To close a directory, double-click it.

Viewing Files

It is good practice when working on FTP sites to view the RE-
ADME and or INDEX files to get a better understanding of wha
files are contained at this site and their size. By default, Window
Notepad is used to view text files. 

• To view a text file, double-click it, or highlight the file and 
choose the View command from the FTP menu, or click the 
View icon on the tool bar.

If you want to use a different application for viewing files:

1 Choose the Options command from the FTP menu. The Option
dialog displays. 
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2 Enter the name of the application (the .EXE name) in the Text 
Files Viewer field. To select the application, click the question 
mark icon next to the field. A standard Windows File Open dial
displays. Highlight the desired application and click OK. For 
information on navigating files and directories, refer to your Wi
dows User’s Guide.

3 Click OK.

Copying Files
You can copy a single file or multiple files from the remote host
your local drive or from the local drive to the host (if you have p
mission to upload files).

Host to Local Copy
To copy files from the remote host to your local hard drive:

1 Highlight the files you want to copy in the Remote System area
Hold down the Shift key when selecting files. If selecting a dire
tory, you do not need to highlight everything contained in the 
directory. All files and sub-directories will automatically be dow
loaded.

2 Choose the Download command from the Commands menu o
click the Download button on the tool bar. The files are copied 
the default download directory on your local hard disk.

To download a single file, simply double-click it.

Local to Host Upload
If you have permission to upload files to an FTP site, you can u
the following procedure to upload a file.

1 Select the remote directory where you want to copy the file (th
destination directory) by clicking and highlighting it in the Remo
System area. 

2 Highlight the file you want to copy in the Local System area. T
copy multiple files, hold down the Shift key when selecting files

3 Choose the Upload command from the Commands menu, or c
the Upload button on the tool bar. The file is copied to the desi
nated directory on the host computer.
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Drag and Drop Copy
You can use drag and drop to copy (download or upload) a file
follows:

1 Click and hold the mouse on the file you want to copy. To copy
multiple files, hold down the Shift key when selecting them. To
copy a directory with its sub-directories, simply highlight the 
folder.

2 Drag the file to the destination directory and release the mouse

3 A confirmation message displays. Click OK.

Renaming a File
You can rename a file in the Local System and, if you have perm
sion, the Remote System area.

To rename a file:

1 Highlight the file you wish to rename.

2 Choose the Rename command from the Commands menu, or 
the Rename icon on the tool bar. The File Rename dialog disp

File Rename dialog

3 Type the new filename and click OK.

The file is renamed.
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Deleting a File or Directory

You can delete a file or directory in the Local System and, if yo
have permission, the Remote System area.

To delete a file or directory:

1 Highlight the file or directory you want to delete.

2 Choose the Delete command from the Commands menu, or cl
the Delete icon on the tool bar. 

3 Click Yes on the displayed confirmation message.

The file or directory is deleted.

Finding a File

You can find a file using the Find dialog.

To find a file:

1 Click the mouse in the Local System or Remote System area 
(where you are looking for a file).

2 Choose the Find command from the Directory menu. The Find
dialog displays.

Find dialog

3 Type the text by which you want to search the list.

4 Click OK.

The Find dialog closes and FTP searches the list and highlights
first entry containing the entered text. If no match can be made
message displays. Try the Find function again using different 
search text.

5 Choose the Find Next command in the Directory menu to contin
searching the list.
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Additional FTP Options

While working with the FTP application, you have the following
options:

Stop an FTP Operation — To stop an FTP operation in progress
choose the Stop command from the FTP menu, or click the Sto
icon on the toolbar. Use this option with caution, as stopping so
operations may result in an error.

Create a Directory  — To create a directory on your local hard 
drive (or if you have permission, on the host drive):

1 Click the system area (local or remote) where you want to crea
the directory.

2 Choose the Make New Directory command from the Command
menu, or click the Make New Directory icon on the tool bar. Th
Make Directory dialog displays.

3 Enter a name for the new directory the displayed dialog.

4 Click OK.

Change Transfer Mode — To change the transfer mode for a fil
(ASCII, Binary or Auto), highlight the file you are going to transfe
then choose the Transfer Type command from the FTP menu. 
sub-menu displays allowing you to select the desired transfer pr
col. You can also click the desired transfer mode on the tool ba

Refresh the Screen  — To refresh the screen and update files a
directories in the selected system area, choose the Refresh co
mand in the View menu, or click the Refresh icon on the tool ba

Display Details  — To display the details of files and directories
choose the Long Details command in the View menu. A 4 displa
beside the option when enabled. 

Change Main Window Display — To change the main window
display (how the Local System and Remote System areas are d
played on your screen), use the commands in the Window men

Log Messages to File — To save all FTP messages to a log file
choose the Options command from the FTP menu. Type the fil
name using a .LOG extension in the Log File text box. To select
other log file as the default file, click the question mark icon next
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the field. A standard Windows File Open dialog displays. Select 
file and click OK.

Change Default Options — To change FTP options for such 
items as the download default directory, log file, display fonts a
colors, choose the Options command from the FTP menu.

Execute a File — To execute a software application in an FTP
site, choose the Execute command from the Commands menu o
lect the Execute icon on the toolbar.

Change Sorting Criteria — To change the sorting options, 
choose the Sorting command from the Commands menu, then s
a sorting option from the sub-menu, or select a sorting option fr
the toolbar.

Disconnecting from the FTP Site
To disconnect from the FTP site, choose the Disconnect comm
from the FTP menu, or click the Disconnect icon on the toolbar

Exiting the Application
To exit the FTP application, choose the Exit command from the
FTP menu. 

Disconnecting and exiting the FTP application does not disconn
you from the Internet unless it is the last application to exit. If y
wish to end your current Internet session, choose the Bye comm
from the Dialer menu in the Trumpet Winsock window (Window
3.1). In Windows 95, click Disconnect in the Connected to... dial
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Overview
Telnet allows you to connect to other Internet computers and access 
the services, commands, and programs found on the host syst
For example, you could use Telnet to access an Archie computer 
and then execute Archie commands (see Chapter 9, Archie), or you 
could search a university’s library catalog, or you could even ru
executable programs— on any Telnet site in the world (mostly 
UNIX). 

Telnet can emulate terminals that support ANSI, VT52, VT102, a
VT220 protocols. Additionally, international character sets are fu
supported. In most cases, you will need a special login ID provid
by the Telnet host in order to gain access.

Using Telnet
To start Telnet, double-click the Telnet icon in the Net Comman
program group, or folder. The Telnet main window displays (se
page 11-4). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. For more information on using these comman
refer to your Windows User Guide.

Minimize button
Click this button to minimize the window.
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Maximize button
Click this button to maximize the window.

Menu bar
Contains the Telnet commands which may be selected and app

Scroll bars
If there is more information than can be displayed in the viewab
area, use the scroll bars to view more.

Terminal screen area
Displays all interactions with a host.

Telnet main menu

Minimize/Maximize 
buttons

Menu bar

Control menu

Scroll bars
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Connecting to a Host Computer
To connect to a host computer:

1 Choose the Connect command from the menu bar. The Telnet
Connect dialog displays.

Telnet Connect dialog

2 Enter a host name or IP address for the system you want to co
nect to. You can enter the system name, if you know it, such a
CC.OWU.EDU. Alternatively, you can enter the IP address num
ber, if you know it, such as 123.456.78.9.

Note
If the IP address requires a particular port setting, enter it as sh
in the following example: 123.456.78.9:8008. In this example, 
“8008” is the port setting. Note that it is preceded by a colon.

3 Click OK.

The stack and dialer application launches and makes the conne
to the specified host. 

Telnet Options
You can use the following options while working in a Telnet ses
sion:

Setup Your Printer  — To turn the printer on (or off) select the 
Printer On/Off command in the Special menu. 

Cut text to the Clipboard  — To cut text from the main window 
to the clipboard, highlight the text and choose the Cut comman
from the Edit menu. 
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Copy text to the Clipboard  — To copy text to the clipboard, 
highlight the text you wish to copy and choose the Copy comma
from the Edit menu. 

Paste Text — To paste text contained in the Clipboard, place the 
cursor in the main window where you wish to place the text and
choose the Paste command from the Edit menu.

Change Display Font — To change the font and font size of th
display text, choose the Font command from the Special menu
Font dialog displays. Select the font and font size, then click OK

Change Background — To change the background to light (or
dark), select the Light/Dark Background command from the Spe
menu.

Exiting Telnet
To exit and close the Telnet application, choose the Exit comm
from the File menu. This command disconnects you from the h
system and closes the application.

Disconnecting and exiting the Telnet application does not disco
nect you from the Internet. If you wish to end your current Intern
session, choose the Bye command in the Dialer menu in the Tr
pet Winsock window (Windows 3.1). In Windows 95, click Disco
nect in the Connected to... dialog.
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Overview
Archie is one of the principal Internet file search tools. With Arch
you can search the Internet for public domain text files, graphic
files or sound files which can then be downloaded to your local h
disk. 

There are approximately 40 Archie database servers around th
world containing a list of Internet files available for you to acces
This list is continuously updated. Acting like a giant index or libra
card catalog, you search an Archie server for a particular file, a
then Archie tells you where it is stored out on the Internet. Actu
files are stored on Archie computers (which are FTP sites).

There are two methods for searching Archie servers: using the a
al file name or a keyword, in which case, Archie displays all file
which match the specified characteristics of the keyword. Once
file is located, Archie displays the key information about the file
(filename, directory, size, and date the file was last updated).

You can retrieve a file using the FTP (file transfer protocol) app
cation (which is automatically linked to Archie). 

Using Archie
To start Archie, double-click the Archie icon in the Net Command
program group, or folder. The Archie main window displays (se
page 12-5). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.
Archie, 12-3
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Control menu
The control menu is accessed by clicking the control menu bar in
upper left corner of the window. It contains the standard Windo
operations to Restore, Move, Size, Minimize, Maximize, and Clo
the window. 

For more information on using these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains the Host menu with all Archie’s available commands.

Status bar
Displays key information about the current search including the
time that the Archie server thinks it will take to process a search,
queue position when the search is received, and the number of p
ets (of data) received.
12-4, Archie
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Archie main window

Locating a File

To locate a file on an Archie server: 

1 Enter the complete file name or a keyword in the Search for te
box.

Keywords
A keyword can be used to search for a file rather than a comple
file name. Archie scans each of its servers and then displays e
file it locates which contains the keyword. Obviously, this could 
sult in a very long list, so you may want to consider using keywo
that are fairly specific. For example, if you are a history buff, ent
ing “History” may display a very long list, but using “Civil War” or
“Gettysburg” will result in a more narrow search. You can also n
row the search by specifying a search type (see Step 4).

Minimize/Maximize 
buttons

Menu bar

Displays host computers 
that have a file matching 
your search.

Displays directories 
on a selected host 
containing a file 
matching your 
search.

Displays actual files 
and their names.

Control menu

File information

Status bar

Search criteria
Archie, 12-5
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2 Select an Archie server from the drop-down list. To improve pe
formance, select an Archie server that is geographically close. Y
may want to set this server as your default server (see page 12-11 
for procedures).

3 If you want to restrict the search to a particular Archie site, ent
the match domain criteria. For example, if you wish to restrict a
search to academic sites in the UK, enter “.ac.uk”.

4 If you are making a search using a keyword, select the type of
search you want Archie to perform. You can select from the fol
lowing options:

Option Description

Substring The most common search type. Archie look
for any file name that contains the keyword
Upper/lowercase letters are ignored.

Substring (case 
sensitive)

Same as above except the search looks fo
case match in the keyword.

Exact The fastest search method. The restriction 
that the keyword has to match exactly (in-
cluding its case). Use this search type if yo
know exactly what you are looking for.

Regex Regular expression search. This method a
lows you to look for several keywords and to
narrow the search using special characters
For example, placing a ^ at the beginning o
the keyword narrows the search to only thos
files that has the keyword at the beginning o
the file name.

For more information on using a Regex 
search, refer to the Search Type topic in the 
on-line help.

Exact first If selected, an exact search method is used
first. If no matches are found, then the meth
od selected using the radio buttons are use
This box is disabled if the exact search met
od is chosen above.
12-6, Archie
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Changing the search type after the search is performed will ha
no effect on the displayed list of matches.

5 Click the Search button. The stack and dialer application is 
launched and a connection made to the Internet. To stop a sea
in process, click the Abort button.

Depending on your search criteria, it may take some time as Arc
scans its database servers.

If you are unable to connect to Archie, try again later. Because
the limited number of Archie sites and the high volume of traffic
trying to access these popular servers, you may find the connectio
periodically busy. 

Additionally, unlike most Internet operations, Archie servers are
only available certain times of the day. If you can’t get through t
desired server, you might try selecting a different server. If a ser
is slow or down in one part of the world, it may be open in anoth

Search Results
The results of the search are displayed in the Hosts, Directories
Files list boxes.

The Hosts list box displays the host computers which contain file
or directories matching the search item. When you highlight a h
in the list box, the Directories and Files list boxes are appropriat
updated.

The Directories list box displays a list of directories for the selecte
(highlighted) Host which contains a file that matches the search
item. Selecting a new directory appropriately updates the Files
box.

The Files list box displays a list of files for the selected Directorie
that match the search time.

The file’s details are displayed in the File details boxes. Each ti
you select a different Host, Directory or File, these details are u
dated for the currently selected file. The displayed file’s details 
clude:
Archie, 12-7
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

di-
e 

ions 

 
log 

s 
Downloading a File
Files download from Archie are by default saved to the current 
rectory. If you wish to specify a different directory in which to sav
downloaded files, choose the FTP Setup command from the Opt
menu and enter the Directory field (see page 12-10) for more infor-
mation.

To download a file:

1 Double-click on the file name in the Files list box or choose the
Retrieve command from the File menu. The FTP Command dia
displays.

FTP Command dialog

2 Click OK. The file is retrieved using the Net Commander FTP 
application and saved to the specified directory.

File Name Full name of the file.

Size Size of the file in bytes.

Mode Access mode of the file.

Date Files original date stamp.

Archie Date Date the Archie server last checked the file
existence.

Host Address The Internet address of the host computer 
where the file resides.

c:\netcmdr\cuteftp.exe/CPSR/historical_docs/gettysburg_address
12-8, Archie
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Archie Options
While working with Archie, you can use the following commands:

Save the results of a search  — choose the Save command 
from the File menu. A standard Windows Save dialog displays. 
ter a name using a .TXT extension in the File Name text box an
click OK. For information on navigating files and directories, ref
to your Windows User Guide.

Expand a directory  — double-click the directory name in the D
rectories list box or choose the Expand command from the File
menu to expand a selected directory.

Copy search results to clipboard  — choose the Copy Results
command from the Edit menu. 

Copy file name to clipboard  — highlight the file name you 
wish to copy in the Files list box and choose the Copy File com
mand from the Edit menu. 

Copy directory to clipboard  — highlight the directory you 
wish to copy in the Directories list box and choose the Copy Dir
tory command from the Edit menu.

Copy host to clipboard  — highlight the host name you wish to
copy in the Hosts list box and choose the Copy Host command f
the Edit menu. 

Changing Defaults
You can change the default Archie server and the keyword sea
type by choosing the User Preferences command from the Opt
menu. The User Preferences dialog displays (see page 12-10).
Archie, 12-9
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User Preferences dialog

1 To select a default Archie server, click the arrow next to the 
Default Archie Server field and select one of the available serv
from the drop-down list.

2 Click a desired default keyword search type.

3 Click OK to apply the changes.

Do not change the User ID default.

FTP Setup
Files downloaded from an Archie computer use the FTP. When 
install Net Commander, it is automatically configured for you an
is ready to use the first time you use Archie. If, however, you ne
to re-configure FTP, or want to change the directory where dow
loaded files are saved, you may do so as follows:

1 Choose the FTP Setup command from the Options menu. The 
Setup dialog displays (see page 12-11).
12-10, Archie
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FTP Setup dialog

2 Enter the following fields:

Field Description

Command Enter the full path name for your FTP pro-
gram. The following special characters are
substituted for the path name the first time a
FTP request is made.

%h the host name
%d the directory name
%f the file name
%u the user name field as entered in the 

user name field
%p the password field as entered in the 

password field

User Name Do not change.

Password Do not change.

Directory Enter the directory name to which you wan
downloaded files saved. The default directo
ry is the current directory.
Archie, 12-11
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Exiting the Application
To exit and close Archie, choose the Exit command from the Fi
menu. 
12-12, Archie
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Overview
Gopher is another Internet system that allows you to search an
trieve files and documents (like Archie, see Chapter 9). Gopher al-
lows you to access text files, graphic files, sound files, even video 
files. 

There are currently more than 1600 Gopher servers on the Inte
One reason for Gopher’s popularity is its ease of use. Gopher m
it very easy to locate Internet documents by utilizing a series of
screen menus (similar to a table of contents). When you find a 
or document you want to view in the main window, simply doub
click on it. 

In most cases, Gopher sites reference other Gopher sites mea
that once you connect to one site, you’ll be able to navigate ma
many more. In Internet lingo, this is known as being in “Gopher
space”.

Using Gopher
To start Gopher, double-click the Gopher icon in the Net Com-
mander program group. The Gopher main window displays (se
page 13-4). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 
Gopher, 13-3
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For more information on using these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains the Gopher commands which may be selected and ap

Scroll bars
If there is more information than can be displayed in the viewab
area, use the scroll bars to view more.

Status bar
Displays key connection and system information.

Gopher main menu

Minimize/Maximize 
buttons

Menu bar

Control menu

Status bar
13-4, Gopher
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Connecting to Gopher
You can manually connect to a Gopher site, or configure it to a
matically connect you to a favorite site each time you start Gop
(see page 13-12). This section shows you how to manually conne
to a site.

To manually connect to a Gopher site:

1 Choose the New Gopher command from the file menu. The Ne
Gopher dialog displays.

New Gopher dialog

2 Enter the server name (the English name) in the top Server tex
box (optional).

3 Enter the server IP address in the lower Server text box. When
first access this dialog, the default server (as defined in the Con
uration dialog, see page 13-12) is automatically entered.

4 Leave the server port number setting at 70.

5 Click Connect.

The stack and dialer launches and connects you to the specified
pher site. After retrieving the data from the site, the Gopher site
displays the main window (see page 13-6).
Gopher, 13-5
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Gopher Display main window

The icons displayed in the Gopher main display indicate the typ
item which may be accessed when you double-click on it. This in-
cludes the following:

To open a folder 
or view a docu-
ment, double-
click on it. 

To view an items 
attributes, dou-
ble-click the spy-
glass.

Icon Description

File. Most files are displayed in an ASCII 
format (.TXT) and displayed in Windows 
Notepad.

Folder. A folder contains documents or othe
folders. To open a folder, double-click it.

Link to another Gopher server. Double-click
this folder to display other Gopher servers 
you can access.

Indexed search pointer. Search for docu-
ments or files on the server.
13-6, Gopher
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Icon Description

CSO Phone Book pointer. Display informa-
tion about individuals at the site (faculty, 
staff, students, employees, etc.).

Telnet pointer. Launch a Telnet session 
based on settings in the Configuration dialo
(see page 13-12).

IBM pointer. Launch a TN3270 Telnet ses-
sion based on settings in the Configuration
dialog (see page 13-12).

BINHEX file. Text file encoded in BINHEX 
format. Gopher cannot decode these files, b
you can save them and move them to a Ma
intosh, as desired.

UUENCODED file. Text file encoded in the
UUENCODED format (usually a UNIX 
item).

DOSBINARY file. DOS document.

BINARY file. These files cannot be dis-
played on your screen (usually they are ex
cutable programs), and must be captured 
directly to file.

Graphic image. You can display graphic file
based on your settings in the Configuration
dialog (see page 13-12).
Gopher, 13-7
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For more information on using Gopher icons to display documen
refer to the on-line help.

Viewing Items

To open a folder or display a document, double click on the fold
or document icon, or highlight the item and choose the View Ite
command from the File menu.

The item is displayed using the application assigned in the Con
uration dialog (refer to page 13-12). For example, text files are, by
default, displayed using Windows Notepad.

Binary items cannot be displayed on your screen. To display a b
ry image, sound or video file, double-click it. The item is downloa
ed and temporarily saved. When you exit Gopher, the binary file
automatically displayed using the assigned viewer. 

Attributes

To display an items attributes — IP address, creation date and a
able alternative views — double-click the spyglass next to the ite
or highlight the item and choose the Attribute Info command fro
the file menu. 

The Attribute dialog displays (see page 13-9).

Icon Description

Sound file. You can sample sound files base
on your settings in the Configuration dialog
(see page 13-12).

Video file. You can sample video files based
on your settings in the Configuration dialog
(see page 13-12).
13-8, Gopher
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Attribute dialog

Alternate Views

Some items may have more than one available views. You can
check by selecting the Attribute dialog for the item as discusse
above.

To display an alternative view, highlight the item in the main wi
dow and choose the Alternate View command from the File me
A Select Alternate View dialog displays (see page 13-10).

The Attribute dialog shows 
you information about an 
item including its address, 
available alternate views, 
and in some cases, an 
abstract.
Gopher, 13-9
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Select Alternate View dialog

• Highlight the desired view and click Retrieve View.

• To close the dialog without displaying the view, click OK or 
Cancel.

Displaying the Description Box

The Description Box is a floating dialog that shows you the deta
of an item when selected in the Gopher menu including its file ty
host name, host port and selector string. This information may 
useful to create bookmarks or add to your Gopher servers.

To display the Description Box, click the Descriptor Box comma
in the Options menu. A 4 displays beside the option when enable

Description Box dialog
13-10, Gopher
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Navigating a Gopher Server

You can move from document to document or site to site by cli
ing the icons contained in the menu. You can also connect to s
and display documents by clicking a bookmark in the BookMar
menu or the BookMark List (see page 13-15 for more information 
on Bookmarks). Gopher also adds each site you visit during the cur-
rent session to the Recent menu. To connect to one of these sites, 
simply choose the Recent menu, then click on the site (or docu
ment).

To return to the previous site, choose the Previous Site comma
from the Recent menu or click the arrow in the status bar.

Saving a Document
To save a displayed document, choose the Save As command 
the File menu, or double-click the right mouse button. A standard 
Windows Save As dialog displays.

1 Select the directory where you wish to save the file.

2 Enter a file name in the File Name text box (use an appropriat
extension based on the file type).

3 Click OK.

If you select the Save As command when an icon pointing to an
er item (a folder or phone book icon for example) is selected, th
item is added to your BookMark List (and the Save As dialog do
not display).

Editing Menu Items
Generally, you cannot edit a Gopher menu item. You can, howe
use the following commands from the Edit menu:

Cut text  — this command is not currently available.

Copy text  — you may copy the title of an item to the clipboard b
highlighting the item and choosing the Copy command. You ma
also copy an IP address or selector string from the Description 
(if displayed).

Paste  — you can paste copied text in the BookMark List or in oth
applications.
Gopher, 13-11
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Configuring Gopher
Gopher is ready to go the first time you launch it using pre-conf
ured defaults. You can change these default settings as may b
sired at any time.

To change Gopher configurations:

1 Choose the Configuration command from the Options menu. T
Configuration dialog displays.

Configuration dialog

2 Enter the following information:

Change default servers, 
download directories and 
set your application asso-
ciations to view docu-
ments.
13-12, Gopher
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Field Description

Default Server Default server name (English name). This i
the server that connects automatically (if e
abled) or displays in the New Gopher dialo

Default Server 
Address

Internet address for the default server.

Default Port Unless specified by a Gopher site, use the d
fault port setting 70.

Connect on 
Startup

Click this checkbox to automatically connec
to the default server whenever Gopher is 
started.

Differentiate 
Gopher Links

Click this check box if you want links to oth-
er Gopher servers to display differently tha
directory items located on the same server

Default Directory Enter the complete path name for the direct
ry where you want downloaded files saved

Application 
Association

This list box allows you to associate file 
types with an application to view the file. 
Most file types are automatically assigned 
during installation. If an association has no
been made for an item, it reads [none spec
fied].

To make an association:

1 Highlight the item for which you wish to 
make an association.

2 Click Edit. The Application Association 
dialog displays.

3 Click Browse. A standard Windows Open
dialog displays. Locate the application you
wish to use to view the file type and click 
OK
Gopher, 13-13
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3 Click the Close Configuration button to save the configuration a
close the dialog.

Field Description

Application 
Association

4 To execute the application immediately a
ter it is downloaded (instead of waiting un
til you quit this Gopher session) click the 
check box.

5 Click OK.

To add a new item to the list:

1 Click New. A blank Application Associa-
tion dialog displays.

2 Enter the file extension for the new item.

3 Select an item type from the drop-down 
list.

4 Click Browse. A standard Windows Open
dialog displays. Locate the application you
wish to use to view the file type and click 
OK.

5 To execute the application immediately a
ter it is downloaded (instead of waiting un
til you quit this Gopher session) click the 
checkbox.

6 Click OK. The new item is added to the lis

To delete an item from the list:

1 Highlight the item you want to delete.

2 Click Delete. The item is removed from the
list.
13-14, Gopher

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Changing the Display Font
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

 the 

dia-

ater 

k-

ok-
Changing the Display Font

You can change the display font using the Font command from
Options menu.

To change the display font:

1 Choose the Font command from the Options menu. The Font 
log displays.

Font dialog

2  Select a font, font style, size, effects and color, and click OK.

Using Bookmarks
Bookmarks allow you to save a site so you can return to it at a l
point quickly.

To add a bookmark:

1 Select the item on the Gopher menu you wish to save as a boo
mark.

2 Choose the Add command from the BookMarks menu. The bo
mark is added to your BookMark List and to the BookMarks 
menu.
Gopher, 13-15
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To connect to a bookmark site:

There are two ways to connect to a bookmark site:

1 Select it from the BookMarks menu.

2 Select it from the BookMark list and click Go To.

BookMark List
The BookMark List contains all your bookmarks. From this list, yo
can view a bookmark sites details, connect to a bookmark site, 
delete or modify a bookmark, or change the order in which the 
bookmarks appear in the list.

To display the BookMark List:

1 Choose the List command from the BookMarks menu.

BookMarks List

The bottom portion of the BookMarks List displays a sites detail
name, item type (for documents), host address, port and select
string.

Added bookmarks.

Selected item’s details.
13-16, Gopher
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2 You have the following options after highlighting a bookmark:

• Click Go To to connect to the bookmark.

• Click Add to add a bookmark. When selected, the Details fiel
are cleared. Enter the new site’s details and click Add again 
add the bookmark to the list.

• Click Modify  to move the cursor to the Details fields allowing
you to edit the details. When finished, click Add.

• Click Delete to delete a bookmark.

• Click Move Up to move the bookmark up one spot in the list.

• Click Move Down to move the bookmark down one spot in th
list.

3 Click OK to close the dialog and save any changes you have 
made.

Exiting Gopher
To disconnect from a Gopher site and exit the application, choo
the Exit command from the File menu. Any changes made to th
Gopher configuration or the BookMark List are automatically 
saved.

Disconnecting and exiting the Gopher application does not disc
nect you from the Internet. If you wish to end your current Intern
session, choose the Bye command in the Dialer menu in the st
and dialer application.
Gopher, 13-17
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Overview
Ping is a diagnostic tool that is used to test and verify a network 
nection to a specific Internet site. Called “pinging”, the applicati
lets you transmit and receive any number of ICMP (Internet Con
Message Protocol echo requests to ensure the connection is wo
properly. (ICMP provides “flow control” when a router gets con-
gested or is otherwise unable to send data to its destination.)

Pinging results are displayed in the main window.

Using Ping
To start Ping, double-click the Ping icon in the Net Commande
program group, or folder. The Ping main window displays (see p
14-4). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 

For more information on using these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.
Ping, 14-3
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Control buttons
Contains the Ping commands which may be selected and appli

Scroll bars
If there is more information than can be displayed in the viewab
area, use the scroll bars to view more.

Ping main window

Starting Ping
You may start a Ping session using the following procedure:

To start a ping session:

1 Type the host ID for which you wish to ping in the Host text bo

2 Click the Start button.

The stack and dialer launches and connects you to the specified
Once connected, the Ping session starts immediately.

Stopping the Ping Session
To stop sending echo requests to the host, click the Stop butto

Minimize/Maximize 
buttonsControl menu

Control buttons
The display area shows the results of each echo request to a 
remote system to verify that it is reachable. It shows the 
number of packets transmitted to the remote system, num-
ber of packets received, and the number of packets lost dur-
ing transmission. Results also show the minimum, average 
and maximum time the packets took to transmit/receive.
14-4, Ping
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To clear the data from the window, click the Clear button.

Exiting Ping 
To exit and close the Ping application, click the Close button. T
command disconnects you from the host system and closes th
plication.

Disconnecting and exiting the Ping application does not disconn
you from the Internet. If you wish to end your current Internet s
sion, choose the Bye command in the Dialer menu in the Trum
Winsock window (Windows 3.1). In Windows 95, click Disconne
in the Connected to... dialog.
Ping, 14-5
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Overview
WhoIs (“who is...”) is a utility program that lets you look up record
on the main Internet database. Typically, you will use WhoIs to
cate people and computers on the Internet and display their na
and e-mail address. You can, however, also look for other reco
host servers, gateways, or networks.

Using WhoIs
To start WhoIs, double-click the WhoIs icon in the Net Command
program group, or folder. The WhoIs main window displays (se
page 15-4). 

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 

For more information on using these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Menu bar
Contains the WhoIs commands which may be selected and app

Scroll bars
If there is more information than can be displayed in the viewab
area, use the scroll bars to view more.
WhoIs, 15-3
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Status area
Displays key connection and system information.

WhoIs main menu

Making a WhoIs Query
When making a WhoIs query, WhoIs searches the main Interne
server, rs.internic.net by default. You can, however, change serv
ers as may desired (see page 15-7). When making a query, you can
use a proper name, keyword, handle, nickname, hostname or n
dress.

To make a WhoIs query:

1 Type the search criteria in the Name to Query text box. 

• To narrow the search, type HA or ! before the target string. For 
example, type !ABC (or HA ABC) to look for records whose 
unique identifier on the Internet starts with ABC. 

• To look for a specific name, type NA or a period (.) before the 
name (e.g., .smith or NA smith).

• To locate a certain type of record, use the following identifier

DO = Finds a domain record.

Minimize button

Menu bar

Control menu

Status area

Query entry box

Response area
15-4, WhoIs
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HO = Finds records for hosts.

GA = Finds gateway records.

NE = Finds network records.

Organization  or Group  = Finds organization/group records.

AS = Finds autonomous system numbers.

• To broaden the search, type a period (.) after the target string. In 
this case, WhoIs displays every item that contains the letters
the target string. For example, typing Sam. would display resu
for Sam, Samuel, Sammy, Samatha, and so on.

2 Click Make Query. WhoIs searches the database and displays
result in the main window. If more than one match is located, a
summary of each match is displayed.

To clear the display window, click the Clear button.

Searching by Handles
Every record in the Internet database contains a single field wh
uniquely identifies it. This is called a record “handle”. The hand
is always shown in parenthesis following the record’s name. Fo
dividuals, the handle is composed of the persons initials plus a t
ing number to make it unique. If you know a person’s or record
handle, use it as your searching criteria, as this is the most pre
method for searching in WhoIs.

Searching by a Mailbox
You may specify that a search only look at mailboxes in its sea
using the following conventions:

Type To search

username@ Searches only those mailboxes with a spec
fied user name.

@host Searches all mailboxes on the host comput

username@host Searches for an exact mailbox match.
WhoIs, 15-5
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Searching by Names

To make a name search more precise, use the full name, as pos
separated by a comma. For example, typing SMITH will cause 
WhoIs to look for all the Smith names. Typing SMITH, JOHN wi
narrow the search to John Smith. You can also use an initial in
search string (e.g., Smith, J).

Displaying On-Line Help

For more information on using WhoIs keywords and commands
display the on-line help.

1 Type Help in the Name to Query field.

2 Click Make Query.

3 Highlight the information.

4 Choose the Copy Response command from the Edit menu.

5 Open Windows Notepad.

6 Paste the help into Notepad.

7 Print the help file using the Notepad print command.

Printing Information

To print information on the WhoIs main screen:

1 Highlight the information you wish to copy.

2 Choose the Copy Response command from the Edit menu.

3 Open a text processing application (Notepad, for example).

4 Paste the text from the clipboard into the text processor.

5 Print the text using the applicable text processor command.
15-6, WhoIs
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Editing Information

You can cut, copy and delete information contained in the Who
main menu. 

Cut Information  — Highlight the information you wish to cut and
choose the Cut Response command from the Edit menu. The te
removed from the WhoIs window and placed in the Clipboard. You 
can paste text in another application accepting a ASCII (.TXT) 
mat.

Copy Information  — Highlight the information you wish to copy
and choose the Copy Response command from the Edit menu.
text is copied from the WhoIs window and placed in the Clipboa
You can paste text in another application accepting a ASCII (.TX
format.

Delete Information  — Highlight the information you wish to de-
lete and choose the Delete Response command from the Edit m
The text is removed from the WhoIs window.

Changing Hosts

To change host servers:

1 Choose the Change Host command from the Options menu. T
New Host dialog displays.

New Host dialog

2 Type the host address for which you want to access.

3 Click OK.
WhoIs, 15-7
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Display a List of Servers

To display a list of available servers, choose the Get List of Serv
command from the Options menu. A list of servers is displayed
the main window.

Exiting WhoIs
To exit the WhoIs application (and disconnect your Internet conn
tion), click the Exit button.
15-8, WhoIs
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Overview
Finger allows you to locate and display information about anoth
user on a specific Internet server. Using Finger, you can display
following user information:

• login name

• full name

• home directory

• login shell

• current login status

• last login

• login terminal/host

Using Finger
To start Finger, double-click the Finger icon in the Net Comman
program group, or folder. The Finger main window displays (se
page 16-4). 

This window is similar to any other Windows application in that
you can re-size it, move it on your desktop, minimize it or maxim
it (refer to your Windows User Guide for procedures).

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It may
used to move the window to another location on the desktop. To
so, click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard Wi
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window

For more information on using these commands, refer to your W
dows User Guide.
Finger, 16-3
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Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains the Host menu with all Finger’s available commands.

Scroll Bar
Scroll bars may be displayed on the far right of the window sho
the viewable area not contain all the available information.

Display area
Displays the requested user information.

Finger main menu

Locating User Information
To locate user information:

1 Choose the Host command from the Host menu. The Host dia
displays (see page 16-5).

Minimize/Maximize 
buttons

Control menu

Display 
Window

Menu bar
16-4, Finger
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Host dialog

2 Enter the host name or internet address for the person you wa
display information.

3 Enter the user login ID of the person you want to display inform
tion.

4 Click OK.

The stack and dialer automatically connects you to the Internet
Once a connection is made, Finger searches for the specified pe
and displays the information in the Finger display area.

5 Repeat steps 1-4 for each person you want to locate informatio

Exiting Finger
To exit and close Finger, choose the Exit command from the H
menu.
Finger, 16-5
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Overview
NetCall is an application that allows you to talk in your own voic
with other Internet users anywhere in the world, at the price of a
cal phone call! It also turns your computer into a personal tele-
phone answering machine, complete with call screening. 

To use NetCall, you need a sound card, microphone and spea
What you are really doing when you speak with someone usin
NetCall is sending recorded messages back and forth. The sp
with which you can send and receive messages, and the quali
the sound, depend on the speed of your Internet connection.

Starting NetCall
Before starting NetCall, establish a connection to the Internet.T
double-click the NetCall icon in the Net Commander program 
group, or folder. The main NetCall window displays.

NetCall main window

The main window is comprised of the following elements:

Title bar
The title bar contains the title of the document or window. It m
be used to move the window to another location on the deskto
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To do so, click and hold the mouse on the title bar and drag it to
desired location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard W
dows operations to Move and Close the window. 

Minimize button
Click this button to minimize the window.

Mode
Allows you to select the NetCall operating option, including:

VoiceChat — Allows you to place and receive calls. This is the 
default mode setting.

Call Screen — Allows you to place and receive calls. When an
incoming call is received, the caller’s name is displayed in a
small window. You are given the choice of accepting the call, 
rejecting it or sending it to the answering machine.

Answering Machine — Sends incoming calls to the answerin
machine.

Calling Information
The drop-down list contains the names of the people you have
called during the current NetCall session; below the list is the e
mail address of the last outgoing call recipient. Below the addr
area is the Open Phone Book button. Use this button to manag
your phone book entries.

Controls
Contains buttons used to place a cal, hang up when done, conf
the application, display the on-line help and exit the application

Caller History
Displays a list of all users who have made incoming calls since
starting the program. When you receive a call, the caller’s user
and time display. To clear the window, click the Clear button.

Status
The Connect, Data Line, and Error indicators give you the statu
your connection. The text area below the indicators provides in
mation about a call. 
17-4, NetTalk 
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Voice System
Standard set of audio control buttons used to record and play y
messages.

Traffic Light
Used to monitor your call activity (talk, listen, and stop): 

Red — no message can be recorded.

Green — messages may be recorded.

Messages
Displays the number of saved incoming messages. The mess
buttons allow you to hear messages left for you and delete the
and record your Answering Machine outgoing message.

Msgs — Play saved messages.

Kill  — Delete a message.

Annc — Record your outgoing greeting message.

Enter a User Name
The first time you run NetCall, it requests your Internet e-mail 
dress. This is how you will be identified to other NetCall users 
when you call them. Your entry is stored in the NetCall Setup d
log (see page 17-6), where you can change it , if necessary.

NetCall Configuration
Before you can make a call (or receive a call), you first need to c
figure the application.

To configure NetCall:

1 Click the Setup button located in the Controls section. The Net
Call Setup dialog displays (see page 17-6).
NetTalk, 17-5
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NetCall Setup dialog

2 Enter the number of seconds you want NetCall to wait before 
answering an incoming call in the Call Screen Timeout field. The 
default is 15 seconds.

3 Select Answering Machine to have the answering machine acti-
vate after the specified number of seconds, or Reject to disconnect 
the call if no action is taken (such as answering the call) once t
specified number of seconds have passed.

4 Select the directory where you want your answering machine m
sages (including the outgoing message) stored in the Messages 
Directory field. It is recommended that you use the same direct
as where NetCall is located (the default directory).

Select a Working Directory. Ideally, this should be a RAM disk 
with at least 700 KB of free space. You can also use your 
C:\TEMP directory.

5 Select your preferred Compression option. 

6 The Key Server fields apply to LANs. Ask your LAN administra-
tor for assistance.

7 Your e-mail address and encrypted password appears in the U
Information fields.

8 Click Done.
17-6, NetTalk 
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Making a Call
To make a call:

1 Make sure VoiceChat or Call Screen is selected in the Mode sec-
tion of the main window.

2 Enter the email address of the person you want to call in the C
ing Information field in the main window.

3 Click the Call button in the Controls section. (The button text 
changes to Hangup.) If the party you are calling is on-line, the 
Connect and Data Line indicators light in the Status section an
the Record and Stop buttons on the audio control button panel
become active.

Note: Outgoing calls are saved in the Call Information drop-dow
list. You can make a future call by simply double-clicking on th
address contained in this list. 

4 When the traffic light turns green, press the Record button, then 
talk into your microphone. When you finish, press the Stop button. 
You may record up to a one-minute message at a time. Record
will automatically stop after one minute.

After recording your message, the traffic light turns red and the
Status bar shows you the transmission of your message includ
when the caller is listening to it.

Listening to a Return Message
When the caller is recording a message to send to you, the tra
light remains red, your audio control buttons are disabled, and
status of the message is shown in the Status bar. 

After hearing the message, the traffic light turns green and you m
send another message.

If you are connected to the user’s answering machine, after hea
their outgoing message, you can record your message. When
ished, you will automatically be disconnected.

5 When you are finished with the call, click the Hangup button in 
the Controls section.
NetTalk, 17-7
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Setting the Answering Machine
Your computer 
must be left on in 
order to receive 
messages.

NetCall can be set to answer your incoming calls, send an outg
greeting message, then record and store incoming messages.

To set the answering machine:

1 Select Answering Machine in the Mode section of the main win-
dow.

2 Press the Annc button located in the Voice System section of the
main window.

3 Press the Record button.

4 Record your greeting message. 

You can also use a pre-recorded .WAV file as a greeting by 
renaming it MESSAGE.WAV and storing it in the Messages 
Directory as specified in the Setup dialog.

5 Press the Stop button.

Listening to Messages
Incoming messages are shown on the digital indicator to the le
the Msgs button. To replay your messages, click the Msgs button.

To delete a message after hearing it, click the Kill  button.

Exiting NetCall
To exit NetCall, click the Exit button. Any open connection will be
disconnected and the application will close.
17-8, NetTalk 
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About CU-SeeME
White Pine’s CU-SeeME brings videoconferencing to
the Internet! Developed at Cornell University (whence
the “CU”), CU-SeeME enables you to view live videos
of friends and colleagues as you talk with them over t
Internet. While you might think that videoconferencing
is an activity reserved for big businesses with fast, de
cated connections to WANs and the Internet, CU-SeeM
puts this capability in your hands, even if you are using
dial-up account and a 28.8 Kbps modem.

What You Will Need
To use the full videoconferencing capabilities of CU-
SeeMe, you generally must have a video capture card
stalled in your system and a video camera attached t
as the video source. However, there are cameras ava
able that do not require a video card; they plug into a p
allel port instead (Connectix QuickCam™ is an example 
of this type of camera).

Note
Visit the CU-SeeMe home page on the Web to acces
list of CU-SeeMe-tested video cards and sound cards
The URL is http://cu-seeme.cornell.edu/ PC.cuseeme
ml.

Of course, the people with whom you want to videoco
ference must also have CU-SeeMe installed, along w
a compatible video capture card and camera. If you d
not have a camera, you can still receive video data if it is 
sent by the other party. And if you have a sound card, y
can send and receive audio.

In order to have a videoconference involving more tha
two people, it is necessary to make use of a reflector—a 
specially equipped server for managing the CU-SeeM
data. For more information on reflectors, visit the CU-
SeeMe Web site at http://cu-seeme.cornell. edu/.
Conferencing with CU-SeeME, 18-3
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Finally, you will need the IP (Internet Protocol) address of the sys-
tem that you want to connect to. When two people videoconfere
with CU-SeeME, one party “calls” the other, using the CU-SeeM
Connect command; but instead of calling a phone number, you
ter an IP address, in the form of an e-mail address. Whichever 
initiates the connection needs to know the other person’s perma
IP address or e-mail address. The same applies for a reflector.

Starting CU-SeeME
When CU-SeeME starts up, it automatically looks for a video ca
ture card or camera and tries to establish an Internet connectio
You should have your camera set up and turned on, if you are u
one, before starting CU-SeeME. Also, your modem must be se
and working before you launch CU-SeeME.

To start CU-SeeME:

Double-click the CU-SeeME icon in the Net Commander progra
group.

After CU-SeeME complete its startup process, the main CU-See
window opens and a local video window display.

CU-SeeME Application Window

The main application window contains the CU-SeeME menus a
status bar.
, Conferencing withh CU-SeeME
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Local Video Window

Note
If you have a video capture card and camera but a Local Video 
dow does not appear, make sure there's an entry in SYSTEM.IN
the [drivers] section for msvideo= that lists your video capture d
er. If your video window shows static, distortion, or a photo-neg
tive image, use the Video Setup dialog to adjust your video. (Se
“Adjusting Video Quality” on page 18-12).

Send Rate Bar

The current frame rate is displayed on the left as nn fps (Frames
Second. Next to that is the send data rate expressed in Kilobits /
ond (Kbps). On the right, in parenthesis, is the send cap in Kilob
/ second. The send cap is an automatically determined maximu
that depends on the amount of data that's lost. It also depends o
minimum and maximum cap set in the control panel (see Trans
sion Control Panel).

 Receive Rate Bar

This bar shows the total amount of data you're receiving for CU
SeeME. In parenthesis is the receive cap. This cap is determine
the reflector based on how much data you receive or lose.

Tip
You can leave a short message right on your video window that
other participants who are receiving your video will see. For exam-
ple, if you have to leave your desk for some reason, you can fre

Name area

video display area

Button Bar

Send Rate Bar

Receive Rate Bar

Freeze video

Show/Hide Con-
trol Panels

Show/Hide Send 
and Receive Rates

Status bar

Menu bar
Conferencing with CU-SeeME, 18-5
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you video (which greatly reduces the bandwidth you are using), 
leave a message telling others who enter the conference when
will return, or that you are in a meeting. 

To put a message in the local video window, move the mouse 
where over the video display area and type the message. To clea
message, press Enter. (You can use the Font command on the
menu to select the font used when you enter keyboard messag
your local video window.)

Setting Up Your Name
Before you connect to a conference with CU-SeeME, you need
set up the name that you want to appear in the title bar of your v
window (both local and remote). 

To enter your name:

1 Choose Preferences from the Edit menu.

The Preferences dialog displays.

2 Next to Your Name, enter the name you want to use for CU-
SeeME conferences.

3 Click OK when done.

Note
See “Setting Preferences” on page 18-15 for a complete description 
of all the Preferences dialog settings.

You can leave a mes-
sage for conference 
participants in your 
local video window.
, Conferencing withh CU-SeeME
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Connecting to a Conference
This section describes the procedure for connecting to one other 
CU-SeeME user. It assumes that both participants are using ca
as. If you have any difficulties, be sure to check other sections in
chapter on CU-SeeME’s video adjustments, audio adjustments
control panels, and preferences.

Both participants must starts CU-SeeME and establish Internet 
nections before attempting to start a conference. The Status Ba
the CU-SeeME window must say “Waiting for a connection.”

As was noted at the beginning of this chapter, you need to know
IP address of the person with whom you want to have a confere
before your CU-SeeME software can connect with his or her CU
SeeME software. Some information on finding out what your ow
IP address is can be found under "What You Will Need," on page 
18-3. 

Note
You do not have to have a camera to connect to a conference, 
gardless of whether the other participants have cameras. You c
start or connect to a conference with just audio. Even if you are
transmitting video, you can receive it from other participants. Con
ference participants who are using audio but no video are referre
as lurkers (they can see and hear but cannot be seen).

To Connect to another CU-SeeME user:

1 Choose Connect from the Conference menu. The Connect dia
displays (see page 18-8).
Conferencing with CU-SeeME, 18-7
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Connect dialog

2 Enter the IP address to which you want to connect. The compu
at the address you enter must not already be connected to a differ
ent CU-SeeME conference, or you will not be able to connect w
that computer.

The Connect field includes a drop-down list, which stores IP 
addresses (or their URL names) that you have connected to in
past. If the address you want is in the list, you may select it rat
than re-entering it.

3 If you want to send video as soon as you enter the conference,
on the “I Will Send Video” option (an x appears when it is on.)

Note
When entering a conference on a reflector, you should leave th
option off until you decide you want to participate in the confer
ence.

4 If you want to enter the conference receiving video, turn on the
Will Receive Video” option. (An x appears when it is on.)

When entering a conference on a reflector, it is quicker to find 
who is in the conference if this option is off (the video windows 
not have to display).

5 In most circumstances, leave 0 in the Conference ID field.

If you are using a reflector and want to have a private conferen
you can enter an agreed-upon Conference ID.

6 Click OK when done.
, Conferencing withh CU-SeeME
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CU-SeeME attempts to connect with the address in the Connec
field. Once connected, if you have set the Open New Video Win
dows option on (see “Setting Preferences” on page 18-15),the re-
mote video windows of participants who are sending video disp
on your screen (up to the maximum set in the Preferences dialo

Remote video windows have a receive rate bar and a button bar sim
ilar to the one on the local video window. The remote video wind
button bar includes the following icons:

Eye - Indicates that the other person is receiving your video.

Speaker - Indicates when you are receiving audio from that pers
Click this icon to toggle audio reception off and on. When it is o
the other person’s microphone button (see next item) shows a s
red x.

Microphone - Indicates when the other person is receiving your au-
dio. When a small red x appears on the microphone, it means t
other person has turned off receiving your audio. If there is a big
X on the microphone, it means the other person is not receiving
audio at all.

Statistics button - Click this button to display various statistics 
about the session.

Information  button - Click this button to show the person’s nam
IP address, and version of CU-SeeME being used. 

Using the Conference Menu Commands

The Conference menu contains the following commands that y
can use during a conference:

Disconnect

Use this command to disconnect from a conference.

Start Receiving Video / Stop Receiving Video

Use this command to stop receiving video from all participants,
to start receiving video.
Conferencing with CU-SeeME, 18-9
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Stop Sending Video / Start Sending Video

Use this command to stop sending video to all participants, or t
start sending video.

Show Audio Panel

Use this command to display the Audio Panel, which is used for ad
justing volume and for speaking to other participants.

Audio Panel

Open Chat Window

The Chat window provides a way to converse with other partici-
pants using the keyboard (this is the venerable way all “chattin
had to be done until the arrival of nearly-real-time speech trans
sion and reception software).

Chat Window

Click here to stop receiving 
audio. Others see a red x over 
the microphone in your video 
window.

Slide the diamond up to down 
to adjust speaker volume.

Click here and hold the 
mouse button down to talk.

 Push to Talk must always be ON.

This meter shows the 
audio level being received.

Click here to stop sending 
audio (“mute” mode).

When Hear Lurkers is ON, 
you can hear participants 
who are not sending video.

Message display area

Movable pane divider

Message typing area

Button bar
0, Conferencing withh CU-SeeME

 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Using the Participants Menu Commands
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

ific 
d in 

oint 

 

on 

ing 
ng 

ici-
um 

See 
f 
The Chat window’s buttons let you filter out messages from spec
participants (and restore them), and choose the font that is use
the Chat window.

To send a message using the Chat window:

• Type your messages in the lower pane (where the insertion p
appears) and press Enter.

To filter out a participant’s messages:

1 Double-click on the participant’s name in the upper pane of the
Chat window.

2 Click the Filter button. Messages from participants whom you 
have filtered out will not appear in your Chat window.

To remove all filters, click on the Reset button.

To select a font for the Chat window:

1 Click on the Configure button. A standard Windows font-selecti
dialog displays.

2 Select the desired font, font style, font size, and font color.

3 Click Ok when done.

Using the Participants Menu Commands
The Participants menu contains commands for displaying or clos
remote video windows and for listing everyone who is participati
in the conference.

Show All

Use this command to display remote video windows for all part
pants in the conference who are sending video, up to the maxim
number of video windows that is set in the Preferences dialog. (
“Setting Preferences” on page 18-15 for a complete description o
the Preference dialog settings.)

Close All

Use this command to close all remote video windows.
Conferencing with CU-SeeME, 18-11
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Show Participants Window

Use this command to open the Participants window. 

The three sections of the Participants window are used as follo

The Senders section is empty; senders are participants whose vid
you are receiving (you can see who they are on your screen).

The Senders (not showing) section lists participants who are sen
ing video, but you are not showing it (you have their remote vid
windows closed).

The Lurkers  section lists participants who are not sending video

The button bar next to each participant’s name is the same as 
button bar that is displayed on an open remote video window. S
page 18-9 for descriptions of these button icons.

Disconnecting from a Conference
When you are ready to disconnect from a conference, choose the
Disconnect command from the Conference menu. 

After you choose the Disconnect command, there is a one-min
period during which your computer ignores data sent from the s
that you just disconnected from. You do not have to wait before
connecting to another site, however.

All video windows are closed, the CU-SeeME application windo
is closed.

Adjusting Video Quality
If you are using a camera, you can use CU-SeeME’s local vide
window to adjust the picture quality with the Video Setup dialog

To adjust video quality:

1 Choose Video Setup from the File menu. The Video Setup dia
displays. 
2, Conferencing withh CU-SeeME
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Video Setup dialog

2 Choose one of the Palette Types:

• 256 Grays - This option gives the best picture, but some cap
cards have a semi-negative looking image in this mode.

• 64 Grays - Use this option for capture cards that will not work
the 256-Grays mode.

• 16 Grays Packed - Choose this option if you are using the Qu
Cam camera.

3 If the image in your local video window looks like a photograph
negative (inverted black and white), turn on the Invert Palette 
option.

Continue with the Video Format and Video Source setup, as ex
plained in the next two sections.

Setting Video Format Options
Click on the Video Format button in the Video Setup dialog. Yo
will see the Format Dialog that comes with your capture card o
camera. Use this to set up your system for 8-bit palettized video w
a 120x160 pixel image size. This dialog might have other optio
depending on your capture card or camera. Click OK when don
Conferencing with CU-SeeME, 18-13
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Setting Video Source Options

Click on the Video Source button in the Video Setup dialog. Yo
will see the Source Dialog that comes with your capture card o
camera. You can try out different settings and watch their effects
the local video window. Click OK when done.

Configuring Audio
CU-SeeME normally detects the sound card that is installed in y
system and uses the appropriate drivers for recording and for p
back. To check which sound device drivers have been selected
recording and playback, choose the Choose the Sound Device
command from the File menu. The Wave Device Selection dial
displays.

Wave Device Selection dialog

If necessary, select a different audio driver from the Recording 
vice and Playback device drop-down lists.

If you are using a modem at 28.8 Kbps or less with CU-SeeME, 
may need to change the audio encoding option. There are two a
encoding methods that CU-SeeME can use: Intel DVI (32 
Kb/s) and Delta-Mod (16 Kb/s). If you are using a modem rated
28.8 Kbps or less, you must use Delta-Mod encoding.
4, Conferencing withh CU-SeeME

 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Setting Preferences
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

n 

re 

 
 

y 
the 
r of 

-

To access the audio encoding setting  if you are using a 
camera:

1 With CU-SeeME running, click on the right button in the local 
video window’s button bar to open the control panels menu.

2 Choose Audio from the drop-down list. Two additional drop-dow
lists appear.

3 In the lower drop-down list, choose Delta-Mod(16 Kb/s) if you a
using a modem at 28.8 Kbps or slower.

To access the audio encoding setting if you  are not  
using  a camera:

1 In File Manager (or Explorer), open the cuseeme.ini file.

2 Scroll down to the [Audio Settings] section.

3 The EncodingMethod= line will say either Intel DVI (32Kb/s) or
Delta-Mod (16Kb/s). If you are using a modem at 28.8 Kbps or
slower, this line must read as follows:

EncodingMethod=Delta-Mod (16 Kb/s)

Setting Preferences
This section explains CU-SeeME’s preference options. The onl
option that needs to be changed before you use CU-SeeME is 
name you want to call yourself. This name appears in the title ba
your video window (both local and remote).

To configure CU-SeeME Preferences:

1 Open the Preferences dialog by choosing the Preferences com
mand from the File menu. The Preferences dialog displays.
Conferencing with CU-SeeME, 18-15
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Preferences dialog

2 Enter the requested information and options as follows:

Field Description

Your Name  This is your “screen name”—what will ap-
pear on everyone else’s screen and in the ti
bar of the local video window. Enter the 
name you want to use here.

Show Splash 
Screen at Startup

Show the two-way arrows graphic every tim
the application starts. Turn this option off if
you want to save a few seconds during the
startup process.

Save Video Win-
dow Positions 

Save the positions where video windows ar
displayed so that they will appear in the sam
positions the next time you connect to a co
ference.

Auto-Tile Video 
Windows

Automatically arrange multiple video win-
dows in a nonoverlapping, “tiled,” layout.
6, Conferencing withh CU-SeeME
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3 Click OK when done.

Using the Control Panels
There are five control panels for adjusting various features of C
SeeME. When you start CU-SeeME, the control panels are norm
not visible. This section explains how to show and hide the con
panels, and how to use each one.

To display the control panels:

1 Click on the Show/Hide Control Panels button in your local vid
window (on the right side of the button bar; see page 18-5). The 
control panel menu displays below the Receiving Bar.

Field Description

Open New Video 
Windows

Automatically open video windows for new
participants (who are sending video) in the
conference. The maximum number of win-
dows that can be open at one time is deter
mined by the Max Video Windows setting. 
Opening new video windows automatically
can significantly increase bandwidth de-
mands. If this option is turned off, you can 
still open video windows for all participants
(who are sending video) by choosing the 
Show All command from the Participants 
menu.

Max Video Win-
dows (2-8)

Enter the maximum number of windows tha
you want to be open at one time. This number 
includes your own local video window (if 
you're sending video).
Conferencing with CU-SeeME, 18-17
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Transmission Control Panel

To hide the control panel, click again on the control panel butto

2 Choose one of the control panels from the drop-down list. The
lowing sections explain how to use the different control panels

Transmission Control Panel
The transmission control panel (see the previous figure) lets you
upper and lower limits on transmission speed. 

Min Kbits/sec
If packets of data are being lost, the transmission speed is auto
ically reduced. Set this to the slowest data transmission rate (in
Kbps) that you want CU-SeeME to use, regardless of data loss

Max Kbits/sec
If you connect to the Internet with a modem, set this number to 
maximum data transfer rate (in Kbps) of your modem (for examp
up to 39—the compressed data transfer rate—for a 28.8 Kbps 
dem). If your network is very busy, it is considerate to keep this
number at 80 or less. 

Max frames/sec
Set the maximum number of frames per second you want to tran
(again, to limit bandwidth consumption).

Reception Control Panel
As with transmission data, you can set an upper and lower limit
the rate at which you receive data (in Kbps).
8, Conferencing withh CU-SeeME
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Reception Control Panel

Picture Control Panel

The upper slider control in the picture control panel lets you adj
brightness in the video windows. 

Picture Control Panel

If you are using a camera, it is preferable to adjust brightness u
the camera adjustment dialog for you video capture card or cam
To access the camera adjustments, choose Video Setup from t
File menu, then click on the Video Format button. See <xref> 
“Adjusting Video Quality” earlier in this chapter.

Compression Control Panel

The values displayed in this control panel are the same ones a
shown in the Transmission panel as Min Kb/s and Max Kb/s.
Conferencing with CU-SeeME, 18-19
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Compression Control Panel

Audio Control Panel

The audio control panel lets you change the audio buffer size a
choose the audio encoding scheme.

Audio Control Panel

The audio buffer size can be 50 or 100 milliseconds. 50 millisec
onds results in less delay at the receive end, but consumes mo
bandwidth. 100 milliseconds uses less bandwidth.

Two methods of audio encoding are provided. Intel DVI consum
32 Kbps of bandwidth, so it cannot be used with any modem at 2
Kbps or slower. The other audio encoding method, Delta-Mod, u
only 16 Kbps of bandwidth and will work with 28.8K modems, b
at some cost to sound quality.
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Overview
Enhanced Mosaic Helpers define the types of files you can vie
and work with as you explore the Internet. Enhanced Mosaic h
built-in support for the following file types:

• HTML documents

• Text documents

• JPEG and GIF images

• AU and AIFF sound files (in addition, RA and RAM sound-file
support is built into Internet Explorer for Windows 95)

Additionally, Enhanced Mosaic offers you the following helper a
plications:

• Video for Windows  — View any .AVI or .MMM video clip.

• QuickTime for Windows  — View QuickTime movies.

• Panorama  — Display SGML documents.

• Adobe Acrobat  — Display documents saved as an Adobe 
.PDF document, including the on-line documentation manua

• VMPEG — Play MPEG compressed video files.

• TrueSpeech Player  — Play TrueSpeech-encoded sound 
files.

• StreamWorks  — Play video and audio files.

• VR Scout  — View virtual reality (VRML) files.

• CheckFree Wallet  — Pay electronically for purchases from
Internet vendors.

This chapter explains how to use each of these helper applicat

Configuring Helper Applications
In order for Enhanced Mosaic or Internet Explorer to launch the
propriate helper application when you select a link to a file in a
Web page, you need to associate different file types with the ap
cation you want to use to read or play the file. For example, if y
click on a link to a VRML—Virtual Reality Modeling Language—

These helper ap-

plications are only 

available on the 

CD version of Net 

Commander. 
Helper Applications, A-5
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file in a Web page, Enhanced Mosaic or Internet Explorer will u
Net Commander’s VR Scout helper application to read the file a
displays it in your browser, as long as you have associated that
cific application with that specific file type.

For instructions on configuring Enhanced Mosaic for helper ap
cations, see “Configuring Helper Applications” on page A-37. F
instructions on configuring Internet Explorer for helper applica-
tions, see “Associating Applications with File Types” on page 5
30.

If you click on a link that points to a file type for which you hav
not configured your Web browser, a dialog like the one shown
low will display. 

Unhandled File Type dialog

Click the Configure Helper button to bring up the same dialogs t
are explained in the file-type configuration instructions for En-
hanced Mosaic (see page A-37) and for Internet Explorer (see pag
A-30).

Video for Windows
After installing Video for Windows, it is automatically inserted an
configured in your Helpers file. You do not have to do anything
order to use it. When sampling a file using the Video for Windo
format (.AVI or .MMM files), it will automatically display.

To open the display (in order to play a saved file), double-click
icon if you have added it to a program group or folder, or doub
click on the Video for Windows file you wish to sample.

The Video for Windows window displays (see page A-7).
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Video for Windows window

The Video for Windows display is comprised of the following el
ments (and icons and samples are from Windows 3.1):

Title bar
The title bar contains the title of the window. It may be used to
move the window to another location on the desktop. To do so
click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu ba
the upper left corner of the window. It contains the standard W
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 

For more information on using these commands, refer to your W
dows User Guide.

Control sound

Play Slide bar Back Forward Size video
Helper Applications, A-7
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Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Control buttons
These buttons allow you to control a playing file ( play, forward
and backward).

Playing a File
If you have configured Enhanced Mosaic to display and play fi
as they are selected while browsing the Internet, Video for Win
dows automatically displays. (See “Configuring Helper Applica
tions” on page A-37 for Enhanced Mosaic, or “Associating 
Applications with File Types” on page A-30 for Microsoft Internet 
Explorer).

Loading a Saved File
If you have saved a Video for Windows file (using an .AVI or 
.MMM extension) you can sample the files as follows:

1 Choose the Open command from the File. A standard Window
Open dialog displays.

2 Select the file you wish to sample and click OK.

3 Click OK.

The selected file plays.

For more information on using Video for Windows, refer to you
Windows User’s Guide.

Exiting Video for Windows
To exit and close the Video for Windows display, choose the Cl
command from the Control menu, or simply double-click on the
Control menu icon in the upper left hand corner of the display.
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QuickTime for Windows
After installing QuickTime for Windows, it is automatically inser
ed and configured in your Helpers file. You do not have to do a
thing in order to use it. When sampling a file using the Quicktim
for Windows format (.MOV files), it will automatically display.

To open the display (in order to play a saved file), double-click
icon from the QuickTime for Windows program group or folder, 
double-click on the QuickTime for Windows file you wish to sam
ple.

The Movie Player window displays.

Movie Player window

The Quicktime for Windows display is comprised of the followin
elements:

Title bar
The title bar contains the title of the window. It may be used to
move the window to another location on the desktop. To do so
click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.
Helper Applications, A-9
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Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard W
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 

For more information on using these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Allows you to select the commands which are available for use

Playing a File
If you have configured Enhanced Mosaic to display and play fi
as they are selected while browsing the Internet, Video for Win
dows automatically displays. (See “Configuring Helper Applica
tions” on page A-37 for Enhanced Mosaic, or “Associating 
Applications with File Types” on A-30 page for Microsoft Internet 
Explorer).

Use the Control buttons to play a file.

Use the commands in the Movie menu to control and alter you
viewing options.
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Loading a Saved File

If you have saved a QuickTime for Windows file (using an .MO
extension) you can sample the files as follows:

1 Choose the Open command from the File. A standard Window
Open dialog displays.

2 Select the file you wish to sample and click OK.

3 Click OK.

The selected file plays.

Exiting QuickTime for Windows

To exit and close the QuickTime for Windows display, choose t
Exit command from the File menu.

For more information on using QuickTime for Windows, refer t
the on-line help available in the QuickTime for Windows menu
bar.

RealAudio Player
RealAudio Player is installed automatically when you install th
Microsoft Internet Explorer Web browser. When you click on a
RealAudio file (.RA or .RAM) in Internet Explorer, RealAudio 
Player automatically runs and loads the file.

Note: RealAudio Player is not available for Windows 3.1 in Net
Commander.

To run RealAudio Player in standalone mode— to play a save
file, for example—use Windows Explorer to find RAPLAY-
ER.EXE, which is installed by default in the Microsoft Internet 
folder.
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RealAudio display

The RealAudio display is comprised of the following elements:

Title bar
The title bar contains the title of the window. It may be used to
move the window to another location on the desktop. To do so
click and hold the mouse on the title bar and drag it to the des
location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard W
dows operations to Restore, Move, Size, Minimize, Maximize, a
Close the window. 

For more information on using these commands, refer to your W
dows User Guide.

Minimize button
Click this button to minimize the window.

Menu bar
Contains the commands available for selection.

Control buttons
These buttons allow you to control a playing file (stop, play, pau
forward and backward).

Audio control buttons.

Information on current 
audio file.

Menu bar.
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File Information
When a audio file is being played, information about the file — i
title, author, copyright information and status (playing, paused
stopped, etc.) is displayed. To hide the file information, click (t
disable) the Info & Volume command in the View menu. A chec
mark displays next to an enabled option.

Status Bar
The status bar shows the current status of the Player, the length
position of the RealAudio file, and help text for the menu com-
mands. To hide the status bar, click (to disable) the Status Bar 
mand in the View menu. A checkmark displays next to an enab
option.

Playing a File
If you have configured Enhanced Mosaic to display and play fi
as they are selected while browsing the Internet, RealAudio au
matically displays. (See “Configuring Helper Applications” on 
page A-37 for Enhanced Mosaic, or “Associating Applications 
with File Types”on page A-30 for Microsoft Internet Explorer).

You can use the Control buttons on a playing audio file as follo

Loading a Saved File
If you have saved a RealAudio file (using an .RA or .RAM exte
sion) you can sample the file as follows:

1 Choose the Open File command from the File menu. A standa
Windows Open dialog displays.

2 Select the file you wish to sample and click OK.

3 Click OK.

The selected file plays.

Back

Stop

Forward

PausePlay
Helper Applications, A-13
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Opening a File from a URL
If you know the complete URL address for a RealAudio file, yo
can sample the file as follows (with the Enhanced Mosaic brow
open and an active on-line connection to the Internet):

1 Choose the Open Location command from the File menu. An o
URL dialog displays.

2 Type the complete URL address and click Open.

The selected file plays.

RealAudio Options

You may select to keep the RealAudio display always on top o
other running applications, or use an 8-bit and/or 11KHz sampl
rate.

To keep the RealAudio display always on top of other running 
plications, choose the Always on Top command from the View
menu. A checkmark displays next to an enabled option.

To change additional RealAudio Options:

1 Choose the Options command from the View menu. The Optio
dialog displays.

Options dialog

2 Select the options you wish to use. To select a sampling rate, c
the Advanced button.

3 Click OK to save and apply the options.

Enabled options are 
checked; disabled options 
are blank.
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Checking File Transmissions
1 To check an audio files transmission statistics, choose the Sta

tics command from the View menu. A Connection Transmissio
dialog displays showing you the transmission statistics.

2 To close the dialog, click Close.

Exiting RealAudio

To exit and close the RealAudio display, choose the Exit comm
from the File menu, or simply double-click on the Control menu
icon in the upper left hand corner of the display.

TrueSpeech Player
DSD Group’s TrueSpeech player plays specially encoded WA
files in real time, as they are being downloaded from the Intern
You can listen to radio interviews as well as music, for exampl
without having to wait until the entire file is transferred to your 
computer before you can begin to play it back. Net Commande
setup configures Enhanced Mosaic for running TrueSpeech w
you click on a link that includes a TrueSpeech-encoded (TSP) file.

TrueSpeech’s Bookmark feature lets you save the addresses 
vorite TrueSpeech links and listen to them later without having
launch your Web browser. If you are not connected to the Inter
when you choose a bookmark to play, The TrueSpeech player d
and make the connection itself.

Playing a File

When you are using Enhanced Mosaic to browse the Web and
come to a link to a TrueSpeech file, simply click on the link; 
TrueSpeech will start automatically. If you just want to play ba
a TrueSpeech file, without starting Enhanced Mosaic, you can s
TrueSpeech by double-clicking on its icon in the TrueSpeech P
gram Manager group window or in Windows Explorer. Both me
ods open the TrueSpeech window on top of the other windows
your screen.

If you would like to 
locate some TSP 
files to try out your 
TrueSpeech player, 
start with a visit to 
DSP Group’s home 
page at 
www.dspg.com.
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TrueSpeech window

When TrueSpeech is playing back a file, the horizontal bar in t
middle of the window animates to indicate the progress of the p
back through the file.

TrueSpeech Tool Bar and Menus

The TrueSpeech tool bar provides one-click access to the follow
commands:

TrueSpeech tool bar

The tool bar commands are also found in the following menus

File menu:

• Open File (play back a local file)

• Open Location (play back a file on the Web)

View menu:

• Add Bookmark

Beginning Stop EndPlay

Elapsed time display 
(during playback)

Enter file name or URL.

Open File

Open Location 
(URL)

Add Bookmark title
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Control menu:

• Beginning (“rewind” to the beginning of the file)

• Play

• Stop

• End (“fast forward” to the end of the file)

Note
TrueSpeech stores some very small files in your system’s TEM
(or TMP) directory. If your system is not set up to clear files in t
TEMP or TMP directory each time you start Windows, you ma
need to delete the files periodically.

Using Bookmarks

TrueSpeech has a bookmarks feature (similar to a hotlist or fa
ites list) for saving the addresses (URLs) of TrueSpeech links 
you want to return to without having to search for them again a
again.

To save a link as a bookmark:

1 Choose Add Bookmark from the View menu. (Or click on the Ad
Bookmark tool bar icon.) The Add Bookmark Title dialog dis-
plays.

Add Bookmark Title dialog

2 Type any descriptive title you like in the Title box.

3 Click OK. The book mark is added to the Bookmarks list.

To play a bookmarked link:

1 Choose Bookmarks from the View menu. (Or click on the Book
marks tool bar icon.) The Bookmarks dialog opens.
Helper Applications, A-17
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Bookmarks dialog

2 The List of bookmarks contains bookmark titles. When you sel
a bookmark, its URL displays in the File Location box.

3 Click OK.

TrueSpeech accesses the URL and plays the file.

To remove a bookmark:

1 Choose Bookmarks from the View menu.

2 Select the bookmark you want to remove and click Remove.

To modify a bookmark:

1 Choose Bookmarks from the View menu.

2 Select the bookmark you want to modify.

3 Make the changes you want in the Bookmark title or File Locati

4 Click Modify. The original bookmark is replaced by your modi-
fied bookmark.

5 Click OK.
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TrueSpeech Options

The Options menu contains two commands and a dialog.

Always on Top
Keeps the TrueSpeech Internet Player window on top of all oth
open windows.

Default Size/Position
Snaps the TrueSpeech Internet Player back to its default size 
position in the upper left corner of the screen.

Options Dialog
It is strongly recommended that you try TrueSpeech first with the 
defaults settings you find in this dialog.

Exiting TrueSpeech

To exit TrueSpeech, choose Exit from the File menu.

Field Description

Initial buffer size default: 6144 bytes
minimum: 1024 bytes
Increase this number if you experience lots 
pauses during downloading.

Silence buffer sizedefault: 512 bytes
minimum: 480

Timeout, sec default: 30

Port Address  default: 0

Sound Card:
Preferred Sam-
pling Rate/Pre-
ferred Resolution

Default: 8 KHz/16 bps
Some sound cards may require a different 
setting for best performance. Other options
are available from this drop-down list <<ver-
ify>>.
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Panorama
Panorama allows you to view SGML documents. After configuri
Panorama as a helper in the Enhanced Mosaic main window, 
orama will automatically display whenever you open an SGML
document (see page A-21). Refer to “Configuring Helper Applica-
tions”on page A-37 for Enhanced Mosaic, or “Associating Appli-
cations with File Types” on page A-30 for Internet Explorer, for 
instructions on configuring your browser for new file types.

To open Panorama (to display a saved SGML document), dou
click the Panorama icon in the SoftQuad WWW Applications p
gram group or folder.

The Panorama main window contains the following componen

Title bar
The title bar contains the title of the document or window. It ma
be used to move the window to another location on the desktop
do so, click and hold the mouse on the title bar and drag it to t
desired location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu bar
the upper left corner of the window. It contains the standard W
dows operations to Move, Size, Maximize, and Close the windo

For more information on these commands, refer to your Windo
User Guide.

Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains all the commands which may be executed while work
with the Panorama application.

Tool bar
Allows you to quickly execute many of the commands contained
the Menus by simply clicking the mouse on the icon.
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Page Forward/Page Backward buttons
These buttons are available only when you have opened more 
one page of a document. They allow you to quickly page back 
forward through the current session.

Document display window
This is the area where the information contained in a URL is d
played. 

Scroll bar
If the window contains more information than can be displayed
the viewable area, use the scroll bar to see more information.

Status bar
Displays a status message and progress indicator. The status
sage may show you the ULR of a hyperlink whenever the mous
moved over a link, the status of a file transfer, or the command
scription whenever the mouse is moved over a menu comman
tool bar icon. The progress indicator shows the time remaining
a file to be loaded.

Panorama main window

Minimize/Maximize
Buttons

Menu 
Bar

Control Menu

Tool Bar

Display area

Status Bar

To change size 
of left or right 
display, drag 
the separation 
bar.
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Opening a SGML File

Panorama will automatically display whenever you select a SG
file if you configure Enhanced Mosaic to display selected files 
mediately.

You can also open saved files as follows:

1 Choose the Open URL command from the File menu, or click t
Open icon on the tool bar. The Open URL dialog displays.

Open URL dialog

2 Enter the name of the file you wish to open (using its complete
path).

3 Click OK. 

The selected file opens and displays in the main window.

Reloading the File

To reload a file, choose the Reload command from the File me

Changing the Display

By default, SGML documents are displayed showing you a doc
ments table of contents (as applicable) on the left hand side of
screen and the actual document on the right hand side of the sc

Use the table of contents to display other pages of the documen
clicking on the desired page or subject.

You may change this display using the commands in the Navig
menu as follows:

Show SGML Tree  — display a flowchart or tree chart of the do
ument on the left hand side of the document (replacing the tabl
A-22, Helper Applications
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contents). Like the table of contents, clicking on one of the flow
chart boxes will display that section of the document in the righ
hand portion of the window.

None — display the actual document in the full window.

Contents — display the default window.

Closing the File
To close a file, choose the Close command from the File menu

Navigating a File
While you can use the hypertext jumps contained in a SGML’s
ble of contents or Tree to navigate to other pages of a docume
you can also use the navigate commands or by searching for 
within the document.

Page Forward  — Choose the Forward command from the Ed
menu (Alt E, O), or click the Page Forward icon on the tool bar

Page Backward  — Choose the Back command from the Edit 
menu, or click the Page Back icon on the tool bar.

Searching a Document
To search a document using a word or phrase, choose the Se
command from the Edit menu, or click the Search icon on the t
bar. The Search dialog displays.

Search dialog

1 Type the word or phrase you wish to locate in the active docu-
ment.

To locate a word or 
phrase in a document, 
type the text and click 
OK.
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2 To narrow the search, click the Case Sensitive checkbox.

3 Click OK. Panorama will search the document and highlight eve
word or phrase which matches the criteria.

4 To navigate to all instances of the match, use the Search Forw
Search Backward icons on the tool bar. You can also use the f
lowing commands from the Edit menu:

First  — go to the first match.

Previous  — go to the previous match.

Next  — go to the next match.

Last  — go to the last match.

Panorama Options
You may enable or disable the following options from the Optio
menu:

Show Toolbar  — display (or hide) the tool bar. Enabled by de
fault.

Show Statusbar — display (or hide) the status bar. Enabled b
default.

Launch Subviews  — display (or hide) subviews (e.g., foot-
notes) as applicable. Enabled by default.

Use Default Navigator — show (or hide) the default navigator
(Enhanced Mosaic) when Panorama launches. Enabled by de

Occurrence Density Display  — highlight (or do not highlight) 
matches from a search. Enabled by default.

Autoshrink Graphics  — shrink graphics to fit in a single page
view. Enabled by default.

Prevent Flicker  — prevent screen flicker when displaying page
Enabled by default.

Show Tags  — show a documents internal tags.

Show Hotspots  — show hotspots on graphics which may be 
used to go to another topic in the document. Enabled by defau
A-24, Helper Applications
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On-Line Help

To display the Panorama on-line help, choose the Manual com
mand from the Help menu. This file provides you with more info
mation on how to work with SGML documents.

Exiting Panorama

To exit and close Panorama, choose the Exit command from t
File menu.

Acrobat Reader
Adobe’s Acrobat Reader allows you to view and print .PDF do
ments, including this on-line documentation manual. After conf
uring Acrobat Reader as a helper in the Enhanced Mosaic ma
window, it will automatically display whenever you open an .PD
document (see page A-27). Refer to “Configuring Helper Applica-
tions”on page A-37 for Enhanced Mosaic, or “Associating Appli-
cations with File Types”on page A-30 for Internet Explorer, for 
instructions on configuring your browser for new file types.

To open Acrobat Reader (to display a saved .PDF document or
on-line documentation manual), double-click the Acrobat Read
icon in the Adobe Acrobat program group or folder.

The Acrobat Reader main window contains the following comp
nents:

Title bar
The title bar contains the title of the document or window. It m
be used to move the window to another location on the desktop
do so, click and hold the mouse on the title bar and drag it to t
desired location, then release the mouse.

Control menu
The control menu is accessed by clicking the control menu ba
the upper left corner of the window. It contains the standard W
dows operations to Move, Size, Maximize, and Close the windo
For more information on these commands, refer to your Windo
User Guide.
Helper Applications, A-25
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Minimize button
Click this button to minimize the window.

Maximize button
Click this button to maximize the window.

Menu bar
Contains all the commands which may be executed while work
with the Acrobat Reader application.

Tool bar
Allows you to quickly execute many of the commands contained
the Menus by simply clicking the mouse on the icon.

Document display window
This is the area where the .PDF document is displayed. 

Scroll bar
If the window contains more information than can be displayed
the viewable area, use the scroll bar to see more information.

Status bar
Displays the following items:

Window splitter  — allows you to change the view, splitting th
window into an overview and document area. Drag the control
adjust the width of the window to the desired size.

Page number box  — displays the current page number. Click o
the box to display the Go to Page dialog. Type the page number
want to go to and click OK.

Magnification box  — displays the current magnification level.
Click and hold the mouse button on the box to display a drop-do
menu of available selections. Move the highlighter to the desir
magnification level and release the mouse. The display chang
based on your selection.

Page size box  — displays the size of the current page.

Window splitter
Page number box

Magnification box
Page size box
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Acrobat Reader main window

Tool Bar

The tool bar allows you to execute key commands when viewi
and navigating a document. 

Page Only  — display the document only and close any display
overview area. This command may also be selected from the V
menu.

Bookmarks and Page  — open the overview area and display
any created bookmarks. Click a bookmark to go directly to that
cation in the document. This command may also be selected f
the View menu.

Thumbnails and Page  — open the overview area and display
thumbnail images of each document page. Click a thumbnail to
to that page in the document. This command may also be sele
from the View menu.

Hand  — move the document in the window by dragging it in th
desired direction. This command may also be selected from th
Tools menu.

Minimize/Maximize
Buttons

Menu 
Bar

Control Menu

Tool Bar

Display area

Status Bar

To change size 
of left or right 
display, drag 
the separation 
bar.
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Zoom  — magnify and reduce a page display by a factor of 2 w
each click of the tool. This command may also be selected from
View menu, or the Tools menu.

Select text — select text in a document. Drag the cursor over t
text you wish to select. Highlighted text can be copied into the c
board using the Copy command from the Edit menu. This com
mand may also be selected from the Tools menu.

Browse  — use these buttons to go to the first page or last pag
the document, or forward and back one page at a time. These 
mands may also be selected from the View menu.

Go Back/Go Forward  — retraces your history as you view doc
uments. These commands may also be selected from the View
menu.

Actual size  — display the page at 100%. This command may a
be selected from the View menu.

Fit page  — scale the page to fit within the window. This com-
mand may also be selected from the View menu.

Fit Width  — scale the page to fill the width of the window.This
command may also be selected from the View menu.

Find  — displays the Find dialog allowing you to search for a wo
or phrase in the document. This command may also be select
from the Tool menu.

Opening a Document
Acrobat Reader will automatically display whenever you selec
.PDF file if you configure Enhanced Mosaic to display selected
files immediately.

You can also open saved files as follows:

1 Choose the Open command from the File menu. A standard W
dows Open dialog displays. 

2 Enter the name of the file you wish to open.

3 Click OK. 
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The selected file opens and displays in the main window.

Displaying Documents Full Screen

You can display the document using your full monitor screen (n
just in the main window). To do so:

1 Choose the Full Screen command from the View menu. 

2 To return to a normal display, press the ESC key.

.PDF Links and Notes

.PDF files can contain hypertext links to other sections of the c
rent document, or to other documents. You use these links in 
same manner as any other hypertext links, simply click the mo
on the link. To return to your previous page view, use the Go B
command from the View menu, or click the Go Back arrow on t
tool bar.

If a document contains a note (it will be labeled as such), doub
click on it to open the note.

To find the next note in a document, choose the Find Next Not
command in the Tools menu. 

To close the note window, double-click the Control menu bar in 
upper left hand corner.

Finding Text

To search a document using a word or phrase, choose the Fin
command from the Tools menu, or click the Find icon on the to
bar. The Find dialog displays (see page A-30).
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Find dialog

1 Type the word or phrase you wish to locate in the active docum

2 To narrow the search, you can click the Match Whole Word On
to search for an exact match, or the Match Case checkbox. 

3 Click Find. Acrobat Reader will search the document and high
light the first word or phrase which matches the criteria.

4 To continue the search, choose the Find Again command from
Tools menu, or press F3.

Reader Preferences
You may change the preferences for how documents are displa
using the commands from the Preferences options in the Edit m

To change preferences:

1 Choose the Preferences command from the Edit menu. A sub-
menu displays allowing you to set general preferences or full-
screen preferences.

2 Select the General Preferences option. The General Preferenc
dialog displays (see page A-31).
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General Preferences dialog

3 You can select or enter the following fields:

Field Description

Default 
Magnification

Press the button next to the field to display
drop-down list of available selections. 
Choose the default magnification you want
to use when documents are opened. This i
typically 100%.

Max “Fit Visible”
Magnification

Select the maximum magnification that will
apply when the Fit Visible command is se-
lected from the drop-down list (default is 
200%).

Display Large 
Images

Allows you to display large images without
replacing them as a gray box. If enabled, d
pending on the image, it may take some tim
to display the image.

Use Page Cache Creates a memory cache which may improv
performance when viewing documents.
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4 After making your selections, click OK to save the settings and
close the dialog.

5 To change additional preferences, choose the Preferences com
mand from the Edit menu. 

6 Select the Full-Screen option from the sub-menu. The Full-Scr
dialog displays (see page A-33).

Field Description

Greek Text 
Below [__] Pixels

Allows you to specify the size of characters
which will display below a “greek” character
(which are displayed as gray lines). Increas
ing the size of greeked characters improve
performance for displaying pages.

Substitution 
Fonts

Allows you to select a substitute font from 
the drop-down list to use if Type 1 fonts are
not available on your local computer.

Page Units Select a page unit from the drop-down list t
use as the unit of measurement (inches, m
limeters or points).

Display Splash 
Screen at Startup

If selected, the Adobe Acrobat Reader ope
ing page (the “Splash” screen) displays prio
to the main window.

Display Open 
dialog at Startup

If selected, a standard Windows Open dialo
displays whenever you launch Acrobat Rea
er from program manager allowing you to se
lect the file you want to open and display.

Maximize 
Application on 
Opening

If selected, Acrobat Reader displays full 
screen whenever it is opened.
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Full-Screen Preferences dialog

7 You can select or enter the following fields:

8 After making your selections, click OK to save the settings and
close the dialog.

Additional Options
You can use the following commands to assist you while worki
with a .PDF document.

Field Description

Change Pages:
With Keyboard

Select how you want to control changing 
pages, by the keyboard or with mouse.

Every ___ 
Seconds

If you would like to advance the page by a 
specified number of seconds, select the op
tion and enter the number of seconds be-
tween automatic page changes.

Loop If selected, the document is continually dis
played from the first page to the last page u
til you close the document.

Background
Color

Select a background color for the window 
from the drop-down list.
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Close a document  — to close the document, but not the Acrob
Reader application, choose the Close command from the File 
menu.

Display document information  — to display information 
about the current document, displayed fonts and security, cho
the Document Info command from the File menu. A sub-menu 
plays allowing you to select:

General  — displays a General Info dialog showing you ke
information about a document including its title, author an
search keywords. Click OK to close the dialog.

Fonts  — displays a Fonts Info dialog allowing you to view a
the fonts used in the document and any substitute fonts u
based on your computer system. Click OK to close the dia

Security  — displays a Document Security dialog showing
your document rights for such functions as printing the do
ment, editing the document, copying text, and so on. Click O
to close the dialog.

Print a document — to print a document, choose the Print com
mand from the File menu. A standard print dialog displays allo
ing you to select printing options. After selecting options, click O
to print the document.

Copying text  — you may copy text or graphics to the Clipboar
which can be pasted into another application as follows:

• Choose the Select All command from the Edit menu to selec
the entire document or click the Select Text icon on the tool 
and highlight the text you wish to copy.

• After selecting text, choose the Copy command from the Ed
menu.

Exiting Acrobat Reader
To close and exit the Acrobat Reader, select the Exit comman
from the File menu.
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With Xing™ Technology’s StreamWorks you can listen to live a
dio broadcasts and watch live video broadcasts on the Interne
play back audio and video files on demand. There are already
eral radio stations that broadcast on the Internet. StreamWork
pre-configured with several choices of stations. Also, each tim
you start StreamWorks, it searches the Internet for StreamWo
servers, so that you have an up-to-date selection of “streams” t
ten to and view. (“Stream” simply refers to a flow of data sent ov
the Internet.)

When using StreamWorks, you will see labels such as “8.5 kbp
“24 kbps,” “ISDN,” and the like. Depending on the speed of yo
Internet connect (e.g., via 14.4 kbps modem, T1 line, ISDN lin
and so on), you will not be able to view or listen to transmissio
that require a greater transfer rate (bandwidth) than your conn
tion provides. As a rule, choose 8.5kpbs for 14.4 kpbs modems
slower), 20 or 24kbps if you have a 28.8 kbps modem, and 56 k
or 112 kbps if you have an ISDN (or faster) connection.

Refer to “Configuring Helper Applications” on page A-37 for En-
hanced Mosaic, or “Associating Applications with File Types” o
page A-30 for Internet Explorer, for instructions on configuring 
your browser for new file types. The configuration information yo
will need is as follows:

• MIME type: application/x-xdma

• extensions: xdm, .xdma

• helper: <path>\netview.exe %s

The following sections explain how to use the basic features o
StreamWorks.

Playing StreamWorks Files
Before starting StreamWorks, you need to have established a
ternet connection. Do this by running the Connect program in 
Net Commander program group window (Windows 3.1) or by u
ing the Dial-Up Networking connection for your ISP (in Window
95). 
Helper Applications, A-35
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Net Commander User’s Guide
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

dou-

. 
 

erv-
ow 

e of 
 to 

 

Once you have an Internet connection, start StreamWorks by 
ble-clicking its icon in the program group where you installed 
StreamWorks. The StreamWorks Startup window appears first
The “Finding Servers” message in the Startup window tells you
that StreamWorks is searching the Internet for StreamWorks s
ers. When the searching is done, the main StreamWorks wind
displays, with its “TV screen” and button controls.

StreamWorks Main Window

Once the main window is available, the next step is to select on
the available StreamWorks servers, from which you will be able
select what you want to hear and watch.

To select a server:

1 Click the Browse button. (Alternatively, you can click one of the
pre-configured buttons to select a server.) The StreamWorks 
Browser window displays.
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StreamWorks Browser Window

2 Pick a server from the Known Servers drop-down list.

Note: The Refresh button is used to update the Known Servers

A list of topics appears in the Keywords window. Keywords are
ranged in a hierarchical list; once you select one, additional ke
words may display.

3 Click on one of the keywords.

4 Click the Search button (or double-click the keyword). A list of 
available streams displays in the Available Streams area. 

Note that a History drop-down list appears under Keywords. U
the History list to re-select a particular keyword that might no 
longer be visible in the Keywords list, or click <ALL> to refresh
the list.

5 Select one of the streams; the Search button changes to Play.

Note: You can sort the streams using the Name and Date radio
tons.

6 Click Play (or double-click the stream title in the Available 
Streams list). The main StreamWorks window displays and the
stream is downloaded.

2. Select a keyword.

3. Click Search.

4. The list of Available 
Streams displays.

1. Select a server.
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Note: If the stream you select requires a faster transfer rate tha
supported by your system, a Transmit Request Error displays 
informing you what the minimum required transfer rate is for th
selected stream, and you will not be able to play it.

Video Playback

You will see the Audio Only icon if the stream contains only 
audio, or if your Internet connection does not have the capacity
play back the video portion of an audiovisual stream.

Audio-Only Playback

Note:You can minimize the StreamWorks window and do other
tasks while StreamWorks is “on.”
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7 To stop playback, click the Stop button. 

To choose another “program” to listen to or watch, click Brows
and select a different server, keyword, or stream.

Now you know the basics of using StreamWorks. The next sect
describes the options which you can use to configure StreamW
for the best quality playback possible on your system.

StreamWorks Options
The Setup button on the main StreamWorks window opens th
StreamWorks Setup dialog.

StreamWorks Setup Dialog - General Settings

The “Modify Settings For” drop-down list provides access to th
following five groups of configuration settings:

• General settings affect video and audio playback.

• Server settings allow you to specify the IP address of specif
servers. 

• Button settings allow you to customize the assignment of 
StreamWorks servers to the buttons in the main window. Yo

Use the drop-
down menu to 
display different 
Settings dialogs
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can also assign custom bitmaps to the buttons.

• Network and Live Stream settings apply to LANs; see your 
LAN administrator for assistance with these settings. 

General Settings
Maximum Connection Speed - Select the option that correspond
to the speed of your modem. If you are using an ISDN connect
you can select 64K or 128K.

Video Window - Choose your preference for sizing the video w
dow.

Audio Decoder - This area displays the current audio decoding s
tings. The default settings provide the maximum sound card co
patibility. To view all of the available audio decoder settings, cli
Edit. The Audio Decoder Settings dialog displays.

Audio Decoder Settings Dialog

Selecting the “Full, Floating, Stereo” settings gives the highest
delity, but they should only be used on a computers with a Pent
microprocessor. You can try different settings to find out which
produce the best performance on your system.

Audio Control  - Use this volume slider to adjust the playback vo
ume, if desired.

Advanced - The Advanced button opens the Advanced Audio S
tings dialog.
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Advanced Audio Settings

You can experiment with different settings to find out which on
produce the best performance on your system.

Server Settings
Use this dialog to add or remove servers, and to change serve
name, address, and port information.

To add a server:

1 Enter the server’s name in the Name text box under Server Da

2 Enter the server’s IP address in the IP Address text box.

3 Enter the port number. This should always be 1558 (unless you
using a LAN and you LAN administrator tells you to use a diffe
ent port number).

4 Click Add.

To remove a server:

1 Select the server from the Servers list.

2 Click Remove.

To change a server address:

1 Select the server from the Servers list.
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2 Enter the new IP address in the IP Address field.

3 Click Apply.

If you are using StreamWorks on a LAN, see your LAN admini
trator about changing the Port number and the firewall option.

Button Settings
The Buttons Settings dialog enables you to customize the butt
that appear in the StreamWorks window.

Button Settings Dialog

To change the button action:

1 Click on the button you want to change.

2 Click the Select Server option button and select the name of th
server to which you want the button to connect.

Note: The Select Live Stream option applies to LANs; refer to yo
LAN administrator for assistance.

To change the button graphic:

1 Click on the button you want to change.

2 In the Button Bitmap text box, enter the path and file name of t
bitmap that you want to use as the button graphic. Alternatively
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click on Browse and locate the bitmap that you want to use; wh
you click OK in the Browse dialog, the correct path and file nam
will be filled in.

Click OK when done with the Buttons settings dialog.

Exiting StreamWorks

To exit StreamWorks, click the Exit button in the main window

CheckFree Wallet
Checkfree Corporation’s CheckFree Wallet provides you with a
cure way to pay for products and services with your credit card
over the Internet. The commercialization of the Internet—of th
World Wide Web in particular—is one of the factors most resp
sible for the explosive growth of the Internet, but it could not ha
happened without the development of secure financial transac
technology like that used by CheckFree Wallet.

CheckFree maintains a list of the Web sites that accept Wallet
transactions at www.checkfree.com.

Note: CheckFree Wallet Version 1.0.0 is not compatible with Win-
dows 95.

Creating a Persona (Wallet)

With CheckFree Wallet you create a “persona”—consisting of 
identification code, a password, and some other security inform
tion—that is associated with a “wallet.” Once you “put” one or 
more credit cards in your wallet, you can use your credit cards
purchase products or services sold on the Internet. You can cr
separate wallets that use the same credit cards (for different m
bers of the family, for example), or put several credit cards in o
wallet.

When you create a persona, you provide credit card informatio
that CheckFree authenticates with the bank that issued the cre
card. All of the information in your wallet—your identity code an
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your credit cards—is encrypted and stored on your hard disk. (
the curious, the encryption method used is an RSA Data Secu
licensed, 768-bit, dual-key encryption scheme.) A backup copy
your security information is also stored on a floppy disk when y
change credit card information or your password. 

Creating additional personas differs slightly from creating your
first persona. The procedure for adding personas is presented
in this section, after the procedure for shopping with CheckFre
Wallet.

To create a persona:

You will be asked to inset a floppy disk during this procedure, f
storing a backup copy of your security and credit card informati
Have a floppy ready, preferably one that you will not use for an
other purpose, before you begin.

1 Start CheckFree Wallet by clicking on its icon in the program 
group where you installed it.

2 The first time you run CheckFree Wallet, a User License windo
displays. Read the license information and click the I Agree bu
ton. The Welcome dialog displays.

Welcome dialog

3 Click New. The first time you run CheckFree Wallet, you are 
asked if you are using a proxy server (such as a firewall server
connect to the Internet. Click No, if you are not using a proxy 
server.
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Note
If you are using a proxy server, click Yes. The Proxy Settings d
log displays. Enter the Proxy Name and Port Number in the are
provides, then click OK.

4 CheckFree Wallet dials your ISP, if you are not already online,
and connects to the CheckFree server. The first time you run 
CheckFree Wallet, a User Agreement window displays. Be sure
read the important information about your CheckFree Wallet pa
word, as well as the rest of the Agreement. Click the I Agree bu
ton.

5 The first time you run CheckFree Wallet, a preliminary New Pe
sona dialog displays explaining what information you need to p
vide in the course of setting up a wallet

. 

New Persona dialog

Click OK. The second New Persona dialog displays.

New Persona dialog
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6 Enter a Persona ID of at least six characters (such as your  firs
last name) and  your e-mail address. In the Language drop-do
list, US English is the only choice at this time. 

Click OK. The Persona Password dialog displays.

Persona Password dialog

7 Enter a password consisting of at least six letters and numbers
spaces) in the Password field. It is best to avoid passwords der
from name or address information. You will need this password
anytime you want to buy something with your CheckFree Walle
Protect your password! Enter the same password a second time
the Confirm Password field. When done, Click OK.

8 CheckFree Wallet displays a Status message while it generate
your security keys. When done, CheckFree Wallet dials up you
ISP again. 

Note
If you get an error message, click Retry. It may take a couple o
tries if the CheckFree server is busy.

When your persona information has been processed by CheckF
the Persona Established dialog displays, with your assigned P
sona ID (this may differ slightly from what you entered in step 6
to make it a unique ID in CheckFree’s records).

9 Select a disk drive where you would like to make backup copies
your security keys. You should store this information on a flopp
disk. If you select a floppy disk drive, you are prompted to inser
disk in the drive. Click OK.
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10 A message appears telling you that the backup was successful. 
remove the floppy diskette and store it in a safe place. Click O

11 You are asked if you want to link a credit card to the persona y
just created. You must link at least one credit card. Click Yes. T
Link New Credit Card window displays.

Link New Credit Card window

12 Enter the following credit card information. Be sure what you 
enter in this screen is accurate.

Field Description

Credit Card Num-
ber

A graphic representing the credit card type
(Visa, MasterCard, etc.) appears based on t
first four digits of the credit card number, and
its name is selected in the pull-down menu
box beside the card number. If this card typ
is incorrect, you can select the correct type
using the drop-down list. (If  using America
Express, enter your Customer Identification
Number. This is the 4-digit, non-embossed
number above your account number.)

Expiration Date Be sure to use one of the formats indicated
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13 Click OK when the information is correct. Click Cancel if you d
not want to enter the persona information at this time. If you cli
Cancel, any information entered in the fields will not be saved.

14 When you click OK, the Link Credit Cards window displays, wit
commands for adding, modifying, and deleting cards.

Link Credit Cards window

If you needed to edit the credit card information that you entere
in step 12, you could click on the Modify Card button and return
the Link New Credit Card window. Or you could open a new Lin
New Credit Card window to add another card by clicking on the
Add card button.

Click Done. The new persona is encrypted and sent to CheckF
for confirmation.

Field Description

Card Description The description provides a way to attach 
unique names to your credit cards. This is e
pecially useful when you are using multiple
cards of the same type.

Street, City, State, 
ZIP code 

Enter this information exactly as it appears
on your credit card billing statement.

Country Code  No entry needed.

Area Code Enter you phone area code.

Phone Enter your phone number.
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Note: If you get an error message at this time, click Retry. The
CheckFree server may be busy.

15 When you see the message informing you the credit card has b
successfully linked to your persona, click OK. 

16 You are asked if you want to link another credit card. If so, clic
Yes and fill in the information in the second Link New Credit Ca
window. If not, click No. The Administration window appears.

Administration window (online version)

17 Click Exit to Main Menu.

18 To exit CheckFree Wallet, click Exit in the Main Menu window.

Note
When you are working offline (not connected to the Internet), 
choosing Administration in the Main Menu window displays a d
ferent Administration window:
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Administration window (offline version)

You can now use your CheckFree Wallet to purchases goods 
services on the World Wide Web.

Making Purchases

Although the terminology may differ from one Internet merchan
to another, all use some sort of shopping metaphor, such as a “s
ping basket.”

To make purchases:

1 When you are at a site that lets you make purchases online, cl
the appropriate buttons or links to add items to your “shopping
basket.” All merchants provide some kind of list of what is cur-
rently in your shopping basket, so that you can see the total am
at any time, including any tax and shipping and handling charg

2 When you are ready to pay for your purchases, click the “Purch
Items in Shopping Basket” link (or the equivalent). During the p
chase process, your CheckFree Wallet will automatically be ac
vated and appear on your screen.

3 Enter your CheckFree Wallet password. CheckFree Wallet dis
plays a Request For Payment page with a list of accepted cred
cards that are configured in your CheckFree Wallet. (If any cre
card in the wallet is not accepted by the merchant, it is “disable
for use.) 
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4 Select the credit card you want to use. When you click on the 
credit card name, the encrypted account information stored on
your system is sent to the merchant’s transaction processing s
tem, which sends it to CheckFree, along with the “bill.” CheckFr
validates the encrypted account information and sends an auth
zation for payment back to the merchant, who then prepares y
order.

6 Finally, payment confirmation is sent and you can see a list of 
your purchases.

That’s all there is to it!

Adding and Deleting Credit Cards
You add or delete credit cards linked to a wallet using the Cre
Cards command in the Administration window, as follows.

Note
You must be online to change credit card data in existing walle
You cannot use the Administration window that displays when y
are working offline for changing credit card information.

To add or delete a credit card in a wallet:

1 Start CheckFree Wallet. The Login window displays.

Login window

2 Choose the wallet (persona) whose cards you want to change f
the drop-down list, if you have set up more than one wallet.
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3 Enter your password.

4 Click OK.

5 When CheckFree Wallet connects to the Internet, the Main Me
window displays.

6 Click the Administration button. The Administration window dis
plays.

7 Click the Credit Card button. The Link Credit Card window dis-
plays.

8 To delete a card, select the card from the list and click Delete, t
Done.

If you want to add a card, click Add Card. The Link New Credit
Card window displays. Then follow steps 12-16 of the Creating
Persona procedure (see page A-43) to enter the card informati
register the card with CheckFree, and exit the program.

Creating Additional Personas
You can create multiple personas, or wallets. Different wallets c
contain the same credit cards or different ones. 

To add a persona:

1 Start CheckFree Wallet. The Login window displays.

2 Click Administration. An abbreviated Administration window dis
plays.

3 Click New Persona.

4 When the New Persona window displays, follow steps 6-18 of 
Creating a Persona procedure (see page A-43).

Changing a Password
If for any reason you feel it is necessary to change a persona’s pa
word, use the following procedure. Before you begin, however
you need to have two floppy disks available to back up the upda
Persona and data files that will be encrypted with your new pa
word. 
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Note
The Administration window that displays when you are workin
offline does not provide access to the change password functi

To change a persona’s password:

1 Start CheckFree Wallet. The Login window displays.

2 Choose the persona (wallet) whose password you want to cha

3 Enter your current password.

4 Click OK.

5 When CheckFree Wallet connects to a CheckFree server, the M
Menu window displays.

6 Click Administration. The Administration window displays.

7 Click Change Password. The Change Password window displa

Change Password window

8 Enter your current password, the new password, and the new 
word again. Then click OK. 

9 You are returned to the Administration window.

10 Click Exit to Main Menu.

11 In the Main Menu window click Exit.
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Using the Pending Transactions List

Transactions that have not been completed or sent to CheckFre
one reason or another can be viewed in the Pending Transact
list and retried.

Note
You must be offline (not connected to the Internet) to access the 
Pending Transactions list.

To open the Pending Transactions list:

1 Start CheckFree Wallet.

2 When the program starts dialing to connect to the Internet, clic
Cancel.

3 Click OK in the message dialogs that appear, until you see the
Login window.

4 Click Administration. The Administration window displays.

5 Click Pending Transactions. The Pending Transactions window
displays.

Pending Transactions window

6 Select a transaction by clicking on it with the mouse.

7 You can view the transaction details (Detail), cancel the transa
tion (Cancel Entry), or send the transaction to CheckFree again
(Retry Entry). 

8 When finished with the Pending Transactions window, click Do
to return to the Administration window.

9 Click Exit to Main Menu.
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10 In the Main Menu, click Exit.

Viewing the Transaction Log
All transactions involving CheckFree are kept in the Transactio
Log for you to review.

To open the Transaction Log:

1 Start CheckFree Wallet. The Login window displays.

2 Choose the persona (wallet) whose password you want to cha

3 Enter your current password.

4 Click OK.

5 When CheckFree Wallet connects to the Internet, the Main Me
window displays.

6 Click Administration. The Administration window displays.

7 Click Transaction Log. The Transaction Log window displays.

Transaction Log

8 To view the details of a transaction, select the transaction by cl
ing on in with the mouse, then click Details. When done, click O
to return to the Transaction Log.

9 Click Done to return to the Administration window.

10 Click Exit to Main Menu.

11 In the Main Menu, click Exit.
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Restoring Data

If you ever need to restore your encrypted security keys and d
files to your hard drive, use the following procedure.

Note
The follow steps assume that you want to restore data without 
necting to the Internet (that is, while you are offline). However, t
Restore Data from Disk command is also available in the Adm
istration window that displays when you are online.

To restore data:

1 Start CheckFree Wallet.

2 When the program starts dialing to connect to the Internet, clic
Cancel.

3 Click OK in the message dialogs that appear, until you see the
Login window.

4 Click Administration. The Administration window displays.

5 Click Restore Data from Diskette. The Restore Data Files dialo
displays.

Restore Data Files dialog

6 Choose one or both of the options provided: Persona and Sec
Keys, and Other data Files.

7 Select the appropriate drive letter for the Source Drive.

8 Click OK.
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Changing Software Options

You can change or set various options using CheckFree Walle
Software Options window, as explained next.

To access the Software Options window:

1 Start CheckFree Wallet. The Login window displays.

2 Choose the persona (wallet) whose password you want to cha

3 Enter your current password.

4 Click OK.

5 When CheckFree Wallet connects to the Internet, the Main Me
window displays.

6 Click Administration. The Administration window displays.

7 Click Software Options. The Software Options window displays

Software Options window

8 The following options can be set in this window:

Field Description

Time Out Sets the number of seconds CheckFree W
let will wait with no ISP response before tim
ing out and redialing.

Retries Sets the number of times CheckFree Walle
will redial the ISP to attempt a connection.
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9 When done, click OK, to return to the Administration window.

10 Click Exit to Main Menu.

11 In the Main Menu, click Exit.

VR Scout
Chaco™ Communication’s VR Scout is your doorway to the 
worlds of three-dimensional (3-D) virtual reality on the Web. VR 
Scout is Net Commander’s helper application for playing VRML—
Virtual Reality Modeling Language—files. With the keyboard o
the mouse you can move through 3-D scenes and jump from one 
scene to another.

To set up VR Scout as a helper application in Enhanced Mosaic
fer to “Configuring Helper Applications” ( page 4-36). To set up
VR Scout as a helper application in Internet Explorer, refer to “A
sociating Applications with File Types” (page 5-30). The  config
ration information you will need is as follows:

• MIME type: x-world/x-vrml

• extensions: .wrl

• helper: <path>\vrscout.exe

VR Scout may also be used as a stand-alone application; you d
have to be using a Web browser to play VRML files. Before yo
can use VR Scout to play files that are located on the Internet, h

Field Description

HTTP Proxy Sets the name of a proxy HTTP server.

Proxy Port Sets the port number of the proxy server,

Ask for Password 
When Paying With 
a Credit Card

Determines whether or not a password is re
quired when using a CheckFree Wallet cred
card to pay for a purchase.

Show Alert Before 
Submitting Trans-
actions When 
Working Offline

Determines whether or not an alert messag
appears when you choose the Retry Entry 
command in the Pending Transactions win
dow while working offline.
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ever, you do need to be connected to the Internet. If you do no
want to launch Enhanced Mosaic or Internet Explorer, use the C
nect program in Windows 3.1 or the Dial-Up Networking progra
in Windows 95 to establish a connection to the Internet before 
ning VR Scout.

Playing VRML Files

This section includes instructions for playing VRML files both 
with and without a Web browser running.

To display a VRML scene in a Web browser:

Click on the VRML link (the extension of the file will typically be
“wrl”). If you have configured Enhanced Mosaic or Internet Ex-
plorer to use VR Scout to read wrl files as described above, the
Scout main application window opens and the scene is loaded
VR Scout.

VR Scout main window

The VR Scout tool bar provides one-click access to the followi
features.
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VR Scout Tool Bar

To use VR Scout as a standalone VRML player:

1 Double-click the VR Scout icon in the program group where yo
chose to install it. The main VR Scout window displays.

2 Choose the Open Location command from the File menu.

3 Enter the URL in the text entry box and click Open. The scene
loaded into VR Scout.

Moving in a Scene
To move around in a VRML scene, you use the mouse or the ar
keys, in combination with the Shift and Ctrl keys. While the tab
below can provide a quick reference for the different movemen
controls for you, the best way to learn how to navigate a scene 
experiment—in other words, play! If you get “lost,” you can al-
ways return to your starting point by choosing the Reset Came
command from the View menu.

There are three “movement modes” you can choose for movin
scenes, as explained below. To select the mode you want, use
tool bar or the View menu.

• Walk  - When you are walking in a scene, you remain on the
same plane (think of it as the floor) wherever you go. You ca
walk around, toward, and away from objects in the scene, a
you can look up and down. But you cannot walk “over” or 
“under” objects. However, you can raise or lower the “floor”—
the plane you are standing on.

• Fly - When you are flying in a scene, it is as though you were
an airplane. But not only can you fly forward and turn left an

Go back.

Go forward.

Go to 
home page.

Examine mode.

Open URL. Fly mode.

Walk mode.

Stop loading.

Context-sensitive
help cursor.
A-60, Helper Applications

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Moving in a Scene
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

 
m 

gh 
 to 
 
. 
-

ding 
ow-
right, you can also “hover” and fly backward. In flying mode,
you can move over and under objects, as well as around the
(depending on the scene’s design).

• Examine - This mode is used for examining objects, as thou
you were holding them in your hand and turning them around
look at all sides. In examine mode, the mouse and keyboard
controls move objects, and not your position relative to them
(Well, it’s all relative; you could just as well say you are mov
ing around an unmoving object in examine mode.)

The keyboard and mouse controls have different effects depen
on which viewing mode you have selected, as shown in the foll
ing table.

Normal Shift+ Ctrl+

Walk mode:

left arrow, or 
drag mouse
left

turn left shift position 
left

right arrow, or 
drag mouse 
right

turn right shift position 
right

up arrow, or 
drag mouse
forward

walk forward shift position
up

look up

down arrow,
or drag mouse 
backward

walk
backward

shift position 
down

look down

Fly mode:

left arrow, or 
drag mouse
left

turn left shift position 
left

tilt left

right arrow, or 
drag mouse 
right

turn right shift position 
right

tilt right
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Using the Headlight

When you are in a scene, think of having a “miner’s lamp,” or 
“headlight,” on your forehead, to light up the scene in the direct
you are facing. You control the brightness of the headlight. If a
scene seems too dark, trying making your headlight brighter.

To brighten the headlight:

• Choose Brighter from the Options menu. For a shortcut, sim
press and hold the Ctrl key while you press the B key (for 
“brighter”). You can repeat this until you get to the desired 
brightness level.

Normal Shift+ Ctrl+

up arrow, or 
drag mouse
forward

fly forward shift position
up

look up

down arrow,
or drag mouse 
backward

fly backward shift position 
down

look down

Examine 
mode:

left arrow, or 
drag mouse 
left

turn left shift position 
left

roll object 
to the left

right arrow, or 
drag mouse 
right

turn right shift position 
right

roll object 
to the right

up arrow, or 
drag mouse
forward

move toward 
object

shift position
up

roll object 
upward

down arrow,
or drag mouse 
backward

move away 
from object

shift position 
down

roll object 
downward
A-62, Helper Applications

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 



Changing Movement Speed
 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

ply 
m-
-

ired 

 a 
 drag 

y-
, 
ey 

ey-
 
ey 
To dim the headlight:

• Choose Dimmer from the Options menu. For a shortcut, sim
press and hold the Ctrl key while you press the D key (for “di
mer”). You can repeat this until you get to the desired bright
ness level.

To set the default brightness of the headlight:

1 Choose Preferences from the Options menu.

2 Click on the 3D Graphics tab, if it is not already the front tab.

3 In the Headlight section, slide the Brightness control to the des
level.

4 Click OK when done, to close the Preferences dialog.

Changing Movement Speed
You can increase or decrease the speed of your movements in
scene. This amounts to changing the size of each “step” as you
the mouse or use the arrow keys.

To increase movement speed:

• Choose Move Faster from the Options menu.

For a shortcut, simply press the + (plus) key on the numeric ke
pad (with Num Lock turned off). Each time you press the + key
speed is increased by a certain amount. You can press the + k
repeatedly, until you find the desired speed.

To decrease movement speed:

• Choose Move Slower from the Options menu. 

For a shortcut, simply press the - (minus) key on the numeric k
pad (with Num Lock turned off). Each time you press the - key,
speed is decreased by a certain amount. You can press the - k
repeatedly, until you find the desired speed.

To find links to 
sample files that 
you can experi-
ment with, visit 
the Chaco Com-
munications home 
page at http://
www.chaco.com.
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Using Different Cameras

A scene can be constructed with several different cameras, or view-
points for viewing the scene. If the scene you are looking at ha
multiple cameras, the following Camera items are enabled in t
View menu:

• Camera submenu - Displays a list of cameras. Select the cam
view you want from this list.

• Next Camera - Shifts the viewpoint of the scene to the next 
defined camera.

• Previous Camera - Restores the viewpoint of the previously
selected camera.

To get back to your starting point in a scene:

• If you get lost in a scene, choose the Reset Camera comman
the View menu. You are returned to your initial position in th
scene.

Configuration Settings

VR Scout’s Preferences dialog allows you to change the defaul
D graphic display settings, select a default starting page, and ad
cache settings.

To open the Preferences dialog:

• Choose Preferences from the Options menu.

The following sections describe the settings on each of the Pre
ences pages.

3D Graphics
Click on the 3D Graphics tab to access the 3D graphics settings.
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3D Graphics Settings

The following table explains each of the available 3D graphic s
tings, except the Headlight Brightness control (see “Using the 
Headlight” on page A-62 for a description of that control).

Field Description

AsciiText Quality Choose High, Medium, or Low. The higher
the setting, the more pixels are used to dra
text characters. This produces better-lookin
text but consumes more memory.

Movement mode Choose Walk, Fly, or Examine as the defa
movement mode for VRML files. These set
tings are also found in the View menu. (Se
“Moving in a Scene” on page A-60.)

Override scene 
movement mode

Some VRML files have a pre-set initial 
movement mode. Turn on this option if you
want to always override the scene’s specifie
movement mode.

Draw a line when 
using the mouse

Turn on this option to draw a line on the 
screen when you click and drag the mouse
move in Walk or Fly mode. The line starts a
the point you clicked and extends to the cu
rent mouse position.
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Home Page
Click on the Home Page tab to access the Home Page setting
tering a URL or local file name in the Home Page text entry bo
makes that file the one that is displayed initially when you start V
Scout in standalone mode.

Cache
Click on the Cache tab to access the Cache settings.

Cache Settings

Field Description

Collision checking The Forward setting turns on detection of co
lisions with objects in front of you as you 
move in a scene. To turn off collision detec
tion, choose None from the drop-down list.

Override scene col-
lision checking 
mode

Some VRML files pre-set the collision detec
tion mode. Turn this setting on if you want t
always override the file’s setting with the on
that is visible in the Collision Checking list.

Sound on collisionTurn on this setting to play a sound file whe
ever a collision is detected. The default soun
is the Windows “Exclamation” sound.
6, Helper Applications
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The cache is a directory on a local hard drive where VRML file
that have been downloaded from the Internet are stored. A cach
lows for faster retrieval of files that have been downloaded wh
you want to return to them after viewing other files. When the s
limit of the cache has been reached, the oldest cached file is del
when a new file is added to the cache. The following table expla
each of the available cache settings.

Additional Features
Open File (File menu)
Use this command to open VRML files that are on your local dr
or on your local network.

Save As (File menu)
When you save a scene using the Save As command, only the
VRML text is saved. Any other files, such as bitmaps, that hav
been added to the scene are not saved with the VRML text.

Reload (View menu)
If your are viewing a file that is being updated continually on th
remote server, this command reloads the file in its current stat

Field Description

Disk__Kilobytes Specifies the size of the cache, in kilobytes
To change the cache size, enter a different
number in the text entry box.

Disk Cache Specifies the full path to the directory wher
cached files will be stored. To change the l
cation of the cache, enter a different directo
path.

Verify Documents Specifies how often you want VR Scout to 
compare a file retrieved from the cache wit
the current version of the file on the Interne
only the first time during a session, always, o
never.

Clear Cache Click this button to delete all files from the 
cache directory.
Helper Applications, A-67
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VMPEG
Installing VMPEG enables the Microsoft Windows Media Player 
to play back MPEG files (also referred to as “streams”). The 
VMPEG setup program adds VMPEG MPEG Player to the list of 
playback devices in the Media Player Device menu. (For inform
tion on using Media Player, refer to your Windows manual or t
Media Player’s extensive online help.) 

Media Player Device Menu with VMPEG Added

You should verify that Enhanced Mosaic or Internet Explorer is
configured to launch Media Player (mplayer.exe) to play MPEG
type files when you click on an MPEG link on the Web. To set 
VMPEG as a helper application in Enhanced Mosaic, refer to 
“Configuring Helper Applications” ( page 4-36). For Internet Ex
plorer, refer to “Associating Applications with File Types” (pag
5-30). The following configuration information applies to MPEG
files: 

• MIME Type: video/mpeg

• Extensions: mpg .mpeg

• The helper application should be MPLAYER.EXE.

If you prefer to have your browser launch VMPEG instead of M
dia Player to play MPEG files, the helper application should be
VMPEGWIN.EXE.

Tip: For command-line parameters to use with vmpegwin.exe, 
“Loading an MPEG Stream” in VMPEG’s online help.

To locate some sample MPEG files to try out Media Player or 
VMPEG, go to your favorite search site on the Web and enter 
“MPEG archive” or “MPEG library” (without the quotation marks
in the Search text box.
8, Helper Applications
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To play MPEG files while browsing the Web:

1 Click on the MPEG link. 

The Media Player main application window and video window 
open.

Click on the Play button when it is enabled.

Playing MPEG Files with VMPEG
Once VMPEG is installed, you can use either Media Player or 
VMPEG in standalone mode to play back MPEG files that you
have downloaded and stored on you system. This section expl
how to use VMPEG in standalone mode. For help with Media P
er, see your Windows manual or Media Player’s online help.

Note: VMPEG does not have Media Player’s “slider control” fea
ture for accessing any point in an MPEG file.

To play back MPEG files with VMPEG:

1 Double-click the VMPEG icon in the program group where you
chose to install it. 

Note: The first time you run VMPEG (if you installed the WinG 
library during the setup procedure), a test screen displays for a
minutes while WinG is optimized for your display. 

The main VMPEG window and an empty video window display
Helper Applications, A-69
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VMPEG windows

2 Choose Open from the File menu. The standard Open dialog d
plays.

3 Find the file you want to play.

4 Click OK in the Open dialog.

5 Click the play button to start the playback in the video window.

Tip: If you associate files that have the extension “mpg” with 
VMPEGWIN.EXE in File Manager or Windows Explorer, you ca
play MPEG files by double-clicking them in File Manager or Wi
dows Explorer.

The following keyboard equivalents are available for the playba
buttons:

F5 - Stop
F6 - Play
F7 - Pause (freezes current frame)
F8 - Step (steps through frames in Pause mode)

Stop Play Pause Step 
forward.
0, Helper Applications
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Setting Video Options

To access VMPEG’s video configuration options, choose Video 
from the Configuration menu. The Video Configuration dialog d
plays.

VMPEG Video Configuration dialog

Display Options
The Display options are listed in increasing order of color reso
tion. The Gray(scale) and 8-bit color settings will be faster than
bit color. You can experiment with different settings, but 8-bit (t
default) is usually the best choice. The 8-bit 4x setting doubles
height and width of the video display.

Frames Options
The Frames options control which frames get skipped during p
back to achieve the desired playback quality. Sync (the defaul
required for synchronized video and audio. The Sync I/P optio
may provide smoother playback. The fps option lets you manua
control the number of frames per second (from 1 to 60).

Disable Graphics Interfaces
These options allow you to turn off graphics interface that do not 
function properly on your system, or optimize playback speed v
sus quality.

Refer to VMPEG’s online help for additional information about th
video configuration.
Helper Applications, A-71
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Setting Audio Options

To access VMPEG’s audio configuration options, choose Audio 
from the Configuration menu. The Audio Configuration dialog d
plays.

VMPEG Audio Configuration dialog

Changes in audio configuration options take effect only after th
next Play command.

Audio
Turn audio off or on.

Bits/Sample
You need to choose the 8 Bit option only if your sound card do
not support 16-bit waveform data. Otherwise, set this option to
Bit.

Sample Rate
22 kHz provides better quality but may result in slower playbac

Precision
These options refer to the decoding arithmetic used. Choose F
if you system uses a 486 CPU. Choose Float if you have a Pen
CPU.

Channels
Choose the channel through which you want to play back mult
channel audio.

Volume
Use these options to correct for distortions in audio playback.
2, Helper Applications
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Refer to VMPEG’s online help for additional information about
the audio configuration.

Advanced Features

VMPEG provides two diagnostic dialogs pertaining to playbac
performance and characteristics of the most recently played MP
stream. These dialogs can be accessed from the following He
menu commands:

• Stream Info

• Performance Stats

Refer to VMPEG’s online help for additional information about
the information displayed in these dialogs.

Exiting VMPEG

To exit VMPEG, choose Exit from the File menu. The main app
cation window and the video window are closed.
Helper Applications, A-73
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Address
The location of a computer or document (graphic, file, etc.,) on the Internet. Eac
ternet computer has a unique IP Address. Each file or document has a unique U
dress. Every person has a unique e-mail address.

Anonymous FTP
Allows you to log on to an FTP computer without using a unique password or lo
ID for file transfers only. Instead you use the word “anonymous” as the user ID 
your e-mail address as your password.

Archie
A software program allowing you to search, view and retrieve public domain file
from FTP hosts. There are more than 1,000 Archie sites on the Internet.

Baud rate
Measures the rate by which a modem converts signals into sounds allowing the
be sent over an analog telephone system.

Binary file
A file that contains characters other than standard ASCII characters. You cannot
binary files (and make since of them). For example, all executable programs are b
files.

BinHex
Allows a Macintosh to encode a binary file into an ASCII text file so the file can 
send via e-mail.

Bit
Binary digit. This is the primary computer unit of information. A bit is either 1 or 

BPS
Bits per second. The measurement of the data transfer rate of a computer netw
modem (how fast information is transferred).

Bookmark
A method for marking sites or documents to allow for easy return. 

Byte
The smallest addressable unit in a computer. A byte consists of eight bits.

Case-sensitive
Able to distinguish between uppercase (capital) letters and lowercase letters.
G-2, Glossary
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Client
A program that requests services from another computer (the server). For exam
Gopher is a “client” used to contact Gopher servers while Super Mosaic is a “cl
for the WWW.

Connection
The physical link between two computers on a computer network where both com
ers are then ready to exchange information.

Database
An organized collection of information on a single topic or group of related topic

Directory
A method for organizing files hierarchically under a common directory name.

Download
Transfer a file from a host computer to your computer’s hard disk using your mo

Extension
One to three characters that are added after a period to a file name to help clar
type of information contained in the file.

Finger
A client application that lets you obtain a list of users currently logged onto your 
system. 

FPS
Frames per second. A measure of video transmission speed.

FTP
File Transfer Protocol. Used to upload/download Internet files.

Gopher
A software client program that allows you to locate, view and retrieve informatio
from a Gopher information server.

Gopherspace
The searchable computer space on worldwide Gopher servers.

Graphics Interchange Format (GIF)
Graphics format widely used to exchange graphic files. GIF files are stored usin
.GIF extension and are compressed to improve transmission speed.
 Glossary, G-3
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Header
The portion of an e-mail message or UseNet posting containing the sender’s an
cipient’s addresses and subject matter.

Home page
The default page for a World Wide Web site, corporate site or personal user site
home page usually tells you where you are at, provides a brief description of wha
be found at the site, and provides the links to access the site’s available information

Host
Any end user computer system that connects to a network. 

Hot List
A Super Mosaic file allowing you to store favorite WWW sites or documents for e
future access. 

HTML
HyperText Markup Language. A set of markup tags used to write documents on
World Wide Web.

HTTP
HyperText Transport Protocol. This protocol makes browsing the World Wide W
possible by clicking on links that are established in a Web document and moving
to that document, even though it may be located on another computer.

Hypermedia
Provides the ability to integrate text, sound, graphics, or video in a single docum

HyperText
Data which provides links to other items in the same document or in other docum
allowing you to move through information in a non-sequential fashion.

IP Address
A unique Internet address. This is a 32-bit address containing a host component
network component that identifies the location of an Internet host.

Internet Relay Chat (IRC)
A real time, multi-user client program that allows you to talk (or chat) with other
ternet users interactively on a variety of subjects.

ISP
Internet Service Provider (such as Portal) who provides access to the Internet.
G-4, Glossary
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Kbps
Kilobits per second. A measure of data transmission speed.

MIME
Multipurpose Internet Mail Extension. A standard protocol for sending multimed
file types by e-mail.

Network
A network is the method by which computers share information with each other
These may consist of a local area network (LAN) connecting up to about 100 com
ers located in a relatively confined area or a wide area network (WAN) connect
computers over larger (even worldwide) distances.

Newsgroups
A UseNet discussion group on a particular topic. Over 11,000 newsgroups curr
exist on the Internet.

Packet
Basic unit of Internet data. Files are assembled into packets, each marked with 
dress of where it is going. Once all packets arrive at their final destination, they
reassembled in their original format.

PPP
Point-to-Point Protocol. A method for exchanging data packets on the Internet o
telephone line.

Post Office Protocol (POP)
Provides a means for storing incoming e-mail messages until you log on and dow
them to your computer.

Protocol
Defines how computers communicate. A protocol is an agreement between diff
systems on how they will work together.

Read only
Ability to read a document but not to change it.

Router
A computer that determines which path Internet traffic will use to reach its destination.

Server
A computer that provides a resource on the network. Client programs access se
to obtain data.
 Glossary, G-5
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Service provider (ISP)
An organization that provides Internet access or communication links.

SLIP
Serial Line Internet Protocol is a software program used by a dialer to tell your c
puter how to communicate with another computer. 

TCP/IP
Transmission Control Protocol (TCP) and Internet Protocol (IP) are software for 
aging Internet data packets on your computer.

Telnet
An Internet protocol that allows you to log on to a remote computer.

Terminal emulation
Communication with a remote computer where your computer acts as a termina
nected to the remote computer.

Thread
A topic or subject in a newsgroup that has received one or more follow-up postings.

URL
Uniform Resource Locator. The Internet address which specifies the exact locati
a service or document on the World Wide Web.

UseNet
A worldwide network of newsgroups covering thousands of topics.

WhoIs
Software application that lets you display information about other Internet users
G-6, Glossary
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