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What's New in Version 1.1?

Faster File I/O

The speed of the file input/output (especially the file reads) has been considerably improved. You will see 
an order of magnitude performance improvements (up to 10 times faster disk reads, especially of large 
files)!

User-Configurable Tools

A new Tools menu contains entries you can define to launch frequently used external programs. You can 
launch both DOS and Windows programs simply by selecting a user-defined menu item. You can define 
these menu items via Options|Tools.

Launching Other Programs

For programs that you would like to launch only occasionally, there is a new Tools|Execute command that 
opens the "Execute Program" dialog box. You can browse through your files and directories in search of 
the program to execute. The box remembers last few programs launched for easy recall.

Running the SETUP Program

The new Tools menu has a Setup command to conveniently launch the Code-A-Line SETUP used to 
install the software. Being able to install the registered version of the program is now just a mouse click 
away...

Improved Line Editor

The line editor (activated by double clicking on a text line) has been improved to perform faster and more 
smoothly. When you double-click, the edit caret lands where the mouse cursor is, not - like previously - 
always at the beginning of the current line.

Improved Appearance

There have been numerous improvements to the overall appearance of the program. You will find the 
visual elements more consistent throughout Code-A-Line, with the now-standard "gray" 3-D look. Notice, 
that the gray 3-D look is built-in and does not depend on any external files to be present on your system. 
CODE.EXE is still self contained, i.e. easy to use and manage!

Resizeable "Common" File Dialogs

All standard file-management dialog boxes ("Open File", "Save File As...", "Execute Program", etc.) are 
now vertically resizeable. 

Ever wondered why, given all the 'real estate' on your display courtesy of your new high-resolution video 
card, with most applications you are still limited to those short standard file dialog boxes that Windows 
provides by default?

Now you can resize Code-A-Line's file dialogs to take full advantage of your screen resolution without 
losing the uniform look-and-feel of the standard dialogs. View lists of files and directories almost as long 
as the entire screen.

Selecting All Lines

A convenient way of selecting all lines in the current file has been added. Choose Edit|Select All, or press 
Shift+* to select all lines at once.



Quick Menu

You can now get access to the most frequently used commands by clickig the right mouse button. A 
convenient "quick menu" will appear, from which you can select commands. (All of these commands are 
also accessibe via the regular menu).



Code-A-Line Procedures
General

Exiting the program...
Undoing the effects of commands...
Running external programs...

File Management
Creating a new file...
Opening an existing file...
Saving a new file...
Saving an existing file...

Printing
Selecting a printer...
Printing a file...
Setting up printer parameters...

Navigation & Selection
Jumping to a given page...
Jumping to a given line...
Selecting a range of lines...
Selecting all lines...

Outline Expansion and Contraction
Expanding one level...
Deeply expanding a line...
Collapsing a heading...
Expanding all headings...
Collapsing all headings...

Editing
Inserting new lines before the current...
Adding new lines after the current...
Editing existing lines...
Deleting lines...
Moving a line up...
Moving a line down...
Promoting a line...
Demoting a line...
Indenting a line...

Searching
Finding text...
Replacing text...

Clipboard
Cutting lines to the clipboard...
Copying lines to the clipboard...
Pasting outline fragments from the clipboard...

Customization
Customizing colors...
Selecting page elements to print/display...



Choosing fonts...
Defining dimensions/layout...
Defining end-of-line markers
Defining tabs...
Defining file filters...
Using external tools...
Configuring theTools menu...
Saving existing configuration...
Saving a new configuration...
Opening an existing configuration...

Administrative
Contacting Optimax...
Registering the program...
Obtaining support...
Upgrading to a later version...



Keyboard Shortcuts
Key Action

Ins Insert a blank line before the current position.

Enter Add a new line after the current position.

Ctrl-Enter Add a new line after the current position and indent it one 
level.

Shift-Enter Add a new line after the current position and undintent it 
(promote) one level.

Del Delete the currently selected lines, but not any unselected 
children of the selected lines.

Ctrl-Del Delete the currently selected lines and any children of these 
lines.

Esc Line editing mode only:
Terminate line editing mode, canceling any changes made to 
the line.

Space,
Any character

or digit

Activates the line editor.

Plus (+) Expand the currently selected lines one level.

Minus (-) Collapse the currently selected line or lines.

Ctrl-Plus (+) Completely expand the selected lines only, but no other lines.

Asterisk (*) Fully expand all lines in the outline.

Slash (/) Collapse all lines.

Up-Arrow Move the highlight bar or editing caret one line up.

Dn-Arrow Move the highlight bar or editing caret one line down.

Shift-Up-Arrow Extend the selection of lines up by one.

Shift-Dn-Arrow Extend the selection of lines down one line.

Ctrl-Up-Arrow Move the selected (current) line one position up.

Ctrl-Dn-Arrwo Move the selected (current) line one position down.

Left-Arrow,
Shift-Tab

Promote the currently selected lines, if possible.

Right-Arrow
Tab

Demote the currently selected lines, if possible, along with all 
their selected and unselected children.

Ctrl-Right-Arrow
Ctrl-Tab

Indent, if possible, the selected lines, but not the unselected 
children of the selected lines.

Home Move the highlight bar to the first visible line.

End Move the highlight bar to the last visible line.

Page Up Scroll the visible outline one page up.

Page Down Scroll the visible outline one page down.



F1 Display help.

F2 Save current file.

F3 Open an existing file.

F4 Find text.

F5 Find and replace text.

F7 Go to a specific line.

F8 Go to a specific page.



About Code-A-Line
Code-A-Line 1.1 Standard Edition (Shareware)
Copyright © 1994 Optimax Corporation. All rights reserved.

Code-A-Line is a Windows utility designed primarily for programmers, but also for all others who deal with 
information structured as ASCII text files. Code-A-Line has the functionality of three utilities in one:

Outline Processor
Text Editor
File Printing Utility

for Program Source Code and other ASCII Text files.

Code-A-Line provides numerous customization options, including the ability to change fonts and colors for 
any text display element. You can maintain several sets of customization options, via configuration files, 
fine-tuned for different purposes, such as viewing files on screen, versus printing, versus editing, versus 
presenting, etc.

Code-A-Line is not copy protected and you are encouraged to copy, and distribute the shareware 
evaluation version of this program, subject to the conditions described in the License Agreement. Please, 
make sure when distributing this program to others that the original CODE???.ZIP remains unchanged. 

If you upload this program to a bulletin board, please name the target file CODE11.ZIP.

See also:
Related Products



Outline Processor
As an Outline Processor or Browser, Code-A-Line allows you to only focus on the relevant portions of 
your program/file, while hiding all the unnecessary details from your view.

This helps you gain a better feel for the overall structure and layout of the program you are editing. You 
can seamlessly collapse and expand elements of the outline using your mouse or keyboard. 

There are no extraneous control marks placed in your file: Code-A-Line relies solely on the indentation of 
each line to build the outline structure. You can feed the file prepared with Code-A-Line directly to the 
compiler. 

The outline structure is truly (programming-) language independent, as there is nothing that relies on a 
particular feature of the programming language (such as comment delimiters).

Code-A-Line lets you easily indent or unindent selected portions of the file, move around and change the 
order of lines in the file, as well as break apart, or combine text lines. While any text editor can do most of 
these tasks too, Code-A-Line features a rich set of powerfull block- and outline-specific functions that let 
you keep things in perspective at all times.

See also:
Text Editor
File Printing Utility



Editor
As an Editor, Code-A-Line lets you maintain program source files. Combining the program's text editing 
function with the powerful outlining (un/folding) capabilities results in a versatile program editor on its own.

You can use the editor to restructure existing files, possibly to bring them to the layout standards of a true 
outline. Once converted, you can use Code-A-Line to continue editing, add comments, or print the files. 
Code-A-Line lets you easily edit, insert, move, cut and paste, etc., individual lines and contiguous block 
selections.

The editor is configurable, so that you can use any combination of available display colors, and any font 
available on your system.

See also:
Outline Processor
File Printing Utility



File Printing Utility
As a Text File Printing Utility, Code-A-Line allows you to print files while automatically (if you desire) 
adding headers with page numbers and directory information to permanently identify the file being 
printed: an ideal tool for printing program source code listings, for instance. 

Thanks to its powerful outlining capabilities, Code-A-Line lets you print only relevant portions of the file, 
while at the same time showing the context of what you print. Unfold only the lines that are of interest 
before you print. This not only saves paper, but also lets you concentrate on the important issues.

See also:
Outline Processor
Text Editor



Code-A-Line Family of Products
Code-A-Line 1.1 Standard (Shareware)
The program you are currently using or evaluating. Available as Shareware only. This is a Single 
Document Interface (SDI) Windows application featuring outlining, editing, and printing 
capabilities. You can edit only one file at a time (although you can launch several copies of Code-
A-Line simultaneously to edit multiple files, and cut and paste among them). There is a limitation 
on the size of (the maximum number of lines in) the file.

Code-A-Line 1.0 Professional Coming Soon!
A Multiple Document Interface (MDI) framework allowing you to manipulate multiple files 
simultaneously under one common application's 'frame' window. There is no limitation on the size 
of the file being edited. Sold as a commercial package only; not available as Shareware. 
Environmentally friendly edition: the package includes master software disk(s) with extensive 
online documentation, but no printed manual.

Code-A-Line 1.0 Complete Coming Soon!
This is a complete commercial package, with a printed manual and a program disk. The program 
is the same as the Professional Edition. A printed manual is provided along with the master 
program disk(s).

Please note that Optimax Corporation reserves the right to withdraw or change any of its offerings without notice at any time. If you 
pre-register for/pre-order any product not available at the time and we later decide to drop the product from our plans, you are 
guaranteed a full refund.

Related Topics:
Fee/Price Schedule



Program Limitations
Standard Shareware Edition

The Standard Shareware edition of Code-A-Line is not crippled or restricted in any way. We want you, the 
User to fully appreciate the capabilities of the program before you register. Below you will find a complete 
list of known limitations of the Standard Shareware Edition. These limitations result from the program's 
design and are not intended to "encourage" you to register. (They are also present in the registered 
version of the program.)

See Code-A-Line Family of Products for a list of other commercial (retail) programs that may offer 
different/enhanced features that may be of interest to you if Code-A-Line does not meet your needs.

1. There currently is a limit on the number of lines in a file that Code-A-Line 1.1 Shareware 
Edition can handle. This limit is about 8000 lines and results from the limitations on the 
maximum number of items in the standard Windows list-box control.

2. With Code-A-Line 1.1 Standard Shareware Edition you may edit only one file at a time. 
This is a Single Document Interface (SDI) Windows program (as opposed to MDI - 
Multiple Document Interface). Please note, however, that you can edit multiple files 
simultaneously by starting several copies of Code-A-Line under Windows.

3. The line length of a Code-A-Line 1.1 Shareware Edition file may not exceed 1023 
characters.

4. Code-A-Line 1.1 Shareware Edition is limited to reading plain ASCII text files. There 
currently is no import/export facility to read other file formats.

5. Code-A-Line 1.1 Shareware Edition cannot print in color. The color settings (Options|
Colors) affect only the display.



License Agreement
Code-A-Line 1.1 Standard Shareware Edition
Copyright © 1994 Optimax Corporation. All rights reserved.

This product is a Shareware computer program provided for evaluation only.

Users are granted a limited license to use and encouraged to make copies of and distribute this program 
for trial use by others, provided that the program and/or documentation are not altered in any way and 
that the entire original package (CODE??.ZIP) is being distributed together. Please encourage others to 
register their copy if they use it.

This software is protected by the United States Copyright Law, and also by international treaty provisions. 
It is NOT free and it is NOT in the public domain. Users of this product must register within 30 days after 
obtaining a copy of this program. Continued use of the software beyond the 30-day trial period constitutes 
a copyright violation.

The license to use this program is effective until terminated. You may terminate this license at any time by 
destroying all copies of this program and its documentation. It will also be terminated upon your failure to 
comply with any of the terms or conditions of this agreement. You must then immediately destroy all 
outstanding copies of the Software and documentation in your possession and/or under your control.

The single-user registration fee (see Fee Schedule) will license one copy for use on one computer at a 
time. You may run a single-user copy of Code-A-Line on different computers (for example, your main 
desktop unit, and a laptop), provided that there is no possiblity of it being used on two computers at the 
same time.

Both private and commercial users must register and pay for all their copies of Code-A-Line within 30 
days of obtaining this program or their license is withdrawn. Site-, and Network-License arrangements 
may be made by contacting Optimax Corporation.

THIS PROGRAM IS PROVIDED ON "AS IS" BASIS, WITHOUT ANY WARRANTY, EXPRESS OR 
IMPLIED, INCLUDING, BUT NOT LIMITED TO WARRANTIES OF MERCHANTABILITY, QUALITY, 
PERFORMANCE, OR FITNESS FOR ANY PARTICULAR PURPOSE.

IN NO EVENT AND UNDER NO CIRCUMSTANCES WILL OPTIMAX CORPORATION BE LIABLE FOR 
ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, CONSEQUENTIAL, OR ANY OTHER DAMAGES 
WHATSOEVER, INCLUDING WITHOUT LIMITATION DAMAGES FOR LOST PROFITS, LOST 
SAVINGS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE, 
ARISING OUT OF THE USE OR THE INABILITY TO USE THIS RODUCT, EVEN IF OPTIMAX 
CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Some jurisdictions do not allow exclusion or limitation of implied warranties or limitation of liability for 
incidental or consequential damages, so the above limitation or exclusion may not apply to you. In no 
event, however, shall Optimax Corporation's liability exceed the amount of the license fee paid upon 
registration. 

Whenever possible, each provision of this License Agreement shall be interpreted in such a manner as to 
be valid and effective under applicable law. If any provision is found to be unlawful or for any reason 
unenforceable, than that provision is shall be deemed severable from this Agreement and shall not affect 
the validity and enforceability of remaining portions of this License Agreement.

The conditions set forth above are exclusive and in lieu of all others, oral or written, express or implied. 
No Optimax distributor, agent, or dealer is authorized to make any modification or addition to this 



agreement.

Any commercial products, brands and trademarks mentioned belong to their respective owners.

See also:
How to register?
Why register?
About Shareware



About Shareware
This program is produced to the standards of the Association of Shareware Professionals.

Shareware is a form of marketing and distribution of computer software directly to users. Shareware 
distribution gives users a chance to try software before buying it. Shareware is NOT "free software".

If you try a Shareware program and continue using it, you are expected to register. Individual programs 
differ on details. We request that you register within 30 days of obtaining your copy. With registration you 
typically get the right to continue using the software, often (as in our case) accompanied by a number of 
other registration benefits (for a list of benefits offered to the registered users of Code-A-Line see Why 
register? section).

Copyright laws apply to both Shareware and other commercial software, and the copyright holder retains 
all rights, with a few specific exceptions as stated below. Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality. (In both cases, 
there are good programs and bad ones!) The main difference is in the method of distribution. The author 
specifically grants the right to copy and distribute the software designated as Shareware, either to all, or 
to a specific group. Some authors require written permission before a commercial disk vendor may copy 
their Shareware (We explicitly grant shareware vendors the right to copy and distribute Code-A-Line 
automatically, without their having to obtain any additional permissions, provided that certain conditions 
are met - see License Agreement for details).

Shareware is a distribution method, not a type of software. You should find software that suits your needs 
and pocketbook, whether it's retail software, or Shareware. The Shareware system makes fitting your 
needs easier, because you can try before you buy. And because the overhead is low, prices are low also 
(see Fee Schedule). Shareware has the ultimate money-back guarantee -- if you don't use the product, 
you don't pay for it.

Code-A-Line is a Shareware program and is provided at no charge to the user for evaluation. Feel free to 
share it with your friends, but please do not give it away altered or as an embedded part of another 
system. The essence of "user-supported" software is to provide personal computer users with quality 
software without high prices, and yet to provide incentive for programmers to continue to develop new 
products.

If you find this program useful and find that you are using Code-A-Line and continue to use it beyond the 
30-day trial period, you must make a registration payment to Optimax Corporation in the amount specified 
by the Fee Schedule.

See also:
How to register?



ASP Ombudsman Statement

Code-A-Line is produced by a member of the Association of Shareware Professionals (ASP). ASP wants 
to make sure that the shareware principle works for you. If you are unable to resolve a shareware-related 
problem with an ASP member by contacting the member directly, ASP may be able to help. The ASP 
Ombudsman can help you resolve a dispute or problem with an ASP member, but does not provide 
technical support for members' products. Please write to the ASP Ombudsman at 545 Grover Road, 
Muskegon, MI 49442, USA or send a CompuServe message via CompuServe Mail to ASP Ombudsman 
70007,3536.



How to Register
You may register Code-A-Line either by mail, or online, via CompuServe. Please select one of the options 
below to see detailed explanation of the registration process.

How to Register by Mail

How to Register via CompuServe



How to Register by Mail:
See also:

How to Register via CompuServe
Why register?

You may register Code-A-Line in either of two ways: by mail, or online, via CompuServe. The following 
instructions describe how to register by mail.

1. Please print and fill out the Registration Form. Click the highlighted words in the previous 
sentence to see it.

2. Please remit the registration fee in the amount defined in the Fee Schedule (U.S. funds 
drawn on a U.S. bank only; no cash, please) along with the completed Registration Form 
to Optimax Corporation.

Credit card customers, please contact Optimax Corporation for availability and the phone 
number for placing orders.

3. After you register, a License Sheeet will be mailed to you with your License Number. You 
will use this number, along with your name and other information you provided to us upon 
registration, to install the registered version of the program.

If you give us your fax number and check the appropriate option on the Registration 
Form, the License Sheet will be faxed back to you rather than mailed, for faster 
processing (Continental U.S. and Canada only). You may also request it be sent via e-
mail. Please provide your CompuServe or Internet address.

4. To install the registered version, re-run the SETUP utility provided with Code-A-Line 
(SETUP.EXE). This is the same utility that you originally used to install the program.

5. Choose the Personalize Registered Version button, then enter the directory where the 
program file (CODE.EXE) resides and press OK.

6. In the dialog box that appears enter the information from your license sheet. Please note, 
that the information you enter must appear exactly as on the license sheet. This is the 
information you provided us with when registering and the registration number is based 
on it.

7. Once you have entered the License Number and your personal registration data, press 
OK, then Exit Setup.

You will no longer see the registration reminder at the program startup. The 
'[UNREGISTERED]' mark will no longer appear as part of the window title. You will thus 
have a fully functional, registered (commercial) version of the software.

Please note, that you may not distribute the registered version of the program. It is a 
good idea to preserve the installation copy of Code-A-Line (i.e. the contents of the 
original CODE??.ZIP) so that you can share it with others, and also so that you are able 
to re-install Code-A-Line later, if needed.



How to Register via CompuServe
See also:

How to register by Mail
Why register?

You may register Code-A-Line in either of two ways: by mail, or online, via CompuServe. The following 
instructions describe how to register via CompuServe.

1. Once connected, enter GO SWREG at any ! CompuServe prompt to get to the 
Shareware Registration Area.

2. Follow the on-screen instructions. Use ID #2293 to register. The registration fee of US 
$15 (limited time offer: until Sep. 30, 1994) or US $35 (after Sep. 30, 1994) will be 
charged directly to your CompuServe account.

3. After you register, a License Sheeet with your License Number will be sent to you via 
CompuServe E-Mail. You will use this number, along with your name and other 
information you provided to CompuServe upon registration, to install the registered 
version of the program.

4. To install the registered version, re-run the SETUP utility provided with Code-A-Line 
(SETUP.EXE). This is the same utility that you originally used to install the program.

5. Choose the Personalize Registered Version button, then enter the directory where the 
program file (CODE.EXE) resides and press OK.

6. In the dialog box that appears enter the information from your license sheet. Please note, 
that the information you enter must appear exactly as on the license sheet. This is the 
information you provided us with when registering and the registration number is based 
on it.

7. Once you have entered the License Number and your personal registration data, press 
OK, then Exit Setup.

You will no longer see the registration reminder at the program startup. The 
'[UNREGISTERED]' mark will no longer appear as part of the window title. You will thus 
have a fully functional, registered (commercial) version of the software.

Please note, that you may not distribute the registered version of the program. It is a 
good idea to preserve the installation copy of Code-A-Line (i.e. the contents of the 
original CODE.ZIP) so that you can share it with others, and also so that you are able to 
re-install Code-A-Line later, if needed.



Code-A-Line 1.1 Registration 
and Order Form

Single -User License. Please, contact Optimax for Site- and Network licensing.

Please include the following information with your registration (you may simply print this Help topic on a 
standard 8"1/2 by 11" or A4 sheet: select Print Topic from the File menu above). Mail the completed form to 
Optimax Corporation.

_____________________________________________________________________
_____
Your Name/Main Contact Information

_____________________________________________________________________
_____
Organization/Department

_____________________________________________________________________
_____
Street and No./P.O. Box and Station

___________________________________________
__

_________________________
_

City/State or Province/Country Zip or Postal Code

_________________________________
__

__________________________________
__

Phone (Optional) Fax (Optional)

_____________________________________________________________________
_____
Electronic Mail Address (Optional)

Check here if you wish us to respond by 
fax (Continental US and Canada only)

Check here if you wish us to respond by e-
mail (CompuServe or Internet only)

Number of 
copies

Price per 
copy

Subtotal

Shareware Edition Special Offer Expires Sep. 30, 1994 _________
_

$15 $____________
_

Shareware Edition - Single User License _________
_

$35 $____________
_

<ASP> Author Member Discount (qualified individuals 
only)

_________
_

$17 $____________
_

Professional (Retail) Edition - Special Pre-Release Offer _________
_

$49 $____________
_

Complete (Retail) Edition - Special Pre-Release Offer _________
_

$69 $____________
_

Subtotal $____________
_

Add: Shipping and Handling (Retail versions only. 
$10 U.S., $15 worldwide)

$________
_

$____________
_

Please pay by cheque or money order (U.S. funds drawn 
on a U.S. bank only).

TOTAL $____________
_

We welcome your suggestions and comments! Please enter them below (continue on reverse if needed):

______________________________________________________________________
____



______________________________________________________________________
____

______________________________________________________________________
____

______________________________________________________________________
____

______________________________________________________________________
____

______________________________________________________________________
____

Thank you for choosing Code-A-Line!

Why register?
Special Offer: If your registration request with payment for Code-A-Line 1.1 Standard Shareware Edition 
is received on or before September 30, 1994, you are entitled to a considerable promotional discount off 
the regular registration fee (see Fee Schedule):

Here is the summary of rights and benefits available to the registered users:

Registering gives you the legal right to the continued use of the program, beyond the trial 30-day 
period.

Registering will disable all the registration reminders that the unregistered version of the program 
displays, including the initial About dialog.

Registered users receive notifications of any new releases of Optimax products. We also 
occasionally send other notifications that we feel may be of interest to our registered users (such as 
notifications of a release of companion products, add-ons, etc.). We do not sell our customer lists.

Registering also entitles you to one free upgrade of the software. Once you register, you are 
automatically licensed for the next higher version of the same program. See How to upgrade?

Registering entitles you to our free support.

When you register, you will be entitled to - often considerable - discounts on other quality 
software titles produced by Optimax.

See also:
The Unregistered Version
How to register?
Registration Form
Software License and Disclaimer



The Unregistered Version
The unregistered, evaluation version of Code-A-Line is not copy protected, crippled, nor lacking any 
features. We want you, the User, to be able to appreciate the full value of the program before you make 
your decision to purchase.

The unregistered version differs from the registered one only in these minor respects:

The unregistered version displays the "About Code-A-Line" dialog with the word 
"UNREGISTERED" painted in red upon startup. Registering will disable this initial dialog.

The main window's title of the unregistered version includes "[UNREGISTERED]". This reminder 
will disappear as soon as you install the registered version.

The About-box displays "UNREGISTERED" in big, red characters. This will change to your name 
and address once you install the registered version.

See also:
How to register?
Registration Form
Software License and Disclaimer



Support for Registered Users
Support is provided only to registered users free of charge. Code-A-Line 1.1 will be supported for the 
period of one year after the release of a subsequent major version (if any) or at least one year after the 
original registration date - if no further versions are planned - by any and all of the following means:

By mail.

By electronic mail.

By fax.

By phone.

See Optimax Corporation for contact information.

You do not have to be a registered user to obtain help on installing the evaluation version of Code-A-Line. 
If you have any problems or questions and need technical assistance while trying to install Code-A-Line, 
feel free to contact Optimax Corporation by any of the means above.

Optimax Corporation reserves the right to change its support policies at any time without prior notice.

See also:
How to register?
Registration Form
Software License and Disclaimer



How to Upgrade?
You may upgrade to a new release of Code-A-Line Standard Edition at any time after it has become 
available.

To upgrade Code-A-Line 1.1 Standard Edition to a higher (newer) version of the Shareware Edition 
(upgrades to the next release are free to registered users):

1. Obtain a copy of the new shareware evaluation version from your local Bulletin Board System 
(BBS), from CompuServe (e.g. WINSHARE Forum, Lib 10), or directly from Optimax (add $2 
to cover the postage and media costs each time you order directly from Optimax; include your 
media preferences with your order: 3.5 or 5.25 inch disks). 

2. Install the new version using SETUP utility provided, choose Register Code-A-Line, and enter 
your License Number you received when registering your current version along with the 
personal information (see also How to Register?). You are automatically registered for the 
new Standard version and you may start using it immediately.

To upgrade your Code-A-Line Standard Edition to any commercial (retail) edition (see Code-A-Line 
Family of Products), when it becomes available, please contact Optimax first for availability, current 
pricing and discounts you may be entitled to as a registered user of the shareware edition.



Mailing Address:

Optimax Corporation
P. O. Box 25447
Chicago, IL 60625-9998

While the above mailing address will likely remain in effect for the foreseeable future, changes are possible. If you are having any 
difficulty reaching us by any means listed here, please contact the Association of Shareware Professionals to obtain our current 
contact information. We take pride in supporting our products and there always is a way to contact us!

CompuServe Mail: 75020,3617
Internet E-Mail: 75020.3617@compuserve.com

Electronic mail is the preferred support and communication vehicle. Please use it if you can. It allows you to correspond directly with 
the author of this shareware and to receive your answers quickly and inexpensively. It is available 24 hours a day, 365 days a year 
from around the world and will be given prompt attention and priority for any support questions.

Phone/Fax (24-hours, 7 days): 312-561-6363

Feel free to leave a message with your name and telephone number and we will get back to you, usually the same day or early next 
morning, provided that your number is within the continental United States or Canada (if you are calling from outside the area code 
312, we will call you back collect; please be prepared to accept the charges). For your own convenience, please indicate in your 
message your time zone and the hours most suitable for you to accept our call. You have a strong chance of speaking to a live 
person on your first attempt if you call between the hours of 8 p.m. and 11 p.m. Central Time.

When faxing, you may hear the first few phrases of our answering machine's greeting message through your fax' speaker. Please, 
do not interrupt your fax transmission at this point as within a few seconds the line will automatically switch to the fax mode at our 
end. If you encounter any difficulties, please press #1 (the pound sign, followed by the digit 'one') to manually switch the line to the 
fax receiving mode.

About Optimax Corp.

Optimax Corporation is a small, dynamic group of information technology professionals providing 
innovative information technology solutions (programming, analysis, consulting) that truly work. We base 
our solutions on a solid, proven software engineering expertise. We are committed to the highest 
professional quality and look forward to long-term business relationships with other companies.

We specialize in custom software solutions based on the Microsoft Windows graphical environment 
exclusively since 1991. Business applications, including databases, networking, distributed and client-
server systems, are among our specialties.

If you would like more information about our consulting services or custom programming options, please 
feel free to contact us by any means listed above.



Fee/Price Schedule
Code-A-Line 1.1 Standard Shareware Edition License Fees:

PROMOTIONAL OFFER!
Standard Edition Single-User Registration
Offer Expires on September 30, 1994

$15

Standard Edition Single-User Registration
After September 30, 1994

$35

Site Licenses, Network Licenses, Corporate and 
Educational Discounts

Available,
 Please Call

Discount for Author-Members of the Association of 
Shareware Professionals (ASP). An ASP Author 
Member's Single-User Registration:
Cannot be combined with other discounts. Standard 
Shareware Edition only.

$17

Retail Edition Code-A-Line Pricing - Pre-Release Special Offer:

Order Code-A-Line 1.1 Professional now and save $20 
off the regular price of $69!
Offer expires with the official release of the Professional 
package. Meanwhile, you will receive an interim license 
number to run the Standard Edition until the Professional 
package becomes available.

$49

Order your copy of Code-A-Line 1.1 Complete now and 
save $20 off the regular price of $89!
Offer expires with the official release of the Complete 
package. You will receive an interim license number to run 
the Standard Edition until the availability of the Complete 
package.

$69

Please remit in U.S. funds drawn on a U.S. bank. No foreign currency, please. Make checks payable to 
Optimax Corporation. Please do not send cash. Please contact Optimax for network- and site-licenses. 
Optimax reserves the right to change the fee schedule and availability at any time without notice.

Should you decide to upgrade to a Retail Edition after you have registered the Standard Edition, we will 
apply the full license fee you paid for the Standard Edition to the price of the Retail Edition in effect at the 
time of upgrade.

See also:
Code-A-Line Family of Products
How to register?
Why register?
About Shareware





CODE??.ZIP Packing List
NOTE: You may have received Code-A-Line 1.1 as CODE.ZIP or CODE11.ZIP. If you are uploading the 
program to a BBS, or distributing on a CD-ROM, please name the Code-A-Line archived distribution file 
CODE11.ZIP.

Below is the list of all the files inside CODE11.ZIP (or CODE.ZIP if downloaded from CompuServe):

README.1ST Text file with essential installation instructions and any last 
minute updates to the documentation.

SETUP.EXE Installation program to be run first.

SETUP.EX$ Archived copy of the installation program to be used after the 
initial installation.

SETUP.INF Installation script file used by SETUP.EXE.

CODE.EX$ Code-A-Line application (archived).

CODE.HLP Online help file for Code-A-Line.

DISPLAY.CF$ Sample configuration suitable for the display (archived).

PRINTER.CF$ Sample configuration suitable for the printer (archived).

FILE_ID.DIZ Standard description of the program for use by online BBS 
services.

VENDOR.DOC Standard description of terms and conditions of distribution for 
BBS sysops and shareware disk vendors.

The files with extensions ending with $ are archived and cannot be used/accessed directly. You should 
use the provided SETUP utility to install the program and its associated files. Setup will take care of 
installing and de-archiving the required files as needed.



Main Window
The main Code-A-Line window consists of the following elements:

Window Frame
Main Menu
Toolbar
Outline
Status Bar



Code-A-Line Window Frame
Windows environment provides a standard look-and-feel for application windows by giving them a frame 
and a title bar. The Code-A-Line title displays the abbreviated form of the file name (just the name 
portion). A shareware evaluation version has the word UNREGISTERED in the window title at all times. 
Registering Code-A-Line removes this reminder (See How to register?).



Code-A-Line Toolbar

Tollbar's speed-buttons give you one-click access to the most frequently used commands.

Toolbar 
Button

Menu 
Equivalent

Function

File|New Blank the editor for a new file.

File|Open Open an existing file.

File|Save Save current file.

File|Print Print current file.

Edit|Cut Cut text to the clipboard.

Edit|Copy Copy text to the clipboard.

Edit|Paste Paste text from the clipboard.

Edit|Find Find text.

Edit|Replace Find and replace text.

Line|Expand All Expand all lines.

Line|Deep 
Expand

Expand only the current line completely.

Line|Collapse All Collapse all lines.

Line|Move Up Move current line up.

Line|Move Down Move current line down.

Line|Promote Promote the current line and its children.

Line|Demote Demote the current line and its children.

Line|Indent Indent the current line without affecting the children..

Help|Contents Display the hHelp Table of Contents.

File|Exit Exit program.



Code-A-Line Outline
The main (client) area of a Code-A-Line window is devoted to displaying the file outline.

What Are Outlines?
Programs As Outlines
Other (Non-Program) Outlines
Outline Editor



What Are Outlines?
An outline is a way of utilizing both dimensions of your screen or paper - vertical and horizontal - to 
organize information. In outline text files lines are indented from the left to show deeper nesting, or 
parent-child-like relationships.

An indented line is considered subordinate (the child) to the previous one, with one less level of 
indentation (the parent). The unindented lines (with indentation of zero) form the main "headline" structure 
of the file and are "parents" of all other, deeper indented lines. Every headline can have a list of sub-
heads. The sub-heads can have more sub-heads, and so on to virtuallyan infinite depth of detail.

With the outline structure you can look at the details of your work or get the broader view by expanding 
and collapsing headlines. Plus, Code-A-Line outlines can be instantly reorganized to facilitate the 
development of your work.



Non-Program Outlines
Code-A-Line can help you organize ideas and details. It can make you more productive by making it 
easier to put every fact and goal where it belongs in relationship to other things. Similar to how 
spreadsheet programs help boost your productivity in financial and quantitative work, an outline processor 
is best used in organizational and qualitative work.

The list of applications for outlining is endless. We include some suggestions here:

TO-DO lists
Task Lists for Project Management
Classifications
Organizational "Charts"
Tables of Contents
Hierarchy Trees



Programs as Outlines
Code-A-Line has been specifically designed with the programmer in mind. Almost no matter which 
programming language you use, you can take advantage of Code-A-Line's powerful outlining capabilities 
to enhance your productivity.

The key to productivity enhancement that Code-A-Line provides is called information hiding. It is a very 
powerful concept, which has far reaching implications as far as software construction is concerned. The 
term itself has many applications. Here we are using the term 'information hiding' in the context of 
developing (i.e. writing and editing) the program source code files.

Rather than looking at the entire source code file all at once, you can concentrate on the selected areas 
by appropriately expanding the lines of interest, while suppressing the display of all the remaining ones. 
You gain an uncluttered view of the problem you are currently trying to solve, without all the extraneous 
noise.

Typically, programmers spend a lot of time paging back and forth between declaration of a routine and its 
implementation, between declaration of a data type and the place where it is being used, and so on. With 
outlines, the related elements can be brougt closer together.

Outlines make it easy to develop pseudo-code (what else!) outlines of your program's logic. You can later 
expand these outlines by providing the implementation details, while the outline headings become 
comments in your code. You can keep things in perspective by expanding and collapsing sub-headings, 
so that you never have to deal with too much detail at once.

You can use outlines to enhance and/or highlight the syntactic structure of your program source code. For 
example, if you treat the headings of subroutines as outline headings, and their bodies as sets of 
subordinate headings in the outline, you can then view the file in the fully contrated state, when it 
becomes a sort of table of contents. You can later expand the heading that you are interested in, to see 
the details of implementation of the subroutine.

This concept can be applied not only at the subroutine level, but at any level, down to individual 
statements or groups of related statements. After all, you are probably using indentation to help you cope 
with your programs' structure anyway. Code-A-Line comes in as an enhancement to let you make much 
better use of that indentation technique.



Outline Editor
Code-A-Line has a powerful Outline Editor. This is the main portion of the Code-A-Line window, 
occupying the area between the toolbar at the top, and the status bar at the bottom.

The editor area is divided into two regions: on the left are the line numbers; on the right are the text lines 
of the current outline.

You can tell which area the cursor is over as it changes from the normal arrow pointing to the left while 
over the text lines into a similar arrow but pointing to the right over the line numbers.

Depending on which area you click/double-click on with your mouse, the outline contracts or expands 
(click on the line numbers' area), or the line editor gets activated (double click the text of the line).



Code-A-Line Status Bar

Displayed at the bottom of the window. The status bar shows the current position in the file, both in terms 
of the display-based line numbers and in terms of pages. It also displays the current directory information, 
including the size of the file in bytes, the date, and the time as it was read from disk. Finally, the status bar 
displays the full path and filename of the file being edited.

Note that when you modify the current file, the directory information and the name of the file are greyed 
out. This is an indication that the file has changed since the last save.



Line Numbers
As a consequence of its outlining capabilities, and the possibility of collapsing some headlines, Code-A-
Line must maintain two different line-numbering schemes.

File-Based (Absolute) Line Numbers

These are the consecutive, sequential numbers that the lines are numbered with as they are read 
from the disk file. These numbers are displayed and printed to the left of each line (unless you 
disabled this option) and they are the same numbers that a regular text editor might report. These 
numbers are "absolute" in the sense that they will remain unchanged when you expand or 
collapse various portions of the outline.

Display-Based (Relative) Line Numbers

These are the sequential numbers of only the displayed lines in the outline. The display-based 
number of the currently selected line is shown inside the leftmost field on the status bar (bottom 
of the window). If you expand all lines in the outline, the Displayed numbers will coincide with the 
file-based Outline Numbers. Normally, the display-based number of a line changes as lines 
before it are expanded or collapsed. In that sense, these numbers are display-relative.



Main Menu Commands

File Opening, Saving and Printing of files.
Edit Cut, Copy, Paste, Select All.
Line Manipulating the Outline.
Tools Execute user-configurable tools/programs.
Options Custom configuration options.
Help Access to help pages.



File Menu Commands
New Creating a New File.
Open Opening an Existing File.
Save Saving an Existing File.
Save As Saving a New File.

Print Printing a File.
Printer Setup Choosing and Setting up Printers.

Exit Exiting the Program.



Edit Menu Commands
Undo Undoing changes effected by previous 

commands

Cut Cutting Lines to the Clipboard.
Copy Copying Lines to the Clipboard.
Paste Pasting Lines from the Clipboard.

Select All Selecting All Lines.
Find Find occurrences of the specified text.
Replace Find and replace one or more occurrences 

of the specified text.

Go To Page Position the highlight bar (caret) at the top 
of the specified page.



Line Menu Commands
Insert Inserting a New Line.
Add Adding a New Line.
Edit Editing an Existing Line.
Delete Deleting a Line.

Expand One Expanding (Unfolding) a Line One Level.
Collapse One Collapsing (Folding) a Line.
Expand All Expanding (Unfolding) All LInes.
Deep Expand Expanding a Line Completely.
Collapse All Collapsing All Lines.

Move Up Moving the Current Line Up.
Move Down Moving the Current Line Down.
Promote Promoting (Unindenting) a Line.
Demote Demoting (Indenting) a Line.
Indent Indenting a Heading, without affecting its 

children

Go To Moving the highligt bar (caret) to the 
specified absolute line.



Tools Menu Commands
Execute Launching other programs.
Setup Run Code-A-Line Setup/Installation 

Program.

<User Tools> Running user-specified programs.



Options Menu Commands
Colors Selecting Custom Colors.
Elements Selecting Page Elements to be included or 

excluded from printing/displaying.
Fonts Selecting custom fonts.
Page Layout Defining page layout, including margins and 

other dimensions.
Preferences Defining miscellaneous custom preferences.
Tools Configuring the Tools menu.

Open Loading a configuration file.
Save Saving the current configuration to a file.
Save As Saving the current configuration to an 

explicitly named file.



Help Menu Commands
Index Help Table of Contents.
Keyboard Keyboard shortcuts.
Commands Menu commands.
Procedures Eplanations on how to accomplish a certain 

task.
Using Help Help on Windows Help.
About Program and copyright information.



Creating a New File
To create a new source file choose New from the File menu (Alt-F, N).

The contents of the outline will be cleared (if you have not saved the currently open file, you will be 
prompted to do so).



Opening an Existing File
To open an existing file 

Choose Open from the File menu (Alt-F, O), or

Drag-and-Drop the file with your mouse from the File Manager onto the Code-A-Line window or icon.

If you choose Open from the File menu, or press open file button on the toolbar, an "Open File" dialog 
appears. Select the file you wish to edit, then press OK.

NEW! The "Open File" dialog box is now resizeable vertically. You can stretch it to the height of the entire 
screen, if you wish to see more file and directory entries at once.

The contents of the current outline will be cleared as the new file is read in. If if you have not saved the 
currently open file, you will be prompted to do so.

Code-A-Line does NOT rely on any extraneous control characters to be inserted into your file in order to 
maintain the outline structure. Only the indentation of the individual, non-blank lines matters when Code-
A-Line builds the outline structure on-the-fly, as it reads the file.



Saving an Existing File
The Save command records any changes you make to the currently open source file. The file name and 
location remain the same. You should save the contents of a file frequently as you work.

To save an existing source file choose Save from the File menu (Alt-F, S).

If this is the first time you have saved the source file, the Save As dialog box appears. See Saving a New 
Document



Saving a New File
To save a new, unnamed document or source code file,

Choose Save from the File menu (Alt-F, S), or

Choose Save As from the File menu (Alt-F, A).

"Save As" dialog box appears.

To save the document in the current drive and directory, type a name of up to eight characters in the File 
Name box.. There is no default extension for the document you save, so you have to specify a complete 
file name, with an extension, if desired. 

To save the document in a different drive or directory select a drive in the Drives box , then select a 
directory in the Directories box, then type the filename or the complete path in the File Name box..

Once you are done filling in file-name components, press the "OK" button.

NEW! The "Save As" dialog box is now resizeable vertically. You can stretch it to the height of the entire 
screen, if you wish to see more file and directory entries at once.



Printing a File
The printer you have installed affects how Code-A-Line prints and displays text on the screen. Before you 
complete the editing of your source file, you should install and select the printer you intend to use to print 
it.

It is a good idea to frequently save your file while you are editing it, but especially before you start 
printing. That way, if a printer error or other problem occurs, you will not lose any work performed since 
the last time you saved the file.

You can print a a range of pages (even a single page), a complete file, or a range of lines from the file.

To print the entire document,

Choose Print from the File menu (Alt-F, P). In the Print box, select All (Pages) inside the Print Range 
box, then press the "OK" button.

To print a range of pages,

Choose Print from the File emnu (Alt-F, P), then select Pages in the Print Range box. Specify the 
desired range of pages in the From and To boxes, then press the "OK" button.

To print a range of lines,

Choose Print from the File menu (Alt-F, P), then select Selection in the Print Range box. and press 
the "OK" button.

The selected range of lines does not necessarily have to coincide with page breaks; it can span 
several pages, or be as short as two lines; it can begin and end at any line on a page; it can also 
include all lines, in which case printing it is equivalent to printing the entire document.



Printer Setup
A file prints on the default printer. If you have installed more than one printer, you can make any of them 
the default printer. You can also change the options for the default printer.

To change printers,

1. Select Printer Setup from the File menu (Alt-F, R). 

2. From the drop-down list of available printers select the one you wish to use. This will become 
your default printer.

3. Press the "OK" button.

To change the default printer options,

1. Select Printer Setup from the File menu (Alt-F, R).

2. Choose the Setup button. A printer options dialog box will appear, allowing you to set the 
preferred options for the printer. The options vary, depending on the printer you selected. 

3. Select the options you prefer. 

4. Press the "OK" button to close the printer's Setup dialog box. 

5. Choose the "OK" button in the Select Printer dialog.



Exiting the Program
To close the window and exit Code-A-Line, 

Select Exit from the File menu, or

Press Alt-F4 while the main window has the input focus.



Undoing Changes
Any editing command that affects the text stream in the outline editor can be un-done. The commands 
involved include: 

Edit Menu Commands
Paste
Cut
Replace

Line Menu Commands
Insert
Add
Edit
Delete
Move Up
Move Down
Promote
Demote

To undo the last command issued, 

Select Undo X from the Edit menu, where X is replaced by the name of the most recently issued 
command (e.g. Undo Insert, Undo Move, etc.).

If there are no commands saved in the Undo buffer, the first Edit menu selection will read 'Nothing to 
Undo' and will be greyed-out. Otherwise the first menu selection will show the most recently issued 
command and the number of undo records remaining in the Undo buffer, in square brackets.

There is no limit on the number of changes that can be undone. Code-A-Line maintains a Last-In, First-
Out queue of recent commands, so that you can undo them in the reverse order, one-by-one.

Please note that line expansion and contraction commands do not affect the undo buffer. You cannot 
currently undo line expansion or contraction commands, and therefore undoing the effects of some of the 
above undo-enabled commands may not be immediately visible if you have collapsed or expanded lines 
since the time the command was issued.

Also note that issuing a File|New, or File|Open commands unconditionally flushes the Undo buffer 
removing all commands stored there.



Cutting Lines
To cut (remove) a range of lines from the file you are editing and place them as text onto the Windows 
Clipboard, 

Select the range of lines, then

Select Cut from the Edit menu (Alt-E, T), or
Press Shift-Delete

Note that only the visible selected lines will be placed onto the Clipboard. The lines hidden (folded) 
underneath the currently visible ones will be cut from the file, but will not appear on the Clipboard.

Also note that the newly cut lines replace any previous contents of the Clipboard.



Copying Lines
To copy (without removing from the file) a range of lines from the file you are editing and place them as 
text onto the Windows Clipboard, 

Select the range of lines, then

Select Copy from the Edit menu (Alt-E, P), or

Press Ctrl-Insert on the keyboard.

Note that only the visible selected lines will be placed onto the Clipboard. The lines hidden (folded) 
underneath the currently visible ones will not appear on the Clipboard.

Also note that the newly copied lines replace any previous contents of the Clipboard.



Pasting Lines
To paste the current contents of the Windows clipboard as text lines into the outline,

Select Paste from the Edit menu (Alt-E, P), or
Press Shift-Insert.

The text from the Clipboard is added at the insertion point (below the currently selected line). If more than 
one line is currently selected, the text lines from the Clipboard replace the selected lines in the file.



Selecting Lines
To select a range of lines:

1. Move the current highlight bar to the first line of the range to be selected.

Then do one of the following:

2. Without moving the highlight bar, scroll the window by the scrollbar so that the last line of the 
range is visible, then

Depress Shift and click on the last line of the range to be selected while Shift is still being 
depressed.

or

2. Depress Shift and move the highlight bar with the cursor (arrow) keys while Shift is still being 
depressed, thereby gradually extending the selection, line-by-line.

See also:
Selecting All Lines



Selecting All Lines
To select all lines in the file in one step,

Choose Select All from the Edit menu (Alt-E, A).

See also:
Selecting Lines



Finding Text
You can find the next occurrence of any sequence of characters in the outline, including uppercase and 
lowercase characters, and parts of words.

To find text

1 From the Edit menu, choose Find (Alt-E, F).

2 A Find dialog box appears.

3 In the Find What box, type the text to search for.

4 Set the options you want to control the search with:

Match Case Find text having a certain pattern of uppercase and 
lowercase letters, when case is significant.

Up Search the outline above the current insertion point 
(highlight bar).

Down Search the outline below the current insertion point 
(highlight bar).

5 Choose the Find Next button. If Code-A-Line finds an occurrence, the outline scrolls and 
expands as necessary, so that you can see the line in context.

6 To cancel a search or when you are finished searching, choose the Cancel button, or 
press Esc.



Replacing Text
With the Replace command, you can find and replace text. You can automatically replace all occurrences 
of the found text, or selectively replace only certain instances.

To replace text

1 Select the portion of the document you want to search. Code-A-Line searches the entire 
document if you do not select a portion of the document.

2 From the Edit menu, choose Replace (Alt-E, R).

3 In the Find What box type the text to search for.

4 Set the options you want to control the search with:

Match Case Find text having a certain pattern of uppercase and 
lowercase letters

5 In the Replace With box type the text.

6 Choose the Find Next button. If Code-A-Line finds an occurrence, the outline scrolls and 
expands as necessary, so that you can see the line in context.

7 Do one of the following:
To replace the text, choose Replace.
To leave the text unchanged and search for the next occurrence, choose Find Next.

8 Do one of the following:
Repeat steps 6 and 7 for each occurrence.
To change all occurrences of the search text without confirmation, choose the Replace All 
button.

9 To cancel a replace operation in progress or when you are finished replacing, choose the 
Close button or press ESC.

To undo the effects of the Replace command, choose Undo Replace from the Edit menu (Alt-E, U) as the 
first action after completing the change. Code-A-Line reverses only the last change if you chose Replace 
for each occurrence. All changes will be reversed if you made the changes in one step with Replace All.



Jumping to a Particular Page
To move the highlight bar (outline caret) to the first line of a particular page,

1. Select "Go To Page" from the Edit menu (Alt-E,G).

A Dialog box will appear allowing you to enter any number within the current range of page numbers.

2. Once you have entered the desired page number to move to, press the "OK" button.

See also: 
Jumping to a Particular Line



Jumping to a Line Number
To move the highlight bar (outline caret) to a particular absolute line,

1. Select "Go To" from the Line menu (Alt-L,G).

A Dialog box will appear allowing you to enter any number within the current range of absolute line 
numbers.

2. Once you have entered the desired line number to move to, press the "OK" button.

See also: 
Jumping to a Particular Page



Inserting a Line
To insert a new line before the currently selected one:

Choose Insert from the Line menu (Alt-L, I), or

Press the Insert key.

A new, blank line will be inserted before the currently selected line, and the editing caret will be shown. 
You can start entering text for the new line immediately. Once you are finished adding text for the line, 
press Enter. If you want to discard changes to the current line and return to the outline editing mode, 
press Esc.

See also:
Adding a Line



Adding a Line
To add a new line after the currently selected one:

Choose Add from the Line menu (Alt-L, A), or

Press the Enter key on your keyboard.

A new, blank line will be added after the currently selected line (if the currently selected is the last line of 
the file, the new line will be appended), and the editing caret will be shown. You can start entering text for 
the new line immediately. Once you are finished adding text for the line, press Enter. If you want to 
discard changes to the current line and return to the outline editing mode, press Esc.

NOTE: Pressing Enter repetitively will insert more lines. If you want to terminate the line-insertion mode 
and return to the outline editing mode, press Esc.

See also:
Inserting a Line



Editing a Line
To make changes to an existing line, 

Choose Edit from the Line menu (Alt-L, E), or

Double click the thext of line with the mouse, or

Press the Spacebar on your keyboard, or

Just start to type the text.

The editing caret (a blinking, vertical bar at the insertion point) will show allowing you to edit the text line. 
Once you are finished with changes, press Enter. If you want to discard changes to the current line and 
return to the outline editing mode, press Esc.



Deleting a Line
To delete a line, 

Choose Delete from the Line menu (Alt-L, D), or

Press the Delete key.

Note that if there is a block marked, the entire block will be deleted.

Also, please note that when the outline is folded, all of the subordinate (lines at a higher level of 
indentation) under the current line will also be deleted.



Expanding a Line
Lines that can be expanded ("outline headings") are lines followed by other lines with deeper indentation. 
They are marked with a plus sign right after the line number on the left. They are also marked with a 
trailing ellipsis (three dots by default. You can change the mark by choosing Preferences from the Options 
menu).

To expand the current line by one level,

Choose Expand One from the Line menu (Alt-L, X), or

Press the Plus key on the numeric keypad, or

Click (once) over the line number of the line you want to expand (to the left of the text of the line) with 
the mouse, provided the line is currently collapsed. If the line is already expanded, it will be collapsed 
instead.

See also:
Collapsing a Line



Collapsing a Line
Lines that can be folded or collapsed ("outline headings") are lines followed by other lines, with a higher 
indentation level. They are marked with a minus sign right after the line number on the left.

To collapse a single outline heading, 

Choose Collapse One from the Line menu (Alt-L, C), or

Press the Minus key on the numeric keypad, or

Click (once) over the line number of the line you want to collapse or fold (to the left of the text of the 
line) with the mouse, provided the line is currently at least partially expanded. If the line is already fully 
collapsed, it will be expanded.

See also:
Expanding a Line



Expanding All Lines
To expand (unfold) all lines, 

Choose Expand All from the Line menu, or

Press the Star (Multiply) key on the numeric keypad.

Expanding all lines unfolds the entire file making all the lines visible.

See also:
Collapsing All Lines



Collapsing All Lines
To collapse all lines, effectively reducing th evisible outline to the top-level headings,

Choose Collapse All from the Line menu, or

Press the Slash (Divide) key on the numeric keypad.

See also:
Expanding All Lines



Deeply Expanding a Line
You can expand an outline heading (a line with subordinate lines) completely, so that all 'child' or 
subordinate lines at the lower levels are visible. This is called 'deeply' expanding, because you are 
effectively in-depth exposing the subtree of hierarchically organized headings. 

To deeply expand the entire su-hierarchy starting at the selected line,

Choose Deep Expand from the Line menu, or

Press Ctrl-+ (Plus on the numeric keypad).

See also:
Expanding All Lines
Expanding a Line



Rearranging the Outline
You can move single lines up or down, thereby rearranging the order of headings in the outline.

To move the single selected line up one position, i.e. to swap the selected line with the next line at the 
same indentation level immediately above it,

Choose Move Up from the Line menu (Alt-L, U), or

Press Ctrl-Up Arrow.

To move the single selected line down one position, i.e. to swap the selected line with the next line at the 
same indentation level immediately below it,

Choose Move Down from the Line menu (Alt-L, W), or

Press Ctrl-Down Arrow.



Promoting a Line
Promoting means decreasing the indentation of (unindenting) a line. The line gets "promoted" since it 
becomes a higher-level outline heading in the process.

To promote the currently selected line or range of lines,

Select Promote from the Line menu (Alt-L, P), or

Press Left Arrow key, or

Press Shift-Tab.

See also:
Demoting a Line



Demoting a Line
Demoting means increasing the indentation of a line and its children (subordinate lines, or subheadings in 
the outline). The line gets "demoted" since it becomes a lower-level outline heading or a simple text line in 
the process.

Demoting a line that already has children (subordinate lines, or lines with higher indentation level) results 
in demoting the entire subtree. If your intention is to demote just one line, without moving its children, see 
Indenting a Line.

To demote the currently selected line or range of lines and all of their children,

Select Demote from the Line menu (Alt-L, M), or

Press Right Arrow key, or

Press Tab.

See also:
Promoting a Line
Indenting Line



Indenting Line
Indenting is similar to Demoting, with the exception that the subordinate (child) lines are not dragged 
along. Only the explicitly selected lines are affected.

To demote just the selected line or lines, without necessarily indenting its, or their, children, 

Select Indent from the Line menu (Alt-L,I), or

Press Right Arrow key while holding Ctrl key simultaneously, or

Hold Ctrl and Tab keys simultaneously.

See also:
Promoting a Line
Demoting a Line



Customizing Colors
To customize the colors used by Code-A-Line on the display

Select Colors from the Options menu (Alt-O, C).

"Select Colors" dialog will appear. You can customize a color for a number of display elements, shown in 
a list box along with sample color boxes.

Use the drop-down selectors inside the Color box near the bottom of the dialog to choose the foreground 
(text) and background colors of the currently selected display element.

Please note, that you can only choose colors for the display: your printouts are always black on white 
regardless of the custom color settings.

The display elements listed are as follows:

Lines Of Code
These are the actual text lines of your file (document). All text lines will be affected by this setting.

Selected Lines
This setting will affect only the selected lines, i.e. lines within a block. This is not the color of the caret 
line, i.e. the currently active line.

Line Numbers
Line numbers are displayed to the left of each text line (unless they are disabled by your other custom 
settings). The settings of the text color will affect the line numbers only, but the background also 
affects the background of all areas within th eoutline window not covered by text.

Caret Line
Caret line is the "current" line, on which the outline caret resides. This setting affects only this single 
line.

Page Breaks
Page breaks, if shown, will use the foreground color. Th ebackground color has no meaning and will 
not be used.



Selecting Page Elements
To select which elements (objects) get displayed and printed on the page, 

Choose Elements from the Options menu (Alt-O, E).

"Select Page Elements" dialog-box will appear in which, for each element or object of interest you can 
either check or uncheck the box next to it using your mouse. Select the object name from the "... 
Elements" list, an appropriate page selection from the list above it (your choices apply to one of the 
selections: All Pages, First Page Only, or Subsequent Pages - other than the First), then check or 
uncheck the checkbox next to the element's name.

Once you are done selecting which elements are to be displayed, press the "OK" button.

When the checkbox is 'on' ('checked') the corresponding page element will get drawn on the display, if 
applicable, and it will also appear on the printed page. If you uncheck (turn 'off') a checkbox, the 
corresponding element will not appear on the printout or screen.

Note that some choices in the "Page Element" list apply only to the display (Page Breaks), while others 
only to the printer (Big Title, Page Header, Top Dividing Line). Only the Line Numbers and Code Lines are 
both applicable for the display and the printer.

When a checkbox is grayed, i.e. it is displayed in an indeterminate, neither checked, nor unchecked state, 
this is an indication of the fact that your page selection (such as All Pages) covers pages of which some 
include and others exclude the current element. Narrow down your page selection (e.g. select First Page 
Only) to see the checkbox turn ito a determinate checked or unchecked state.

Here is the list of the object names displayed in the "Page Elements" box:

Big Title
This is typically a large-print title of the file. By default, it is printed at the top of the first page only.

Page Header
This consists of the full path name of the file being printed, along with the directory information 
including its size in bytes, and its date and time, as well as the page number of the printout.

Top Dividing Line
A horizontal line dividing the header from the rest of the page is drawn by default underneath the 
header. You can disable the printing of this line by unchecking the corresponding box.

Line Numbers
File-based (absolute) line numbers are printed by default. If line number printing is not desirable, 
uncheck the appropriate box.

Code Lines
The text of the lines is typically what you want to pront in the first place. Sometimes, however, a need 
may arise to, for instance, overprint the headers with page numbers over a bare source code listing, 
possibly pre-printed by other means. You can accomplish that by unchecking the Code Lines box.

Page Breaks
Page breaks are displayed for your information to allow you to preview the printout and possibly 
adjust the text lines. You can disable the display of the page breaks by unchecking the box. Note that 
the page breaks will only display properly once you selected the printer that you intent to use for 
printing the file.





Selecting Fonts
To customize the fonts with which the page elements or objects are displayed and printed, 

Choose Fonts from the Options menu (Alt-O, F).

"Select Fonts" dialog will appear, in which you can choose a custom tailored font for each of the following 
page elements: Lines of Code (regular text), Line Numbers, First-Page Title (typically the "Big Title", and 
Page Headers.

As you select a particular page element, the corresponding font attributes are copied to the entry fields 
inside the "Font" box. You can edit these entries and thereby change the font attributes of the currently 
selected Page Element.

If you prefer, you can choose from a list of all available fonts on your system. Press the "Fonts" button to 
open the standard "Font" dialog that allows you to selct the typeface name and other attributes of the font.

Once you are done with the selections, press the "OK" button.

Once you made a change to a page element's font, if you wish to apply the same font attributes to 
another page element, use the "Repeat" button. It will copy the last font attributes into the currently 
selected page element.

You can activate the "Repeat" button without doing any font attribute editing by double-clicking on an 
entry with the desired font properties inside the Page Element box. Once the button has been activated, 
you can apply the font properties to other Page Element entries by selecting the other entry and then 
pressing the "Repeat" button.



Customizing Page Layout
To customize the overall layout of the page, i.e. to set-up margins and other key dimensions, 

Select Page Layout from the Options menu (Alt-O, L).

"Page Layout" dialog with a list of page dimensions will appear allowing you to select the desired value for 
each dimension. You can edit the value below the list-box, inside the "Size" box.

You can also choose one of the possible measurement units to be one of: points, milimeters, thousands-
of-an-inch, or device pixels.

Please note, that the last choice (device pixels) is device- (printer-) dependent, and that the results will 
likely change as you select a different printer.



Defining Preferences
To customize miscellaneous Code-A-Line settings not covered by other, specific commands choose 
Preferences from the Options menu (Alt-O, P).

A "Custom Preferences" dialog will appear, in which you can change the following settings affecting the 
display and/or printed output:

End-Of-Line Markers:
These are displayed and printed at the end of some text lines to indicate a special status of a line. 
Two endline markers are currently defined:

Expansion
This is a string of characters displayed at the end of an expandable line. By default it is a space 
character followed by three dots. It can be changed to any combination of characters and/or 
special symbols.

Null-Line
This marker string is displayed in place of empty (null) lines. By default it is a single underscore. It 
can be changed to any combination of characters and/or special symbols.

Tab Size:
Tab size settings affect how Code-A-Line reads text files and how it generates the output file.

Source
Source Tab Size setting is used to determine the number of consecutive leading spaces (ASCII 
32) which are to be treated as one logical indentation level. Note that TAB characters in th einput 
file are always assumed to increase the logical indentation level by one. By default this value is 
two, which means that each indentation level is indented two space characters to the right from 
the previous one.

Destination
When Code-A-Line saves a file, it uses this setting to determine how many space characters to 
output at the beginning of a line for each logical indentation level. By default this is set to two 
spaces. Please note, that depending on the setting of the Use TAB Char checkbox (see the 
explanation below), TAB characters may be output one per indentation level instead of space 
characters.

This setting also affects the line indentation on the display. Its value roughly corresponds to the 
number of characters in the currently selected font by which a line is offset from the left for each 
level of indentation. Please note, that this setting has no effect on the printed output; use Options|
Page Layout to determine the indentation of the printed lines.

Use TAB Character 
This setting determins whether TAB characters (ASCII 9) are used on output to indicate the 
indentation level of a text line. If this box is checked, the settings in the Destination Tab Size box 
have no effect other than on the display.

Filter Button, when pressed, expands the dialog box further to show the File Filter settings.

Once you are satisfied with the settings, press the "OK" button and your preferences will immediately take 
effect.



See also:
Saving a Configuration File



File Filter
Whenever you attempt to open a file by choosing Open from th eFile menu, an "Open File" dialog box 
appears with, among other elements, a drop-down list of file extensions ("List Files of Type") near its 
bottom left hand corner.

These file extensions lists are typically predefined in most Windows applications and cannot be changed 
by the user. It then becomes a very frustrating task to repetitively have to open files with extensions not 
foreseen by th eprogram designers. Code-A-Line takes the extra step of allowing you to customize the list 
- we call it File Filter - to suit your needs, and change it on the fly.

To customize the File Filter settings, 

Select Preferences from the Options menu (Alt-O, P), then
Press the Filter button.

The Custom Preferences dialog box expands showing a File Filter list of filename extensions and their 
descriptions.

You can manipulate the list by simply clicking on the entries to bring their contents to the edit boxes above 
the list itself, editing the entries, and by pressing the Add or Remove buttons, as needed.

Once theFile Filter list suits your preferences, press the "OK" button to exit and save your settings.



Opening a Configuration File
All custom program settings can be stored in a configuration file. To open an existing configuration file, 

Select Open from the Options menu (Alt-O, O).

An "Open Configuration" dialog box will appear allowing you to select a configuration file. Configuration 
files typically have the extension of *.cfg.

Once you have selected the configuration file you wish to load, press the "OK" button.

NEW! The "Open Configuration" dialog box is now resizeable vertically. You can stretch it to the height of 
the entire screen, if you wish to see more file and directory entries at once.



Updating a Configuration File
All custom program settings can be stored in a configuration file. To update an existing configuration file, 

Select Save from the Options menu (Alt-O, S).

The file will be updated with the current custom settings. You can retrieve these settings later by choosing 
Open on the Options menu.



Saving Current Configuration
All custom program settings can be stored in a configuration file. To save the current program settings in 
an explicitly named configuration file, 

Select Save As from the Options menu (Alt-O, A).

A "Save Configuration As..." dialog box will appear allowing you to choose the destination drive, path and 
file name for th econfiguration settings. Once you have selected the name for the configuration file, press 
the "OK" button.

The file will be updated with the current custom settings. You can retrieve these settings later by choosing 
Open on the Options menu.

NEW! The "Save Configuration As..." dialog box is now resizeable in the vertical direction. You can stretch 
it to the height of the entire screen, if you wish to see more file and directory entries at once.



Running the SETUP Program
To run the Code-A-Line SETUP program, e.g. to install the personalized, registered version of Code-A-
Line, 

Select Setup from the Tools menu (Alt-T,S).

Please note, that Code-A-Line itself (CODE.EXE) must not be running while SETUP is running in order 
for SETUP to function properly. SETUP will attempt to close Code-A-Line if it is running. If you have an 
unsaved file in the outline editor, you will be prompted to save it first.

See also:
Running External Programs
Configuring Tools Menu



Running External Programs
To launch any (DOS or Windows) external program at any time,

Select Execute from the Tools menu (Alt-T,E)

An "Execute Program" dialog box will appear. Choose the program file to load and run by selecting drives, 
directories and individual files.

The "Command Line" box can contain partial or full path of the executable program, followed by its 
command-line arguments, if necessary. If the string does not contain a path, Code-A-Line searches the 
directories in the following order:

1 The current directory. 

2 The Windows directory (the directory containing WIN.COM, usually C:\WINDOWS).

3 The Windows system directory (the directory containing such system files as GDI.EXE, usually C:
\WINDOWS\SYSTEM). 

4 The Code-A-Line directory containing the executable file CODE.EXE.

5 The directories listed in the PATH environment variable. 

6 The directories mapped in a network, if applicable.

See also:
Configuring Tools Menu



Configuring the Tools Menu
To define additional entries for the Tools menu, select Tools from the Options menu (Alt-O,T).

A "Tools Setup" dialog box will appear allowing you to define the individual Tools-Menu entries.

The "Tools Menu" list-box shows the structure of the configurable portion of the Tools menu as it is 
currently defined. Click on any entry and its corresponding definition will fill the edit boxes directly 
underneath the list-box.

You can use the "Label", "Command", and "Hint Text" edit boxes below the list-box to modify the existing 
menu labels and related data, or to add new menu entries.

To Add a New Tools Menu Entry:

1 Press the "New" button. This will blank the entry/edit boxes in preparation for the new data.

2 Enter the "Label" for a menu item. This is the text that will appear as part of the Tools menu. You 
may use the ampersand (&) character to cause the next character of the label to be underlined 
and to act as a keyboard shortcut. If you wish the &-character to appear as part of the label itself, 
insert another & in front of it, like this: &&.

3. Enter the "Comand" for the menu item. This is the command line you wish the external tool to be 
invoked with, including any command-line parameters, switches, etc.

4. Optionally, you may also enter a "Hint Text" to be displayed on the status line at the bottom of the 
main Code-A-Line window whenever you are browsing through the available menu choices, to 
remind you what the new menu entry does.

5. Once you are done entering the information, press the Add button. The new entry you created will 
appear in the list box just below the previously selected one, if any.

6. Repeat steps 1 through 5 to add more entries to the Tools menu.

To Edit/Change an Existing Tools Menu Entry:

1. Click inside the "Tools Menu" list box on the entry you wish to modify. The label for the entry along 
with its associated data will appear in the edit boxes just below the list-box.

2. Modify the data inside the edit boxes. When satisfied, press the "Save" button to save the 
changes to the list box entry. The same comments about the editing apply as in the case of 
adding a new entry.

3. Repeat the steps 1 and 2 for each menu entry you wish to modify.

To Delete an Existing Tools Menu Entry:

1. Click inside the "Tools Menu" list box on the entry you wish to delete. The label for the entry along 
with its associated data will appear in the edit boxes just below the list-box.

2. Press the "Remove" button while the list box highlight is still on the item you wish to remove. The 
item will disappear from the list.

3. Repeat the steps 1 and 2 for each menu entry you wish to delete.



To Move an Existing Item:

1. Click inside the "Tools Menu" list box on the entry you wish to move. The label for the entry along 
with its associated data will appear in the edit boxes just below the list-box.

2. Use the "Up" and "Down" buttons to reposition the currently selected list box entry relative to 
other entries.

3. Repeat the steps 1 and 2 for each menu entry you wish to move.

To Save Changes:

Once you are done with the changes to the menu, press the "OK" button.

If you wish to cancel all the changes you have made since opening the dialog box, press the "Cancel" 
button (or the Esc key). Rememeber that all changes to the menu will be lost when you do that!



External Configurable Programs
See also:

Configuring Tools Menu
Launching External Programs

The new Tools menu, among other, contains user-configurable entries to launch external programs.

This menu allows you to define convenient menu entries for the most frequently launched programs and 
tools. Examples include command-line and Windows-hosted compilers, dialog- and resource editors, 
small utilities, etc.

Aside form the two predefined menu choises (Execute, and Run Setup), you are in control of what the 
Tools menu contains.

To configure the contents of the Tools menu, select Tools from the Options menu.






