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Chapter 1

MajorBank

1.1 MajorBank

M A J O R B A N K

Version 1.90

-- © 1997-98 Donat Michel --

E-Mail : MajorBank@wanadoo.fr

W.W.W : http://perso.wanadoo.fr/majorbank/

How to register and why ?

License

Disclaimer

Discovering MajorBank

How to use MajorBank

Description of menus

History of versions

1.2 Registration

______________________________________________________________________________

REGISTRATION :

______________________________________________________________________________

!! IMPORTANT !!

The demo version of MajorBank is limited to 100 transactions.

In order to encourage the author for the accomplished work and

that to come for future versions,

In order to encourage developers to program softwares for your

Amiga, it would be nice of you to register if you are to use

MajorBank.

That is what it’s price is reasonable : 100 French Francs, 40 DM
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or 20 US$ , which doesn’t deprive it of anything but allows more

of you to afford it.

After registrating, every coming update of MajorBank will be free

of charge, available either :

o by downloading it from MajorBank’s web site :

http://perso.wanadoo.fr/majorbank/

o or on simple request, without forgetting to supply the original

floppy disk and a pre-paid self-addressed envelop.

The author.

Order form

------------------------------------------------------------------

English translation by Valéry Amiot <valery.amiot@hol.fr>

As you may have discovered, English is not my mother tongue :)

So I would really appreciate getting some feedback about this

translation : suggestions, critics, comments... Thank you !

I hope you’ll enjoy MajorBank as much as I do.

------------------------------------------------------------------

1.3 Introduction to Majorbank

______________________________________________________________________________

INTRODUCTION TO MajorBank :

______________________________________________________________________________

What is it ?

It’s a software that allows you to manage your bank accounts easily

and intuitively.

Its main assets compared to the different existing softwares are :

o Fully localized in English , French and Deutsch (documentation

+ catalog).

o Its simple, powerful and intuitive graphical interface.

o Highly configurable.

o The management of 10 accounts simultaneously.

o The loading of ABank, BlitzBank or HomeBank accounts.

o A realtime Euro conversion.

o Groups allowing you to load and save several accounts at one go.

o The ability to manage transfers and deductions automatically.

o The management of predefined transactions.

o A powerful search function.

o Cut, copy, paste handling.



MajorBank 3 / 26

o A powerful sort function.

o A graphical display of transactions.

o A statistics window.

o The printing and exportation of the account.

o The balance calculation at a date of your choice.

o A calculator available at any moment.

o The ability to merge several accounts.

o No limit for the number of transactions.

o The multiselection of transactions.

o A hypertext documentation available at any moment.

1.4 Use of MajorBank

______________________________________________________________________________

USE OF MajorBank :

______________________________________________________________________________

MajorBank opens its own screen.

On this one, you can distinguish several buttons :

Graphic buttons at the top which allow you to rapidly access the

main functions of MajorBank :

Load : Loads an account into the current account.

Save : Saves the current account.

Account : Edits the account parameters.

Categories : Edits the list of predefined categories.

Notepad : Edits the notepad.

Graphics : Displays transactions in a graphical way.

Print : Prints the account.

Calculator : Opens the calculator.

Quit : Quits MajorBank.

The display area which is composed of 5 parts :

1. Tabs.

They allow you to rapidly change account without using the menu

items, with the ability to manage 10 accounts simultaneously.

A star indicates that an account is loaded.

2. The ’information’ part which comprises the account’s informations :

o The ’NAME’ field displays the name of the account’s owner.

. Ex: John Smith

o The ’NUMBER’ field displays the account number.

. Ex: 125489720A
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o The ’TYPE’ field displays the type of the account.

. Ex: Current, Savings, Deposit, etc ...

o The ’DATE’ button changes the date for the balance

calculation.

. Ex: in order to know the state of your account on the

10th of August 1996, choose the appropriate date

from the date-selection window which pops up.

o The ’BALANCE’ field displays the calculated balance at the

aforechosen date.

o The ’REAL BALANCE’ field displays the balance taking all

the transactions into account.

3. The ’display’ part (just below) composed of four horizontal

gadgets which allow to display the account’s transactions in

several ways.

o The first one allows to select the year.

o The second one allows to display transactions :

. Within a single month from January to December,

. Within the whole current year,

. Or all the transactions of the account since its creation.

o The third one allows to display only :

. Credits,

. Debits,

. Both (credits and debits).

o The last one allows to display only :

. Validated transactions,

. Not validated transactions,

. Both (validated and not validated).

4. The ’central’ part which displays the list of the transactions

according to the criteria chosen in the third part. It gives you

some control over the transactions :

o Select a transaction by clicking on it with the mouse or by

pressing the Up and Down arrow keys of your keyboard.

o It supports multiselection, by holding down the left mouse

button.

o Change the validation state of the selected transaction by

pressing the ’Return’ key of your keyboard.

5. The ’edition’ part (at the bottom) composed of 7 horizontal

gadgets allowing to create and manage the transactions :

o The ’ADD’ button allows to add a transaction.
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o The ’MODIFY’ button allows to modify the selected

transaction(s).

o The ’DELETE’ button allows to delete the selected

transaction(s).

o The ’ALL’ button allows to select all the transactions.

o The ’NONE’ button allows to unselect all the transactions.

o The ’INVERSE’ button allows to inverse the current selection.

o The ’CALCULATE’ button allows to calculate the sum of both

the credits and the debits of the selected transactions.

A text gadget at the bottom of the screen displays the function of

the gadget pointed by the mouse pointer.

1.5 Description of menus

DESCRIPTION OF MENUS :

PROJECT menu :

About : Informations about the version

and user’s name.

New : Opens a new account.

Load : Opens an account as the current one.

Save : Saves current account.

Save as : Saves current account with a different name.

Merge : Includes into current account the transactions

of another account.

Close : Closes current account.

Load group : Loads a group of accounts.

Save group : Saves a group of accounts.

Help : Displays this documentation.

Quit : Quits MajorBank.

EDIT menu :

Add : Adds a transaction.

Modify : Modifies a transaction.

Cut : Cuts one or several transactions.

Copy : Copies one or several transactions.

Paste : Pastes one or several transactions.

Selection : Selects transactions in

different ways.

All : Selects all transactions.

None : Selects no transaction.
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Inverse : Inverses the current selection of transactions.

Calculate : Calculates the sum of the selected transactions.

Search : Searches for one or several transactions.

Sort : Sorts all the transactions.

Take categories : Copies the categories of another account.

Automatic transact. update

Account : Edits account’s parameters.

Categories : Edits the list of predefined categories.

Automatic transactions : Edits the list of automatic transactions.

Predefined transactions : Edits the list of predefined transactions.

Notepad : Edits the notepad.

TOOLS menu :

Preferences : Edits MajorBank’s preferences.

Statistics : Displays transactions statistics.

Graphics : Displays transactions in a graphical way.

Balancing : Displays the balancing of the year.

Calculator : Opens the calculator.

Print : Prints the account.

Export : Exports the account.

ACCOUNTS menu :

Account : Gives you access to the 10 accounts handled

by MajorBank.

1.6 New

_______________________________________________________________________________

OPEN A NEW ACCOUNT :

_______________________________________________________________________________

o Select an account number using the tabs, unavailable accounts

being disabled.

o In the Project menu, click on ’NEW’.

A window opens, showing 4 tabs :

Account, Savings , Display et Preferences.

In the Account tab, type the parameters of your account :

o Owner (name of the account’s owner),

. Ex: John Smith

o Bank (name of the bank),

. Ex: Barclays

o Bank Logo (logo of the bank),
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Choose it from the GFX/Blogos directory

o Account No (account number),

. Ex: 6553224569

o Type of account (type of account),

. Ex: Current, Savings, Credit card...

o Opening balance, (amount of money at start),

. Ex: 635.00

o Minimum amount, (minimum amount not to exceed),

. Ex: -100.00

MajorBank reports overstepping of the minimum amount

by displaying the balance in red.

Confirm your choice with ’ACCEPT’ or ’CANCEL’.

1.7 Load

_______________________________________________________________________________

LOAD AN ACCOUNT :

_______________________________________________________________________________

There are 2 possibilities :

o Either you click on the ’LOAD’ icon,

o Or you choose the ’LOAD’ item from the Project menu.

In either case, a window opens allowing you to select the

correct file.

Confirm your choice with ’OK’ or ’CANCEL’.

MajorBank handles loading of ABank v1.1 accounts, in which

case you have to supply the year of the account.

1.8 Save

_______________________________________________________________________________

SAVE THE ACCOUNT WITH ITS CURRENT NAME :

_______________________________________________________________________________

There are 2 possibilities :

o Either you click on the ’SAVE’ icon,

o Or you choose the ’SAVE’ item from the Project menu.

!! IMPORTANT !!

The saving process is instantaneous, the previously saved file

being renamed with the ’.bak’ extension in order to allow you

to use it again if needed.

Only the current account is saved. In case you have loaded

several accounts, they have to be saved one after the other.
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1.9 Save as

______________________________________________________________________________

SAVE THE CURRENT ACCOUNT WITH A NEW NAME :

______________________________________________________________________________

In the Project menu, click on ’SAVE AS’.

A window opens allowing you to type the new filename.

Confirm your choice with ’OK’ or ’CANCEL’.

!! IMPORTANT !!

The previouly saved file is renamed with the ’.bak’ extension in

order to allow you to use it again if needed.

Only the current account is saved. In case you have loaded

several accounts, they have to be saved one after the other.

1.10 Merge

______________________________________________________________________________

THIS FUNCTION ALLOWS TO INCLUDE TRANSACTIONS FROM ANOTHER ACCOUNT :

______________________________________________________________________________

In the Project menu, click on ’MERGE’.

A window opens allowing you to select the correct file.

Confirm your choice with ’OK’ or ’CANCEL’.

The selected account merges automatically with the current account.

MajorBank handles loading of ABank v1.1 accounts, in which

case you have to supply the year of the account.

1.11 Close

______________________________________________________________________________

THIS FUNCTION ALLOWS TO CLOSE AN ACCOUNT :

______________________________________________________________________________

Select using tabs the account you want to close. In the Project

menu, click on ’CLOSE’.

!! IMPORTANT !!

The closing process is instantaneous.

In case your account has been modified, a requester asks you

to confirm your choice with ’YES’ or ’NO’.
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1.12 Load a group

_______________________________________________________________________________

LOAD A GROUP OF ACCOUNTS :

_______________________________________________________________________________

This function allows the loading of several accounts at one time.

. Ex: Current, Savings, Credit card, etc...

In the Project menu, click on ’LOAD GROUP’.

A file requester pops up allowing you to select the correct group

file.

Confirm your choice with ’OK’ or ’CANCEL’.

All the accounts being part of the group are loaded.

!!! ATTENTION !!!

All the accounts already loaded are automatically closed by

MajorBank.

However, a requester asks you if you wish to save them.

1.13 Save a group

_______________________________________________________________________________

SAVE A GROUP OF ACCOUNTS :

_______________________________________________________________________________

This function allows the saving of several accounts at one time.

. Ex: Current, Savings, Credit card, etc...

In the Project menu, click on ’SAVE GROUP’.

A file requester pops up allowing you to select the correct group

file.

The file extension is ’.grp’.

Confirm your choice with ’OK’ or ’CANCEL’.

A group file holding the name of the accounts already loaded is

created.

All the accounts already loaded are saved.

!!! IMPORTANT !!!

Each account is saved independently.
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1.14 Quit

______________________________________________________________________________

THIS FUNCTION ALLOWS TO QUIT MAJORBANK :

______________________________________________________________________________

In the Project menu, click on ’QUIT’.

A requester informs you about this choice and asks you to confirm

with ’OK’ or ’CANCEL’.

If one or several accounts are currently loaded, MajorBank asks you

if you wish to save them.

1.15 Add a transaction

______________________________________________________________________________

ADD A TRANSACTION :

______________________________________________________________________________

This function allows you to add a transaction to the account.

In order to add a transaction, there are 2 possibilities :

o Either you click on the ’ADD’ button,

o Or you choose the ’ADD’ item from the Edit menu.

In either case, the edit window opens :

. Select the date :

If it’s different from the current date, click on the date

in order to change it.

. Description : description of the transaction.

Type the description of the transaction, or select a

predefined transaction from the pop-up gadget to the right.

Ex: Restaurant, Rent, Shopping...

. Category : category of the transaction.

Type the name of the category, or select it from the pop-up

gadget to the right.

Ex: Leisure, Cheque, Credit card...

. Type : debit or credit.

. Amount : amount of the transaction.

Type the amount of the transaction, using the + or -

sign if you wish to. The ’Type’ gadget changes according

to the amount entered.

. Validated : validated or not validated transaction.

Click on the checkbox in order to validate/unvalidate the
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transaction. A checkmark means that the transaction is

validated.

. Transfer : in order to make a transfer to another account.

Click on Transfer, select the payee account using the file

selection window.

!! IMPORTANT !!

The transaction is added and saved into the selected account,

even if this one is already loaded.

The ’Return’ key allows you to cycle from one field to

another.

Confirm your choice with ’ADD’ or ’STOP’.

If you select ’ADD’, the window doesn’t close in order to let

you add a new transaction.

(Note of the translator : great feature !)

The transaction is taken into account instantaneously.

1.16 Modify a transaction

______________________________________________________________________________

MODIFY A TRANSACTION :

______________________________________________________________________________

This function allows you to modify an existing transaction.

Click on the transaction you wish to modify.

In order to modify a transaction, there are 2 possibilities :

o Either you click on the ’MODIFY’ button,

o Or you select the ’MODIFY’ item from the Edit menu.

In either case, the edit window opens :

. Select the date :

If it’s different from the current date, click on the date

in order to change it.

. Description : description of the transaction.

Type the description of the transaction, or select a

predefined transaction from the pop-up gadget to the right.

Ex: Restaurant, Rent, Shopping...

. Category : category of the transaction.

Type the new name of the category, or select it from the

pop-up gadget to the right.

Ex: Leisure, Cheque, Credit card...

. Type : debit or credit.
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. Amount : amount of the transaction.

Type the amount of the transaction, using the + or -

sign if you wish to. The ’Type’ gadget changes according

to the amount entered.

. Validated : validated or not validated transaction.

Click on the checkbox in order to validate/unvalidate the

transaction. A checkmark means that the transaction is

validated.

The ’Return’ key allows you to cycle from one field to

another.

Confirm your choice with ’ACCEPT’ or ’CANCEL’.

The transaction is taken into account instantaneously.

1.17 Cut one or several transactions

______________________________________________________________________________

CUT ONE OR SEVERAL TRANSACTIONS :

______________________________________________________________________________

This function allows you to cut one or several transactions and

put them into the clipboard.

Select the transactions to cut.

o Click on the ’CUT’ button,

o Or select the ’Edit/Cut’ menu item.

1.18 Copy one or several transactions

______________________________________________________________________________

COPY ONE OR SEVERAL TRANSACTIONS :

______________________________________________________________________________

This function allows you to copy one or several transactions to

the clipboard.

Select the transactions you wish to copy.

Select the ’Edit/Copy" menu item.

1.19 Paste one or several transactions

______________________________________________________________________________

PASTE ONE OR SEVERAL TRANSACTIONS :

______________________________________________________________________________
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This function allows you to copy the transactions from the

clipboard to the current account.

Select the correct account.

Select the ’Edit/Paste’ menu item.

The transactions held in the clipboard are added to the account.

1.20 Select all the transactions

______________________________________________________________________________

SELECT ALL :

______________________________________________________________________________

This function allows you to select all the transactions displayed

on screen.

In order to choose this option, select the ’SELECT ALL’ item

from the Edit menu.

The selection is instantaneous.

1.21 Select no transaction

______________________________________________________________________________

SELECT NONE :

______________________________________________________________________________

This function allows you to cancel the current selection.

In order to cancel the current selection, choose the ’SELECT NONE’

menu item from the Edit menu.

The unselection is instantaneous.

1.22 Inverse the selection of transactions

______________________________________________________________________________

INVERSE SELECTION :

______________________________________________________________________________

This function allows you to inverse the current selection of

transactions.

In order to select this option, choose the ’INVERSE SELECTION’

menu item from the Edit menu.

The selection is instantaneous.
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1.23 Calculate the total amount of the selected transactions

______________________________________________________________________________

CALCULATION OF THE SELECTION :

______________________________________________________________________________

This function allows you to calculate the total amount of the

selected transactions.

A window opens and shows the total amount of credits and debits

for the selected transactions.

Ex: you wish to know how much were your incomes for the year :

. Make a search on the Salary criterion.

. Select all the transactions via the Edit menu.

. Then, thanks to this function, you’ll get the total amount

of your incomes.

1.24 Search for a transaction

______________________________________________________________________________

SEARCH FOR A TRANSACTION :

______________________________________________________________________________

This function allows you to search for some kind of transaction,

according to the following search criteria :

o By the description of the transaction,

o By the amount,

o By the date.

The selected transactions are shown in the list.

1.25 Sort the transactions

______________________________________________________________________________

SORT :

______________________________________________________________________________

This function allows you to sort the transactions in several ways.

In the Edit menu, click on ’SORT’, then select the kind of sorting :

o Either by date,

o Or by description of the transactions,

o Or by category,

o Or by number,

o Or by amount.
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o Or by comment.

o Ascending or descending order.

!! IMPORTANT !!

The sorting being instantaneous, it can take some time according

to the account size.

1.26 Edit the account parameters

______________________________________________________________________________

ACCOUNT PARAMETERS :

______________________________________________________________________________

This function allows you to edit the parameters of the current

account.

Click on the ’ACCOUNT’ icon.

4 tabs are available :

Account, Savings, Display and Preferences.

1. THE ACCOUNT TAB.

Owner : name of the account’s owner.

Bank : name of the bank.

Logo : bank logo.

Account No : account number.

Opening balance : amount of money at account creation time.

Minimum amount : amount of money not to exceed.

2. THE SAVINGS TAB.

Yet unavailable option, it will allow to define the account’s

rate of interest.

3. THE DISPLAY TAB.

It allows to select the display order of the different

columns and to modify their name and size.

Previous : moves the column to the left.

Next : moves the column to the right.

All the columns placed under the "**********" line won’t be

displayed on screen.

Name : column name.

Size : column size in %.

4. THE PREFERENCES TAB.

o Password :

Determines whether the account will make use of a password or

not.
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If it will, type the password into the text gadget.

o Date format :

Determines the transactions’ date format :

DD.MMM.YY (day, full month, year),

YY.MMM.DD (year, full month, day),

MM.DD.YY (month, day, year),

DD.MM.YY (day, month, year),

Locale (like your Workbench prefered language).

o Default validation :

Determines whether new transactions will be validated or not.

o Validation string :

Choose the string that will display in the validation column.

o Colour :

Changes the display colour of several functions :

. Date,

. Description,

. Category,

. Credits,

. Debits,

. Amount,

. Notepad,

. Negative balance.

A 16 colour palette is available to choose from.

Confirm the changes with ’ACCEPT’ or ’CANCEL’.

1.27 Edit the list of predefinied categories

______________________________________________________________________________

CATEGORIES :

______________________________________________________________________________

This function allows you to edit the list of predefined categories,

you can :

o Modify them,

o Delete them,

o Or create new ones.

Click on the ’CATEGORIES’ icon.

An edit window opens :

Add : adds a predefined category to the list.

Sort : sorts the list of predefined categories.
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Delete : deletes a predefined category from the list.

Accept : accepts the changes.

Cancel : cancels the changes.

By clicking on the category’s name, you can modify it in the edit

window.

Confirm the changes with ’ACCEPT’ ou ’CANCEL’.

1.28 Take the categories of another account

______________________________________________________________________________

TAKE CATEGORIES :

______________________________________________________________________________

This function allows you to copy the categories from another

account.

A requester pops-up, select the account number (from 1 to 10)

from which you wish to take the categories.

The categories of the selected account are instantaneously added to

the ones of the current account.

If the selected account has no predefined category, an alert box

warns you.

1.29 Edit the notepad

______________________________________________________________________________

NOTEPAD :

______________________________________________________________________________

This function allows you to edit a notepad associated with the

account.

You can write different informations concerning the account :

Ex: Your bank office opening hours,

The name of the person who handles your account,

The phone number of some bank services,

The number of the current cheque book, etc...

In the Edit menu, click on ’NOTEPAD’, the notepad window opens.

Confirm what you’ve typed with ’ACCEPT’ ou ’CANCEL’.
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1.30 Edit the automatic transactions

______________________________________________________________________________

AUTOMATIC TRANSACTIONS :

______________________________________________________________________________

This window allows you to manage your automatic transactions.

In order to create your automatic transactions, in the Edit menu,

click on ’AUTOMATIC TRANSACTIONS’.

A window showing different gadgets and the list of your automatic

transactions opens.

Gadgets function :

. Add : adds an automatic transaction.

. Modify : modifies an automatic transaction.

. Sort : sorts the automatic transaction.

. Delete : deletes an automatic transaction.

. Accept : uses these automatic transactions.

The edition of an automatic transaction :

Transaction name :

The name of the transaction.

Transaction day :

Day of the month your transaction will occur.

Begining date :

Begining date of your automatic transaction.

The current day is displayed by default, in order to change

it, click on the date, then use the calendar.

Ending date :

Ending date of your automatic transaction.

The current day is displayed by default, in order to change

it, click on the date, then use the calendar.

Repeat every :

Select the periodicity of your automatic transaction :

. Every day,

. Every 1, 2, or 3 weeks,

. Every month,

. Every 2,4,5,7,8,9,10, or 11 months,

. Every quarter,

. Every half year,

. Every year.

Description :



MajorBank 19 / 26

Transaction description that will appear in your

account.

Category :

The category of your automatic transaction.

Type :

Select credit or debit.

Amount :

Amount of the transaction.

Transfer :

In order to make an automatic transfer to another account.

Click on Transfer, select the payee account using the file

selection window.

!! IMPORTANT !!

The transaction is added and saved into the selected

account, even if it’s already loaded.

In case of a transfer, if the payee account is loaded into

MajorBank, the transfer will automatically appear at the

transaction date.

Confirm your transaction with ’ACCEPT’ or ’CANCEL’.

1.31 Edit the predefinied transactions

______________________________________________________________________________

PREDEFINIED TRANSACTIONS:

______________________________________________________________________________

This window allows you to manage your predefined transactions.

The predefined transactions allow to fill one or several fields

when adding or modifying a transaction.

In order to use them, in the ’Add a transaction’ window, click

on the gadget beside the description field which will make appear

the list of predefined transactions.

In order to create your predefined transactions, choose the

’PREDEFINED TRANSACTIONS’ item from the Edit menu.

A window holding different gadgets and the list of your predefined

transactions appears.

Gadgets function :

. Add : adds a predefined transaction.

. Delete : deletes a predefined transaction.

. Accept : uses these predefined transactions.
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Edition of the predefinied transaction :

Name : Name of the transaction.

Description : Description of the transaction.

Category : Category of the transaction.

Type : Select credit or debit.

Amount : Amount of the transaction.

Validated : Validation or not of the transaction.

Comments : Comments about the transaction.

1.32 Edit MajorBank’s preferences

______________________________________________________________________________

PREFERENCES :

______________________________________________________________________________

This function allows you to change and give a personal touch to

MajorBank’s preferences.

In order to modify the preferences, choose the ’PREFERENCES’ item

from the Tools menu.

A window opens and shows you all the changes you can make.

3 tabs are available :

Global, Toolbar and Start.

1. THE GLOBAL TAB :

o Toolbar.

It’s the list of icons situated above the account tabs, in

the main window.

You may select 4 different display modes :

. Nothing (the toolbar doesn’t appear),

. Pictures (the icons appear),

. Texts (only the icons’ title appear),

. Pictures + Texts (the icons and titles both appear).

o Fonts.

In order to select MajorBank’s display font.

o Transactions date.

This gadget allows you to select the default date that will

appear when adding new transactions.

. Latest, date of the lastest transaction,

. Today, today’s date.

o Automatical sorting.

This gadget allows you to activate or not the automatical
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sorting of transactions when creating them.

o Automatic transactions update.

This gadget allows you to decide whether the automatic

transactions will be updated from the 1st of the month

or according to the chosen date.

o Screen.

In order to select MajorBank’s screen mode.

. Like Workbench, MajorBank opens its own screen in the same

resolution as WorkBench,

. Private, MajorBank opens its own screen in the resolution

that you want, a screen mode requester appears.

o Palette.

In order to modify MajorBank’s palette of colours.

2. THE TOOLBAR TAB :

This function allows you to give a personal touch to the buttons

of MajorBank’s toolbar.

Add : adds a new button,

Delete : deletes a button,

Previous : moves a button to the left,

Next : moves a button to the right,

Sort : sorts the buttons in alphabetical order.

Example of the creation of a new button that will print your

account :

. Click on Add.

. In the Name field, type for example ’Print’.

. Using the Action button, choose in the list the ’Print’ option.

. Then, thanks to the ’Pictures’ button, you are able to combine

a picture with the tool button.

3. THE START TAB :

This tab allows you to select the group or accounts that will

load at start.

If you wish to start with a group, check the group gadget, then

select the group file.

Else, select each account you want to be loaded at start using the

10 account gadgets available.

Confirm the changes with :

o SAVE (the changes are saved),

o USE (the changes are just used),

o CANCEL (the changes are not taken into account).

!! IMPORTANT !!

Preferences linked to the account are not saved, you need to

save the account in order to save them as well.
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1.33 Display the account’s statistics

______________________________________________________________________________

STATISTICS :

______________________________________________________________________________

This function displays the account’s statistics.

It allows you to display the transactions according to different

criteria.

Different gadgets allow to modify the statistics.

Type : in order to display the transactions according to their

category or to the months.

List : In order to choose only one category or one month

according to the type.

Year : In order to display only the transactions of the year.

The window is resizable in order to adjust the graphic size.

Two gadgets allow you to save or print the graphic.

1.34 Display transactions in a graphical way

______________________________________________________________________________

GRAPHICS :

______________________________________________________________________________

This function displays the account graphic.

This way, you can look at the proportion of your categories in

your budget.

Several gadgets allow you to manage the graphic.

Credits/Debits : In order to look at the transactions of credit

or debit type.

Year : In order to choose the year of process.

Whole year : In order to display transactions of a single month

or of the whole year.

The window is resizable in order to adjust the graphic size.

Two gadgets allow you to save or print the graphic.

1.35 Display the balancing of months

______________________________________________________________________________

BALANCING :

______________________________________________________________________________
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This function displays the balancing (credits and debits) of the

current account.

You can choose the year of process.

The window is resizable in order to adjust the graphic size.

Two gadgets allow you to save or print the graphic.

1.36 The calculator

______________________________________________________________________________

THE CALCULATOR :

______________________________________________________________________________

This function allows you to display the Workbench calculator on

MajorBank’s screen.

In order to activate the calculator, click on the ’CALCULATOR’

icon.

The calculator window opens.

1.37 Print the account

______________________________________________________________________________

PRINT :

______________________________________________________________________________

This function allows you to print informations about your account.

A requester pops-up asking you which part of the account you want

to print.

All -> Prints all the transactions of the account.

List -> Prints the transactions held in the list.

Select -> Prints the transactions selected in the list.

At any moment, you can stop the printing by clicking on the

’STOP PRINTING’ gadget.

1.38 Export the account

______________________________________________________________________________

EXPORT THE ACCOUNT :

______________________________________________________________________________

This function allows you to save your account in a different format

than MajorBank’s one.

In the Tools menu, select ’EXPORT’, then choose the correct format :
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o ASCII

A requester pops-up asking you which part of the account you wish

to export.

All -> Exports all the transactions of the account.

List -> Exports the transactions held in the list.

Select -> Exports the transactions selected in the list.

A file requester asks you the saving filename.

1.39 Account

______________________________________________________________________________

DISPLAY THE ACCOUNTS :

______________________________________________________________________________

This menu allows you to display one of the 10 accounts available

in MajorBank.

In the Account menu, choose the number of the account you want

to be displayed :

. Numbers range from 1 to 10

!! REMINDER !!

There a 2 ways of changing account :

o Either by the Account menu,

o Or simply by clicking on the account tabs.

1.40 License

______________________________________________________________________________

LICENSE

______________________________________________________________________________

1. This license applies to the product called "MajorBank", a set of

programs for the Amiga computer, published by Michel Donat under the

concepts of ShareWare, and the accompanying documentation, example

files and anything else that comes with the original distribution. The

terms "Programs" and "MajorBank" below, refer to this product. The

licensee is addressed as "you".

2. You may copy and distribute verbatim copies of the programs’

executable code and documentation as you receive it, in any medium,

provided that you conspicuosly and appropriately publish only the

original, unmodified programs, with all copyright notices and

disclaimers of warranty intact and including all the accompanying
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documentation, example files and anything else that came with the

original.

3. You may not copy and/or distribute these programs without the

accompanying documentation and other additional files that came with

the original. You may not copy and/or distribute modified versions of

these programs.

4. You may not copy, modify, sublicense, distribute or transfer the

programs except as expressly provided under this license. Any attempt

otherwise to copy, modify, sublicense, distribute or transfer the

programs is void, and will automatically terminate your rights to use

the programs under this license. However, parties who have received

copies, or rights to use copies, from you under this license will not

have their licenses terminated so long as such parties remain in full

compliance.

5. By copying, distributing and/or using the programs you indicate

your acceptance of this license to do so, and all its terms and

conditions.

6. Each time you redistribute the programs, the recipient

automatically receives a license from the original licensor to copy,

distribute and/or use the programs subject to these terms and

conditions. You may not impose any further restrictions on the

recipients’ exercise of the rights granted herein.

7. You may not disassemble, decompile, re-source or otherwise

reverse engineer the programs.

8. You may use the programs for a period of up to 30 days for

evaluation. After that, you have to register.

9. If you wish to incorporate parts of the programs into other

programs, write to the author to ask for permission.

10. You agree to cease distributing the programs and data involved if

requested to do so by author.

11. You may charge a fee to recover distribution costs. The fee for

diskette distribution may not be more than the cost to obtain a public

domain diskette from Fred Fish.

1.41 Disclaimer

______________________________________________________________________________

DISCLAIMER

______________________________________________________________________________
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THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE

LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDER AND/OR

OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND,

EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE

ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU.

SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY

SERVICING, REPAIR OR CORRECTION.

IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL

ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY REDISTRIBUTE THE PROGRAM

AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL,

SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR

INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR

DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES

OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF

SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH

DAMAGES.

THE AUTHOR HAS NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES,

ENHANCEMENTS, OR MODIFICATIONS.
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