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What is "Software Grove Messages"?

Welcome to Software Grove Messagesä (also referred to as Messagesä).

Messages is an electronic telephone-message-pad program oriented toward enabling you 
to answer the phone and take messages without turning your attention away from the 
computer screen or searching for the message book and pen.

Messages uses the universally known format of the telephone message pad.    A major 
advantage to Messages is that instead of turning away from your current task, and losing 
your concentration, you will be able to maintain screen contact and take those important 
phone messages simultaneously.

Messages uses Microsoft Windows standards whenever possible.    Any exceptions are 
noted within this help document.

Messages can be displayed (and used) as an icon, a message pad, or as a logfile window. 
Multiple "industry standard" message pad formats are provided, allowing you to choose 
the form most similar to the paper form you are now using.





Messages Features Include:

· phone message pad is always close and handy.

· faster than hand-writing a message.

· messages are printed;    no problems reading handwriting.

· all messages are stored in the computer and can be found and retrieved quickly.

· "smart" message pad fields:

· date and time are automatically filled in.

· phone numbers are automatically formatted.

· list of message recipients can be used for quick selection to For (To) field.

· name in From (M) field can automatically be added to client datafile.

· can automatically fill in the Of and Phone fields from the client datafile.

· names in For (To) and From (M) fields can be anticipated as you type..

· multiple printing templates allows you to choose a print form that best suits your needs.

· many user-settable options.



Menubars

The main menubar is somewhat different as seen from the Messages icon, Message Pad and 
Message Log, but each contains essentially the same drop-down submenus. 

From the Messages icon, the menu is available from the Control menu as cascading submenus:

Similarly, the Message Pad menu cascades from the Control menu:

The Message Log menu is a standard menubar:





Run Command

Starts an application or opens a document. 
The Run dialog box has the following options: 

Command Line
Type the application filename, including the path, if necessary. 
If you want to open a document, type the application filename following by a space 
and the name of the document. 

      If you don't know the name or location of the application or document file, use 
the Browse button to open the Browse dialog box. 

Run Minimized
Select this checkbox if you want the application to be reduced to an icon as it starts. 



Message Log Command

Use this command to view the currently open logfile(s).

The main log window consists of a title frame and a menubar.    Within the log frame, 
multiple windows may contain daily logfiles and selected messages.    Each log or 
message window may be opened, closed, moved, sized, or mimimized (iconized) using 
standard Windows menu/key commands.

The Edit menu Cut and Copy commands can be used to cut/copy the selected message(s) 
to the Clipboard for pasting into other applications.

The Edit menu Clear command can be used to delete the selected message(s) from the 
logfile.

The File menu Print command can be used to print the selected message(s).    If no 
messages are selected, the entire message log will be printed.

The File menu Open command can be used to open a different message logfile.

The Edit menu Flag n commands can be used to attach a user-defined flag to the selected 
message(s).



The Windows menu commands can be used to organize and stack the subwindows, or to 
change the currently active subwindow.



Message Pad Command

Use this command to create a new message.

The current version of Messages supports the two message pad formats displayed below. 
Use the option, PAD_Form, to specify your preference. 

Choose from the following list for help on specific areas of the message pad:

Review an old message
Print current message
Save current message to Folder
Increment/decrement For (To) field
Increment/decrement Date and Time fields
Add / Modify current Caller fields to cardfile
For (To) Field
Date and Time Field
From (M), Of, and Phone Fields
Flag Fields
Message Field
Note Field
Scrolling in fields





Options Menu

The Options menu includes commands that enable you to modify Messages' default settings.

For more information, select the Options menu command name:

Set Options Modify or reset default settings.
Set Font Change the current log window font (log window only).
Set Password Change your login password.



File Menu

The File menu includes commands that enable you to open and save files, select messages, and 
to print.

For more information, select the File menu command name:

Open Open the specified logfile(s). 
Save As Save an open logfile.
Print Print selected message(s).
Printer Setup Specify the printer and printer options to use.



Edit Menu

The Edit menu includes commands that enable you to move text to and from the Clipboard, to 
delete text, and to undo a previous editing operation.

For more information, select the Edit menu command name:

Clear Deletes text without moving it to the clipboard.
Copy Copies text to the clipboard.
Cut Deletes text and moves it to the clipboard.
Paste Moves text from the clipboard to the edit window.
Undo Cancels a previous operation.



Help Menu

The Help menu includes commands to get Help while running Messages.

For more information, select the Help menu command name:

Contents
Search for Help On
Keyboard Help
How to Use Help
About Messages



Exit Messages

Use this command to exit from Messages.    This command may be called by pressing 
Alt-F4 (note:    if the CLOSE_EXITS_PROGRAM option is no, this key only exits 
from the icon.    Alt+F4 from the PAD or LOG would return to the icon).



Glossary

cardfile
clipboard
enter
field
flag
logfile
template
click
double-click
right-click
select



messages.ini Entries

The listing below describes the Messages default values.

Messages GENERAL OPTIONS

USERNAME and MESSAGES_PASSWD are required entries.    Removal or moficication of these entries 
could cause MESSAGES to fail to run.

ICON_ALWAYS_ON_TOP, PAD_ALWAYS_ON_TOP, LOG_ALWAYS_ON_TOP determine whether 
the icon, message-pad and/or message-log (respectively) will always remain visible, even when 
another application is running (defaults:NO to window/pad, YES to ICON).

ICON_Always_On_Top=YES
PAD_Always_On_Top=NO
LOG_Always_On_Top=NO

ALWAYS_RETURN_TO_APP determines whether the message-pad will return automatically to the last 
active application from which you jumped into MESSAGES (default:YES).

Always_Return_To_App=YES

STARTUP_AS determines whether MESSAGES will startup as the message LOG, the message PAD or as 
an ICON (default: ICON)

Startup_As=ICON

EXIT_ON_SAVE determines whether the SAVE button on the message-pad will also cause the message-
pad to exit (default:YES).

Exit_On_Save=YES

EXIT_ON_PRINT determines whether the PRINT button on the message-pad will also cause the 
message-pad to exit (will save first if SAVE_ON_PRINT is YES) - (default:NO).

Exit_On_Print=NO

SAVE_ON_PRINT determines whether the PRINT button will also automatically SAVE the message 
(default:YES).

Save_On_Print=YES

CLOSE_EXITS_PROGRAM determines whether the CLOSE menu item (and ALT-F4 hotkey) will exit 
from MESSAGES when executed from the message-pad and the message-log, or simply return to the 
icon (default:YES).    Close will always exit when executed from the icon.

Close_Exits_Program=YES



DELETE_ON_READ determines whether READING a message will automatically flag it as DELETED 
(default:NO).

Delete_On_Read=NO

CARDFILE to use in preloading "FROM (M)" fields after from-name is entered 
(default:CALLERS.CRD).

Caller_CardFile=CALLERS.CRD

MESSAGES can add or modify the cardfile "FROM" fields (if a cardfile is specified above) 
 (options:    ALWAYS, NEVER, CHECKON, CHECKOFF) (default:CHECKON).

Modify_Cardfile=CHECKON

AREACODE specifies the default areacode to be used in the "PHONE" field (default:initialized by setup).

Default_AreaCode=000

CARDFILE containing the names to be pre-defined for the "FOR (TO)" field on the message-pad 
(default:INBOXES.CRD).

InBox_CardFile=INBOXES.CRD

If this option is turned on the "Set Options..." dialog box will include a button that can be used to start 
NotePad (or other text editor).    (default:NO).

Options_Editor_Button=YES
Options_Editor=notepad.exe

MESSAGES DISPLAY OPTIONS

WINDOW DEFAULT POSITIONS...
LOG_x defines where the main window will be placed initially...
_STYLE can be one of:    1=normal, 2=minimized, 3=maximized,
if _style is "normal" _x, _y, _w, and _h can be used to specify
the default x & y, width & height.

LOG_X=0
LOG_Y=0
LOG_W=1000
LOG_H=1000
LOG_Style=3

PAD_X and PAD_Y specify a screen location for the Message-Pad.    If these options are not used or are 
less than 1, the pad is placed by Windows.



PAD_X=
PAD_Y=

ICON_X and ICON_Y specify a screen location for the icon.    If these options are not used or are less than 
0, the icon is placed by Windows (default: placed by Windows).

ICON_X=
ICON_Y=

LOG_BKGND and PAD_BKGND, LOG_FRGND and PAD_FRGND define the background and 
foreground colors, for the LogFile windows and Message-Pad, respectively, and can be:    (case 
ignored)
BLACK, RED, BLUE, GREEN, YELLOW, MAGENTA, CYAN, WHITE,
DKRED, DKGREEN, DKBLUE, TAN, PURPLE, AQUA, GRAY, LTGRAY, 
or a hexadecimal RGB value (two hex chars each for Blue,Green,and Red).

LOG_Bkgnd=ltgray
LOG_Frgnd=black

PAD_Frgnd=black
PAD_Bkgnd=magenta

PAD_FONTFACE and LOG_FONTFACE (and _FONTSIZE) define the font to use in the message 
pad/log windows    (defaults are the system defaults).

LOG_FontFace=
LOG_FontSize=

PAD_FontFace=
PAD_FontSize=12

PAD_FORM - defines the message-pad form to use 
(choices currently include PINK_PAD (square) and BLUE_PAD (horizontal rectangle))    
(default:PINK_PAD)

PAD_Form=PINK_PAD

INIT_TO_NAME determines whether the first person in the INBOXES cardfile (if a cardfile is specified 
above) is automatically inserted in the "For (To)" field when the form appears (options:NONE or n 
where n is the nth card in the cardfile) (default:1).

Init_To_Name=1

MULTILINE_TO_FIELD determines whether or not the "TO" field uses carriage-returns (enter-key) to 
enter additional names or to move to the next field (default:NO (move)).

MultiLine_To_Field=NO



AUTOFILL determines whether or not to fill the "OF" and "PHONE" fields for a given "FROM", using 
the cardfile specified above (default:YES).

AutoFill=YES

MULTILINE_CALLER_FIELDS determines whether the "OF" and "PHONE" fields for a given 
"FROM" use carriage-returns (enter-key) to enter additional lines (default: NO (move)).

MultiLine_Caller_Fields=NO

COMPLETE_TO_NAME and COMPLETE_FROM_NAME determine whether or not to attempt to 
anticipate the names being typed in the "TO" and "FROM" fields (defaults: NO).

Complete_To_Name=NO
Complete_From_Name=NO

CAPITALIZE_NAMES determines whether or not to automatically capitalize the first character in each 
word in the "TO" and "FROM" fields    (default:NO).

Capitalize_Names=NO

MULTIPLE_ICON_FLAGS determines whether or not multiple icons may be selected for a given 
message.    If YES, the selection must be made (or unmade) using the <Space> key, otherwise just 
normal selecting (default:NO).

Multiple_Icon_Flags=NO

These options can be used to change the format used in date and time strings on the message-pad (as 
opposed to Date_MDY and Time_12hr) (defaults:NO).

Date_DMY_Format=NO
Time_24hr_Format=NO

These options can be used to automatically pre-select the specified checkboxes on the message-pad 
(defaults:NO).

Phoned_Default_On=NO
Called-To-See-You_Default_On=NO
Wants-To-See-You_Default_On=NO
Please-Call-Back_Default_On=NO
Will-Call-Again_Default_On=NO
Returned-Call_Default_On=NO

SHOW_EXCERPTS determines whether the first several words of the message should be displayed in the 
log message-list and in the message-select box (default:NO).

Show_Excerpts=YES



SHOW_FLAGS determines whether the icon-flags of the message should be displayed in the log message-
list and in the message-select box (default:NO).

Show_Flags=YES

SHOW_TIME determines whether the time of the message should be    displayed in the log message-list 
and in the message-select box (default:NO).

Show_Time=YES

MESSAGES PRINTER OPTIONS

LOG_PRINT_TEMPLATE and PAD_PRINT_TEMPLATE are used to define the default printing 
formats. (NONE=PROMPT USER) 
(defaults:message-pad=trackltr.frm, other=4up-ltr.frm).

LOG_Print_Template=4up-ltr.frm
PAD_Print_Template=trackltr.frm

PRINT_FONTFACE (and _FONTSIZE) defines the font to use in printing messages.    
PRINT_FONTSIZE is only used when printing an entire logfile, otherwise the best-fit fontsize will be 
used. (defaults: fontface=ARIAL, fontsize=12)

Print_FontFace=ARIAL
Print_FontSize=12

PRINTERDEVICE is used to define the default printer.    Must be of the format 
DEVICENAME,DRIVER,PORT:    and must be found in win.ini (see Control Panel) (NONE=system 
default) (default:NONE)

PrinterDevice=NONE

LOG_TEMPLATE_PROMPT and PAD_TEMPLATE_PROMPT define whether to force the use of the 
default templates defined above or to prompt at printing time (options:ALWAYS,NEVER,FIRST)    
(defaults:NEVER to PAD_TEMPLATE_PROMPT,ALWAYS to LOG_TEMPLATE_PROMPT).

LOG_Template_Prompt=ALWAYS
PAD_Template_Prompt=NEVER

DEVICE_PROMPT defines whether to force the use of the default printerdevice defined above or to 
prompt at printing time (options:ALWAYS,FIRST)    (default:FIRST).

Device_Prompt=FIRST



Message Pad - Review Messages

Messages provides two methods to view the messages in the currently open logfile: 

· use the Message Log menu command to view entire logfiles,

· scroll forward/backward through the messages, displaying one at a time on the 
message pad.

To scroll the message pad, mouse click on the pad scrollbutton , left to scroll forward, right to 
scroll backward. 

To view messages from other daily logfiles, use the File menu Open command.

By default, "historic" messages will not automatically be saved when the message-pad Print 
button (if the SAVE_ON_PRINT option is on) is pressed. 

See also:
Message Log Command



Message Pad - FOR (TO) Field

The option, InBox_CardFile, can be used to supply names that may be entered in the For (To) 

field.    If a cardfile is supplied, the dropdown button  (or the up-arrow and down-arrow keys) 
can be used to view and scroll up and down through the list, each name being automatically 
entered into the field.    More information on this field is available in the Message Pad - Cardfile 
topic.

If the option, Init_To_Names, is set, the first (or specified) name in the list will automatically be 
placed in the field. 

See also:
Message Log Command
messages.ini Entries



Message Pad - DATE and TIME Fields

The Date and Time fields are automatically initialized to the system date and time.    They may 
be changed manually by typing a new value into the appropriate field.    If a legitimate date/time 
is entered, the field will be formatted when you leave it.    Scrolling the date and time fields will 
increment/decrement the date/time (see below).

The default formats are 
Sat Jan 2 1992 (Month-Date-Year format)
11:00 PM (12-hour format)

Optional formats are:
Sat 2 Jan 1992 (Date-Month-Year format)
23:00 PM (24-hour format)

You can specify the formats by using Windows' Control Panel (International Settings), or by 
setting the options, Date_DMY_Format and/or Time_24HR_Format,. 

The Date and Time fields have special scrolling features.    Click on the field scrollbutton  or 
use the following keys:

Up Arrow increment date/time by one day/minute.
Down Arrow decrement date/time by one day/minute.
Shirt+Up Arrow increment date/time by one month/hour.
Shift+Down Arrow decrement date/time by one month/hour.
Control+Up Arrow increment date/time by one week/hour.
Control+Down Arrow decrement date/time by one week/hour.

See also:
Message Log Command
messages.ini Entries



Message Pad - FROM (M), OF and PHONE Fields

Like the For (To) field, the From (M) field is special in that it may be used as the connection 
between Messages and a Windows CardFile database.    More information on this field is 
available in the Message Pad - Cardfile topic.

The Of, and Phone fields are multiple-line fields which, like the From field, are capable of 
accepting up to 255 characters of text (see ENTER).    The multiple-line fields will automatically 
format and word-wrap.

See also:
Message Log Command
Message Pad Scrolling



Message Pad - FLAG Fields

The flag fields vary in sequence and name on the different Messages message pad forms.    But 
the flags are identical. 

Messages flags include:
Telephoned 
Please Call Back 
Returned Your Call 
Will Call Again 
Wants To See You 
Was In To See You 

Each of these is turned off by default, although the following options may be used to 
automatically preset the checkboxes on:

Phoned_Default_On
Called-To-See-You_Default_On
Wants-To-See-You_Default_On
Please-Call-Back_Default_On
Will-Call-Again_Default_On
Returned-Call_Default_On

Messages includes a set of icons that function as flags, as well.    These include:

no icon flags are set.

IMPORTANT flag.

RUSH flag.

URGENT flag.

SECOND CALL flag.

THIRD CALL flag.

CALLER IS ON HOLD flag.

PERSONAL flag.

FAX flag.

FYI flag.

PLEASE SEE OPERATOR flag.



See also:
Message Log Command



Message Pad - MESSAGE Field

Unlike any other field on the message pad, other than the Notes field, the Message field has 
virtually no size limit.    It is a multiline field which will automatically format and word-wrap its 
text to fit in the display box.    Use the Enter key to insert additional line breaks.

If the message consists of more lines than can display in the message field, the field will 
automatically scroll to keep the cursor visible.    Use the cursor movement keys and text edit keys 
to modify the message.

See also:
Message Log Command
Message Pad - Notes Field
Message Pad Scrolling



Message Pad - NOTES Field

Like the Message field, the Notes field has virtually no size limit.    It is a multiline field which 
will automatically format and word-wrap its text to fit in the display box.    Use the Enter key to 
insert additional line breaks.

If the note consists of more lines than can display in the message field, the field will 
automatically scroll to keep the cursor visible.    Use the cursor movement keys and text edit keys 
to modify the message.

If your computer and Windows are set up to support a Pen device, the Notes field can contain 
handwritten notes which may be saved in that form.

See also:
Message Log Command
Message Pad - Message Field
Message Pad Scrolling



Message Pad - Scrolling in fields

Scrolling and moving around the message pad can be accomplished with or without a mouse, to 

move between fields, either click on the destination-field with the  left mouse button, or use 
the following keys:

Tab, or ENTER jump to next field.
Shift-Tab jump to previous field.
Page Up jump to previous field.
Page Down jump to next field.

See also ENTER

To edit/view text, click the left mouse button in the field or on the field's scrollbuttons 

, or move within the field using the following keys:
Up Arrow scroll up one line within the field (see exceptions below).
Down Arrow scroll down one line within the field (see exceptions below).
Left Arrow scroll left within the field.
Right Arrow scroll right within the field.
Backspace delete the character before the cursor.
Del delete the character after the cursor.

Exceptions to the these scrolling rules are noted in the topics regarding the For (To) field and 
Date and Time fields.

Click anywhere in Messages with the right mouse button  to "popup" the main (Control) 
menu.



See also:
Accelerator Keys
messages.ini Entries



Message Pad - Printing

      Click on the message-pad Print button to print the current message. 

The printing template defined by the option, PAD_Print_Template, will be used to determine 
the default page layout.    If no default layout is specified, Messages will prompt for a template 
file.

If the option, Save_On_Print, is on, the message will be saved before printing.

See also:
File - Print Command
messages.ini Entries



Message Pad - Save Message

      Click on the message-pad Save button to save the current message in the open 
logfile.    If the currently open logfile is not the default daily log, a warning message will be 
displayed to remind the user to first reopen the correct logfile.

If the option, Save_On_Print, is on, the message will be saved before printing.

See also:
File - Open Command
File - Print Command
messages.ini Entries



Message Pad - Card File

Messages can use files of the Windows cardfile format as a callers database for the From (M), 
Of, and Phone fields, and as a inbox database for the For (To) field.

If the option, Caller_CardFile (or InBox_Cardfile), supplies a file of the proper format, the 
data will be scanned as a name is entered in the From (M) field (or For (To) field).    If the 
option, Complete_From_Name (or Complete_To_Name) is on, the name will be 
predetermined, if possible.    If the name is found, the corresponding field will be filled in,    If the 
From (M) name is found, Of and Phone fields will also be filled in. 

Adding a Card File Entry

If the name in the From (M) field is not found in the caller cardfile, one of four things will 
happen, depending upon the setting of the Modify_CardFile option:

Always automatically add the From, Of and Phone fields to the cardfile when the 
Save button is clicked.

Never no action, do not modify the cardfile.

CheckOn place a checkbox,    Add, preset to on,on the screen.    If the checkbox is 
checked when the Save button is clicked, the From, Of and Phone fields 
will be added to the cardfile.

CheckOff place a checkbox,    Add, preset to off,on the screen.    If the checkbox is 
checked when the Save button is clicked, the From, Of and Phone fields 
will be added to the cardfile.

Modifying a Card File Entry

If the From field name is found in the cardfile, and the Of or Phone field is subsequently 
changed, one of three things will happen, depending upon the setting of the Modify_CardFile 
option:

Always automatically update the Of and Phone fields in the cardfile when the Save 
button is clicked.

Never no action, do not modify the cardfile.

CheckOn place a checkbox,    Modify, preset to on,on the screen.    If the checkbox 
is checked when the Save button is clicked, the From, Of and Phone fields 
will be updated in the cardfile.

CheckOff place a checkbox,    Modify, preset to off,on the screen.    If the checkbox 
is checked when the Save button is clicked, the From, Of and Phone fields 
will be updated in the cardfile.

Notes: 
Messages makes every attempt to prevent damage to or loss of your cardfiles.    This is 
accomplished by writing only to a temporary cardfile (e.g., callers.tmp), and saving the 



existing cardfile as a backup (e.g., callers.bak) before replacing it with the temporary.    If any 
message indicating that reading, writing, or saving the cardfile failed, remember that any 
unsaved changes are likely still in the temporary and that your backup cardfile is still in the 
same directory.    In the event of a problem or machine/system crash, these files can replace 
the cardfile using DOS copy or Windows File Manager. 

A message stating that the cardfile is not recognizable can mean one of two things: 
(1) the cardfile was modified by another application that inserted non-textual data into it, or 
(2) the memory offsets that Messages uses to allow fast scanning of the cardfile no longer 
match the file itself.    This latter case may also be the result of another application modifying 
the cardfile, and can usually be overcome by exiting Messages and restarting.

See also:
messages.ini Entries





Accelerator Keys

Messages Accelerator Keys

Message-Pad Accelerator Keys

Message-Log Accelerator Keys

The keyboard topics below come from Help for Windows.    Any exceptions in Messages are 
noted.    Choose from the following list to review the keys used in Windows:

Cursor Movement Keys

Dialog Box Keys

Editing Keys

Menu Keys

System Keys

Text Selection Keys

Window Keys



Messages Accelerator Keys

Messages keys are effective as long as the current active window is the Message Pad, the 
Message Log, or the Messages icon.

Key(s) Function

Alt+Space Drop down the main (Control) menu.
F1 Help index
Alt+F1 About Messages
Shift+F1 Search for Help On
Control+F1 Help on help
Control+Shift+F1 Keyboard Help
Alt+F4 Exit Messages
F5 Message-Pad
F6 Message-Log
F7 Start options editor
Shift+F7 Choose window font
F9 Open logfile
Alt+F9 Printer setup
Control+F9 Save logfile and/or message
Shift+F9 Print
Esc Return to icon/log/pad



Message Pad Accelerator Keys

Message Pad keys are effective as long as the active window is the Message Pad.

Key(s) Function

Enter Same as Tab, move from field to field.
Up Arrow Scroll field up.
Down Arrow Scroll field down.
Del Clear edit field.
Control+Z Undo last edit (or last undo).
Shift+Del or Control+X Cut from edit field to clipboard.
Control+Ins or Control+C Copy from edit field to clipboard.
Shift+Ins or Control+V Paste to edit field from clipboard.
Esc Return to icon/log

Alt+O Jump to For (To) field.
Alt+M Jump to From (M) field.
Alt+F Jump to Of field.
Alt+N Jump to Phone No. field.
Alt+B Jump to By field.
Alt+G Jump to Message field.
Alt+E Jump to Date field.
Alt+T Jump to Time field.
Alt+P Print current message
Alt+S Save current message
Alt+D Add/Modify current From in cardfile
Alt+H Toggle Telephoned flag checkbox.
Alt+C Toggle Please Call Back flag checkbox.
Alt+R Toggle Returned Your Call flag checkbox.
Alt+A Toggle Will Call Again flag checkbox.
Alt+W Toggle Wants To See You flag checkbox.
Alt+I Toggle Was In To See You flag checkbox.

F10 Show/Hide Notes field.

Control-F Popup File Menu
Control-E Popup Edit Menu
Control-O Popup Options Menu
Control-H Popup Help Menu



Message Log Accelerator Keys

Message Log keys are effective as long as the active window is the Message Log Viewer.

Key(s) Function

Enter View selected message(s).
Del Delete selected message(s).
Alt+Del Undelete selected message(s).
Shift+Del or Control+X Cut selected message(s) to clipboard.
Control+Ins or Control+C Copy selected message(s) to clipboard.



Cursor Movement Keys

Key(s) Function
Direction (arrow) key Moves the cursor left, right, up, or down in a field (see 

exceptions in Message Pad Keys).
End or Control+Right Arrow Moves to the end of a line.
Home or Control+Left Arrow Moves to the beginning of a line.
PageUp or PageDown Moves up or down in a field, one screen at a time(see 

exceptions in Message Pad Keys).



Dialog Box Keys

Key(s) Function

Tab Moves from field to field (left to right and top to bottom).

Shift+Tab Moves from field to field in reverse order.

Alt+letter Moves to the option or group whose underlined letter 
matches the one you type.

Direction key Moves from option to option within a group of options.

Escape Closes a dialog box without completing the command. 
(Same as Cancel)

Alt+Down Arrow Opens a drop-down list box.

Alt+Up or Down Arrow Selects item in a drop-down list box.

Spacebar Cancels a selection in a list box.
Selects or clears a check box.

Control+Slash Selects all the items in a list box.

Control+BackSlash Cancels all selections except the current selection.

Shift+ Direction key Extends selection in a text box.

Shift+ Home Extends selection to first character in a text box.

Shift+ End Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.
Or, deletes selected text.

Delete Deletes the character to the right of the cursor.
Or, deletes selected text.



Menu Keys

Key(s) Function

Alt+Spacebar Pulls down the Control menu.

Left or Right Arrow Moves among menus.

Up or Down Arrow Moves among menu items.

Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are using.

Key(s) Function

Control+Escape Switches to the Windows Task List.

Alt+Escape Switches to the next application window or minimized 
icon, including full-screen programs.

Alt+Tab Switches to the next application window, restoring 
applications that are running as icons.

Alt+PrtSc Copies the entire screen to Clipboard.

Ctrl+F4 Closes the active window.

F1 Gets Help and displays the Help Index for the application.



Text Selection Keys

Key(s) Function

Shift+Left or Right Arrow Selects text one character at a time to the left or right.

Shift+Down or Up Arrow Selects one line of text up or down.

Shift+End Selects text to the end of the line.

Shift+Home Selects text to the beginning of the line.

Shift+Page Down Selects text down one window.

Or, cancels the selection if the next window is already 
selected.

Shift+Page Up Selects text up one window.

Or, cancels the selection if the previous window is 
already selected.

Control+Shift+Left or Right Arrow Selects text to the next or previous word.

Control+Shift+Up or Down Arrow Selects text to the beginning (Up) or end (Down) of the 
paragraph.

Control+Shift+End Selects text to the end of the document.

Control+Shift+Home Selects text to the beginning of the document.



Window Keys

Key(s) Function

Alt+Spacebar Opens the Control menu for an application window.

Alt+Hyphen Opens the Control menu for a document window.

Alt+F4 Closes a window.

Alt+Esc Switches to the next application window or minimized 
icon, including full-screen programs.

Alt+Tab Switches to the next application window, restoring 
applications that are running as icons.

Alt+Enter Switches a non-Windows application between running in a 
window and running full screen.

Direction (arrow) key Moves a window when you have chosen Move from the 
Control menu.
Or, changes the size of a window when you have chosen 
Size from the Control menu.





Options - Set Options Command

Use this command to execute the Options Editor to set / reset / modify Messages' default 
settings.

The Options Editor provides a graphical interface to the defaults and options stored in 
messages.ini.    The options are subdivided into groups, each represented by an icon. 

      Click on an icon in the "Groups" field then click on the Select button to 
display the group's variable names and values in the "Current Values" field (double-clicking on 
an icon has the same effect).

Click on a line within the "Description" field to display a textual explanation of the selected 
variable in the "Current Values" field. 

Enter a change in the "New Value" field, which may change in appearance depending upon the 
type of variable selected.    The entry may consist of a menu selection or a value typed in. 

      Click on the Ok button to save the changes in the messages.ini file. 

      Click on the Reset button to reload the selected group from messages.ini.    Reset 
will not change values once Save has been pressed.

      To reset ALL the values in the messages.ini file to the factory presets, click on 
the Factory button, then on the Save button.

      Click on the Exit button to leave the Options Editor.

See also:
messages.ini Entries





Options - Set Font Command

Use this command to change the font used in the current Message Log window. 
This.is a temporary change.    Use the Set Options... command to make permanent changes.

See also:
Option - Set Options Command



Options - Set Password Command

Use this command to change the your login password. 

See also:
Option - Set Options Command



File - Open Command

Use this command to open existing logfile(s). 

Using this command, multiple logfiles can be opened at one time.    The messages in the open 
logfiles can be viewed or printed.

See also:
File - Print Command



File - Save As Command

Use this command to save and name the currently open logfile. 

The currently open logfile can be saved as either a formatted logfile with a new name, or as a 
plain-text file.

See also:
File - Open Command



File - Select Command

Use this command to select messages from currently open logfiles. 

This command will temporarily open multiple logfiles simultaneously.    The temporarily opened 
files will be closed upon exiting the dialog box.

Messages can be selected based upon any one of several filters:

ALL: all messages in the logfile(s).
TO: messages taken for the specified name.
FROM: messages from a specified source.
DATE: messages taken on a specified date.
OF: messages from a specified source company.
PHONE: messages from a specified source phone number (or areacode).
FLAG: messages with a specified flag (or icon). 
BY: messages taken by a specified operator.
UNPRINTED: all unprinted messages.
UNREAD: all unread messages.
User Flag 1: messages with User-Flag-1 set.
User Flag 2: messages with User-Flag-2 set.
User Flag 3: messages with User-Flag-3 set.

The selection filter can be used to include or exclude messages.    For example, all messages for a 
specific person can be included, or all messages except those for the specific person.    To 
exclude, select the Exclude checkbox.

The Exact Match checkbox can be used to force a character-by-character match between the 
specified filter string and the appropriate message field.    The default will allow the specified 
filter string to be a subset of the message field. 

See also:
File - Open Command
File - Print Command





File - Print Command

Use this command to control printing of messages. 

The Print command will prompt for the printer to use.    The messages.ini options 
Device_Prompt, LOG_Template_Prompt,. and PAD_Template_Prompt control whether to 
prompt for the template and whether subsequent printing will use the same template and printer 
settings.    To change the printer or print settings, use the Printer Setup... command. 

· if messages have been selected from the log window, they will be printed,
· otherwise, the Select... command is run.

See also:
File - Printer Setup Command



File - Printer Setup Command

Use this command to specify a printer and it's connections.

See also:
File - Print Command



Edit - Clear Command

Use this command to remove selected text from the message-pad, without copying it to the 
Clipboard. 

This command is unavailable if you have no selected text.

Selected text is a selected field on the Message Pad.



Edit - Copy Command

Use this command to copy selected text onto the Clipboard. 

This command is unavailable if you have no selected text.

Selected text can be either a selected field on the Message Pad or selected message(s) from the 
Message Log window.



Edit - Cut Command

Use this command to remove selected text from the message-pad and put it on the Clipboard. 

This command is unavailable if you have no selected text.

Selected text is a selected field on the Message Pad.



Edit - Paste Command

Use this command to insert a copy of the Clipboard at the insertion point. 

This command is unavailable is the Clipboard is empty.



Edit - Undo Command

Use this command to reverse the last editing action (or last undo command), if possible. 

The Undo command is disabled on the menu if you cannot reverse your last action.



Log - Flag Command

Use this set of commands at a Message Log window to flag selected messages with one of the 
user-defined flags. 

This command is unavailable if you have no selected messages.



Log - Delete Command

Use this command at a Message Log window to delete selected messages, without copying it to 
the Clipboard. 

This command is unavailable if you have no selected messages.



Log - Copy Command

Use this command at a Message Log window to copy selected messages onto the Clipboard. 

This command is unavailable if you have no selected messages.



Log - Cut Command

Use this command at a Message Log window to delete selected messages and copy them on the 
Clipboard. 

This command is unavailable if you have no selected messages.



Help - Contents Command

Use this command to get help on using Messages.    The entry point will be the Table of 
Contents.



Help - Search for Help On Command

Use this command to specify keywords on which to search for help. 



Help - Keyboard Command

Use this command to get help on using the keyboard (with or without a mouse) to run 
MESSAGES. 



Help - How to Use Help Command

Use this command to obtain help on using this help program.



Help - About MESSAGES Command

Use this command to see the About Messages dialog box:





Clipboard

A temporary storage area for cut or copied text. You can paste the contents of the Clipboard 

into any edit field or into a file of another application, such as Microsoft Word. The Clipboard 

holds the information until you cut or copy another piece of text.



Click

 
Press and release the left mouse button.
If using a pen, press and release the pen button.



Double Click

 
Quickly press and release the left mouse button twice without moving the mouse. 
If using a pen, press and release the pen button twice.



Right Click

 
Press and release the right mouse button.
If using a pen, press and release the pen button while depressing the Shift key.



Select

Choose an item by clicking on it or by using the Tab key and the Up or Down Arrow keys to 

move the selection bar to it.    The selected item displays in a different color or with a box 

surrounding it.



LogFile

The Messages "logfile" is a formatted file containing a specific day's or person's messages.    

A logfile can also be a "folder" of messages stored together. Each message contains special 

character codes that facilitate searching through fields and printing. 



Flag

A Messages "flag" is any of the checkboxes (e.g., Telephoned) or icons (e.g., Urgent) on the 

message pad.    Each message may have a number of flags and one icon associated with it. 



Template

A Messages "template" is a text file used to define a format in which messages will be 

printed.    A number of these are provided with this release of Messages (e.g., 1up-

form.frm, 4up-form.frm, tracker.frm).



Field

A Messages "field" is a text edit box.    

You'll notice that whenever you move the mouse pointer over a field, the cursor changes 

from the normal arrow to the "I-beam" and that when you click on a field (or move to a 

field using the Tab key), the blinking text-entry bar can be seen.

Using the mouse or the Tab key to move from field-to-field , you can "select" all or a part 

of the text in a field.    The selected text is visibly highlighted, and can be replaced by 

hitting any key or selecting a Clipboard command from the Edit menu.

Some fields on the message pad are multiple-line fields.    These are generally identified 

by the presence of a scrollbutton beside the field.    The Message field is an exception in 

that it has a scrollbar rather than a scrollbutton.      Multiple-line fields automatically word-

wrap long lines, inserting carriage-returns to allow the lines to fit within the display width 

of the field.    User-input carriage-returns (see ENTER) may also be used to break lines.



Enter

      If the option, MULTILINE_CALLER_FIELDS, is on, the Of and Phone fields will accept 
carriage-returns within the multiple line entries.    Otherwise, Enter will jump to the next field. 

Similarly, the MULTILINE_TO_FIELD option, if on, allows multiple lines to be inserted in the For (To) 
field.

Note:    the Of and Phone fields will always word-wrap long lines into multiple-lines and accept 
Control+Enter as a carriage-return within the field.



CardFile

A "cardfile" is in a format defined by Microsoft's Windows Cardfile application.    This 

useful application can be used to initialize and maintain an "address book" of clients or 

customers from whom you may expect frequent calls.    Any additions and/or 

modifications made by Messages are faithful to the cardfile format.



Information in this online document is subject to change without notice and does not 
represent a commitment on the part of Software Grove Corporation.    The software and/or 
databases described in this document is furnished under a license agreement or 
nondisclosure agreement.    The software and/or databases may be used or copied only in 
accordance with the terms of the agreement.    It is against the law to copy the software on 
any medium except as specifically allowed in the license or nondisclosure agreement.    The 
purchaser may make one copy of the software for backup purposes.    No part of this online 
document and/or databases may be reproduced or transmitted in any form or by any means, 
electronic or mechanical, including photocopying, recording or information storage and 
retrieval systems, for any purpose other than the purchaser's personal use, without the 
express written permission of Software Grove Corporation.

ã Copyright Software Grove Corporation, 1992-1993.    All rights reserved.

Software Grove is a registered trademark and Software Grove Messages is a trademark of Software Grove 
Corporation.




