Welcome to the Do 3D online tutorials, which explain how to build exciting realtime 3D worlds.
Before you start the tutorials, we recommend that you familiarize yourself with:

8 The Do 3D window

8 How to use the tutorials

To follow the tutorials click one of the following:
8 Creating a simple world

§ Manipulating objects

§ Aligning objects

§ Materials

8 Actions and sounds




How to use the Superscape Tutorials

Each short tutorial contains steps that achieve a particular task. The instruction sequences include
words underlined with dotted green lines and sometimes unbroken green lines. Click the dotted lines to
display popup windows, which may display pictures of toolbar icons you need to click, or contain
explanations of particular concepts. Click the unbroken lines to jump to new topics.

Click the buttons in the Help window to navigate through the tutorial or display extra information. The
following buttons are used:

Button Action

Displays the next topic in the sequence; you can also press the right arrow key;
Displays the previous topic in the sequence; you can also press the left arrow key;

Displays further information about the current topic;
Runs a movie that shows you how to complete a task;
Takes you back to the Contents window;

Exits the tutorials.

In addition, the Contents button in the Help window toolbar takes you back to the Contents window.

We recommend that you work through the tutorials in the order that they are listed. Click here to go to
the first tutorial Creating a Simple World.




Warehouse — click-and-drag objects.

textures and sounds into the 3Space window

Urvtitleat - 01030

Ein Edb Mew windew [Hek

3Space window — build
and preview your worlds

[owe & sk < »mm

[ ovects 4t Sound| BRb 400

by |_Dm.m*.-pmm

Areh Dtk freh Light

E R

Coner Dok, Highy  Cone Dk Low

4 ||
e Y

Faads

[

Attributes palette — set each ohject's
appearance, sound, actions, position

e “‘E{:’_iﬂi) 4]z @ 3

Movement bar — click-and-drag
the icons to mowe around the world



Creating a simple world

This tutorial shows you how to create a simple world, move around it in realtime and then add, move
and resize objects.

If you want a printed copy of this tutorial, click here.



Load a world

3 Choose File>New, and double-click the template Blank World to load a blank world.

For the best results, Do 3D should cover the whole of your screen. If it does not, click the
Maximize icon in the title bar of the program.

As you do not need the Attributes palette in this tutorial, choose Window>Attributes Palette (or
click the Exit icon in the top right hand corner of the palette) to hide it.



Add a snowman
1. Click Objects in the Warehouse.
2. Click People in the Category drop-down list.
All the objects in this category are displayed in the scroll box.

To find out information about an object, click the What's This? icon in the toolbar and click the
object. A popup description appears.
3. Click the object Snowman. Drag it into the 3Space window and drop it in the middle behind the

default cube object in the foreground. As you drag the object in, it is surrounded by its editing frame
(dark blue) and its position is indicated by a crosshair (light blue).



Add a bench
1. Click Chairs, Benches, Tables in the Object Warehouse Category drop-down list.

2. Scroll down the list, click the object Wood Bench Straight S and drag it into the 3Space window.
Place it to the left of the Snowman and level with it.

Your 3Space window should now look like this.



Walk around the world

1.

2.

Click the Play icon in the toolbar. This lets you to see the world as it would appear if you displayed
it in Viscape on the World Wide Web.
Click the Walk icon in the toolbar. This mode lets you move around the world at a fixed height, with

collisions active so you cannot move through objects. The Move Up and Down icons on the
movement bar (at the bottom of the 3Space window) are unavailable.

. Click-and-drag the Move Forward icon on the movement bar and move directly towards the

snowman, passing over the default cube.

When you reach the snowman, all forward movement is stopped. Release the mouse button. You
cannot move through the object as collisions are active.

. Click-and-drag the Move Back icon to move back a little way from the Snowman.
. Click-and-drag the Tilt Up and Down icons to look up and down the snowman, and the Rotate Left

icon to turn to the left, and the Rotate Right icon to turn to the right.
Adjust the viewpoint so that you are looking at the snowman.



Fly around the world

1.
2.

Click the Fly icon in the toolbar. Now you can move through objects in any plane.

Click-and-drag the Move Forward icon on the movement bar and move directly towards and
through the snowman.

You should now be looking at the horizon.

. Use the other icons to move around the world in fly mode. For example, click on the Rotate left icon

to turn to the left until you can see the back of the snowman.

. When you have finished experimenting, click the Reset World icon to reset the viewpoint to its initial

position in the world.



Move the showman

1.
2.

X
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Click the Edit Object icon in the toolbar to display the world in Edit Object mode.
Click the snowman.

The object is now surrounded by a frame (dark blue) that lets you manipulate the object. It contains
green grips in the center of the faces that you use to move the object, and gray grips in the corners
that you use to resize it.

. Click the green grip in the center of the front of the snowman and with the mouse button still

pressed drag the object up. This movement grip turns yellow as you click it. Release the mouse
button.

As you move the object you will see two horizontal guides on the ground and a vertical guide
running from the object to the ground. These indicate the object's horizontal and vertical position in
the world.

. Click-and-drag the same movement grip towards the right side of the 3Space window, and then

down until the movement grip turns red. This indicates that the object is colliding with the ground.
For more information on collisions, see the Manipulating Objects tutorial.



Resize the bench

1. Click the bench.

2. Click-and-drag the bottom right resize grip on the front of the bench towards the snowman. The grip
turns yellow as you click it.

As you drag the mouse right to enlarge the bench, make sure that you also drag it down a little so
that the grip turns red indicating that the object is still colliding with the ground. Release the mouse
button when the right end of the bench is close to the snowman but not touching it.



Move around the world
1. Click the Play icon in the toolbar.
2. Move around the world using the movement bar to see what it now looks like.

3. Choose File>Save to save your virtual world. Type SIMPLE.SVR in the Name box in the Save
dialog box, and click OK.



Congratulations

You have successfully completed the Creating a Simple World tutorial.
Topics covered in this tutorial include:

Loading a world;

Walking and flying around a world;

Adding objects;

Moving and resizing objects.
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Further information

For more information on topics covered by or related to this tutorial, choose Help>Help Topics and then
choose from the following books or topics:

For the Do 3D interface: What is Do 3D?>The Do 3D Window.

For general information on objects, including grips and guides: What is Do 3D?>Objects.
For moving around worlds: What is Do 3D?>Viewpoints and moving around.

For adding, moving and resizing objects: How do I?>Build a World>Add an object.
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Manipulating objects

This tutorial shows you how to open a world based on a template, set a viewpoint, position objects in a
template, and rotate objects.

We recommend that you have completed the Creating a Simple World tutorial before you follow this
tutorial, as it explains many of the basic concepts you will use.

If ﬁou want a printed copy of this tutorial, click here.



Load a world

Choose File>New, and double-click the template Street to load the street world.

The 3Space window displays a world containing a street surrounded by buildings.

For the best results, Do 3D should cover the whole of your screen. If it does not, click the
Maximize icon in the title bar of the program.

If the Attributes palette is open, choose Window>Attributes Palette (or click the Exit icon in the top
&gﬁlt corner) to close it, as you will not need it in this tutorial.



Set a viewpoint
1. Click the Fly icon so you can move in any plane.

2. Use the movement bar to turn to the left, move to the end of the street, and turn around so that you
can see both sidewalks clearly. Then move the viewpoint up so that you are looking at the street
like this.

3. Click the Set Viewpoint icon on the toolbar.
This sets the viewpoint for the world.

4. Use the movement bar to move to the left and then click the Reset World icon on the movement
bar.

The world is reset to the viewpoint you shapped.
3]
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Add a street lamp
1. Click Objects in the Warehouse.
2. Click Lights in the Category drop-down list.
Objects related to lights and lighting are displayed in the scroll box.

3. Click Street Lamp S in the Objects scroll box and drag it into the center of the street in the 3Space

window.
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Orientations

Many of the objects in the Warehouse are exactly the same, but have a different orientation (North,
South, East, West and so on). Whenever you add an object to a world you should use the object with
the correct orientation if possible, rather than using a similar object and rotating it, as unrotated objects
create a faster world. In addition, each orientation is lit using the same light source, so that rotating an
object may make it look less realistic.



Move the street lamp

1. Press cTRL and click the green grip in the center of the front of the street lamp and with the mouse
button still pressed drag up. This moves the lamp post object down the street. Pressing CTRL
moves the object perpendicular to the axes you are dragging.

Stop when it is opposite the tall gray building on the left hand side. Release the mouse button
before releasing CTRL, otherwise the object returns to its original position.

2. Click the same movement grip and drag the object up so it is above the street level (the light blue
vertical guide indicates the height of the object above the road), and then drag it to the left until the
lamp is above the sidewalk.

3. Drag the object down until it collides with the sidewalk. The sidewalk object is outlined in red, and
the selected movement grip on the lamp turns red, when the objects collide.

4. Drag the lamp to the right until the vertical part of the lamp is positioned correctly on the edge of the
sidewalk.

. Click the Play icon to see how the street looks in Play mode.
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Add another street lamp
1. Double-click Street Lamp N in the Objects scroll box in the Warehouse.
The object is automatically placed in the center of the street in the 3Space window.
2. Right-click on the right sidewalk in front of the far red building.
The object is automatically moved to the position you click.
3. Use the left mouse button to adjust the position of Street Lamp N on the edge of the sidewalk.
]
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Duplicate the street lamps
1. Make sure that Street Lamp N is selected.
2. Click the Copy icon on the toolbar.
3. Click the Paste icon on the toolbar.
A duplicate street lamp is displayed in the center of the window.

4. Drag the duplicate object with the right mouse button until it is positioned on the right sidewalk in
front of the nearest red building.

5. Duplicate Street Lamp S and move it in front of the nearest red/gray building on the left sidewalk.
Your world should now look like this.



Add a dumpster
1. Move the viewpoint back so that you have space to add another object in front of the street lamps.
2. Click Objects in the Warehouse.
3. Click Streets in the Category drop-down list.
4. Click-and-drag Dumpster into the world.
Place it down on the middle of the road, before the street lamps.
o
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Rotate the dumpster

1. Move the mouse over the vertical blue line of the editing frame at the front right of the dumpster.
The blue lines are the rotation grips for objects. The line changes to white to show it is selected.

2. Click the line (it changes to yellow) and with the mouse button still pressed, drag the mouse to the
left. As you drag, the object rotates clockwise. Release the mouse.

. Hold down cTRL and click one of the rotation grips. Dumpster is reset to its default orientation.

. Hold down sHIFT and drag the rotation grip to the right. The object rotates in multiples of 45°. When
the object rotated through exactly 90°, release sHIFT and the mouse button.
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Move the dumpster

1. Click the Dumpster movement grip facing towards the viewpoint, and drag the object right to the
side of the street until it collides with the sidewalk and it is sitting on the road.

If you cannot move Dumpster to the side of the road, it may be colliding with the lamp which is
outlined in red. In this case drag it towards you first and then to the side of the road.

2. Press CTRL and drag the same Dumpster movement grip up the street. Dumpster should move up
the street and collide with the lamp object, which is outlined in red to show the collision.

3. Keeping CTRL pressed, hold down ALT to temporarily ignore collisions and drag the dumpster
through the lamp object. Release ALT when the dumpster is through the lamp.

Be careful using ALT when moving objects as you can easily move through the ground.
4. Position Dumpster between the two street lamps.
Your world should now look like this.



Add a virtual human

1. Click Objects in the Warehouse, click People in the Category drop-down list, and drag Bob into the
world. Use the movement grips to move the figure to ground level on the street, and rotate the
figure 90° anticlockwise.

Your finished world should look like this.

2. Click the Play icon on the toolbar to switch to Play mode.
Bob starts walking, stops, and then starts again.

3. Click the Reset World icon on the movement bar.
The world and all the objects are reset, including Bob.

3. Choose File>Save, and save your world as OBJECTS.SVR.
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Congratulations

You have successfully completed the Manipulating Objects tutorial.
Topics covered in this tutorial include:

§ Creating a world from a preset template;

§ Setting a viewpoint;

8 Moving objects;

§ Duplicating objects;

§ Rotating objects.
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Further information

For more information on topics covered by or related to this tutorial, choose Help>Help Topics and then
choose from the following books or topics:

For creating new worlds: How do I?>Create a world.

For setting viewpoints: How do I?>Preview a world.

For moving objects, including grips and guides: What is Do 3D?>The virtual world>Objects.
For duplicating objects: How do 1?>Build a world>Add an object.

For rotating objects: What is Do 3D?>The virtual world>Objects.
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Aligning objects
This tutorial shows you how to align objects and move rotated objects.

We recommend that you have completed the Creating a Simple World and Manipulating Objects
tutorials before you follow this tutorial, as it explains many of the basic concepts you will use.

If ﬁou want a printed copy of this tutorial, click here.



Object alignment

One of the most common requirements in 3D worlds is the alignment of two or more objects. When you
are adding objects to an enclosed area such as a room that has already been created (template), it is
easy to align objects by moving them until they collide with a wall. If, however, you are aligning objects
in an open area, you do not have walls to butt objects against. In this case there are two ways you can
align a group of objects:

§ “sticky” objects
8 an additional “dummy” object
The method you select depends on the object and the world you are designing.



Load a world

Click File>New, and double-click the template Blank World to load a blank world.
For the best results, Do 3D should cover the whole of your screen. If it does not, click the
Maximize icon in the title bar of the program.



Add two parts of a bridge

1.
2.

3.

Click Objects in the Warehouse, and Gardens, Statues in the Category drop-down list.

Click-and-drag BridgeWend into the 3Space window and position it to the left and behind the
default cube. Drag the movement grip down until the object touches the ground - the grip goes red.

Click-and-drag BridgeWarch into the 3Space window and place it on the ground to the right of
BridgeWend. Do not try an align the objects yet.

The 3Space window should look like this.
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Align “sticky” objects
1. Make sure you are in Fly mode - click the Fly icon.
2. Click BridgeWarch, and adjust the viewpoint so that you can see the top movement grip on it

3. Drag the top movement grip towards BridgeWend until they collide - BridgeWend is outlined in red
when the objects collide.

4. Keep BridgeWarch in contact with BridgeWend by dragging to the left, and at the same time slowly
move it forward or back to align the two objects.
When the leading edge of the BridgeWarch frame is aligned with the edge of the BridgeWend
frame the objects appear to stick together temporarily. If necessary, move the viewpoint closer to
the objects until you can see the sticky movement clearly.

5. Release the mouse when the objects stick together. Click the Play icon and move the viewpoint
around to check that the objects are aligned.
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Use a dummy object

You can also align objects by using a dummy object, that you delete when you have finished the
operation. This is particularly useful if you want to align very thin objects.

1. Click the default object, and drag the top movement grip to move it in front of and against
BridgeWend and BridgeWarch. Make sure it collides with bridge objects.

2. Hold down sHIFT and click the front right resize grip and drag right to stretch it until it is
approximately twice the width of the two bridge objects.



Use a dummy object

1. Click Gardens, Statues in the Object Category drop-down list in the Warehouse, and double-click
BridgeEarch to place it in the 3Space window.

2. Adjust the viewpoint so you can see the top movement grip on BridgeEarch, and drag BridgeEarch
into its correct position against BridgeWarch, making sure that it collides with BridgeWarch and the
default object like this.

3. Click-and-drag BridgeEend from the Warehouse into the 3Space window and position it against
BridgeEarch and the default object.

. Click the default object, and choose Edit>Delete to delete it.

. Click the Play icon and move around the bridge to check that all the components are aligned
correctly.
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Rotated collisions

1. Click-and-drag Wall NS from the Gardens, Statues Category in the Warehouse to the 3Space
window, and position it in front of the right end of the bridge. Drag a side movement grip down to
make sure it is on the ground.

2. Drag the front right rotation grip anti-clockwise to rotate Wall NS approximately 30°. If you cannot
rotate the object because it is too close to the bridge, drag it towards the viewpoint and then rotate
it.

3. Drag the top movement grip until it collides with the bridge.

As the wall collides with the bridge, the “volumes” of Wall NS and BridgeEend are displayed. The
volume is the orthogonal space an object occupies within the world axes, and is used to detect
collisions between objects.

4. Click-and-drag the rotated object along BridgeEend until the right edge of the Wall NS volume
“sticks” to the edge of BridgeEend.

This illustrates how the object volume is used to align objects rather than the frame.



Unrotated collisions

1. Press cTRL and click one of the Wall NS movement grips to restore the object to its original
orientation. Position Wall NS against BridgeEend.

When an unrotated object collides with another, the volume of the moving object is not displayed,
just that of the object it collides with.

2. Click File>Save As and save you world as ADVANCED.SVR.
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Congratulations

You have successfully completed the Aligning Objects tutorial.
Topics covered in this tutorial include:

§ Aligning “sticky” objects;

§ Aligning objects using a dummy;

§ Aligning rotated objects;

§ Object volumes.



Further information

For more information on topics covered by or related to this tutorial, choose Help>Help Topics and then
choose from the following books or topics:

For aligning objects, including rotated objects: Tips and Tricks>Objects.

For object volumes: What is Do 3D?>The virtual world>Objects.












Materials

This tutorial shows you how to use materials to enhance realism in your worlds. You will drag textures
in from the Warehouse, manipulate them in realtime using the mouse, and change an object'’s colors.

If ﬁou want a printed copy of this tutorial, click here.



Load a world

Choose File>New, and double-click the template Room to load the an empty room.

The 3Space window displays a world containing an interior of a room

For the best results, Do 3D should cover the whole of your screen. If it does not, click the
Maximize icon in the title bar of the program. Make sure that both the Warehouse and the Attributes
%Iettes are visible on the left of the 3Space window.



Add a table

1. Click Objects in the Warehouse.

2. Click Chairs, Benches, Tables in the Category drop-down list.

3. Double-click Conference Table.

4. Move the viewpoint so you can see the whole of the top of the table.



Add a texture to the table

1. Click Materials in the Warehouse and then Natural Wood in the Category drop-down list.
All the images in the Woods category are displayed in the scroll box.

2. Click the image Dragged Walnut and drag it onto the center of the table top.

3. In the Apply Texture dialog box, click Wrap from the Method drop-down list, click the middle
orientation, and click OK. The texture is placed over the center of the table as it is the only part of
the object that uses the color range.

4. Press ALT, and drag the image Oak Stripes from the Woods category in the Warehouse onto the
table.

Pressing ALT displays the Apply Texture dialog box, which by default does not appear when you
load a texture on top of another.

5. In the Apply Texture dialog box, click Wrap from the Method drop-down list, click the end
orientation, and click OK.

6. Experiment loading other textures using different orientations with both the Wrap and Planar
methods.



Wrap and Planar

The Wrap method wraps the texture around the object like a sheet of paper (the texture is adjusted in
each axis so that it is not distorted). You can wrap the texture in the X, Y or Z axis.

The Planar method maps the texture as a single image onto all the facets in the color range from one
direction. You can apply the texture in the X, Y or Z axis.



Reset the material

1. Click Materials in the Attributes palette, and scroll down to the third color chart. The texture you
have just dragged onto the table is displayed at the end of the range, highlighted in a white box.
The original color material is highlighted with a yellow box.

2. Click the yellow box. The texture is removed from the table, which is returned to its original color.
The texture material is removed from the end of the color range in the Attributes palette.
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Add cylinder and sphere objects

1. Click Objects in the Warehouse.

2. Click _Cubes, Cones, Spheres in the Category drop-down list.

3. Click-and-drag the objects Cylinder Light High and Sphere Light High onto the conference table.
]



Add textures

1.
2.
3.

)]

7.

Click Materials in the Warehouse and then Backdrops in the Category drop-down list.
Click the image Planet Earth and drag it onto the sphere.

In the Apply Texture dialog box, click Spherical from the Method drop-down list, click the left
orientation, and click OK.

. Click Cylinders in the Category drop-down list.
. Click the image Tree Trunk and drag it onto the cylinder.
. In the Apply Texture dialog box, click Cylindrical from the Method drop-down list, click the left

orientation, and click OK.

Experiment loading other textures using different orientations with the Spherical and Cylindrical
methods. Don't forget to press ALT to display the Apply Texture dialog box.



Spherical and Cylindrical

The Spherical method wraps the texture around the object like a sphere, covering all the facets in the
color range. The sphere can have its axis in the X, Y or Z axis.

The Cylindrical method wraps the texture around the object like a tube, covering all the facets in the
color range. The tube can point in the X, Y or Z axis.



Add a laptop computer

1. Click Objects in the Warehouse.

2. Click Computers in the Category drop-down list.

3. Click PC Laptop in the scroll box, and drag it on top of the table.

4. Move the viewpoint so you are facing the laptop.

5. Click the Play icon to switch to Play mode, and click the laptop with the left mouse button.
The laptop opens and its screen is displayed.

Click the Edit Object icon to switch back to Edit Object mode.
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Change the texture on the laptop screen

1. Make sure that you have the Warehouse and Attributes palette open and visible, and the laptop is
selected in the 3Space window. Click Materials in the Attributes palette and scroll down the color
charts until you see the chart with the screen texture (blue clouds)

. Click Materials in the Warehouse, and click Signs in the Category drop-down list.
. Click 3D Logo and drag the texture onto the screen texture color range in the Attributes palette.
The new image replaces the previous contents of the laptop screen.

w N
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Resetting textures

Once you have changed the texture on a facet or range of facets, the original texture disappears from
the materials chart.

If an object has a built-in texture, as PC Laptop has, the only way to return to the original texture is by
either repeatedly clicking the Undo icon until the texture reappears, or re-importing the object from the
Warehouse.



Resize the texture

1. Click the Edit Material icon on the toolbar to change to Edit Material mode.
The Texture toolbar is displayed.

2. Click the Scale Texture icon in the Material toolbar.

3. Click 3D Logo at the bottom right of the laptop screen and drag to the top left, so the image
becomes duplicated. Release the mouse button when there are approximately six to nine copies of
the image.
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Rotate the texture
1. Click the Rotate Texture icon in the Texture toolbar.
2. Click-and-drag 3D Logo to the right. The columns rotate clockwise. Release the mouse.

3. Press sHIFT, and click and drag 3D Logo to the right again. The texture rotates 90° at a time from its
current rotation.

Leave the image slanting from left to right.
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Move the texture

1. Click the Move Texture icon in the Texture toolbar.

2. Click 3D Logo at the right end of the laptop screen and drag towards the left, so the colored bands
move across the screen. Release the mouse.

3. Click 3D Logo at the bottom of the laptop screen and drag up, so the bands move up the screen.
Try pressing SHIFT as you move the texture to constrain the movement to one direction.
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Add a virtual human
1. Move the viewpoint away from the table so you can see some of the office floor.
Be careful not to move through the office walls.
2. Click Objects in the Warehouse.
3. Click People in the Category drop-down list.
4. Click Manual Walk Baley and drag it into the 3Space window in front of or beside the table.
Move the viewpoint so you can see the front of the virtual human.
]
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Recolor the jacket and trousers
1. Click Materials in the Attributes palette.

Manual Walk Baley comprises eight materials charts. Each chart consists of ranges of colors. The
sixth chart represents the object's jacket color. The present color range is highlighted with a white
border.

2. Click the mid blue color in the second row.

The man's jacket turns blue in the 3Space window. The original range is now highlighted with a one
pixel wide yellow box.

3. Scroll down the materials charts so you can see the seventh chart, which represents the object's
trouser color. The present range is highlighted with a white border.

4. Click the red color in the second row.
The man's trousers turn red.



Reset a color

1. Scroll down in Materials in the Attributes palette so you can see the fourth chart, which represents
the object's hair color. The present color range is highlighted with a white border.

2. Click the yellow color in the third row.
The man's hair turns bright yellow.
3. Click the color highlighted by the yellow box to return the hair to the original color.
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Play the world

1. Click the Play icon in the toolbar and move around the world.
2. Choose File>Save to save your virtual world.

3. Type MATERIALS.SVR in the Name box, and click OK.
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Congratulations

You've successfully completed the Materials tutorial.

Topics covered in this tutorial include:

§ Dragging textures onto objects, in different orientations;

§ Changing textures;

§ Scaling, rotating and moving textures in Edit Material mode;
§ Using the Materials attributes palette;

§ Changing object colors.
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Further information

For more information on topics covered by or related to this tutorial, choose Help>Help Topics and then
choose from the following books or topics:

For general information on materials, including colors and textures: What is Do 3D?>The virtual
world>Materials.

For manipulating textures, including the Apply Texture dialog box: How do 1?>Build a world>Add a
texture to an object.

For changing object colors: How do 1?>Build a world>Change object attributes>Change the color of an
object.
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Actions and sounds

This tutorial shows you how to define actions for objects, such as linking to the World Wide Web and
setting object properties. It also explains how to add and edit sounds.

To publish a world on the Web, you need Viscape, Superscape's 3D Web browser. This is freely
available from the Superscape Web Site (http://www.superscape.com) and enables you to view worlds
on the Web in Microsoft Internet Explorer and Netscape Navigator.

|ﬁou want a printed copy of this tutorial, click here.



Load a world

Choose File>New, and double-click the template City Center to load the city center world.
The 3Space window displays a world containing a city square surrounded by buildings, with a
clock in the center.
For the best results, Do 3D should cover the whole of your screen. If it does not, click the
Maximize icon in the title bar of the program. Make sure that both the Warehouse and the Attributes
%Iette are visible on the left of the 3Space window.



Add a car

1. Move the viewpoint back slightly and rotate it to the right so you can see the bottom right edge of
the grass. A high rise glass building is in the far corner.

2. Click Objects in the Warehouse.

3. Click Cars, Boats, Trains in the Category drop-down list.

4. Click Yellow Cab in the objects scroll box, and drag it into the world.
Position it in on the road near the edge of the grass.
You will now add an external link to the car to take you to another Web Site.
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Add a link to an external Web Site

1. Click Actions in the Attributes palette.

2. Type the following URL in the URL box:
WWW. superscape.com

3. Type the following description in the Description box:
Superscape's Web Site

This will appear as a tooltip and in the Netscape Navigator status bar (Internet Explorer does not
support this functionality in version 3).

If you are want to link to a particular frame, add the name of the frame in the Target box.

Note that links to Web Sites only work when the world is displayed in Viscape (Superscape's 3D
Web browser) and not in Do 3D.
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Targets
The following names, which begin with an underscore, are supported by Target in Actions:

_blank - load this link into a new, unnamed frame.

_current - load this link over yourself.

_self - load this link over yourself.

_parent - load this link over the parent frame (becomes self if there is no parent).
_top - load this link at the top level (becomes self if you are at the top).



Add a mail box

1. Click Objects in the Warehouse.

2. Click Streets in the Category drop-down list.

3. Click US Mail Box in the scroll box, and drag it into the street.
Position it on the grass near to the cab.



Add an email link

1. Click Actions in the Attributes palette.

2. Make sure that the Click To Send Mail check box is selected.

3. Type the following text in the Email Address box:
noone@nowhere.com

This is not a valid email address and will result in a “Failed Mail” message. You can use your own
email address if you wish. The Email Address box is a user definable property attached to the US
Mail Box object.

4. Type the following text in the Description box:
Email No One

This will be displayed as a tooltip and in the Netscape Navigator status bar (Internet Explorer does
not support this functionality in version 3).

Note that email links only work when the world is displayed in Viscape (Superscape's 3D Web
browser) and not in Do 3D.
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Play the world

@ Click the Play icon in the toolbar, and move around the world.

As you move your mouse over the yellow cab and US mail box, the mouse pointer changes to a
pointing hand indicating a link (the links do not work in Do 3D). If you leave the pointer over the cab or
mail box, a tooltip displays the text you wrote in the Actions Description box.

When you display this world in Viscape on the World Wide Web, and click on the yellow cab, the
default browser will start and connect to the specified URL. Clicking the mail box will start your email
Iafﬁication with the email address you specified in the Send To box.



Add a virtual human
1. Click Objects in the Warehouse.
2. Click People in the Category drop-down list.

3. Click-and-drag Automatic Walk Baley into the 3Space window, and place him on the street in front
of the car and facing the mail box.

4. Click the Set Viewpoint icon on the toolbar to make this viewpoint the default.
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Change object properties

Automatic Walk Baley has a set of properties that let you determine how it moves in the world.
1. Click Actions in the Attributes palette.

2. Type 90 in the Maximum Turn box. The figure can turn up to 90° as he moves around.

3. Click the Play icon on the toolbar. The figure walks around the world and turns at random, but at no
more than 90°.

4. Press F12 to reset the world.

Try changing the other properties for Automatic Walk Baley. For Help on the properties, click the
What's This? icon on the toolbar and click Automatic Walk Baley in Objects in the Warehouse.
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Add sound to the human

1.
2.
3.

ekl

Click Sounds in the Warehouse, and click Human in the Category drop-down list.
Double-click the sound Ouch to play it.

Click-and-drag Ouch onto Automatic Walk Baley.

The Sound options are displayed automatically in the Attributes palette.

. Select Click in the Trigger drop-down list in the Attributes palette.
. Drag the Volume slider to the far right, to set the base volume of the sound to full.
. Make sure that the Ambient check box is selected, so that the sound will be heard at the same

volume wherever you are in the world.

. Make sure the Loop check box is clear, so that the sound is only played once when you click the

human.
Click the Play icon in the toolbar and click Automatic Walk Baley with the left mouse button.



Add a speaker stack

1. Click Objects in the Warehouse.

2. Click Electrical Goods, Musical in the Category drop-down list.

3. Click-and-drag Speaker Stack into the world, and position it on the grass besides the mail box.
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Add a sound to the speaker stack

1.
. Double-click Alien Transporter to play it, and then drag it onto Speaker Stack.

. Click Loop in Sounds in the Attributes palette. The sound will play in a continuous loop.

. Clear the Ambient check box, so that the sound will be distanced as you move around the world.

. Drag the Volume slider to the far right, so that the sound fades slowly as you move away from the
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6.

Click Sounds in the Warehouse, and click FX in the Category drop-down list.

source.
Select Click On/Off in the Trigger drop-down list.
The sound will start and stop playing when the object is clicked with the mouse.



Distanced sound

Clearing the Ambient check box lets you use distanced sound in your world. The sound will appear
louder when you are nearer the object and quieter as you move further away.

The Volume slider for distanced sounds sets how close you have to be to the object before you hear
the sound at full volume. If the slider is at the left end of the scale you will have to be very close to the
object to hear the sound at full volume. If the slider is at the right end of the scale the sound will be
heard at full volume further away from the object.



Play the world
1. Click the Play icon in the toolbar and move around the world.
2. Click the speaker stack with the left mouse button to start playing the Alien Transporter sound.
Note how the sound changes as you move closer or further away from the Speaker Stack object.
3. Click the object to stop the sound playing.
4. Choose File>Save, and save your world as ACTIONS.SVR.
]
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Congratulations

You've successfully completed the Actions and Sounds tutorial.
Topics covered in this tutorial include:

Adding Web and email links to objects;

Setting object properties;

Adding sounds to objects;

Changing the volume of sounds;

Using both Ambient and distanced sound;

Playing sounds in a loop or when clicked.
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Further information

For more information on topics covered by or related to this tutorial, choose Help>Help Topics and then
choose from the following books or topics:

For information on editing properties and URLs: How do I?>Build a world>Change object attributes.
For general information on sounds: What is Do 3D>The virtual world>Sounds.
For information on adding and editing sounds: How do 1?>Build a world>Add a sound to an object.






