


World essentials

Do 3D is one of the fastest ways to create interactive realtime 3D virtual worlds on a PC. Its point-and-
click interface and extensive libraries of objects, textures and sounds make it easy to create exciting
realtime 3D worlds.

Do 3D uses very simple building blocks, called objects, to create worlds. Each object contains a cube
that defines its position in the world and a predefined shape. You simply need to piece the cubes
together, and add any necessary material or sound.

Supplied with Do 3D is a selection of world templates, such as a room or street, that provide basic
environments to add your own ideas to, and make it very quick to build worlds. Alternatively you can
start from a bare world with just the default object and horizon.

Each world is seen from a viewpoint which you can think of as your monitor window. As you move
around a world, you are actually moving the position of the viewpoint relative to all the objects in it.

{button ,AL("creating_worlds")} Related Topics



Objects

The basic building blocks of Do 3D worlds are objects. These can range from very simple cubes and
cones, that you can use to build other objects, to complex objects like a piano or clock which have a
high level of detail and complex behaviors, or virtual humans who walk around your world.

Objects are stored in the Warehouse, from where you drag them into your world in the 3Space window.
When they are in the 3Space window you can manipulate them using the mouse.

The objects are split into different libraries. For more information on the object libraries, see the online
manual that you can print or read on the screen. For Help on each individual object, click the What's
This? icon in the toolbar and click the object in the Warehouse.

Each object contains all the information needed to draw it in the world, including materials (colors and
textures), sounds and behaviors. Their shape is predefined by one-dimensional and two-dimensional
surfaces called facets.

Most objects are automatically distanced, so that they appear finely detailed when they are close to the
viewpoint, but as they recede into the distance, and less detail can be reasonably determined, they are
replaced by less complex shapes. This helps the world run faster, as simpler objects take less time to
process than complex ones.

Some objects contain animation sequences that automatically run over a number of frames. Other
objects have properties which you can set that control the object’s behavior, such as adjusting the
speed of a moving object.

{button ,AL("add_obiject;file_types")} Related Topics
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Object grips and guides
Each object is enclosed by a frame that contains "grips" in each corner and in the middle of each side,
which you use to resize or move the object using the mouse.

The resize grips in the corner are colored in three shades of gray (indicating their direction). The corner
grips are joined by the edges of the frame which are displayed in dark blue, that you use to rotate the
object. The movement grips in the center of each face are green. As the mouse passes over an edge or
grip it changes to white, and then yellow if you click with the left mouse button.

Whenever you manipulate an object two horizontal guides cross the ground (or any object in between
the ground and the currently selected object) to indicate the object's position in the world. If you have
moved the object above the ground or another object, a vertical guide runs from the center of the object
to the ground or object beneath to indicate the current plane.
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Collisions

Each object occupies a “volume” of space in the virtual world that is always aligned with the world
axes. Do 3D uses object volumes to decide which order to draw objects in, and check for collisions
between objects. If you use an object in its default orientation, its volume is the same as its editing
frame. If, however, you rotate an object by an angle other than 90°, 180° or 360°, or it has dynamics,
the volume will be larger as it must cover all the possible positions of the object and its components.

As you move objects around, you should make sure that their volumes do not overlap so that they can
be drawn in the correct order, and the world runs at optimum speed. If objects' volumes have to
overlap, the world takes longer to process, which slows down the speed at which it runs.

You can use collisions to place an object flush with another or with the ground.

If an object collides with another, the
currently selected grip of the colliding
object turns red and the volume of the
hit object is outlined in red:

If the object is colliding with the
ground, just the currently selected grip
turns red:

If you collide a rotated object with
another object, both volumes are
displayed with a red outline:

You can override collisions at any time by:

§ pressing ALT as you move, resize or rotate objects through other objects. Take care if you use ALT to
override collision detection as objects can easily get lost within other objects. We recommend that
you do not drag an object below ground level.

§ dragging an object completely through another object. When the object you were dragging would

have passed through the stationary object completely, it is displayed again giving the appearance
that it has jumped to the other side of the object.

{button ,AL("object_grips;orientation;move_object_right")} Related Topics



Materials

Each facet in an object has a material which defines the object appearance. The material can be either
a color in a given range or a texture, and is indicated in the Materials tab in the Attributes palette. The
color ranges are displayed first - the default range is outlined by a yellow box, and the current range by
a wide white box.

The stipple range, which you can use to create transparent objects, is represented by a black box with
a white cross.

If a texture is used, it is displayed at the end of the color ranges.

{button ,AL("materials")} Related Topics



Textures

You can create photorealistic objects in your worlds by attaching graphics to objects, a technique
known as texture mapping.

More than 400 textures are supplied, each in many different colors, which you drag from the
Warehouse and map to an object in the 3Space window according to a method you select. They can be
displayed on one or more of the object’s facets. By default, a texture is sized to the dimensions of the
facet or object it is attached to, and its orientation is set by the axis you select.

You can adjust the size, orientation and position of a texture (which has been applied to an object)
using the mouse in Edit Material mode.

The Apply Texture dialog box, which is displayed when you first drag a texture from the Warehouse
onto an object in the 3Space window, lets you set the orientation for the image. You can then select
whether the dialog box is always displayed when you add a texture, or only if you hold down the ALT
key.

In addition to using textures supplied with Do 3D, you can also use your own. Simply drag them from
Windows Explorer onto an object in the 3Space window. Many of the common graphics file formats are
supported.

{button ,AL("add_texture;file_types;textures")} Related Topics



Sounds

Sounds let you add additional interest and realism to your worlds. You attach sounds to an object, and
play them either continuously in the background or when a specific object is clicked with the mouse.
You can create distanced sound, where it gets quieter as the viewpoint moves further away. Do 3D
supports the Windows .WAV format.

Various everyday sounds are supplied with Do 3D, which you drag from the Warehouse onto an object
in the 3Space window. You can also use your own sounds, by dragging them from Windows Explorer
into the 3Space window.

Some objects already have sounds built-in, which you can change for either your own sounds or
sounds from the Warehouse.

{button ,AL("add_sound;file_types")} Related Topics



Colors

All objects have their own colors which belong to a set of ranges (two or more consecutive colors) in
the default palette of 256 colors.

You can change the color of an object by remapping a range of colors to another range within the
palette. You do not have to remap every color in the range separately as each color in a source range
is automatically changed to its corresponding color in the target range. For example you could change
a red object to a blue object by remapping the red range of colors to the blue range.

{button ,AL("colors")} Related Topics



Viewpoints and moving around

All the objects in your worlds are drawn from the current viewpoint, which you can think of as a window
onto the world through which you are looking. Each viewpoint has attributes such as the number of
axes it can move in at one time, and whether it can collide with objects in the world.

There are two modes in which you can move the viewpoint around the world:

« Flying - the viewpoint can move freely in any axis, and collisions are not activated so that it can
move through objects. This is the default mode.

» Walking - the height of the viewpoint is fixed, and collisions are activated.

Once you have selected your movement mode, there are two ways to change the position of the
viewpoint:

« Using the movement bar - clicking and dragging on the three blue icons.

+ Using the mouse in mouse movement - switching the mouse from selection mode to movement
mode, and then moving the cursor around the screen.

{button ,AL("movement")} Related Topics



3Space window
The 3Space window is where you build and preview your worlds. It can be displayed in three modes:

Edit Object mode - lets you build your world by manipulating objects. You can add, resize, reposition
and rotate objects and edit an object’s actions. The 3Space window is switched automatically to Edit
Object mode when you add an object from the Warehouse.

Play mode - lets you preview and interact with your world as it will be seen when displayed in
Superscape's 3D browser Viscape. All objects and their attributes are automatically processed. This is
the default mode when you start Do 3D.

Edit Material mode - lets you resize, reposition and rotate textures on an object. The 3Space window is
automatically switched to Edit Material mode when you drag a texture onto an object, and the Texture
toolbar is displayed.



Warehouse palette

The Warehouse contains all the items that you need to build your worlds. From the Warehouse you
simply drag them into the 3Space window with the mouse. All objects and materials are illustrated by a
small picture that shows what the item will look like when it is added to the world.

The Warehouse consists of three tabs which contain the following items:

@

Objects - all the objects that you can use in the world. To find out more about objects in the Warehouse,
click the What's This? icon in the toolbar and click the object. A popup window appears which explains
object behavior and user-definable properties;

.

"

Sounds - all the sounds that you can attach to objects;

i

Materials - all the images and color ranges that you can attach to objects to make them look more
realistic.

Items are divided into well-defined categories under each option.



Attributes palette

The Attributes palette lets you add and adjust the attributes of each selected object in the 3Space
window. It consists of four tabs which display the following information:

@

Actions - the URL fields for the object, and any additional properties you can set for the object. These
options are specific to the VCA object, created when the object is built in Superscape VRT;

o

Sounds - the name of a sound attached to the object, and how the sound is played;

Materials - the color ranges which an object uses, and the textures applied to the object. You can apply
one texture to each color range - a texture is indicated by a sample at the end of the range.

58

Position - the current position, size and rotation of the object. This tab lets you move, resize or rotate
objects by entering values in meters or degrees, instead of manipulating the object with the mouse.

{button ,AL("properties")} Related Topics



Components
Do 3D consists of three main components:
Authoring - Edit Object mode in which you build your world and edit objects.

Browsing - Play mode in which you view the world as a realtime 3D world. This is how you will see it
on the World Wide Web if you publish it using Viscape, Superscape's 3D browser.

Content - the libraries of objects, textures and sounds you use to build a world. Do 3D uses a simple
drag-and-drop interface for creating worlds. All the items you need are stored in the Warehouse.

Do 3D has a set of toolbars and palettes that you use to build your worlds, manipulate object attributes
and move around worlds.



Axes

Do 3D worlds use a coordinate system with three perpendicular axes, X, Y, Z. The X axis runs from
East to West, the Y axis runs up and down, and the Z axis runs from North to South. Objects have their
own local coordinate system similar to the world coordinates - with 3 perpendicular axes. Object’s
coordinate systems and the world coordinate system may not always coincide.

Rotations are specified around each axis, looking towards the origin. A positive Y rotation is a clockwise

rotation in the vertical axis (looking down on the object). A negative rotation is an anti-clockwise
rotation.

For objects that move, the positive Z axis is defined as ‘forward’.



File types

Do 3D supports the following file types:

.SVR - A virtual world file.

.VCA - A Virtual Clip Art object. Each object contains all the information required to display it, including
textures and sounds.

WAV - The standard Windows sound file format. Each sound has been sample at 11 kHz, 8-bit, mono
WAV format. In addition to dragging sounds from the Warehouse, you can drag them directly onto an
object from Windows Explorer.

.BMP - All textures are supplied in the standard Windows format.

.PCX, .GIF, .JPEG, .TIF, .TGA - Common graphics file formats. Drag them directly onto an object from
Windows Explorer.



Ground level

The ground level is an invisible object that stretches an infinite distance in the horizontal plane and
down. We recommend you build all your worlds in the space above ground level.

You can only drag an object below ground level if you press ALT, the hot key which lets you drag an
object into another. You should avoid this whenever possible, however, as it will slow down your world
and may cause the object to appear in unexpected positions. If you do move an object below ground,
its vertical guide runs from the top of the object upwards.

The crosshair indicates the ground
level.

If the vertical guide points up, the
Il object is below ground level.

[P

i Texture toolbar




Create a world based on a template

1. Choose File>New.
The Select Template dialog box is displayed.
2. Click a template and click OK.
The template world is loaded into the 3Space window.
Tip

{button ,AL("new_worlds;add_object")} Related Topics



Create a blank world
1. Choose File>New.
The Select Template dialog box is displayed.
2. Click Blank World from the list of templates and click OK.
A blank world, containing an horizon and the default cube object, is loaded into the 3Space window.
4 Tip
{button ,AL("new_worlds;add_object")} Related Topics




Open an existing world
1. Choose File>Open.
The Open dialog box is displayed.
2. Click an SVR file and click Open.
The world is loaded into the 3Space window.
Tip

{button ,AL("new_worlds")} Related Topics



Save a world

1. Choose File>Save.
2. Enter a filename and directory, and click Save.

If you use an existing filename and destination, an alert box warns you that you are about to
overwrite existing data. Click Cancel to abort the operation and change the name of the file or its
destination, or OK to overwrite the existing file.

4 Tips



=
Click the Save icon on the toolbar to save a world.
Choose File>Save As to save the file with a new name.



o

Click the New World icon in the toolbar to create a new world.
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Click the Open World icon in the toolbar to open a world.

You can also load an SVR file by dragging it from Windows Explorer and dropping it into Do 3D. If you
have a shortcut to Do 3D on the Windows desktop, you can drag a file onto the Do 3D icon.



Use the movement bar
3 Click and hold the left mouse button on one of the three movement icons (blue icons), and then
drag the mouse.
Click on the graphic below to display further information on each icon.

&\ 3

As you move the mouse the arrows change to red to indicate which direction you are moving, and
the viewpoint moves in the corresponding direction. You can move in more than one direction at the same
time by moving the mouse between two arrows. The further you move the cursor from the icon the faster
you move. Release the mouse to stop the movement.

b Tips
{button ,AL("movement;viewpoints")} Related Topics




You can move around your world in Edit Object, Edit Material and Play modes.

Move faster around a world by pressing the following keys as you click-and-drag the icons:
SHIFT - X2 speed
CTRL - X3 speed
SHIFT+CTRL - X4 speed



Click-and-drag to move forwards.



Click-and-drag to move backwards.



Click-and-drag to turn to the left.



Click-and-drag to turn to the right.



Click-and-drag to move up.



Click-and-drag to move down.



Click-and-drag to move to the right.



Click-and-drag to move to the left.



Click-and-drag to look up.



Click-and-drag to look down.



Click to look straight ahead, level with the ground.



Click to reset the world to the position at which you entered the world.



Click to display a pop-up menu that you can use to access Viscape functions.
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b

Use the mouse in movement mode

1.

4.

Place the mouse cursor over the 3Space window, and press the SPACEBAR once to switch the
mouse from selection mode to movement mode.

A small square (known as the Mouse Home) is displayed at the tip of the mouse pointer indicating
that you are in movement mode.

. Move the mouse.

As you move the viewpoint moves. The further you move the mouse pointer from the Mouse Home
the faster you move in the world. When the mouse pointer is over the top of the Mouse Home any
movement stops.

. Hold down the left or right mouse button at the same time as moving the mouse to change the

direction of the viewpoint.
To switch back to selection mode press the sPACEBAR. The Mouse Home disappears and you can
use the mouse to select items again.

Tip

{button ,AL("movement;viewpoints")} Related Topics



You can move around your world in Edit Object, Edit Material and Play modes.



Add an object

1. Click Objects in the Warehouse.
2. Click a category in the drop-down list.

The objects belonging to the selected category are displayed in the object scroll box.
3. Click the object you want and drag it into the 3Space window.

4. Move the mouse pointer to position the object and then release the mouse button. As you move the
mouse, the object moves around the world. If you drag it near another object the new object tries to
align itself to it.

When you release the mouse button, the 3Space window switches to Edit Object mode. The
current object is enclosed by a frame that has a set of ‘grips’ at the corner and in the middle of
each face, that you use to size and position the object.

4 Tips

{button ,AL("objects;object_prop;object_url;object_color;object_texture;object sound;add_vrml")}
Related Topics



Double-click the object in the Warehouse to load it in the center of the 3Space window.

Make sure there is enough space for the new object in your world. If your viewpoint is too close to an
existing object, the new object may be partially or completely obscured.



Add an object from a VRML file

1. Choose File>Import VRML.
The Open dialog box is displayed.
2. Click a .WRL file and click OK.

The VRML file is loaded into the center of the 3Space window, which switches to Edit Object
mode . The file is treated as a single object and is enclosed by a frame that has a set of ‘grips’ at
the corner and in the middle of each face, that you use to size and position the object.
Only the geometry and textures of the objects are loaded.

» Tip

{button ,AL("objects;object_prop;object_url;object_color;object_texture;object _sound;preview_object;v
rml")} Related Topics



Do 3D supports pure VRML 2.0 files only. It will not import VRML files that are:
§ very large files

§ files with nodes that are not currently supported.

A warning is displayed if the VRML file cannot be imported.



Switch to Edit Object mode
3 Choose View>Edit Objects.
In Edit Object mode the current object is enclosed by a frame that has a set of ‘grips’ at the
corner and in the middle of each face, that you use to size and position the object.

» Tip



@

Click the Edit Object icon to change to Edit Object mode.



Move an object using the left mouse button
1. Make sure you are in Edit Object mode.
2. Click the object you want to move.

3. Click-and-drag the green grips in the middle of the object’s editing frame to move it. The mouse
cursor changes to a hand.

You can move the object in the two axes in which the grip lies.
4. Press the following keys as you drag to constrain the axes in which you move the object:
SHIFT to move the object in one axis only at any time.
CTRL to move the object perpendicular to the axes you are dragging in.
4 Tips

{button ,AL("object_grips;edit_object;move_object;move_object_through")} Related Topics



You can use collisions to position objects flush with one another. Take care, though, that objects'
volumes do not overlap as it will take longer to process the world.

We recommend that you do not move an object through the ground.

When you have moved an object by pressing CTRL as you drag, release the mouse button before
releasing CTRL, otherwise the object returns to its original position.



Move an object using the right mouse button

k Either:

Click the object to select it, and then click where you want to move it to with the right mouse
button.

The object is positioned at the point where you clicked.

-Or-

Drag the selected object with the right mouse button.

The object moves in the horizontal plane and also in the vertical plane at a certain distance from
the viewpoint. If you drag it near another object the selected object tries to align itself to it.

4 Tip
{button ,AL("edit_object;move_object;move_object_through")} Related Topics




Positioning objects using the right mouse button is very effective for rough placement. Use the left
mouse button and the movement grips for fine adjustment.



Move an object using the Attributes palette
1. Make sure you are in Edit Object mode.

2. Click the object you want to move.

3. Click Position in the Attributes palette.

4. Enter the position of the center of the object in the Center position boxes.
r For help on an item click
7 at the top of the dialog box and then click the item.

{button ,AL("move_object;edit_object;axes")} Related Topics



Resize an object using the mouse

1. Make sure you are in Edit Object mode.

2. Click the object you want to resize.

3. Click-and-drag the light gray grips in the corner of the object’s editing frame to resize it. The mouse
pointer changes to the Resize cursor.
You can resize the object in the two axes in which the corner grip lies.

4. Press the following keys as you drag to constrain the axes in which you resize the object:
CTRL to change the size in all three axes at the same time.
SHIFT to change the size in one axis only at any time.

4 Tips
{button ,AL("object_grips;edit_object;object_resize;move_object_through")} Related Topics




You can use collisions to resize objects so that they lie flush with one another. Take care, though, that
objects’ volumes do not overlap as it will take longer to process the world.

When you have resized an object by pressing CTRL as you drag, release the mouse button before
releasing CTRL, otherwise the object resizes to the current position of the mouse cursor.



Resize an object using the Attributes palette
1. Make sure you are in Edit Object mode.

2. Click the object you want to resize.

3. Click Position in the Attributes palette.

4. Enter the new size for the object in the Depth, Width and Height boxes.
r For help on an item click
7 at the top of the dialog box and then click the item.

{button ,AL("object_resize;edit_object;axes")} Related Topics



Rotate an object using the mouse

1. Make sure you are in Edit Object mode.
2. Click the object you want to rotate.

3. Click-and-drag the edges of the object’s editing frame to rotate it. The mouse pointer changes to
the Rotation cursor.

An object rotates in the axis in which the edge lies about its center of rotation (or the center of the
object if it does not have a center of rotation).

3. Press sHIFT while you drag to constrain the angle rotated to multiples of 45°.
L Tips

{button ,AL("object_grips;orientation;edit_object;object_rotate")} Related Topics



Press cTRL and click an edge of the frame to reset the object to its original orientation.

Use rotations sparingly as worlds with many rotated objects take longer to process. Many objects are
provided in a variety of orientations to prevent the need for rotating.

If you rotate an object and then collide with another object, both objects' volumes will be outlined in red.
The rotated object's volume will appear much bigger than before, as it now must contain all the
possible positions of the objects’ components.



Rotate an object using the Attributes palette
1. Make sure you are in Edit Object mode.

2. Click the object you want to rotate.

3. Click Position in the Attributes palette.

4. Enter the values for the rotated object in the Roll, Pitch and Yaw boxes.
r For help on an item click
7 at the top of the dialog box and then click the item.

{button ,AL("object_rotate;edit_object;axes")} Related Topics



Duplicate an object

1. Make sure you are in Edit Object mode.

. Click the object you want to duplicate.

. Choose Edit>Copy.

. Move the viewpoint to where you want to place the object.
. Choose Edit>Paste.

The object is inserted into the world in the current view. It contains the same properties and
attributes as the original object.

4 Tips
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jlick the Copy icon on the toolbar to copy an object.
i

Click the Paste icon on the toolbar to paste an object.



Delete an object

1. Make sure you are in Edit Object mode.
2. Click the object, and choose Edit>Delete.
4 Tip

{button ,AL("edit_object")} Related Topics



Press DELETE on the keyboard to delete an object.



Change object properties

1. Make sure you are in Edit Object mode.

2. Click the object you want.

3. Click Actions in the Attributes palette, and enter or select the necessary value.
Changes that you make to an object’s properties are reflected immediately in the 3Space window
whenever possible. If they are not immediately visible, switch to Play mode to see the changes.
To find further details of each option, click the What's This? icon on the toolbar and click the object
in the Warehouse.

{button ,AL("properties;edit_object")} Related Topics



Add a URL to an object

1. Make sure you are in Edit Object mode.

. Click the object to which you want to add a URL.
. Click Actions in the Attributes palette.

. Enter the address in the URL box.

. Enter the target frame in the Target box.

This can be a user defined frame beginning with an alphanumeric character, or one of the reserved

names.

6. Enter a text string in the Description box. The text string is displayed in the Netscape status bar
when the mouse cursor changes to a hand to indicate the link (Internet Explorer does not support
this function), or as a tooltip.

k Example

g b~ W N
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Target frames

The following names, which begin with an underscore, are supported by Target in Actions:
_blank - load this link into a new, unnamed frame.

_self -load this link over yourself.

_parent - load this link over the parent frame (becomes self if there is no parent).
__top - load this link at the top level (becomes self if you are at the top).



Example URL

The following example will display a tooltip “Go to the VWWW?” (and the same string in the Netscape
status bar) and link to the center of the Virtual World Wide Web replacing the current Web Page:
URL http://vwww.com/

Description Go to the VWWW
Target _current



Change the color of an object
1. Make sure you are in Edit Object mode.
2. Click the object you want to recolor.
3. Click Materials in the Attributes palette.
4. Scroll to the color chart that defines the color range you want to remap.
The current color range has a wide white outline. The original color range has a thin yellow outline.
5. Click the segment in the chart to which you want to map the range.
Click the original color range to reset the facets in a range to their original colors.
4 Tip

{button ,AL("color;edit_object")} Related Topics



Add a texture to an object

1. Click Materials in the Warehouse.
2. Click a category in the drop-down list.
The textures belonging to the selected category are displayed in the textures scroll box.

3. Click the texture you want and drag it onto a facet in the color range you want to change. If
necessary, press ALT while you drag the texture to display the Apply Texture dialog box. If you do
not display the Apply Texture dialog box, the texture is mapped using the most recent option.

4. Click the mapping option you want to use. The orientation of the mapping is illustrated in the dialog
box.

5. Click OK.
Once you have applied a texture to an object, you can use the mouse to adjust its size, orientation
and position, or one of the preset transformations in the Attributes palette.
] Tips

{button ,AL("preview_texture;texture_manipulate;textures")} Related Topics



Apply Texture dialog box

The Apply Texture dialog box is displayed when you first drag a texture from the Warehouse palette
onto an object in the Edit Object mode. You can then select whether it is always displayed when you
add a texture, or only if you hold down the ALT key as you add the texture. If you clear the check box
the dialog is always displayed. If you select the check box, the dialog is only displayed if you press ALT
as you drag a texture onto the object.

If the object or facet already has a texture, the Apply Texture dialog box is not displayed if you change it
to another texture. The original texture is deleted and the new texture uses the original mapping
method.



Mapping options
There are four ways you can map a texture:

8§ Wrap: the texture is wrapped around the object like a sheet of paper (it is adjusted in each axis so
that it is not distorted). You can wrap the texture in the X, Y or Z axis.

§ Planar: the texture is mapped as a single image onto all the facets in the color range from one
direction. You can apply the texture in the X, Y or Z axis.

§ Cylindrical: the texture is wrapped around the object like a tube, covering all the facets in the color
range. The tube can point in the X, Y or Z axis.

§ Spherical: the texture is wrapped around the object like a sphere, covering all the facets in the color
range. The sphere can have its axis in the X, Y or Z axis.



As well as dragging textures directly onto the object, you can also drag them onto the relevant range in
Materials in the Attributes palette.

If you import a texture onto an object that has a built-in texture, the original texture can only be
recovered by choosing Edit>Undo or by re-importing the object from the Warehouse.

In addition to using textures supplied with Do 3D, you can also drag images from Windows Explorer
into the 3Space window. The following formats are supported: .BMP, .PCX, .GIF, .JPEG, .TIF, .TGA.



Switch to Edit Material mode
k Choose View>Edit Materials.
In Edit Material mode the Texture toolbar is displayed, which allows you to manipulate a texture
using the mouse. The current object is highlighted.
4 Tip



1]

Click the Edit Material icon to change to Edit Material mode.



Manipulate a texture using the mouse
1. Make sure you are in Edit Material mode.
QCIick an icon from the Texture toolbar:
K
move the texture around object while retaining its current size and orientation;
il
enlarge or shrink the texture while retaining its current orientation;
®
rotate the texture about the initial position of the mouse cursor.
3. Click-and-drag on the texture on the object in the 3Space window to change it.

To rotate the texture drag left and right.
4 Tip

{button ,AL("texture_manipulate;textures;edit_material")} Related Topics



Manipulate a texture using transformations

1. Make sure you are in Edit Material mode.

2. Click Materials in the Attribute palette.

3. Click an icon beside the material range you want to change:

Ef

~flips the texture horizontally;

_lflips the texture vertically;

rotates the texture 90° clockwise.

{button ,AL("texture_manipulate;textures;edit_material")} Related Topics



Change a texture’s mapping coordinates
1. Drag the texture from the Warehouse onto the object you want, while pressing ALT to display the

Apply Texture dialog box.
2. Click the Coordinate Mapping option you want to use, and click OK.

If the object or facet already has a texture, you must press ALT to display the Apply Texture dialog
box, otherwise the new texture uses the original mapping method.

{button ,AL("texture_manipulate;textures")} Related Topics



Delete a texture from a selected object
1. Make sure you are in Edit Material mode.
2. Click the object you want.

3. Click Materials in the Attributes palette and click on one of the swatches in the texture’s color
range.

{button ,AL("edit_material")} Related Topics



Add a sound to an object
1. Click Sounds in the Warehouse.
2. Click a category in the drop-down list.
The sounds belonging to the selected category are displayed in the sounds scroll box.
3. Click the sound you want and drag it onto the currently selected object in the 3Space window.

Once you have added a sound to an object, you can use the Attributes palette to set the way it is
played in the world.

» Tips

{button ,AL("preview_sound;sounds_manipulate;sounds")} Related Topics



Set the sound volume

. Make sure you are in Edit Object mode.

. Click the object with the sound attached.

. Click Sounds in the Attributes palette.

. Drag the Volume slider to set the maximum volume the sound can be played at:

If Ambient is selected, the volume slider sets the volume level for the sound. The further you drag
the handle to the right, the louder the sound is played.

§ If Ambient is clear, the volume slider sets the distance you must be from the object to hear it at
maximum volume. The further you move the handle to the right, the further away from the object
you must be to hear the sound at full volume.

4 Tip
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{button ,AL("sounds_manipulate;sounds;edit_object")} Related Topics



To hear the sound, click Play.



Create a distanced sound

1. Make sure you are in Edit Object mode.

2. Click the object with the sound attached.

3. Click Sounds in the Attributes palette.

4. Clear the Ambient check box.

5. Drag the Volume slider to set the distance from the object where you hear the sound at full volume.

{button ,AL("sounds_manipulate;sounds;edit_object")} Related Topics
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Loop a sound

1. Make sure you are in Edit Object mode.

2. Click the object with the sound attached.

3. Click Sounds in the Attributes palette.

4. Select the Loop check box.

5. Select how the sound is played in the world from the Trigger drop-down list.
Tip

{button ,AL("sounds_manipulate;sounds;edit_object")} Related Topics



If you click Play to hear a looped sound, you can stop the sound playing by either clearing the Loop
check box, or, if Trigger is set to Click On/Off, by clicking Play again.



Activate a sound

1. Make sure you are in Edit Object mode.

2. Click the object with the sound attached.

3. Click Sounds in the Attributes palette.

4. Select how the sound is played in the world from the Trigger drop-down list.

{button ,AL("sounds_manipulate;sounds;edit_object")} Related Topics



Change the pitch of a sound

1. Make sure you are in Edit Object mode.

2. Click the object with the sound attached.

3. Click Sounds in the Attributes palette.

4. Drag the Pitch slider to adjust the pitch at which the sound is played.

By default, the slider is set to 64 in the center of the scale. Drag the slider to the right to increase
the pitch, and the left to decrease it. Each marker indicates an octave change.

{button ,AL("sounds_manipulate;sounds;edit_object")} Related Topics



Delete a sound from an object

1. Make sure you are in Edit Object mode.

2. Click the object with the sound attached.

3. Click Sounds in the Attributes palette, and click Delete.

{button ,AL("edit_object")} Related Topics



Preview a world

k Choose View>Play to run the world. This is how the world will look if it was displayed in Viscape,
Superscape's 3D Web browser.
] Tips

{button ,AL("movement;viewpoints")} Related Topics



Change viewpoints
k Choose one of the following commands on the View menu to switch to:
Walk - the viewpoint is set at a fixed height. You can move the viewpoint forwards, backwards and
sideways, or rotate and tilt it. You cannot, however, raise or lower the viewpoint. In this mode

collisions are enabled so you cannot walk through other objects, although you can walk over small
objects and climb stairs.

Fly - the viewpoint is free to move in all axes at any time. Collisions are not enabled so you can
move through other objects.

When you change from Fly to Walk you are returned to ground level.
4 Tip

{button ,AL("viewpoints")} Related Topics
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jlick the Walk icon on the toolbar to walk.
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Click the Fly icon on the toolbar to fly.



Set a starting viewpoint
1. Adjust the viewpoint until it is in the position you want to start at.
2. Choose View>Set Viewpoint to set the initial position for your world.

When you load or reset the world, it will be loaded at this position. You can set a new starting
viewpoint at any time.

» Tip

{button ,AL("viewpoints;movement")} Related Topics



Reset a world
k Choose View>Reset World.
This resets the view in the world to its initial position.
4 Tip

{button ,AL("viewpoints;movement")} Related Topics



@

Click the Reset World icon on the toolbar to reset the world.



Publish a world

To display your world on the WWW, it must be placed, with any accompanying content, on a web
server. The web server decides how to deliver the world to the client, based on a list of content or
MIME types. To make sure your world is delivered correctly the following MIME type must be added to
the server for files ending in the .SVR extension:

type: x-world
subtype: x-svr

{button ,AL("publishing")} Related Topics




Embed a world in an HTML page

To embed a world in an HTML page you need to use the OBJECT tag for Microsoft Internet Explorer
and the EMBED tag for Netscape Navigator. The easiest way to do this is to use some HTML as
follows:

<OBJECT CLASSID="clsid:1B487523-BEC2-11CF-BF9E-0020AF998FF5"
WIDTH=480 HEIGHT=360>

<PARAM NAME="World" VALUE="myworld.svr" ID="iesvr">

<EMBED SRC=myworld.svr WIDTH=480 HEIGHT=360 N. ="nssvr'">
</OBJECT>

classid must always be the same - this is the unique class id for Viscape.

The EMBED tag is not understood by Internet Explorer as a parameter for the OBJECT tag so it
ignores it. The OBJECT tag is not understood by Netscape so it ignores it and uses the EMBED tag
instead.

» Tip

{button ,AL("publishing")} Related Topics



Link a world to the VWWW

The Virtual World Wide Web (VWWW) is a web of interconnected independently owned 3D web pages
that you can view using Viscape.

You can add a link to your own 3D world by visiting the VWWW at vwww.com, and following the
instructions for adding a link.

{button ,AL("publishing")} Related Topics




Export a world as a VRML world

1. Choose File>Export VRML.
2. Enter a filename and directory, and click Save.

If you use an existing filename and destination, an alert box warns you that you are about to
overwrite existing data. Click Cancel to abort the operation and change the name of the file or its
destination, or OK to overwrite the existing file.

The exported world is a snapshot of the current Do 3D world. It is saved as a .WRL file and a set
of .GIFs for the textures.

» Tip

{button ,AL("publishing;vrmI")} Related Topics



The VRML exporter exports worlds in VRML 2.0 format, but only exports geometry and textures. If you
want to add behaviors you must use a VRML editor and edit the world after export.



You can also change a range of colors by:

§ dragging the range from the Colors category in Objects in the Warehouse onto the object in the
3Space window;

§ dragging the range from the Colors category in Objects in the Warehouse onto the Attributes
palette.



You can move and scale the texture in just one axis at a time by pressing SHIFT as you drag.

You can constrain the rotation of the texture by pressing the following keys as you drag:

SHIFT to rotate the texture 90°. Drag left or right to rotate it anticlockwise or clockwise from its current
position;

CTRL to manipulate the texture on a single facet, without affecting the texture on any of the other facets.

Warning: If you do manipulate the texture on a single facet by pressing CTRL, the texture will be
displayed in its original orientation on any objects that replace it as part of its distancing attribute.



The Ambient check box sets the sound mode:
§ Selected - sound is played at the same volume everywhere in the world.
§ Clear - sound is distanced.



Double-click a sound in the Warehouse to listen to it.

In addition to using sounds supplied with Do 3D, you can also drag a .WAV file directly from Windows
Explorer onto an object in the 3Space window.



Sound triggers

8

Click - the sound is played once, or continuously if looped, when you click on the object with the
mouse;

Click On/Off - the sound is played once, or continuously if looped, when you click on the object with
the mouse. Clicking the object again stops the sound.
Reset - the sound is played once, or continuously if looped, when the world is reset;

Reset or Click - the sound is played once, or continuously if looped, when the world is reset or you
click the object with the mouse;

Reset or Click On/Off - the sound is played once, or continuously if looped, when the world is reset
or you click the object with the mouse. Resetting the world or clicking the object again stops the
sound.



Sounds are played at different pitches, based on the MIDI standard note numbers. Middle C is defined
as note 60, with lower numbers representing lower notes and higher numbers higher notes. Therefore,
if you have a sample of the C below middle C which you want to play at middle C, you need to set the
play pitch to one octave above its original level.

The default play pitch is 64.



You can preview your world without the Warehouse and Attributes palette by selecting the Hide
Palettes on Play option in the Preferences dialog box. The palettes are closed temporarily when you
are in Play mode, and displayed again when you change to Edit Object or Edit Material mode.

N

Click the Play icon on the toolbar to preview a world.



gt
[

Click the Set Viewpoint icon on the toolbar to set a viewpoint.



The MIME type is used by web browsers and servers to identify the file type it is about to download. If
the MIME type is not set correctly, your world will be downloaded as an ASCII text file.



Do not include more than one world in each HTML page - create a separate document for each world -
as Viscape does not support multiple instances in an HTML document when run under Windows 3.1.



ﬂ Play icon



b

Save changes to the setup

1.
2.

Click Movement Bar>Menu>Setup.
Select the Save Settings check box, and click OK
The Save Preferences File dialog box is displayed, showing the current preferences file (.CFG).

. Click Save.

An alert box warns you that the file already exists. Saving the new configuration will overwrite the
current data.

. Click OK.

You must save the preferences file if you want to keep changes to device configuration, display
options or display mode.

Tip



If you do not save any changes you make to the current configuration using the Setup dialog box, you
are prompted to save them when you exit the application.



Change the display mode
b Choose View>Display Mode and then select the mode from the list.
We recommend that you use the Auto Detect option (default) which checks your system and

selects the best match for it.
If you have trouble with the selected mode, you may be able to solve the problem by switching to

another mode.
4 Tip
{button ,AL("configuration")} Related Topics




The modes that are available depend on what is actually installed in your system. For further
information on some common modes, see Help Topics>Troubleshooting>My 3Space Window Display
Looks Poor.



Undo actions
b Choose Edit>Undo.
Repeat the command for as many actions you wish to undo. The Undo command grays out when
there is nothing left to undo.

» Tip



=

Click the Undo icon on the toolbar to reverse your actions.



Hide palettes in Play mode
1. Choose Edit>Preferences.
2. Select the Hide Palettes in Play Mode check box.

When you click the Play icon in the toolbar to preview your world, the Warehouse and Attributes
palettes, status bar and toolbar will be hidden.

Tip



To return to your previous editing mode, choose either View>Edit Objects or >Edit Materials.



Move the toolbar

b

1.

Click the mouse on the toolbar background and drag it around the screen. You can drag the toolbar
inside the window or outside it. The current position is indicated by a gray outline.

If you drag the toolbar over the edge of the window the orientation of the toolbar changes from
landscape to portrait. Releasing the mouse button as the toolbar changes its orientation attaches it
to the edge or bottom of the window and enables you to drag the toolbar along the border.

. To return the toolbar to its last position, double-click its background.

Tip



If you turn off the toolbar by clicking the Exit icon in the top right corner, choose Window>Toolbar to
redisplay it. You can also use this command to hide the toolbar.

Atick (V) appears next to the menu item when the toolbar is displayed.



b

Move and resize palettes

1.

w

Click the mouse anywhere on the gray palette background and drag it around the screen. You can
drag the palettes inside the window or outside it. The current position is indicated by a gray outline.

If you drag the palette over the edge of the window its orientation changes to the same as the
window edge. Release the mouse button as the toolbar changes its orientation to attach it to the
sides, top or bottom of the window.

. Hold down cTRL and drag the palettes to make them float anywhere.
. To return the palettes to their last position, double-click the gray background.
. To resize the palettes, click and drag any of the palette borders.

Tips



If you turn off a palette by clicking the Exit icon in the top right corner, choose either
Window>Warehouse Palette or >Attributes Palette to redisplay them. You can also use these
commands to hide the palettes. A tick (v) appears next to the menu item when the appropriate item is
displayed.

If the both palettes are docked in the same horizontal or vertical area, arrows are enabled in the top
right corner. Click the up arrow to extend one palette over the other and click the down arrow to display
both palettes.



b

Display the Apply Texture dialog box
1. Choose Edit>Preferences.
2. Select the Display Apply Texture Dialog check box.
The Apply Texture dialog box is displayed each time a texture is dropped into a world.
If this check box is clear, the dialog box is only displayed the first time a texture is dropped into a
world.
Tip



If the check box is clear, press ALT while you drag the texture to display the Apply Texture dialog box. If
you do not display the Apply Texture dialog box, the texture is mapped using the most recent option.



Display or hide the status bar
b Choose Window>Status Bar.
Atick (V) appears next to the menu item when the status bar is displayed.



Change the world horizon

1. Click Objects in the Warehouse.

2. Click Horizon Types in the Category drop-down list.
The category contains three types of objects: Horizon objects that set the horizon colors to those of
the template worlds, Sky objects that only alter the color of the sky, and Ground objects that alter
the color of the ground.

3. Double-click the horizon you want.
The new horizon loads in the 3Space window.
To create interesting effects try a combination of objects. For example, to create a night scene over

a city setting, drag in the Horizon City Center object, and then drag in the Sky Night object to
change the sky to night.



Keyboard shortcuts

Command Shortcut
New CTRL+N
Open CTRL+O
Save CTRL+S
Save As SHIFT+CTRL+S
Print CTRL+P
Undo CTRL+Z
Cut CTRL+X
Copy CTRL+*C
Paste CTRL+V
Delete DEL

Play CTRL+W
Edit Object CTRL+D
Edit Material CTRL+F
Walk CRL+K
Fly CTRL+L
Reset World F12

Help F1
What's This? SHIFT+F1



Use objects in their correct orientations

Many objects are supplied in a number of orientations. When building your worlds you should try and
use objects in the orientations they are intended for. For example, if you want to have a West facing
street lamp in your world you should use a street lamp that by default faces West, rather than use a
North facing lamp and rotate it.

There are two reasons for this:
§ Using unrotated objects creates a faster world;

§ Each orientation is lit using the same light source and so looks different, creating a more realistic
environment when put together.

The orientation of objects that are duplicated to face different directions is usually indicated by one or
more of the following letters in their name: N, S, E, W (North, South, East and West). To aid object
orientation as you build worlds, load the object Compass from the Signs, Symbols, Buttons category.
This always points North in Play mode, unless you specify otherwise in Actions in the Attributes palette.



Move an object through another object

If the object you are manipulating collides with another object, the middle grips on the object turn red.
There are two ways you can override the collision:

§ press ALT and then continue to drag it through the stationary object;
§ continue dragging through the stationary object. When the object you were dragging would have

passed through the stationary object completely, it is displayed again giving the appearance that it
has jumped to the other side of the object.

» Tip

{button ,AL("object_grips")} Related Topics



Objects that are completely flat (O in the Height box in Position in the Attributes palette) and positioned
at ground level will move through other objects without you pressing ALT.



Align objects with each other

Many objects can be used independently or together with other objects to form a larger group. If you
want to align these objects, or two or more other objects, you can either:
§ align the objects against a dummy object that you delete once the other objects have been aligned;

§ use the objects’ ‘sticky’ attribute. When two objects collide, drag the object you are moving against

and along the side of the other until it appears to stick momentarily, indicating that the two leading
edges of the objects’ volumes are aligned.
— e ¥

The illustration shows a green object being dragged left into another object, and forward until the
front edge of its volume is aligned with the front edge of the other object’s volume.



Number of sounds

Do not include lots of sounds in a world, as they increase the download time if you publish the world on
the Web, and decrease the speed at which the world is rendered.



Number of textures

Do not include lots of textures in a world, as they increase the download time if you publish the world
on the Web, and decrease the speed at which the world is rendered.

Do not add more than 15 textures to one object.



Define URLs

Stick to a case format (such as, UPPERCASE, or lowercase) for all your hotlinks and filenames. UNIX
webservers are very fussy about case sensitivity, and will treat Myfile.svr, MYFILE.SVR and myfile.svr
as three different files. Most FTP programs have an option to automatically convert filenames to
lowercase on upload to the server, making this a good choice for case of links.



Objects

We recommend that you do not use lots of objects in any world as it will generally run very slowly. If
you intend to display your world on the Web, bear in mind that while many users may be using Pentium
based computers with 16 MB RAM or more, there will also be many who are running 486 based
computers with 8 MB RAM.

If objects disappear from your world unexpectedly, you probably have too many objects in your world.



Distanced objects

Many objects have a distancing attribute which replaces a detailed object with a simplified object as
you move the viewpoint further away. Many objects are removed completely when they are a long way
from the viewpoint. Each of the replacement objects is stored within the VCA file.

Distancing is very important because it allows the speed of the world to be maintained - simple objects
are processed more quickly than very complex ones. However, distancing means that you must be
careful where you position objects when designing a world because an object’s "intelligence" is
sometimes only attached to the most detailed object rather than one of its replacements. Therefore,
when you click a replacement object it will not work as expected, until you move closer to it.



Build complex objects

Although Do 3D provides many ready made objects for use in virtual worlds, you can create your own
complex objects from the shapes provided in the Cubes, Cones, Spheres category. These include both
basic shapes and more complex ones, ranging from cubes, cones and spheres to tetrahedrons,
dodecahedrons and icosahedrons. Some of the shapes have multiple levels of detail and some have
properties that you can set.

All of the shapes are available in dark or light colors.



Create text in your world

Three-dimensional letters and numbers are available as individual objects for you to use in worlds.
They are provided in a Superscape font, uppercase only. Simply load these from the Letters, Numbers
category in Objects in the Warehouse, and align them to form words and sentences.

In addition to using separate objects for each letter, you can create complete words and sentences as
single objects by using one of the three text creation objects. These let you type in text as an object
property in Actions in the Attributes palette. When you switch Do 3D into Play mode, the object displays
the letters and words that you have written.

You can create 2D text in the MBE (Micro Bold Extended) and AG fonts, using the Text Creator MBE
Font or the Text Creator AG Font objects, or 3D text, using the Text Creator AG Font 3D object. These
objects are located in the Letters, Numbers category.

For more information on any of these objects, click the What's This? icon and then click the object in
the Warehouse.



Change the mouse movement setup

If you are using mouse movement mode to move around your worlds, you can adjust the following
options:

8 how the Mouse Home is displayed and its default position;

§ the speed at which you move around a world;

§ the way you switch between movement and selection modes;

§ the direction you move or rotate the viewpoint as you move the mouse.
Note: These options should be changed by advanced users only.

{button ,AL("mousemovement")} Related Topics



Adjust the mouse home position

1. Click Movement Bar>Menu>Setup.

2. Click the Devices tab, and click Proportional: Mouse Movement in the devices list.
3. Click either Floating or Centered.

4. Set the Home Visible check box to visible or invisible.
r For help on an item click
7 at the top of the dialog box and then click the item.

{button ,AL("mousemovement")} Related Topics



Adjust the speed you move around the world

1. Click Movement Bar>Menu>Setup.

2. Click the Devices tab, and click Proportional: Mouse Movement in the devices list.
3. Drag the Movement Sensitivity slider.

The further the slider is to the right, the faster you move in the world as you move the mouse away
from the Home position.

4. Drag the Rotation Sensitivity slider.
The further the slider is to the right, the faster you rotate in the world as you move away from the
Home position.
L For help on an item click
¥ at the top of the dialog box and then click the item.

{button ,AL("mousemovement")} Related Topics



Set the way you switch to movement mode
1. Click Movement Bar>Menu>Setup.
2. Click the Devices tab, and click Proportional: Mouse Movement in the devices list.

3. Click the switch transition method from the Mode Change drop-down list.
» For help on an item click
% at the top of the dialog box and then click the item.

{button ,AL("mousemovement")} Related Topics



Set the axes for mouse movement

1. Click Movement Bar>Menu>Setup.

. Click the Devices tab, and click Proportional: Mouse Movement in the devices list.
. Click Functions.

. Click Move or Select for the Left Mouse Button and the Right Mouse Button.

. Click a movement option from the six drop-down lists for each mouse movement. The top row of list
boxes set the sideways movement of the mouse and the bottom row set the forward and backward
movement.

These options are only effective if you select Move in Step 4.
6. Click Relative or Absolute below each movement option.
You can set the buttons to their default setup by clicking Restore.
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Move - moves or rotates the viewpoint in one of the axes.
Select - the mouse acts as it does in selection mode.



Move X, Move Y, Move Z - moves the viewpoint in each axis.
Rotate X, Rotate Y, Rotate Z - rotates the viewpoint in each axis.



Relative - the distance of the mouse pointer from the home position determines the speed of rotation of
movement.

Absolute - the distance of the mouse from the home position determines the absolute orientation or
position of the viewpoint.



Proportional devices

Proportional devices, such as the Logitech Magellan (Spacemouse) and joystick, are the most intuitive
control devices for virtual worlds. Each device has (or emulates in some way) six basic axes of
operation, X, Y and Z translational motion and X, Y, Z rotations. In a ‘normal’ setup the Z+ axis
translational movement defines forward movement and the Y- axis rotational movement defines an anti-
clockwise spinning in the vertical axis.

Each device has a control type configuration that dictates how the viewpoint moves when you use it.
You can:

§ choose from 10 preset proportional device configurations, each with four levels of sensitivity. Each
configuration is designed to restrict the axes of operation that are not required and adjust the
sensitivity of the required axes.

§ redefine the number of axes the device can operate in simultaneously;

§ adjust the sensitivity of the device in each axis;

§ adjust the deadzone of the device in each axis.

You must configure the Do 3D software for a device before you can use it.

Note: Configuring proportional devices should be attempted by advanced users only.

{button ,AL("prop_devices")} Related Topics



Proportional device configurations

Car Cntl Lets you control and 'drive’ car type objects.

Fly Cntl Provides total control over an object.

Fly No Z Same as Fly Cntl but with no object tilt.

Man Cntl  Lets you control and 'walk' humanoid type objects.
Plane Cntl Lets you control and 'fly" airplane type objects.
View Move Provides total control over the viewpoint.

View No Z Same as View Move but with no viewpoint tilt.
View Spin  Moves a viewpoint around an object.

View Stat  Provides control from a stationary viewpoint. It only has movement in the three rotational
axes.

View Walk  Where vertical movement or tilt is not required.
You can use the four User Types to define your own control type configuration.

{button ,AL("prop_devices")} Related Topics



Set up a device
1. Click Movement Bar>Menu>Setup.
2. Click the Devices tab, and click your device in the device scroll box.
The current state of the device is displayed - Enabled or Disabled.
3. If the device is disabled, Click Enable to enable it.
The current settings for the device are displayed below the scroll box.
4. Enter the necessary details, referring to the documentation supplied with the device.
5. Repeat Steps 3 to 6 for each additional device.

If you want to save any changes that you make to your setup so that devices use the new
configuration when you start Do 3D again, you must save the Do 3D preferences file.

» Tip

{button ,AL("prop_devices")} Related Topics



To configure devices that are Windows resources, such as your graphics card or sound card, you must
use the Windows Control Panel Application.



Change the control type
1. Click Movement Bar>Menu>Proportional Control Setup.

2. Click the device tab that you want to edit - if you are using one proportional device, you only need
to edit Device 1.

3. Click Select and click a configuration from the Proportional Control Type list.
If there is no suitable control type, select one of the User Types and set the number of
simultaneous axes, sensitivity and deadzone for the device in each axis.

r For help on an item click
¥ at the top of the dialog box and then click the item.

{button ,AL("prop_devices")} Related Topics



Change the number of simultaneous axes
1. Click Movement Bar>Menu>Proportional Control Setup.

2. Click the device tab that you want to edit - if you are using one proportional device, you only need
to edit Device 1.

3. Click one of the Number of Simultaneous Axes options from the drop-down list.

When set to 1, only the axis with the greatest force applied passes information to the virtual world
at any one time. When this field is set to 6, information from all the axes affects the viewpoint or
object.

k For help on the item click

¥ at the top of the dialog box and then click the item.

{button ,AL("prop_devices")} Related Topics



Adjust the sensitivity of a proportional device
1. Click Movement Bar>Menu>Proportional Control Setup.

2. Click the device tab that you want to edit - if you are using one proportional device, you only need
to edit Device 1.

3. Adjust the Sensitivity slider for each of the six basic axes.

The higher the value, the more sensitive the device is in that axis. Setting the sensitivity to zero
switches the device off in that translation or rotation axis.

{button ,AL("prop_devices")} Related Topics



Adjust the deadzone of a proportional device

1. Click Movement Bar>Menu>Proportional Control Setup.

2. Click the device tab that you want to edit - if you are using one proportional device, you only need
to edit Device 1.

3. Adjust the Deadzone slider for each of the six basic axes.
The higher the value, the greater the input required to start the device operating in that axis. Setting
the deadzone to zero switches the deadzone off entirely, making the device sensitive to tiny
amounts of input.

k For help on an item click
¥ at the top of the dialog box and then click the item.

{button ,AL("prop_devices")} Related Topics



Deadzone sets the amount of force needed to start an action in the any of the axes.



Display options
You can adjust the following drawing options which affect the way objects are rendered in a world:

8

Detail Level - sets globally the distance at which objects are replaced by less or more detailed
objects. As you increase the detail level value, the replacement distances are pushed further away
from you so that more detail is retained. If you set the detail level to a negative number, the
replacement distances are brought closer to you, so that objects are replaced with similar ones
nearer to you.

Zoom Ratio - sets the ratio of magnification on the screen. If you think of the viewpoint as a
camera, zoom sets the focal length of the lens from telephoto (small values) to wide angle (large
values).

Background - sets the background to an horizon, a solid color or a backdrop (if there is one in the
world). The horizon lets you orientate yourself in a world.

Locked viewpoints - you can lock a viewpoint to one or more axes so that a rotating object appears
to rotate in the axes. Normally all locks are off, and a viewpoint attached to a rotating object rotates
with it and the object is always seen in the same orientation.

Note: These options should be changed by advanced users only.
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Change the detail level

1. Click Movement Bar>Menu>Setup.

2. Click the Display tab.

3. Drag the Detail Level slider in the range -10 to 10. The default value is 0.
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Change the zoom ratio

1. Click Movement Bar>Menu>Setup.

2. Click the Display tab.

3. Drag the Zoom Ratio slider in the range 256 to 16384. The default value is 8192.
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Change the background
1. Click Movement Bar>Menu>Setup.
2. Click the Display tab.
3. Select a background from the Background drop-down list:
8 Horizon - displays the ground and sky with a horizon.
§ Solid - displays a solid color behind the world (this is black by default).
§ Backdrop - displays a backdrop (if the world contains one) behind the world.

Each background has a No Redraw option. It is not recommended you use this option as it may
cause image trails to be left on the screen.
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Lock a viewpoint to an axis

1. Click Movement Bar>Menu>Setup.

2. Click the Display tab

3. Select the Viewpoint Lock check boxes for the axes that you want to lock.
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My 3Space window display looks poor

By default, when you start Do 3D it checks your hardware and selects the best display mode for it
(Auto Detect option).

If your display looks poor and the world runs slowly, the display mode may be incorrect. You may be
able to solve the problem by switching to another mode.

Some of the following modes may be available, depending on your system:

DirectDraw - Gives the best quality graphics on computers without Direct3D hardware acceleration. All
the graphic data is processed at the screen depth you are using (8-bit, 16-bit, 24-bit or 32-bit).

WinG - May increase the speed of the graphics on computers without Direct3D hardware acceleration,
but at the loss of some graphics quality. All the graphical data is processed at 8-bit color depth
regardless of the screen depth you are using.

Direct3D HAL - This can provide good graphics and fast worlds, but it is only available if you have a
Direct3D graphics card in your computer. You must also have Direct3D software installed on your
system to use this option.

RGB Emulation - A Direct3D software emulation mode. Worlds run in RGB Emulation mode may run
very slowly compared to worlds using any of the other modes. An MMX enhanced processor may
improve performance in this mode if MMX Emulation mode is not available.

MMX Emulation - Same as RGB Emulation mode but uses an MMX enhanced processor.



The colors in my 3Space window flash

If the colors in your 3Space window flash or change unexpectedly when using Help, or when activating
other programs, then you may be running Windows in 256 color mode.

For best results change Windows to run in High Color (16 bit) mode. Choose Start>Settings>Control
Panel>Display, click the Settings tab, and click High Color (16 bit) in the Color Palette drop-down list
box.

If you have to run in 256 color mode, keep the number of other active programs to a minimum while
you run Do 3D.



I can't hear any sound

If you cannot hear any of the sounds supplied with Do 3D, or sounds built-in to objects, make sure you
have a sound card installed and properly connected, and that you have installed the relevant software.
Consult the documentation that came with your hardware for further information about installing a
sound card.

If your sound card is installed and working correctly check that you have your speakers turned on and
the volume turned up. Sounds supplied with Do 3D are recorded at a lower volume so you may need to
increase the volume on your speakers to hear them.



System lockup with Matrox graphics cards
Your system may lock if you run Do 3D with a Matrox Mystique graphics card installed in your PC.

You may be able to solve this by changing an option in the Matrox Advanced Settings. Choose
Start>Control Panel>Display and click the Performance tab in the MGA Advanced Settings dialog box.
Select the Use 3D Acceleration check box and restart Do 3D.






