Scanning Tools and Methods

You can use a number of methods to create pictures for your Help file. Each
method will influence the visual appearance of the picture as well as your
approach to design. If possible, try to match the strengths and weaknesses of the
method used to create the picture to the kind of image for which it is best suited.

The resolution and accuracy of any device will affect the quality of the final
image. Also, many methods require some ability to draw. Employing a
professional designer for this work (unless there is one in the team) should be
considered—they will probably save time and produce better results.

For example, you can use any of the following methods to create pictures:
@ Use the Windows screen capture facility to take a screen shot and then edit the
bitmap in Windows Paintbrush.

@ Use a graphics application to create the picture from scratch.

@ Use a scanner to capture existing illustrations or clip art. Use a digitizing
tablet to trace an image.

() Import a picture created using a Macintosh graphics application.
Each picture that you include in the Help file must be saved as a separate file.
One way to manage pictures for a project is to create a subdirectory where all
pictures are stored, such as an \ART subdirectory in the project directory.

When building the Help file, the Help compiler can compress bitmap files
(including .SHG files) if you specify Medium or High using the COMPRESS
option in the [OPTIONS] section of the Help project file. On the average, you
can expect 25 percent to 50 percent reduction in size using compression.

(For details, see Chapter 16, “The Help Project File.”)

Picture Formats

Pictures that appear in Help files must be in one of the following standard
Windows formats.

Format Description

.DIB Windows version 3.x device-independent bitmap

.BMP Windows version 2.x bitmap

WMF Windows metafile

.SHG Windows Help hypergraphic bitmap



.MRB Windows Help multiresolution bitmap

Several applications, such as Microsoft Word for Windows, Micrografx®

Designer, Corel® Draw, and Aldus® PageMaker® and FreeHand®, and others
can save files or export them as metafiles. However, some applications, Aldus
FreeHand, for example, use a metafile format that differs somewhat from the
standard metafile format for Windows. For that reason, you can’t use their files
directly. You must convert them to the standard metafile format for Windows or
convert them to bitmap files.

Note:

If Help cannot display the file because it is in an unsupported format, you can take
a screen shot of it, paste it into Windows Paintbrush, and then save it as a
Windows-based bitmap. If you can’t display the picture in Windows, you must
use a conversion utility to convert the file to a supported format.

Because Windows-based metafiles are not binary compatible with the Macintosh,
you should use only bitmaps if you want to ensure cross-platform compatibility.
Creating Bitmaps from Screen Shots

Another easy way to create art for your Help file is to use the Windows screen
capture facility. Using screen shots, you can create a bitmap from anything that
you can display in Windows—a window, dialog box, or icon, for example. You
can also use this method to convert unsupported picture formats into Windows-
based bitmap format. For example, you may want to use a full-featured draw
program to create art for your Help file but save the final pictures as bitmaps. You
can do that just by previewing the finished art in Windows. When the image
displays in Windows, you can copy it to the Clipboard and paste it into a graphics
editor such as Windows Paintbrush. Then you use the graphics editor to clean up
the image as needed, and save the image in an appropriate format.

To create a bitmap from a screen shot

1. Display on the Windows desktop the element you want to make into a picture.
For some shots, this may require a special setup—starting the application,
opening a document, scrolling to a specific location, and so on.

2. Press ALT+PRINTSCREEN to copy a picture of the active window to the
Clipboard.

3. Open Paintbrush.

4. From the View menu, choose Zoom Out.

Zooming out ensures that Paintbrush will capture the entire screen dump
5. From the Edit menu, choose Paste.

6. Select any Paintbrush tool.

Paintbrush displays a zoomed out version of the screen dump



1. From the View menu, choose Zoom In.
The screen shot appears full size.

2. Make any changes you want to this piece of art.

3. Use the Pick tool to select the portion of the drawing you want to save as the
final bitmap.

4. From the Edit menu, choose Copy To.

Save the file as a Windows bitmap.

v

Creating Pictures from Scratch

Both paint and draw programs are now widely available. Paint programs are well-
suited to freehand-type illustrations. They include many features such as facilities
for brushes, lines and shapes, filling areas with colors and patterns, image
manipulation, and so on. Draw programs are better suited for creating mechanical
or structured images. Generally, they take longer to learn to use than paint
programs, but they allow greater flexibility in editing the details of the drawing.
Unlike pictures created by paint programs, pictures created in draw programs can
contain multiple layers, each of which can be manipulated independently.

Painting and drawing programs are based on two very different ways of
describing a picture. Painting software uses an array of color pixels (or bit maps)
to represent the image. Drafting or object orientated software describes pictures as
a list of graphic primitives such as line or circle which have a number of attributes
such as position and size.

Creating graphics from scratch may pose a large problem for the inexperienced
Help author because their use seems to require the ability to draw. Frequently
there appears to be a bewildering variety of shapes, styles, colors, patterns, and
specialized tools to choose from. However, creating effective graphics often
depends to a large extent on applying sound principles, rather than on pure artisitc
skill. The documentation that comes with your graphics editor should provide
some direction and guidelines for designing and creating graphics. And if you
want to provide a more professional look to your pictures, you can have them
created by a competent graphic designer or illustrator.

Microsoft Windows does not include a draw program, but it does offer a basic
paint program—W indows Paintbrush. You can use Paintbrush to create freehand
illustrations and prepare screen images of your application or the Windows
environment. The procedure for creating a simple drawing in Windows
Paintbrush involves the following steps.

To create a simple drawing in Windows Paintbrush
1. Start Paintbrush.
2. Determine the size of the drawing area.

You define the drawing area by choosing the Image Attributes command from the
Options menu. Frequently, it is a good strategy to use the default drawing area
(equivalent to the entire screen) while you are creating the drawing so that you



have more room to work. When you are ready to save the drawing, you can define
the size of the final art.

3. Select a background and foreground color.
You can change from a color palette to a black-and-white palette (or vice
versa) by choosing the Image Attributes command from the Options menu.
However, after you begin a drawing, you must stay with the palette you
selected.

4. Select a drawing tool.
In most cases, you will use several tools to create a picture.

5. Draw the picture.
If you make a mistake while drawing, you can use the Undo command on the
Edit menu and the Eraser tool.

6. Make any changes or edits to the picture.
If you need to see the drawing in greater detail to make fine adjustments, you
can use the Zoom In command on the View menu. The Zoom In command
maghnifies a portion of the drawing so you can change one pixel at a time.

7. When the picture looks the way you want it to, save it as a Windows 16-color
bitmap.
Make sure that you save just that portion of the drawing that you want to
appear in Help and not the entire drawing area (if the drawing area is larger
than the picture you are creating).

For complete instructions on how to use Paintbrush to create pictures, see the
Microsoft Windows User’s Guide, version 3.0 or 3.1. If you are using a different
graphics editor to prepare your pictures, see the user’s guide for the graphics
application you are using to learn how to create the pictures.

Creating Realistic 3D Graphics

When an object is displayed in two dimensions, as in a drawing, depth
relationships, such as whether one line is in front of or behind another, are often
ambiguous. On the other hand, when perceiving an actual solid object or scene,
the human eye uses certain information, sometimes referred to as depth cues, in
order to deduce the spatial structure.

You can include some of these cues, such as occlusion (closer objects overlap
those that are further away) and shading, in order to make your pictures more
realistic. There are various ways of showing depth with three-dimensional images.
You can:

Creating Pictures from Scanned Images

Scanning images is one of the easiest ways to include graphics in the Help file
because the most difficult task—creating the image—has already been done. You
only have to work the scanning software and then perform final cleanup and
editing in Windows Paintbrush or some other graphics application.



The problem with most scanned color images, however, is that they need at least
256 colors to look realistic when they are displayed on a computer screen.
Because Windows Help does not support 256-color pictures, and also because
256-color pictures often do not display adequately on systems with standard VGA
(16-color) video adapters, you are limited in the kind of images you can scan for
use in Help files.

Sixteen-color pictures are suitable for diagrams, line drawings, cartoons, and
simple drawings, most of which can be scanned successfully. Also, there is an
increasing amount of public clip art available that would be suitable to scan. The
goal is to offer the highest possible image quality to users with low-end video
hardware but avoid short-changing users with more powerful video capabilities. If
you can use a scanner to obtain pictures that meet Help’s basic requirements, then
scanning is a good way to create graphics for your Help file.

Creating Bitmaps with a Digitizing Tablet

A digitizing tablet is the best way to trace the outline of an existing image and
ensures that the proportions are correct. A mouse or a tablet can be used to copy a
picture by eye, but this requires more skill than tracing. Tablets are based on an
absolute coordinate system, while mice use relative coordinates: this affects the
physical drawing action and is the principal reason why mice are not good for
tracing.

Digitizing tablets can be fitted with a stylus (like a pen) which is good for
freehand drawing or a transparent cross-hair cursor which is good for accurate
tracing and for positioning elements on screen. Mice are also good for positioning
elements.

Creating Pictures on the Macintosh

Many graphics artists use the Apple Macintosh computer as their primary tool for
creating art. Although the file formats most commonly used by Macintosh
applications are not supported by Windows Help, you can use the Macintosh
computer to create art for your Help file. Basically, you have two options:

1) You can use a Macintosh draw or paint program to create the art and convert
the files to a standard Windows graphics format.

2) You can insert art in a Word for the Macintosh document and then import the
entire document to Word for Windows and capture the art in screen shots.

Importing Art from Macintosh Graphics Applications

Most draw and paint programs that run on the Apple Macintosh have the ability to
save files in PICT format. Since there are several ultilities that convert graphics
files from PICT to DIB format and from DIB to PICT format, you can create art
for your Help file using your favorite Macintosh graphics application and then
transfer the art to the PC



so it can be built into the Help file. You can also move original art and screen
shots Windows saved in DIB or BMP format to the Macintosh application and
edit them there.

To move art back and forth between the Macintosh and PC, you need the
following tools:

@ A conversion utility that can convert the file formats you are using. Alchemy
is one example.

@ Network hardware and software that connects the PC and Macintosh
computers or software like DOS Mounter that enables Macintosh computers
to read and write to MS-DOS 3.5-inch floppy disks formatted on the PC. A
palette file in the Macintosh application that matches the standard Windows
16-colors.

Some Conversion Issues
When importing art created by Macintosh applications, you should be aware of
the following issues:

@ When transferring files from Windows to the PC, the Macintosh graphics
application may not be able to see the files in its Open list box. If this
happens, it is probably because the converted file has the wrong TYPE and
CREATOR set. You can change these settings manually with Macintosh
utilities such as DiskTop; however, DOS Mounter and some network software
(Microsoft LANManager 2.1, for example) perform automatic extension
mapping, which assigns the proper TYPE and CREATOR to a file with a
particular MS-DOS file extension whenever a file is moved to the Macintosh.

) Because Windows Help only supports bitmaps with 16 colors, you should
create a custom “Windows 16-color palette” for your graphics application.
That will ensure that the art you create and edit on the Macintosh will display
with the correct colors when transferred back to Windows. If you want to use
dithered colors that are found in Windows Paintbrush, you may need to create
those as well, for example as custom brush patterns in Studio/8.

@ Some graphics applications on the Macintosh save files with a minimum 256-
color depth (8-bit color). If this is true, make sure that the conversion utility
reduces the file to 16 colors (4-bit color) when it converts it to a bitmap. Or
open the 256-color bitmap in Paintbrush and save the file as a 16-color
bitmap. Storing bitmaps on the PC in 16 colors will also keep file sizes to a
minimum and conserve disk space.

MS-DOS only accepts filenames that have 8 characters plus a 3-character
extension. Because the Macintosh does not have this limitation, you should
follow the MS-DOS 8-character naming convention when naming the art you
create on the Macintosh, and use the .PIC extension. Otherwise, the filenames
of graphic files you transfer may be difficult to interpret.



Using Batch Files to Control the Conversion Process

If the conversion utility you are using runs in MS-DOS, you may want to create a
batch file to control the conversion process. Batch processing ensures consistency
in the conversion routine and also allows you to convert many files at the same
time. The following example shows one way to set up a batch-file process for
converting art between the Macintosh and PC.

The first batch file converts Windows BMP files to Macintosh PICT format:
@echo off

break on

if "%1" =="" goto ERROR

echo.

echo Converting BMP file to PICT format...
echo.

‘RESTART

for %%p in (%1) do c:\tadpole\alchemy -mo %%p
shift

if not "%1" =="" goto RESTART

goto MOVEFILE

:ERROR

cls

echo This batch file converts Windows BMP files to Mac PICT format.
echo Wildcards and multiple sets are allowed.
echo Syntax is:

echo.

echo %0 file(s).BMP

echo.

echo where file(s) = separate file names and/or wildcards.
echo.

goto EXIT

:MOVEFILE

echo.

echo Conversion complete.

echo Now moving file to EDITS\PICT folder...
echo.

copy *.pic ..\edits\pict

del *.pic

EXIT

echo.

echo All done!

The second batch file converts Macintosh PICT files to Windows BMP format:
@echo off
break on



if "%1" =="" goto BIGERROR
set loc=%1

echo.

echo ---------------

echo !'! WARNING !!!

echo.

echo If you are processing art for existing SLM

echo art files (that have already been 'addfile'd), you MUST first

echo check out the file(s). Otherwise the edits and changes will be lost!
echo.

echo Press the CTRL+C keys to stop this batch file, or pause

direxist \archive\%loc%

if errorlevel 1 goto ERROR1

goto PICT2ARC

:ERROR1

echo.

echo \TOAD\MAC!ARCHIVE\%loc% does not exist.
echo Please check the spelling of the directory name
echo or confirm you are starting from the net drive.
echo.

goto EXIT

:PICT2ARC

echo.

echo Placing copy of PICT files in \TOAD\MAC!ARCHIVE\%Iloc%...
echo.

copy *.pic \archive\%loc%

direxist c:\tadpole\%loc%\art

if errorlevel 1 goto ERROR?2

goto PICT2C

:ERROR2

echo.

echo C:\TADPOLE\%loc%\ART does not exist.
echo Please check the spelling of the directory name.
echo.

goto EXIT

:PICT2C

echo.

echo Moving files to CA\TADPOLE\%LOC%\ART...
echo.

copy *.pic c:\tadpole\%loc%\art

del *.pic

c:

cd \tadpole\%loc%\art
:CONVERT

echo.

echo Converting PICT files to BMP...



echo.
for %%p in (*.pic) do c:\tadpole\alchemy %%p -wo -D -f c:\tadpole\bmp16.pal

del *.pic

echo.

echo Now, addfile or check in the .BMP files...

echo.

goto EXIT

:BIGERROR

cls

echo This conversion starts from the server drive, copies ALL the
echo PICT files to the net archive directory, then moves those files
echo to your C: drive in the appropriate \TADPOLE SLM project
echo directory and performs the conversion. Part of the conversion echo

limits the colors of the PICT files to the basic Windows 16 colors. echo.
echo Syntax is:

echo.

echo PREP4PC (location)

echo.

echo (location) is the name of the application subdirectory.
echo For example, the syntax:

echo.

echo PREP4PC calc

echo.

echo would place the final converted file(s) in

echo the C:\TADPOLE\CALC\ART directory.

echo.

:EXIT

set loc=

break off

Importing Art From Microsoft Word for the Macintosh

If you have art that is stored in Word for the Macintosh files, you can import that
art into Word for Windows and use it in your Help file. To convert the art, you
import the Word for the Macintosh document to Windows and then take a screen
shot of the art and save it in Paintbrush as a Windows bitmap.

To import art from a Word for the Macintosh file:

1. Save the Word for the Macintosh file as RTF.

2. Open the RTF file in Word for Windows.

3. Select the picture you want to use in your Help file.

Note

If you are using Word for Windows version 2.0, do not double-click the piece of
art, or Word will convert the picture into an embedded Draw graphic. If that
happens, you will not be able to paste the picture into Paintbrush.



4. Copy the picture to the Clipboard.

5. Open Paintbrush.

6. From the Edit menu, choose Paste.

7. Make any changes you want to the picture.

8. When the art looks the way you want it to, save it as a Windows 16-color
bitmap.

End.
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