
ATTENTION! This SOFTWARE (including the media and printed materials) is
transferred to you on the terms of End-User License Agreement (EULA), NOT SOLD.

Before opening the packet, study the End-User License Agreement (EULA). The opening of
the packet means that you agree with the terms of the EULA.

If you do not agree with any terms of this EULA, then within seven days of buying the
SOFTWARE return the unopened SOFTWARE (with media and documentation) to the
company from which you obtained it.

END-USER LICENSE AGREEMENT FOR THE SOFTWARE

The End-User License Agreement (EULA) for SOFTWARE is the legal agreement between
you (either an individual or a single entity) and ABBYY.

The enclosed document "Proof of Purchase" is part and parcel of this EULA.

The software ("SOFTWARE") distributed by ABBYY is a set of programs, databases and
documentation, protected by copyright laws. For the purposes of this text, "documentation"
means printed material and text files, carrying the description of the SOFTWARE
components, which are the integral part of the SOFTWARE.

1. Subject of EULA

1.1 The subject of this EULA for SOFTWARE is the non-exclusive license on this
SOFTWARE use, transferred by ABBYY to the End-User.

1.2 All items listed below refer both to the SOFTWARE in the whole and to its components in
particular.

2. Copyright

2.1 Exclusive copyright to this SOFTWARE is owned by ABBYY.

2.2 As the End-User you get a license for the use of the SOFTWARE if you accept the
following terms and conditions.

2.3 The license is given exclusively to you (unless there is additional special written
permission on the part of ABBYY).

3. Terms of the SOFTWARE use

3.1 You may use the SOFTWARE at one and the same time only on the number of
processors specified in the "Number of licenses" column in the "Proof of Purchase". You may
not use the SOFTWARE on a larger number of processors at one and the same time. You
may not store (whether installed or not) more copies of the SOFTWARE on than you hold
licenses.

3.2 You may make one backup copy to retain as your SOFTWARE Master Backup Copy for
use only should the original be lost or damaged. The backup copy may not be used for any
other purpose.

3.3 You may create your own databases for programs which are part of the SOFTWARE if
such possibility is mentioned in the documentation.

3.4 If you receive the SOFTWARE on more than one medium, regardless of the type or size
of medium you receive, you may use only one medium that is appropriate to your single
computer. Both media are considered to contain the same copy of the SOFTWARE.

3.5 You may not redistribute the SOFTWARE. Under redistribution of the SOFTWARE we
mean giving access to the third parties to the SOFTWARE components copied by any
company, by network and other ways, or sold, rent or leased.



3.6 You have limitations on the following activities:

3.6.1 You may install and use the Software on, at most, one processor at any given time. If
the software is to be installed on a network, it may be accessed by only one workstation at a
time;

3.6.2 You may not reverse engineer, decompile or disassemble programs, databases and
other SOFTWARE components;

3.6.3 You may not make any changes in the object code of the program or of databases
except those specially provided by the SOFTWARE and described in the documentation;

3.6.4 You may not give copyright on the use of the SOFTWARE or any other rights on the
SOFTWARE to third parties;

3.6.5 You may not do any other actions that violate Russian and international laws on
copyright and software use.

4. Termination

4.1 This EULA for the SOFTWARE comes into effect after the SOFTWARE is installed on the
computer and remains in force during the time you use the SOFTWARE.

4.2 If you fail to comply with the terms and conditions of this EULA, you must destroy all
copies of the SOFTWARE (including printed materials, media (disks), information files,
archive copies of the SOFTWARE), and the agreement is terminated.

5. Responsibility

5.1 Illegal use, redistribution and copying of the SOFTWARE is the breach of the law of
Russian Federation "On the legal software protection" and is sued according to the Law.

5.2 If you fail to comply with the terms and conditions of this EULA, ABBYY immediately
withdraws your right to use the SOFTWARE and cancels its warranties, technical support and
free delivery of the SOFTWARE.

6. Warranty

6.1 ABBYY guarantees the quality of data on media, working capacity of programs enclosed
in the SOFTWARE packet under conditions described in the documentation, conformation of
the SOFTWARE components to the specifications, and the typographical quality of
documentation.

6.2 As for the other components, the SOFTWARE is delivered "as is". ABBYY does not
warrant that the software carries no errors, nor does it take on any liability for consequential
damages, either direct or indirect, including damages caused by possible errors or misprints in
the SOFTWARE package.

6.3 ABBYY makes no guarantees as to the operation of this software in combination of any
other installed software or hardware, especially any models of software or hardware of earlier
release.

6.4 The restricted warranty remains in force during 60 days from the dated of the SOFTWARE
purchase. During this time ABBYY takes all claims to the SOFTWARE quality.

ABBYY (BIT Software).

For letters: P.O. Box 19, Moscow 105568, Russia, ABBYY

Phone no.: +7 095 263-6658, 263-6659.

Fax: +7 095 263 6278.

E-mail: sales@abbyy.com

http://www.abbyy.com



Thank you for choosing FineReader!
FineReader is a powerful tool that saves you time working with
documents. We have been working on this program for many years
and will be happy if it makes your life easier!

 The team of ABBYY (BIT Software)
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We all need to input textual data into computers. This could be text from
newspaper and magazine articles, contracts, business letters, faxes, price lists,
questionnaires, etc. 90% of all the documents we receive are on paper. For years
there was only one way to input printed documents – via the keyboard. Do you
remember the hours you have spent typing text from a document? How wonderful
if the computer could read by itself, straight from the sheet of paper!

Sometimes dreams come true. The FineReader Optical Character Recognition
(OCR) program will allow your computer and scanner to read printed text by
themselves.

But can’t the scanner do the job on its own?

No. The scanner only makes a picture, a photograph of the text. A photograph is a
set of black and white dots, or, in other words, a graphic file, and can’t be edited in
text editors such as MS Word, WordPerfect, Word Pro, etc. You need an OCR
system that will find symbols in the set of black and white dots, “recognize” a
letter in each symbol and turn the image into computer-editable text. Such a
program will create a file that is understandable by text editors and desktop
systems.

So I can now input my document to my computer automatically?

Yes, you can now input your document to your computer automatically without
retyping it on the keyboard.

Enjoy!
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& K D S W H U � �

*HWWLQJ�6WDUWHG
FineReader is an OCR program meant for automatic input of documents in the
computer. The principle of its work is quite simple: you insert a page with text in
the scanner, the scanner makes a picture of the text, after that FineReader
recognizes the image and displays the text file in the text editor. In 30-60 seconds
you will have the necessary text in your text editor, with page layout, color
pictures and tables retained.

+RZ�WR�UHFRJQL]H�WH[W�RU�WDEOH
You have installed FineReader on the computer, and connected a scanner to it.
(Detailed instruction about system installation is given in the Chapter “Installation
and Setup”, p. 22.)

Now you can input text to the computer. (If FineReader is already running,
continue with item 5.)

+RZ�GR�,�LQSXW�WKH�WH[W�RI�D�SDSHU�GRFXPHQW�WR�P\�FRPSXWHU"
1. Switch the scanner on.
2. Switch the computer on.
3. Run FineReader. To do this, from the Start menu, select

Programs/ABBYY FineReader/FineReader 4.0.

Figure 1. Main window of FineReader 4.0.
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You will see the main window of FineReader (Figure 1, p. 12) and the Tips
dialog. This dialog box contains useful information.
After that you will see the Welcome dialog.

4. Insert the “Recognition sample” (you will find it in the end of this book) in the
scanner.

5. Click the Scan&Read Wizard button located in the upper left corner of the
screen.

6. Follow the instructions of Scan&Read Wizard. In several minutes you will
learn how to transform paper document into a file.
The process of document input is very simple and consists of the following
three steps: scanning, marking of blocks and recognition.

7. If you use a flatbed scanner, operation will be accompanied by a sound and
a moving light under the scanner cover.

 If you use an edge-fed scanner, the sheet of paper will start to move, as with
a fax.

 If you use a hand-held scanner, you will need to move it across the sheet of
paper yourself. Click the start-button and move the scanner across the page.
To finish scanning, press any key on the keyboard. (These are tips for the
most of scanners. If you have any problems, read scanner user’s manual.)
Note: If the Scanner parameters dialog box is displayed, make sure that the parameters are set
correctly: resolution – 300 dpi, brightness – middle value, scanning mode – gray); then click the
Scan (or the alike) button in the Scanner parameters dialog.

Figure 2. Recognition in process…
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7. After scanning, the Image window containing a “picture” of the page, will be
displayed. Next, the program automatically starts analyzing the image locating
text, pictures and tables and, finally, recognizes text and tables. During the
recognition, FineReader highlights the recognized part (Figure 2, p. 13).

THAT’S ALL YOU NEED TO DO! THE RESULTS OF FINE READER’S
WORK CAN NOW BE SEEN IN THE “TEXT” WINDOW  (Figure 3).

Figure 3. “Text” window.

Text window is the in-built text editor of FineReader. Here you can edit the
recognized text and check recognition results (Check Results button).

8. You can send recognized text to MS Word, Excel, etc. To do this, click the
arrow to the right of the Save button and from the displayed menu, select Send
to…(MS Word, MS Excel, etc.).

9. Recognition results can be saved onto the disk as well. Click the arrow to the
right of the Save button and from the displayed menu, select Save to File. The
program will suggest saving recognition results in the DOC format. This
format allows saving not only text, but also information about page layout,
pictures and tables.

+RZ�WR�UHFRJQL]H�DQ�LPDJH�ILOH
1. Switch the computer on.

2. Run FineReader. To do this, from the Start menu, select
Programs/ABBYY FineReader/FineReader 4.0.
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3. Next, click the arrow to the right of the Scan&Read button and from the
opened menu select the Open&Read item.

4. Select the necessary drive, folder and graphic file in the Open dialog box. This
can be a file with a TIF, PCX, BMP, DCX or JPEG extension (the full list of
the formats that FineReader loads, is given in Appendix).
For example, open demo.tif (by default it is located in the c:\Program
Files\ABBYY FineReader\Demo folder). In the Image window you will see a
“photograph” of the page. After that the program will start recognizing the
image and in 30-90 seconds you will see the result in the Text window.

5. Now you can send the results to another application or save it on the disk. See
items 8, 9 in the previous section.

+RZ�WR�UHFRJQL]H�IRUPV��DYDLODEOH�LQ�)LQH5HDGHU
3URIHVVLRQDO�DQG�+DQGSULQW�

What is meant by recognizing a form?

Forms recognition means recognition of standardized paper forms, such as
questionnaires, bulletins, or payment documents. Standardized forms are forms
with the alike fields layout.

What do you want to achieve? You have 50, 100 or 10,000 examples of a form.
They contain fields with information, e.g., “Last Name”, “First Name”, “Payment
Sum, in writing”, “Payment Sum, in digits” and so on. You need to input this
information into the database, by reading the value of each field of each form and
recording it in the corresponding field of the database. This way, entries from the
same place on all the forms will be recorded together and in order in the database.

We shall explain how to input forms using the sample forms given at the end of
this manual – “Job Application”. We shall use them in the example that follows.

These forms are typewritten. In real life, forms can be also filled in by hand. It is
FineReader Handprint that is used to recognize forms filled in using
handwriting.

A prepared batch of forms is located in the c:\Program Files\ABBYY
FineReader\Forms\Demo folder, identified with a template name DEMO.FRM .
You will find the description of this file in this chapter.

+RZ�FDQ�,�LQSXW�D�EDWFK�RI�IRUPV"

Prepare the original of your machine-readable form. (You will find three forms
one of which is already filled in at the end of this manual.) We shall take the form
before it is filled in as the original.
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1. Make copies of this original by printing it or using a laser printer, etc. Do not
make alterations in your copy to ensure that the layout of the fields on the
copies coincides exactly with the disposition of the fields on the original.

2. Fill in the forms.

3. Run FineReader 4.0 Forms, selecting Programs/ABBYY FineReader 4.0
Forms from the Start menu.

You will see the Batch of Forms dialog (Figure 4).

Figure 4. “Batch of forms” dialog.

4. Select the Create a new batch of forms item and click HD.

5. In the New Batch Name (Figure 5) dialog box, specify the batch name and the
path to the batch files; then click Next.

Figure 5. “New Batch Name” dialog.
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Figure 6. Form Template dialog.

In the Form Template (Figure 6) dialog, set the switch in the Create a new
template position. Click Next and you will see the Template Image dialog (Figure
7).

Figure 7. Specify the nature of the template image.

In the Template Image dialog (Figure 7), indicate the nature of the template image.
Select Scan. Now we shall use the first of the forms which is not filled-in. Insert
the page into the scanner and click Next.
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Figure 8. Form image in the “Template Editor” dialog.

After scanning you will see the scanned image of the original form in the Template
Editor dialog (Figure 8). The Properties dialog will be also displayed.

&UHDWLQJ�WKH�IRUP�WHPSODWH
1. From the Template menu, select Create Form Template Automatically.

Black squares in the corners of the form will be marked as blocks of Black
Square type. All the rest objects on the form will be marked as Static Text.

$WWHQWLRQ��Do not delete static text and black squares, since they are used for
correct template matching.

2. On the Default Settings tab of the Properties dialog (Figure 9��j� 19) change
the following parameters: language – English, text type – typewriter, clean
block – yes.
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Figure 9. “Default Settings” tab of the “Properties” dialog.

3. Now you need to “draw” text fields that will contain text to be recognized.
One of the fields you need to recognize in the example is the “Last name”
field. Place the mouse pointer on the image in the upper left corner of the
“Last name” field. Click the mouse and drag to the right bottom corner until
the whole field is enclosed. Release the mouse button. A block (a rectangle
with a green frame) will appear on the image. This is the text field.
Note. Everything included in blocks with green frame will be recognized. For this reason, you
should not enclose the name of the field and other explanatory lines in a block. In this case, do
not include the “Last name” title in the block. The block must enclose only the part of the page
that contains the value of the field (the filled-in part).

If you need to set the margins of the recognized area more precisely, size the
block or move its frame with the mouse. If you make a mistake while marking
blocks, you can delete the active block by pressing DEL.

4. Now you need to specify the field in the database to which the recognition
results of the current field should be exported. Enter “Lastname” in the
Database Field box.
Note: If the database already exists, then select the necessary value in the Database field. If you
haven’t created a database yet, then naming the database fields bear in mind the naming
restrictions of the format you are planning to use for export, e.g., use of long names and
additional characters. You will have no problems in any format if you use only Latin letters and
give names not longer than 8 characters.

5. Repeat these operations for all text fields of the form: “First Name”, “Month
of Birth”, “Town”, “Street”, “House”, “Apartment”, “Series”, “Issued”,
“Date”, giving each of them appropriate names in the data base.

Repeat these operations for all digit fields on the form: “Index”, “Zip code”,
“Phone number”, “Day of Birth”, “Year of Birth”, “Date”, specifying
appropriate fields in the database for them. In contrast to text fields, deselect
the Default Settings checkbox and choose Digits in the Language list.

6. Select “Male (M)” and “Female (F)” in two check boxes and then “draw” a
block that will enclose both of them as one radio group “Sex”.
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7. In the upper part of the template there are checkboxes (“squares”) “Done” and
“History” that were automatically marked as static text. Now you need to
change their type to Checkboxes. To do this, holding the SHIFT key, click
these blocks one after another with the mouse. After that click the right
mouse button on one of these blocks and from the local menu select Block
Type, and then – Checkbox.

8. The electronic template of the form is now ready. Click Close.

 The batch window will be displayed.

9. Working with a batch involves a number of sequential or parallel operations:
scanning, recognition, editing and export of recognition results.

6FDQQLQJ

Prepare the completed forms for scanning (in our example there are two completed
forms) and click the Scan button on the toolbar.

$WWHQWLRQ� All images in the batch must have the same resolution as the form
template.

For each scanned form, a new icon will appear in the batch window, and a special
mark will appear in the Image column. These images are only pictures of the forms
and cannot be edited.

5HFRJQLWLRQ

After you have scanned all the forms, you can start recognizing them. Click the
arrow to the right of the Recognize button and from the local menu select
Recognize All Pages.

The program will start recognition. A special mark will appear in the Text column
for each form which is recognized.

(GLWLQJ

To view and edit (if necessary) the recognition results, double-click the icon of the
form in the Batch window.

In the right part of the screen you will see the Editor window with the recognized
form, and in the bottom part, the enlarged image of the form.

To move between batch pages use  and  buttons.

([SRUW

To export the recognition results to a file, click the arrow to the right of the Save
button and from the displayed menu select Export to File... Select the disk and
folder to save recognition results and name the file. Then click the Save button.
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THAT’S ALL YOU NEED TO DO! THE RECOGNIZED FORM IS IN THE
TXT FILE .

Of course, the TXT format is not the only one. You can save recognition results in
the DBF, CSV or XLS formats.

In FineReader Handprint, you can also export data via ODBC to a database, e.g.,
to MS Access.

1HWZRUN�SURFHVVLQJ

If you have several computers in the network, you can do all procedures described
above at different computers at the same time. For details, see “Batch processing
in the network”, p. 52.
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& K D S W H U � �

,QVWDOODWLRQ�DQG�6HWXS

6RIWZDUH�DQG�KDUGZDUH�UHTXLUHPHQWV
What you will need to install FineReader 4.0:

• A computer with an Intel 486 processor or higher (Pentium 133 or higher is
recommended).

• One of the following operating systems: Windows 95, (Pan-European version
is recommended), Windows 98, Windows NT 4.0 (Service Pack 3).

• 16 Mb of RAM for Windows 95, 98; 32 Mb for Windows NT.

• 30 Mb of free space on the hard disk for minimal configuration and about
60 Mb for maximal configuration.

• A TWAIN-compatible scanner or analogous device.

• A mouse or other pointing device.

• A CD-drive.

,QVWDOOLQJ�)LQH5HDGHU
FineReader takes you through installation with onscreen instructions at every step.
For best results, do not run any other programs (e.g., MS Outlook, MS Word, etc.)
during installation.

$WWHQWLRQ� If you want to use user dictionaries and patterns from the previous
versions of the program, do not deinstall it before you have installed the new
version. Having installed the new version, you can use patterns and dictionaries of
the previous version. For details see Appendix, “Using user dictionaries and
patterns from FineReader 3.0”.

1. Insert the CD-ROM in the CD-drive.

2. Click Start on the Taskbar and choose Settings/Control Panel.

3. Double-click Add/Remove Programs.

4. Select the Install/Uninstall tab and click Install...

5. Follow the onscreen instructions.
Note: Items 2-4 are equal to running the install.exe.



Installation and setup

FineReader 4.0. User’s Guide. 23

,I�WKHUH�DUH�SUREOHPV�GXULQJ�LQVWDOODWLRQ

In rare cases problems can arise during installation because of incompatibility
between different software components.

If the program displays an error message, see the Readme.hlp for
recommendations helpful in most cases.

6WDUWLQJ�)LQH5HDGHU
If you are planning to scan, make sure that your scanner is attached to your
computer, turned on* and working, before you start FineReader. If you have not
connected a scanner yet, read the User’s Guide which comes with the scanner to
connect it.

If you do not have a scanner, you can see how FineReader works on the demo.tif,
which you will find in the c:\Program Files\ABBYY FineReader\Demo folder. For
more information about the work with graphic files see “How do I input the text of
a paper document to my computer?”, p. 12.

7R�VWDUW�)LQH5HDGHU�

• Click Start button on the Taskbar and choose Programs/ABBYY
FineReader/FineReader 4.0.

:RUNLQJ�ZLWK�D�VFDQQHU

,PSRUWDQW��To connect a scanner correctly, read the user’s manual of the scanner.
Connecting the scanner, do not forget to install all software bundled (TWAIN
driver and/or scanning program).

 To start scanning, prepare everything for scanning and click Scan.

 Your scanner should start working immediately, and in 20 seconds you will
see a “photograph” of the scanned page on the screen.

 Now you can go onto the section entitled “How do I input the text of a paper
document to my computer?”, p. 12.

 If the scanner doesn’t start working, you will see the scanner parameters dialog
box.

Note: Different scanners have different interfaces. Scanner manager dialog, (a built-in TWAIN
interface of scanner), is developed by the scanner manufacturer. That is why it is different for
different scanners and not always friendly and intuitive.

                                                          

*  If your scanner has a separate power source, turn your scanner on before you turn
your computer on.
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 Now check the scanning parameters. If you have never worked with a scanner
before, remember that scanners have THREE MAIN PARAMETERS, which
influence the quality of the scanned image. These are resolution, brightness and
scanning mode (image type).

 7R�VHW�WKH�VFDQQLQJ�SDUDPHWHUV�FRUUHFWO\�

• Resolution – select 300 dpi.
Note: Some TWAIN-interfaces (e.g., HP PictureScan) do not allow to set OCR resolution other
than 300 dpi.

• Brightness (can be also called threshold or pictured with the “sun” icon or
black-&-white circle, etc.) – select middle value (50%).

• Scan mode – select gray (256 colors)*.

After setting parameters, click Scan (this button can be called in some other way,
e.g., Final) to start your scanner.

If you use a flatbed scanner, operation will be accompanied by a sound and a
moving light under the scanner cover.

If you use an edge-fed scanner, the sheet of paper will start to move, as with a
fax.

If you use a hand-held scanner, you will need to move it across the sheet of
paper yourself. Click the start-button and move the scanner across the page. To
finish scanning, press any key on the keyboard.

After the scanning is over, in the Image window of FineReader you will see the
“photograph” of the scanned page.

If you have any questions, read scanner’s user manual.

&KHFNLQJ�WKH�VFDQQHG�LPDJH�SURSHUWLHV
You can check the properties of the scanned image. To do this, click the right
mouse button on the image and from the displayed local menu select Properties...
If you have followed all recommendations of the given manual, it must have the
following properties: image type – gray (see above), resolution – 300 dpi.
These values are the most common values for recognition.

,I�\RX�KDYHQsW�ERXJKW�D�VFDQQHU�\HWg
If you are just going to buy a scanner, choose a TWAIN-compatible one. TWAIN
is a standard protocol supported by the most scanner manufacturers and guarantees
a normal work of scanners with FineReader.

                                                          

*  For all scanners except hand-held. For hand-held scanners – black-&-white (Line
Art, OCR, Text)
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Note: Unfortunately, with the most of scanners you can get satisfactory scanning results only
when using Show TWAIN-driver dialog. When this option is switched off, some TWAIN-drivers
may not allow to set brightness and/or paper size manually.

You can view the list of FineReader-compatible scanners in the readme.hlp file or
on the web-page of ABBYY (www.abbyy.com).

,I�\RXU�VFDQQHU�GRHVQsW�ZRUN�ZLWK�)LQH5HDGHU
If your scanner doesn’t work with FineReader, try the following:
1. Get a new version of the driver from scanner distributor or via the Internet.

Note: If you do not know the address of the manufacturer of your scanner, address to the
TWAIN organization committee: www.twain.org. Besides there exist independent TWAIN-
drivers manufacturers for the most of popular models, e.g., CFM (www.cfm.de)

2. Go to web-page of ABBYY: http://www.abbyy.com. Perhaps you will find
there the new config file for your scanner.

3. Write to technical support service of ABBYY: support@abbyy.com.
4. If you can’t get a new version of the scanner driver, try the following

“emergency” mode. Scan the necessary images with the scanning software,
save them in the format supported in FineReader (TIFF, BMP, JPEG, PCX,
DCX*) and open these images in FineReader.
Note. You can assemble a batch automatically. To do this, put images in the batch folder. The
names of the images to be assembled to the batch must consist of the batch name and the 4-digit
number. To update pages in the Batch window, press F5.

:KHUH�WR�JR�IURP�KHUH
After you have installed FineReader 4.0, and your scanner has started working, go
to “Getting Started” chapter, where you will find instructions how to get the
necessary result quickly.

You can learn to work with the program in the interactive mode, running
Scan&Read Wizard. The Wizard will help you to learn the basics of scanning and
recognition. Read the messages and follow the Wizard’s instructions. Good luck!

                                                          

*  The list of supported formats is given in Appendix.
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& K D S W H U � �

)LQH5HDGHU�����w�DQ�2YHUYLHZ
FineReader is an omnifont OCR (Optical Character Recognition) system. This
means that without preliminary training it can deal with texts of practically any
quality, printed with any font.

FineReader is extremely tolerant of printing defects. This is a result of a special
technology called “fontain image transformation”.

This chapter gives an overview of the features of FineReader 4.0 Standard,
Professional and Handprint.

)LQH5HDGHU�����6WDQGDUG�IHDWXUHV
• FineReader allows you to input texts 5-10 times faster than a professional

typist and with many fewer mistakes.

• To input an image in the computer, insert a document in the scanner and click
Scan&Read. In 30-90 seconds you will see the recognized text in the Editor
window.

• The Scan&Read Wizard is the way to get the results quickly, without going
into program details.

• FineReader allows to recognize and edit recognized text on one and the same
computer simultaneously.

• Support of drag-&-drop.
• Support of MMX.
• Integration with Lingvo 4.5 and greater.

6FDQQLQJ�DQG�PDUNLQJ�RI�EORFNV

• Work with all scanners that support the TWAIN protocol.

• Automatic brightness setting – for getting the best results when scanning light
and dark parts of the page.

• Automatic and manual segmentation of tables.
• Scanning and saving colored pictures.

:RUN�ZLWK�LPDJHV

• Automatic detection of orientation of the page under recognition and rotation
of the page into normal position.

• Cleaning of images.
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• Rotation of images to 90, 180 and 270 grades.

• Automatic inversion of dark blocks with light text.

5HFRJQLWLRQ

• Recognition of Russian, English, French, German, Spanish, Italian, Swedish
and other texts, including texts where any combinations of the supported
languages occur. The list of supported languages is given in Appendix (p. 57).

• Recognition of multi-column text with pictures and tables; saving layout of
recognized page.

• Recognition of blocks with light text on the dark background.

• Recognition of color images.

• The program can be trained to recognize new characters.

(GLWLQJ�DQG�H[SRUW

• Built-in text editor allows you to change font and size, and the formatting of
text and paragraphs, etc.

• The built-in spell-checking system allows you to add new words to the system
dictionary. For Bulgarian, Czech, Danish, Dutch (Standard, Belgian), English,
Estonian, Finnish, French, German, Greek, Italian, Norwegian (Bokmal,
Nynorsk), Polish, Portuguese (Standard, Brazilian), Russian, Spanish,
Swedish, Tartar*, Turkish, Ukrainian.

• Automatic creation of different paragraph styles for text with different shape
and size of font.

• Work with Internet – saving recognition results in HTML format.

• Recognition results can be sent to another application (e.g., MS Word 6.0, MS
Word 95, MS Word 97, MS Excel 6.0, MS Excel 95, MS Excel 97, Word
Pro 97, WordPerfect 7.0, WordPerfect 8.0, Stylus 3.0, PROMT 98) without
saving them to the disk.

)LQH5HDGHU�����3URIHVVLRQDO�IHDWXUHV
• All features of FineReader 4.0 Standard (see above).

• Network processing of documents to increase considerably the speed of
processing large documents (when there are licenses for several working
stations).

                                                          

*  Tartar is in the special delivery.
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• Recognition of forms using a template: bulk input of standardized information
into information systems.

• Matching of template using reference points.
• Template designer, which allows recognition of different forms.

• Recognition of texts in unsupported languages.

• Recognition of bar-codes (Check Code 39, Check Interleaved 25, Code 128,
Code 39, EAN 13, EAN 8, Interleaved 25).

• Automatic compensation for scanning skew when matching template.

)LQH5HDGHU�����+DQGSULQW�IHDWXUHV
• All features of FineReader 4.0 Professional (see above).

• Recognition of block hand-printed characters: for Russian, English, German
and Ukrainian.

• Automatic template matching when recognizing non-sorted pile of forms in a
batch.

• Export of images into databases.

• Automatic check of recognition results with regular expressions, validation
rules and checks against database.

• Export to databases via ODBC.
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& K D S W H U � �

:RUNLQJ�ZLWK�)LQH5HDGHU����
This chapter tells about the main features of FineReader 4.0. For more detailed
information and step-by-step instructions, see on-line help.

0DLQ�ZLQGRZ

When the program is run, a new batch is open by default, into which scanning and
recognition results are placed. Each scanned image is represented as a separate
page in the batch. You can see the following working windrows in the Main
window: Batch, Image, Text and Zoom (Figure 10).

Figure 10. Main window of FineReader 4.0.

In the upper part of the window you can see toolbars. To hide or display the
toolbars, use View > Toolbars menu or local menu. To open the local menu
(Figure 11, p. 30), click the right mouse button on one of the toolbars. The
toolbars that can be seen on the screen are marked with the checkmark. The Edit
toolbar is switched off by default (it is not displayed on the screen). Select the
toolbar you want to hide or display.
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7RROEDUV

Figure 11. Local menu with the list of toolbars. The checked toolbars are
those that are displayed on the program screen. The “Edit” toolbar is
switched off.

0DLQ�WRROEDU�w�6FDQ	5HDG

The Scan&Read toolbar (Figure 12) contains buttons that carry out the main
operations of the program. The numbers on the buttons show the order of
operations to get an electronic version of the paper document: 1 – Scanning, 2 –
Marking of blocks, 3 – Recognition, 4 – Checking results and 5 – Export.

The leftmost button Scan/Open&Read (Wizard) can carry out scanning, marking
of blocks and recognition (in the Scan&Read mode – for paper documents) or
marking of blocks and recognition (in the Open&Read mode – for electronic
images). This button can also work in the Scan&Read Wizard mode, that will
teach you to work with the OCR program.

Figure 12. “Scan&Read” toolbar.

The mode of Mark Blocks and Recognize buttons depends on what window is
active and also whether the Batch window has some pages selected.

If the Image window is active, the buttons process the open page.

If there are no images open and at least one page is selected in the Batch window,
the buttons process selected images.

Note: The button mode different from the default mode can be set manually. Click the arrow to
the right of the button and you will see the menu. On the picture (Figure 12) you can see the
open menu for the 2 – Mark Blocks button. One of the menu items is formatted in bold. This
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command will be run when you click the button. When you select another menu item, the
corresponding operation is carried out.

6WDQGDUG�WRROEDU

The Standard toolbar (Figure 13) has the following buttons: five standard buttons
(new, open, cut, copy, paste), buttons to move up and down in the batch (to the
next and previous pages), buttons to rotate and clean images and a Help-mode
button.

Clicking the button operates on the open image or images selected in the Batch
window. When you click the Help Mode button, the mouse pointer works in the
following way: click on an object (button or menu item) and you get brief help (the
shape of the mouse pointer in this mode is an arrow with the question mark).

&RS\

1HZ

2SHQ

&XW

3DVWH

1H[W

SDJH

3UHYLRXV�SDJH 5RWDWH�FORFNZLVH

&OHDQ�LPDJH

+HOS�PRGH

5RWDWH

FRXQWHU�FORFNZLVH

,PDJH�RU�WH[W

VFDOH

Figure 13. “Standard” toolbar.

6WUXFWXUH�RI�WKH�EDWFK
When the program is run, a new batch is open by default. A batch is a kind of
folder where scanned and recognized pages are assembled. You can save separate
pages of the batch or the whole batch. In the Batch window you can see the list of
pages of the current batch. To view a page, double-click its icon or its number.
You will see files that the page has: text and/or image in the Text and/or Image
windows, respectively.

Pages in the batch are selected in the same way as files in Explorer: with the
mouse click (or with keys). For details see “Selecting pages”, p. 33.
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+RZ�WKH�%DWFK�ZLQGRZ�ORRNV

By default the batch window is docked to the left edge of the Main window and
pages are showed with large icons (Figure 14).

Figure 14. Batch window in the docking view with large icons for pages
(default view).

If you want to move the Batch window, you can undock it (click the right mouse
button inside the window and from the local menu, deselect Docking view).

The Batch widow can also display information about the operations carried out for
this or that page: whether it was recognized, edited, exported, whether there was
an error during its recognition, etc. To get information about the batch pages, there
is a special view with parameters (Figure 15). To get the necessary view, from the
local menu, select Display page parameters.

Figure 15. Batch window. The view with parameters. The components of the
pages are marked with bullets (image, blocks, text, etc.).
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&RQYHQWLRQDO�6LJQV�IRU�3DJHV

A page in a batch can have:

A graphic file (scanned and saved image). This type of page is indicated by a
yellow icon (if the view without parameters is selected).

A text file (recognized text). This type of page is indicated by a white (or blue)
icon. A page can be exclusively a text file if the image of the page was deleted
after recognition (if the view without parameters is selected).

Both graphic and text files. This type of page is indicated by two overlapping
icons – yellow and white (if the view without parameters is selected).

1XPEHULQJ�RI�EDWFK�SDJHV

One batch may contain up to 9999 pages. You can see the page number near the
conventional sign for the page in the Batch window (see above) and in the heading
of the window where the page files are opened, for example, “Image – 5”, “Text –
5”.

:RUNLQJ�ZLWK�EDWFK�SDJHV

6HOHFWLQJ�SDJHV

The batch supports multiple selection of pages. This means that you can select
many consecutive or non-consecutive pages at the same time.

To select a number of consecutive pages, click the mouse on the first page.
Holding the SHIFT key, click the last page of the selection.

To select a number of non-consecutive pages, click them with the mouse holding
the CTRL key.

To select all pages of the batch, activate the Batch window and from the Edit
menu choose Select All…

Note: 1. What Select All command does depends on what window is active – Batch, Image or
Text: this command selects pages in the active batch, all blocks on the image, all text in the text
editor.
2. It is more convenient to select several pages when the Batch window is displayed with
parameters (local menu, Display Page Properties item).

:RUNLQJ�ZLWK�LPDJHV
The working mechanism of the Mark Blocks and Recognize buttons is described in
the “Main toolbar – Scan&Read” section, p. 30.
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As for rotation, inversion, cleaning, these operations are carried out for an active
window. If the Batch window is active, the command is carried out for the pages
selected in the window.

:RUNLQJ�ZLWK�WH[W

Operations with the recognition results (search, spell-check, etc.) are carried out
for the active page of the batch. If none of the pages is open, the operation is
carried out for the first page of the selection. Then the program prompts to
continue.

For details see on-line help.

6FDQQLQJ
Recognition accuracy depends to a great extent on the quality of the scanned
image. This section will help you to distinguish between “good” and “bad” texts
and to learn how to set scanner options to get the most of the system.

*RRG�DQG�EDG�WH[WV

t*RRGu�7H[WV

Good quality texts have very few torn, stuck together, smudged or distorted
characters. A human reader doesn’t have to make a special visual effort to read
such texts.

Examples: the Guide you are now reading; texts, printed on a laser printer; nearly
all modern magazines; nearly all colored print production.

t%DGu�7H[WV

“Bad” texts are difficult to read because of low contrast, i.e. insufficient difference
between black and white areas. Such texts may be either too dark or too light.

Examples: text from a dot-matrix printer in draft mode, with a worn-out ribbon; a
typewriter carbon copy; text from a typewriter with a worn-out ribbon; any texts
with characters which are distorted, torn, or stuck together (Figure 16, p. 35).
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Letters stuck together Torn letters

Distorted and smudged letters

Figure 16. Samples of poor quality text. To improve the recognition quality of
the text, try to set scanning brightness correctly. Increase brightness (make
the image lighter) for distorted, smudged and stuck together letters, and
decrease it (make the image darker) for torn letters.

6FDQQLQJ�IRU�D�JRRG�LPDJH

When you run FineReader for the first time, the default scanning parameters are
set automatically. They are gray (256 colors*) image type, medium level of
brightness and 300 dpi resolution.

Sometimes you may need to change these parameters. e.g., if you want to save
color pictures in the output text, then choose color scanning mode. To scan texts
printed with small fonts (8-th point and smaller), set 400 to 600 dpi. In these cases
the default parameters are not suitable for you and you have to set them manually.

7R�VHW�VFDQQLQJ�SDUDPHWHUV�

1. From the Tools menu, select Scanner Parameters…

2. In the displayed dialog set the necessary options.
Note: If on the Scanning tab of the Options dialog (Tools>Options…) you have Show TWAIN-
driver dialog selected, then you will be able to use the TWAIN dialog of your scanner to set
scanning parameters. This dialog and the options must be described in the scanner
documentation. For some models of scanners the Show TWAIN-drive dialog... is off by default.
Anyway, it is you who decide whether to display the TWAIN-driver dialog. Each scanning mode
(with TWAIN-driver dialog and without it) has its own advantages. Thus, for instance, if you
check the Show TWAIN-driver dialog..., box, as a rule you are able to preview the scanned
image, and set scanning height and width, brightness, contrast. When you do not use the
TWAIN-driver dialog, you can set scanning options from FineReader’s dialog. When you scan

                                                          

*  Actually, 16 grades is enough, but not all scanner drivers support this feature.
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without TWAIN you can save scanning options for the batch, scan in cycle with the set pause,
etc.

&OHDQLQJ�WKH�,PDJH

If you can’t get rid of “garbage” or a dirty background on the image, in spite of
following the scanning instructions, you can clean the image. To do this click the

 button. But do not use this option excessively, since as a result of cleaning of
the image, dots, commas and thin elements of letters may disappear that will
inevitably lead to poor recognition quality.

6FDQQLQJ�PXOWL�SDJH�GRFXPHQWV

To scan a large number of pages, it is convenient to use the automatic document
feeder (ADF). Of course it is convenient when you have separate (not bounded)
pages. If you want to scan a book using an ADF, then you would have to unbound
it.

To make the scanner take pages from the ADF bed, in the Scanner Parameters
dialog (Tools>Scanner Parameters…) select the Use Automatic Document Feeder
checkbox. Or, if you work with TWAIN dialog, select the MultiPage mode.
If by this or that reason you can’t use an ADF mechanism, you can scan in the
following way: after a page is scanned, the scanner makes a pause (you specify its
length in options), during which you insert the next page in the scanner. Then the
scanning continues automatically.

You only need to set the pause length. In the Scanner Parameters dialog (Tools>
Scanner Parameters…) select the Pause Between Pages checkbox. Then enter the
necessary value (in seconds). This is the time that will pass between processing of
two pages.

1XPEHULQJ�SDJHV

When you start scanning, the system prompts you to specify the numbering mode
of the scanned pages (Figure 17, p. 36).

Figure 17. Choose the numbering mode of scanned pages.
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In the Page Number dialog enter the number of the first scanned page. The pages
can be numbered in an ascending or descending order. They can also be
consecutive or non-consecutive (only even or only odd) numbers. If, for instance,
you are scanning a pile of two-sided pages (the pages where the text is printed on
both sides) sorted by number using an ADF mechanism, we advise you to scan all
pages first from one side, and then from the other side. In this case you should
select only odd- or even-numbering. Whether to select ascending or descending
order depends on how you place the pile in the ADF bed – starting from larger or
smaller numbers.

$GGLQJ�LPDJHV�WR�WKH�EDWFK

1. To add image files to the batch, click .
2. In the Open dialog, select one or more images that will be added to the current

batch.
Note: In this dialog you can simultaneously select several files. Hold the SHIFT key – to select a
number of consecutive files, or CTRL – to select non-consecutive files.

You may move the files to the batch when opening them (in the Open dialog check
the Move files to batch checkbox).

:KDW�KDSSHQV�ZLWK�FRORU�RU�JUD\�LPDJH�ZKHQ�LW�LV�RSHQHG�LQ�)LQH5HDGHU

$ERXW�FRORU�DQG�JUD\�LPDJHV

When FineReader opens color and gray images, it creates a black-&-white copy
that is recognized. That is why when you edit the recognized text of a color or gray
page, in the Zoom window you can see its black-&-white copy.

+RZ�WR�VDYH�EODFN�	�ZKLWH�LPDJH�LQVWHDG�RI�JUD\�RU�FRORUHG�LPDJH
To save disk space, you can save color or gray images as black-&-white. To do
this, check Store only black-&-white images in the batch (Tools>Options…>
Scanning tab). Then when loading or adding color or gray image to the batch
FineReader will save it in black-&-white.

,QFRUUHFW�UHVROXWLRQ�PHVVDJH
Sometimes, when loading the image whose resolution is less than 100 dpi or
greater than 800 dpi, the program will suggest you to change the resolution to a
one more appropriate for recognition.
These are the reasons why such images occur:
• There are image formats (e.g., BMP), whose resolution can be read

differently.
• Non-standard image format.
• Incorrect scanning options.
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• For the majority of hand-held scanners the real scanning resolution for gray
and color images is not 300, 400 dpi as specified, but much less (75-100 dpi).

Depending on the origin of the image, you may change image resolution or leave it
unchanged.

Bear in mind that incorrect image resolution may lead to the following:

• The program will not be able to mark blocks on the image.

• The program will detect the font size incorrectly.

3DJH�DQDO\VLV��PDUNLQJ�RI�EORFNV�
Before the recognition, the program must “know” what parts of the image should
be recognized. For this, the program analyzes the image and marks blocks as text,
pictures and tables. A page can be analyzed both automatically and manually.
FineReader can successfully analyze pages with compound text layout. To analyze
an image, click the Mark Blocks button on the Scan&Read toolbar. To learn how
this button works, see “Main toolbar – Scan&Read”, p. 30.

&UHDWH�WH[W

EORFN

$GG�D�SDUW�RI

EORFN

'HOHWH�D�SDUW�RI

EORFN

0RYH�EORFNV

5HQXPEHU�EORFNV

$GG�YHUWLFDO

OLQH

$GG�KRUL]RQWDO

OLQH

'HOHWH�OLQH

'HOHWH�EORFNV

Figure 18. Tools toolbar.

To edit results of automatic page analysis, use the necessary tools (Figure 18,
p. 38).

7R�PDUN�RXW�DQG�HGLW�EORFNV�PDQXDOO\

To mark out a block, select the  tool (it is selected by default) and click in the
upper left corner of the block you want to mark out. Drag diagonally until the
frame encloses the necessary part of the image. Release the mouse button. The
selected part of the image will be enclosed in the frame. It is a text block by
default, i.e. it will be recognized.
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According to the image enclosed, a block can be of the following type: picture,
table, bar-code* or text not for recognition.

To change the block type, click the block with the right mouse button and from
the displayed menu select Block Type, and then the necessary type.

To change block’s size, place the mouse pointer on the block’s frame, until it
takes the shape of the two-headed arrow; then click on the block frame and drag.

0DUNLQJ�RI�EORFNV�RQ�WKH�SDUW�RI�D�SDJH�DXWRPDWLFDOO\

To mark blocks on a part of a page, select it with a mouse (as when selecting a
new block), holding the CTRL key. The selected part will by analyzed
automatically.

You can also mark the block with the mouse in a usual way and then select
Analyze Block from the local menu.

6SHFLI\LQJ�WDEOH�VWUXFWXUH

When the system marks blocks on the page, it automatically finds any tables and
analyzes them (i.e. marks out cells). For accurate recognition of a large number of
tables of a single type, you should set their specific features:

<RX�FDQ�VSHFLI\�WKH�IROORZLQJ�

• Whether the table is “regular” or not.

• Whether the table is linear or not.

• Whether division into cells coincide with black lines in the original image.

Table B (see below) is “regular”. The black lines in such a table cross the whole
table (in contrast to table A – an “irregular” one).

Table A (see below) is linear, since it contains cells with one line of text each.
Table B is non-linear, since it contains cells with more than one line of text.

Temperature

Celsius Kelvin

-273 0

100 373

Table A. Linear, irregular

                                                          

*  Only in FineReader 4.0 Professional and Handprint.
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Celsius

Boiling point
of water

100

Freezing point
of water

0

Table B. Non-linear, regular.

Linear tables may have no black lines – vertical or horizontal (Table C).

Kilometers Miles

1 0.62

5 3.1

10 6.2

Table C. Linear table without black lines.

7R�VSHFLI\�WKH�VWUXFWXUH�W\SH�RI�WKH�WDEOH�

1. From the Tools menu select Options…

2. On the Page Analysis tab of the Options dialog select the necessary
checkboxes in the Tables group.

,PSRUWDQW�

1. The table structure should be specified in system options before recognition.
2. Incorrect specification of the table structure can affect segmentation quality.
3. If you want to perform a bulk input of tables of different structure, select no
items in the Tables group of the Page Analysis tab (Options dialog box).

(GLWLQJ�WDEOH�EORFNV

:KDW�WDEOHV�VKRXOG�EH�DQDO\]HG�PDQXDOO\

If a table does not have black horizontal lines, has more than one line of text per
cell (i.e. is not “linear”) and has equal intervals between lines (Figure 19, p. 41) it
is better to analyze such a table manually.

You should enclose such a table in a separate block and mark it as a Table; then
add vertical and horizontal lines with the help of buttons on the Tools toolbar
(Figure 18, p. 38).
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1. Jim 1990.
Johnson

2. Mary 1996.
Lay

3. Boris 1997.
Namin

Figure 19. A table requiring manual analysis. The table is non-linear and has
no horizontal lines.

You can also analyze the table block automatically (click the right mouse button
on the block with a table and from the displayed menu select Analyze Table), and
then edit the result manually.

7R�DQDO\]H�D�WDEOH�PDQXDOO\�
1. Activate the Image window, clicking it with the mouse.
2. If the table in the window is too small, increase the scale. To do this, click the

right mouse button in the Image window and from the displayed menu select
Scale and then the necessary item.

3. If the table is not marked out, mark it with the mouse (see “To mark out and
edit blocks manually”, p. 38).

4. Then use the following tools:

Add a vertical line

Add a horizontal line

Delete a line
Note: 1. To delete a line in the table, you can also move it until it coincides with the table frame.
2. To change the direction of the line you are adding to the table (from vertical to horizontal
direction and vice versa), press the SHIFT key.

5. When adding or deleting of lines is over, click  or press ESC to return the
mouse pointer to the normal mode.

6. You can also merge or divide table cells (Edit>Merge table cells and Divide
table cells, respectively).
Note: To select several cells, use the mouse (or right-left arrow) and the SHIFT key.
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5HFRJQLWLRQ
The task of recognition is to transform the input (scanned) image into text. To put
it another way, to replace the image of each input character with its computer
code.

Before you start recognition, make sure you have set appropriate recognition
parameters on the Recognition toolbar (Figure 20): language of recognition and
text type.

/DQJXDJH�RI

5HFRJQLWLRQ
7H[W�7\SH

Figure 20. Recognition toolbar.

/DQJXDJH�RI�UHFRJQLWLRQ

• To recognize English, Spanish, Italian, German, Russian, English-Russian,
Ukrainian, French, Swedish, Danish and Dutch texts, Polish, Finnish and
Norwegian texts and also texts consisting of Arabian digits, select the
language in the list on the Recognition toolbar.

 

Figure 21. “Language of Recognition” dialog. Selecting languages for
recognition of English-German texts.

• To recognize other languages and language combinations, select the Other…
value and go on with the next item.
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You will see the Language of recognition dialog (Figure 21), where you can
select several languages, whose words can occur in your text.

After you have clicked OK in this dialog you will see the combination of the
languages you have chosen on the Recognition toolbar (Figure 22).

Figure 22. Recognition language list. Combination of languages for
recognition of English-German texts.

7H[W�W\SH

Texts printed on a matrix printer in draft mode or on a typewriter have specific
features (see pictures below) in comparison with the standard typeset characters.
Symbols printed on a matrix printer consist of separate dots (Figure 24, p. 43).
Typewritten symbols (Figure 25, p. 43), have almost identical width.

For the majority of texts, text type is detected automatically: the Automatic line is
selected in the Text type list (Figure 23, p. 43). As for typewritten and matrix
printer texts, to increase the recognition quality of such texts, select a special value
in the Text Type list – Typewriter or Matrix Printer, respectively.

Figure 23. “Automatic” line selected in the “Text type” list.

Figure 24. Fragment of a page, printed on a matrix printer in draft mode.
You can see that the letters consist of separate dots.

Figure 25. Fragment of a typewritten page.

6DYLQJ�SDJH�OD\RXW�DQG�GRFXPHQW�IRUPDWWLQJ

Before recognition you should specify how you want to save the recognition
results: i.e. whether to save font formatting, text and picture layout on the page.
Options of text formatting and page layout are specified on the Formatting tab of
the Options dialog (Tools>Options...).
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• If you need only text and do not worry about its layout or formatting (e.g., you
want to insert it in another text), then select the Remove formatting option.

• If you would like to save lines breaks and first line indents, select Use spaces
to show formatting.

• If you are not interested in line indents but would like to save font formatting,
select Save letters shape and font.

• If you want to save page layout and font formatting completely, select Save
formatting with frames. This option will allow you to get a result closest to the
original.

• But frames (look above) can complicate editing. That is why if you are
planning to edit the result in your text editor, select the saving mode that is
most convenient for editing Save letters shape, font and columns. Frames will
be mostly used for pictures.

6DYLQJ�SLFWXUHV�LQ�WKH�UHFRJQL]HG�WH[W

To save pictures in the recognized text, on the Formatting tab of the Options
dialog (Tools>Options...) select the Save Pictures checkboxes.

Note: You can also save pictures in separate files. To do this, activate the picture block on the
image and from the File menu select Save Image Copy. In the displayed dialog select Save active
block only.

5XQQLQJ�UHFRJQLWLRQ
To start recognition, click the Recognize button on the Scan&Read toolbar.

If there is an image open, the default operation of the button is recognition of the
open image. If there are one or more pages selected in the Batch window, the
program starts recognizing the selected pages.

You can change the button mode. To do this, click the arrow to the right of the
button and from the displayed menu, select the necessary item.

Note: During recognition the system displays a dialog box, which warns you that certain
parameters are set incorrectly. The messages are in the form: “Brightness too low (or too high)”,
“Incorrect Text type”, etc. These messages help you to check parameters, but you can ignore
them or not display them if you wish (Tools>Options…>Recognition>Show tips during
recognition).

5HFRJQLWLRQ�LQ�WKH�EDFNJURXQG�PRGH
FineReader allows you to run recognition and edit recognized pages at one and the
same time, that considerably speeds up the processing of documents on one and
the same computer.
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Start recognition in the background mode (Scan&Read>Recognize in background
mode). In the Status bar you will see the  indicator. If page parameters are
displayed in the batch (local menu, Display Page Properties item), then you will
see the Background recognition… line near the page under recognition. You can
also see the bullets that appear opposite the processed pages in the Blocks and then
– in the Text columns.

While the program is recognizing, you can open and edit the recognized pages.

&KHFNLQJ�DQG�HGLWLQJ�UHVXOWV
Edit toolbar (Figure 26, p. 45) allows you to edit recognized text.

The Edit toolbar is off by default. To display it on the screen, click the right mouse button on
one of the toolbars and from the local menu select Edit.
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)RQW�6L]H
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Figure 26. “Edit” toolbar.

&KHFNLQJ�UHFRJQLWLRQ�UHVXOWV

One of the useful features of FineReader’s text editor is the in-built spell-checking
system for texts in the following languages and their combinations: Bulgarian,
Czech, Danish, Dutch (Standard, Belgian), English, Estonian, Finnish, French,
German, Greek, Italian, Norwegian (Bokmal, Nynorsk), Polish, Portuguese
(Standard, Brazilian), Russian, Spanish, Swedish, Tartar*, Turkish, Ukrainian.

The original text may contain spelling errors and misprints that are transferred in
the recognized text. Besides original text errors, the recognized text may contain
indefinitely recognized and unrecognized words (words containing indefinitely
recognized and unrecognized characters). To make the spell-checker stop on such
words, check the corresponding option (Tools>Options…>Results check tab).

                                                          

*  Tartar is in the special delivery.
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Figure 27. “Checking results” dialog.

7R�FKHFN�UHFRJQLWLRQ�UHVXOWV�

1. Click the Check Results button.
The Checking Results dialog box (Figure 27, p. 46) displays a possible error
and the Zoom window displays the original image.

2. Select one of these options for the word:

• Click Ignore to allow the word to remain as it is.

• Click Ignore All to ignore all instances of the word.

• Click Add.. to add the found word to the dictionary.

• Click Paradigm… to view the paradigm (sum-total of all word forms) 1 of the
word selected in the Suggest list.

• Click Suggest… to get replacement variants for the word edited in the Replace
With box.

• Click Options… to set checking options2.

• Click Close to close the dialog box.

0RYLQJ�WR�HUURUV

To check and edit recognition results you can use  and  buttons, to move to
the next and previous words, respectively. You can also use hot keys: F4 and
SHIFT+F4 respectively.

9LHZLQJ�UHFRJQLWLRQ�UHVXOWV

By default the recognition results are displayed in the draft mode, i.e. all the text is

displayed with the font of one size. To display the font with its real size, click .

                                                          

1 For Russian, English, German, French, Ukrainian, Spanish, Italian.

2 To set spell-checking options, select the Results check tab of the Options dialog
(Tools> Options…).
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You can change the font size of the draft view (Tools>Options>General>Font
size in draft mode).

6DYLQJ�UHFRJQLWLRQ�UHVXOWV
You can save recognition results to a file, send them to an application (MS Word,
MS Excel, etc.) without saving it on the disk, copy to Clipboard or send by e-mail.
You can choose whether to export all recognized pages or only selected ones.

7R�H[SRUW�UHFRJQLWLRQ�UHVXOWV�

1. Click the arrow to the right of the 5-Save button and from the displayed menu
select Export Wizard…

2. In the displayed dialog (Figure 28) select where to export recognition results.
If you want to export only the pages selected in the Batch window, set the
switch in the Save only selected pages position.

3. Click Finish.

Figure 28. “Export” wizard.

Note: If when you were working with a new (unnamed) batch the work of the program was
cancelled (e.g., the power was switched off), then next time you run FineReader it will open this
very batch. You will lose only information about the page you were working with. The
information about other pages will be recovered.

6DYLQJ�EDWFK�IRU�WKH�IXUWKHU�ZRUN

If you are planning to continue working with the batch in the next session, you can
save it (File>Save Batch…). By default a special folder is created in the
c:\Program Files\ABBYY FineReader\Packets folder for each batch. The title of
the folder is the title of the batch. The following files are stored in the batch folder:
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• Batch file (BatchName.pac).

• Image (BatchName_number.TIF) and/or text file (BatchName_number.FRF)
for each page.

• File with blocks (BatchName_number.BOX) (only for pages that have an
image file).

• Files with batch scanning options (BatchName.SCN).

• Batch options file (BatchName.opt).
• The Forms folder also has a language database file textlang.dat (for

FineReader Professional and Handprint).

/HDUQLQJ�QHZ�FKDUDFWHUV
FineReader can recognize texts of any quality, printed with any font. Good- and
medium-quality texts, and standard fonts can be recognized without preliminary
training. Poor-quality texts and unusual fonts can be recognized after special
training.

To make the system recognize the whole text accurately, train it on a couple of
sample pages. A pattern will be established, which the system can use to recognize
the rest of the text.

The training is run during recognition in a special mode. The result of training is a
pairing of the image of the symbol and its name, set up in the OCR memory. The
sum-total of pairs, created during training, is called the “pattern”. This pattern is
used for recognition of the rest of the text.
The user pattern can be used only to recognize text of the same size as the font on
which it was trained.

+RZ�WR�WUDLQ�WKH�V\VWHP

To recognize low-quality texts or unusual fonts you should do the following:

1. Create a pattern (name it).

2. Set Read&Learn mode (check the corresponding item on the Recognition tab
of the Options dialog).

3. When training the program to learn unusual fonts or fonts different from
Cyrillic or Latin fonts (e.g., Greek, Irish), switch the omnifont off.

4. Recognize 1-2 pages with training.
Note: If you want to recognize texts in the language not supported in FineReader, print any text
with the typesets (not bold and not italic) you are planning to train.

5. Edit the pattern (Tools>Pattern Editor...).

6. Cancel Read&Learn mode.
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7. Start recognition of the rest of the text with the pattern attached.
Note: When you go onto recognition of texts printed in other fonts, do not forget to switch the
pattern off (select None in the Current User Pattern list on the Recognition tab of the Options
dialog box).

Further on we shall describe these operations in detail.

&UHDWLQJ�DQG�$WWDFKLQJ�D�3DWWHUQ

1. Choose Options... from the Tools menu.

2. On the Recognition tab of the Options (Tools>Options) dialog click the
Patterns... button in the Training group.

3. In the Patterns dialog box, click New...

4. Name the pattern.

5. Before you start recognition with training, make sure that the created pattern
is selected in the Current User Pattern box and the Read&Learn checkbox is
selected.
Note: You need to switch the omnifont off only when training the program to learn unusual fonts
or fonts different from Cyrillic or Latin (e.g., Greek, Irish).

Figure 29. “Manual Training” dialog.

7R�VWDUW�UHFRJQLWLRQ�ZLWK�WUDLQLQJ�

1. Check whether the Read&Learn checkbox is selected on the Recognition tab
of the Options dialog box (Tools>Options...).
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2. Click the Recognize button.
The program will start recognition and display the image of an indefinitely
recognized letter in the Pattern Training dialog box (Figure 29).

3. Name the letter and click Train.
Note: When training a pattern, watch that images of capital letters are named with capital letters
and images of small letters – with small letters.

4. The enclosing rectangular in the upper part of the dialog must contain one
whole character. If it contains a part of the letter or more than one character,
use Move right and Move left buttons to move the rectangular so that it
encloses one whole letter.

5. If you have made a mistake during training, you can click the Back button, and
the enclosing rectangle will return back to the previous position, and the last
trained pairing “image – character” will be deleted from the pattern.

Note: The Back button works inside one word.
6. You can edit the pattern after it is trained. See “Editing a Pattern”.

Note: When training the pattern, bear the following restrictions in mind: the recognition system
doesn’t distinguish between some characters and connects their images with one and the same
character. Thus, for instance, images of a straight ('), left (‘) and right (’) apostrophes are stored
in the pattern as images of a straight apostrophe. That is why you will never see a left or right
apostrophe in the recognized text, although it is these characters that you have entered during
recognition with training.

7R�FDQFHO�5HDG	/HDUQ�PRGH�

• On the Recognition tab of the Options dialog box (Tools>Options...) deselect
the Read&Learn checkbox.

(GLWLQJ�D�3DWWHUQ

Before you run recognition using the new pattern you should check it and edit it if
necessary. That will minimize recognition errors, made because of incorrect
pattern learning by the system. Your pattern must contain only whole symbols or
ligatures (combinations of two or three letters, which can’t be unstuck during
training, and are therefore taught as one character).

7R�(GLW�D�3DWWHUQ�

1. From the Tools menu select Patterns...

2. Select the pattern in the list and click Edit... to display the list of characters
(Figure 30).

3. Delete the incorrect pairs and close the dialog box.
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Figure 30. “Edit Pattern” dialog.

/HDUQLQJ�/LJDWXUHV

Some groups of two or three characters in the text may stick together because of
their form. If during training you can’t move the enclosing rectangle so that it
encloses one whole symbol and no parts of the adjacent symbols, you can teach
this combination of characters as a single symbol. Such combinations of two or
three symbols that can’t be unstuck are referred to as ligatures. Examples are ff,
ffi, ffl, etc. While training the system, you can select the necessary ligature from
the Symbol list. If you can’t find the necessary ligature in the list, create a new one.
One pattern cannot contain more than 100 new symbols. But do not create too
many new ligatures, because this can affect recognition quality.

Note: If you are teaching the program to recognize new characters that can’t be entered from the
keyboard, use a double-letter combination to name them or copy the necessary characters from
&KDUDFWHU�0DS��H�J���DQ�DFFHQWHG�OHWWHU�D�FDQ�EH�WUDLQHG�DV��Z��$QVZHU�Yes, when the program
asks you whether to create a new ligature.
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/DQJXDJHV�LQ�)LQH5HDGHU
To recognize texts in Russian, English, German, French, Ukrainian, Spanish,
Italian and any other languages from the list of supported languages, select the
correct value in the languages list on the Recognize toolbar. If you do not see the
necessary language in the list, select the Other… value and create a new
combination (for details see “Language of recognition”, p. 42). The list of
supported languages can be found in Appendix, p. 57.

8VHU�ODQJXDJHV�DQG�ODQJXDJH�JURXSV��IRU�)LQH5HDGHU�����3URIHVVLRQDO�DQG
+DQGSULQW�

FineReader supports 53 languages and it is enough for the most users (list of
supported languages can be found in Appendix, p. 57). But in some cases you may
need to create new languages yourself.

:KHQ�WR�FUHDWH�D�QHZ�ODQJXDJH�

• To attach a text file or regular expression for a dictionary. Mostly used for
creation of new languages for recognition of form fields.

• To recognize texts in the languages not supported in the program.

• When you often use this or that language combination, e.g., English-Spanish.

You can attach a dictionary to a new language. It should be a text file in ANSI
encoding. In FineReader Handprint you can also attach a database column as a
dictionary.

To create a new language or language group, call Language Editor dialog (Tools>
Language Editor…).

The sample of creating new language is given in Appendix, p. 55.

%DWFK�SURFHVVLQJ�LQ�WKH�QHWZRUN��IRU�)LQH5HDGHU����
3URIHVVLRQDO�DQG�+DQGSULQW�

You can process one batch on several computers simultaneously. This speeds up
input of large documents considerably. Each computer involved in the processing
of the batch must have a separate copy of the program installed.

Input of text to the computer involves scanning, page analysis, recognition, editing
and export. When processing a single batch simultaneously on several computers,
you can spread the task so that one operation or combination of operations can be
performed on each computer. For example, one computer, equipped with a scanner
and ADF mechanism, can be used for scanning, while another computer (or
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several other computers) recognizes the scanned pages and/or edits and exports
recognition results.

If batch recognition is run on several computers simultaneously, they divide the
work between themselves automatically: as long as there are unrecognized pages
in the batch, the computers will not stand idle.

+RZ�WR�ZRUN�ZLWK�D�EDWFK�LQ�WKH�QHWZRUN
1. Create a new batch (unless it already exists) and save it in a folder that is read-

and write-accessible by all computers involved in the document processing.
2. Close the batch to save its options.
3. Run FineReader and open the batch on the computers that will work with it.
4. Start scanning on the computer which is equipped with a scanner and ADF

mechanism.
5. Start recognition in the Read&Wait mode on the computer meant for

recognition (Scan&Read>Recognize All Unrecognized Pages and Wait) and
then on the remaining computers meant for recognition.

6. Once some pages have been recognized, you can start editing them on any
free computers, or on the computers where background recognition is running,
without waiting for the remaining pages.

7. Recognized pages (all or the selected) can be exported to a file or sent to
another application.
Note: To be able to monitor the processing in the batch, click the right mouse button in the batch
window and from the displayed local menu select Show page parameters. This batch view will
ease your work with the batch in the network (Figure 15, p. 32).

5HDG	:DLW�PRGH

In the Read&Wait mode, the recognition automatically continues when new
unrecognized pages appear in the batch.

7R�UXQ�UHFRJQLWLRQ�LQ�WKH�5HDG	:DLW�PRGH�

• Click the arrow to the right of the Scan&Read button and from the displayed
menu select Recognize All Unrecognized Pages and Wait.
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$SSHQGLFHV

,PSURYLQJ�UHFRJQLWLRQ�TXDOLW\��WLSV�DQG�WULFNV

0DLQ�SULQFLSOHV

If you have a text with many unrecognized characters, the reason may be that the
source image is of a poor quality. You should set the correct brightness, resolution
text type and rescan the image. If there is any garbage on the image, clean it.

A poorly recognized text can be due to incorrect recognition parameters, e.g.,
selection of an incorrect language or selecting too many languages. For instance,
recognition errors in each line may be caused with recognition of an English text
with English-Russian language.

$GGLQJ�ZRUGV�WR�WKH�GLFWLRQDU\

The system uses a dictionary during recognition. If you add frequently occurring
terms and abbreviations to the dictionary, recognition accuracy is improved. You
can add words to the speller dictionary (Tools>View Dictionaries...) or you can
create a new language and attach the words as a text file (in ANSI encoding) or a
database column to it.

For more information see “Supported languages”, p. 57 and on-line help.

7UDLQLQJ

If you need to recognize large texts of very poor quality or unusual fonts, you can
train the system on 2 or 3 sample pages, and it will then recognize the rest of the
text accurately. The training is run in a special mode during recognition. The result
of training is a user’s pattern, applied during recognition of the text. For details see
“Learning new characters”, p. 48.

&UHDWLQJ�QHZ�ODQJXDJHV

To speed up recognition and improve its accuracy you can create new languages
and attach dictionaries to them. You can use a text file in the ANSI encoding as a
dictionary.

For example, to recognize a table column, in which a very limited range of words
occur, you can create a new language and attach a dictionary, containing all the
words which can occur in this column, to it.
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6DPSOH�RI�UHFRJQLWLRQ�RI�WKH�2OG�5XVVLDQ�ODQJXDJH
To recognize Old Russian texts do the following:

1. Create a copy of the Russian language.

2. Set created language as the language of recognition.

3. Create a new (empty) pattern, attach it and start recognition with training.

4. Recognize 1 or 2 pages in Old Russian in the Read&Learn mode.

5. View and edit the pattern.

6. Switch the Read&Learn mode off (but do not switch the trained pattern off).

7. Run recognition.

8. In the recognized text replace ligatures containing “*” with the corresponding
characters (see below).

Later, we shall explain how to create and attach a new language in greater detail.

&UHDWH�D�QHZ�ODQJXDJH�

1. From the Tools menu select Language Editor...

2. In the displayed dialog, click New…

3. Set the switch in the To edit the copy of the existing language position.

4. In the appeared list select Russian and click Next.

5. Enter the name for the new language: OldRussian.

6. You will see Russian characters in the dialog. Now add the “*” character (or
any other character that exists in the Cyrillic code page and you can enter
from the keyboard). This character will be used to create ligatures. To make
the system ignore the “*” character during the spell-check, mark it as ignored
(click the button on the right of the Ignored box to select it from the table).

&UHDWH�D�QHZ�SDWWHUQ�

1. From the Tools menu, select the Pattern Editor... item.

2. In the Patterns dialog click New...

3. In the Create Pattern dialog name the new pattern, e.g., OldRussian.

$WWDFKLQJ�WKH�SDWWHUQ�DQG�VHWWLQJ�WKH��5HDG	/HDUQ��PRGH

1. On the Recognition tab of the Options dialog (Tools>Options...) in the
Training group, from the Current User Pattern list select the pattern, that you
have just created and now want to train.



Appendices

56 FineReader 4.0. User’s Guide.

2. Select the Read&Learn and Use Omnifont1 checkboxes.

7R�VSHFLI\�UHFRJQLWLRQ�ODQJXDJH�

1. In the Recognition Language list on the Recognition toolbar select the
Other… value.

2. In the displayed dialog, select Russian and OldRussian2.
Now start recognition.

5HFRJQLWLRQ�ZLWK�WUDLQLQJ

During recognition with training (Read&Learn mode), the system displays the
Pattern Training dialog. In the upper part of the dialog box you can see a fragment
of the text line under recognition, where the indefinitely recognized character is
enclosed in rectangle (Figure 29, p. 49).

Enter the character from the keyboard and specify its language (Old Russian). If
the “i” character is enclosed in the rectangular, then in the Symbol box enter the
³
c´�FKDUDFWHUV��LI�WKH�³υ´�FKDUDFWHU�LV�HQFORVHG�LQ�WKH�UHFWDQJXODU��HQWHU�WKH�³
b´
ligature; if the “Θ´��WKH�³
n´�OLJDWXUH��LI�WKH�³ ´�FKDUDFWHUV�±�WKH�³
_´�OLJDWXUH�

When the training is over, the pattern will be created. Before you use it for
recognition, view and edit it if necessary (Tools>Pattern Editor...) (Figure 30,
p. 51).

After you have trained the pattern on one or two pages of the text, recognize the
rest of the text, and attach the created and edited pattern. Then specify that you
will recognize without training using the created pattern, and start recognition
specifying the combination of Russian and OldRussian languages on the toolbar.

5HSODFH�LQ�WKH�HGLWRU

After the text is recognized, in the text editor that has special characters (e.g., Θ, υ
and so on), carry out context replacement of ligatures with the characters, i.e.
UHSODFH�
n�ZLWK�Θ��
b�ZLWK�υ and so on.

)RU�DGPLQLVWUDWRU�RI�)LQH5HDGHU�+DQGSULQW�DQG�)LQH5HDGHU�%DQN

The administrator’s guide for FineReader Handprint and FineReader Bank is in the
.pdf file located in the Guide folder on the CD-ROM form the FineReader
distributive.

                                                          

1 Omnifont is deselected only in rare cases – to teach the program to recognize
letters of some exotic language.

2 The Russian language is attached for the use of the dictionary that improves
recognition quality and allows to check spelling.
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,PDJH�IRUPDWV�)LQH5HDGHU�FDQ�ORDG

BMP: b/w; gray, color
PCX, DCX: b/w; gray, color (16, 256 colors)
JPEG: gray, color
TIFF: b/w – unpacked, CCITT3, CCITT3FAX, CCITT4, Packbits;

gray – unpacked, Packbits, JPEG;
color – unpacked, Packbits, JPEG

PNG b/w; gray, color

6XSSRUWHG�ODQJXDJHV

Afrikaans, Albanian, Basque, Breton, Bulgarian* , Byelorussian, Catalan,
Chechen, Crimean Tatar, Croatian, Czech, Danish, Dutch (Standard, Belgian),
English, Estonian, Fijian, Finnish, French, German, Greek, Hawaiian,
Hungarian, Icelandic, Indonesian, Irish, Italian , Kabardian Latin, Latvian,
Lithuanian, Macedonian, Maori, Moldavian, Norwegian (Bokmal, Nynorsk),
Ossetic, Polish, Portuguese (Standard, Brazilian), Rhaeto-Romanic, Romanian,
Russian, Samoan, Serbian (Cyrillic alphabet), Slovak, Slovenian, Spanish,
Swahili, Swedish, Tagalog, Tartar ** , Turkish, Ukrainian .

8VLQJ�XVHU�GLFWLRQDULHV�DQG�SDWWHUQV�IURP�)LQH5HDGHU����

8VLQJ�XVHU�GLFWLRQDULHV
After the new version is installed, convert the old dictionaries to the new format:
1. From the Tools menu, select Options…
2. On the Results Check tab of the Options dialog click Add to Dictionary…
3. In the displayed dialog specify the path to the FineReader folder (the folder

where Fine32.exe of the old version is located).
In the upper part of the dialog you will see the list of languages with user
dictionaries.

4. Select the necessary languages and click Add.

8VLQJ�XVHU�SDWWHUQV
After the new version is installed, copy pattern files (with .ptn extension) from the
folder of the previous version of the program to the folder c:\Program
Files\ABBYY FineReader.

                                                          

*  Spell checks in marked languages

**  Tartar is in the special delivery
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8VLQJ�NH\V�LQ�)LQH5HDGHU
To: Press:
Create a new batch CTRL+N
Open a batch or an image, add image to the batch CTRL+O
Run the “Export” wizard CTRL+D
Save to file ALT+SHIFT+S
Send to MS Word ALT+SHIFT+W
Send to MS Excel ALT+SHIFT+E
Send to Word Pro ALT+SHIFT+D
Send to WordPerfect ALT+SHIFT+P
Send by e-mail ALT+SHIFT+M
Send to Clipboard ALT+SHIFT+C
Undo an action ALT+BKSP or CTRL+Z
Redo an action ALT+SHIFT+BKSP or CTRL+Y
Cut the selection and place it on the Clipboard CTRL+X
Copy the selection to the Clipboard CTRL+INS or CTRL+C
Insert the Clipboard’s contents in the text CTRL+V or SHIFT+INS
Delete active blocks, a selection, selected pages DEL
Delete pages… ALT+DEL
Select all text in the editor, or all pages in the batch, or
all blocks on the current image

CTRL+A

Make the block “Text” CTRL+1
Make the block “Table” CTRL+2
Make the block “Picture” CTRL+3
Merge table cells CTRL+ENTER
Split table cells CTRL+SHIFT+ENTER
Find the necessary fragment in the recognized text ALT+F3 or CTRL+F
Repeat the search F3
Find the necessary fragment in the recognized text
and replace it with another fragment

CTRL+H

Open the “Font” dialog CTRL+SHIFT+F
Open the “Formatting” dialog ALT+SHIFT+F
Open the dialog to set the language of the selection CTRL+L
Make the selection Bold CTRL+B
Make the selection Italic CTRL+I
Format the selection with a continuous underline CTRL+U
Show the entire image CTRL+SHIFT+1
Scale the image according to its width CTRL+SHIFT+2
Scale the image according to its height CTRL+SHIFT+3
Zoom in CTRL+ up arrow
Zoom out CTRL+ down arrow
Open the next page CTRL+ Num + 
Open the previous page CTRL+ Num -
Open the page with number… CTRL+G
Update the page list F5
View properties of the active image (block) ALT+ENTER
Select a tool to create a text block ALT+1
Select a tool to add a part of block ALT+2
Select a tool to remove a part of block ALT+3
Select a tool to move blocks ALT+4

File menu

Edit menu

View menu

Image menu



Appendices

FineReader 4.0. User’s Guide. 59

To: Press:
Select a tool to renumber blocks ALT+5
Select a tool to delete blocks ALT+6
Select a tool to add vertical lines to a table block ALT+SHIFT+1
Select a tool to add horizontal lines to a table block ALT+SHIFT+2
Select a tool to delete lines from the table block ALT+SHIFT+3
Run scanning with recognition F9
Run scanning and recognition of multiple pages SHIFT+F9
Open and recognize the image ALT+SHIFT+O
Run Scan&Read Wizard CTRL+J
Run scanning CTRL+K
Run scanning of multiple pages CTRL+SHIFT+K
Stop scanning ALT+SHIFT+K
Mark blocks on open page CTRL+E
Mark blocks on all pages without blocks CTRL+SHIFT+E
Recognize open page CTRL+R
Recognize all unrecognized pages CTRL+SHIFT+R
Recognize all unrecognized pages in background
mode

ALT+SHIFT+R

Check results F7
Move to next indefinitely recognized word F4
Move to previous indefinitely recognized word SHIFT+F4
Discard error marks CTRL+Q
View dictionaries CTRL+SHIFT+D
Translate selected word or word combination CTRL+SHIFT+T
Open the “Language Editor” dialog CTRL+SHIFT+L
Open the “Pattern editor” dialog CTRL+SHIFT+A
Open the “Scanner Parameters” dialog CTRL+SHIFT+S
Open the “Options” dialog CTRL+SHIFT+O
Arrange windows CTRL+W
Get context help to selected interface object (menu or
dialog item)

SHIFT+F1

Open the selected batch page ENTER
Activate the Batch window ALT+0
Activate the Image window ALT+8
Activate the Text window ALT+9
Move from one table cell to another one ALT+ left arrow, right arrow, down

arrow or up arrow

Window menu

Help menu

Other
commands

Tools menu

Scan&Read
menu










