
What's new for this release

ÐÐÐÐÐÐÐÐÐÐÐÐÐÐÐ
Thanks for helping us make this the best release of Create yet. 
Following are lists of new features and bug fixes that you can expect 
to see in this release. As always, we welcome your comments and 
suggestions. 

Note that if you are an experienced Create user, it is essential that 
you read this file thoroughly so that you are aware of any changes 
that might affect the way you work with the application.
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Features New in 3.x

Ö Selection_Status;¬QUAD Fat Architecture.

Create now runs on Motorola, INTEL, HP-PA RISC and SPARC 
architectures.

Ö Selection_Status;¬Image Inspector.

953831_paste.tiff ¬
When an EPS or TIFF is selected, the First Inspector brings up 
information on the underlying data format of the image..

Ö Layers: Selection_Status;¬Hide, lock and show.

612287_paste.tiff ¬
Create has new power with Layers - each page can have as many 
layers of graphics as you want - it's easy to add them and work with 
them.
124400_paste.tiff ¬

Ö Selection_Status;¬More Art Galleries.



You can keep many on-line art galleries:
925275_paste.tiff ¬

"My Art" is loaded from ~/Library/Stone/Create/CreateImages
"Our Art" is loaded from:

/LocalLibrary/Stone/Create/CreateImages
If that directory exists, or:

/LocalLibrary/Create/CreateImages
if that directory exists.

Ö Selection_Status;¬Paint Brush Settings.

Now you can be styling with a totally adjustable paint brush, look 
under "Info->Preferences..."    and select "Tools" from the pop up 
button:

427909_paste.tiff ¬

Ö Selection_Status;¬Background Image.

Now, each page can have a background image displayed while you 
work. It doesn't print, and only it's filename is saved, but this is 
handy for tracing or autotracing images

282778_paste.tiff ¬639479_paste.tiff ¬.

Open Image... allows you to choose an image from the open panel. 
Remove Image to get rid of image from view. Hide Image to 
temporarily hide it from view.

You can control the amount of transparency in the image by moving 
the "Background Image Transparency" slider:

277093_paste.tiff ¬



<----- Transparency                    Opacity------>

which is located in the "TIFF" subportion of the Preferences panel.

Ö Selection_Status;¬Auto Tracing of TIFF images.

Now you scan in quick sketches and have Create turn them into 
editable lines and curves! Any type of TIFF can be converted.
A TIFF like this:

685477_paste.tiff ¬
Can become editable objects like these:

446759_paste.tiff ¬
On STONE_CD, Volume 2, you'll find the "MayanMan.tiff" image in 
Stone_Stuff/Create/AutoTrace, so you can try this!

Ö Selection_Status;¬Colorful Interface:
Icons on the inspector panel are more colorful.

Ö Selection_Status;¬ Template Files
You can now save template files for later use with New...
When you open a template, you get a new, unsaved document 
identical to the template. This is useful for creating stationary, 
reports, etc.

To save a template, select File->Save Template...

634110_paste.tiff ¬

This will allow you to save a document to one of the Template 
directories:
~/Library/Stone/Create/Templates
/LocalLibrary/Stone/Create/Templates
You can traverse between these directories with the accessory 
view's radio button matrix:

308654_paste.tiff ¬



The semantics of "New" have changed slightly:
"New Empty" means a new, empty document.

970475_paste.tiff ¬

"New..." runs the Open Template panel: 

910045_paste.tiff ¬

The same radio button matrix lets you choose either of the 
template directories, you can also choose "New Empty" if you 
want a fresh one...

To edit a template, use the standard Open... command. Any 
existing document can be a template; to make it easy to access, 
move it to one of the template directories...

Export, Embedding, and Links:

Ö Selection_Status;¬Editable EPS files

Now you can re-edit EPS files generated by Create (either by 
exporting or by using the DataWell). When you drag the EPS created 
by Create back into a Create document, you can access each 
component of the file in their original form.

To enable this functionality, in Preferences, select this switch in the 
Document subpanel:

620707_paste.eps ¬ 

Ö Selection_Status;¬OOE Compliance: Embed Create graphics 
in OpenWrite.

OOE_Logo.tiff ¬Create 3.0 is Level 2 OOE compliant - which means 



that you can use Create to design and edit graphics in OOE Client 
applications, such as XANTHUS's OpenWrite word processing 
application.
From within OpenWrite, you can launch Create and make a new 
mini-doc, and as you save, your changes are reflected in the 
OpenWrite document. The image, with its Create file format, is 
stored within the OpenWrite document for single-click editing by 
Alternate-clicking the OOE_IconSmall.tiff ¬.

Level 2 OOE allows you copy Create graphics and then paste 
and embed them into an OpenWrite document. Moreover, you can 
drag and drop Create files into an OpenWrite document to either 
copy or embed the graphics for later editting by Create.

Ö Selection_Status;¬File Filtering

Built into the Create.app wrapper is "CreateConverter.daemon" - a 
filter application which can convert Create files into other data 
formats. Applications which check NXImage's 
+imageUnfilteredFileTypes can accept drag & drop Create 
documents as EPS, TIFF, ascii, RTF or OOE.

Moreover, this applet is callable from the command line for bulk 
conversion of files.

NOTE: a hideous bug in NS 3.3 and earlier versions that we notified NEXT about 
in 1993 prevents using the filter with Edit and Mail. If you have more clout than we 
do, ask them to fix:[40011] Filter services!

Ö Selection_Status;¬Export Control of TIFF images.

A new preferences module, "TIFF", allows you to decide how TIFF 
images are exported when dragged from the DataWell or exported 
via Save As... Their compression, bit depth, presence of alpha are 
user definable:



                    884392_paste.tiff ¬
  

NOTE: the "Export all representations" switch applies to the case 
where you are exporting a single TIFF object that has multiple 
representations (eg, a 12 bit and 2 bit representations). Also, Export 
with alpha, has no affect in this case. If you need to remove alpha 
from a single TIFF image, we suggest drawing a white rectangle 
around the TIFF, selecting both, and then dragging from the 
DataWell.

Ö Selection_Status;¬True object links with no redundant 
storage.

NEXTSTEP's behavior of object linking is to store a representation 
locally of the linked image. On large TIFF files, this will double the 
space needed to store both the source TIFF and the destination 
Create document. Create offers an option to not store the image:

1. Select the linked image
2. Edit->Link->Link Inspector to bring up Link Inspector
3. Select "Save space: no local copy of image":

768434_paste.eps ¬ 
As well as altering this on an image by image basis, you can select 
which behavior you want in the Preferences Panel, under the Misc 
pop up:

620831_paste.tiff ¬
Mail:

Ö Selection_Status;¬Prepare for Mailing.

Object links are handy, except when you need to send the 
documents off-site. This new menu item prepares a version of your 
document that has all the links "folded" in, so that the recipient gets 
all the linked files. It's under Edit->Link menu:



123250_paste.eps ¬

Ö Selection_Status;¬ Allow user to set alternate email of 
suggestions/bugs:
In a terminal window, type:

 dwrite Create SupportEmail <address> 

 where <address>    is where you want the email sent; which is by 
default bugs@stone.com.

Ö Selection_Status;¬ Allow user to set alternate Mail 
application:
In a terminal window, type:

dwrite GLOBAL Mailer <MAIL_APPLICATION> 

where <MAIL_APPLICATION> is your Mail application; by 
default, this is Mail.app. When you send your suggestions and 
bug reports, they will be sent using this Mail application.

Ö Selection_Status;¬ Zooming now remembers your zooms
When you zoom to non-standard zooms via the "Set..." item, 
Create remembers where you have been, and all documents 
created or opened thereafter will show these zooms on the zoom 
pop up list:

630633_paste.tiff ¬

Ö Selection_Status;¬ Panel Management made easier
You can change on the fly whether or not Create's panels float 
over the main document. This is useful on small screens. In 
Preferences, Launch, select this switch:

743263_paste.tiff ¬

This setting is remembered for the next session.



Ö Selection_Status;¬ Printing just the zoomed portion of a page

Normally, Create prints at 100% of the document size, regardless 
of what zoom you have selected. Now, you have a choice of what 
to print when you are zoomed in above 100%. In Preferences-
>Printing, use this switch:

746844_paste.tiff ¬

to print what's visible at the higher zoom instead of the whole 
page at 100%.

Text:

Ö Selection_Status;¬Support for 2 byte fonts, like Kai-Su: 
490468_paste.eps ¬
Other two-byte fonts can be enabled by typing this into a 

terminal window, where FONT_NAME is the name of two-byte 
font:

dwrite Create <FONT_NAME> yes

Ö Selection_Status;¬ Convert Text Types

You can now convert a Super Text to a Paragraph Text, or a 
Paragraph Text to a Super Text by simply clicking a menu item:

693044_paste.tiff ¬

Ö Selection_Status;¬ Text in a box

You can add a box around any paragraph text graphic by simply 
clicking on the Outline checkbox:



813900_paste.eps ¬
Use the outline inspector's outline width and color well to set it's 
attributes. In order to give a pleasing offset equally on the left and 
the top, the box extends 5 pixels to the left and top of the 
standard text graphic.

Design:

Ö Selection_Status;¬Layout Guides for easy placement of 
objects.

Now you can drag in guides from the rulers for easy alignment of 
objects. Guides create "Gravity" - when an object is moved across a 
guide, the object "clings" to the guide in the following manner, in this 
example, we'll describe a vertical guide:

If the left of the object is near the guide, the left side of the object 
aligns with the guide. Otherwise, if the right side of the object is near 
the guide, then the right side of the object is aligned with the guide. 
Finally, if neither of the above cases produced gravity and the center 
of the object is near the guide, the center is aligned with the guide.

To Insert Guides into your document:

1. bring up the rulers with "Show Rulers" (command-r)
        When the cursor enters the ruler area, it becomes 
a:863851_paste.tiff ¬ in the side ruler and a 16657_paste.tiff ¬ in the 
top ruler.
  
2. Click in the top ruler and drag down a horizontal guide
        Click in the side ruler to drag across a vertical guide:

805703_paste.tiff ¬

3. To move a guide, click on it and drag with the mouse-down.
4. To remove a guide, click on it and drag it off the document.



5. Guides do not print, they are hidden and turned off when the 
rulers are hidden. Grid should be turned off for the guides' "gravity" 
to work.
6. Guides are saved with your document.

Ö Selection_Status;¬Allow multiple items to receive a pattern: 
With multiple objects selected,    drag a pattern onto the Fill 
Pattern Inspector to give all of those objects the selected pattern:
130060_paste.tiff ¬

Ö Selection_Status;¬ Initial Colors:
Now it's easy to set the initial colors of outlines, fills, blends, 
shadows,    and multiples by using the newest addition to the 
Preferences Panel, "Initial Colors":

462092_paste.tiff ¬

Just use the Color Panel to select your favorite colors.

Ö Selection_Status;¬ Groups of clipping objects:
Now, groups composed of Splines, Poly-Splines, Freehand 
curves and Paint Brush graphics can be used as a composite 
Mask in "Mask Group".    Since any other object can be turned 
into a spline via "Make Spline", this allows you to clip, for 
example, TIFFs, with disjoint paths:
example.tiff ¬

Ö ReversePath;¬ Reverse Path feature for splines and lines:
Splines, Poly-Splines, Freehand curves and Paint Brush graphics 
can be "reversed", ie the first point becomes the last point, the 
last becomes the first. Object -> Splines/Lines menu:

 500601_paste.tiff ¬

 This is very useful to exploit the "non-zero winding number rule" 
in PostScript, especially in conjunction with groups of paths used 



for creating a    composite Mask in "Mask Group".    This would, 
for example let you make a pencil graphic, reverse it with 
"Reverse Path" and then it use it to create "holes" within the 
mask:

368725_paste.eps ¬

Ö Unscale;¬Unscale Objects

In the original Create Paradigm,    an object 'remembers' the size 
it was created at. If you later resize that graphic, the outline 
would scale. Because this creates very interesting effects, we 
kept this paradigm. BUT - there are times when this is not what 
you want. Instead, you want the object to grow to its new size 
and then consider itself    not a scaled object.

339572_paste.tiff ¬

Here is an example of what we mean:

original: after resize:     after "Unscale":

106193_paste.eps ¬

Features New In 2.1

Ö Selection_Status;¬The Arc Tool was added:      paste.tiff ¬

Now it's easy to do pie charts and accurate arcs with precision:
369972_paste.eps ¬454128_paste.eps ¬



        DataWell                  Selection Status Field                  Zoom Controls        Page 
Controls
paste.eps ¬
Data Type popup      Select Previous          Select Next 

DataWell;¬Ö The Create DataWell

The new datawell in each create document has 6 different file types 
that you can drag out and drop in all conforming NEXTSTEP apps: 
EPS, TIFF, CreateImage, PS, RTF and ASCII.
You can even drag them into another Create document, as a 
shorthand for copy/paste!

What you get depends on the current type in the well, use the Data 
Type pop up    to change to another data type.

EPS: if nothing is selected, than all the objects on that page are 
saved to a .eps file. Otherwise, just the selected objects are saved.
  
TIFF: if nothing is selected, than all the objects on that page are 
saved to a .tiff file. Otherwise, just the selected objects are saved.
  
Create: if nothing is selected, then all the objects on that page are 
saved to a .createImage file in /tmp. Otherwise, just the selected 
objects are saved.

PS: the entire document is printed to a .ps file in /tmp. 

ASCII: if no objects containing text are selected, all the text in the 
document are saved to a .ascii file in /tmp. If there are no objects 
containing text, you get a beep.

RTF: if no objects containing text are selected, all the text in the 
document are saved to a .rtf file in /tmp. If there are no objects 
containing text, you get a beep.



NOTE: the files created in /tmp are removed when you quit Create. 
Remember, if you want to keep a file, don't leave it in /tmp! All /tmp 
files are removed by the system when you reboot your computer.

Selection_Status;¬ÖSelection Status Field

This field helps you identify what type of object is currently selected 
in your document. If more than one object is selected and they are 
all of the same type, it will display those objects's name.

Use the buttons on either side of the Selection Status field to select 
the previous object (left button) or next object (right button) in the 
layer of objects on the page. If all objects are selected, then clicking 
one of these buttons causes no object to be selected; this is handy 
when clicking outside of the selected objects would be hard because 
they fill the page.

Ö Selection_Status;¬Complete On-line Manual Database

A complete, searchable online database is provided as an installable 
package. Once installed, this will place a new menu item in the Info 
menu, Online Manual....

87177_paste.tiff ¬

This will launch DataPhile (included on the CDROM as a demo).
;¬;Online_Manual.rtfd;;¬ For more information.

Ö Selection_Status;¬Double-Click a text object to edit

Brought back by popular demand, you can quickly edit Super Text or 
Paragraph Text    by double clicking it.

Ö User patterns now flow with .createImage files

This allows you to paste or drag and drop patterns that reside on the 



pasteboard or in a .createImage file into DataPhile or into another 
user's Create doc.

Features New in 2.0

Ö Create 2.0 introduces full compatibility with NEXTSTEP 3.1 for 
Intel Processors on NeXT-qualified Intel-based configurations 
and for original Motorola-based NeXT hardware.

Ö You can include link buttons, icons and linked files in any Create 
document for automatic and manual updating. You can also link 
to Create files from any other NEXTSTEP application that 
supports linking. 

Ö Create supports Bacchus' ImageAgent image filters. For 
example, you can drag and drop GIF images into Create. 

Ö You can create stunning patterns with unlimited variety, and 
easily share them on your network. 

Ö You can have multiple pages in a single Create file, and can also 
automate their sequential display using a specified delay time 
between pages. Users who have worked with previous versions 
of Create should note that the Command-key equivalent Cmd-D 
has been removed from Disable Redisplay and reassigned to 
Delete (Page). 

Ö The new paintbrush tool functions similarly to the freehand tool, 
but yields wide swaths of color or patterns and an on-the-fly 
choice of two drawing styles. 

Ö You can bind Super Text to a curve or spline, and edit the 
resulting text object. 

Ö You can add a date marker and/or page number (a favorite of 
DataPhile users everywhere) to any Create document. 

Ö You can instruct Create to remember any number of editing 
actions so that you can undo those actions in reverse order. The 



Undo and Redo commands update to specify the edit actions that 
would be undone and restored by issuing the commands, 
respectively. 

Ö The Free Undo Buffers command clears your computer's 
memory of editing actions that it is holding for the Undo 
command. 

Ö To accommodate newly established NEXTSTEP standards, the 
Command-key equivalent of Create's Paste Effects command 
has changed. It was Cmd-V in previous versions; it is now Cmd-
E, and the new command Link-menu command Paste and Link is 
Cmd-V per NEXTSTEP convention.

Ö Create 2.0 introduces extensive on-line Help. Hold down the 
Help key (or applicable Help key-combination) on your keyboard 
so that the mouse arrow becomes a question mark, then click 
anything on your screen to learn about its uses. 

Ö When you zoom into a document while an object is selected, 
Create will adjust the zoomed window's orientation so that the 
selection is in view. 

Ö In previous versions of Create you could double-click Super text 
or Paragraph text as a shortcut for selecting it when a non-text 
tool was active. As of Create 2.0, you Command-click instead of 
double-clicking. This is both a feature and a fix; it streamlines the 
selection process and fixes some spurious bugs. 

Fixes 3.1
Ö If your page is fully exposed and you change the page layout, 

Create will fully expose your new layout.

Ö Layers with groups works now.

Ö If you add an object to an invisible layer, it becomes invisible.

Ö Background images now zoom correctly.



Ö Menu Item Windows->Remove Gremlins is useful if you've 
created too tiny objects or objects which are off of page.

Ö Other various bug fixes.

Fixes 3.0
Ö Zoomed Images that are rotated don't disappear.

Ö The file document wrapper modification time is updated when 
you save.

Ö Any key down will terminate the construction of a multi-path 
object such as spline and poly line.

Ö Mask Groups scale correctly now.

Ö When you cannot save a file, you get a useful message.

Ö Super Text moves correctly without "jumping".

Ö Super Text handles appear in correct place if you edit the object 
via the Font Kern Inspector.

Ö Groups with lines now ungroup correctly.

Ö When you edit a Super Text object, key downs no longer get 
"lost".

Fixes 2.1
Ö Save works correctly with Version 1.x documents.

Ö If you saved a file at a zoom other than 100%, it now redraws 
correctly when loading.

Ö Create reads your "use alpha" preference correctly.



Ö If you make changes to a document, where the last change is a 
move or a nudge and save that document, subsequently moving 
the selected object now causes the window to become dirty, and 
therefore allows the "Save..." command to be activated.

Ö If you are editing paragraph text, and the cursor is still active, and 
you go to another page or print, you no longer lose the newly 
edited text.

Ö Splines correctly mask when used in a mask group.

Ö There were occasions when a single page document would be 
printed on two pages incorrectly - this is fixed.

Ö If you tried to save a doc where you had read permissions, but no 
write permissions, you'd think you saved it (the title changes) but 
in reality, nothing was saved! Fixed.

Ö Size Inspector updates after each "nudge".

Ö When you "make spline" on a Super Text graphic, the pieces 
which make up the inside of letters like "AaBbdDegOoPpQqR" 
(did you find the pattern?) are correctly brought to front and filled 
with white.

Ö Graphics took the "don't use cache" bit at creation time, but there 
was no way to modify this afterwards. Now, toggling the 
preference will toggle all graphics in the main window.

Ö Drag & Dropping an image correctly updates the inspector.

Ö Copy Effects on an object with Fill incorrectly ignored whether a 
pattern was used - it always said it was. Fixed.

Ö When you change pages, the view no longer loses it's first 



responder status.

Ö If you shortened or lengthed the amount of text in a Super Text 
object by editing, the handle's location got messed up. Fixed.

Fixes 2.0
Ö Drawing a NEXTSTEP-style box no longer causes the application 

to crash upon next draw action.

Ö Canceling out of the Page Layout window no longer crashes the 
application.

Ö Find now works correctly in the User PS window.

Ö The rulers now track the mouse when the document is not the 
key window.

Ö The Size·Location inspector now agrees with the rulers.

Ö Pressing Return will OK the Custom Zoom panel.
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