
About face factory

With face factory you can design anyone you know - your family, friends and work colleagues - or create a face 
using your own imagination.

face factory allows you to create faces by making selections from a group of tabs containing lists of ready-made 
facial features such as eyes, noses, mouths etc. To add a feature to your face, simply drag the feature from its 
relevant tab and position it anywhere in the design area. It’s so simple.

Your version of face factory may have variations within the Feature tabs, i.e., you may have more or less tabs, or 
more or less clipart contained within those tabs. This will have no bearing on any part of this Help, including the 
illustrations shown, as all Feature tabs work in exactly the same way. If the Help mentions a specific feature or 
group of features, use a different feature or group of features appropriate to your version.

Keep adding features to your face until it’s complete. If you don’t like a particular feature, just replace it by dragging 
another feature from the same tab into the design area.

face factory replaces the old feature with the new feature - it couldn’t be easier.

Once all features are in position, you can transform them easily by rotating and reflecting, skewing, resizing, 
coloring and changing their position.

If you make a mistake, just use the undo and redo commands to rectify it. Once you’ve created a face, save it as a 
face file (.FAC). You can then print your face directly from face factory.

If you want to use your face in other programs, you can export it as a (.WMF), (.CGM) or (.GEM) file, probably three 
of the most catered for graphics formats. If you prefer, you can copy and paste the face, or drag-and-drop it into the 
program window.

{button ,KL(`face factory')}Related Topics



Using face factory with other programs

Once you’ve created your face using face factory, you can use it in your other Windows programs, e.g. your 
graphics or DTP programs.

If you’ve got greenstreet Draw on your machine, you can copy your face from the face factory design area 
and paste it into the greenstreet Draw window. You can then edit the face in the same way that you would any (.ART) 
file.

If you’ve got a graphics or DTP program that support the (.WMF), (.CGM) or (.GEM) graphics formats, you 
can export your face from face factory in one of these formats and import the face into your desired program.
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Lets you move faces to different programs or individual features into the design area. Click and hold down the 
mouse button while you drag the face or feature to the position you want. To position the face or feature, release 
the button.

You can also display features in the design area by double-clicking on the feature.



A bar that appears at the bottom and/or right edge of a window whose contents are not entirely visible.



A list of available commands and actions in face factory. Menu names are displayed in the menu bar near the top of 
the face factory window.



A temporary holding place for a face that has been copied.



A window used to supply information to face factory. When a dialog box is displayed, all interaction with face factory 
must be through the dialog box.



Part of a structure for organizing your files on a disk. A folder can contain files and other folders called subfolders.



A face stored on hard or floppy disk, or other media.



A key or key combination that you press to carry out a command or action. If a menu command has a keyboard 
shortcut, the key combination is listed to the right of the command name in the menu.



To save a picture onto the Windows Clipboard, without removing it from the face factory design area, so it can be 
transferred to another location.



To save the face as a (.WMF), (.CGM) or (.GEM) file that can then be loaded into your other programs, e.g. 
greenstreet Draw.



The horizontal bar displaying the names of face factory’s menus. It is displayed below the title bar.



A number of tools you can use to create or edit your face.



A bar at the foot of the face factory window giving you hints and tips as you work.



A standard Windows menu displayed by clicking on the icon at the top left of a window. By using Control menu 
commands you can restore, move, size, minimize, maximize and close the window.



The white area to the right of the Feature tabs where the face is displayed.



A selection of features in the design area.



Small boxes displayed around a selected feature. Handles can be dragged to change the size or shape of the 
feature.



A component of a face e.g. eyes, nose, mouth etc.



Rotating a feature using the rotate buttons in the toolbar.



Reflecting a feature using the reflect buttons in the toolbar.



Skewing a feature using the skew buttons in the toolbar.



The feature tabs are positioned on the left of the face factory desktop. Each tab has an icon heading relevant to the 
type of facial features that can be found on the tab card below. 

Your version may have variations within the Feature tabs, i.e., you may have more or less tabs or more or less 
clipart contained within those tabs.





Howto



Work with faces



Opening an existing face

1. From the File menu, select Open. The Open dialog box appears.

2. From the Look in drop-down list box, select the disk drive and folder where the face is saved. The contents of 
the last used folder are shown by default.

3. From the Folders list box, select the face you want to open, then click on Open.

After a short time the selected face appears in the face factory design area.

Note:

If there are any unsaved changes to the current face, a message will appear asking if you want to save the 
changes. Click on Yes, No or Cancel as appropriate.

If you select Yes, the Save As dialog box appears for you to save your face.

Keyboard shortcut: Ctrl+O
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Opening an recently used face

A list of recently used faces can be found in the File menu directly above the Exit command.
From the File menu, select the filename of the face you want to open. The face appears in the design area.

Note:

If there are any unsaved changes to the current face, a message will appear asking if you want to save the 
changes. Click on Yes, No or Cancel as appropriate.

If you select Yes, the Save As dialog box appears for you to save your face.
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Starting a new face

1. From the File menu, select New. A new untitled face is opened within the design area.

2. Create your new face.

Save the face so it can be re-opened for use at a later time.

Note:

If there are any unsaved changes to the current face, a message will appear asking if you want to save the 
changes. Click on Yes, No or Cancel as appropriate.

If you select Yes, the Save As dialog box appears for you to save your face.

Shortcut:
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Saving a new face

1. From the File menu, select Save As. The Save As dialog box appears.

2 From the Save in drop-down list box, select the disk drive and folder where you want to save your face.

face factory is selected in the Save as type drop-down list by default. This saves your face as a face factory file.

3. Type the name of your face in the File name text box.

4. Click on Save.

Keyboard shortcut: Ctrl+S
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Exporting a face

1. From the File menu, select Export. The Export dialog box appears.

2. From the Save in drop-down list box, select the disk drive and folder where you want to export your face.

3. From the Save as type drop-down list box, select the format in which you want to export your face.

4. Type the name of your face in the File name text box, then click on Save.

Note:
face factory files can be exported in either (.WMF), (.CGM) or (.GEM) graphics file formats.
You can also drag-and-drop a face into another program.

Keyboard shortcut: Ctrl+E

{button ,KL(`exporting')}       Related Topics  



Copying a face to the Windows Clipboard

1. From the Edit menu, select Copy All. The face is copied to the Windows Clipboard.

2. Paste your face into your desired program.

Keyboard shortcut: Ctrl+C
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Dragging-and-dropping a face into another program

1. If it is not already running, open the program in which you want to use your face.

2. Make sure both face factory and the program are visible on your desktop.

3. In face factory, press and hold down the mouse button on your funny face.

4. Drag the mouse pointer so it is positioned over the program window.

5. When the pointer is over the program window, release the mouse button. The funny face is redrawn in the 
program window.

Note:
face factory files can also be exported in either (.WMF), (.CGM) or (.GEM) graphics file formats using the 

Export command in the Edit menu.
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Setting up your printer

1. From the File menu, select Print Setup. The Print Setup dialog box appears.

2. In the Printer group box, select the printer you want to use from the Name drop-down list box.

3. Click on Properties to display a dialog box providing various options for the selected printer. This dialog box 
originates from the printer driver and is specific to the selected printer.

Select the appropriate options on this dialog box, then click on OK to return to the Print Setup dialog box.

4. From the Size drop-down list box, specify the paper size you want to print to.

5. From the Source drop-down list box, select the paper source appropriate to your selected printer.

6. From the Orientation group box, select Portrait or Landscape.

7. Click on OK. The new printer remains selected until you next change it.
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Printing a face

1. From the File menu, select Print. The Print dialog box appears.

2. Select the number of copies you want to print using the Number of copies spin box.

3. Click on OK.

The current face present in the design area is printed to your default printer.

Keyboard shortcut: Ctrl+P
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Exiting face factory

To exit face factory, do any of the following:
Click on the Close button in the top right-hand corner of the window
From the File menu, select Exit
From the Control menu, select Close
Double-click on the Control-menu icon.
Press ALT+F4

If there are any unsaved changes to the current face, a message will appear asking if you want to save the 
changes. Click on Yes, No or Cancel as appropriate.
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Create faces



Selecting a Feature tab
To bring the required tab into view, simply click at the top of the tab. The features contained within that tab 

are displayed on the tab card.

Note:

Your version may have variations within the Feature tabs, i.e., you may have more or less tabs or more or less 
clipart contained within those tabs.
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Selecting and dragging a feature into the design area

1. With the required tab in view, click and hold the mouse button down on the feature and drag it into the design 
area.

2. Release the mouse button.

The feature is added to the existing features of the face. If Snap to Position is selected in the Options menu, the 
feature is dropped in its default facial position. If Snap to Position is turned off, the feature is dropped at the 
current mouse pointer position.

Note:
If you have already added this type of feature to your face, the new feature replaces the existing feature. 

(This does not apply to features taken from the Accessories tab.)
In addition to dragging a feature into the design area, you can double-click on a feature to add it to your 

current face. The feature will appear in its default position whether or not Snap to Position is selected from the 
Options menu.

Your version may have variations within the Feature tabs, i.e., you may have more or less tabs or more or 
less clipart contained within those tabs.
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Selecting features from within the design area

To select an individual feature from within the design area, simply click on the feature. The selected feature is 
surrounded by a frame indicating that it is selected.

To select all of the features within the design area, select Select All from the Edit menu. All features are 
surrounded by their respective frames indicating that they are selected.

To select some of the features within the design area, Shift+Click on the individual features that you want to select. 
A selection frame is drawn around the selected features.

You can also select some features by dragging the mouse pointer diagonally over the features you want to select. A 
selection frame appears as you drag and the features within are selected when you release the mouse button.

You need to select a feature(s) to resize, rotate or skew them etc.

Keyboard shortcut: Select All - Ctrl+A
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Moving features within the design area

1. Select the feature(s) you want to move.

2. When the pointer changes shape to an arrow with a selected rectangle at its base, press the mouse button and 
drag the feature(s) to its new position. As you drag the feature(s), an outline of its new position is displayed.

3. Release the mouse button to redraw the feature(s) in its new position.

You can also move feature(s) using the Nudge control or cursor keys.
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Deleting features from the design area

1. Select the feature(s) you want to delete.

2. From the Edit menu, select Delete.
You can also delete any feature(s) using the Delete key.
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Changing features within the design area

1. Select the feature in the design area you want to change.

2. With the same tab in view, click on another feature to select it. The feature is highlighted.

3. Either double-click on the highlighted feature or click and hold down the left mouse button and drag it into the 
design area.

4. Release the mouse button.

The feature replaces the existing feature you selected at step 1.

Note:
Because a face can include multiple accessory features, you are not able to change selected features that 

originate from the Accessories tab using this method. Instead, the accessory feature will be added to the face 
without overwriting the existing feature.

Your version may have variations within the Feature tabs, i.e., you may have more or less tabs or more or 
less clipart contained within those tabs.
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Undoing and redoing an action
From the Edit menu, select Undo or Redo. The last action is undone or the previous undo command is 

redone.

Note:
You cannot undo commands that do not change your faces' content, e.g. opening a face, scrolling the 

window or making selections on a dialog box. 
You can only redo a command immediately after it has been undone.

Shortcuts:

 



Edit faces



Changing the line and fill color of features

1. Click and hold down the right mouse button (to change the line color), or the left mouse button (to change the fill 
color) on the desired color in the color bar.

2. Drag the mouse pointer into the design area. The pointer changes to a paint pot.

3. Position the paint pot over a feature. Parts of the feature are highlighted with selection handles.

4. With the chosen part highlighted. Release the mouse button.

The line or fill color of the selected feature is changed.
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Reflecting features

1. Select the feature(s) you want to reflect.

2. Click on the reflect tool of your choice:

     

In the above picture, the eyes have been reflected using the Reflect Vertically tool.

{button ,KL(`editing')}            Related Topics  



Rotating features

1. Select the feature(s) you want to rotate.

2. Click on the rotate tool of your choice. The selected feature(s) is rotated by 10 degrees each time you click on the 
tool.

     

In the above picture, the hair has been rotated using the Rotate Left tool.
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Skewing features

1. Select the feature(s) you want to skew.

2. Click on the skew tool of your choice. The selected feature(s) is skewed by 10 percent each time you click on the 
tool.

     

 

 

In the above picture, the eyes have been skewed using the Skew Down tool.
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Resizing a feature

1. Select the feature whose size you want to change. Handles are displayed around the feature to show that it is 
selected.

2. Click on one of the handles around the feature. Without releasing the mouse button, drag the handle.
dragging a corner handle will resize the height and width of the feature from a central point within the 

feature.
dragging a side handle will resize either the height or width of the feature from a central point within the 

feature.

3. When the feature frame is the correct size, release the mouse button.

Note:
You can only resize one feature at a time. If you have two or more features selected, only the feature whose 

handles you drag is resized.
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File menu

Click on the menu command that you want help with.

Hint:
When you highlight a menu command, the information line displays a prompt telling you what action that command 
performs.
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Click on this command to start a new face. The design area is cleared and you can begin working on a completely 
new face.



Click on this command to open an existing face. The Open dialog box appears.

Select the face that you want to open, then click on Open. After a few moments the selected face is opened in the 
face factory design area.



Click on this command to save the face in the design area with its current filename. If the face is untitled the Save 
As dialog box appears, where you can type a filename for the face.



Click on this command to save a new face or to save the current face under a different filename. The Save As 
dialog box appears.

Select a drive and folder in which to save the face and type a filename.



Click on this command to export the current face as a (.WMF), (.CGM) or (.GEM) file. The Export dialog box 
appears.

Select a graphics format, drive and folder in which to save the face and type a filename.



Click on this command to print the current face. The Print dialog box appears. Select the desired options and click 
on OK to print the face to the selected printer.



Click on this command to change your printer options. The Print Setup dialog appears. Select the desired options 
and click on OK to accept the changes.



Lists the face files most recently used by face factory. Select the face you want to open; after a few moments it 
appears in the face factory design area.



Click on this command to close face factory. If the current face contains any unsaved changes, a message appears 
giving you the opportunity to save or abandon the changes, or to cancel the exit command.



Edit menu

Click on the menu command that you want help with.

Hint: 
When you highlight a menu command, the information line displays a prompt telling you what action that command 
performs.
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Click on this command to abandon the last command. You can undo up to fifty commands.

You cannot undo commands that do not change your faces' content, e.g. opening a face, scrolling the window or 
making selections on a dialog box.



Click on this command to abandon the previous Undo command. You can redo up to fifty Undo commands. Please 
note that you can only redo a command directly after it has been undone.



Click on this command to copy the face present in the design area to the Windows Clipboard.



Click on this command to delete selected features from the current face.



Click on this command to select all of the features used in the current face.



Click on this command to de-select any features used in the current face.



Options menu

Click on the menu command that you want help with.

Hint: 
When you highlight a menu command, the information line displays a prompt telling you what action that command 
performs.
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Click on this command to snap all features to their default positions when dragging them into the design area.



View menu

Click on the menu command that you want help with.

Hint: 
When you highlight a menu command, the information line displays a prompt telling you what action the command 
performs.
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Click on this command to turn the display of the Toolbar on and off. This command is ticked when the Toolbar is 
displayed.



Click on this command to turn the display of the information line on or off. When the command is ticked, the 
information line is displayed at the bottom of the face factory desktop.



Click on this command to turn the display of the nudge control on and off. Initially it is displayed next to the Toolbar, 
but it can be made to float on the face factory desktop. This command is ticked when the nudge control is 
displayed.



Help menu

Click on the menu command that you want help with.

Hint: 
When you highlight a menu command, the information line displays a prompt telling you what action that command 
performs.
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Click on this command to display the Help Topics dialog box. From this dialog box, you can select the area of face 
factory you want help on.



Click on this command to display the face factory billboard. This shows the version number of your copy of face 
factory and a copyright notice.





Toolbar

The toolbar contains a range of tools, each with a specific function.

Click on a tool below to popup a description of its function.
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New tool: This is the shortcut tool for the New command in the File menu. Click on it to create a new face.

Keyboard shortcut: Ctrl+N



Open tool: This is the shortcut tool for the Open command in the File menu. Click on it to open an existing face.

Keyboard shortcut: Ctrl+O



Save tool: This is the shortcut tool for the Save command in the File menu. Click on it to save the current face in 
the face factory design area with its current filename. 

If the face is untitled the Save As dialog box appears, where you can type a name for the face.

Keyboard shortcut: Ctrl+S



Copy All tool: This is the shortcut tool for the Copy All command in the Edit menu. Click on it to copy the entire 
face present in the design area to the Windows Clipboard.

Keyboard shortcut: Ctrl+C



Undo tool: This is the shortcut tool for the Undo command in the Edit menu.

Click on it to undo the last command. You can undo up to the last fifty commands.

Keyboard shortcut: Ctrl+Z



Redo tool: This is the shortcut tool for the Redo command in the Edit menu.

Click on it to redo the last command that was undone.

Keyboard shortcut: Ctrl+Y



Show Grid tool: This is the shortcut tool for the Show Grid command in the Options menu.

Click on it to turn the display of the grid on or off for the face in the design area.



Snap to Grid tool: This is the shortcut tool for the Snap to Grid command in the Options menu.

Click on it to turn snap control on or off for the face in the design area.



Reflect Horizontally tool: Use this tool to reflect the selected feature from left to right. Multiple selected features 
are treated as a single object.



Reflect Vertically tool: Use this tool to reflect the selected feature from top to bottom. Multiple selected features 
are treated as a single object.



Rotate Left: Use this tool to rotate the selected feature(s) 10 degrees to the left.



Rotate Right: Use this tool to rotate the selected feature(s) 10 degrees to the right.



Skew Left tool: Use this tool to skew the selected feature(s) 10 percent to the left.



Skew Right tool: Use this tool to skew the selected feature(s) 10 percent to the right.



Skew Up tool: Use this tool to skew the selected feature(s) 10 percent upwards.



Skew Down tool: Use this tool to skew the selected feature(s) 10 percent downwards.



Nudge control: Use this control to move the selected feature(s) by small increments.



Nudge control

The nudge control lets you 'nudge' feature(s) up and down, or left and right; you can also use the cursor keys for 
the same effect.

Note:

The nudge control is disabled when you do not have anything selected in the design area.
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Color bar

The color bar is displayed at the bottom of the desktop.

Select a color from the range available. Right click to change the line color; Left click to change the fill color.
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Menu command keyboard shortcuts

If you are familiar with Windows, you will already know that there are many keyboard equivalents to using a mouse.

face factory provides its own equivalents and shortcuts.

Press To

Ctrl+A Select all of the features in the design area; Edit menu.

Ctrl+C Copy all of the features in the design area to the Windows Clipboard; Edit menu.

Ctrl+E Export a face to a (.WMF), (.CGM) or (.GEM) graphics file; File menu.

Ctrl+N Start a new face; File menu.

Ctrl+O Open an existing face; File menu.

Ctrl+P Print a face to the selected printer; File menu.

Ctrl+S Save a face; File menu.

Ctrl+Y Redo the action that was last undone; Edit menu.

Ctrl+Z Undo the last action; Edit menu.

Del Delete a selected feature(s) from the design area; Edit menu.

Esc Deselect any features that are selected in the design area; Edit menu.

F1 Open the Help; Help menu.
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Design area keyboard shortcuts

If you are familiar with Windows, you will already know that there are many keyboard equivalents to using a mouse.

face factory provides its own equivalents and shortcuts.

Press To

Home Move the selected feature(s) back to its default position.

Cursor keys Nudge the selected feature(s) around the design area; Nudge control.

Tab Select the next feature in the stacking order.

Shift Tab Select the previous feature in the stacking order.
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Feature tab keyboard shortcuts

If you are familiar with Windows, you will already know that there are many keyboard equivalents to using a mouse.

face factory provides its own equivalents and shortcuts.

Press To

Tab/Shift Tab Pass control between the tab icons and the features in the tab window below

Home Highlight the first feature/tab in the list.

End Highlight the last feature/tab in the list.

Pg Up Highlight the first feature in the current tab window.

Pg Dn Highlight the last feature in the current tab window.

Cursor keys Highlight individual features/tabs in the list.
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What does everything do?

Click on an area of the face factory desktop below to popup a description of the selected area.
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Control-menu icon: Click on this icon to display the face factory Control menu. By using Control menu 
commands you can restore, move, size, minimize, maximize and close the window.

When using a mouse you can also perform these tasks by dragging and clicking.



Title bar: This shows the name of the program and the file name of the current face in the design area.
You can maximize the face factory window by double-clicking on the title bar. To restore it to its previous 

size, double-click on the title bar again.
To move face factory to another location on your desktop, drag the title bar to the new location.



Minimize button: Click on this button to reduce the face factory window to an icon.
When you reduce face factory to an icon it continues to run, but its window does not take up space on your 

desktop.



Maximize button: Click on this button to increase the face factory window to its maximum size.
When you maximize the face factory window, the Maximize button is replaced with a Restore button that 

contains two overlapping squares. Click on the Restore button to return the window to its previous size.



Close button: Click on this button to close the face factory window.



Menu bar: Displays the names of the face factory’s menus. Click on a menu name to drop-down the menu's 
commands.



Information line: Displays information about face factory.
 
The information line displays hints on what to do, so it changes depending on what you are doing.



Design area: Displays the current face. Drag features from the Feature tabs into this area to add them to the 
current face.



Scroll bar: Scroll this bar to move up or down the design area and view the entire face.



File: Drops down the File menu. From this menu you can create a new face, open and save an existing face, 
export a face to another program, change your printer options and print a face. You can also exit face factory.



Edit: Drops down the Edit menu. From this menu you can undo or redo the previous action, copy the entire face 
present in the design area to the Windows Clipboard, select areas of the face in the design area and delete 
selected features.



Options: Drops down the Options menu. From this menu you can select whether you want to snap features to 
their default positions when dragging them into the design area.



Help: Drops down the Help menu. From this menu you can go to the Help Topics dialog box and display a 
copyright notice.



Feature tabs: Displays all of the features needed to create a face. Click on a tab to display a list of associated 
features on the card below.

Note:

Your version may have variations within the Feature tabs, i.e., you may have more or less tabs or more or less 
clipart contained within those tabs.



Color bar: The color bar is displayed at the bottom of the desktop. Select a color from the range available.






