
Manually setting up an Internet connection

The Internet Setup wizard makes it easy for you to manually set up a connection to the Internet. You can use 
your local area network (LAN) or another Internet service provider to connect. 
The information you need to provide to the wizard depends on how you connect. For more information, click a 
button below.
            I want to use a local area network.  
            I want to use an Internet service provider.  

Note
If you want to use an Internet service provider to connect to the Internet, you will need a modem. For 

information about setting up a modem, click Related Topics below.

{button ,AL("A_MODEM_SET_UP")} Related Topics



Using a local area network to connect

To use a local area network to connect to the Internet, you need to provide the following information in the 
Internet Setup wizard.

The Internet protocol (IP) addresses of your main and alternate Domain Name System (DNS) servers. 
If you have a Dynamic Host Configuration Protocol (DHCP) installed, the IP addresses are assigned 

automatically.
The address of the Internet gateway computer (or proxy server) on your local area network.

If you do not know this information, see your network administrator before continuing with the wizard. 

Do you want to use Internet mail?
            Yes, tell me what I need.  
            No, I don't want Internet mail.  

            Return to Manually Setting Up an Internet Connection.  



Using Internet mail

You can use Windows Messaging to receive e-mail messages over the Internet. To receive Internet mail, you need
to provide the wizard with the following information:

Your e-mail address.
The name of your Internet mail server. 
You can get this information from your service provider or, if you are using a local area network to connect,

from your network administrator.
The Windows Messaging profile you want to use. You can use an existing profile or create a new one 

especially for Internet mail.

Note
If you want to use a program other than Windows Messaging for Internet mail, you will need to set it up 

yourself. For more information, see the documentation that comes with your mail program.



Turning off Internet mail

If you don't want to use Internet mail, when you see the Internet Mail screen in the wizard, make sure the No, I 
Don't Want To Use Windows Messaging check box is cleared.



Using an Internet service provider to connect

If you already have a point-to-point protocol (PPP) account with an Internet service provider, you can use the 
wizard to set up access to this account. 
The wizard will ask for the following information, which you can obtain from your service provider:

The name of your service provider. This appears in the Dial-Up Networking folder in My Computer as the 
name of your connection.

User name.
Password.
The phone number you dial to connect to the Internet.
Domain Name System (DNS) server address.
IP address and subnet mask, if any.
Authentication procedure (whether or not your provider requires a terminal window to log on).

Note
Your service provider must support PPP. 

Do you want to use Internet mail?
            Yes, tell me what I need.  
            No, I don't want Internet mail.  

            Return to Manually Setting Up an Internet Connection.  



The Internet is a collection of computer networks that connects millions of computers around the world, including
the one on your desktop. It is also a vast source of information that is constantly changing and expanding. Since 
its creation in the 1970s, it has grown exponentially and is now used by millions of people, from those in 
commercial and educational institutions to individual consumers. 
Once you're connected to the Internet, you can access a wealth of information, including pages on the World 
Wide Web, newsgroups (BBS), news and weather information, software, and games.



An Internet service provider maintains a server that is directly connected to the Internet. To connect your 
computer to the Internet, you use a modem to dial into this server. In exchange for this service, a provider 
charges you for the time you spend using the Internet. 
You must connect to the Internet through a service provider unless you are working in a company or organization
that provides Internet access through a local area network.



An Internet gateway computer acts as a bridge between your local area network and the Internet. On a local 
area network, you can gain access to the Internet by connecting to this computer.



Profiles enable more than one person to use Windows Messaging to receive e-mail on the same computer. You 
can also use different profiles for different types of e-mail. For example, you could set up one profile for receiving
e-mail over your corporate network and another profile for receiving e-mail over the Internet. 



Internet Troubleshooter

This troubleshooter will help you identify and solve problems with connecting to your Internet service provider 
(ISP). Just click to answer the questions, and then try the suggested steps to fix the problem.

What's wrong?
            I can't connect or log in to my Internet service provider (ISP).   
            I can connect and log in to my ISP, but I have trouble with my Internet programs, such as my Web browser.   



What problem occurred?
            My ISP hangs up right after answering the phone.   
            I can't find any Web pages or other servers.   
            I can connect to my ISP, but I cannot read e-mail or run programs such as my Web browser.   

               My ISP hangs up unexpectedly.   



How are you accessing the Internet?
               I access the Internet by using a server on a LAN.   
               I access the Internet by using a modem to connect to my ISP.  



What problem occurred?
               I connect to my ISP, but it hangs up, with a message saying that it couldn't negotiate a compatible set of   
protocols. 
               I can't log in. It keeps prompting me for my login name and password.   
               I can connect to my ISP, but it hangs up right after answering the phone.   
               The terminal window appears, I type my username and password, and then nothing happens.   
               Dialing doesn't work correctly.   



Click the Continue button
In the Terminal window, click Continue.

Did this fix the problem?
               Yes. I was able to log in. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Try to connect again later
Wait a while, and then try your connection again. Your ISP might have been shut down for maintenance. 

               OK. Click here to close the troubleshooter.   
               Return to the beginning of the troubleshooter.   



Make sure the connection is using the TCP/IP protocol

1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu, click Properties. 
3 On the Server Type tab, make sure the TCP/IP box is selected.

Did this fix the problem?
               Yes. I was able to log in. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Make sure the TCP/IP protocol is bound to your Dial-Up Adapter

1 Click here        to display Network properties.
2 Make sure the Dial-Up Adapter appears in the list.
3 Make sure the TCP/IP network protocol is in the list. A protocol has a  icon beside it. 

4 Click the Dial-Up Adapter, and then click Properties.
5 Click the Bindings tab.
6 Make sure the TCP/IP box is selected. 

Did that fix the problem?
               Yes. I was able to log in. Close the troubleshooter.   
               No. TCP/IP is installed and is bound to the Dial-Up Adapter, but I still can't connect. What else could be   
wrong? 
               The TCP/IP protocol is not on the list of network components. How do I install it?   



Make sure you typed your login name and password correctly

Check your login name and password and make sure you have typed them correctly. If the login program for your
ISP is case-sensitive, also make sure that your CAPS LOCK key is not on. 
Also, some ISPs require you to type a character, such as P, S, or # in front of your login name to indicate the 
server connection type that you are using. (For example, if your login name is Chris, you might have to type 
Pchris to indicate a PPP connection, or Schris to indicate a SLIP connection.) 
For more information about logging in to your ISP, contact the ISP's administrator.

Did this fix the problem?
               Yes. I was able to log in. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Bring up a terminal window

1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu, click Properties. 
3 Click Configure. 
4 Click the Options tab, and select the Bring Up Terminal Window After Dialing box. 
5 Try your call again. 

Did this fix the problem?
               Yes. I was able to reconnect. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Make sure you have the correct version of Winsock in your Windows folder

1 In My Computer, click View, and then click Options.
2 Make sure the Show All Files box is selected, and then click OK.
3 On the Start menu, click Find.
4 Click Named, type winsock.dll and then click Find Now.

The correct version should be located in your Windows folder, and should be dated 3/7/96

Did this fix the problem?
               Yes. I was able to connect. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Try to ping a server by name
While you are connected to your ISP, click here {button ,EF(`PINGNAME.BAT',`SW_SHOWMINNOACTIVE',1)}

to ping a server by looking for its name. The results of the ping attempt will appear in an MS-DOS window.
If the attempt was successful, the results look like this:
REPLY FROM 198.105.232.1: BYTES=32 TIME=324MS TTL=46.

Was at least one ping attempt successful?
            Yes, it was successful. Close the troubleshooter.  
            No, I got a different response. What do I do now?   



Try to ping a server by IP address
While you are connected to your ISP, click here {button ,EF(`PINGNUM.BAT',`',1,`')} to ping a server by 

looking for its IP address. The results of the ping attempt will appear in an MS-DOS window.
If the attempt was successful, the results look like this:
REPLY FROM 198.105.232.1: BYTES=32 TIME=324MS TTL=46.

Was at least one ping attempt successful?
            Yes, it was successful. What does this mean?   
            No, I got a different response. What do I do now?   



Check the default gateway settings

1 Close your connection.
2 In the Dial-Up Networking window, click the connection to your ISP.
3 On the File menu, click Properties. 
4 Click Server Type, and then click TCP/IP Settings.
5 Select the Use Default Gateway On Remote Network check box.

Did this fix the problem?
            Yes. I was able to connect. Close the troubleshooter.   
            No, I'm still having trouble. What else could be wrong?   



Make sure you have specified the correct server type

1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu in the Dial-Up Networking folder, click Properties.
3 Click the Server Types tab, and make sure you have specified the correct server type. For example, you might 

have specified the server type as PPP or CSLIP when it should be SLIP. If you are not sure what this should be, 
contact the administrator for your ISP.

Did this fix the problem?
            Yes. I was able to connect. Close the troubleshooter.   
            No, I'm still having trouble. What else could be wrong?   



Are you prompted for your IP address when you connect to your ISP?
            Yes.   
            No.   



Make sure you're using the correct IP address
Try your call again, making sure that you are typing the IP address correctly. If you are not sure what to 

type, contact your ISP's administrator. 
            Go back to the beginning of the troubleshooter.   
            Close the troubleshooter.   



Make sure you're using the correct IP address

1 Close your connection.
2 In the Dial-Up Networking window, click the connection to your ISP.
3 On the File menu, click Properties. 
4 Click Server Type, and then click TCP/IP Settings.
5 If the Specify An IP Address box is selected, make sure the IP address for your computer is typed correctly. For 

more information, or if Server Assigned IP Address is not selected, contact your network administrator.
            Go back to the beginning of the troubleshooter.   
            Close the troubleshooter.   



A utility that sends a signal to a server to see whether the server is communicating properly with the network. It 
can contact a server by looking for the server's name (for example, ping ftp.microsoft.com), or by looking for the 
server's IP address (for example, ping 198.105.232.1). If the signal reaches the server, the server sends a reply 
acknowledging the signal. The reply from a successful ping looks like this:
REPLY FROM 198.105.232.1: BYTES=32 TIME=324MS TTL=46.



Make sure you've specified your Domain Name Server correctly

In order to be able to send mail to, view Web pages on, or connect to other computers over the Internet, you 
need to specify your domain name server (DNS) address. The DNS address is the IP address of a computer on 
the Internet that keeps a list of computer names and their IP addresses, so that you can refer to the computers 
by their names instead of typing the IP address every time.
1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu in the Dial-Up Networking folder, click Properties.
3 Click the Server Types tab, and then click TCP/IP Settings.
4 Click Specify Name Server Addresses.
5 Make sure the Primary DNS address is set correctly. If the Primary DNS box is blank, click it, and then type the 

DNS address. If you don't know your DNS address, contact the administrator for your Internet service provider 
(ISP).

Tip
If the information you received from your ISP administrator does not include any mention of a DNS 

address, perhaps it is listed under a different name. Other names for DNS address include:
· Name server
· Name server IP address
· Domain server address
· Domain name server

Did this fix the problem?
            Yes. I was able to connect. Close the troubleshooter.   
            No, I'm still having trouble. What else could be wrong?   



Is your Internet program using a proxy server?

If you are accessing the Internet over a LAN, your Internet program may be set up to use a proxy server, then 
you won't be able to ping IP addresses. If you don't know whether you need to use a proxy server, contact your 
network administrator.

To find out whether Internet Explorer is using a proxy server

1 Click here        to display Internet properties.
2 Click the Advanced tab, and look to see whether Use Proxy Server is selected. If it is, make sure the Proxy 

Server box contains the correct server name. If you don't know the correct server name, contact your network 
administrator.

Did this fix the problem?
            Yes. I was able to connect. Close the troubleshooter.   
            No, I'm still having trouble. What else could be wrong?   



Check the settings for your Internet program

If you are accessing the Internet by using a modem, then you should make sure your Internet program isn't set 
up to use a proxy server. The following instructions are for Internet Explorer. If you are using a different Internet 
program, see the documentation for the program.
1 Click here        to display Internet properties.
2 Click the Advanced tab, and make sure Use Proxy Server is not selected.

Did this fix the problem?
               Yes. I was able to connect. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



A proxy server acts as a barrier between the Internet and your local area network (LAN), protecting information 
on your LAN from being accessed by others. 
When you use a proxy server, all requests to and from the Internet are filtered through it, so confidential 
information on your network does not become available on the Internet. Proxy servers can provide other Internet
services as well. 
For more information about your proxy server, see you network administrator.



Make sure you have specified the correct server type

1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu in the Dial-Up Networking folder, click Properties.
3 Click the Server Types tab, and make sure you have specified the correct server type. For example, you might 

have specified the server type as PPP or CSLIP when it should be SLIP. If you are not sure what this should be, 
contact the administrator for your ISP.

Did this fix the problem?
               Yes. I was able to connect. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Bring up a terminal window

1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu, click Properties. 
3 Click Configure. 
4 Click the Options tab, and then select the Bring Up Terminal Window After Dialing box. 
5 Try your call again. 

Did this fix the problem?
               Yes. I was able to reconnect. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Make sure you have specified the correct server type

1 In the Dial-Up Networking window, click the connection to your ISP.
2 On the File menu in the Dial-Up Networking folder, click Properties.
3 Click the Server Types tab, and make sure you have specified the correct server type. For example, you might 

have specified the server type as PPP when it should be SLIP, or vice versa. If you are not sure what this should
be, contact the administrator for your ISP.

Did this fix the problem?
               Yes. I was able to connect. Close the troubleshooter.   
               No, I'm still having trouble. What else could be wrong?   



Run the Internet Connection wizard again
 Click here 
 to start the Internet Connection wizard.

Did this fix the problem?
               Yes. I was able to connect. Close the troubleshooter.   
               No. I'm still having trouble.   



Contact your ISP's administrator

You've encountered a problem that the Internet Troubleshooter can't help you solve. 
For more information, contact your ISP's administrator. 

               Go back to the beginning of the troubleshooter.   
               Close the troubleshooter.   



An Internet service provider maintains a server that is directly connected to the Internet. You must connect 
through a service provider unless your organization is directly connected to the Internet. 




