
Additional Notes About
gmax™

This file contains the latest information regarding known issues and behavioral issues. For 
information about new features, download the online help, gmax.chm. 

Information regarding the Scripter (MAXScript) feature is contained in a separate help download, 
maxscript.chm.

Notes About Authorization, Installation, and Registration
 After uninstalling gmax, there may be files left in the \gmax folder. Before reinstalling gmax, please

delete any files that may not have been uninstalled.

 Before a user with Restricted Privileges can run gmax under Windowsâ, an Administrator must 
launch it at least once. The first launch generates registry information, which completes the install. 

 Flash 5.0 Player is required to run gmax. If you declined the Flash install the gmax Material Editor 
will not work. To install Flash 5.0 after gmax is installed, just run the gmax install from Add/Remove
Programs in your Control Panel. Select Repair in the dialog and when prompted to install Flash, 
accept it. Another option is to download and install Flash 5.0 Player at 
http://www.macromedia.com/downloads/ (219Kb).

Notes About Features
ASSET BROWSER

 Voloä View is currently not supported.

 The Display Obsolete File message option does not apply to files that you drag and drop, as 
opposed to those that you open with File > Open.

 Scene XRef drag and drop of files with scripts that depend on explicit scene-object references 
can cause unpredictable results or program failure.

BONES
 Bones creation behavior can be unpredictable when using Snap Override. When you use 
SHIFT+right-click to invoke Snap Override, the Bones system interprets this as a left-click and places a 
bone in the scene.

 The Macro Recorder does not support Bones creation. However, you can manipulate the bones 
with the Macro Recorder after creating them.

BOOLEANS
 Edges created during a Boolean operation involving compound (nested) Booleans will be visible. 

These edges should be invisible. This affects only viewport display modes that display visible 
edges, such as Wireframe, Lit Wireframes, and Edged Faces.

CAMERAS
 Panning a Camera view with the middle mouse button highlights the Truck Camera navigation 

button, but does not turn off this mode when you release the mouse.



CHAMFER
 Using a negative value can result in fillet edges reversed in opposite directions.

CONTROLLERS
 On/Off controller keys might be deleted when animating a parameter on and off. Repeatedly 

toggling a Boolean parameter on and off while Animate is on might delete downstream On/Off 
keys.

 Shift-cloning path-constrained objects might not position copies properly. Creating clones of a 
path-constrained object using the Shift-Move technique will not evenly space each clone apart 
from its previous sibling.

 Mirroring an object constrained by the Look-At constraint flips the look-at axis. To correct this, use
the new Mirror Bones option, which prevents the Mirror tool from inverting the object’s scale. You 
can also activate the Flip check box in the Look-At constraint’s upnode Source Axis group.

 Master Point controllers are compound controllers, and depend on sub-controllers and their 
structure; therefore you cannot cut and paste Master Point controllers.

CUSTOM ATTRIBUTES
 Making a copy of a material that has custom attributes also copies the custom attributes.  Any 

custom attribute changes then affect both materials. Using Delete All to delete the Custom 
Attributes rollout on the copy should end this behavior.

 The Default value in the Integer UI Options rollout is ignored when creating a new Integer custom 
attribute. The value in the Float UI Options rollout is used instead. When creating a new Integer 
custom attribute, set the default value in the Float UI Options rollout first before defining the other 
values in the Integer UI Options.

DISPLAY
 Direct3D display might work incorrectly on video cards with less than 32 MB of video memory.

 Vertex colors display correctly only with the Software Z-Buffer and OpenGL drivers. They are not 
fully supported by the Direct3D driver.

 
 Drivers that are not fully compatible with DirectX 8 do not work correctly with gmax in Direct3D 

mode.

 Occasionally, scenes containing transparent geometry do not display correctly. To fix this, switch 
to Stipple transparency using the Viewport Configuration dialog.

 Windows NT 4.0 does not support Direct3D for gmax.

 The option Display Wireframe Objects Using Triangle Strips does not work in OpenGL or 
Direct3D.

 Switching options in the Configure Direct3D dialog might cause problems. To correct this, delete 
d3dgfx.ini from your \gmax directory.

 Some video cards might display only half the lines on wireframe objects. To fix this, turn off the 
toggle Use Wireframe Faces (Custom Driver Extension) in the Configure OpenGL dialog, located 
under Customize > Preferences > Viewports panel.

 Viewport antialiasing is not supported under Direct3D or OpenGL.



 Running gmax with the Track Bar UI hidden can increase viewport performance. The Track Bar 
UI can be turned off through Customize > Show UI and turning off Show Track Bar.

 Running gmax with some Matrox cards can cause the gmax.exe process to remain in the task 
manager after closing gmax. Matrox G400/450 and G5XX series cards are currently unsupported
in gmax.

 Display wireframe objects with triangle faces doesn't work with the Use Wire Faces option turned 
on. Be sure to turn off the Use Wire Faces check box.

EDITABLE MESH
 The Redraw Viewports shortcut key 1 doesn’t work with Edit Mesh or Editable Meshes. To fix this,

go to the Customize > Customize User Interface dialog, Keyboard panel, under Group: 
Edit/Editable Mesh, and Remove the shortcut (1 by default) assigned to Vertex Level.

 Changes to the alpha value of a sub-object cannot be undone in an Editable Mesh if you type the 
number in the Alpha field. Use the spinner instead.

EDITABLE POLY & POLYMESH OBJECT
 If an Editable Mesh has selected face normals flipped, converting it to an Editable Poly can cause

problems. The conversion process attempts to divide the object into elements to keep a legal 
condition. The division method might be unpredictable and will probably be based on how many 
vertices are shared between flipped and nonflipped faces. Unifying the normals before conversion
is recommended. Or, you can detach the flipped faces as elements before conversion, and the 
elements will be respected by the Editable Poly conversion. This will ensure a more orderly and 
predictable conversion.

 Interior patch edges that are not displayed will always appear as visible edges after a Polymesh 
conversion.

INI FILES
 Before editing gmax.ini or any other INI file, it is advised that you save a copy for backup.

INVERSE KINEMATICS
 Sometimes the mouse loses track of the end effector during Interactive IK. The cursor might 

become separated from the end effector over time as you drag the mouse around in the viewport.
This effect is limited to the Interactive IK feature in the Hierarchy > IK panel. This is not a problem
with IK Limb solvers. 

 Invalid IK dependency loops might not trigger a warning. It is possible to create an IK dependency
loop that generates an undesirable solution. No warning is given to indicate this occurrence; 
however, the results are generally evident immediately and completely undoable.

 Setting joint limits on IK Limb start joints might lead to non-intuitive behavior. The joint limits on a 
start joint might interfere with the IK Limb requirements to create an IK solution. In this event, the 
resulting configuration of the chain might be unexpected. To correct this, free up as many degrees
of rotational freedom as possible. It can also help to adjust the preferred angles of the start joint.

 The IK Limb might flip when the goal is moved. This usually happens when the start joint of the IK
chain is parented to another object with a substantially different (perpendicular) orientation. To 
correct this, switch the IK chain's parent space to Start Joint. If you choose to work in the default 
parent space (IK Goal), then hierarchically link the IK goal object to the same parent of the start 
joint and adjust the chain's Swivel Angle until the IK solution becomes desirable. Resetting this 
parameter to zero usually works in most cases.



MACRO RECORDER
 Not all features are macro-recordable at this time.

MANIPULATORS
 The Transform Type-In controls on the status bar don't re-enable properly after you've been in a 

sub-object mode. To correct this, deselect and then reselect the object.

 Changing the properties of a manipulator while Play is on can cause unpredictable results.

MATERIAL EDITOR & MATERIAL NAVIGATOR
 If textures are not being found on merge, use File > Open instead of Merge.

 It is possible for materials to be assigned the same name as sub-materials of multi-materials. In 
order to maintain unique material names and avoid confusion, users should take care when 
assigning material names in scenes that contain multi-materials.

 Unsupported materials and materials that use unsupported shaders can be loaded into gmax. In 
some cases the Unsupported Objects dialog will appear. The materials can be viewed in the 
Material Navigator with some limitations, but they will not be able to be loaded into the Material 
Editor for any editing operations.

 Material Editor UI elements (spinners and color swatches) of animated parameters are not 
highlighted in red at keyframes.

MAXSCRIPT
 MAXScript information can be found in the MAXScript Reference download.

MESHSMOOTH 
 When using Smoothness on a mesh that has had control-level editing, Smoothness will smooth 

down to the highest level that has had control-level editing applied to it, or to the currently active 
control level, whichever is higher.

 At this time, control-level editing in MeshSmooth should be considered a modeling tool only. 
Having an animated deformer placed before a MeshSmoothed object that has had control-level 
editing can result in the MeshSmoothed object becoming distorted. It's recommended that 
deforming modifiers be placed after the MeshSmooth modifier in the stack if you're using the 
deformers for animation. For best results, using a deforming modifier before the MeshSmooth 
modifier in the stack, you'll need to limit your control-level edits to moving vertices in their local Z 
axis.

 Using MeshSmooth with values of more than 10 iterations is not supported.

 Even with MeshSmooth set to 0 iterations, a polygon conversion of the MeshSmoothed object still
occurs. This can result in viewport playback slowdown. For optimal playback, set the 
MeshSmooth modifier to be Off in viewports.

MODIFIERS
 Using PathDeform and Stretch can leave remnants in the viewport. Press 1 to refresh the display.

 A helix with display mesh turned on and an FFD modifier vanishes when using Edit Mesh. To fix 
this, first make the helix an editable spline.

 Mesh Select/Poly Select: Pinch and Bubble soft selection spinner settings cannot currently go 
below 0 using the Mesh Select/Poly Select spinners. You can use Track View to set those 
numbers lower. 



MOTION PANEL
 When a trajectory of an object is derived from a spline, using the Convert From feature, the 

Previous Key, and Next Key buttons on the Key Info (Basic) rollout do not work unless Time 
Display, in the Time Configuration dialog, is set to FRAMES:TICKS. This is because the keys are 
created between frames.

PARAMETER WIRING
 Wiring a parameter to a value outside the constrained range of that parameter can cause 

unpredictable results.

 Cloning an object, which has a transform parameter wire with another object, results in a clone 
with an unattached parameter wire. Selecting the unattached parameter in the Parameter Wiring 
dialog displays a warning asking if the unattached parameter wire should be disconnected. 
Choosing “Yes” to disconnect may result in a crash.

QUAD PATCH
 Performance is slow when creating Quad Patches with 100x100 segments.

RESOURCE COLLECTOR
 The Resource Collector does not collect Environment, Displacement, or Projector maps.

 The Resource Collector does not collect the image files used by IFL files, only the IFL file itself.

SKIN
 Using Splines as bones for Skin within complex animated hierarchies is not recommended. 

 The Skin Paint Str. spinner range is 0 to 1. Negative Weight can be applied by holding down the 
ALT key while painting weights.

 Modifiers that cause a topology change, and are placed above Skin in the stack, can create 
instability when accessing Envelope mode. To avoid the problem, make sure Show End Result or 
the Converting Modifier is OFF before accessing Skin Envelope mode. This situation would arise,
for instance, when Skin is applied to a Patch object and a Disp Approx (Displacement 
Approximation) modifier is added to the top of the stack.

USER INTERFACE
 The proper highlighting of UI elements (mainly check boxes and radio button fields) might not 

appear in the Command panel during keyboard tabbing when running gmax under Windows 
2000. To force the highlighting to display properly, undock the Command panel. Then the 
highlighting will display, properly showing where UI focus is. Once you have tabbed while the 
Command panel was floating, you can re-dock the Command panel, and highlighting will operate 
properly.

 CUI files created in 3ds max 3.x are not forward-compatible with gmax. These files need to be 
recreated for use in gmax.

 CUI files should not be removed from the UI folder. If gmax looks for a CUI file that is not in the 
UI folder upon startup, the application can fail. This can be a problem if multiple users are using 
the same configuration settings, but don’t have the correct CUI files associated with that 
configuration.

 Large fonts are not supported in gmax, and can produce unpredictable display results.

UVW REMOVE
 Applying UVW Remove to a Patch Surface surface is not supported.



XREF
 XRef Automatic Update has more restrictive functionality under Windows 98. XRef objects and 

scenes can be set to update automatically whenever a file change is detected. Under Windows 
2000, this occurs each time the source file is saved. Due to different system notifications in 
Windows 98, the automatic update only occurs when the source file is closed by exiting gmax or 
by loading another file. Manual Update works as expected.

 When clicking to unbind the highlighted XRef(s) from whichever parent they'd been bound to, the 
XRef Scene does not return to its origin, typically the 0, 0, 0 world origin of the .gmax file scene it 
came from.

 Drag and drop when running under Windows 98 requires the Local Intranet security level to be 
set to Low in IE. This setting can be found in the IE Options dialog, under the Tools menu.

Autodesk, the Autodesk logo, and 3D Studio MAX are registered trademarks, and 3ds max, combustion,
gmax, gmax dev, Discreet, i-drop, and Volo are trademarks of Autodesk, Inc., in the U.S.A. and/or other 
countries. All other brand names, product names, or trademarks belong to their respective holders."
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